Arbeiten mit platzierten Komponenten

Auf einen Blick

Dieser Artikel erklärt, wie Komponenten, häufig auch als Bauteile bezeichnet, in Schaltplänen in Altium Designer dargestellt und verwaltet werden. Sie erfahren, was ein Bauteil ist, wie mehrteilige Komponenten funktionieren und auf welche Arten Sie diese über das Components-Panel oder den Schaltplanbibliothekseditor platzieren können. Außerdem behandelt der Artikel die Suche nach Komponenten, grundlegende grafische Bearbeitungsschritte wie Verschieben, Drehen und Spiegeln sowie Werkzeuge, die Schaltplankomponenten mit ihren Gegenstücken auf der Leiterplatte verknüpfen. Dazu gehören Cross Probe, Cross Select Mode und die Auswahl von Komponenten zur Platzierung im PCB-Editor. Darüber hinaus lernen Sie die wichtigsten Optionen der Bauteileigenschaften auf der Registerkarte „General“ kennen. So verstehen Sie besser, wie platzierte Komponenten definiert und gesteuert werden. Lesen Sie weiter, um sicherer mit Komponenten in Ihren Schaltplänen zu arbeiten.

- Erfahren Sie, woher Komponenten stammen, wie Bauteile und mehrteilige Komponenten gehandhabt werden und welche grundlegenden Möglichkeiten es gibt, sie in einem Schaltplan zu platzieren.
- Lernen Sie, effizienter nach Komponenten zu suchen und während oder nach der Platzierung schnelle grafische Änderungen vorzunehmen.
- Verstehen Sie den Zusammenhang zwischen Schaltplan- und PCB-Komponenten und erfahren Sie, welche grundlegenden Eigenschaften Sie nach der Platzierung prüfen oder bearbeiten können.
Mit KI tiefer einsteigen:

Ein Bauteil in einer Bibliothek repräsentiert das physische Bauelement, das auf der tatsächlichen Leiterplatte platziert wird. Auf einem Schaltplanblatt wird ein Bauteil durch sein Schaltplansymbolmodell dargestellt. Jedes Bauteil kann einen oder mehrere Teilbausteine enthalten.

Aktualisieren und Ersetzen von Bauteilen aus einer Bibliothek

Nachdem Bauteile auf den Schaltplanblättern eines Leiterplattendesigns platziert wurden, muss es eine Möglichkeit geben, diese Bauteilinstanzen mit allen Änderungen an ihren verknüpften Quellbauteilen im jeweiligen Workspace zu aktualisieren. Mit anderen Worten: Es wird eine Möglichkeit benötigt, das Design mit den von ihm verwendeten Workspace-Elementen synchron zu halten.

Beispielsweise wurde ein Bauteil möglicherweise erneut im Workspace gespeichert, etwa aufgrund einer Änderung an einem untergeordneten Modell. Dadurch entsteht eine neue Revision dieses Bauteils. Die platzierte Instanz dieses Bauteils verwendet nun eine ältere Revision, und Sie möchten sie möglicherweise auf die neueste Revision aktualisieren. Alternativ haben Sie sich vielleicht für ein völlig anderes Bauteil entschieden und müssen das vorhandene Bauteil im Design lediglich durch ein anderes ersetzen.

  • Auf dieser Seite wird beschrieben, wie Sie ein Bauteil aktualisieren, das aus Ihrem verbundenen Workspace platziert wurde. Informationen zum Aktualisieren eines Bauteils, das aus einer Datenbank- oder dateibasierten Bibliothek platziert wurde, finden Sie auf der Seite Aktualisieren von Bauteilen aus Datenbank- und dateibasierten Bibliotheken.

  • Bauteile, die aus Ihren verbundenen Workspaces in einem Designprojekt platziert wurden, können lokal geändert werden. Beispielsweise können Parameter über das Eigenschaften-Panel hinzugefügt, geändert oder entfernt werden, wenn ein platziertes Bauteil im Designbereich ausgewählt ist. Wenn das platzierte Bauteil mit seinem Gegenstück in der Workspace-Bibliothek übereinstimmen soll (also lokale Änderungen rückgängig gemacht werden sollen), können Sie den Dialog Aus Bibliothek aktualisieren (Tools » Update From Libraries) verwenden.

Nach der ersten Platzierung in einem Design stehen verschiedene Methoden zur Verwaltung der Bauteile zur Verfügung.

Ändern einer einzelnen Bauteilinstanz

Jedes platzierte Bauteil ist mit der zugehörigen Bauteilrevision im Workspace verknüpft. Diese Informationen finden Sie im Properties-Panel, wenn Sie die Eigenschaften des ausgewählten Bauteils anzeigen.

Jede platzierte Instanz eines Bauteils ist mit der jeweiligen Revision dieses Bauteils im Workspace verknüpft.Jede platzierte Instanz eines Bauteils ist mit der jeweiligen Revision dieses Bauteils im Workspace verknüpft.

Wenn eine neuere Revision des vorhandenen Bauteils verfügbar ist, wird dies im Eintrag für den Revisionsstatus (im Panel Properties) durch den Text Out of date rechts neben dem Lebenszyklusstatus der aktuellen Revision angezeigt. Beachten Sie, dass stattdessen Inapplicable angezeigt wird, wenn der Lebenszyklusstatus als nicht für das Design zulässig gekennzeichnet wurde (die Option Allowed to be used in designs ist dafür im Dialogfeld State Properties deaktiviert).

Auf dieser untersten Ebene einzelner Bauteile kann die platzierte Instanz:

  • Durch Klicken auf die Schaltfläche auf die neueste Revision des vorhandenen Bauteils aktualisiert werden.

Beispiel für die Aktualisierung desselben Bauteils auf seine neueste Revision – bewegen Sie den Mauszeiger über das Bild, um das Ergebnis zu sehen.Beispiel für die Aktualisierung desselben Bauteils auf seine neueste Revision – bewegen Sie den Mauszeiger über das Bild, um das Ergebnis zu sehen.

  • Durch die neueste Revision eines anderen Workspace-Bauteils (eines Ersatzbauteils) oder durch ein Bauteil aus einer dateibasierten Bibliothek ersetzt werden, indem Sie auf die Schaltfläche rechts neben dem Feld Design Item ID klicken. Das Dialogfeld Replace Component wird geöffnet und zeigt die Bauteile in Ihrem verbundenen Workspace sowie in den verfügbaren dateibasierten Bibliotheken an. Das aktuelle Bauteil wird ganz oben in der Liste angezeigt. Suchen Sie nach dem gewünschten Ersatzbauteil, wählen Sie es aus und klicken Sie anschließend auf OK.

    Beispiel für das Ersetzen des vorhandenen Bauteils durch ein anderes (eine Alternative)Beispiel für das Ersetzen des vorhandenen Bauteils durch ein anderes (eine Alternative)

    Das Dialogfeld Replace Component bietet direkten Zugriff auf alle verfügbaren Workspace-Bibliotheksbauteile und Bauteile aus dateibasierten Bibliotheken. Es bietet umfassende Details zum ausgewählten Bauteil (Parameter, Modelle, Bauteiloptionen, Lieferantendaten usw.), einen Bauteilvergleich sowie für Workspace-Bibliotheksbauteile eine filterbasierte parametrische Suche, mit der Sie die gewünschten Bauteilparameter festlegen können.

    Das Dialogfeld Replace Component kann beim Ersetzen von Bauteilen auch aus anderen Bereichen von Altium Designer aufgerufen werden, z. B. aus einem ActiveBOM-Dokument oder dem Dialogfeld Item Manager.

Bauteiländerungen im Stapel durchführen – der Item Manager

Related page: Inhalte mit dem Item Manager verwalten

Das Ändern einzelner Bauteile ist praktisch, wird jedoch bei einer größeren Anzahl von Bauteilen schnell mühsam. Dafür benötigen Sie eine zentrale Stelle, an der Sie mehrere Änderungen in einem Stapelvorgang durchführen können. Hier kommt der Item Manager (Tools » Item Manager) ins Spiel.

Der Item Manager ist die zentrale Schaltstelle, um auf Schaltplanblättern platzierte Workspace-Designelemente mit den Quellinhalten zu synchronisieren, mit denen sie in einem Workspace verknüpft sind. Er erkennt automatisch alle Bauteile, listet sie auf und kennzeichnet, ob es sich um Workspace-Elemente handelt. Anschließend vergleicht er die Item-Revision jedes Workspace-Bauteils in den Schaltplänen mit den verfügbaren Revisionen dieses Bauteils im Workspace. Für jedes Element werden Informationen zum aktuell verknüpften Item angezeigt: Revision, Lebenszyklusstatus und der Quell-Workspace, in dem es sich befindet.

Der automatisierte Revisionsvergleich für Workspace-Inhalte kennzeichnet alle veralteten Inhalte. Diese lassen sich anschließend mit minimalem Aufwand auswählen und für die Aktualisierung auf die neueste Revision vorbereiten. Weitere Einzelheiten finden Sie unter Erkennen erforderlicher Aktualisierungen.

Sie haben die volle Kontrolle darüber, welche dieser Workspace-Elemente aktualisiert werden und wie dies geschieht. Zum Beispiel:

  • Wählen Sie einen einzelnen Eintrag aus und aktualisieren Sie ihn auf die neueste Revision des verknüpften Items oder verwenden Sie stattdessen die neueste Revision eines völlig anderen Items.
  • Wählen Sie eine Gruppe von Einträgen aus, die dasselbe verknüpfte Item verwenden, und aktualisieren Sie diese entweder auf die neueste Revision dieses Items oder verwenden Sie stattdessen die neueste Revision eines völlig anderen Items.

Alle vorgesehenen Änderungen werden im Manager angezeigt.

Sobald Sie die Änderungen wie gewünscht vorbereitet haben, erstellen Sie einen Engineering Change Order (ECO) und prüfen Sie die Aktionen, mit denen diese Änderungen umgesetzt werden. Deaktivieren Sie bei Bedarf einzelne Aktionen – Sie behalten jederzeit die Kontrolle! Wenn alles bereit ist, führen Sie den ECO aus, um die Änderungen anzuwenden. So verwalten Sie Ihre platzierten Workspace-Inhalte schnell, effizient und ganz unkompliziert.

Wenn Sie sich Ihrer Änderungen sicher sind, können Sie die Funktion Item Manager's Apply ECO verwenden. Sie setzt die Änderungen im Hintergrund um, ohne den Dialog Engineering Change Order zu öffnen.

Die folgenden Beispiele veranschaulichen die Verwendung des Item Manager:

  • Mehrere Bauteile aktualisieren, sodass sie die neueste Revision des bestehenden Workspace-Bauteils verwenden.

Eine Gruppe veralteter Bauteile auf ihre neuesten Revisionen aktualisieren.
Eine Gruppe veralteter Bauteile auf ihre neuesten Revisionen aktualisieren.

Ein oder mehrere Bauteile durch ein anderes Workspace-Bauteil ersetzen.
Ein oder mehrere Bauteile durch ein anderes Workspace-Bauteil ersetzen.

Mit dem Item Manager können Sie nicht nur die Bauteile in Ihren Designs mit Änderungen an den Quellinhalten in den verbundenen Workspaces synchron halten. Er ist auch ein leistungsstarkes Werkzeug, das Sie bei der Migration Ihrer bestehenden Leiterplattendesigns unterstützt – von der Verwendung lokaler Designelemente hin zu Workspace-Designinhalten. Sobald Sie Ihre Designbauteile und gegebenenfalls vorhandene Schaltplanblätter (Device Sheets) in einen Workspace migriert haben, verwenden Sie den Item Manager, um die bestehenden Bauteile und Blattsymbole durch ihre neu migrierten Workspace-Entsprechungen zu „ersetzen“. Mit anderen Worten: Aus Sicht des Designs bleiben die Bauteile unverändert, lediglich ihre Quelle ändert sich.

Leistungsstarke Funktionen für den automatischen Abgleich ermöglichen es Ihnen, lokale Bauteile und Blattsymbole schnell den passenden Items im Workspace zuzuordnen.

Ein Bauteil aus einem BomDoc heraus ändern

Es kommt häufig vor, dass beim Prüfen des BomDoc und bei der Vorbereitung der Bauteilbestellung ein Problem mit einem Bauteil auffällt. Beispielsweise hat der Entwickler möglicherweise vergessen, die Auswahl eines Bauteils abzuschließen, oder ein Bauteil hat das Ende seines Lebenszyklus (EOL) erreicht und der Entwickler möchte Preise und Verfügbarkeit möglicher Ersatzbauteile prüfen. Sie könnten dazu zum Schaltplan zurückkehren, das Bauteil bearbeiten, ein geeignetes Teil auswählen und anschließend das BomDoc aktualisieren. ActiveBOM ermöglicht es jedoch, dies direkt im BomDoc durchzuführen und die Änderung anschließend über einen Engineering Change Order an den Schaltplan zu übertragen.

Klicken Sie im BomDoc mit der rechten Maustaste auf die ausgewählten Bauteile und wählen Sie den Befehl Operations » Change <ComponentName>. Der Dialog „Bauteil ersetzen“ wird geöffnet, in dem Sie nach dem Ersatzbauteil suchen können. Wählen Sie das gewünschte Ersatzbauteil aus und klicken Sie anschließend auf OK. Der Dialog Engineering Change Order wird geöffnet und zeigt die Änderungen an, die zur Synchronisierung des Schaltplans mit dem BomDoc erforderlich sind.

Beispiel für den Austausch eines Bauteils direkt in einem BomDoc.
Beispiel für den Austausch eines Bauteils direkt in einem BomDoc.

  • Die Funktion zum Ersetzen von Bauteilen sucht im aktuell aktiven Workspace nach einem neuen Bauteil.
  • Wenn sich die Bauteiländerung auch auf das Leiterplattendesign auswirkt, sollte die Leiterplatte ebenfalls vom Schaltplan aus aktualisiert werden.
  • Der Dialog Replace Component ist ähnlich aufgebaut wie das Panel „Bauteile“ und bietet viele derselben Funktionen. 

Ein generisches Bauteil ersetzen

Wenn ein Design so weit fortgeschritten ist, dass ein generisches Bauteil durch ein konkretes physisches Bauteil ersetzt werden kann, öffnen Sie den Dialog „Bauteil ersetzen“, indem Sie im Panel Properties die Schaltfläche auswählen. Dies ist auch über den Item Manager oder das ActiveBOM-Dokument des Projekts möglich.

Parameterwerte, die dem generischen Bauteil zugewiesen wurden (hier Leistungs- und Widerstandswerte), werden automatisch als Suchbegriffe im Dialog Replace Generic Component verwendet. So können Sie aus den gefilterten Ergebnissen ein geeignetes Ersatzbauteil auswählen – im gezeigten Beispiel erfüllen zwei Bauteileinträge die Suchkriterien.

Javascript ID: GenericComponents_Replace_AD23

Ein generisches Bauteil über das Panel Properties ersetzen.

Ein generisches Bauteil über das Panel Properties ersetzen.

Beachten Sie, dass die Logik zum Ersetzen von Bauteilen auch die Mehrfachauswahl unterstützt. Wenn mehrere generische Bauteile über das Panel Properties zum Ersetzen ausgewählt werden, ersetzt das im Dialog Replace Generic Component gewählte Herstellerbauteil alle ausgewählten Bauteile.

Footprints im gesamten Design verwalten

Der Schaltplaneditor von Altium Designer enthält einen leistungsstarken Footprint Manager. Der Footprint Manager wird über das Menü „Werkzeuge“ des Schaltplaneditors (Tools » Footprint Manager) aufgerufen und ermöglicht es Ihnen, alle Footprints zu überprüfen, die den einzelnen Bauteilen im gesamten Projekt zugeordnet sind. Dank der Unterstützung für die Mehrfachauswahl können Sie die Footprint-Zuordnung für mehrere Bauteile einfach bearbeiten, die Art der Footprint-Verknüpfung ändern oder bei Bauteilen mit mehreren zugewiesenen Footprints den aktuell verwendeten Footprint wechseln. Der Footprint Manager erleichtert es, Footprint-Zuordnungen im gesamten Design zu prüfen und Probleme zu erkennen. Dies ist besonders nützlich, wenn Sie an einem älteren Design oder einem Design aus einer anderen Organisation arbeiten. Designänderungen werden über das ECO-System angewendet, das bei Bedarf sowohl den Schaltplan als auch die Leiterplatte aktualisiert.

Der Dialog Footprint Manager zeigt eine Liste aller Bauteile in sämtlichen Quellschaltplänen des aktiven Projekts. Mit den Bedienelementen auf der rechten Seite des Dialogs verwalten Sie die Footprints, die für die Bauteile des Designs verfügbar sind und aktuell verwendet werden. Zu den Funktionen gehören:

  • Footprint-Modelle für ein oder mehrere ausgewählte Bauteile hinzufügen, bearbeiten und entfernen.
  • Footprints zwischen Bauteilen kopieren.
  • Die aktuelle Footprint-Zuordnung ändern, also den Footprint auswählen, der aus den gegebenenfalls mehreren verfügbaren Footprints aktuell zur Darstellung eines Bauteils auf der Leiterplatte verwendet wird.
  • Footprints validieren, um sicherzustellen, dass die Footprint-Modelle tatsächlich verfügbar sind – insbesondere diejenigen, die als aktuell zu verwendendes Modell festgelegt sind.

Sobald alle erforderlichen Änderungen an den Zuweisungen der Footprint-Modelle vorgenommen wurden, werden diese über einen standardmäßigen Engineering Change Order (ECO) umgesetzt. Klicken Sie dazu einfach auf die Schaltfläche Accept Changes (Create ECO) unten rechts im Dialog Footprint Manager.

Bei einem Design mit Device Sheets werden die Bauteile auf diesen Blättern nur aufgelistet, wenn die Blätter nicht als schreibgeschützt markiert sind. Den Schreibschutz für Device Sheets in Projekten können Sie auf der Seite „Data Management – Device Sheets“ des Dialogs Preferences umschalten.
Wenn das Design mithilfe verschiedener Bibliotheken erstellt wurde und die Footprints manuell zugewiesen oder bearbeitet wurden, müssen sämtliche Footprint-Daten unbedingt sorgfältig geprüft werden. Mit dem Footprint Manager können Sie die Footprints im gesamten Design vereinheitlichen. Eine zusätzliche Plausibilitätsprüfung ist jedoch ebenfalls erforderlich. Das System kann Designfehler wie die Zuweisung eines 20-W-Widerstands zu einem 0603-Footprint nicht erkennen. All diese Angaben müssen sorgfältig überprüft werden. Beachten Sie außerdem, dass die Footprint-Namen je nach Bauteillieferant variieren können. Verlassen Sie sich nicht auf Annahmen!
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents