Erstellen und Pflegen Ihrer Komponenten und Bibliotheken
Auf einen Blick
- Erfahren Sie, wie Schaltplansymbole, PCB-Footprints und andere Modelle reale Bauteile abbilden.
- Vergleichen Sie die Bibliotheksoptionen und entdecken Sie Workspace-Funktionen wie gemeinsam genutzte Bauteildaten, die Wiederverwendung von Modellen, Lieferketteninformationen und die Nachverfolgung des Lebenszyklus.
- Lernen Sie, wie Sie mit dem Bauteileditor und Bauteilvorlagen ein neues Workspace-Bauteil erstellen.
Ein Elektronikdesign besteht aus einer Vielzahl miteinander verbundener Bauteile. Der spannende Teil der Produktentwicklung besteht darin, clevere Lösungen für technische Herausforderungen zu finden und diese Bauteile zu Ihrem individuellen Design zu verbinden.
Ein großer Teil der Arbeit – und für viele Entwickler der eher mühsame Teil – besteht jedoch darin, die Bauteile zu erstellen. Auch wenn dies wenig aufregend sein mag, werden diese Bauteile zu einer wertvollen Ressource für Ihr Unternehmen. Daher ist es unerlässlich, dass sie das reale Bauteil exakt abbilden.
Das Bauteil, das Sie kaufen und auf die Leiterplatte löten oder in einem Kabelbaum verwenden, ist das reale Bauteil. Dieses muss jedoch in jeder Disziplin des Elektronikdesigns modelliert werden, in der Sie es verwenden möchten.
Je nachdem, welche Arten von Designs Sie umsetzen möchten, kann Ihr Bauteil ein Symbol für den Schaltplan, ein Simulationsmodell für den Schaltungssimulator, ein IBIS-Modell für die Signalintegritätsanalyse, ein Anschlussmuster oder einen Footprint für das Leiterplattenlayout und ein 3D-Modell zur Visualisierung, zur 3D-Abstandsprüfung und zum Export in die mechanische CAD-Umgebung umfassen.
Bauteilverwaltung
Eine effektive Verwaltung der Bauteildaten ist für das Elektronikdesign unerlässlich. Die Verwaltung der in einem Design verwendeten Bauteile war schon immer ein grundlegender Bestandteil der Altium-Designsoftware. Mit der Weiterentwicklung der Software über die Jahre haben sich auch die Methoden der Bauteilverwaltung erheblich weiterentwickelt: von einfachen, separaten Bibliotheken für Schaltplan- und Leiterplattenmodelle über Datenbankbibliotheken bis hin zu Workspace-Bauteilen, die Designbauteile für einen größeren Kreis von Beteiligten an der Produktentwicklung verfügbar machen. Hinzu kommen modernste, benutzerfreundliche Funktionen für eine herausragende Zusammenarbeit während des gesamten Designprozesses.
| Workspace-Bibliothek | Bauteile, die in einem verbundenen Workspace gespeichert sind, der Ihrem gesamten Entwicklungsteam als zentrale Quelle aktueller und standardisierter Bauteildaten dient. Mit parametrischen und facettierten Suchfunktionen können Sie die benötigten Bauteile schnell und effizient finden und platzieren. Diese Bauteile sind eng mit dem realen, gefertigten Bauteil und den bereits während der Entwicklung zugänglichen Lieferkettendaten verknüpft. Dadurch lassen sich bei der Fertigung des bestückten Produkts Beschaffungskosten und -zeiten erheblich reduzieren. |
|
| Datenbankbibliothek | Möchten Sie Ihre Designbauteile eng mit Ihrer Unternehmensdatenbank verknüpfen? Dann sind Datenbankbibliotheken die richtige Wahl. Jeder Datensatz entspricht einem Bauteil und verweist auf die erforderlichen Modelle und parametrischen Bauteildaten. Die Modellverknüpfungen und Parameter werden dem Symbol beim Platzieren hinzugefügt, wodurch es zu einem Altium Designer-Bauteil wird. | |
| SVN-Datenbankbibliothek | Eine SVN-Datenbankbibliothek ist eine Erweiterung des Datenbankbibliotheksmodells, bei der die Quellsymbole und -modelle unter Versionskontrolle gespeichert werden. Die Quellbibliotheken werden in einem Subversion-basierten Repository erstellt, ergänzt und gepflegt. Die Verknüpfungen zum Repository und zur externen Datenbank werden in einer SVN-Datenbankbibliotheksdatei (*.SVNDbLib) definiert. |
|
| Datenbankverknüpfung | Bei dieser Methode definiert die Datenbankverknüpfungsdatei (*.DbLink) die Verknüpfung zwischen dem Schaltplanbauteil und einem passenden Datensatz in einer Datenbank. Die Zuordnung des Datensatzes erfolgt über Schlüsselfelder. Dabei kann es sich um ein einzelnes Schlüsselfeld (z. B. eine Teilenummer) oder um mehrere Schlüsselfelder handeln (durch Definition einer WHERE-Klausel). |
|
| Integrierte Bibliothek | Möchten Sie Ihre Bauteile lieber fertig zusammengestellt und vorab geprüft in einer einzigen Datei haben? Dann kompilieren Sie die Schaltplan-, Leiterplatten- und Simulationsquellmodelle, um eine integrierte Bibliothek (*.IntLib) zu erstellen. |
|
| Schaltplanbibliothek | Eine Schaltplanbibliothek (*.SchLib) kann eine Modellbibliothek sein, die Bauteilsymbole enthält. Werden jedem Symbol Modellverknüpfungen und parametrische Daten hinzugefügt, wird daraus eine Bauteilbibliothek. |
|
| Leiterplattenbibliothek | Eine Bibliothek zum Speichern von Leiterplatten-Footprint-Modellen (*.PcbLib). Bei Bedarf kann jedem Footprint ein 3D-Modell hinzugefügt werden. 3D-Modelle werden aus 3D-Körperobjekten oder aus einem STEP-Modell erstellt, das in ein 3D-Körperobjekt importiert wird. |
Workspace-Bibliothek
Bauteile werden in Ihrem Workspace gespeichert – einem zentralen, sicheren Speicherort für alle Ihre Designdaten, auf den Ihr gesamtes Entwicklungsteam zugreifen kann. Die Verwendung von Bauteilen, die in einem Workspace gespeichert sind, bietet zahlreiche Vorteile. Dazu gehören:
-
Single source of component data – Mit einem für das gesamte Team zugänglichen Workspace können Entwickler aktuelle und standardisierte Bauteile von einem sicheren, zentralen Ort beziehen, Lieferkettendaten in Echtzeit abrufen und mithilfe der parametrischen und facettierten Suche genau die benötigten Bauteile finden.
-
Design-time choice of physical components – Für jedes Bauteil können Sie festlegen, welche Herstellerteile bei der Leiterplattenbestückung zu dessen Realisierung verwendet werden dürfen.
-
Real-time supply-chain information – Diese Informationen werden aus der zusammengeführten Bauteildatenbank des Altium Parts Provider zurückgemeldet, der seinerseits mit den aktivierten Lieferanten verbunden ist und deren Bauteile erfasst. So erhält der Entwickler aktuelle Informationen zu Preisen und Verfügbarkeit der ausgewählten Teile bei allen Anbietern, die diese Teile verkaufen (wie im lokalen Teilekatalog des Workspace definiert). Diese Informationen können einem Bauteil jederzeit hinzugefügt werden, auch nachdem es im Workspace gespeichert wurde – ohne es direkt zu bearbeiten und somit ohne Auswirkungen auf Designs, in denen es bereits verwendet wird. Anschließend können sie in einer Stückliste verwendet werden.
-
Concurrent editing of the library – Da die Workspace-Bibliothek im Wesentlichen aus einer Reihe von Bauteil-Items besteht, die in diesem Workspace gespeichert sind, können mehrere Benutzer unabhängig voneinander Bauteile für die Workspace-Bibliothek bearbeiten oder neu erstellen, ohne warten zu müssen, bis andere Benutzer ihre Arbeit abgeschlossen haben.
-
Component Models Reuse – Ein Bauteil lässt sich als „Behälter“ betrachten, in dem alle parametrischen Informationen und disziplinspezifischen Modelle gespeichert sind, darunter Schaltplansymbole, Leiterplatten-Footprints, Kabelbaumverdrahtungs- und Simulationsmodelle. Ein Bauteil enthält nicht die disziplinspezifischen Modelle selbst, sondern Verknüpfungen zu den entsprechenden Modell-Items, die ebenfalls in einem Workspace gespeichert sind. Dadurch kann ein einzelnes disziplinspezifisches Modell von mehreren Bauteilen verwendet werden. Wenn sich ein Modell ändert, wird Ihnen vorgeschlagen, alle Bauteile zu aktualisieren, die dieses Modell verwenden. So wird sichergestellt, dass kein Bauteil ein veraltetes Modell verwendet.
-
Direct Component Editing – Wenn ein Bauteil bearbeitet werden muss, können Sie es direkt aus Ihrem Workspace zur Bearbeitung öffnen. Eine temporäre Instanz des Bauteileditors ermöglicht es Ihnen, alle Aspekte dieses Bauteils zu bearbeiten, einschließlich der referenzierten disziplinspezifischen Modelle – ganz ohne dateibasiertes Dokument.
-
Use of Component Templates – Wenden Sie Vorlagen auf Basis von Parametern und Bauteiltaxonomien an, damit jeder neue Bauteiltyp automatisch den korrekten, stücklistenkonformen Parametersatz erhält. Gleichzeitig werden die korrekten Benennungs-, Revisions- und Lebenszyklusschemata automatisch angewendet.
-
Component Lifecycle Validation – Wenn sich ein Bauteil im Status „Ende des Lebenszyklus“, „abgekündigt“ oder „aufgegeben“ befindet, werden Sie gewarnt, bevor Sie Leiterplatten fertigen lassen, die dieses Bauteil verwenden.
-
Where-used Component Traceability – Die Verwendung von Bauteilen lässt sich lückenlos nachverfolgen: Wird ein Teil abgekündigt, können Sie ermitteln, in welchen Designs es verwendet wurde, und erkennen so, welche aktualisiert werden müssen. Wenn ein Symbol oder Footprint einen Fehler aufweist, können Sie alle Bauteile anzeigen, die dieses Symbol bzw. diesen Footprint verwenden, um sie zu korrigieren.
-
Requests of new components – Entwickler können Anfragen für neue oder fehlende Bauteile an die zuständigen Bibliotheksverantwortlichen richten. Sie werden benachrichtigt, sobald das Bauteil für die Verwendung in Designs durch den Anfragenden und andere Entwickler im Unternehmen verfügbar ist.
Ein neues Bauteil in der Workspace-Bibliothek erstellen
Das physische Bauteil, das auf der Leiterplatte montiert oder bei der Herstellung des Kabelbaums verwendet wird, wird bei der Schaltplanerfassung als Schaltplansymbol und beim Leiterplattenentwurf als PCB-Footprint dargestellt (optional mit einem 3D-Modell zur Visualisierung, zur 3D-Abstandsprüfung und zum Export in die mechanische CAD-Umgebung). Ein Entwicklungsbauteil kann auch ein Simulationsmodell für den Schaltungssimulator und ein IBIS-Modell für die Signalintegritätsanalyse enthalten. Um Entwicklungsbauteile auch im umfassenderen Produktentwicklungsprozess abzubilden, können ihnen ein oder mehrere ausgewählte Herstellerteile zugeordnet werden.
Bauteile für Ihr Entwicklungsprojekt können in der Workspace-Bibliothek Ihres Unternehmens erstellt und abgelegt werden. Sie werden über das Panel Components platziert, das die leistungsfähige Bauteilsuchmaschine von Altium Designer nutzt.
Ein neues Bauteil für die Workspace-Bibliothek wird im Bauteileditor erstellt. Dort können Sie alle Bauteildaten (Domänenmodelle, Parameter, ausgewählte Herstellerteile usw.) manuell definieren oder Daten aus dem Panel Manufacturer Part Search verwenden.
So erstellen Sie ein neues Bauteil für die Workspace-Bibliothek:
-
Wählen Sie einen Befehl zur Bauteilerstellung aus. Dieser ist wie folgt zugänglich:
-
Wählen Sie den Befehl File » New » Component aus den Hauptmenüs.
-
Wählen Sie File » New » Library aus den Hauptmenüs und anschließend im sich öffnenden Dialogfeld New Library die Option Create Library Content » Component im Bereich Workspace des Dialogfelds.
-
Klicken Sie im Panel Components mit der rechten Maustaste in den Bereich der Bauteilliste und wählen Sie den Befehl Create aus dem Kontextmenü.
-
-
Wählen Sie im sich öffnenden Dialogfeld Create new component einen Bauteiltyp aus. Wenn mit dem ausgewählten Bauteiltyp eine Bauteilvorlage verknüpft ist, wird diese verwendet, um das Bauteil mit den darin enthaltenen Daten vorzudefinieren.

Öffnen Sie das Dialogfeld Create new component, um den Typ des zu erstellenden Bauteils auszuwählen. -
Nach einem Klick auf OK öffnet sich der Bauteileditor im Einzelbauteil-Bearbeitungsmodus. Er bietet eine übersichtliche Benutzeroberfläche zum Definieren und Bearbeiten eines einzelnen Bauteils.
-
Definieren Sie das Bauteil, indem Sie seine Details im Bauteileditor hinzufügen:
- Definieren Sie im Bereich Component des Bauteileditors die Angaben Name und Description des Bauteils. Diese Angaben sind für die spätere Bauteilsuche unerlässlich, wenn Sie ein benötigtes Bauteil in Ihrem Entwicklungsprojekt verwenden möchten.
-
Klicken Sie auf das Bedienelement Advanced Settings, um weitere Bauteildetails zu definieren oder zu ändern, beispielsweise die Angabe Id für das im Workspace gespeicherte Bauteil und Folder im Ziel-Workspace, in dem das Bauteil gespeichert wird.
-
Definieren Sie im Bereich Parameters des Bauteileditors weitere Bauteildetails: Standardparameter, URL-Links zu Webseiten (z. B. zur Website eines Herstellers) und Links zu Datenblättern (in beliebigem Format).
-
Geben Sie im Bereich Part Choices des Bauteileditors ein oder mehrere ausgewählte Herstellerteile für das Bauteil an – die „zulässigen“ Herstellerteile, die zur Realisierung des Bauteils auf der bestückten Leiterplatte verwendet werden können.
-
Fügen Sie im Bereich Models des Bauteileditors Verknüpfungen zu gespeicherten (oder direkt erstellten) Domänenmodellen hinzu, die das Bauteil verwenden soll. Ein Bauteil kann ein Schaltplansymbol und mehrere PCB-Footprint- und Simulationsmodelle oder ein Kabelbaumverdrahtungsmodell enthalten. Ein Bauteil muss mindestens ein Modell besitzen.
-
Prüfen Sie das definierte Bauteil, um sicherzustellen, dass es die Anforderungen gemäß den Einstellungen auf der Seite „Data Management – Component Rule Checks“ des Dialogfelds Preferences erfüllt. Speichern Sie Ihr Bauteil lokal (File » Save) und wählen Sie anschließend den Befehl Tools » Component Rule Check aus den Hauptmenüs. Alle gefundenen Verstöße werden im Panel Messages aufgeführt.
-
Nachdem Sie das Bauteil definiert haben, wählen Sie den Befehl File » Save to Server aus den Hauptmenüs, um das Bauteil im Workspace zu speichern. Das Dialogfeld Edit Revision wird angezeigt. Darin können Sie den Namen und die Beschreibung ändern und bei Bedarf Freigabehinweise hinzufügen. Der Editor wird nach dem Speichern geschlossen.
Ihr neues Bauteil steht nun im Panel Components zum Suchen und Bearbeiten zur Verfügung.
Hinweise
-
Um ein neues Bauteil zu erstellen, das einem vorhandenen Bauteil in Ihrem Workspace ähnelt, können Sie eine Kopie dieses Bauteils anlegen. Navigieren Sie im Panel Components zum gewünschten Bauteil, klicken Sie mit der rechten Maustaste darauf und wählen Sie den Befehl Operations » Make a copy aus. Der Bauteileditor wird geöffnet, wobei das Bauteil bereits mit den Daten des ausgewählten Bauteils vordefiniert ist.
-
Eine Komponente kann anhand von Daten definiert werden, die von der Herstellerteilsuche bereitgestellt werden. Beginnen Sie mit der Eingabe im Feld Name und wählen Sie ein passendes Herstellerteil aus oder fügen Sie der zu definierenden Komponente eine Bauteiloption hinzu. Daraufhin wird der Dialog „Komponentendaten verwenden“ geöffnet, in dem Sie auswählen können, welche Daten Sie auf die gerade erstellte oder bearbeitete Komponente anwenden möchten: Name, Beschreibung, Parameter, Modelle und Datenblätter.

Komponentendaten können aus der Herstellerteilsuche übernommen werden. Hier wird beispielhaft gezeigt, wie Sie auf diese Funktion zugreifen, indem Sie einen Komponentennamen in das Feld Name eingeben und einen passenden Eintrag aus der Popup-Liste auswählen. -
Der Komponenten-Editor kann auch im Modus zur Stapelbearbeitung von Komponenten verwendet werden, der eine Oberfläche zum Definieren und Bearbeiten mehrerer Komponenten bietet. Wenn sich der Komponenten-Editor im Single Component Editing Modus befindet, können Sie den Stapelbearbeitungsmodus über den Befehl Tools » Switch to Batch Editor in den Hauptmenüs des Editors aufrufen.
-
Um Ihre vorhandenen dateibasierten Bibliotheken und Datenbankbibliotheken (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) schnell in den Workspace zu importieren, können Sie den Bibliotheksimporter verwenden. Der Bibliotheksimporter bietet eine Ein-Klick-Lösung, die die ausgewählten Bibliotheken automatisch analysiert und in den Workspace importiert, mit dem Sie aktuell verbunden sind.
-
Eine neue Komponente kann auch erstellt werden, indem Sie im Projects Panel mit der rechten Maustaste auf den Eintrag des verbundenen Workspace klicken und den Befehl Create Component aus dem Menü wählen.
-
Um eine Workspace-Komponente zu bearbeiten, klicken Sie im Panel „Komponenten“ mit der rechten Maustaste auf den Eintrag einer Komponente und wählen Sie den Befehl Edit aus dem Kontextmenü. Der Komponenten-Editor wird im Single Component Editing Modus geöffnet, wobei die Komponentendefinition zur Bearbeitung bereitsteht. Nehmen Sie die erforderlichen Änderungen vor und speichern Sie die Komponentendefinition anschließend als nächste Revision der Workspace-Komponente.
-
Auf dieselbe Weise können Sie im Panel „Komponenten“ mehrere Komponenten auswählen und den Befehl Edit aus dem Kontextmenü wählen. Wenn die ausgewählten Komponenten auf dieselbe Komponentenvorlage verweisen, wird eine einzelne Instanz des Komponenten-Editors im Modus zur Stapelbearbeitung von Komponenten geöffnet. Andernfalls wird für jede Gruppe von Komponenten, die dieselbe Komponentenvorlage verwenden, eine separate Instanz des Komponenten-Editors geöffnet.
-
Zur Bearbeitung geöffnete Workspace-Komponenten werden unter dem Eintrag Workspace Components im Panel Projects angezeigt.
Über das Kontextmenü des Eintrags Workspace Component können Sie die Komponenten der Gruppe öffnen, schließen, lokal speichern, im verbundenen Workspace speichern oder Änderungen verwerfen (ohne Änderungen schließen)
. Wenn Sie den Befehl Close All verwenden und mehrere Komponenten der Gruppe geändert wurden, wird ein Dialog zur Bestätigung des Speicherns angezeigt. Dieser bietet Entscheidungsoptionen, die auf die Arbeit mit einem zur Bearbeitung geöffneten Workspace-Objekt zugeschnitten sind
-
Wenn Sie als Benutzer mit reinen Leseberechtigungen versuchen, eine Workspace-Komponente zur Bearbeitung zu öffnen, wird der Komponenten-Editor geöffnet. Sie können dann auf die Komponentendetails zugreifen, jedoch keine Änderungen im Workspace speichern. In diesem Fall wird der Eintrag dieser Workspace-Komponente im Panel Projects mit der Kennzeichnung Local Edits Only angezeigt
-
Beim Speichern einer bearbeiteten Komponente in Ihrer Workspace-Bibliothek können Sie den aktuellen Lebenszyklusstatus der Komponente beibehalten. Dies wird über die Option Preserve lifecycle state (not recommended) gesteuert, die beim erneuten Speichern im Dialog Edit Revision verfügbar ist (Bild anzeigen). Ist diese Option aktiviert, wird für die neue Komponentenrevision automatisch der Lebenszyklusstatus der vorherigen Revision festgelegt. Diese Möglichkeit steht Benutzern zur Verfügung, denen die Berechtigung für den Vorgang Allow to skip lifecycle state change for new revisions zugewiesen wurde (weitere Informationen finden Sie unter Globale Berechtigungen für Vorgänge in einem Workspace festlegen).
Datenbankbibliotheken
Altium Designer bietet die Möglichkeit, Komponenten direkt aus einer Unternehmensdatenbank zu platzieren, indem Sie eine Database Library erstellen und verwenden. Die Platzierung erfolgt über das Panel Components, das nach der Installation einer Datenbankbibliothek als Browser für Ihre Datenbank dient.
Nach der Platzierung können die Designparameter zwischen den platzierten Komponenten und den zugehörigen verknüpften Datensätzen in der Datenbank synchronisiert werden. Vollständige Komponentenaktualisierungen sind möglich – einschließlich des grafischen Symbols, der Modellreferenzen und der Parameter. Parameterdaten aus der Datenbank können auch in die endgültige Stückliste (BOM) aufgenommen werden, die damit für die Bauteilbeschaffung bereitsteht.
Lesen Sie mehr über Datenbankbibliotheken.
Dateibasierte Bibliotheken
Wenn Sie Ihre Komponenten lokal in Ihrem Dateisystem speichern müssen, können Sie sie in dateibasierten Bibliotheken organisieren.
Eine dateibasierte Bibliothek in Altium Designer ist eine beliebige Sammlung von Modellen oder Komponenten. Wie die Modelle oder Komponenten in Bibliotheken organisiert werden, bleibt Ihnen überlassen. Sie können Ihre Bibliotheken nach Bauteillieferanten strukturieren oder Komponenten nach ihrer Funktion gruppieren, beispielsweise mit einer Bibliothek für alle Mikrocontroller, die Ihr Unternehmen verwendet.
Schaltplansymbole für Komponenten werden in Schaltplanbibliotheken (*.SchLib) erstellt. Die Komponenten in diesen Bibliotheken verweisen dann auf Footprints und andere Modelle, die in separaten Footprint-Bibliotheken (*.PcbLib) und Modelldateien definiert sind. Als Entwickler können Sie Komponenten aus diesen einzelnen Komponentenbibliotheken platzieren oder die Symbolbibliotheken, Footprint-Bibliotheken und Modelldateien zu integrierten Bibliotheken (*.IntLib) kompilieren.
Lesen Sie mehr über dateibasierte Komponentenbibliotheken.
Modelle
Aus Sicht eines Entwicklers fasst eine Komponente alle Informationen, die zu ihrer Darstellung in sämtlichen Designdomänen erforderlich sind, in einem einzigen Objekt zusammen. In dieser Hinsicht kann sie daher als Container betrachtet werden.
Jede Komponente ist eine Sammlung verknüpfter Modelle und parametrischer Komponentendaten. Die Modelle enthalten die detaillierten Informationen, die von den einzelnen Designdomänen benötigt werden.
Die folgenden Modelltypen können verwendet werden:
| Schaltplansymbol | Das Symbol stellt die Komponente auf dem Schaltplanblatt dar. Es wird mit Standard-Zeichenobjekten erstellt; die Pins ergänzen die elektrischen Eigenschaften. |
| SPICE-Modell | Simulieren Sie das Verhalten der verbundenen Komponenten mit dem SPICE-Simulator. SPICE-Modelle werden in der Regel von Bauteillieferanten bereitgestellt. |
| Signalintegritätsmodell | Mit zunehmenden Schaltgeschwindigkeiten von Bauteilen und Schaltungen werden Leiterplattenverbindungen selbst zu einem Bestandteil der Schaltung. IBIS-Modelle beschreiben das Verhalten der Pins und ermöglichen es dem Signalintegritätssimulator von Altium Designer, die Leiterbahnen zu analysieren. |
| Leiterplatten-Footprint | Für jede Komponente muss ein Bereich auf der Leiterplatte definiert sein, in dem sie montiert und angeschlossen wird. Der Footprint ist das Modell, das diesen Bereich auf der Leiterplatte festlegt. Ein Leiterplatten-Footprint wird aus einer Reihe von Standardobjekten erstellt, wobei die Pads die elektrischen Verbindungen bereitstellen. |
| 3D-Modell | Heutige Elektronikprodukte sind kompakt und dicht bestückt, haben ungewöhnliche Formen und enthalten möglicherweise eine Leiterplatte, die gefaltet ist, damit sie in das Gehäuse passt. Um ein solches Produkt zu entwickeln, müssen Sie die Leiterplatte in 3D modellieren können – so können Sie die fertige Leiterplatte visualisieren, 3D-Abstandsprüfungen durchführen und die bestückte Leiterplatte in die mechanische CAD-Umgebung übertragen. Dafür benötigen Sie ein 3D-Modell jedes Bauteils. |
Erfahren Sie mehr über das Erstellen und Verwalten von Symbolen, Footprint-Modellen, Simulationsmodellen und 3D-Modellen in Ihrem Workspace.
Das Components-Panel
Das Components-Panel bietet in Altium Designer direkten Zugriff auf alle verfügbaren Bauteile, einschließlich Bauteilen aus dem Workspace, aus Datenbanken und aus dateibasierten Bibliotheken.
Das Panel bezieht Bauteile aus einem Workspace sowie aus allen geöffneten oder installierten Bibliotheksdateien. Es bietet umfassende Details zum ausgewählten Bauteil (Parameter, Modelle, Bauteiloptionen, Lieferantendaten usw.), einen Bauteilvergleich und für Workspace-Bauteile eine filterbasierte parametrische Suche, mit der sich die gewünschten Bauteilparameter festlegen lassen. Mithilfe kontextabhängiger dynamischer Filter können Sie über die Suchfunktion des Panels schnell genau das benötigte Bauteil im verbundenen Workspace Ihres Unternehmens finden.
Erfahren Sie mehr über das Components-Panel.
Das Manufacturer Part Search-Panel
Sie können auch mit dem Manufacturer Part Search-Panel nach tatsächlich erhältlichen Herstellerteilen suchen. Es verwendet die grundlegenden Suchfunktionen und die Ansicht des Components-Panels. Ein ausgewähltes Herstellerteil kann als Grundlage für ein neues Bauteil in Ihrem verbundenen Workspace dienen. Alternativ können seine Parameter und Datenblätter einem bereits platzierten Bauteil hinzugefügt werden.
Das
-Symbol in einem Bauteileintrag bedeutet, dass diesem Bauteil Modelle (Schaltplansymbole, PCB-Footprints, Simulationsmodelle) zugewiesen sind. Wenn Sie auf Grundlage dieses Herstellerteils ein neues Bauteil erstellen, werden auch dessen Modelle übernommen. Alternativ können Sie dieses Bauteil lokal herunterladen oder direkt in Ihrem Schaltplan platzieren.
Erfahren Sie mehr über das Manufacturer Part Search-Panel.
Wie geht es weiter?
Erstellen eines Schaltplansymbols
Erstellen eines PCB-Footprints
Erstellen einer Kabelbaum-Verdrahtungskomponente



).
).



