Support for Zipping ODB Output in TGZ Format (New Feature Summary)

Created: February 25, 2016 | Updated: December 14, 2017

When generating your board fabrication data in ODB++ format, Altium Designer now creates a TGZ archive file of that data as well. A TGZ file is GZIP compressed TAR Archive file. The TAR Archive is used to bundle files together and then the GZIP compression is used to reduce the size of the files; TGZ files are smaller than regular Zip files.

Because TGZ files are favored by many CAM software options, such as Frontline Genesis, a TGZ file can make it easier to facilitate the fabrication process.

Where Do I Access it?

To access the TGZ file, simply open the folder used for ODB++ outputs. If you're not sure where this folder is on your local drive, or if you'd like to change its location, you can view and edit the path from the Options tab of Project Options dialog (Project » Project Options).

You can generate a TGZ file along with your output ODB++ files for board fabrication in the following ways:

  • From a PcbDoc, use the ODB++ Setup dialog. The dialog can be accessed from File » Fabrication Outputs » ODB++ File.
  • From an OutJob file, click Generate Content under the output container section. Make sure that ODB++ files have been added to Fabrication Outputs and are selected before generating output. To add ODB++ files to Fabrication Outputs, click Edit » Fabrication Outputs » ODB++ Files and select the PcbDoc you want to add ODB++ files from.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: