Working with Reuse Blocks & Snippets (Old Design Reuse Panel)

De un vistazo

Este artículo explica cómo Altium Designer te ayuda a guardar y reutilizar secciones de circuitos habituales mediante bloques de reutilización y fragmentos, para que no tengas que volver a crear desde cero los elementos de diseño que se repiten. Describe qué incluye cada opción de reutilización, cómo acceder al panel Design Reuse y utilizarlo, y cómo crear, gestionar, cambiar el nombre y organizar el contenido de diseño tanto en un espacio de trabajo como en ubicaciones locales. Si trabajas habitualmente con secciones de esquemas o de PCB que se repiten, esta guía te muestra cómo integrar estas herramientas en tu flujo de trabajo y empezar a utilizarlas de forma eficaz. Sigue leyendo para agilizar tu proceso de diseño y hacerlo más coherente.

- Descubre las diferencias entre los bloques de reutilización, los fragmentos de esquemas y los fragmentos de PCB, y cuándo se utiliza cada uno.
- Aprende a utilizar el panel Design Reuse para encontrar, filtrar, ordenar, buscar y gestionar contenido de diseño reutilizable.
- Sigue los pasos para crear, guardar, cambiar el nombre y organizar bloques de reutilización y fragmentos tanto en un espacio de trabajo como en ubicaciones locales.
Profundiza con IA:

La interfaz de usuario de la funcionalidad de reutilización de diseños descrita en esta página es la versión anterior del panel Design Reuse, disponible cuando la opción UI.ModernDesignReusePanel está desactivada en el cuadro de diálogo Advanced Settings. Cuando esta opción está activada, se utiliza una nueva versión del panel, descrita en las páginas Trabajar con bloques de reutilización y Trabajar con fragmentos. El nuevo panel Design Reuse está en beta abierta.

Si sus diseños suelen incluir «secciones» de circuitos comunes, Altium Designer ofrece una forma sencilla y fácil de guardar y reutilizar secciones de circuitos del diseño, tanto almacenadas en un Workspace como en archivos locales. Estas secciones pueden añadirse a cualquier diseño de PCB sin tener que empezar desde cero cada vez. Es una función excelente para esos fragmentos de uso frecuente y pequeñas secciones de circuitos que desea reutilizar. El sistema permite guardar cualquier selección de:

  • Circuitos de una sola hoja de esquemático (un fragmento de esquemático).

  • Circuitos de un diseño de PCB, incluidos los componentes y el enrutado (un fragmento de PCB).

Cuando se conecta a un Workspace, puede crear una única entidad —un bloque de reutilización— que contenga tanto los circuitos del esquemático como su representación física para la PCB. Al colocar un bloque de reutilización de este tipo en una hoja de esquemático, su representación física se colocará automáticamente en el documento de PCB durante el proceso ECO.

El panel Design Reuse es el centro de control para crear, gestionar y utilizar bloques de reutilización y fragmentos, tanto almacenados en un Workspace como en archivos locales.

El panel Design Reuse
El panel Design Reuse

Se puede acceder al panel de las siguientes maneras:

  • Haga clic en el botón Panels situado en la parte inferior derecha del espacio de diseño y, a continuación, haga clic en Design Reuse.
  • Seleccione View » Panels » Design Reuse en los menús principales.
  • Seleccione Place » Reuse Block en los menús principales.

El menú desplegable de la parte superior del panel muestra todas las carpetas disponibles en el Workspace al que está conectado que contienen bloques de reutilización y fragmentos almacenados en el Workspace. El número junto al nombre de cada carpeta indica cuántos bloques de reutilización de diseños y fragmentos contienen esa carpeta y sus subcarpetas. Seleccione una carpeta en el menú desplegable para mostrar en la sección principal del panel los bloques de reutilización y los fragmentos que contienen esa carpeta y sus subcarpetas. Seleccione la entrada del Workspace al que está conectado en el menú desplegable para mostrar todos los bloques de reutilización y fragmentos disponibles.

La estructura de carpetas del Workspace puede definirse desde Altium Designer mediante el panel Explorer.

Utilice los botones de filtrado de la ventana emergente del icono  para mostrar u ocultar el contenido de tipos específicos (Reuse Blocks, Schematic Snippets, PCB Snippets) en el panel. Utilice el control Sort By para seleccionar la opción de ordenación que prefiera.

Utilice las opciones de filtrado y ordenación para configurar la visualización del contenido en el panel
Utilice las opciones de filtrado y ordenación para configurar la visualización del contenido en el panel

Para buscar bloques de reutilización y fragmentos disponibles en la carpeta seleccionada por su nombre o descripción, introduzca una frase en el campo Search para filtrar la lista y ajustarla a sus necesidades específicas.

Cada bloque de reutilización y fragmento se presenta en la sección principal del panel mediante una ficha que contiene los siguientes datos:

  • Imagen de vista previa – puede hacer clic en ella para alternar entre la vista normal y la vista a tamaño completo. Para un bloque de reutilización, utilice el botón  Haga clic y arrastre para mover​ para alternar entre las vistas previas de sus documentos de PCB y esquemático;

  • El icono de tipo –  Haga clic y arrastre para mover​ para un bloque de reutilización,  Haga clic y arrastre para mover​ para un fragmento de esquemático,  Haga clic y arrastre para mover​ para un fragmento de PCB;

  • Nombre y descripción (si se ha definido);

  • El ID de la revisión más reciente, la fecha de creación y el autor de un bloque de reutilización o de un fragmento de esquemático/PCB del Workspace.

La información y los controles de un bloque de reutilización o fragmento se presentan en una ficha dentro del panel.
La información y los controles de un bloque de reutilización o fragmento se presentan en una ficha dentro del panel.

Crear un bloque de reutilización

Se puede crear un nuevo bloque de reutilización de las siguientes maneras:

  1. Seleccione el comando para crear un nuevo bloque de reutilización:

    • Desde el panel Design Reuse, haciendo clic en el botón  de la parte superior del panel.

    • Mediante el comando File » New » Reuse Block del menú principal.

    • Desde el panel Explorer, haciendo clic en el botón  situado en la parte superior derecha del panel cuando se esté explorando una carpeta del tipo Design Reuse Blocks.

  2. Se abrirá una estructura temporal y editable del bloque de reutilización, similar a la de un proyecto de PCB, en el panel Projects (bajo una entrada del Workspace al que está conectado actualmente), y se abrirá el editor de esquemáticos temporal en la ventana principal de diseño, listo para definir el documento de esquemático del bloque de reutilización. Utilice los comandos y las técnicas de colocación habituales para definir el documento de esquemático del bloque de reutilización.

  3. Cuando haya terminado, utilice el comando Design » Update PCB Document y el proceso ECO para transferir el esquemático capturado al documento de PCB del bloque de reutilización y, a continuación, aplique los cambios necesarios a ese documento (definir las ubicaciones de los componentes, el enrutado, etc.).

    Se pueden añadir varios documentos de PCB al bloque de reutilización que se está definiendo. Para ello, utilice el comando Add New to Project » PCB del menú contextual de la entrada del bloque de reutilización en el panel Projects.

    Utilice el comando Rename del menú contextual de la entrada del documento de PCB añadido en el panel Projects para asignarle un nombre significativo. Utilice un comando Design » Update del menú principal del editor de esquemáticos para actualizar el documento de PCB correspondiente.

    Cuando haya definido tanto el documento de esquemático como el de PCB del bloque de reutilización, guarde el bloque de reutilización en el Workspace mediante el comando Save to Server del menú contextual de la entrada del bloque de reutilización en el panel Projects o el control Save to Server situado a la derecha de la entrada.

    Dado que los bloques de reutilización se almacenan en el Workspace conectado, deben utilizar componentes de ese Workspace. De esta manera, podrá aprovechar al máximo el sistema de contenido que ofrece el Workspace.

    • Tanto el documento esquemático como el documento PCB del bloque de reutilización deben contener al menos un componente para poder guardarse en el espacio de trabajo.

    • Si los documentos esquemático y PCB del bloque de reutilización no están sincronizados (se detectan diferencias entre ellos), se mostrará el cuadro de diálogo de advertencia al intentar guardar el bloque de reutilización en el espacio de trabajo. Puede cancelar el guardado para volver al bloque de reutilización y resolver las diferencias, o continuar con el guardado.

  4. Aparecerá el cuadro de diálogo New Reuse Block, en el que puede definir Name, Description y la Folder del espacio de trabajo en la que se guardará el nuevo bloque de reutilización.

    El cuadro de diálogo New Reuse Block
    El cuadro de diálogo New Reuse Block

  5. Después de hacer clic en OK, el bloque de reutilización se guardará en el espacio de trabajo y se cerrará su estructura temporal.

El bloque de reutilización guardado podrá encontrarse en el panel Design Reuse al seleccionar la carpeta en la que se haya guardado (o la entrada del espacio de trabajo conectado) en la lista desplegable superior. Puede que sea necesario utilizar el comando Refresh del menú del botón  para que el nuevo bloque de reutilización aparezca en el panel.

Cambiar el nombre de un bloque de reutilización

Una vez creado un bloque de reutilización, puede cambiarle el nombre por un título más adecuado si lo desea. Para cambiar el nombre de un bloque de reutilización, utilice el comando Rename , al que puede acceder desde el submenú  y el menú contextual que aparece al hacer clic con el botón derecho en el panel Design Reuse . En el cuadro de diálogo Rename Reuse Block que se abre, introduzca el nuevo título y haga clic en OK. El bloque de reutilización tendrá ahora el nombre deseado, como se muestra en las siguientes imágenes.

Crear un fragmento

Puede crear rápidamente un nuevo fragmento de esquemático o PCB a partir de circuitos existentes en una hoja de esquemático o un documento PCB:

  1. Seleccione los circuitos necesarios en el editor de esquemáticos o de PCB.

  2. Haga clic con el botón derecho y elija Snippets » Create Snippet from selected objects en el menú contextual, o seleccione el comando Tools » Convert » Create Snippet from selected objects en los menús principales.

  3. Aparecerá el cuadro de diálogo New Schematic Snippet o New PCB Snippet, en el que puede definir el nombre, la descripción, el destino de guardado (un espacio de trabajo o una carpeta local) y la carpeta en la que se guardará el nuevo fragmento.

    Al guardar un fragmento en una carpeta local, haga clic en el botón  situado a la derecha del campo Path del cuadro de diálogo para acceder al cuadro de diálogo Choose Snippet Folder, que le permite seleccionar una carpeta local de fragmentos existente en la que guardar el fragmento, o crear una nueva subcarpeta dentro de una carpeta local de fragmentos existente.

    Para obtener información sobre cómo organizar los fragmentos locales en carpetas, consulte la sección Organización de fragmentos locales más abajo.
  4. Después de hacer clic en OK, se guardará el fragmento.

El fragmento guardado podrá encontrarse en el panel Design Reuse al seleccionar la entrada del espacio de trabajo conectado (o la carpeta en la que se haya guardado) en la lista desplegable superior.

Puede crear un fragmento a partir de un conjunto de objetos seleccionados. Aquí se muestra la creación de un fragmento de esquemático. Pase el cursor sobre la imagen para ver la creación de un fragmento de PCB.
Puede crear un fragmento a partir de un conjunto de objetos seleccionados. Aquí se muestra la creación de un fragmento de esquemático. Pase el cursor sobre la imagen para ver la creación de un fragmento de PCB.

Puede que sea necesario utilizar el comando Refresh del menú del botón  del panel para que el nuevo bloque de reutilización aparezca en el panel.

Para acceder a los fragmentos locales desde el panel Design Reuse, debe estar habilitada la opción Local Snippets en el menú .

También puede crear un fragmento en el espacio de trabajo a partir de un fragmento local existente haciendo clic en el botón  de la ficha del fragmento (o haciendo clic con el botón derecho en cualquier parte de la ficha) y seleccionando el comando Save to Server en el menú. En el cuadro de diálogo New Schematic Snippet o New PCB Snippet que aparece, defina Name, Description y la Folder del espacio de trabajo en la que se guardará el fragmento.

Puede guardar un fragmento local en el espacio de trabajo conectado mediante el comando Save to Server.
Puede guardar un fragmento local en el espacio de trabajo conectado mediante el comando Save to Server.

Los fragmentos del espacio de trabajo deben utilizar componentes de ese mismo espacio de trabajo. De este modo, aprovechará al máximo el sistema de contenido que ofrece el espacio de trabajo.

Organización de fragmentos locales

El panel Design Reuse permite organizar los fragmentos locales en carpetas de fragmentos para agrupar los fragmentos relacionados y facilitar su búsqueda. Las carpetas de fragmentos son carpetas existentes de Windows que no se pueden crear desde el panel Design Reuse. En su lugar, se «abren» o se «cierran» al explorar los fragmentos locales que contienen. Estas carpetas solo se pueden crear directamente en el disco duro o en la red, fuera de Altium Designer.

Las carpetas de fragmentos se pueden abrir y cerrar desde el cuadro de diálogo Available Snippets Folders, al que se accede haciendo clic en el botón  situado en la esquina superior derecha del panel Design Reuse y seleccionando el comando Snippet Folders en el menú. Haga clic en Open Folder para buscar la carpeta deseada en el disco duro o en la red. La carpeta seleccionada se añadirá a la lista del cuadro de diálogo y aparecerá después en la lista desplegable de la parte superior del panel Design Reuse.

Para eliminar una carpeta de fragmentos de la lista (lo que, a efectos de exploración, equivale a cerrarla), seleccione la carpeta en la lista y haga clic en Remove Folder. Utilice los botones Move Up y Move Down para cambiar el orden en el que se mostrarán los fragmentos locales en el panel Design Reuse al seleccionar la entrada Local en la lista desplegable del panel.

Colocar bloques de reutilización y fragmentos

Para colocar un bloque de reutilización o un fragmento en un diseño, haga clic dentro de su ficha y después en el botón , haga clic en el botón de su ficha, o haga clic con el botón derecho en cualquier parte de la ficha y seleccione uno de los siguientes comandos:

  • Place – seleccione esta opción para colocar el bloque de reutilización o el fragmento directamente en el documento esquemático o PCB activo.
  • Place as Sheet Symbol – cuando haya un documento esquemático activo, seleccione esta opción para colocar el bloque de reutilización o el fragmento de esquemático como un símbolo de hoja en la hoja de esquemático. El contenido del bloque de reutilización o del fragmento de esquemático se colocará en una hoja de esquemático secundaria creada automáticamente y referenciada por el símbolo de hoja colocado.

Coloque un bloque de reutilización o un fragmento mediante el menú del botón Place de su mosaico en el panel. Aquí se muestra la selección del comando Place, con el que el bloque de reutilización o fragmento de esquema se coloca en la hoja de esquema activa. Pase el cursor sobre la imagen para ver la selección del comando Place as Sheet Symbol, con el que el bloque de reutilización o fragmento de esquema se coloca en la hoja secundaria a la que hace referencia el símbolo de hoja colocado.
Coloque un bloque de reutilización o un fragmento mediante el menú del botón Place de su mosaico en el panel. Aquí se muestra la selección del comando Place, con el que el bloque de reutilización o fragmento de esquema se coloca en la hoja de esquema activa. Pase el cursor sobre la imagen para ver la selección del comando Place as Sheet Symbol, con el que el bloque de reutilización o fragmento de esquema se coloca en la hoja secundaria a la que hace referencia el símbolo de hoja colocado.

Haga clic en el control Show more del mosaico del bloque de reutilización para mostrar la sección PCB que contiene la lista de documentos PCB del bloque de reutilización. Seleccione el documento PCB deseado en la lista y el bloque de reutilización se colocará con este documento. El documento PCB seleccionado se muestra en el área de vista previa del mosaico del bloque de reutilización cuando se selecciona PCB para la vista previa.

Seleccione un documento PCB que se colocará con el bloque de reutilización para mostrar su vista previa.
Seleccione un documento PCB que se colocará con el bloque de reutilización para mostrar su vista previa.

Después de colocar el documento de esquema de un bloque de reutilización, su documento PCB puede colocarse en el documento PCB mediante el proceso ECO. Desde el editor de esquemas, utilice el comando Design » Update PCB Document de los menús principales y, a continuación, valide y ejecute los cambios mediante el cuadro de diálogo Engineering Change Order. El documento PCB se colocará en el documento PCB como una unión y podrá gestionarse desde el modo Uniones del panel PCB.

Cuando un componente seleccionado del esquema o de la PCB forma parte de un bloque de reutilización colocado en el diseño, puede examinar sus propiedades haciendo clic en el enlace Reuse Block del panel Properties . Las propiedades del bloque de reutilización al que pertenece el componente se mostrarán en el panel. Para volver a las propiedades del componente seleccionado inicialmente, utilice el enlace Component.

Acceda a las propiedades del bloque de reutilización desde un componente que forme parte de él. Las imágenes anteriores muestran el acceso a las propiedades desde un componente del esquema. Pase el cursor sobre la imagen para ver el acceso desde un componente de la PCB.
Acceda a las propiedades del bloque de reutilización desde un componente que forme parte de él. Las imágenes anteriores muestran el acceso a las propiedades desde un componente del esquema. Pase el cursor sobre la imagen para ver el acceso desde un componente de la PCB.

En el caso de un bloque de reutilización, al utilizar el comando de colocación se usará su documento de esquema o su documento PCB, según el tipo de documento que esté activo al ejecutar el comando.

En el caso de un fragmento, asegúrese de que el documento de destino correcto esté abierto y activo antes de colocarlo. El comando de colocación solo estará disponible si el fragmento puede colocarse correctamente en ese documento; es decir, el tipo de fragmento y el tipo de documento deben coincidir.

Edición de bloques de reutilización y fragmentos

Para editar un bloque de reutilización o un fragmento alojado en un espacio de trabajo, haga clic en el botón de su mosaico (o haga clic con el botón derecho en cualquier parte del mosaico) y seleccione el comando Edit del menú.

Abra un bloque de reutilización o un fragmento alojado en un espacio de trabajo para editarlo mediante el comando Edit del mosaico correspondiente en el panel.
Abra un bloque de reutilización o un fragmento alojado en un espacio de trabajo para editarlo mediante el comando Edit del mosaico correspondiente en el panel.

Se abrirá el editor temporal con el documento (que contiene el bloque de reutilización o fragmento de origen) incluido en la última revisión del elemento del espacio de trabajo, listo para editarlo. Realice los cambios necesarios y, a continuación, guarde el documento en la siguiente revisión del bloque de reutilización o fragmento mediante el comando File » Save to Server del menú principal o el comando Save to Server del menú contextual de la entrada del bloque de reutilización o fragmento en el panel Proyectos.

Las propiedades (Nombre, Descripción y Ruta) de un fragmento local pueden editarse mediante el cuadro de diálogo Snippet Properties, al que se accede haciendo clic en el botón  del mosaico del fragmento local (o haciendo clic con el botón derecho en cualquier parte del mosaico) y seleccionando el comando Edit Properties del menú.

Edite las propiedades de un fragmento local mediante el cuadro de diálogo Snippet Properties, al que se accede desde el panel Design Reuse.
Edite las propiedades de un fragmento local mediante el cuadro de diálogo Snippet Properties, al que se accede desde el panel Design Reuse.

Eliminación de bloques de reutilización y fragmentos

Para eliminar un bloque de reutilización o un fragmento, haga clic en el botón  del mosaico del fragmento (o haga clic con el botón derecho en cualquier parte del mosaico) y seleccione el comando Delete del menú.

  • En el caso de un bloque de reutilización o un fragmento alojado en un espacio de trabajo, aparecerá el cuadro de diálogo Delete Items para confirmar la eliminación. En realidad, la acción es una «eliminación lógica», mediante la cual el bloque de reutilización o el fragmento se trasladará al área Trash del espacio de trabajo. El área Trash es, en esencia, una papelera de reciclaje a la que puede trasladarse cualquier contenido del espacio de trabajo (mediante una acción de eliminación lógica). Está aislada del resto del espacio de trabajo. En el caso de un bloque de reutilización, también puede optar por eliminar su contenido relacionado (por ejemplo, fragmentos de esquema y de PCB).

    Realice una eliminación lógica de un bloque de reutilización o un fragmento mediante el comando Delete del mosaico correspondiente en el panel.
    Realice una eliminación lógica de un bloque de reutilización o un fragmento mediante el comando Delete del mosaico correspondiente en el panel.

  • En el caso de un fragmento local, aparecerá el cuadro de diálogo Confirm para confirmar la eliminación. Esta acción eliminará los archivos del fragmento del disco duro.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents