Trabajar con hojas de esquemático gestionadas

De un vistazo

Este artículo explica cómo las hojas de esquemático gestionadas en un Workspace conectado a Altium Designer permiten reutilizar diseños de forma más fiable, trazable y coherente que simplemente copiando y pegando. Muestra qué es una hoja de esquemático gestionada, en qué se diferencia de las hojas de dispositivo, cómo se almacena y se controla su versión en el Workspace, y las principales formas de crearla y guardarla para su uso futuro. También verá cómo el tipo de carpeta, el tipo de contenido, la nomenclatura, el ciclo de vida y la edición directa encajan en el proceso de crear contenido de esquemáticos reutilizable en el que su equipo pueda confiar. Siga leyendo para descubrir cómo las hojas gestionadas en el Workspace pueden ayudarle a reutilizar bloques de diseño probados con mayor confianza.

- Comprenda qué son las hojas de esquemático gestionadas, cómo facilitan la reutilización y por qué el almacenamiento en el Workspace aporta control de versiones, trazabilidad e integridad del contenido.
- Conozca las distintas formas de crear y guardar hojas de esquemático gestionadas, como la edición directa, el guardado de la hoja actual y la carga de un documento de esquemático en una revisión.
- Descubra cómo los detalles de configuración, como el tipo de carpeta, el tipo de contenido, los esquemas de nomenclatura y los ajustes del ciclo de vida, ayudan a organizar y gestionar el contenido de esquemáticos reutilizable.
Profundiza con IA:

La posibilidad de reutilizar contenido de diseño es algo que todas las empresas de desarrollo de productos desean y de lo que pueden beneficiarse enormemente. La reutilización no solo ahorra tiempo: poder reutilizar fácilmente una sección de un diseño anterior significa que toda la cualificación y las pruebas de esa parte del diseño ya están realizadas. Sin embargo, la reutilización del diseño es mucho más que copiar y pegar: para que sea una reutilización real, el contenido debe estar bloqueado, de modo que se garantice que es idéntico al anterior. Nada de ediciones rápidas para cambiar el color de un componente ni de pequeños ajustes en el valor de una resistencia; trabajar con contenido reutilizable debe ser como trabajar con componentes comerciales: se coloca el contenido, se conecta y funciona igual que la última vez.

Altium Designer, junto con un espacio de trabajo conectado, permite crear hojas de esquemático gestionadas (elementos de hoja de esquemático gestionada) en ese espacio de trabajo. Estas hojas se pueden crear:

  • Mediante edición directa.

  • Guardando la hoja de esquemático actual en el espacio de trabajo.

  • Cargando el documento de esquemático correspondiente (*.SchDoc) en una revisión de una hoja de esquemático gestionada de destino.

Una vez creada una hoja de esquemático gestionada (y guardados los datos en una revisión de ella), se puede reutilizar en futuros proyectos de diseño de placas.

¿Qué es exactamente una hoja de esquemático gestionada?

Una hoja de esquemático gestionada es una hoja de esquemático estándar de Altium Designer que contiene componentes y conexiones y que se ha almacenado en un espacio de trabajo para poder reutilizarla en otros diseños. Se edita como cualquier otra hoja de esquemático. El concepto de hoja de esquemático gestionada tampoco se limita a una sola hoja: puede colocar en su diseño una hoja de esquemático gestionada que sea la raíz de un árbol de otras hojas de esquemático gestionadas.

Las hojas de esquemático gestionadas se diferencian de las hojas de dispositivo en que se almacenan en un espacio de trabajo, mientras que las hojas de dispositivo se almacenan en una carpeta de un disco duro. Por tanto, las hojas gestionadas disfrutan de las ventajas del contenido del espacio de trabajo, como un almacenamiento simplificado, un control de versiones obligatorio y, por supuesto, una integridad garantizada.

► Consulte la información sobre las hojas de dispositivo gestionadas localmente.

La decisión de pasar de las hojas de dispositivo a las hojas de esquemático gestionadas surge cuando se desea realizar la transición del contenido reutilizable al contenido Workspace reutilizable; es decir, cuando se desea o se necesita poder controlar la publicación de ese contenido de diseño y proporcionar una fuente única de dicho contenido para todo el equipo.

Al convertirlo en contenido del espacio de trabajo, puede tener la certeza de que la revisión de una hoja de esquemático gestionada que utiliza en un diseño se podrá identificar fácilmente y rastrear hasta su origen siempre que sea necesario. Además, al tratarse de contenido del espacio de trabajo, se puede revisar y actualizar cuando sea necesario, y se pueden rastrear todas las relaciones de uso, tanto hacia los componentes de esa hoja como hacia los diseños que la utilizan. Esto garantiza que disponga de toda la información necesaria para decidir si esa hoja revisada debe incorporarse a los diseños existentes o si un diseño concreto debe seguir utilizando la revisión anterior.

Tipo de carpeta

Al crear la carpeta en la que se almacenarán las hojas de esquemático gestionadas, puede especificar su tipo. Esto no afecta al contenido de la carpeta: guardar una hoja de esquemático siempre dará lugar al correspondiente elemento de hoja de esquemático gestionada. Simplemente proporciona una «pista» visual sobre lo que se almacena en una carpeta y puede resultar útil al buscar contenido específico en un espacio de trabajo. Para indicar que una carpeta se utilizará como contenedor de hojas de esquemático gestionadas, establezca su Folder Type en Managed Schematic Sheets al definir las propiedades de la carpeta en el cuadro de diálogo Editar carpeta.

Especificar el tipo de carpeta, es decir, su uso previsto, proporciona una indicación visual del contenido de esa carpeta al explorar el espacio de trabajo.
Especificar el tipo de carpeta, es decir, su uso previsto, proporciona una indicación visual del contenido de esa carpeta al explorar el espacio de trabajo.

Tipo de contenido

Al crear un elemento de hoja de esquemático gestionada de destino en el que almacenar su hoja de esquemático, asegúrese de que su Content Type esté establecido en Managed Schematic Sheet en el cuadro de diálogo Crear nuevo elemento. Si está creando el elemento en una carpeta de tipo Managed Schematic Sheets, este tipo de contenido estará disponible en el menú contextual que aparece al hacer clic con el botón derecho al crear el elemento.

Creación de una hoja de esquemático gestionada dentro de una carpeta Managed Schematic Sheets: el Content Type correcto está disponible en el menú contextual.
Creación de una hoja de esquemático gestionada dentro de una carpeta Managed Schematic Sheets: el Content Type correcto está disponible en el menú contextual.

Guardar una hoja de esquema

Related page: Crear y editar contenido

Hasta ahora, hemos hablado de la compatibilidad del espacio de trabajo con las hojas de esquema gestionadas en lo que respecta a los tipos de carpetas y de contenido relacionados. Una hoja de esquema ya definida se puede guardar en una revisión de un elemento de hoja de esquema gestionada de varias maneras, como se describe en las siguientes secciones.

Para facilitar la reutilización de las hojas gestionadas en sus diseños, se recomienda encarecidamente anotar manualmente la hoja de esquema (Tools » Annotation » Annotate Schematics) antes de guardarla como hoja gestionada. Una vez completado un diseño que utilice hojas gestionadas, se pueden renumerar todas las hojas y los componentes del proyecto.

► Consulte la sección Anotar componentes y hojas más adelante para obtener más información.

Edición directa

Gracias a la función de edición directa del espacio de trabajo, es posible editar una hoja de esquema y guardarla en la revisión inicial de un elemento de hoja de esquema gestionada recién creado. La edición directa le libera de las limitaciones de mantener datos de origen independientes bajo control de versiones. Basta con editar un tipo de contenido compatible mediante un editor temporal que carga los datos de origen más recientes directamente desde el propio espacio de trabajo. Una vez finalizada la edición, la entidad se guarda (o se vuelve a guardar) en una revisión posterior planificada de su elemento principal y se cierra el editor temporal. No hay archivos en su disco duro, no tiene que preguntarse si está trabajando con los datos de origen correctos o más recientes, ni necesita mantener un software de control de versiones independiente. El espacio de trabajo se encarga de todo, con un alto grado de integridad y de una manera que agiliza considerablemente los cambios en sus datos.

Al crear un elemento de hoja de esquema gestionada, tiene la opción de editar y guardar una hoja de esquema en la revisión inicial de dicho elemento tras su creación. Para ello, active la opción Open for editing after creation, situada en la parte inferior del cuadro de diálogo Crear nuevo elemento (que está activada de forma predeterminada). Se creará el elemento y se abrirá el editor de esquemas temporal, que mostrará un documento .SchDoc como documento activo en la ventana principal de diseño. Este documento recibirá un nombre basado en el elemento y su revisión, con el formato: <Item><Revision>.SchDoc (p. ej., SCH-0007-1.SchDoc).

Si su espacio de trabajo tiene al menos una plantilla de esquema guardada, aparecerá el cuadro de diálogo Select configuration item (Schematic Templates). Utilícelo para elegir qué plantilla se aplicará al documento de esquema.

Ejemplo de edición de la revisión inicial de una hoja de esquema gestionada directamente desde el espacio de trabajo: el editor de esquemas temporal proporciona el documento en el que definir la hoja de esquema.
Ejemplo de edición de la revisión inicial de una hoja de esquema gestionada directamente desde el espacio de trabajo: el editor de esquemas temporal proporciona el documento en el que definir la hoja de esquema.

Utilice el documento para definir la hoja de esquema según sea necesario. Dado que las hojas de esquema gestionadas se almacenan en un espacio de trabajo, sus componentes también deben almacenarse en él. De este modo, podrá aprovechar todas las ventajas del sistema de contenido que ofrece el espacio de trabajo, incluida la posibilidad de identificar y localizar todos los componentes utilizados en la hoja de esquema gestionada (los elementos secundarios), así como identificar y localizar los diseños en los que se ha utilizado dicha hoja (dónde se utiliza). Para obtener más información, consulte Crear y mantener sus componentes y bibliotecas.

La posibilidad de utilizar componentes del espacio de trabajo para crear bloques de diseño de mayor tamaño permite agilizar cada vez más el flujo de diseño y trabajar con un mayor nivel de abstracción. Como quien elige piezas de una estantería, el diseñador reutiliza estas hojas de esquema gestionadas, que implementan determinadas funciones, como componentes de un proyecto de diseño más amplio. Cuantas más hojas de esquema gestionadas con estos circuitos se hayan creado y guardado en el espacio de trabajo, mayor será la funcionalidad a la que tendrá acceso el diseñador, lo que a su vez aumentará la productividad en los diseños posteriores.

Hay tres controles relevantes para la edición directa, disponibles en Quick Access Bar (en la parte superior izquierda de la ventana principal de la aplicación) o en la barra de herramientas Schematic Standard:

  • – Save Active Document. Utilice este botón para guardar localmente los cambios realizados en el documento. Esto permite guardar los cambios actuales si desea volver más adelante para realizar otros cambios antes de guardar definitivamente en el espacio de trabajo.
  • / – Save to Workspace. Utilice este botón para guardar la hoja de esquema definida en el espacio de trabajo, almacenándola en la revisión inicial (planificada) del elemento de hoja de esquema gestionada de destino. Aparecerá el cuadro de diálogo Editar revisión, en el que podrá cambiar el nombre y la descripción, así como añadir notas de publicación según sea necesario. El documento y el editor se cerrarán después de guardar. El documento que contiene la hoja de esquema de origen (*.SchDoc) se almacenará en la revisión del elemento.

    También se proporciona un control Save to Server a la derecha de la entrada de la hoja de esquema, dentro del propio panel Proyectos.
  • / – Discard Local Changes. Utilice este botón si desea cancelar la edición y descartar los cambios realizados. El documento y el editor se cerrarán y no se guardará nada en el elemento de hoja de esquema gestionada de destino.

Estos controles también están disponibles como comandos —Save (atajo: Ctrl+S), Save to Server (atajo: Ctrl+Alt+S) y Discard Local Changes— en el menú principal File y en el menú contextual de la entrada de la hoja de esquema en el panel Projects.

Los datos guardados en el espacio de trabajo incluyen la hoja de esquema de origen, definida en el archivo de documento de esquema (<Item><Revision>.SchDoc), así como los archivos de definición de arneses asociados (*.Harness). En el panel Explorador, cambie a la pestaña de vista Preview para ver una representación gráfica de la hoja, junto con una lista de los componentes que la integran (y la plantilla de hoja de esquema gestionada, si corresponde).

Haga clic en el hipervínculo de una revisión de elemento de componente secundario para localizarla en el panel Explorer. El área de elementos secundarios también ofrece un menú contextual con comandos para trabajar con una revisión de elemento de componente secundario.

Examine la revisión guardada de la hoja de esquema gestionada de nuevo en el panel Explorer. Cambie a la pestaña de vista Preview para ver una representación gráfica y una lista de las revisiones de los componentes secundarios.
Examine la revisión guardada de la hoja de esquema gestionada de nuevo en el panel Explorer. Cambie a la pestaña de vista Preview para ver una representación gráfica y una lista de las revisiones de los componentes secundarios.

Los componentes secundarios utilizados en la hoja también se pueden examinar desde la pestaña de vista Children. Haga doble clic en una entrada para localizarla o haga clic con el botón derecho para acceder a un conjunto de comandos relacionados con el componente.

Examine los componentes que integran la hoja de esquema gestionada a través de la vista Children.
Examine los componentes que integran la hoja de esquema gestionada a través de la vista Children.

Guardar una hoja existente en el espacio de trabajo

Aunque la edición directa es el método preferido para la mayoría del contenido de diseño que se puede almacenar en un espacio de trabajo, en el caso de las hojas de esquema existentes (o de las hojas de dispositivo), también puede guardar una hoja directamente en el espacio de trabajo. Para ello, es necesario disponer de una revisión planificada de un elemento de hoja de esquema gestionada existente, en la que se guardará la hoja. El proceso es el siguiente:

  1. Cree un nuevo elemento de hoja de esquema gestionada con su revisión inicial planificada, o disponga de una revisión planificada de otro elemento existente, según sea necesario.

  2. Abra la hoja de esquema o la hoja de dispositivo en Altium Designer.

  3. Seleccione el comando File » Save as Managed Sheet to Server en los menús principales.

  4. Aparecerá el cuadro de diálogo Choose Planned Item Revision. Utilícelo para seleccionar la revisión de destino del elemento de hoja de esquema gestionada requerido (que debe estar en el estado Planned) y, a continuación, haga clic en OK.

    Si el elemento de hoja de esquema gestionada de destino no existe, puede crearlo sobre la marcha mediante el cuadro de diálogo Choose Planned Item Revision. En ese caso, asegúrese de desactivar la opción Open for editing after creation (en el cuadro de diálogo Create New Item); de lo contrario, accederá al modo de edición directa.
  5. Aparecerá el cuadro de diálogo Editar revisión, en el que podrá cambiar el nombre y la descripción, así como añadir notas de publicación según sea necesario.

  6. Después de hacer clic en OK, la hoja se guardará y se almacenará en la revisión del elemento.

Ejemplo de envío de una hoja de dispositivo existente al espacio de trabajo al que está conectado actualmente. Debe guardarse en una revisión existente de una hoja de esquema gestionada, y esa revisión debe estar en el estado Planned.
Ejemplo de envío de una hoja de dispositivo existente al espacio de trabajo al que está conectado actualmente. Debe guardarse en una revisión existente de una hoja de esquema gestionada, y esa revisión debe estar en el estado Planned.

Buscar y colocar una hoja de esquema gestionada

El panel Design Reuse que se describe a continuación está en beta abierta y está disponible cuando la opción UI.ModernDesignReusePanel está activada en el cuadro de diálogo Configuración avanzada. Cuando esta opción está desactivada, se puede colocar una hoja de esquema gestionada desde el panel Explorador. Para ello, busque o explore hasta encontrar la hoja de esquema gestionada que desea colocar, haga clic con el botón derecho en la revisión específica que necesita (normalmente la más reciente, en cuyo caso basta con hacer clic con el botón derecho directamente en la entrada del elemento de nivel superior) y seleccione el comando Place.

Las hojas de esquema gestionadas almacenadas en el espacio de trabajo al que está conectado se pueden examinar y utilizar desde el panel Design Reuse cuando está configurado para mostrar los recursos del espacio de trabajo ().

Puede explorar las carpetas del espacio de trabajo para encontrar la hoja de esquema gestionada que necesita. Como alternativa, utilice el campo Search situado en la parte superior del panel Design Reuse para buscar una hoja de esquema gestionada por su nombre o descripción.

  • En el panel Design Reuse solo se muestra la revisión más reciente de cada hoja de esquema gestionada.

  • Si la última revisión de una hoja de esquema gestionada se encuentra en un estado del ciclo de vida que tiene desactivada la opción Visible in Vault panels (más información), dicha hoja de esquema gestionada no se mostrará en el panel de forma predeterminada. Para mostrar las hojas de esquema gestionadas que no están visibles actualmente, haga clic en el botón  de la esquina superior derecha del panel y, a continuación, active la opción Show Hidden Revisions en el menú asociado.

Haga clic en el control Details de la parte inferior del panel para expandir el subpanel Details, que muestra los detalles de las hojas de esquema gestionadas seleccionadas, entre ellos:

  • Nombre de la hoja de esquema gestionada.

  • El icono del estado del ciclo de vida y la revisión (haga clic en el enlace para abrir la vista detallada del historial del elemento de hoja de esquema gestionada con la última revisión seleccionada).

  • Descripción de la hoja de esquema gestionada.

  • Información general de la hoja de esquema gestionada.

Mediante el acceso controlado al contenido del espacio de trabajo, junto con un esquema de ciclo de vida adecuado, el personal autorizado (responsables de bibliotecas, responsables superiores de diseño) puede aprobar y poner a disposición únicamente las hojas de esquema gestionadas que deban utilizarse en los diseños. Esto permite al diseñador trabajar con la tranquilidad de estar utilizando únicamente hojas de circuitos de diseño reutilizables cuyo uso está autorizado.

Prior to Placement

Hay un par de aspectos que deben tenerse en cuenta antes de colocar una hoja de esquema gestionada en un diseño:

  • El símbolo de hoja de una hoja de esquema gestionada no puede colocarse en un esquema independiente; la hoja de destino debe formar parte de un proyecto.

  • Asegúrese de que la hoja de esquema que va a recibir el símbolo de hoja asociado esté abierta en Altium Designer y sea el documento activo. Si hay documentos abiertos en varias ventanas, asegúrese también de que la ventana que contiene el documento de esquema activo tenga el foco.

Para colocar una hoja de esquema gestionada en un diseño, sitúe el cursor sobre su entrada en el panel Design Reuse, haga clic en el botón  (o haga clic con el botón derecho en la entrada) y seleccione el comando Place del menú. Un símbolo de hoja que hace referencia a la hoja quedará unido al cursor; haga clic en el lugar deseado de la hoja de esquema para colocarlo.

Al colocar el símbolo de hoja, Altium Designer copia la hoja gestionada que representa el símbolo desde el espacio de trabajo a la carpeta del proyecto, dentro de una subcarpeta denominada \Managed\Sheets. Aquí se almacena una copia de cada hoja gestionada, cada una en su propia subcarpeta identificada por un identificador único generado por el sistema (GUID).

La subcarpeta cuyo nombre es el GUID, en la que se descarga y almacena la instancia de la hoja de esquema gestionada, no debe editarse ni cambiarse de nombre de ninguna manera.

Anotación de los componentes y las hojas

Para garantizar la integridad de los circuitos utilizados en una hoja de esquema gestionada, dicha hoja no puede editarse durante el uso normal del diseño. Esto significa que el número de hoja y las asignaciones de designadores no pueden modificarse en la hoja. Entonces, ¿cómo se numeran todas las hojas del proyecto y se anotan todos los componentes?

Estas tareas se gestionan mediante dos comandos: las hojas se numeran mediante el comando Tools » Annotation » Annotate Compiled Sheets y los componentes se anotan mediante el comando Tools » Annotation » Board Level Annotate. El número de hoja y las asignaciones de designadores se almacenan en un archivo independiente, <ProjectName>*.annotation. 

Las herramientas de anotación de componentes necesitan conocer el orden en el que deben procesarse las hojas de esquema. Por este motivo, es mejor numerar las hojas antes de numerar los componentes.

Los principios de anotación de componentes y hojas son los mismos que cuando se utilizan hojas de dispositivo locales. Para obtener más información sobre la anotación de diseños que incluyen hojas de esquema gestionadas, consulte las siguientes secciones de la página Hojas de dispositivo:

Edición de una hoja de esquema gestionada

Para editar una hoja de esquema gestionada, sitúe el cursor sobre su entrada en el panel Design Reuse y haga clic en el botón  (o haga clic con el botón derecho en la entrada) y seleccione el comando Edit del menú. Se abrirá el editor temporal, con la hoja de esquema contenida en la última revisión del elemento de hoja de esquema gestionada abierta para su edición. Realice los cambios necesarios y, a continuación, guarde el documento en la siguiente revisión del elemento (File » Save to Server).​​​

Si necesita cambiar la hoja de esquema almacenada en un elemento de hoja de esquema gestionada y dispone de la hoja actualizada, puede cargarla en ese elemento mediante el panel Explorer; la nueva hoja se almacenará en la siguiente revisión de dicho elemento. Para obtener más información, consulte la página Creación y edición de contenido.

Otras acciones para las hojas de esquema gestionadas

El menú del botón  (y el menú contextual) de una entrada de hoja de esquema gestionada en el panel Design Reuse también proporciona acceso a los siguientes comandos:

  • Move – utilícelo para cambiar la ubicación del elemento de hoja de esquema gestionada en la estructura de carpetas del espacio de trabajo. Al ejecutar el comando se abrirá el cuadro de diálogo Move Item, en el que podrá seleccionar la carpeta de destino en la que debe colocarse el elemento. 

  • Share – utilícelo para definir los permisos de uso compartido de la hoja de esquema gestionada. Tras seleccionar el comando, se abrirá el cuadro de diálogo Share For Item, en el que podrá configurar el uso compartido según sea necesario. Obtenga más información sobre el uso compartido a nivel de elemento.

  • Operations – utilícelo para acceder a un menú desplegable con funciones adicionales para las hojas de esquema gestionadas, tal como se describe a continuación.

    • Make a Copy – utilícelo para copiar la hoja de esquema gestionada. Se abrirá un editor temporal de la hoja de esquema gestionada con el mismo contenido que la hoja original. Realice los cambios necesarios y guarde la hoja de esquema gestionada en el espacio de trabajo. 

    • Change Revision State – utilícelo para cambiar el estado de revisión de la última revisión de la hoja de esquema gestionada. Tras seleccionar el comando, se abrirá el cuadro de diálogo de cambio de estado por lotes, que permite cambiar el estado de revisión de la hoja de esquema gestionada.

    • Download – utilícelo para descargar los datos almacenados en la hoja de esquema gestionada. Los datos asociados se descargarán en una subcarpeta del directorio elegido, cuyo nombre será el ID de revisión del elemento de hoja de esquema gestionada. El archivo se encuentra en las carpetas Released que contiene.

  • Delete – utilícelo para eliminar la hoja de esquema gestionada del espacio de trabajo al que está conectado. Tras seleccionar el comando, aparecerá el cuadro de diálogo Delete Items, en el que podrá confirmar la eliminación. 

    En realidad, se trata de una «eliminación lógica», mediante la cual la hoja de esquema gestionada se trasladará al área Trash del espacio de trabajo. Obtenga más información sobre la eliminación lógica.

  • History – utilícelo para acceder a una vista detallada de la hoja de esquema gestionada, que se abrirá como una nueva pestaña en Altium Designer.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents