Trabajar con bloques de reutilización

De un vistazo

Este artículo explica cómo utilizar el panel Design Reuse de Altium Designer para crear, gestionar, buscar, colocar, editar y organizar bloques de reutilización formales almacenados en un Workspace conectado. Describe cómo estos bloques pueden incluir tanto datos de esquemáticos como de PCB y cómo se transfieren esos elementos de PCB a una placa mediante el proceso ECO. También repasa las principales acciones del panel, como explorar los recursos del Workspace, consultar detalles, seleccionar opciones de colocación, guardar revisiones y realizar tareas de gestión como cambiar el nombre, mover, compartir, descargar y eliminar. Si buscas una forma más clara y eficiente de reutilizar secciones de diseño probadas en distintos proyectos, sigue leyendo: este artículo te mostrará por dónde empezar y cómo trabajar con confianza con las herramientas disponibles.

- Aprende cómo se crean los bloques de reutilización formales, se guardan en un Workspace y se reutilizan en diseños de esquemáticos y PCB mediante el panel Design Reuse.
- Descubre cómo buscar, examinar y colocar bloques de reutilización, con opciones de colocación directa, colocación mediante símbolos de hoja y gestión de varios documentos de PCB.
- Conoce las principales acciones de gestión disponibles para los bloques de reutilización, como la edición, la actualización de revisiones, el uso compartido, el traslado, la descarga y la eliminación lógica.
Profundiza con IA:

El Design Reuse panel que se utiliza para gestionar bloques de reutilización y que se describe en esta página está en beta abierta y está disponible cuando la opción UI.ModernDesignReusePanel está habilitada en el cuadro de diálogo Configuración avanzada. Cuando esta opción está deshabilitada, se utiliza la versión anterior del panel descrita en la página Trabajar con bloques de reutilización y fragmentos.

Si sus diseños suelen incluir «secciones» comunes de circuitos de esquemático y PCB, Altium Designer ofrece formas sencillas y fáciles de guardar y reutilizar estas secciones, lo que elimina la necesidad de crearlas desde cero cada vez.

Cuando está conectado a un espacio de trabajo, puede crear un reuse block que puede contener tanto los circuitos del esquemático como su representación física para la PCB. Cuando se coloca uno de estos bloques de reutilización en una hoja de esquemático, su representación física se coloca automáticamente en el documento de PCB durante el proceso de ECO.

El panel Design Reuse le permite acceder rápidamente a todos los controles necesarios para trabajar con sus bloques de reutilización y gestionarlos.

  • El panel también permite acceder a sus hojas de esquemático gestionadas y fragmentos.

  • Además de los métodos habituales para acceder a un panel (el menú del botón  y el submenú View » Panels de los menús principales), se puede acceder al panel Design Reuse seleccionando el comando Place » Reuse Block en los menús principales del editor de esquemáticos o de PCB.

Para trabajar con bloques de reutilización a través del panel Design Reuse, asegúrese de que el panel esté configurado para explorar los recursos del espacio de trabajo. Para ello, haga clic en el icono situado más a la izquierda de la barra de direcciones, en la parte superior del panel, y seleccione la entrada del espacio de trabajo al que está conectado. El icono se mostrará como .

Crear un bloque de reutilización

Se puede crear un nuevo bloque de reutilización como se describe a continuación.

  1. Haga clic en el  botón situado en la parte superior derecha del panel Design Reuse. También puede seleccionar el comando File » New » Reuse Block en los menús principales.

  2. Se abrirá una estructura temporal editable del bloque de reutilización, similar a la de un proyecto de PCB, en el panel Projects (bajo una entrada del espacio de trabajo conectado), y se abrirá el editor temporal de esquemáticos, listo para definir el documento de esquemático del bloque de reutilización. Utilice los comandos y las técnicas de colocación habituales para definir el documento de esquemático del bloque de reutilización.

    Si desea crear un bloque de reutilización que contenga solo un esquemático o solo una PCB, puede eliminar el documento de PCB o de esquemático de la estructura del fragmento haciendo clic con el botón derecho en el documento de PCB o de esquemático, respectivamente, en el panel Projects y seleccionando el comando Remove from Project.

  3. Utilice el comando Design » Update PCB Document y el proceso de ECO para transferir el esquemático capturado al documento de PCB del bloque de reutilización y, a continuación, aplique los cambios necesarios a ese documento (definición de las ubicaciones de los componentes, enrutado, etc.).

    Se pueden añadir varios documentos de PCB al bloque de reutilización que se está definiendo. Para ello, utilice el comando Add New to Project » PCB del menú contextual de la entrada del bloque de reutilización en el panel Projects.

    Utilice el comando Rename del menú contextual de la entrada del documento de PCB añadido en el panel Projects para asignarle un nombre significativo. Utilice un comando Design » Update del menú principal del editor de esquemáticos para actualizar el documento de PCB correspondiente.

  4. Una vez definidos los documentos de esquemático y de PCB del bloque de reutilización, guarde el bloque en el espacio de trabajo mediante el comando Save to Server del menú contextual de la entrada del bloque de reutilización en el panel Projects o el control Save to Server situado a la derecha de la entrada.

    Dado que los bloques de reutilización se almacenan en el espacio de trabajo conectado, se recomienda utilizar componentes de ese espacio de trabajo en el bloque de reutilización. De este modo, aprovechará al máximo el sistema de contenido que ofrece el espacio de trabajo.

    • Tanto el documento de esquemático como el de PCB del bloque de reutilización deben contener al menos un componente para poder guardarse en el espacio de trabajo.

    • Si los documentos de esquemático y de PCB del bloque de reutilización no están sincronizados (se detectan diferencias entre ellos), aparecerá un cuadro de diálogo de advertencia cuando intente guardar el bloque de reutilización en el espacio de trabajo. Puede cancelar la operación de guardado para volver al bloque de reutilización y resolver las diferencias, o continuar con el guardado.

  5. Aparecerá el cuadro de diálogo Create New Reuse Block, en el que puede definir Name, Description y la Folder del espacio de trabajo en la que se guardará el nuevo bloque de reutilización.

  6. Después de hacer clic en OK en el cuadro de diálogo Create New Reuse Block, el bloque de reutilización se guardará en el espacio de trabajo y se cerrará su estructura temporal.

Buscar y colocar un bloque de reutilización

Los bloques de reutilización almacenados en el espacio de trabajo conectado se pueden explorar y utilizar desde el panel Design Reuse cuando está configurado para mostrar los recursos del espacio de trabajo (). En este modo, el panel presenta la estructura de carpetas del espacio de trabajo para que pueda explorar las carpetas donde se almacenan sus bloques de reutilización. Cada carpeta y cada bloque de reutilización se muestran en la lista de la parte superior del panel con su nombre y descripción.

Para encontrar el bloque de reutilización que necesita, puede navegar por las carpetas o utilizar el campo Search situado en la parte superior del panel Design Reuse para buscar un bloque de reutilización por su nombre o descripción ().

  • En el panel Design Reuse solo se muestra la revisión más reciente de cada bloque de reutilización.

  • Si la revisión más reciente de un bloque de reutilización se encuentra en un estado del ciclo de vida cuya opción Visible in Vault panels está deshabilitada (más información), ese bloque de reutilización no se mostrará en el panel de forma predeterminada. Para mostrar los bloques de reutilización que no están visibles actualmente, haga clic en el botón  situado en la parte superior derecha del panel y, a continuación, habilite la opción Show Hidden Revisions en el menú correspondiente.

Haga clic en el control Details situado en la parte inferior del panel para expandir el panel Details, que muestra los detalles del bloque de reutilización seleccionado, incluidos:

  • Nombre del bloque de reutilización.

  • Icono del estado del ciclo de vida y revisión (haga clic en el enlace para abrir la vista detallada del historial del elemento de bloque de reutilización con la revisión más reciente seleccionada).

  • Descripción del bloque de reutilización.

  • Información general del bloque de reutilización y sus parámetros.

  • Imágenes de vista previa de los documentos de esquemático y de PCB del bloque de reutilización.

  • Lista de proyectos () y versiones publicadas de proyectos () en los que se utiliza el bloque de reutilización (la región Where Used).

Mediante el acceso controlado al contenido del espacio de trabajo, junto con un esquema de ciclo de vida adecuado, el personal autorizado (responsables de bibliotecas y de la gestión del diseño) puede aprobar y poner a disposición únicamente los bloques reutilizables que deban utilizarse en los diseños. Esto permite al diseñador trabajar con la tranquilidad de estar utilizando solo bloques reutilizables autorizados.

Para colocar un bloque reutilizable en un diseño, sitúe el cursor sobre su entrada en el panel Design Reuse, haga clic en el botón  (o haga clic con el botón derecho en la entrada) y seleccione uno de los siguientes comandos del menú:

  • Place – seleccione esta opción para colocar el bloque reutilizable directamente en el documento de esquemático o de PCB activo. Según el tipo de documento que esté activo al ejecutar el comando, se colocará el documento de esquemático o de PCB del bloque reutilizable.

     
  • Place as Sheet Symbol – cuando haya un documento de esquemático activo, seleccione esta opción para colocar el bloque reutilizable como símbolo de hoja en la hoja de esquemático. El símbolo de hoja colocado incluirá entradas de hoja correspondientes a los puertos del bloque reutilizable. El contenido del bloque reutilizable se colocará en una hoja de esquemático secundaria creada automáticamente y referenciada por el símbolo de hoja. El símbolo de hoja de un bloque reutilizable colocado tendrá un icono distintivo.

Si el bloque reutilizable incluye más de un documento de PCB, seleccione el documento de PCB que necesite haciendo clic en su pestaña debajo de la imagen de vista previa del documento de PCB, en la región Preview del panel Details, antes de colocar el bloque reutilizable (). Cuando el bloque reutilizable se coloque en el esquemático, el documento de PCB seleccionado se asociará al bloque reutilizable y se colocará en la PCB cuando esta se actualice mediante el proceso ECO.

Tras colocar el documento de esquemático de un bloque reutilizable, su documento de PCB se puede colocar en el documento de PCB mediante el proceso ECO. Desde el editor de esquemáticos, utilice el comando Design » Update PCB Document de los menús principales y, a continuación, valide y ejecute los cambios mediante el cuadro de diálogo Engineering Change Order.

Edición de un bloque reutilizable

Para editar un bloque reutilizable, sitúe el cursor sobre su entrada en el panel Design Reuse y haga clic en el botón  (o haga clic con el botón derecho en la entrada) y seleccione el comando Edit del menú.

Se abrirá para su edición la estructura de proyecto temporal del bloque reutilizable que contiene la revisión más reciente del elemento de bloque reutilizable. Realice los cambios necesarios y, a continuación, guarde el bloque reutilizable en su siguiente revisión (File » Save to Server).

Otras acciones de los bloques reutilizables

El menú del botón  (y el menú contextual) de una entrada de bloque reutilizable en el panel Design Reuse también permite acceder a los siguientes comandos:

  • Rename – utilícelo para cambiar el nombre del bloque reutilizable. Tras seleccionar el comando, introduzca el nuevo nombre que desee en el cuadro de diálogo Rename Reuse Block que aparece y, a continuación, haga clic en OK.

  • Move – utilícelo para cambiar la ubicación del elemento de bloque reutilizable en la estructura de carpetas del espacio de trabajo. Al ejecutar el comando, se abrirá el cuadro de diálogo Move Item , en el que podrá seleccionar la carpeta de destino donde se colocará el elemento.

  • Share – utilícelo para definir los permisos de uso compartido del bloque reutilizable. Tras seleccionar el comando, se abrirá el cuadro de diálogo Share For Item, en el que podrá configurar el uso compartido según sus necesidades. Obtenga más información sobre el uso compartido a nivel de elemento.

  • Operations – utilícelo para acceder a un menú desplegable con funciones adicionales para los bloques reutilizables, tal como se describe a continuación.

    • Make a Copy – utilícelo para copiar el bloque reutilizable. Se abrirá una estructura de proyecto temporal del bloque reutilizable, con el mismo contenido que el bloque reutilizable original. Realice los cambios necesarios y guarde el bloque reutilizable en el espacio de trabajo. 

    • Change Revision State – utilícelo para cambiar el estado de revisión de la revisión más reciente del bloque reutilizable. Tras seleccionar el comando, se abre el cuadro de diálogo de cambio de estado por lotes, que permite cambiar el estado de revisión del bloque reutilizable.

    • Download – utilícelo para descargar los datos almacenados en el bloque reutilizable (sus documentos de esquemático y/o de PCB). Los datos asociados se descargarán en una subcarpeta del directorio elegido, cuyo nombre se basará en el ID de revisión del elemento de bloque reutilizable. Los archivos se encuentran en las carpetas Released de dicha subcarpeta.

  • Delete – utilícelo para eliminar el bloque reutilizable del espacio de trabajo al que está conectado. Tras seleccionar el comando, aparecerá el cuadro de diálogo Delete Items , en el que podrá confirmar la eliminación. También puede optar por eliminar el contenido relacionado con el bloque reutilizable (es decir, los fragmentos de esquemático y de PCB).

    La acción es, en realidad, una «eliminación lógica», por la que el bloque reutilizable se trasladará al área Trash del espacio de trabajo. Obtenga más información sobre la eliminación lógica.

  • History – utilícelo para acceder a una vista detallada del bloque reutilizable, que se abre como una nueva pestaña dentro de Altium Designer.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents