Diseños jerárquicos y de múltiples hojas

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

De un vistazo

Este artículo explica por qué organizar un esquema en varias hojas puede facilitar la creación, lectura, colaboración e impresión de un diseño, incluso cuando el circuito no es muy complejo. Presenta las dos decisiones clave de un diseño de varias hojas: la relación estructural entre las hojas y cómo se gestiona la conectividad. A continuación, se centra en el aspecto estructural y compara los enfoques plano y jerárquico en Altium Designer. También descubrirás en qué casos resulta más útil cada enfoque, qué ventajas y limitaciones presenta y cómo encajan los símbolos de hoja en la organización de un esquema de varias hojas. Esta guía práctica te ayudará a elegir la estructura adecuada antes de empezar a diseñar. Sigue leyendo para sentar unas bases más claras para tu próximo esquema.

- Comprende la diferencia entre los diseños de varias hojas planos y jerárquicos, y cuándo puede ser más adecuado cada enfoque.
- Descubre por qué la organización en varias hojas puede mejorar la legibilidad, el trabajo en equipo, la modularidad y la facilidad de impresión.
- Aprende cómo se utilizan los símbolos de hoja para representar hojas secundarias y estructurar los esquemas en Altium Designer.
Profundiza con IA:

Cuando los esquemas se dibujaban originalmente en papel, solían ocupar una única hoja lo suficientemente grande como para cubrir una mesa de dibujo de gran tamaño, que se reproducía en una copiadora específica de gran formato. Los tiempos han cambiado: ahora los esquemas se crean en un PC de escritorio, se almacenan en un servidor y se imprimen en una impresora láser de pequeño formato.

Este cambio significa que incluso un diseño sencillo puede visualizarse y comprenderse más fácilmente si se presenta en varias hojas de esquema. Incluso cuando el diseño no es especialmente complicado, organizarlo en varias hojas puede ofrecer ventajas.

Por ejemplo, el diseño puede incluir diversos elementos modulares. Mantener estos módulos como documentos individuales permite que varios diseñadores trabajen en un proyecto al mismo tiempo. Dividir el diseño en módulos lógicos también mejora considerablemente su legibilidad, un aspecto importante para quienes necesiten leer e interpretar el esquema en etapas posteriores de la vida útil del producto. Otra ventaja es que, cuando un diseño se estructura en varias hojas con menos componentes en cada una, se pueden utilizar impresoras de pequeño formato, como las impresoras láser.

Si tiene previsto distribuir su diseño en varias hojas, debe tomar dos decisiones:

  • la relación estructural entre las hojas y

  • el método empleado para establecer la conectividad eléctrica entre los circuitos de esas hojas.

Su elección variará según el tamaño y el tipo de cada proyecto, así como sus preferencias personales.

Este artículo se centra en las relaciones estructurales entre las hojas, cómo funcionan y las herramientas y técnicas disponibles para crear un diseño de varias hojas. Para obtener más información sobre cómo se establece la conectividad, consulte el artículo Creación de conectividad.

Diseño plano o jerárquico

Como se ha mencionado, como diseñador debe decidir cómo se organizan las hojas de esquema y cómo se establece la conectividad entre ellas. Sin embargo, no son decisiones independientes: al elegir la estructura, también deberá elegir cómo se crearán las conexiones entre esas hojas.

Existen dos enfoques para estructurar un diseño de varias hojas: flat o hierarchical.

Ambos enfoques son válidos; cada uno tiene sus propias ventajas e inconvenientes. Un diseño plano será más rápido de crear, pero a otras personas les resultará más difícil seguir las señales e interpretar su funcionamiento, especialmente a partir de una copia impresa. Un diseño jerárquico llevará más tiempo de dibujar, ya que requiere más pasos para establecer la conectividad, pero a cambio permitirá que otras personas interpreten más fácilmente su funcionamiento y sigan las señales entre las hojas. El diseño jerárquico también es importante para la reutilización de diseños y constituye una parte esencial de un diseño multicanal.

La técnica utilizada para conectar una hoja secundaria a la hoja principal es la misma tanto en los diseños planos como en los jerárquicos: lo que determina si un diseño es plano o jerárquico es cómo se establece la conectividad.

Diseño plano

Puede imaginar un diseño plano como una hoja de esquema grande que se ha dividido en varias hojas más pequeñas: en un diseño plano, todas las hojas se encuentran en el mismo nivel. La conectividad en un diseño plano se establece directamente desde cualquier hoja a cualquier otra; este tipo de conectividad se denomina conectividad horizontal.

El uso de una hoja superior es opcional en un diseño plano. Si se incluye una, tendrá un símbolo de hoja para cada una de las hojas del diseño, pero no podrá incluir ningún cableado. Un diseño plano puede contener cualquier número de hojas.

Primera imagen: el diseño plano no tiene hoja superior; segunda imagen: el mismo diseño tiene una hoja superior. Observe que la hoja superior no tiene cableado. Simplemente muestra las hojas del diseño. 
Primera imagen: el diseño plano no tiene hoja superior; segunda imagen: el mismo diseño tiene una hoja superior. Observe que la hoja superior no tiene cableado. Simplemente muestra las hojas del diseño.

Las dos imágenes anteriores muestran un diseño plano: la versión de la izquierda no tiene hoja superior, mientras que la de la derecha sí. En un diseño pequeño que solo tenga dos o tres hojas de esquema, puede considerar que una hoja superior no aporta ningún valor. Cuando aumenta el número de hojas, una hoja superior puede ayudar al lector a comprender el funcionamiento del diseño del circuito a partir de la disposición de los bloques lógicos (símbolos de hoja). Todas las hojas del diseño aparecen en el mismo nivel en el panel Projects porque no existe ninguna jerarquía.

Diseño jerárquico

Es importante recordar que, en los diseños jerárquicos, un proyecto solo puede contener una hoja de nivel superior. Todos los demás documentos fuente deben estar referenciados mediante símbolos de hoja. Al validar el diseño, se puede utilizar la comprobación de infracción Varios documentos de nivel superior para señalar si no se cumple esta condición. Además, ningún símbolo de hoja puede hacer referencia a la hoja en la que se encuentra ni a ninguna hoja situada en un nivel superior, ya que esto crearía un bucle irresoluble en la estructura.

Un diseño jerárquico es aquel en el que se representa la estructura de árbol —o las relaciones entre hojas— del diseño. Esto se hace mediante símbolos de hoja, que representan las hojas de niveles inferiores en la jerarquía del diseño. El símbolo representa la hoja del nivel inferior, y las entradas de hoja que contiene representan los puertos de esa hoja (o se conectan a ellos). La conectividad se establece a través de las entradas de hoja de esos símbolos de hoja, no directamente de los puertos de una hoja a los puertos de otra.

Al igual que en un diseño plano, la hoja hija se identifica definiendo su nombre de archivo en el símbolo de hoja. En un diseño jerárquico, esa hoja hija también puede incluir símbolos de hoja que hagan referencia a hojas de niveles inferiores, lo que crea otro nivel en la jerarquía. La imagen siguiente muestra un diseño jerárquico con 3 niveles.

En un diseño jerárquico, la estructura que se muestra en el árbol viene determinada por las relaciones entre hojas padre e hijas creadas por los símbolos de hoja.
En un diseño jerárquico, la estructura que se muestra en el árbol viene determinada por las relaciones entre hojas padre e hijas creadas por los símbolos de hoja.

En un diseño jerárquico, una señal de una hoja secundaria sale de ella a través de un puerto, que se conecta hacia arriba con una entrada de hoja coincidente en la hoja principal. La hoja principal incluye conexiones que llevan la señal de la hoja secundaria hasta una entrada de hoja de otro símbolo de hoja; a continuación, la señal desciende hasta un puerto coincidente en la segunda hoja secundaria, como se muestra en la imagen siguiente.

The connectivity is from a Port on the child sheet up to a matching Sheet Entry in the Sheet Symbol on the parent sheet

Esta estructura de hojas principales y secundarias se puede definir con cualquier nivel de profundidad, y un diseño jerárquico puede contener cualquier número de hojas.

La conectividad entre las hojas está determinada por Net Identifier Scope. Esto se configura en la pestaña Options del cuadro de diálogo Options for Project. Para obtener más información sobre cómo crear conectividad, consulte la página Creación de conectividad. Tenga en cuenta que el alcance de los identificadores de red incluye una opción automática; a menos que tenga requisitos de conectividad poco habituales, esta opción es una buena elección.

La ventaja del diseño jerárquico es que muestra al lector la estructura del diseño y que la conectividad es totalmente predecible y fácil de seguir, ya que siempre va desde la hoja secundaria hacia arriba hasta el símbolo de hoja en la hoja principal.

Otra ventaja de un diseño jerárquico es que proporciona la base para implementar un sofisticado sistema de reutilización de diseños. Este sistema se ofrece de dos formas, según cómo se almacenen los datos: basado en archivos o basado en servidor.

  • El sistema basado en archivos se denomina Hojas de dispositivo y permite colocar un esquema existente de una biblioteca de hojas de dispositivo directamente en el diseño que se está creando. Para obtener más información sobre las hojas de dispositivo, consulte la página Trabajo con hojas de dispositivo.

  • El sistema basado en el espacio de trabajo se denomina Hojas de esquemático gestionadas y permite colocar un esquema existente de un espacio de trabajo conectado directamente en el diseño que se está creando. Para obtener más información sobre las hojas gestionadas, consulte la página Trabajo con hojas de esquemático gestionadas.

Adición de referencias cruzadas

Añadir referencias cruzadas al proyecto permite seguir fácilmente el recorrido de las conexiones de las redes entre las hojas de esquema de un proyecto. El editor de esquemas permite crear y actualizar automáticamente las referencias cruzadas.

Habilite la opción Automatic Cross References en la sección General y configure las opciones de la sección Cross References de la pestaña Opciones del cuadro de diálogo Opciones del proyecto. Puede definir un estilo específico de referencias cruzadas para el proyecto activo o habilitar la opción Follow Cross References settings in Preferences para heredar las opciones de la sección Port Cross References de la página Esquema – General del cuadro de diálogo Preferences. Desde aquí, también puede seleccionar los objetos (puertos, conectores entre hojas y entradas de hoja) para los que se mostrarán las referencias cruzadas.

Puede acceder rápidamente a la pestaña Options del cuadro de diálogo Project Options seleccionando el comando Reports » Automatic Cross References Settings en los menús principales o haciendo clic con el botón derecho en el espacio de diseño y seleccionando el comando Sheet Actions » Automatic Cross References Settings en el menú contextual.

Configure las referencias cruzadas automáticas del proyecto activo en la pestaña Options del cuadro de diálogo Project Options.
Configure las referencias cruzadas automáticas del proyecto activo en la pestaña Options del cuadro de diálogo Project Options.

Las referencias cruzadas se mostrarán en los esquemas junto a los objetos elegidos y con el estilo configurado. Los valores de referencia cruzada también se muestran en el panel Properties, desde donde puede activar o desactivar la visibilidad de las referencias cruzadas de los objetos seleccionados.

Las referencias cruzadas pueden consultarse en los esquemas y, para el objeto seleccionado, en el panel Properties. Aquí se muestra un ejemplo de referencias cruzadas para un puerto.
Las referencias cruzadas pueden consultarse en los esquemas y, para el objeto seleccionado, en el panel Properties. Aquí se muestra un ejemplo de referencias cruzadas para un puerto.

Las referencias cruzadas también se admiten en los archivos PDF de los esquemas. Si un objeto está relacionado con más de un objeto conectado (p. ej., un puerto está conectado a una entrada de hoja en las hojas de esquema superiores y a puertos en otras hojas), al hacer clic en el objeto en el PDF se mostrará la lista de hojas donde se encuentran los objetos conectados. Seleccione un elemento de la lista para abrir la página correspondiente. Si un objeto está relacionado con un único objeto conectado, al hacer clic en él se abrirá directamente la página correspondiente.

En el PDF del esquema, se puede navegar fácilmente entre varios objetos conectados mediante el menú emergente.
En el PDF del esquema, se puede navegar fácilmente entre varios objetos conectados mediante el menú emergente.

Creación de un diseño de varias hojas

En cuanto añade una segunda hoja de esquema a su proyecto, ya ha creado un diseño de varias hojas. Si tiene previsto crear un diseño plano sin una hoja superior, simplemente siga añadiendo hojas de esquema al proyecto (haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando Add New to Project » Schematic en el menú contextual) y, a continuación, confirme que el alcance de los identificadores de red esté configurado correctamente.

Si desea utilizar símbolos de hoja para hacer referencia a hojas de nivel inferior, puede colocar el símbolo de hoja y editarlo manualmente para que haga referencia correctamente a la hoja de nivel inferior, o bien utilizar los distintos comandos integrados para facilitar la tarea, como se describe a continuación.

Referencia a la hoja secundaria

Es la propiedad Filename del símbolo de hoja la que hace referencia a la hoja de nivel inferior. Tenga en cuenta que este campo solo debe incluir el nombre del archivo de esquema, no la ruta a su ubicación (estos datos de ubicación se almacenan en el archivo del proyecto).

La propiedad Filename vincula este símbolo de hoja con la hoja de esquema secundaria.
La propiedad Filename vincula este símbolo de hoja con la hoja de esquema secundaria.

Tenga en cuenta que el esquema secundario no tiene que almacenarse en la misma carpeta que el esquema principal. Si el archivo se almacena en una subcarpeta de la carpeta del esquema principal, se utiliza una referencia relativa al archivo. Si el archivo se almacena en otra ubicación, se utiliza una referencia absoluta. Tenga cuidado al cambiar la ubicación de los archivos de un proyecto de este tipo, o utilice Project Packager para comprimir los archivos en un ZIP, ya que esta herramienta resuelve las rutas de los archivos al comprimir el proyecto.

Navegación por un diseño de varias hojas

El editor de esquemas proporciona herramientas que permiten navegar rápidamente entre los documentos de un diseño de varias hojas y los objetos relacionados que contienen.

El comando Tools » Up/Down Hierarchy se utiliza para pasar del documento actual al nivel inmediatamente superior o inferior de la jerarquía de diseño. Tras ejecutar el comando, el cursor cambiará a una cruz y se le pedirá que elija un punto de navegación. Si hace clic en una entrada de hoja, se mostrará el puerto correspondiente en la hoja secundaria; si hace clic en un símbolo de hoja, se mostrará toda la hoja secundaria. Para subir por la jerarquía, haga clic en un puerto para mostrar la entrada de hoja correspondiente en la hoja principal.

Si una entrada de hoja o un puerto están conectados a un bus, el primer clic abrirá un menú desde el que podrá seleccionar todo el bus o una señal individual del bus. Se resaltará el cableado correspondiente de la entrada de hoja o del puerto. Al hacer clic por segunda vez en la entrada de hoja o el puerto originales, se mostrará el puerto correspondiente en la hoja de esquema inferior o la entrada de hoja en la hoja superior, respectivamente.

Para abrir la hoja secundaria a la que hace referencia el símbolo de hoja situado bajo el cursor, haga clic con el botón derecho sobre un símbolo de hoja colocado y elija el comando Sheet Symbol Actions » Open SubSheet <SchematicDocumentName> en el menú contextual. Tras ejecutar el comando, se abrirá el documento de esquema al que hace referencia el símbolo (si aún no está abierto) y se convertirá en el documento activo de la ventana principal de diseño.

Cuando las referencias cruzadas automáticas están habilitadas para los objetos asociados, también puede utilizar los comandos Jump To de los submenús Port Actions, Sheet Entry Actions y Off Sheet Actions (para un diseño plano) del menú contextual de los objetos para navegar entre puertos, entradas de hoja y conectores fuera de hoja. Por ejemplo, cuando la opción Automatic Cross References está habilitada y se selecciona el ajuste Sheet Entry & Ports para la opción Ports en la pestaña Options del cuadro de diálogo Options for Project, puede hacer clic con el botón derecho sobre un puerto y elegir el comando Port Actions » Jump to Port <PortName> on <SchematicDocumentName> o Port Actions » Jump to Sheet Entry <PortName> on <SchematicDocumentName> que necesite en el menú contextual: el documento de origen del puerto o de la entrada de hoja indicados se convertirá en el documento activo y el cursor se situará sobre el puerto o la entrada de hoja. Se resaltarán todos los puertos con el mismo nombre (y cualquier cableado conectado) en el documento de destino.

Utilice el comando Jump to para ir a un objeto coincidente en cualquier parte del diseño.
Utilice el comando Jump to para ir a un objeto coincidente en cualquier parte del diseño.

  • Al navegar entre objetos, el objeto correspondiente se resaltará en el espacio de diseño. La visualización se ajusta a los Highlight Methods (atenuación, zoom y selección) definidos en la página Sistema - Navegación del cuadro de diálogo Preferences.
  • También puede navegar por la jerarquía manteniendo pulsado Ctrl y haciendo doble clic sobre un puerto, una entrada de hoja o un símbolo de hoja.
  • También puede navegar por la jerarquía mediante la función Interactive Navigation del panel Navegador.

Creación de jerarquías

El software incluye una serie de comandos que permiten crear una estructura jerárquica de varios documentos de forma rápida y eficiente. Los comandos que utilice dependerán de su metodología de diseño, que puede clasificarse, en términos generales, como descendente o ascendente. Estos comandos son más eficientes que la creación manual de la jerarquía, ya que gestionan todos los elementos necesarios durante el proceso, como añadir entradas de hoja, crear nuevas hojas de esquema, colocar puertos, etc.

Utilice este comando para crear la jerarquía de forma descendente:

  • Create Sheet From Sheet Symbol (en el menú principal Design o en el submenú Sheet Symbol Actions del menú contextual del símbolo de hoja): utilice este comando para crear una nueva hoja de esquema debajo del símbolo de hoja especificado. Los puertos correspondientes a las entradas de hoja del símbolo se situarán en la esquina inferior izquierda del nuevo documento. No se preocupe si aún no ha incluido todas las entradas de hoja en el símbolo de hoja; si añade más posteriormente, podrá volver a sincronizar las entradas de hoja y los puertos, como se explica más adelante.

    • El documento de esquema creado toma como nombre de archivo el nombre de archivo del símbolo de hoja. Puede introducir el nombre previsto para el documento en el campo File Name del símbolo de hoja, con su extensión (es decir, <DocumentName>.SchDoc), o dejar el nombre en blanco e introducirlo más adelante al guardar el documento.
    • Debe tener cuidado al crear una hoja a partir de un símbolo de hoja si ya existe una hoja con ese nombre de archivo. Se creará una nueva hoja con el mismo nombre de archivo. Esta duplicación puede resolverse al guardar, ya sea guardando la nueva hoja con un nombre diferente o sobrescribiendo la hoja existente si es necesario.
    • Los tipos eléctricos de E/S de los puertos creados en la nueva hoja secundaria serán los mismos que los de las entradas de hoja del símbolo de hoja principal de origen.

Utilice este comando para crear la jerarquía de forma ascendente:

  • Create Sheet Symbol From Sheet (en el menú principal Design o en el submenú Sheet Actions del menú contextual del espacio de diseño): utilice este comando para crear un símbolo a partir de la hoja de esquema especificada. Para utilizar este comando, primero cambie a la hoja que contendrá el nuevo símbolo de hoja y, a continuación, ejecute el comando. Se abrirá el cuadro de diálogo Elegir documento para colocar; utilícelo para elegir el documento de esquema de destino al que hará referencia el símbolo de hoja recién creado. El símbolo de hoja incluirá una entrada de hoja por cada puerto que encuentre. Si posteriormente se añaden o eliminan puertos o entradas de hoja, se pueden volver a sincronizar, como se explica más adelante.

    • Como el símbolo de hoja se crea y se coloca en la hoja activa, esta hoja no aparecerá en el cuadro de diálogo Choose Document to Place . Esto se debe a que un símbolo de hoja no puede hacer referencia a la misma hoja en la que está colocado.
    • Los tipos eléctricos de E/S de las entradas de hoja creadas en el nuevo símbolo de hoja principal serán los mismos que los de los puertos de la hoja secundaria de origen.

Utilice este comando para reorganizar la distribución de los circuitos en el diseño:

  • Edit » Refactor » Move Selected Sub-circuit to Different Sheet - utilice este comando para mover los componentes y el cableado seleccionados a otra hoja del proyecto. Se abrirá el cuadro de diálogo Choose Destination Document, donde podrá elegir cualquier esquema existente en el proyecto. Este comando se describe con más detalle a continuación.

Si se pregunta por qué existen comandos específicos para mover componentes de una hoja a otra, es porque los comandos estándar Cortar y Copiar restablecen automáticamente el identificador único de cada componente. El UID vincula el componente del esquema con el componente de la PCB. Si se ha restablecido el UID de un componente del esquema, se le pedirá que intente establecer la correspondencia mediante los designadores cada vez que se sincronice el diseño (al utilizar el comando Design » Update). Si es necesario, los UID pueden volver a sincronizarse mediante el comando Project » Component Links desde el editor de PCB.

► Más información sobre Sincronización del diseño

Reestructuración del diseño

Main article: Refactorización del diseño

El proceso de diseño suele ser poco estructurado y desarrollarse de forma orgánica: el diseñador puede estar formulando ideas para varias partes del diseño al mismo tiempo y plasmando secciones a medida que evolucionan sus ideas. Esto significa que lo que comenzó como un conjunto de esquemas bien organizado y distribuido puede terminar sobrecargado y mal organizado. Aunque puede utilizar Cortar, Copiar y Pegar para reorganizar el diseño esquemático, este no siempre es el mejor método.

¿Por qué no cortar y copiar? Porque a cada componente se le asigna un identificador único al colocarlo, y este identificador se restablece automáticamente cada vez que se corta o copia y se pega un componente. Esta gestión de los UID garantiza que solo haya una instancia de cada UID en el diseño, ya que es el campo clave que vincula el componente del esquema con el componente de la PCB. El método de Cortar/Copiar/Pegar es adecuado si el diseño aún no se ha transferido al editor de PCB, pero, si ya se ha transferido, es mejor utilizar las herramientas de refactorización.

Mover un subcircuito a otra hoja

La forma más sencilla de mover una sección del circuito de una hoja a otra es seleccionarla y, a continuación, ejecutar el comando Edit » Refactor » Move Selected Sub-circuit to Different Sheet. Se abrirá el cuadro de diálogo Choose Destination Document. Tras seleccionar la hoja de destino y hacer clic en OK, aparecerá esa hoja con el subcircuito unido al cursor, listo para colocarlo.

Una sección seleccionada del circuito puede moverse fácilmente a otra hoja del proyecto mediante el comando Move Selected Subcircuit to Different Sheet.
Una sección seleccionada del circuito puede moverse fácilmente a otra hoja del proyecto mediante el comando Move Selected Subcircuit to Different Sheet.

► Más información sobre Refactorización del diseño.

Sincronización de los puertos y las entradas de hoja

Si ha movido componentes y cableado como parte de la reestructuración del diseño, es posible que también deba volver a sincronizar la hoja secundaria con su símbolo de hoja, de modo que cada puerto tenga una entrada de hoja correspondiente. Esto se hace mediante el comando Synchronize Sheet Entries and Ports, que puede utilizar para lo siguiente:

  • A specific Sheet Symbol - haga clic con el botón derecho en el símbolo de hoja para mostrar el menú contextual y seleccione el comando Sheet Symbol Actions » Synchronize Sheet Entries and Ports para analizar únicamente el símbolo de hoja situado bajo el cursor.
  • All Sheet Symbols in the design - seleccione el comando Design » Synchronize Sheet Entries and Ports para analizar todos los símbolos de hoja del diseño completo. El cuadro de diálogo incluirá una pestaña para cada símbolo de hoja del diseño, de acuerdo con la opción Only Show unmatched sheet symbols situada en la parte inferior del cuadro de diálogo.

Con ambos comandos se abrirá el cuadro de diálogo Synchronize Ports to Sheet Entries. En el lado derecho se mostrarán los puertos y las entradas de hoja que ya tienen correspondencia, mientras que los puertos y las entradas de hoja sin correspondencia aparecerán en dos columnas en el lado izquierdo. Se considera que un símbolo de hoja está «sincronizado» con la hoja secundaria a la que hace referencia si todas sus entradas de hoja coinciden con los puertos correspondientes de esa hoja secundaria, tanto por nombre como por tipo de E/S.

El cuadro de diálogo Synchronize Ports to Sheet Entries se utiliza para garantizar que las entradas de hoja coincidan con los puertos de la hoja secundaria. Observe las dos pestañas, que indican que hay dos símbolos de hoja con discrepancias entre entradas de hoja y puertos en este diseño.
El cuadro de diálogo Synchronize Ports to Sheet Entries se utiliza para garantizar que las entradas de hoja coincidan con los puertos de la hoja secundaria. Observe las dos pestañas, que indican que hay dos símbolos de hoja con discrepancias entre entradas de hoja y puertos en este diseño.

Centrándose en las discrepancias que se muestran a la izquierda del cuadro de diálogo, la idea es seleccionar la entrada de hoja en la primera columna, después el puerto correcto en la segunda columna y, a continuación, hacer clic en el botón correspondiente en el centro del cuadro de diálogo para actualizar uno de los dos elementos de modo que queden sincronizados (y pasen a la lista de la derecha del cuadro de diálogo).

Los botones funcionan de la siguiente manera:

  • Button, update the Port to Match the Sheet Entry - utiliza las propiedades de la entrada de hoja y las aplica al puerto seleccionado.
  • Button, update the Sheet Entry to Match the Port - utiliza las propiedades del puerto y las aplica a la entrada de hoja seleccionada.

Si se seleccionan varias entradas de hoja en la columna de la izquierda, el software sincronizará cada entrada de hoja con el puerto adyacente de la segunda columna. Si no hay ningún puerto (o entrada de hoja) adyacente, se creará uno nuevo.

  • Si el comando añade nuevas entradas de hoja o nuevos puertos, será necesario colocarlos correctamente en la hoja del esquema una vez que haya finalizado.
  • Tenga en cuenta que cualquier cambio realizado en el cuadro de diálogo se aplica de inmediato. Los cambios no se pueden deshacer desde el cuadro de diálogo. Deberá utilizar la función Undo del documento para deshacer un cambio.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents