Capture de la conception logique du système
En un coup d'œil
- Comprenez les étapes de création d’un schéma multicarte et de liaison des modules aux projets PCB enfants.
- Découvrez comment le paramètre `System:Connector` identifie les connecteurs à inclure dans la conception au niveau système.
- Apprenez à valider les projets PCB enfants et à importer leurs données de connectivité dans les entrées des modules.
Les étapes essentielles pour créer un schéma système multi-cartes à partir de projets PCB enfants sont les suivantes :
-
Créez un projet de conception multi-cartes et ajoutez-y un document schématique multi-cartes.
-
Placez des blocs graphiques (modules) dans le schéma multi-cartes pour représenter logiquement les projets PCB enfants.
-
Liez chaque module au projet enfant approprié.
-
Importez les données de connectivité des projets enfants dans la conception multi-cartes.
-
Ajoutez des connexions entre les modules pour créer la conception logique du système.
Pour ajouter un document schématique multi-cartes (*.MbsDoc) au projet de conception multi-cartes, faites un clic droit sur l'entrée du projet dans le panneau Projects, puis sélectionnez Add New to Project » Multi-board Schematic dans le menu contextuel.
Préparation des projets PCB pour la conception multi-cartes
Les projets PCB Altium Designer qui représentent les cartes enfants d'une conception multi-cartes contiennent des connexions spécifiques, telles que des connecteurs de bord de carte ou des connecteurs à broches mâles/femelles, qui constituent l'interface électrique et physique avec les autres PCB de la conception du système.
Ces connexions et les nets électriques associés doivent être détectés et traités par un document schématique multi-cartes (logique) pour établir la connectivité entre les cartes dans la conception au niveau système. Cette fonctionnalité est activée par la présence d'un paramètre de composant spécifique pour les connecteurs du projet PCB : un paramètre nommé System, dont la valeur est Connector.
Pour chaque connecteur d'un projet PCB destiné à une interconnexion au niveau système, sélectionnez le composant du connecteur, puis ajoutez le paramètre de composant spécial à la liste dans la zone Parameters, sous l'onglet General du panneau Properties, lorsque le composant est sélectionné.
Pour en savoir plus sur les propriétés des composants, consultez la page Utilisation des composants placés.

La présence du paramètre nommé System, avec la valeur Connector, lie ce connecteur PCB au schéma multi-cartes.
Représentation des projets enfants dans le schéma multi-cartes
La connectivité entre les projets PCB qui composent une conception multi-cartes est établie en plaçant des blocs représentatifs (modules) sur le schéma et en reliant leurs connecteurs exposés (entrées de module) à l'aide de connexions.
Les modules, qui représentent les projets PCB enfants et les PCB spécifiques qu'ils contiennent, sont placés dans l'espace de conception à partir du menu Place » Module.
Pour définir la source d'un module placé, sélectionnez-le dans l'espace de conception, puis, dans le panneau Properties, utilisez le bouton
associé au champ Project dans la zone Source sous l'onglet General pour ouvrir la boîte de dialogue Choose Project (une variante de la boîte de dialogue Open Project), qui vous permet de rechercher et de sélectionner un projet PCB ou multi-cartes comme source du module. Une fois le projet requis choisi, sélectionnez la conception de carte PCB ou l'assemblage multi-cartes souhaité dans ce projet à l'aide de la liste déroulante Assembly/Board.
Un projet multi-cartes établi présente une structure hiérarchique de documents qui comprend les documents sources et les sous-projets enfants liés aux modules du schéma système. La structure d'un projet enfant est immédiatement ajoutée au projet multi-cartes lorsqu'un module de la conception système est lié à ce projet externe. Développez la structure du projet dans le panneau Projects pour afficher les fichiers constituant le projet multi-cartes et ses projets enfants.
Pour que le projet multi-cartes extraie et traite les données correctes de ses sous-projets, le PCB de chaque projet doit être synchronisé avec son schéma et ne présenter aucune erreur de conception ou de dessin. Pour valider un sous-projet PCB, faites un clic droit sur son nom dans le panneau et sélectionnez la commande Validate PCB Project <ProjectName>.PrjPcb ; les éventuels problèmes seront répertoriés dans le panneau Messages.
Lorsqu’un module placé est sélectionné, utilisez le panneau Properties pour définir ses autres propriétés :
-
Utilisez les propriétés Designator et Title dans la zone Properties de l’onglet General du panneau pour spécifier respectivement l’identifiant schématique du module et son titre. Utilisez le bouton
à droite du champ correspondant pour activer ou désactiver sa visibilité dans le schéma multi-cartes, et le bouton
pour autoriser ou interdire la modification de la valeur. Utilisez les commandes de police et Other pour configurer la police du texte, sa position dans le document et, pour le titre, la visibilité du nom du paramètre.
-
Lorsque le module est sélectionné, le tableau de la zone Entries de l’onglet General du panneau Properties est renseigné lorsque des entrées de module sont ajoutées au module – voir ci-dessous.
-
Utilisez les commandes de la zone Graphical de l’onglet General du panneau pour configurer l’affichage du module : sa taille (largeur et hauteur), l’épaisseur, le style et la couleur du trait de son contour, ainsi que sa couleur de remplissage. Les options d’épaisseur et de style de trait disponibles sont définies dans la zone Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document schématique multi-cartes.
-
Utilisez les commandes de l’onglet Parameters du panneau pour ajouter, modifier et supprimer des paramètres de module, et configurer leur visibilité dans l’espace de conception.
Ajoutez d’autres modules et les liens vers leurs projets enfants au schéma multi-cartes, selon les besoins de la conception du système complet.
Les modules sont renseignés avec les données de conception des projets auxquels ils sont liés, en important les données de projet à l’aide des commandes suivantes, accessibles depuis les menus principaux ou le menu contextuel de l’espace de conception :
-
Design » Import From Child Projects – transfère les données de conception de tous les projets sources (enfants) vers les modules qui leur sont associés.
-
Design » Import From Selected Child Projects – transfère les données de conception des projets sources (enfants) correspondants pour le ou les modules actuellement sélectionnés.
Cette opération traite surtout les données de broches et de nets de chaque connecteur des projets enfants auquel le paramètre spécial System:Connector est associé (voir les détails ci-dessus). Une fois l’importation terminée, une entrée de module est automatiquement créée pour chacun de ces connecteurs sur la représentation graphique du bloc du module correspondant. L’entrée de connecteur est liée dynamiquement aux broches et aux nets du connecteur dans le projet enfant. Sélectionnez la représentation graphique d’une entrée de module dans l’espace de conception pour afficher ses détails, tels que les broches/nets de son connecteur, dans le panneau Properties. Tant que l’entrée n’est pas connectée à celle d’un autre module, la liste des composants/broches du panneau indique que le connecteur et ses broches ne sont pas accouplés.
Lorsqu’une entrée est sélectionnée, utilisez le panneau Properties pour définir ses propriétés :
-
Utilisez les commandes de la zone Properties de l’onglet General du panneau pour modifier la valeur, la visibilité et le style du Designator de l’entrée, et choisir son Type (Male/Female). Cette zone du panneau indique également le nombre de broches du connecteur de l’entrée (Number of Pins) et le numéro d’identification attribué à cette entrée dans le module parent (Entry Number).
-
Activez l’option System Entry pour désigner l’entrée comme une connexion au niveau du système qui n’est pas câblée à un autre module, par exemple une entrée représentant une prise d’alimentation.
-
Lorsque l’entrée est raccordée par une connexion de type faisceau ou câble (en savoir plus), la zone Mated Component du panneau est renseignée avec les données du composant accouplé.
-
Dans la Mated Pins région du panneau, la colonne Pin répertorie les différentes broches du connecteur et leurs nets associés. Une fois cette entrée connectée, la colonne Mated Pin affiche la liste des broches correspondantes. De plus, une fois cette entrée connectée, l’onglet Addresses du panneau Properties affiche un tableau des chemins de connexion et des nets de l’entrée (en savoir plus).
-
Utilisez les commandes de l’onglet Parameters du panneau pour ajouter, modifier et supprimer les paramètres de l’entrée et configurer leur visibilité dans l’espace de conception.
Lorsque des entrées de module sont ajoutées à un module, le tableau de la région Entries sous l’onglet General du panneau Properties affiche ces entrées lorsque le module est sélectionné. La colonne Part(s) répertorie chaque entrée de module par le repère et le nom du connecteur d’entrée dans la conception source. Vous pouvez modifier ces informations pour plus de commodité : cette dénomination est locale à la conception multi-cartes et n’affecte pas les projets enfants sources.
Prise en charge des périphériques/composants externes
Le document schématique multi-cartes prend en charge les périphériques/composants externes qui ne font pas partie des assemblages de cartes PCB enfants habituels (c’est-à-dire les composants « hors PCB »). Il peut s’agir, par exemple, d’interrupteurs externes, de capteurs et de tout autre module électronique tiers du commerce. Cette fonctionnalité repose sur la prise en charge de deux types d’objets :
-
Custom Part – une entité semblable à un module, qui permet d’associer un ou plusieurs composants de bibliothèque et qui est ajoutée au document schématique multi-cartes à l’aide de la commande Place » Custom Part des menus principaux. Lorsque la pièce personnalisée placée est sélectionnée dans l’espace de conception, utilisez la région Linked Components du panneau Properties pour ajouter des composants à la pièce personnalisée ou en supprimer, à l’aide des boutons
et
, respectivement. Si la liste des composants associés contient des composants obsolètes de l’espace de travail, cliquez sur le bouton
pour les mettre à jour vers leurs dernières révisions. Une entrée est automatiquement ajoutée pour chaque composant associé.
-
Custom Connection – permet d’ajouter un seul composant de bibliothèque au document schématique multi-cartes en faisant glisser le composant souhaité depuis le panneau Components vers un espace libre de la feuille. Une entrée est automatiquement ajoutée pour chaque broche du composant.
Les composants de bibliothèque sont ceux disponibles dans votre espace de travail connecté et dans les bibliothèques locales disponibles. Une fois placés/définis, vous pouvez connecter les composants au reste de votre conception, par exemple à l’aide de connexions par câble et par faisceau.
Navigation croisée
Les commandes de navigation croisée disponibles dans le menu principal Design et dans le menu contextuel de l’espace de conception vous permettent de passer rapidement du document schématique multi-cartes aux éléments correspondants des projets enfants.
-
Pour accéder, par navigation croisée, depuis le module ou l’entrée actuellement sélectionné au document PCB ou au connecteur de ce document dans le projet de conception PCB référencé par ce module, utilisez la commande Design » Crossprobe to PCB/Multi-board. Si le module référence un document d’assemblage multi-cartes (
*.MbaDoc) dans un projet multi-cartes source (*.PrjMbd), la navigation croisée mène alors au document d’assemblage multi-cartes. -
Pour accéder, par navigation croisée, depuis le module ou l’entrée actuellement sélectionné au schéma de niveau supérieur ou au connecteur du schéma concerné dans le projet de conception PCB référencé par ce module, utilisez la commande Design » Crossprobe to Schematic.
-
Pour accéder, par navigation croisée, depuis le module ou l’entrée actuellement sélectionné à la carte, ou au connecteur de cette carte, dans le document d’assemblage multi-cartes (
*.MbaDoc) du projet multi-cartes (*.PrjMbd), utilisez la commande Design » Crossprobe to MBA. -
Pour accéder, par navigation croisée, depuis la connexion par faisceau actuellement sélectionnée dans le document schématique multi-cartes (
*.MbsDoc) à un projet de faisceau associé (*.PrjHar), utilisez la commande Design » Crossprobe to Harness. Le document du schéma de câblage du projet de faisceau associé s’ouvre.
Imprimer ou exporter au format PDF
Pour imprimer le document schématique multi-cartes actuellement actif, sélectionnez File » Print dans le menu principal (raccourci : Ctrl+P). La boîte de dialogue Print s’ouvre. La partie gauche de la boîte de dialogue présente un aperçu avant impression redimensionnable. Les options d’impression standard sont disponibles dans la partie droite. Elles permettent notamment de sélectionner une imprimante, de vérifier son emplacement, de consulter le nombre de documents actuellement dans la file d’attente d’impression, de définir le nombre de copies à imprimer, ainsi que le format et l’orientation des pages. Après avoir cliqué sur
, les documents à imprimer sont envoyés à l’imprimante sélectionnée, conformément aux options définies.
Pour exporter un document schématique multi-cartes vers un fichier PDF, sélectionnez File » Export to PDF dans le menu principal.



).
).









