Création de l’assemblage physique multi-cartes

Altium Designer prend en charge la création d’un assemblage multi-cartes, appelé multi-board assembly. Une fois la structure logique du système définie dans un schéma multi-cartes (*.MbsDoc), la conception physique multi-cartes est ensuite créée en transférant la conception du système dans un document d’assemblage multi-cartes vide (*.MbaDoc). Ce processus charge dans l’éditeur d’assemblage multi-cartes la représentation physique (PCB et autres assemblages multi-cartes) référencée par chaque bloc logique du schéma multi-cartes. Cette page décrit ce processus.

Pour en savoir plus sur l’étape de conception logique d’un assemblage multi-cartes, consultez la page Capturing the Logical System Design.

Les projets multi-cartes et leurs sous-projets associés peuvent être enregistrés dans un Workspace connecté, où ils bénéficient des fonctions de contrôle de version, de partage et de gestion fournies par un Altium 365 Workspace ou un Enterprise Server Workspace.

Pour plus d’informations sur le stockage et le partage d’un projet multi-cartes dans un Altium 365 Workspace, consultez la page Workspace Projects .

Pour créer un nouveau document d’assemblage multi-cartes :

  1. Ajoutez un nouveau document d’assemblage multi-cartes (*.MbaDoc) au projet multi-cartes en cliquant avec le bouton droit sur l’entrée du projet dans le panneau Projects, puis en sélectionnant Add New to Project » Multi-board Assembly dans le menu contextuel.

    Chaque projet de conception multi-cartes ne peut contenir qu’un seul document d’assemblage multi-cartes.

  2. Enregistrez le nouveau document d’assemblage multi-cartes (cliquez avec le bouton droit sur son entrée dans le panneau Projects, puis sélectionnez Save As dans le menu contextuel).

  3. Transférez la représentation logique du système depuis le schéma multi-cartes vers le document d’assemblage multi-cartes – en savoir plus.

  4. Si le boîtier est disponible, chargez-le dans l’assemblage – en savoir plus.

  5. Positionnez chaque élément dans l’assemblage – consultez la page Positioning & Orienting Your Boards pour en savoir plus.

  6. Connectez les éléments dans l’assemblage à l’aide de contraintes d’assemblage (mates) – consultez la page Working with Mates pour en savoir plus.

Exemple d’un assemblage multi-cartes. Plusieurs PCB connectés sont placés dans un boîtier.
Exemple d’un assemblage multi-cartes. Plusieurs PCB connectés sont placés dans un boîtier.

Opening a Multi-board Assembly Created in Altium Designer 18

Les assemblages multi-cartes créés dans Altium Designer 18 doivent être importés en raison de changements de format de fichier requis pour prendre en charge le moteur 3D et l’ensemble de fonctionnalités amélioré. Lorsqu’un document d’assemblage multi-cartes dans l’ancien format est ouvert, la boîte de dialogue Legacy document import s’ouvre.

Sélectionnez la commande Design » Import dans l’éditeur d’assemblage multi-cartes pour générer des ECO qui rechargeront les modules enfants.

Notez qu’en raison des changements de format de fichier requis pour prendre en charge l’ensemble de fonctionnalités amélioré et le moteur 3D, un assemblage multi-cartes enregistré dans une version ultérieure d’Altium Designer ne peut pas être ouvert dans Altium Designer 18.

L’éditeur Multi-board Assembly utilise la bibliothèque Open CASCADE pour la modélisation géométrique d’un assemblage multi-cartes. Notez que lors de l’ouverture d’un ancien document d’assemblage multi-cartes (provenant d’une version précédente du logiciel), les contraintes d’assemblage créées seront supprimées (vous pouvez choisir de conserver les positions relatives des pièces de l’assemblage ou de les placer en ligne). Vous avez la possibilité de créer une sauvegarde de cette ancienne version au moment de l’ouverture.

Cette fonctionnalité est en Open Beta et disponible lorsque l’option System.MBAEngine.UseOpenCascade est activée dans la boîte de dialogue Advanced Settings dialog.

Transfert de la conception du système vers le document d’assemblage multi-cartes

La conception multi-cartes est transférée du schéma multi-cartes vers le document d’assemblage multi-cartes à l’aide de l’une des commandes suivantes :

  • Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc depuis les menus principaux de l’éditeur de schéma multi-cartes.

  • Design » Import Changes From <MultiBoardProjectName>.PrjMbd depuis les menus principaux de l’éditeur d’assemblage multi-cartes.

Lorsque vous exécutez l’une de ces commandes, le logiciel examine chaque module du schéma multi-cartes, identifie le PCB/l’assemblage sélectionné pour chacun des projets enfants, et présente dans la boîte de dialogue Engineering Change Order la liste des modifications requises pour ajouter chacune de ces cartes à l’assemblage.

La carte de chaque projet PCB est répertoriée comme modification ECO et est chargée dans l’éditeur Multi-board Assembly lorsque les ECO sont exécutés.
La carte de chaque projet PCB est répertoriée comme modification ECO et est chargée dans l’éditeur Multi-board Assembly lorsque les ECO sont exécutés.

Lorsque le bouton  est cliqué, les cartes/assemblages sont chargés dans l’éditeur d’assemblage multi-cartes. Chaque carte/assemblage est placé dans l’espace de conception avec la même orientation que dans le projet enfant. Ce processus prendra un certain temps, car l’ensemble complet des données de chaque PCB doit être analysé et chargé.

Les cartes de cet assemblage multi-cartes sont chargées dans l’espace de conception de l’éditeur d’assemblage multi-cartes, prêtes à être positionnées.
Les cartes de cet assemblage multi-cartes sont chargées dans l’espace de conception de l’éditeur d’assemblage multi-cartes, prêtes à être positionnées.

  • À l’aide des options de la page Multi-board Assembly – General page de la boîte de dialogue Preferences, vous pouvez configurer si les corps 3D libres des PCB enfants doivent être importés et si les corps 3D dont la hauteur est inférieure à la valeur spécifiée ne doivent pas être importés.

  • Utilisez la commande View » Toggle Units dans les menus principaux (ou le raccourci Q) pour basculer les unités entre impériales et métriques.

Ajout d’objets supplémentaires à l’assemblage multi-cartes

Vous pouvez également charger des objets supplémentaires dans un assemblage multi-cartes (en plus des PCB référencés dans le schéma multi-cartes). Les objets supplémentaires peuvent être chargés à l’aide du menu Design ou des boutons situés en haut du panneau Multi-board Assembly.

Chaque entité, ou élément, d’un assemblage multi-cartes est appelée part.

Utilisez la commande ou le bouton approprié pour :

  • Insert PCB Part () – insérer un autre PCB dans cet assemblage.

  • Insert MBA Part () – insérer un autre assemblage multi-cartes dans cet assemblage.

  • Insert STEP Part () – insérer dans cet assemblage un modèle mécanique au format STEP.

  • Notez qu’une pièce est insérée dans l’assemblage multi-cartes comme une entité unique. Par exemple, si vous insérez le modèle STEP d’un boîtier composé d’une moitié supérieure et d’une moitié inférieure, vous ne pourrez pas manipuler ces moitiés indépendamment. Dans ce cas, vous devez insérer chaque moitié séparément dans l’assemblage.

  • L’assemblage ou le PCB inséré est not ajouté au projet Multi-board Design (*.PrjMbd) et n’apparaît donc pas comme enfant de ce projet dans le panneau Projects.

Mise à jour ou modification d’une pièce d’assemblage

Verrouillage/déverrouillage d’une pièce

Pour verrouiller/déverrouiller une pièce, sélectionnez la pièce souhaitée, cliquez avec le bouton droit, puis choisissez la commande Lock Selected Part/Unlock Selected Part dans le menu contextuel pour verrouiller/déverrouiller la pièce (ou les pièces contraintes) à son emplacement actuel dans l’espace de conception de l’éditeur d’assemblage. Vous pouvez aussi cliquer avec le bouton droit sur une entrée de pièce dans le panneau Multiboard Assembly, puis choisir Locked.

  • Une pièce verrouillée ne peut pas être modifiée/déplacée.

  • Les pièces verrouillées sont marquées d’une icône de cadenas dans le panneau Multiboard Assembly.

  • Une pièce individuelle verrouillée n’affiche pas de gizmo d’objet (pour en savoir plus sur le gizmo d’objet, consultez la page Positioning & Orienting Your Boards). Une pièce verrouillée ne peut pas être contrainte si elle est sélectionnée comme source (l’objet qui se déplace – pour en savoir plus sur la mise en contrainte des pièces, consultez la page Working with Mates).

Mise à jour d’une pièce

Si une pièce ou un corps 3D ajouté à un assemblage a été mis à jour, la mise à jour peut être chargée dans l’assemblage multi-cartes à l’aide de l’une des actions suivantes :

  • Choisissez la commande Edit » Update All Parts dans les menus principaux ou cliquez avec le bouton droit n’importe où dans l’espace de conception et choisissez la commande Update All Parts dans le menu contextuel (raccourci : Shift+Ctrl+U) pour mettre à jour toutes les pièces de l’assemblage multi-cartes actif avec les dernières informations de routage de leurs documents PCB enfants correspondants.

  • Sélectionnez la ou les pièces requises et choisissez la commande Edit » Update Selected Part dans les menus principaux ou cliquez avec le bouton droit n’importe où dans l’espace de conception et choisissez la commande Update Selected Part dans le menu contextuel (raccourci : Ctrl+U) pour mettre à jour les pièces sélectionnées dans l’assemblage multi-cartes actif avec les dernières informations de routage de leurs documents PCB enfants correspondants.

  • Sélectionnez le corps 3D requis et choisissez la commande Edit » Update Selected 3D Body dans les menus principaux ou cliquez avec le bouton droit n’importe où dans l’espace de conception et choisissez la commande Update Selected 3D Body dans le menu contextuel pour mettre à jour les corps 3D sélectionnés dans l’assemblage multi-cartes actif avec les dernières informations de routage de leurs documents PCB enfants correspondants.

Modification d’une pièce

Une session de modification d’assemblage ou de PCB peut être lancée depuis l’éditeur d’assemblage multi-cartes. Sélectionnez la pièce requise et exécutez la commande Edit » Edit Selected Part ou cliquez avec le bouton droit n’importe où dans l’espace de conception et choisissez la commande Edit Selected Part dans le menu contextuel (raccourci : Ctrl+E). Après avoir lancé la commande, vous passerez en mode de modification de pièce, avec le PCB sélectionné zoomé et centré (dans la mesure du possible) pour s’adapter à la fenêtre principale de conception. La carte restera affichée avec toutes ses couleurs, tandis que toutes les autres cartes seront grisées (lecture seule).

Apportez les modifications requises au placement des composants, à l’aide des fonctions de placement manuel et/ou d’alignement. Une fois la modification terminée, utilisez la commande Finish Part Editing (Ctrl+E). La vue de l’espace de conception reviendra à l’ajustement de toutes les cartes de l’assemblage, la carte qui était en cours de modification restant sélectionnée.

Si vous souhaitez annuler la modification sans appliquer les changements, utilisez la commande Cancel Part Editing.

Navigation et gestion de l’assemblage multi-cartes

Pour naviguer et gérer un assemblage multi-cartes, vous pouvez utiliser le panneau Multiboard Assembly.

Le panneau présente une vue arborescente extensible de la structure complète de l’assemblage, y compris :

  • Les cartes incluses (PCB) et les assemblages multi-cartes, ainsi que les composants, couches et nets de chaque PCB

  • Les modèles STEP inclus

  • Les autres assemblages multi-cartes inclus

  • Les contraintes d’assemblage formées entre les objets de l’assemblage

Mise en évidence des éléments dans l’assemblage multi-cartes

Le panneau Multiboard Assembly fournit des capacités de mise en évidence, où la pièce sélectionnée dans l’arborescence est mise en évidence dans l’espace de conception. La mise en évidence est bidirectionnelle pour les sélections effectuées en haut de l’arborescence de l’assemblage ; par exemple, l’état de sélection des entrées du panneau change en réponse aux objets de niveau supérieur sélectionnés dans l’espace de conception. Depuis le panneau, la sélection est prise en charge à tous les niveaux de l’arborescence lorsque cela est pertinent. Par exemple, la sélection d’un net individuel mettra ce net en évidence sur toute la carte, mais la sélection d’une couche diélectrique individuelle ne mettra pas cette couche en évidence. Les raccourcis Windows standard Shift+Click ou Ctrl+Click peuvent être utilisés pour effectuer une sélection multiple dans le panneau.

Trois cartes sélectionnées dans l’espace de conception sont également mises en évidence dans le panneau.
Trois cartes sélectionnées dans l’espace de conception sont également mises en évidence dans le panneau.

La mise en évidence depuis le panneau constitue une excellente méthode pour localiser une pièce spécifique ou examiner le chemin d’un ensemble de nets lorsqu’ils passent sous une carte fille.

Contrôle de la visibilité et de la transparence des pièces de l’assemblage

En plus de mettre en évidence une ou plusieurs pièces spécifiques, le panneau peut également être utilisé pour contrôler la visibilité et la transparence des pièces actuellement sélectionnées dans le panneau. Cliquez avec le bouton droit sur la ou les pièces sélectionnées, puis choisissez Visible ou Transparent dans le menu contextuel. Les pièces transparentes deviennent translucides. Les pièces dont l’option Visible est désactivée seront masquées.

Javascript ID: MBA_Pnl_MultiboardAssembly_PartVisibility

Un modèle STEP est entièrement visible dans l’assemblage.

Le même modèle a été rendu transparent.

Le même modèle a été complètement masqué.

Vous pouvez également contrôler directement dans l’espace de conception la visibilité d’un PCB, d’un composant PCB ou d’un modèle STEP.

  • Pour un objet complet, tel qu’un PCB ou un modèle STEP, sélectionnez l’objet, puis cliquez avec le bouton droit pour afficher le menu contextuel et choisissez l’option Visible pour masquer l’objet. Utilisez le panneau Multi-board Assembly pour restaurer sa visibilité.

  • Pour un composant PCB, sélectionnez le PCB dans l’espace de conception, cliquez avec le bouton droit et choisissez Edit Selected Part. Ensuite, cliquez avec le bouton droit sur n’importe quel composant de cette carte et choisissez les commandes Visible ou Transparent dans le menu contextuel. Lorsque vous avez terminé de configurer la visibilité des composants sur cette carte, cliquez à nouveau avec le bouton droit sur celle-ci et choisissez Finish Editing Part ou Cancel Editing Part.

Mesure de la distance

La commande Tools » Measure Distance dans les menus principaux (raccourci : Ctrl+M) est utilisée pour mesurer les distances entre les corps 3D dans l’assemblage multi-cartes. Après avoir lancé la commande, vous passerez en mode de mesure. La mesure s’effectue comme suit :

  1. Choisissez le premier objet 3D, ou une face spécifique de cet objet. Lorsque vous déplacez le curseur sur un objet 3D potentiel, la couleur de cet objet change. Si vous souhaitez sélectionner une face spécifique de l’objet, maintenez la touche Ctrl  enfoncée pendant que vous déplacez le curseur – la face actuellement sous le curseur sera mise en évidence. Une fois le curseur en place, cliquez pour confirmer la sélection de l’objet/de la face.

  2. Choisissez le second objet 3D, ou une face spécifique de cet objet.

  3. L’outil affiche visuellement la distance la plus courte entre les deux objets (faces) choisis.

  4. Continuez à mesurer la distance entre d’autres objets/faces ou appuyez sur Esc pour quitter le mode de mesure.

  • Tous les résultats de mesure pendant la session de mesure active sont présentés dans le panneau Messages. Vous pouvez double-cliquer sur une entrée pour effectuer un cross-probing vers cette mesure dans l’espace de conception.

  • Une fois la session de mesure terminée, toutes les mesures visuelles seront effacées, ainsi que toutes les entrées de mesure du panneau Messages.

  • Lors du passage du curseur sur un corps 3D (ou l’une de ses faces), la couleur passera à celle spécifiée pour la couleur système Highlight Under Cursor, dans la section System Colors du panneau View Configuration.

Test de collision

Les collisions sont signalées dès que deux objets ont des surfaces qui se touchent ou se croisent.

Pour vérifier les collisions, sélectionnez Tools » Check Collisions (raccourci : Ctrl+K). Après le lancement de la commande, le logiciel recherche les collisions entre les différentes entités impliquées dans l’assemblage multi-cartes. Tout d’abord, chaque carte est vérifiée pour détecter toute collision avec les parties supérieure et inférieure du boîtier/coque (pièces STEP), puis la vérification est effectuée entre les cartes elles-mêmes (PCB).

Toutes les collisions seront signalées dans le panneau Messages, et les objets concernés seront mis en évidence à l’aide de la couleur système Violation. Utilisez la zone Details du panneau Messages pour déterminer quel composant d’une carte impliquée dans un conflit est à l’origine de la collision.

Si nécessaire, les violations de collision mises en évidence dans l’espace de conception après l’exécution de la vérification des collisions peuvent être effacées en sélectionnant la commande Tools » Clear Violations.

  • La vérification des collisions sera effectuée entre toutes les cartes et les pièces du boîtier/de la coque, indépendamment de la visibilité d’une carte/pièce dans l’espace de conception.

  • Les surfaces contraintes par mate ne sont pas considérées comme étant en collision.

Prise en charge du rigide-flex

L’éditeur d’assemblage multi-cartes prend en charge les PCB rigide-flex. Le terme rigide-flex désigne un circuit imprimé combinant à la fois un ou plusieurs circuits flexibles et un ou plusieurs circuits rigides. L’éditeur d’assemblage multi-cartes affiche le PCB dans son état final plié tel que défini dans l’éditeur PCB.

Pour plus d’informations sur la conception de PCB rigide-flex, consultez la page Designing a Rigid-Flex PCB.

Exportation vers la MCAD

L’assemblage peut être exporté au format STEP 3D ou Parasolid. Pour exporter l’ensemble de l’assemblage en STEP 3D (*.step ou *.stp), sélectionnez File » Export » STEP 3D  dans les menus principaux. Pour exporter l’ensemble de l’assemblage au format Parasolid (*.x_t), sélectionnez File » Export » Parasolid dans les menus principaux.

Exemple du fichier STEP de l’assemblage multi-cartes ouvert dans un outil MCAD.
Exemple du fichier STEP de l’assemblage multi-cartes ouvert dans un outil MCAD.

Un assemblage multi-cartes peut également être synchronisé entre Altium Designer et un outil MCAD pris en charge à l’aide de la fonctionnalité Altium MCAD CoDesigner.

Pour en savoir plus, consultez la page Synchronizing a Multi-board Assembly.

Exportation vers PDF 3D

Un document d’assemblage multi-cartes peut également être exporté vers un fichier PDF (*.pdf). Pour cela, choisissez la commande File » Export to PDF File dans les menus principaux.

Pour plus d’informations, consultez la page Preparing a PDF3D File.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contenu