Capture de la conception logique du système

En un coup d'œil

Découvrez comment saisir la conception logique d’un système multicarte dans Altium Designer en reliant des projets PCB enfants aux modules d’un schéma multicarte. Cet article explique comment préparer les connecteurs pour la connectivité au niveau système, définir les sources et les propriétés des modules, et importer les données des broches et des nets des connecteurs pour renseigner les entrées des modules. Poursuivez votre lecture pour commencer à créer une représentation claire des connexions entre les cartes de votre système.

- Comprenez les étapes de création d’un schéma multicarte et de liaison des modules aux projets PCB enfants.
- Découvrez comment le paramètre `System:Connector` identifie les connecteurs à inclure dans la conception au niveau système.
- Apprenez à valider les projets PCB enfants et à importer leurs données de connectivité dans les entrées des modules.
Approfondissez avec l'IA :

Les étapes essentielles pour créer un schéma système multi-cartes à partir de projets PCB enfants sont les suivantes :

  1. Créez un projet de conception multi-cartes et ajoutez-y un document schématique multi-cartes.

  2. Placez des blocs graphiques (modules) dans le schéma multi-cartes pour représenter logiquement les projets PCB enfants.

  3. Liez chaque module au projet enfant approprié.

  4. Importez les données de connectivité des projets enfants dans la conception multi-cartes.

  5. Ajoutez des connexions entre les modules pour créer la conception logique du système.

Pour ajouter un document schématique multi-cartes (*.MbsDoc) au projet de conception multi-cartes, faites un clic droit sur l'entrée du projet dans le panneau Projects, puis sélectionnez Add New to Project » Multi-board Schematic dans le menu contextuel.

Chaque projet de conception multi-cartes ne peut contenir qu'un seul document schématique multi-cartes.

Préparation des projets PCB pour la conception multi-cartes

Les projets PCB Altium Designer qui représentent les cartes enfants d'une conception multi-cartes contiennent des connexions spécifiques, telles que des connecteurs de bord de carte ou des connecteurs à broches mâles/femelles, qui constituent l'interface électrique et physique avec les autres PCB de la conception du système.

Ces connexions et les nets électriques associés doivent être détectés et traités par un document schématique multi-cartes (logique) pour établir la connectivité entre les cartes dans la conception au niveau système. Cette fonctionnalité est activée par la présence d'un paramètre de composant spécifique pour les connecteurs du projet PCB : un paramètre nommé System, dont la valeur est Connector.

Les connecteurs présentant la paire paramètre:valeur System:Connector sont détectés lorsque chaque module du système est synchronisé avec son projet PCB enfant à l'aide de la commande Import from Child Projects. Cette opération est expliquée dans la section Représentation des projets PCB enfants dans le schéma multi-cartes ci-après.

Pour chaque connecteur d'un projet PCB destiné à une interconnexion au niveau système, sélectionnez le composant du connecteur, puis ajoutez le paramètre de composant spécial à la liste dans la zone Parameters, sous l'onglet General du panneau Properties, lorsque le composant est sélectionné.

Pour en savoir plus sur les propriétés des composants, consultez la page Utilisation des composants placés.

La présence du paramètre nommé System, avec la valeur Connector, lie ce connecteur PCB au schéma multi-cartes.
La présence du paramètre nommé System, avec la valeur Connector, lie ce connecteur PCB au schéma multi-cartes.

Représentation des projets enfants dans le schéma multi-cartes

La connectivité entre les projets PCB qui composent une conception multi-cartes est établie en plaçant des blocs représentatifs (modules) sur le schéma et en reliant leurs connecteurs exposés (entrées de module) à l'aide de connexions.

Les modules, qui représentent les projets PCB enfants et les PCB spécifiques qu'ils contiennent, sont placés dans l'espace de conception à partir du menu Place » Module.

Pour définir la source d'un module placé, sélectionnez-le dans l'espace de conception, puis, dans le panneau Properties, utilisez le bouton  associé au champ Project dans la zone Source sous l'onglet General pour ouvrir la boîte de dialogue Choose Project (une variante de la boîte de dialogue Open Project), qui vous permet de rechercher et de sélectionner un projet PCB ou multi-cartes comme source du module. Une fois le projet requis choisi, sélectionnez la conception de carte PCB ou l'assemblage multi-cartes souhaité dans ce projet à l'aide de la liste déroulante Assembly/Board.

Un projet multi-cartes établi présente une structure hiérarchique de documents qui comprend les documents sources et les sous-projets enfants liés aux modules du schéma système. La structure d'un projet enfant est immédiatement ajoutée au projet multi-cartes lorsqu'un module de la conception système est lié à ce projet externe. Développez la structure du projet dans le panneau Projects pour afficher les fichiers constituant le projet multi-cartes et ses projets enfants.

Pour que le projet multi-cartes extraie et traite les données correctes de ses sous-projets, le PCB de chaque projet doit être synchronisé avec son schéma et ne présenter aucune erreur de conception ou de dessin. Pour valider un sous-projet PCB, faites un clic droit sur son nom dans le panneau et sélectionnez la commande Validate PCB Project <ProjectName>.PrjPcb ; les éventuels problèmes seront répertoriés dans le panneau Messages.

Javascript ID : Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • Un projet PCB, un autre projet multi-cartes ou un projet de conception de faisceau peut être ajouté à la structure du projet multi-cartes en faisant un clic droit sur l'entrée de ce dernier dans le panneau Projects, en sélectionnant la commande Add Existing to Project, puis en recherchant et en sélectionnant le fichier local *.PrjPcb, *.PrjMbd ou *.PrjHar correspondant. Si un projet PCB ou de conception de faisceau à intégrer au projet multi-cartes est déjà ouvert dans Altium Designer, vous pouvez faire glisser son entrée dans le panneau Projects sur l'entrée du projet multi-cartes parent pour l'ajouter à sa structure (). Ensuite, placez manuellement un nouveau module sur le document schématique multi-cartes (du projet multi-cartes parent), puis, une fois le module sélectionné, choisissez le projet PCB enfant (et son document PCB) ou le projet multi-cartes enfant (et son document d'assemblage multi-cartes) comme source de ce module dans la liste déroulante du champ Source du panneau Properties (). Le projet de faisceau peut être synchronisé avec le projet multi-cartes (consultez la page Définition du schéma de câblage pour en savoir plus).

  • Pour retirer un projet PCB ou de conception multi-cartes enfant de la structure du projet multi-cartes parent, supprimez tous les modules faisant référence à ce projet enfant dans le document schématique multi-cartes du parent. Le projet enfant sera alors automatiquement retiré de la structure.

  • Un projet PCB ou de conception de faisceau enfant peut également être retiré de la structure du projet multi-cartes parent en faisant glisser son entrée hors de la structure du projet multi-cartes. Notez que dans ce cas (et uniquement pour un projet PCB), les modules faisant référence au projet enfant resteront dans le document schématique multi-cartes, tout comme leurs liens vers ce projet enfant. Pour supprimer complètement toute référence au projet enfant retiré dans le projet multi-cartes parent, supprimez ces modules manuellement.

Lorsqu’un module placé est sélectionné, utilisez le panneau Properties pour définir ses autres propriétés :

  • Utilisez les propriétés Designator et Title dans la zone Properties de l’onglet General du panneau pour spécifier respectivement l’identifiant schématique du module et son titre. Utilisez le bouton  à droite du champ correspondant pour activer ou désactiver sa visibilité dans le schéma multi-cartes, et le bouton  pour autoriser ou interdire la modification de la valeur. Utilisez les commandes de police et Other pour configurer la police du texte, sa position dans le document et, pour le titre, la visibilité du nom du paramètre.

  • Lorsque le module est sélectionné, le tableau de la zone Entries de l’onglet General du panneau Properties est renseigné lorsque des entrées de module sont ajoutées au module – voir ci-dessous.

  • Utilisez les commandes de la zone Graphical de l’onglet General du panneau pour configurer l’affichage du module : sa taille (largeur et hauteur), l’épaisseur, le style et la couleur du trait de son contour, ainsi que sa couleur de remplissage. Les options d’épaisseur et de style de trait disponibles sont définies dans la zone Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document schématique multi-cartes.

  • Utilisez les commandes de l’onglet Parameters du panneau pour ajouter, modifier et supprimer des paramètres de module, et configurer leur visibilité dans l’espace de conception.  

Ajoutez d’autres modules et les liens vers leurs projets enfants au schéma multi-cartes, selon les besoins de la conception du système complet.

Les modules sont renseignés avec les données de conception des projets auxquels ils sont liés, en important les données de projet à l’aide des commandes suivantes, accessibles depuis les menus principaux ou le menu contextuel de l’espace de conception :

  • Design » Import From Child Projects – transfère les données de conception de tous les projets sources (enfants) vers les modules qui leur sont associés.

  • Design » Import From Selected Child Projects – transfère les données de conception des projets sources (enfants) correspondants pour le ou les modules actuellement sélectionnés.

Cette opération traite surtout les données de broches et de nets de chaque connecteur des projets enfants auquel le paramètre spécial System:Connector est associé (voir les détails ci-dessus). Une fois l’importation terminée, une entrée de module est automatiquement créée pour chacun de ces connecteurs sur la représentation graphique du bloc du module correspondant. L’entrée de connecteur est liée dynamiquement aux broches et aux nets du connecteur dans le projet enfant. Sélectionnez la représentation graphique d’une entrée de module dans l’espace de conception pour afficher ses détails, tels que les broches/nets de son connecteur, dans le panneau Properties. Tant que l’entrée n’est pas connectée à celle d’un autre module, la liste des composants/broches du panneau indique que le connecteur et ses broches ne sont pas accouplés.

 
  • Bien que les entrées soient placées automatiquement lors de l’importation des données des projets enfants, vous pouvez également placer une entrée de module manuellement en sélectionnant la commande Place » Entry dans les menus principaux.

  • Sélectionnez une entrée de module en cliquant sur sa représentation graphique, puis faites-la glisser le long du périmètre du module jusqu’à un emplacement approprié. Notez que le désignateur de l’entrée peut être déplacé indépendamment vers une autre position.

  • Vous pouvez également déplacer un groupe d’entrées de module en sélectionnant plusieurs entrées, puis en faisant glisser le groupe jusqu’à l’emplacement souhaité.

  • La couleur de l’entrée vous aide à la déplacer et à la placer correctement. Lorsqu’elle se trouve à l’extérieur d’un module, l’entrée est partiellement affichée et grisée, et vous ne pouvez pas la placer. Lorsqu’elle se trouve sur un module, l’entrée apparaît intégralement et en couleur, ce qui indique qu’elle peut être placée à cet endroit.

Lorsqu’une entrée est sélectionnée, utilisez le panneau Properties pour définir ses propriétés :

  • Utilisez les commandes de la zone Properties de l’onglet General du panneau pour modifier la valeur, la visibilité et le style du Designator de l’entrée, et choisir son Type (Male/Female). Cette zone du panneau indique également le nombre de broches du connecteur de l’entrée (Number of Pins) et le numéro d’identification attribué à cette entrée dans le module parent (Entry Number).

  • Activez l’option System Entry pour désigner l’entrée comme une connexion au niveau du système qui n’est pas câblée à un autre module, par exemple une entrée représentant une prise d’alimentation.

    Un projet multi-cartes enfant comporte un module dont une entrée a l’option System Entry activée.

    Lorsque les modifications sont importées dans le projet multi-cartes parent, ce connecteur d’entrée est ajouté comme entrée de module au module du projet enfant.

     
  • Lorsque l’entrée est raccordée par une connexion de type faisceau ou câble (en savoir plus), la zone Mated Component du panneau est renseignée avec les données du composant accouplé.

  • Dans la Mated Pins région du panneau, la colonne Pin répertorie les différentes broches du connecteur et leurs nets associés. Une fois cette entrée connectée, la colonne Mated Pin affiche la liste des broches correspondantes. De plus, une fois cette entrée connectée, l’onglet Addresses du panneau Properties affiche un tableau des chemins de connexion et des nets de l’entrée (en savoir plus).

  • Utilisez les commandes de l’onglet Parameters du panneau pour ajouter, modifier et supprimer les paramètres de l’entrée et configurer leur visibilité dans l’espace de conception.

Lorsque des entrées de module sont ajoutées à un module, le tableau de la région Entries sous l’onglet General du panneau Properties affiche ces entrées lorsque le module est sélectionné. La colonne Part(s) répertorie chaque entrée de module par le repère et le nom du connecteur d’entrée dans la conception source. Vous pouvez modifier ces informations pour plus de commodité : cette dénomination est locale à la conception multi-cartes et n’affecte pas les projets enfants sources.

  • La colonne Mated part(s) est renseignée lorsque l’entrée est reliée à une autre entrée de la conception multi-cartes au moyen d’une connexion. Pour plus d’informations, consultez la page Utilisation des connexions.

  • Dans la liste, vous pouvez rapidement basculer la visibilité du repère de l’entrée (  /  ) et son type (  /  ). Utilisez les boutons  et  pour, respectivement, ajouter une nouvelle entrée non définie au module et à la liste, et supprimer du module l’entrée sélectionnée dans la liste.

  • Utilisez les boutons  et  pour, respectivement, scinder la connexion sélectionnée dans la liste en deux entrées de module associées et réunir les entrées précédemment scindées en une seule entrée. Pour plus d’informations, consultez la page Utilisation des connexions.

Prise en charge des périphériques/composants externes

Cette fonctionnalité est disponible lorsque les options MBS.PlacePart et MBS.UseGeometryMaker sont activées dans la boîte de dialogue Advanced Settings.

Le document schématique multi-cartes prend en charge les périphériques/composants externes qui ne font pas partie des assemblages de cartes PCB enfants habituels (c’est-à-dire les composants « hors PCB »). Il peut s’agir, par exemple, d’interrupteurs externes, de capteurs et de tout autre module électronique tiers du commerce. Cette fonctionnalité repose sur la prise en charge de deux types d’objets :

  • Custom Part – une entité semblable à un module, qui permet d’associer un ou plusieurs composants de bibliothèque et qui est ajoutée au document schématique multi-cartes à l’aide de la commande Place » Custom Part des menus principaux. Lorsque la pièce personnalisée placée est sélectionnée dans l’espace de conception, utilisez la région Linked Components du panneau Properties pour ajouter des composants à la pièce personnalisée ou en supprimer, à l’aide des boutons  et , respectivement. Si la liste des composants associés contient des composants obsolètes de l’espace de travail, cliquez sur le bouton  pour les mettre à jour vers leurs dernières révisions. Une entrée est automatiquement ajoutée pour chaque composant associé.

  • Custom Connection – permet d’ajouter un seul composant de bibliothèque au document schématique multi-cartes en faisant glisser le composant souhaité depuis le panneau Components vers un espace libre de la feuille. Une entrée est automatiquement ajoutée pour chaque broche du composant.

    Vous pouvez également créer un symbole personnalisé pour un composant, spécifiquement destiné à être utilisé dans un document schématique multi-cartes. L’ajout de noms séparés par des virgules dans le champ Name des propriétés d’une broche permet de regrouper plusieurs broches dans des entrées. Vous obtenez ainsi des symboles visuellement plus épurés, comportant moins d’entrées, ce qui simplifie considérablement la connexion de ces composants.

    Javascript ID : MBS_CustomConn_MultiplePins_AD24_5

    Lors de la modification d’un symbole schématique, ajoutez plusieurs noms séparés par des virgules dans le champ Name d’une broche.

    Lorsque le composant est ajouté à une pièce personnalisée dans un schéma multi-cartes, une entrée est créée pour chaque broche du composant plutôt qu’une seule entrée pour le composant, et des entrées comportant plusieurs broches sont créées.

    Lorsque le composant est placé dans un schéma multi-cartes en tant que connexion personnalisée, des entrées comportant plusieurs broches sont créées.

Les composants de bibliothèque sont ceux disponibles dans votre espace de travail connecté et dans les bibliothèques locales disponibles. Une fois placés/définis, vous pouvez connecter les composants au reste de votre conception, par exemple à l’aide de connexions par câble et par faisceau.

Les composants associés définis au moyen de pièces personnalisées et/ou de connexions personnalisées ne sont pas automatiquement inclus dans la nomenclature globale du produit/système et ne sont pas représentés dans l’assemblage multi-cartes (*.MbaDoc).

Navigation croisée

Les commandes de navigation croisée disponibles dans le menu principal Design et dans le menu contextuel de l’espace de conception vous permettent de passer rapidement du document schématique multi-cartes aux éléments correspondants des projets enfants.

  • Pour accéder, par navigation croisée, depuis le module ou l’entrée actuellement sélectionné au document PCB ou au connecteur de ce document dans le projet de conception PCB référencé par ce module, utilisez la commande Design » Crossprobe to PCB/Multi-board. Si le module référence un document d’assemblage multi-cartes (*.MbaDoc) dans un projet multi-cartes source (*.PrjMbd), la navigation croisée mène alors au document d’assemblage multi-cartes.

  • Pour accéder, par navigation croisée, depuis le module ou l’entrée actuellement sélectionné au schéma de niveau supérieur ou au connecteur du schéma concerné dans le projet de conception PCB référencé par ce module, utilisez la commande Design » Crossprobe to Schematic.

  • Pour accéder, par navigation croisée, depuis le module ou l’entrée actuellement sélectionné à la carte, ou au connecteur de cette carte, dans le document d’assemblage multi-cartes (*.MbaDoc) du projet multi-cartes (*.PrjMbd), utilisez la commande Design » Crossprobe to MBA.

  • Pour accéder, par navigation croisée, depuis la connexion par faisceau actuellement sélectionnée dans le document schématique multi-cartes (*.MbsDoc) à un projet de faisceau associé (*.PrjHar), utilisez la commande Design » Crossprobe to Harness. Le document du schéma de câblage du projet de faisceau associé s’ouvre.

Lors d’une navigation croisée à partir d’une entrée de module, les objets ciblés dans le document schématique/PCB de destination sont affichés conformément aux options Highlight Methods définies sur la page System – Navigation de Preferences boîte de dialogue. La mise en surbrillance ne sera pas appliquée au document schématique multi-cartes.

Imprimer ou exporter au format PDF

Pour imprimer le document schématique multi-cartes actuellement actif, sélectionnez File » Print dans le menu principal (raccourci : Ctrl+P). La boîte de dialogue Print s’ouvre. La partie gauche de la boîte de dialogue présente un aperçu avant impression redimensionnable. Les options d’impression standard sont disponibles dans la partie droite. Elles permettent notamment de sélectionner une imprimante, de vérifier son emplacement, de consulter le nombre de documents actuellement dans la file d’attente d’impression, de définir le nombre de copies à imprimer, ainsi que le format et l’orientation des pages. Après avoir cliqué sur , les documents à imprimer sont envoyés à l’imprimante sélectionnée, conformément aux options définies.

La boîte de dialogue Print
La boîte de dialogue Print

Pour exporter un document schématique multi-cartes vers un fichier PDF, sélectionnez File » Export to PDF dans le menu principal.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents