Preparazione degli output e rilascio del progetto

Main page: Preparazione del progetto per la produzione

Ora che hai completato la progettazione e il layout del PCB, puoi generare la documentazione di output necessaria per la revisione, la fabbricazione e l'assemblaggio della scheda.

Poiché nella produzione dei PCB vengono utilizzate diverse tecnologie e metodologie, Altium Designer consente di generare numerosi tipi di output per scopi differenti, tra cui file Gerber, file ODB++, file Pick and Place, report della distinta base, ecc.

Aggiunta di un file Output Job al progetto

Main page: Preparazione dei dati di produzione con gli Output Job

Sebbene tu possa generare selettivamente gli output richiesti dai singoli editor (ad esempio, utilizzando i comandi nei sottomenu Fabrication Outputs e Assembly Outputs del menu principale File nell'editor PCB), Altium Designer supporta i file Output Job. Un file Output Job (o, in breve, «OutJob») memorizza le impostazioni per ciascun tipo di output. Un OutJob consente di configurare ciascun tipo di output, definendone il nome, il formato e la posizione di destinazione. Gli output possono essere generati direttamente da un OutJob oppure nell'ambito del processo integrato di rilascio del progetto.

  1. Fai clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e seleziona il comando Add New to Project » Output Job File dal menu contestuale. Si aprirà un nuovo file Output Job e la relativa voce comparirà collegata al progetto nel pannello Projects, sotto la voce Settings\Output Job Files.

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. Fai clic con il pulsante destro del mouse sulla voce dell'OutJob nel pannello Projects e seleziona il comando Save As. Si aprirà la finestra di dialogo Save As, pronta per salvare il documento nella stessa posizione del file di progetto. Digita il nome Fabrication nel campo File name e fai clic sul pulsante Save.

  3. L'aggiunta dell'OutJob ha modificato il progetto, quindi salvalo localmente facendo clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e selezionando Save.

Aggiunta e configurazione degli output di fabbricazione

Main page: Preparazione dei dati di fabbricazione

In questa parte del tutorial configurerai gli output necessari per fabbricare la scheda: i file Gerber e NC Drill. 

  1. Per aggiungere un nuovo output Gerber, fai clic sul collegamento Add New Fabrication Output nella sezione Fabrication Outputs dell'area Outputs dell'OutJob e seleziona Gerber Files » [PCB Document].

    Se selezioni l'opzione [PCB Document], il documento PCB del progetto verrà utilizzato automaticamente come sorgente dell'output. Questa scelta consente inoltre di copiare facilmente l'OutJob da un progetto all'altro, poiché non sarà necessario aggiornare questa impostazione. Se il progetto contiene più documenti PCB, dovrai selezionare la scheda specifica.

  2. Fai doppio clic sulla voce dell'output Gerber Files appena aggiunta. Si aprirà la finestra di dialogo Gerber Setup. Configura le opzioni nella finestra di dialogo come segue:

    1. Poiché la scheda è stata progettata utilizzando il sistema metrico, assicurati che l'opzione Units sia impostata su Millimeters.

    2. L'unità minima utilizzata sulla scheda è di 0,25 mm per il routing e le distanze di isolamento, ma poiché la maggior parte dei componenti ha il punto di riferimento nel proprio centro geometrico (ed è stata posizionata su una griglia di 1 mm), alcune piazzole si troveranno effettivamente su una griglia di 0,01 mm. Imposta l'opzione Decimal su 0.001 mm. In questo modo, la risoluzione dei dati di output sarà più che sufficiente per rappresentare queste posizioni sulla griglia.

    3. Fai clic sul pulsante  nella parte inferiore della scheda Layer to plot e scegli Select Used. Gli strati utilizzati nel progetto verranno abilitati nella colonna Plot della griglia soprastante.

  3. Fai clic su Apply per accettare le altre impostazioni predefinite e chiudere la finestra di dialogo Gerber Setup.

  4. Poiché la scheda presenta dei fori, è necessario generare anche un file NC Drill. Analogamente, aggiungi l'output NC Drill al file OutJob: fai clic sul collegamento Add New Fabrication Output nella sezione Fabrication Outputs dell'area Outputs dell'OutJob e seleziona NC Drill Files » [PCB Document].

  5. Fai doppio clic sulla voce dell'output NC Drill Files appena aggiunta per accedere alla finestra di dialogo NC Drill Setup. Per assicurarti che i file NC Drill vengano creati nello stesso formato dei file Gerber, imposta Units su Millimeters e Format su 4:3. Assicurati che l'opzione Coordinate Position sia impostata su Reference to relative origin.

  6. Fai clic su OK per accettare le altre impostazioni predefinite e chiudere la finestra di dialogo NC Drill Setup.

  7. Ora che le impostazioni Gerber e NC Drill sono configurate, il passaggio successivo consiste nel definirne i nomi e la posizione di destinazione. Per farlo, associali a un contenitore di output sul lato destro dell'OutJob. Per i singoli file con un proprio formato, utilizza un contenitore Folder Structure. Un nuovo OutJob include alcuni contenitori predefiniti. Seleziona la voce Folder Structure nell'elenco dei contenitori di output, quindi fai clic sui pulsanti di opzione per i file Gerber e NC Drill nella colonna Enabled dell'area Outputs per associare questi output al contenitore selezionato, come mostrato di seguito.

  8. L'ultimo passaggio consiste nel configurare il contenitore. Per farlo, fai clic sul collegamento Change nella voce del contenitore selezionato per aprire la finestra di dialogo Folder Structure settings. Nella parte superiore della finestra di dialogo sono presenti alcuni controlli utilizzati per configurare la posizione di destinazione degli output. Assicurati che il primo controllo sia impostato su Release Managed. La parte inferiore della finestra di dialogo mostrerà come cambiano i nomi e la struttura delle cartelle quando selezioni opzioni diverse.

  9. Fai clic su OK per chiudere la finestra di dialogo Folder Structure settings.

Aggiunta e configurazione di un report di validazione DRC

Main page: Preparazione dei report di validazione

Altium Designer include una serie di controlli di validazione che possono essere inclusi come output durante la generazione degli output. Ciascuno produce un file di report HTML. Durante il processo di rilascio del progetto, questi controlli verranno eseguiti prima della generazione degli altri output; se anche uno solo dei controlli di validazione non viene superato, il rilascio non andrà a buon fine.

  1. Per aggiungere un nuovo output di validazione DRC, fai clic sul collegamento Add Validation Output nella sezione Validation Outputs dell'area Outputs dell'OutJob e seleziona Design Rules Check » [PCB Document].

  2. Associa il report aggiunto al contenitore Folder Structure esistente. Seleziona la voce Folder Structure nell'elenco sul lato destro dell'OutJob, quindi fai clic sul pulsante di opzione per l'output Design Rules Check nella colonna Enabled dell'area Outputs.

  3. Salva localmente il file Output Job facendo clic con il pulsante destro del mouse sulla relativa voce nel pannello Projects e selezionando Save dal menu contestuale.

  4. Chiudi il file Output Job facendo clic con il pulsante destro del mouse sulla sua scheda nella parte superiore dell'area di progettazione e selezionando il comando Close Fabrication.OutJob dal menu contestuale. 

Aggiunta e configurazione degli output di assemblaggio

Main page: Configurazione della BOM nel Report Manager

Il file BOM di output viene generato tramite la finestra di dialogo Report Manager, un motore di generazione di report altamente configurabile che consente di produrre output in diversi formati, tra cui testo, CSV, PDF, HTML ed Excel. Alle BOM in formato Excel è inoltre possibile applicare un modello, scegliendo tra quelli predefiniti o utilizzandone uno proprio.

  1. Aggiungi un nuovo file OutJob al progetto facendo clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e selezionando il comando Add New to Project » Output Job File dal menu contestuale.

  2. Fai clic con il pulsante destro del mouse sulla voce OutJob nel pannello Projects e seleziona il comando Save As. Si aprirà la finestra di dialogo Save As, pronta per salvare il documento nella stessa posizione del file di progetto. Digita il nome Assembly nel campo File name e fai clic sul pulsante Save.

  3. Salva il progetto localmente facendo clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e selezionando Save.

  4. Per aggiungere un nuovo output BOM, fai clic sul collegamento Add New Report Output nella sezione Report Outputs dell'OutJob e seleziona Bill of Materials » [ActiveBOM Document].

  5. Fai doppio clic sull'output Bill of Materials aggiunto per aprire la finestra di dialogo Report Manager.

  6. Nell'area Export Options del riquadro Properties sul lato destro della finestra di dialogo, usa il menu a discesa File Format per selezionare Generic XLS (*.xls, *.xlsx, *.xlsm) e poi usa il menu a discesa Template per selezionare il modello BOM Template Single Supplier tra quelli presenti nel tuo Workspace.

  7. Fai clic su OK per salvare le modifiche e chiudere la finestra di dialogo Report Manager.

  8. Aggiungi un nuovo output Draftsman facendo clic sul collegamento Add New Documentation Output nella sezione Documentation Outputs dell'OutJob e selezionando Draftsman » All Draftsman Documents.

  9. Associa gli output BOM e Draftsman aggiunti al contenitore di output PDF esistente. Per farlo, seleziona la voce PDF nell'elenco dei contenitori di output sul lato destro dell'OutJob, quindi fai clic sui pulsanti di opzione degli output Bill of Materials e Draftsman nella colonna Enabled dell'area Outputs.

  10. Con la voce del contenitore PDF selezionata, fai clic sul collegamento Change al suo interno per aprire la finestra di dialogo PDF settings.

  11. Fai clic sulla voce Assembly.PDF nella parte superiore della finestra di dialogo PDF settings, seleziona Separate file for each output using output name e fai clic sul pulsante . Alla BOM e al disegno di output verrà assegnato il nome impostato per l'output nell'OutJob (rispettivamente Bill of Materials.pdf e Draftsman.pdf), visibile nell'area Preview della finestra di dialogo.

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. Fai clic su OK per chiudere la finestra di dialogo.

  13. Aggiungi un nuovo output Pick & Place facendo clic sul collegamento Add New Documentation Output nella sezione Documentation Outputs dell'OutJob e selezionando Generates pick and place files » [PCB Document].

  14. Fai doppio clic sull'output Generates pick and place files aggiunto per accedere alla finestra di dialogo Pick and Place Setup.

  15. Nell'area Output Setting nella parte inferiore sinistra della finestra di dialogo, imposta Units su Metric.

  16. Fai clic su OK per accettare le altre impostazioni predefinite e chiudere la finestra di dialogo Pick and Place Setup.

  17. Associa l'output Pick & Place aggiunto al contenitore di output Folder Structure esistente. Per farlo, seleziona la voce Folder Structure nell'elenco dei contenitori di output sul lato destro dell'OutJob, quindi fai clic sul pulsante di opzione dell'output Generates pick and place files nella colonna Enabled dell'area Outputs.

  18. Salva il file Output Job localmente facendo clic con il pulsante destro del mouse sulla sua voce nel pannello Projects e selezionando Save dal menu contestuale.

  19. Chiudi il file Output Job facendo clic con il pulsante destro del mouse sulla sua scheda nella parte superiore dell'area di progettazione e selezionando il comando Close Assembly.OutJob dal menu contestuale.

Rilascio del progetto

Main page: Rilascio del progetto di progettazione

Una volta configurata la documentazione di output nei file Output Job, il progetto è pronto per essere rilasciato nel Workspace connesso. Il processo di rilascio del progetto della scheda è automatizzato e consente di rilasciare i progetti delle schede senza i rischi associati alle procedure di rilascio manuali. Quando un progetto viene rilasciato, viene creata un'istantanea dei sorgenti di progettazione, che viene archiviata insieme a tutti gli output generati e rappresenta un prodotto tangibile realizzato a partire da quel progetto e venduto dall'azienda.

Il processo di rilascio viene eseguito tramite Project Releaser di Altium Designer, la cui interfaccia utente è disponibile in una vista dedicata: la vista Release. Il processo di rilascio è un flusso articolato in fasi; le voci sul lato sinistro della vista consentono di vedere a colpo d'occhio in quale fase ci si trova.

  1. Fai clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e seleziona il comando Project Releaser dal menu contestuale. La vista Release si aprirà come scheda documento separata.

  2. Nella prima fase, 1. Configure Server Release, specifichi i tipi di dati che desideri generare. Fai clic sui controlli Details all'estrema destra dell'intestazione di ciascun set di dati per visualizzare i dettagli di ciò che verrà generato da quel set.

  3. Fai clic sul pulsante  in basso a sinistra nella vista per accedere alla finestra di dialogo Project Release Options. Nella scheda Release Options della finestra di dialogo, assicurati che Managed - <WorkspaceName> sia selezionato come Release Target, che Fabrication sia assegnato al set Fabrication Data e che Assembly sia assegnato al set Assembly Data.

  4. Fai clic su OK per chiudere la finestra di dialogo e tornare alla vista Release.

  5. Assicurati che entrambe le opzioni Include Fabrication Data e Include Assembly Data for No Variant siano abilitate.

  6. Fai clic sul pulsante  in basso a destra nella vista per procedere.

  7. Si aprirà la finestra di dialogo Item Creation, con l'elenco degli elementi di rilascio di destinazione da creare nel Workspace. Seleziona l'opzione Create items per confermare la creazione degli elementi.

  8. Nella finestra di dialogo Project Modified che si apre, seleziona l'opzione Save and Commit changes per salvare le modifiche localmente e procedere al loro salvataggio nel Workspace.

  9. Nella finestra di dialogo Commit to Version Control che si apre, inserisci un commento significativo nel campo Comment (ad esempio, The project is ready for release), quindi fai clic sul pulsante .

  10. La fase successiva del processo di rilascio – 2. Validate Project – viene eseguita automaticamente perché il file Output Job Fabrication include il report di verifica delle regole di progettazione.

    Se una qualsiasi verifica di convalida non viene superata, il rilascio non andrà a buon fine. Per il rilascio del progetto di questo tutorial, ciò significa che il documento PCB contiene almeno una violazione DRC. In questo caso, interrompi il processo di rilascio con il pulsante  in basso a destra nella vista, apri il documento PCB, risolvi le violazioni DRC e quindi avvia nuovamente il processo di rilascio.

  11. Una volta completata correttamente la convalida, la fase successiva del processo di rilascio – 3. Generate Data – viene eseguita automaticamente. In questa fase vengono generati tutti gli altri output, definiti nei file OutJob assegnati agli elementi di dati inclusi, per produrre i dati da rilasciare negli elementi di destinazione corrispondenti nel Workspace.

  12. Una volta superate tutte le verifiche di convalida e generati i dati di output, la fase successiva del processo di rilascio – 4. Review Data – consente di esaminare i dati generati. Prosegui con il rilascio facendo clic sul pulsante  in basso a destra nella vista.

  13. Si aprirà la finestra di dialogo Confirm Release, che riepiloga le configurazioni del progetto che verranno rilasciate nel Workspace. Inserisci un Release Note (ad esempio, Initial Release) e fai clic su OK.

  14. Dopo aver confermato il rilascio nella fase precedente, si passa automaticamente alla fase successiva – 5. Upload Data. Questa mostra semplicemente l'avanzamento del caricamento dei dati nelle revisioni degli elementi di dati corrispondenti nel Workspace.

  15. La fase finale del processo – 6. Execution Report – fornisce un riepilogo del rilascio. Chiudi la vista di rilascio facendo clic sul pulsante  in basso a destra nella vista.

Progettazione collaborativa con un Workspace

Nella maggior parte dei casi, più persone sono coinvolte nella progettazione e nello sviluppo di un prodotto elettronico. Per svolgere queste attività in modo efficace, i membri del team di progettazione devono poter lavorare in modo collaborativo. Altium Designer, insieme a un Workspace connesso, supporta diverse funzionalità di progettazione collaborativa. Alcune sono elencate di seguito.

  • Project history – la vista dedicata History è una cronologia avanzata del progetto con una rappresentazione grafica che mostra in sequenza i principali eventi relativi al progetto: creazione, commit, rilasci, clonazioni e scambi MCAD. Per questi eventi sono disponibili varie azioni, ove applicabili (). Per accedere alla vista History di un progetto del Workspace da Altium Designer, fai clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e seleziona il comando History & Version Control » Show Project History dal menu contestuale.

    Per saperne di più: Cronologia del progetto, Project History (Workspace Altium 365, Workspace Enterprise Server)

  • Web Viewer – l'interfaccia Web Viewer del Workspace offre accesso universale ai documenti del progetto tramite un browser standard. Molto più di un semplice visualizzatore basato su browser, la sua tecnologia avanzata consente agli utenti di navigare nella struttura del progetto, interagire con i documenti di progettazione, evidenziare aree o oggetti per aggiungere commenti, nonché cercare, eseguire il cross-probing, selezionare e ispezionare componenti e reti nell'intero progetto. Per accedere al Web Viewer di un progetto del Workspace da Altium Designer, fai clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e seleziona il comando Show in Web Browser dal menu contestuale.

    Per saperne di più: Web Viewer (Piattaforma Altium 365, Workspace Enterprise Server)

  • Document commenting – un commento è una nota aggiunta da un utente e assegnata a un punto, un oggetto o un'area specifici, a seconda dei casi, in una vista dati supportata; gli altri utenti possono rispondere alla nota. I commenti favoriscono la collaborazione tra gli utenti senza modificare i dati condivisi, poiché vengono memorizzati dal Workspace indipendentemente da tali dati. I commenti inseriti nell'interfaccia Web Viewer nelle posizioni indicate di seguito diventano disponibili in Altium Designer e viceversa. In Altium Designer, la funzionalità di commento è gestita tramite il pannello Comments and Tasks ().

    Per saperne di più: Commenti sui documenti, Web Viewer (Piattaforma Altium 365, Workspace Enterprise Server)

  • Sharing a project – una volta salvato un progetto nel Workspace, puoi stabilire quali utenti possano effettivamente accedervi per la progettazione collaborativa e/o la revisione del progetto. A tale scopo, occorre condividere il progetto o, più precisamente, configurarne le autorizzazioni di accesso. In Altium Designer, la condivisione del progetto è gestita tramite la finestra di dialogo Share (), accessibile facendo clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects e selezionando il comando Share dal menu contestuale.

    Per saperne di più: Condivisione di un progetto, Workspace Projects (Workspace Altium 365, Workspace Enterprise Server)

Congratulazioni! Hai iniziato con un foglio schematico vuoto e sei arrivato a un PCB completo, con gli output rilasciati nel Workspace: hai completato l'intero processo di progettazione in Altium Designer!

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents