アイテムの参照
Altium Essentials: Workspace Folder Structure
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- フォルダー、アドレスバー、検索、配置済みコンポーネントからの直接リンクを使ってアイテムを見つける方法を学びます。
- Workspaceアイテムの作成、編集、移動、コピー、レビューに使用するコマンドをご紹介します。
- アイテムのリビジョンや関連コンテンツ、特定のリビジョンの使用箇所を確認する方法を理解します。
Workspace内のコンテンツには、いくつかの方法でアクセスできます。
- ExplorerパネルのServer Folders領域で、内容を確認したいフォルダーをクリックします。
- パネル上部のアドレスバーを使用します。アドレスバーには、現在参照しているフォルダーと、そのフォルダーまでの階層パスが表示されます。
-
Workspaceの検索機能を使用します。コメントや説明に基づくキーワードを入力し、Enterを押すか、虫眼鏡アイコンをクリックします。Workspace全体が検索され、一致するアイテムが検索結果として一覧表示されます。
選択したフォルダーの内容は、パネルのアイテム領域に表示されます。
アイテム領域のコマンド
-
Place – 現在選択しているアイテムリビジョンのインスタンスを、配置がサポートされている場所に配置します。たとえば、アクティブな回路図シートにコンポーネントや管理対象シートを配置できます。コンポーネントのシンボルまたは管理対象シートのシンボルがカーソルに追従して表示され、配置できる状態になります。
-
Edit – コンポーネント、管理対象シート、テンプレートなどのアイテムを、対応するエディターで開きます。編集後は、アイテムの新しいリビジョンとしてWorkspaceに保存されます。
-
Upload – 新規リビジョンの作成ダイアログを使用して、アイテムを構成するオブジェクトをアップロードします。たとえば、管理対象回路図シートに回路図ドキュメントを、出力ジョブテンプレートにOutJobファイルをアップロードできます。
-
Operations – 次のコマンドを含むサブメニューにアクセスします。
-
Add to Content Cart – Content Cartダイアログを使用して、現在選択しているアイテムをContent Cartに追加します。
-
Download – Browse for Folderダイアログを使用して、現在選択しているアイテムをダウンロードし、別の場所に保存します。
-
Change state – 状態の一括変更ダイアログを開き、現在選択しているアイテムリビジョンの状態を変更します。
-
Make a copy – 現在選択しているアイテムリビジョンをコピーします。コピーしたアイテムは、対応するエディターで編集用に開かれます。たとえば、コンポーネントを複製した場合はコンポーネントエディターで開かれます。
-
Change component type – Choose component typeダイアログにアクセスし、選択したコンポーネントの
ComponentTypeパラメーターを別のタイプに設定します。 -
Export Grid – データエクスポート用の列を選択ダイアログを開き、エクスポートする列データを指定します。エクスポートされるセミコロン区切りのCSVファイルには、現在のリストのグリッドビューにあるすべてのアイテムのデータが含まれます。
-
-
Create Item – 現在のフォルダーに対応するタイプ(コンポーネント、テンプレート、管理対象回路図シートなど)の新しいコンテンツアイテムを追加し、対応するエディターで開きます。別のタイプのアイテムを作成するには、Other Item Typeサブオプションを選択し、新規アイテムの作成ダイアログのContent Typeメニューから別のタイプを選択します。
-
Delete Item – アイテムを削除します。
-
History – 現在選択しているアイテムの詳細ビューにアクセスします。このビューは、ソフトウェア内の新しいタブとして開きます。アイテムビューには、特定のアイテムのリビジョン履歴とライフサイクル履歴の詳細に加え、そのアイテムを構成するすべての要素が表示されます。このビューにはタイムラインも含まれます。タイムラインを使用すると、そのアイテムのリビジョンレベルまたはライフサイクル状態が変更された正確な日時と、変更を行ったユーザーを確認できます。
-
Properties – View Item Propertiesダイアログにアクセスし、現在選択しているアイテムのプロパティを表示します。そのアイテムのリビジョンがまだ一度もリリースされていない場合は、プロパティを変更できます。
-
Navigate To <item> – Item ID列から、選択したアイテムのプレビューをExplorerパネルで開きます。
Workspace内の各アイテムリビジョンについて、Explorerパネルでは、そのリビジョンのさまざまな側面を必要に応じて参照できます。パネル下部のタブを使用し、そのリビジョンの1つ以上のビューを切り替えて参照します。
デフォルトのビューはPreviewです。ほかのタブをクリックすると、さらに詳しい情報を表示できます(使用できるタブは、現在選択しているアイテムのタイプによって異なります)。
-
Preview – 選択したアイテムの全体像を表示します。これには、ドキュメントやモデルのグラフィック表示、パラメーターデータ、関連するサブアイテムなどが含まれます。ビューは、アイテムのタイプや、コンポーネントおよびプロジェクトでClassic表示モードと解釈表示モード(上記参照)のどちらが選択されているかに応じて、自動的に設定されます。
-
Lifecycle – アイテムのリビジョンレベルとライフサイクルの状態変化を確認します。ライフサイクルは、アイテムタイプに割り当てられた状態に従って進めることができます。たとえば、コンポーネントの場合はコンポーネントのライフサイクル状態(
Draft、Prototypeなど)に従います。 -
Children – アイテムの構成要素を表示します。たとえば、リリース済みプロジェクトの製造パッケージ(
FAB-<project name>)に含まれる生成済みの製造用ドキュメント(Gerber、NC Drillなど)や、管理対象回路図シートで使用される回路図ドキュメントおよびコンポーネントを表示できます。 -
Part Choices – コンポーネントに割り当てられた部品選択(関連するサプライヤーデータを含むメーカー部品エントリ)を表示または追加します。
-
Where-used – 選択したアイテムのリビジョンが、他のWorkspaceアイテムで使用されている場所を表示します。たとえば、現在選択されているコンポーネントを使用しているプロジェクトなどです。
-
Origin – Altiumのクラウドリソースから取得したコンポーネントなど、アイテムの取得元を表示します。可能な場合は、取得元アイテムの詳細情報も表示されます。
-
Data Sheet – 選択したコンポーネントとともに保存されているファイル形式のデータシートを表示または追加します。

関連するビューを使用して、アイテムのリビジョンのさまざまな側面を参照できます。
クリック可能なURL
Workspaceの使いやすさをさらに向上させるため、Explorerパネルはクリック可能なURLに対応しています。この機能は、次のような関連するさまざまな箇所で利用できます。
- 値がURLであるコンポーネントパラメーターをクリックすると、外部Webブラウザーでリンク先のページが開きます。
- コンポーネントのサプライチェーンデータ内のURLをクリックすると、外部Webブラウザーでリンク先のページが開きます。
- PCB製造データアイテム、PCB実装データアイテム、またはPCBプロジェクト設計アイテムのリビジョンのPreviewアスペクトビュータブにあるReleased Documents領域でドキュメントをクリックすると、そのドキュメントが開きます。
クリック可能なサプライチェーンのURL
Workspace内の各リリース済みコンポーネントには、部品選択という形式でサプライチェーンデータを定義できます。これらはPart Choicesアスペクトビュータブに表示されます。実際のサプライチェーン情報は、WorkspaceのローカルのPart Catalogと、関連する部品ソースから取得されます。部品ソースには、Altium Parts Providerの集約部品データベース(有効なサプライヤーに接続し、そこから部品情報を収集するもの)、またはリンクされたローカル部品データベース(Custom Database Parts Providerとして構成された部品ソースで、使用しているWorkspaceの種類でサポートされている場合)があります。各部品選択に関連するクリック可能なURLは次のとおりです。
- メーカー名とメーカー部品番号 – メーカーのサイトへのクリック可能なリンクで、そのメーカー部品の詳細情報を確認できます。
- サプライヤー部品番号(SPNタイル内) – サプライヤーのサイトにある該当部品へのクリック可能なリンクです。
URLをクリックすると、外部ブラウザーで開きます。
クリック可能なリリース済みドキュメントのURL
基板設計プロジェクトをリリースすると、製造用のベア基板(PCB製造データアイテム)でも実装済み基板(PCB実装データアイテム)でも、その設計の任意のドキュメントを開くことができます。まず、目的のプロジェクトのフォルダーをクラシックビューで表示していることを確認します(Explorerパネルの右上にある
ボタンをクリックし、コンテキストメニューから Classic Viewコマンドを選択します)。該当するアイテムのリビジョンに移動し、そのリビジョンのPreviewアスペクトビュータブに切り替えます。次に、Released Documents領域で生成された出力ドキュメントにカーソルを合わせると、URLを示す手の形のカーソルに変わります。これらのURLのいずれかをクリックすると、そのドキュメントが開きます。Altium Designerのネイティブドキュメントは、Altium Designer内で直接表示用に開かれます。 出力PDFファイルやExcel形式のBOMなど、Altium Designer以外のドキュメントは、対応するソフトウェアアプリケーションがインストールされていれば、そのアプリケーションで直接開かれます。

クリックしてリリース済みドキュメントを開きます。Altium Designerのネイティブ形式ではないドキュメントは、対応するアプリケーションが利用可能な場合、そのアプリケーションで開かれます。
リビジョンの表示
アイコンをクリックしてリビジョン選択用のドロップダウンを開くと、パネルに表示するリビジョンを設定できます。
- Load all pages – すべてのリビジョンを読み込むには、これを選択します。
- Show Hidden Revisions – 非表示のリビジョンを表示するには、これを選択します。
- Show only latest – 最新のリビジョンのみを表示するには、これを選択します。
- View – アイテムをClassic Viewまたは専用ビュー(Components View/Project View)のどちらで表示するかを選択します。
フォルダーコンテンツの読み込み
ExplorerパネルのServer Folders構造領域でフォルダーをクリックすると、該当する場合は、最初にそのフォルダーのコンテンツの一部のみが読み込まれます。これにより、フォルダーの初回読み込み時間が大幅に短縮されます。最初に読み込まれたコンテンツの末尾までスクロールすると、フォルダーのコンテンツが追加で読み込まれます。
非表示のリビジョンの表示
Related page: Workspaceのライフサイクル定義の設定 – アイテムリビジョンの表示と適用範囲の制御
Visible in Vault panels属性が無効になっているライフサイクルステートに移行したアイテムリビジョンは、デフォルトではExplorerパネルに表示されません。また、それがアイテムの最新リビジョンである場合、そのアイテムのエントリ全体が実質的に非表示になります。この表示状態はステートレベルで定義されていますが、すべてのアイテムに対して一括で上書きできます。
現在非表示になっているすべてのアイテムリビジョンを表示するには、パネルのItems領域の右上にある
コントロールをクリックし、表示されるメニューでShow Hidden Revisionsオプションを有効にします。

Explorerパネルでコンテンツを参照しているときに、非表示のアイテムリビジョンを表示します。画像にカーソルを合わせると、結果を確認できます。
最新のアイテムリビジョンのみを表示
Workspace内のコンテンツは、時間の経過とともに更新されることがあり、変更のたびに、変更されたデータを格納する新しいリビジョンが作成されます。アイテムを参照する際、通常必要なのは最新のリビジョンのみです。それ以前のリビジョンは、設計者の視界を煩雑にするノイズになりがちです。これを軽減するため、Explorerパネルではデフォルトでアイテムの最新リビジョンのみが表示されます。
Explorerパネルでアイテムのすべてのリビジョンを表示するには、パネルのItems領域の右上にある
コントロールをクリックし、表示されるメニューでShow only latestオプションを無効にします。

デフォルトでは、Explorerパネルにはアイテムの最新リビジョンのみが表示されます。画像にカーソルを合わせると、このコマンドを無効にした例を確認できます。
専用ビュー
このパネルには、コンポーネントとプロジェクトに適用される2つの専用ビューも用意されています。パネルの表示オプションがClassic Viewモードに変更されていない限り、コンポーネントまたはプロジェクトを選択すると、ビューは自動的にこの形式に切り替わります。
これらの特別なアイテムタイプのいずれかを選択すると、表示メニューからクラシックビューまたは専用ビュー(Component View / Project View)を選択できます。
- Classic View – アイテムとそのリビジョンのみを表示するには、これを選択します。
- Components View – リビジョンと、表示用に整理されたコンポーネントデータを表示するには、これを選択します。詳細については、コンポーネントビューを参照してください。
- Project View – プロジェクトリリースデータとプロジェクトパラメーターにアクセスできる、構造化されたグラフィカルなプロジェクト表示を使用するには、これを選択します。詳細については、プロジェクトビューを参照してください。
アイテムリビジョンの比較
Workspaceでは、Altium Designerのネイティブファイル形式の比較技術を活用し、サポートされている各種コンテンツタイプについて、同じアイテムまたは異なるアイテムの2つのリビジョンを、Explorerパネルから直接、視覚的に比較できます。次のコンテンツタイプのアイテムリビジョンを比較できます。
- コンポーネントアイテム
- シンボルアイテム
- フットプリントアイテム
- 管理対象回路図シートアイテム
- 回路図テンプレートアイテム
- PCB製造データアイテム
- PCB実装データアイテム
- PCBプロジェクト設計アイテム
Explorerパネルで該当するフォルダーに移動し、比較する2つのアイテムリビジョンを選択してから、右クリックし、コンテキストメニューからOperations » Compareを選択します。
2つのコンポーネントアイテムリビジョンの比較
2つのコンポーネントアイテムリビジョンを比較する場合、Compareをクリックすると、次の処理が順に実行されます。
- 参照先のフットプリントアイテムリビジョンが比較されます。
- 参照先のシンボルアイテムリビジョンが比較されます。
- 2つのコンポーネントアイテムリビジョンのパラメトリックデータが比較されます。
比較結果はCompare component revisionsダイアログに表示されます。
ダイアログは3つのセクションに分かれており、パラメトリックデータ、フットプリント、シンボルの比較結果が表示されます。パラメーターの値が一致しない場合は、背景が赤みがかった色で強調表示されます。フットプリントとシンボルについては、同一または同一ではないと表示されます。
シンボルアイテムの2つのリビジョンの比較
シンボルアイテムの2つのリビジョンを比較する場合、Compareをクリックするとグラフィカルな比較が行われ、検出された差異がDifferencesパネルに一覧表示されます。2つのリビジョンのSchLibドキュメントがデザインスペース内で開きます。デザインエディターウィンドウに並べて表示することで、差異をグラフィカルに確認できます。検出された差異の最上位フォルダーをクリックすると、両方のドキュメントでその差異が同時にハイライト表示されます。
フットプリントアイテムの2つのリビジョンの比較
フットプリントアイテムの2つのリビジョンを比較する場合、Compareをクリックするとグラフィカルな比較が行われ、検出された差異がCompare Componentsダイアログに一覧表示されます。

フットプリントの2つのリビジョンの比較例。ソースライブラリはデザインスペース内では開かれません。ここでは、実際に存在する差異を示すためにフットプリントのプレビューを掲載しています。
フットプリントは正方形のセルに分割され、各セルの差異が解析されます。差異があるセルはフルカラーで表示され、差異がハイライト表示されます。レイヤータブには、比較対象の各レイヤーで差異があるプリミティブオブジェクトの数が表示されます。タブをクリックすると、差異をより詳しく確認できます。
グリッドデータのエクスポート
Explorerパネルでは、グリッド表示のデータをcsv形式またはxls形式のファイルにエクスポートできます。この機能は、たとえば次の場所で利用できます。
- コンポーネントアイテムのグリッド(クラシック表示とコンポーネント表示の両方)。
- アイテムのグリッド。
- Previewアスペクト表示タブのリンクモデルのグリッド(選択したコンポーネントアイテムが対象)。
- 検索結果のグリッド。
- Where-usedアスペクト表示タブのアイテムのグリッド。
- Childrenアスペクト表示タブのアイテムのグリッド。
グリッド内を右クリックし、コンテキストメニューからOperations » Export Gridコマンドを選択します。Select columns for data exportダイアログが表示されます。列リストのチェックボックス、または Select All / Deselect All ボタンを使用して、エクスポートするデータの有効/無効を切り替えます。 このダイアログにはグリッドで使用可能なすべての列が含まれ、現在パネルに表示されている列は、デフォルトでエクスポート対象として有効になっています。OKをクリックすると、標準のWindowsのSave Asダイアログが表示されます。このダイアログで、エクスポートするファイルの保存先と名前を指定します。Save as typeフィールドで、ファイル形式をカンマ区切り値ファイル(*.csv)またはExcelファイル(*.xls)から選択します。

選択したコンポーネントアイテムのリビジョンにリンクされたモデルのデータを、Excel形式のファイルにエクスポートする例。
プロジェクト表示
パネルのProject Viewでは、選択したプロジェクトがプロセス指向の表示形式で示され、関連するプロジェクトデータやそのリリースに直接アクセスできます。
Project Viewには、プロジェクトのプレビュー、基本的な説明、パラメーター、リリースが表示されます。
Releases領域には、選択したプロジェクトに関連付けられたプロジェクトリリースがまとめて表示され、各リリースとその構成パッケージの概要が含まれます。この領域の
ボタンをクリックすると、Batch state changeダイアログが開きます。このダイアログを使用すると、同じリリースに関連する複数のアイテムのライフサイクル状態を、1回のバッチ処理でまとめて変更できます。
プロジェクト表示の右上には、次のコントロールがあります。
- Open – 対象のプロジェクトをAltium Designerで開きます。
- Open in Web – Workspaceのブラウザーベースのインターフェースでプロジェクトを開きます。
- Share – 共有ダイアログを開きます。このダイアログでは、ソフトウェア内から直接、世界中のどこにいる相手とも設計プロジェクトを共有できます。
-
– ボタンをクリックすると、次のコマンドにアクセスできます。
-
コピーを作成 – Create Project Copyダイアログを開きます。このダイアログでは、プロジェクトをコピーし、接続先のWorkspaceに保存できます。デフォルトでは、元のプロジェクト名に接尾辞
' - Copy'が追加されます。 - History – プロジェクトの履歴ビューを開きます。このビューには、そのプロジェクトのCADを中心とした詳細管理ページからアクセスできます。
- Delete – プロジェクト、そのフォルダー、およびプロジェクトのすべてのコンテンツを削除します。削除が完了する前に、確認を求められます。
-
コピーを作成 – Create Project Copyダイアログを開きます。このダイアログでは、プロジェクトをコピーし、接続先のWorkspaceに保存できます。デフォルトでは、元のプロジェクト名に接尾辞










