アイテムの参照
Altium Essentials: Workspace Folder Structure
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Workspace内のコンテンツは、いくつかの方法で参照できます。
- ExplorerパネルのServer Folders領域で、内容を確認したいフォルダーをクリックします。
- パネル上部のアドレスバーを使用します。アドレスバーには、現在参照しているフォルダーと、そのフォルダーまでの階層パスが表示されます。
-
Workspaceの検索機能を使用します。コメントや説明に含まれるキーワードを入力し、Enterを押すか、虫眼鏡アイコンをクリックします。Workspace全体が検索され、一致するアイテムが検索結果として一覧表示されます。
選択したフォルダーの内容は、パネルのItems領域に表示されます。
Items領域のコマンド
-
Place – 現在選択されているアイテムリビジョンのインスタンスを、配置がサポートされている場所に配置します。たとえば、アクティブな回路図シートにコンポーネントや管理対象シートを配置できます。コンポーネントのシンボルまたは管理対象シートのシンボルがカーソルに追従して表示され、配置できる状態になります。
-
Edit – コンポーネント、管理対象シート、テンプレートなどのアイテムを、対応するエディターで開きます。編集後は、そのアイテムの新しいリビジョンとしてWorkspaceに保存されます。
-
Upload – Create New Revisionダイアログを使用して、アイテムの構成要素となるオブジェクトをアップロードします。たとえば、Managed Schematic Sheetに回路図ドキュメントを、Output Job TemplateにOutJobファイルをアップロードできます。
-
Operations – 次のコマンドを含むサブメニューを開きます。
-
Add to Content Cart – Content Cartダイアログを使用して、現在選択されているアイテムをContent Cartに追加します。
-
Download – Browse for Folderダイアログを使用して、現在選択されているアイテムをダウンロードし、別の場所に保存します。
-
Change state – Batch State Changeダイアログを開き、現在選択されているアイテムリビジョンの状態を変更します。
-
Make a copy – 現在選択されているアイテムリビジョンをコピーします。コピーしたアイテムは、対応するエディターで編集用に開かれます。たとえば、コンポーネントを複製する場合は、Component Editorで開かれます。
-
Change component type – Choose component typeダイアログを開き、選択したコンポーネントの
ComponentTypeパラメーターを別のタイプに設定します。 -
Export Grid – Select columns for data exportダイアログを開き、エクスポートする列データを指定します。エクスポートされるセミコロン区切りのCSVファイルには、現在のリストのグリッドビューにあるすべてのアイテムのデータが含まれます。
-
-
Create Item – 現在のフォルダーに対応するタイプ(コンポーネント、テンプレート、管理対象回路図シートなど)の新しいコンテンツアイテムを追加し、対応するエディターで開きます。別のタイプのアイテムを作成するには、Other Item Typeサブオプションを選択し、Create New ItemダイアログのContent Typeメニューから別のタイプを選択します。
-
Delete Item – アイテムを削除します。
-
History – 現在選択されているアイテムの詳細ビューを、ソフトウェア内の新しいタブとして開きます。Item Viewには、特定のアイテムのリビジョン履歴とライフサイクル履歴が詳細に表示されるほか、そのアイテムを構成するすべての要素も表示されます。このビューにはタイムラインも含まれます。タイムラインを使用すると、そのアイテムのリビジョンレベルまたはライフサイクル状態が変更された正確な日時と、変更を行ったユーザーを確認できます。
-
Properties – View Item Propertiesダイアログを開き、現在選択されているアイテムのプロパティを確認します。そのアイテムのリビジョンがまだ一度もリリースされていない場合は、プロパティを変更できます。
-
Navigate To <item> – Item ID列から、選択したアイテムのプレビューをExplorerパネルで開きます。
Workspace内の各アイテムリビジョンについて、Explorerパネルでは、該当するリビジョンのさまざまな情報を参照できます。パネル下部のタブを使用して、そのリビジョンの1つ以上のビューを切り替えます。
デフォルトのビューはPreviewです。ほかのタブをクリックすると、さらに詳しい情報を確認できます(使用できるタブは、現在選択されているアイテムのタイプによって異なります)。
-
Preview – 選択したアイテムの情報をまとめて表示します。ドキュメントやモデルのグラフィック表示、パラメーターデータ、関連するサブアイテムなどが含まれます。ビューは、アイテムのタイプや、コンポーネントおよびプロジェクトでClassic表示モードと解釈表示モード(上記参照)のどちらが選択されているかに応じて、自動的に設定されます。
-
Lifecycle – アイテムのリビジョンレベルとライフサイクルの状態変更を確認します。ライフサイクルは、そのアイテムタイプに割り当てられた状態に沿って進めることができます。たとえば、コンポーネントの場合は、コンポーネントのライフサイクル状態(
Draft、Prototypeなど)を使用します。 -
Children – アイテムの構成要素を表示します。たとえば、リリース済みプロジェクトの製造パッケージ(
FAB-<project name>)に含まれる生成済みの製造ドキュメント(Gerber、NC Drillなど)や、管理対象回路図シートで使用されている回路図ドキュメントおよびコンポーネントを確認できます。 -
Part Choices – コンポーネントに割り当てられている部品の選択肢(サプライヤーデータが関連付けられたメーカー部品エントリ)を表示または追加します。
-
Where-used – 選択したアイテムのリビジョンが、他のWorkspaceアイテムで使用されている箇所を表示します。たとえば、現在選択しているコンポーネントを使用しているプロジェクトなどです。
-
Origin – アイテムの取得元を表示します。たとえば、Altiumのクラウドリソースから取得したコンポーネントなどが対象です。可能な場合は、取得元アイテムの詳細情報がすべて表示されます。
-
Data Sheet – 選択したコンポーネントとともに保存されているファイル形式のデータシートを表示または追加します。

関連するビューを使用して、アイテムのリビジョンのさまざまな側面を参照できます。
クリック可能なURL
Workspaceの使いやすさをさらに向上させるため、Explorerパネルはクリック可能なURLに対応しています。この機能は、次のようなさまざまな関連箇所で利用できます。
- 値がURLであるコンポーネント パラメーターをクリックすると、外部のWebブラウザーでリンク先のページが開きます。
- コンポーネントのサプライチェーンデータに含まれるURLをクリックすると、外部のWebブラウザーでリンク先のページが開きます。
- PCB製造データアイテム、PCB実装データアイテム、またはPCBプロジェクト設計アイテムのリビジョンのPreviewアスペクトビュータブにあるReleased Documents領域でドキュメントをクリックすると、そのドキュメントが開きます。
クリック可能なサプライチェーンのURL
Workspace内の各リリース済みコンポーネントには、部品の選択肢としてサプライチェーンデータを定義できます。これらはPart Choicesアスペクトビュータブに表示されます。実際のサプライチェーン情報は、WorkspaceのローカルのPart Catalogと、関連する部品ソースから取得されます。部品ソースには、Altium Parts Providerの集約部品データベース(有効なサプライヤーと連携し、各サプライヤーから部品情報を収集するもの)、またはリンクされたローカル部品データベース(カスタムデータベース部品プロバイダーとして設定された部品ソースで、お使いのWorkspaceの種類が対応している場合)を使用します。各部品の選択肢に関連付けられたクリック可能なURLは、次のとおりです。
- メーカー名とメーカー部品番号 – メーカーのサイトへのクリック可能なリンクで、そのメーカー部品の詳細情報を確認できます。
- サプライヤー部品番号(SPNタイル内) – サプライヤーのサイトにある該当部品へのクリック可能なリンクです。
URLをクリックすると、外部ブラウザーで開きます。
クリック可能なリリース済みドキュメントのURL
基板設計プロジェクトを、製造用のベアボード(PCB製造データアイテム)または実装済み基板(PCB実装データアイテム)としてリリースした後、その設計の任意のドキュメントを開くことができます。まず、対象プロジェクトのフォルダーがクラシックビューで表示されていることを確認します(Explorerパネルの右上にある
ボタンをクリックし、コンテキストメニューから Classic Viewコマンドを選択します)。該当するアイテムのリビジョンに移動し、そのリビジョンのPreviewアスペクトビュータブに切り替えます。次に、Released Documents領域で生成された出力ドキュメントにカーソルを合わせると、URLを示す手の形のカーソルに変わります。これらのURLをクリックすると、そのドキュメントが開きます。Altium Designerネイティブのドキュメントは、Altium Designer内で直接開いて表示されます。 出力PDFファイルやExcel形式のBOMなど、Altium Designer以外のドキュメントは、対応するソフトウェアアプリケーションがインストールされている場合、そのアプリケーションで直接開きます。

クリックしてリリース済みドキュメントを開きます。Altium Designerネイティブではない形式のドキュメントは、対応するアプリケーションが利用可能な場合、そのアプリケーションで開きます。
リビジョンの表示
アイコンをクリックしてリビジョン選択用のドロップダウンを開くと、パネルに表示するリビジョンを設定できます。
- Load all pages – すべてのリビジョンを読み込む場合に選択します。
- Show Hidden Revisions – 非表示のリビジョンを表示する場合に選択します。
- Show only latest – 最新のリビジョンのみを表示する場合に選択します。
- View – アイテムをClassic Viewで表示するか、専用ビュー(Components View/Project View)で表示するかを選択します。
フォルダー内容の読み込み
ExplorerパネルのServer Folders構造領域内でフォルダーをクリックすると、該当する場合、そのフォルダーの内容の一部のみが最初に読み込まれます。これにより、フォルダーの初回読み込み時間が大幅に短縮されます。最初に読み込まれた内容の末尾までスクロールすると、フォルダーの内容が追加で読み込まれます。
非表示のリビジョンの表示
Related page: Workspaceのライフサイクル定義の設定 – アイテムリビジョンの表示と適用の制御
Visible in Vault panels属性が無効になっているライフサイクル状態に移行したアイテムリビジョンは、デフォルトではExplorerパネルに表示されません。また、それがアイテムの最新リビジョンである場合、そのアイテムのエントリ全体が実質的に非表示になります。この表示状態は状態レベルで定義されますが、すべてのアイテムに対して一括で上書きできます。
現在非表示になっているすべてのアイテムリビジョンを表示するには、パネルのItems領域の右上にある
コントロールをクリックし、表示されるメニューでShow Hidden Revisionsオプションを有効にします。

Explorerパネルでコンテンツを参照しながら、非表示のアイテムリビジョンを表示します。画像にカーソルを合わせると、結果を確認できます。
最新のアイテムリビジョンのみの表示
Workspace内のコンテンツは、時間の経過とともに更新されることがあり、変更のたびに、変更後のデータを格納する新しいリビジョンが作成されます。アイテムを参照する際、通常必要なのは最新のリビジョンだけです。それ以前のリビジョンは、設計者の視界を煩雑にするノイズになりがちです。これを軽減するため、Explorerパネルではデフォルトでアイテムの最新リビジョンのみが表示されます。
Explorerパネルでアイテムのすべてのリビジョンを表示するには、パネルのItems領域の右上にある
コントロールをクリックし、表示されるメニューでShow only latestオプションを無効にします。

デフォルトでは、Explorerパネルにはアイテムの最新リビジョンのみが表示されます。画像にカーソルを合わせると、このコマンドを無効にした例を確認できます。
専用ビュー
このパネルには、コンポーネントとプロジェクトに対応した2つの専用ビューも用意されています。パネルの表示オプションがClassic Viewモードに変更されていない限り、コンポーネントまたはプロジェクトを選択すると、ビューが自動的にこの形式に切り替わります。
対象の特殊なアイテムタイプを選択すると、表示メニューからクラシックビューまたは専用ビュー(Component View / Project View)を選択できます。
- Classic View – アイテムとそのリビジョンのみを表示する場合に選択します。
- Components View – リビジョンと、見やすく整理されたコンポーネントデータを表示する場合に選択します。詳細については、コンポーネントビューを参照してください。
- Project View – プロジェクトリリースデータやプロジェクトパラメーターにアクセスできる、構造化されたグラフィカルなプロジェクト表示を使用する場合に選択します。詳細については、プロジェクトビューを参照してください。
アイテムリビジョンの比較
Workspaceでは、Altium Designerのネイティブファイル形式の比較技術を活用し、対応するさまざまなコンテンツタイプについて、同じアイテムまたは異なるアイテムの2つのリビジョンを、Explorerパネルから直接、視覚的に比較できます。次のコンテンツタイプのアイテムリビジョンを比較できます。
- コンポーネントアイテム
- シンボルアイテム
- フットプリントアイテム
- 管理対象回路図シートアイテム
- 回路図テンプレートアイテム
- PCB製造データアイテム
- PCB実装データアイテム
- PCBプロジェクト設計アイテム
Explorerパネルで該当するフォルダーに移動し、比較する2つのアイテムリビジョンを選択してから、右クリックしてコンテキストメニューからOperations » Compareを選択します。
2つのコンポーネントアイテムリビジョンの比較
2つのコンポーネントアイテムリビジョンを比較する場合、Compareをクリックすると、次の処理が順に実行されます。
- 参照されているフットプリントアイテムのリビジョンが比較されます。
- 参照されているシンボルアイテムのリビジョンが比較されます。
- 2つのコンポーネントアイテムリビジョンのパラメトリックデータが比較されます。
比較結果はCompare component revisionsダイアログに表示されます。
ダイアログは3つのセクションに分かれており、パラメトリックデータ、フットプリント、シンボルの比較結果が表示されます。パラメーターの値が一致しない場合、赤みがかった背景で強調表示されます。フットプリントとシンボルについては、同一または同一ではないというテキストが表示されます。
シンボルアイテムの2つのリビジョンの比較
シンボルアイテムの2つのリビジョンを比較する場合、Compareをクリックするとグラフィカルな比較が行われ、検出された差分がDifferencesパネルに一覧表示されます。2つのリビジョンのSchLibドキュメントが設計スペース内で開きます。設計エディターウィンドウで左右に並べて表示することで、差分をグラフィカルに確認できます。検出された差分の最上位フォルダーをクリックすると、両方のドキュメントでその差分が同時にハイライト表示されます。
フットプリントアイテムの2つのリビジョンの比較
フットプリントアイテムの2つのリビジョンを比較する場合、Compareをクリックするとグラフィカルな比較が行われ、検出された差分がCompare Componentsダイアログに一覧表示されます。

フットプリントの2つのリビジョンの比較例。ソースライブラリは設計スペース内で開かれません。ここでは、実際の差分を示すためにフットプリントのプレビューを掲載しています。
フットプリントは正方形のセルに分割され、各セルの差分が解析されます。差分があるセルはフルカラーで表示され、差分がハイライト表示されます。レイヤータブには、比較対象の各レイヤーで差分があるプリミティブオブジェクトの数が表示されます。タブをクリックすると、差分をより詳しく確認できます。
グリッドデータのエクスポート
Explorerパネルでは、グリッド表示のデータをcsv形式またはxls形式のファイルにエクスポートできます。この機能を使用できる場所には、次のようなものがあります。
- コンポーネントアイテムのグリッド(クラシック表示とコンポーネント表示の両方)。
- アイテムのグリッド。
- Previewアスペクト表示タブのリンク済みモデルのグリッド(選択したコンポーネントアイテムに対するもの)。
- 検索結果のグリッド。
- Where-usedアスペクト表示タブのアイテムのグリッド。
- Childrenアスペクト表示タブのアイテムのグリッド。
グリッド内を右クリックし、コンテキストメニューからOperations » Export Gridコマンドを選択します。Select columns for data exportダイアログが表示されます。列リストのチェックボックスを使用するか、 Select All / Deselect All ボタンをクリックして、エクスポートするデータを有効または無効にします。 このダイアログには、グリッドで使用できるすべての列が表示されます。現在パネルに表示されている列は、デフォルトでエクスポートが有効になっています。OKをクリックすると、Windows標準のSave Asダイアログが表示されます。このダイアログで、エクスポートするファイルの保存先とファイル名を指定します。Save as typeフィールドで、ファイル形式をカンマ区切り値ファイル(*.csv)またはExcelファイル(*.xls)から選択します。

データ(選択したコンポーネントアイテムのリビジョンにリンクされたモデル)をExcel形式のファイルにエクスポートする例。
プロジェクト表示
パネルのProject Viewでは、選択したプロジェクトがプロセス指向の表示で示され、関連するプロジェクトデータとそのリリースに直接アクセスできます。
Project Viewには、プロジェクトのプレビュー、主な説明、パラメーター、リリースが表示されます。
Releases領域には、選択したプロジェクトに関連付けられたプロジェクトリリースがまとめて表示されます。各リリースと、それを構成するパッケージの概要も含まれます。この領域の
ボタンをクリックすると、Batch state changeダイアログが開きます。このダイアログでは、同じリリースに関連する複数のアイテムのライフサイクル状態を、1回のバッチ処理でまとめて変更できます。
プロジェクト表示の右上には、次のコントロールがあります。
- Open – 対象プロジェクトをAltium Designerで開きます。
- Open in Web – Workspaceのブラウザーベースのインターフェースでプロジェクトを開きます。
- Share – 共有ダイアログを開きます。このダイアログでは、ソフトウェア内から直接、世界中のどこにいる相手とも設計プロジェクトを共有できます。
-
– ボタンをクリックすると、次のコマンドにアクセスできます。
-
コピーを作成 – Create Project Copyダイアログを開きます。このダイアログでは、プロジェクトをコピーして、接続先のWorkspaceに保存できます。デフォルトでは、元のプロジェクト名に接尾辞
' - Copy'が付加されます。 - History – プロジェクトの履歴ビューを開きます。このビューには、そのプロジェクトのCAD中心の詳細管理ページからアクセスできます。
- Delete – プロジェクト、そのフォルダー、およびプロジェクトのすべてのコンテンツを削除します。削除が完了する前に、確認を求められます。
-
コピーを作成 – Create Project Copyダイアログを開きます。このダイアログでは、プロジェクトをコピーして、接続先のWorkspaceに保存できます。デフォルトでは、元のプロジェクト名に接尾辞










