Designing a Rigid-Flex PCB in Advanced Rigid-Flex Mode in Altium Designer

Defining the Substacks

The structure of your board is defined in the Layer Stack Manager (Design » Layer Stack Manager). From here, you can enable the required rigid-flex mode and define the substacks needed in your rigid-flex design.

Defining the substacks:

  • To enable the features needed to design a rigid-flex board in advanced mode, select the Tools » Features » Rigid-Flex (Advanced) command from the main menus of the Layer Stack Manager.
  • Board mode of the Layer Stack Manager is used to visually edit and organize the various substacks in the rigid-flex design. An individual substack can be edited by double-clicking on it. When you do, the Stackup mode is displayed for that substack.
  • Add a new substack by selecting the required layers in an existing substack in the Board mode using Shift+Click and selecting the appropriate command from the Creating a flex region within a board cutout. button menu. A board can include any number of substacks.
  • Define the properties of the substack in the Properties panel.
  • If the design has a structure of stackups that cannot be modeled in Board mode, additional branches can be added.

Learn more about Defining the Substacks - Advanced Mode

Defining the Board Shape and Regions

The layer stack defines the board in the vertical direction, or Z plane. In the PCB editor, the area that the board occupies in the X and Y planes is defined by the Board Shape. The board shape can be a polygonal region of any shape, with straight or curved edges that lie at any angle, that can also include cutouts (internal holes) of any shape.

There are two techniques that can be used to defining the overall board shape and the various rigid and flex regions:

  1. Define the overall board shape, and then slice it into regions. Learn more about Slicing the Board Outline into Regions.
  2. Place each rigid and flex Board Region in the design space to build up the final board shape. Learn more about Placing a Board Region.

The final shape can be created using a mixture of the two techniques.

The overall Board Shape is defined by the set of Board Regions, the video shows two ways these regions can be created.

Defining the Board Shape and Regions:

  • The board shape can be defined interactively in Board Planning Mode (View » Board Planning Mode), or it can be defined based on an existing outline in 2D layout mode (View » 2D Layout Mode).
  • To define the board shape from an existing outline, select the outline in 2D layout mode and run the Design » Board Shape » Define from selected objects command (or the Tools » Convert » Create Board Region from selected primitives command). The software will trace along the centerline of the selected track/arc objects to define the outer edge of the board shape.
  • To define the board shape interactively, switch to Board Planning Mode and select the Place » Board Region command (or click the  button on the Active Bar). The standard region object placement behaviors apply, use the Snap Grid and Work Guides to help with this process. Enable the Board Shape option in the Snap Options palette to give the best level of control during Board Region editing. Learn more about Understanding the Snap Behavior.
  • Place the required number of Regions. Regions can be drawn so they are overlapped, note that this does not define the extent that a flex region overlaps into a rigid region, that is defined by the Intrusion values in the Stackup definition.
  • To define the Name and assign a Layer stack for each region, select the region and edit the properties in the Board Region mode of the Properties panel.
  • To slice a Board Region into two smaller regions, use the Design » Slice Board Region command (or click the  button on the Active Bar). The Slicing tool uses the standard line placement cornering modes, including 45°, 90°, 45° arc, 90° arc and any angle, press Shift+Spacebar to change the mode during slicing.
  • The location and shape of an existing Board Region can be edited, using the standard polygonal object editing techniques.
  • In the standard rigid-flex mode, the boundary between two Board Regions is defined by placing a Split Line. The Advanced rigid-flex mode does not use Split Lines, instead the edge of the Board Region defines where one Substack ends and the adjacent Substack begins. If two Board Regions are overlapped (and those regions have common layers), then the stack with more layers is applied in the overlapping area.
  • When overlapped regions do not have common layers they can be folded independently.

Learn more about Planning Rigid & Flex Regions - Advanced Mode

Defining Bends in the Flex Region

A bend in a flexible section of a rigid-flex board is defined by placing a Bending Line. A bending Line is a linear object, whose properties are edited in the Bend mode of the Properties panel.

Placing Bending Lines

  • Bending Lines are placed in Board Planning Mode (1 shortcut).
  • To place a Bending Line run the Place » Define Bending Line command (or click the  button on the Active Bar). Place the Bending Line across the flexible Board Region. It is not necessary to precisely touch each edge of the region with the start and end of the Bending Line, the software will automatically extend it (if too short) or reduce it (if too long). At least one end of the Bending Line must touch or pass over the edge of the Region.
  • To edit the properties of a Bend, select it and edit the settings in the Bend mode of the Properties panel:
    • The Bend zone is displayed in a green-orange color, click anywhere within the zone to select that Bend.
    • Each Bend can be named so it can be easily identified.
    • Confirm that the Bend is being applied to the correct Substack Region, available regions are listed in the Stack Regions section.
    • Set the Bend Zone Radius and Bend Angle as required.
    • Bends are folded in the order of their Fold Index, use this feature when the folding order is important to check.
  • To move a Bending Line, click and drag on each end handle.
  • Bending Lines can be applied to board cutouts edges.
  • A selected Bend can be removed by clicking and holding on one of the vertices, then pressing Delete on the keyboard.

Learn more about Defining Bending Lines - Advanced Mode

Designing a Flex-only PCB

A flex-only board can only be created in Advanced Rigid-Flex mode.

The Layer Stack Manager requires at least one rigid substack to be defined. To design a flex-only PCB, first define the rigid substack then add a flex substack, as shown in the image below.

A flex-only board still requires a rigid substack to be defined in the Layer Stack Manager.A flex-only board still requires a rigid substack to be defined in the Layer Stack Manager.

In Board Planning Mode, define the shape of the flex-only PCB and assign the flex substack in the Board Region mode of the Properties panel.

A flex-only PCB, hover the cursor over the image to show the board in 3D.A flex-only PCB, hover the cursor over the image to show the board in 3D.

Designing a Board with a Flex Region Inside a Cutout

It is possible to design a rigid-flex board that has a flexible region within a cutout in the main PCB.

A board with a flex region inside a cutout can only be created in Advanced Rigid-Flex mode.

Notes about creating this type of board:

  • The video below demonstrates the process.
  • The board cutout must trace the outline of the flex region(s) within the cutout.
  • Place the cutout before placing the flex region(s) inside the cutout zone.
  • Any region within the cutout that does not use the same substack as the outer rigid region must have its priority set to a higher value than the value assigned to the outer rigid region.
  • Configure the Used Stack Regions options for Bending lines placed on internal flex regions so that they only apply to that flex region.
  • It can be easier and more accurate to define the shapes required for the cutout and the flex region(s) as outlines on a mechanical layer, using tracks and arcs. Then use the tools available to convert a selected outline to a board cutout, or a board region. Note that the conversion tool follows the centerline of the selected tracks and arcs, and requires the end points of adjacent tracks/arcs to exactly meet.
    • Design » Board Shape » Create Board Region from Selected Objects (in 2D Mode)
    • Tools » Convert » Create Board Cutout From Selected Primitives (in 2D Mode)
    • Tools » Convert » Convert Selected Line to Bend Line (in 2D Mode)

Creating a flex region within a board cutout.

Download the PcbDoc file used in the video

注記

利用できる機能は、Altium Designer ソフトウェア サブスクリプション のレベルによって異なります。

Content