製図テンプレートの作成

概略

この記事では、Altium DesignerにおけるDraftsmanのドキュメントテンプレートとシートテンプレートの仕組み、それぞれのテンプレートで設定できる内容、および接続先のWorkspaceとローカル環境での作成、保存、編集、移行の方法について説明します。Draftsman全体の内容と構成を定義するドキュメントテンプレートと、用紙サイズや表題欄などのページ単位の設定を定義するシートテンプレートの実用上の違いを、新しいテンプレートの作成や既存テンプレートの再利用に関する基本的なワークフローとともに紹介します。Draftsmanの出力を標準化し、テンプレートをより効率的に管理する方法を理解したい方は、ぜひこのガイドを読み進めてください。

- Draftsmanのドキュメントテンプレートとシートテンプレートの違い、およびそれぞれの使いどころを学びます。
- Workspaceで新しいテンプレートを作成する方法、ローカルのテンプレートをWorkspaceに保存する方法、後から編集したりリビジョンをアップロードしたりする方法を確認します。
- デフォルトのテンプレートの保存場所と、テンプレート管理プロセス全体におけるローカルでのテンプレート作成の位置付けを理解します。
AIでさらに深掘り:

Draftsmanドキュメントでは、ドキュメントテンプレートとシートテンプレートを使用できます。

  • Document templates – 新しいDraftsmanドキュメントの内容を定義するために使用します。

  • Sheet templates – Draftsmanドキュメントのページプロパティを定義するために使用します。

What is the Difference between a Sheet Template and a Document Template?

DraftsmanドキュメントテンプレートはDraftsmanドキュメント全体の内容と構造を定義し、シートテンプレートは個々のシートの書式を設定します。

  • Draftsmanドキュメントテンプレートには、複数のシート(ページ)や、ビュー、テーブルなどのさまざまな要素を含めることができます。Draftsmanドキュメントをドキュメントテンプレートとして保存すると、現在のPCBのデータが保持され、図面内容の「ひな形」が定義されます。 その後、このテンプレートを新しいDraftsmanドキュメントのドキュメントテンプレートとして使用すると、テンプレートのPCBデータの代わりに、プロジェクトの現在のPCBデータがひな形に読み込まれ、ドキュメントの書式と内容の種類が再現されます。

  • DraftsmanシートテンプレートをDraftsmanドキュメントのページに適用すると(詳細はこちら)、シートのサイズや表題欄など、Draftsmanドキュメントのシートレベルのプロパティが定義されます。

多数のDraftsmanドキュメントテンプレートおよびシートテンプレートが、デフォルトで次の場所に用意されています。

  • 接続先のWorkspace内 – WorkspaceのManaged Content\Templates\Draftsman Templates\Document TemplatesフォルダーとManaged Content\Templates\Draftsman Templates\Sheet Templatesフォルダー内(Workspaceの有効化/インストール時にサンプルデータを含めることを選択した場合)。

  • ローカル – Altium Designerのインストール先にあるShared Documentsフォルダー内のTemplatesサブフォルダー(デフォルトのインストールではC:\Users\Public\Documents\Altium\AD<Solution/Version>)。

これらのデフォルトテンプレートを要件に合わせて編集することも、以下の説明に従って新しいテンプレートを作成することもできます。

WorkspaceでのDraftsmanテンプレートの作成

Draftsmanドキュメントテンプレートとシートテンプレートは、接続先のWorkspaceに作成できます。Workspaceは、すべての設計データを安全に一元管理でき、設計チーム全体からアクセスできる場所です。

WorkspaceでのDraftsmanドキュメントテンプレートの作成

接続先のWorkspaceで新しいDraftsmanドキュメントテンプレートを作成するには、次の手順に従います。

  1. Preferencesダイアログの「データ管理 – テンプレート」ページで、Templatesタブを開きます。

  2. ボタンのメニュー、またはテンプレート一覧のコンテキストメニューから、Draftsman Documentコマンドを選択します。

  3. コマンドを選択した後、開いたClose PreferencesダイアログでOKをクリックすると、Preferencesダイアログが閉じ、一時的なDraftsmanエディターが開きます。新しいDraftsmanドキュメントテンプレートアイテムの計画済みリビジョンが、Draftsman TemplatesタイプのWorkspaceフォルダー内に自動的に作成されます。

  4. ドキュメントテンプレートの内容を定義します。ドキュメントテンプレートは、複数ページのドキュメント、主要なドキュメント属性(ビュー、テーブル、リストなど)のデータ、ページ設定、およびPCBの設計内容に依存しないDraftsmanで作成された要素をサポートします。

    シートテンプレートを使用して、表題欄やサイズなどのページレベルの属性を定義できます(シートテンプレートの適用を含む、ドキュメントシートの設定について詳しくは、「Draftsmanドキュメントの設定」ページを参照してください)。シートテンプレートへの参照は、ドキュメントテンプレートの一部として保存されます。シートテンプレートについては、次のセクションで説明します。

    単一ページのDraftsmanドキュメントテンプレートの例
    単一ページのDraftsmanドキュメントテンプレートの例

    Draftsmanドキュメントは、PCBドキュメントをコンテキストとして使用します。WorkspaceのDraftsmanドキュメントテンプレートを作成する際にドキュメントオプションを定義できるように、6000×4000 milの仮想PCBドキュメントが作成され、このコンテキストが提供されます。

  5. メインメニューからFile » Save to Serverコマンドを選択し、ドキュメントテンプレートを接続先のWorkspaceに保存します。Edit Revisionダイアログが表示され、Workspaceに作成するDraftsmanドキュメントテンプレートアイテムのNameとDescriptionを定義し、必要に応じてリリースノートを追加できます。

    ドキュメントテンプレート形式と互換性のない要素はすべて削除されます。互換性のない要素がある場合は、保存前に警告ダイアログが表示され、実行される処理の詳細が示されます。

WorkspaceでのDraftsmanシートテンプレートの作成

接続先のWorkspaceで新しいDraftsmanシートテンプレートを作成するには、次の手順に従います。

  1. Preferencesダイアログの「データ管理 – テンプレート」ページで、Templatesタブを開きます。

  2. ボタンのメニュー、またはテンプレート一覧のコンテキストメニューから、Draftsman Sheetコマンドを選択します。

  3. コマンドを選択した後、開いたClose PreferencesダイアログでOKをクリックすると、Preferencesダイアログが閉じ、一時的なDraftsmanエディターが開きます。新しいDraftsmanドキュメントテンプレートアイテムの計画済みリビジョンが、Draftsman TemplatesタイプのWorkspaceフォルダー内に自動的に作成されます。

  4. シートテンプレートの内容を定義します。テンプレートには、シートサイズ、パラメーター、ゾーンおよび枠の設定など、ページのグラフィック情報を含めることができます。エディターのグラフィックツールで作成したオブジェクト(線や長方形など)も含まれます。たとえば、作成した表題欄とその内容などです。

    Draftsmanシートテンプレートの例
    Draftsmanシートテンプレートの例

    Draftsmanシートテンプレートを作成する際は、ページサイズと書式の設定元として別のシートテンプレートを使用しないことをお勧めします。つまり、デザインスペースでオブジェクトが選択されていない状態で、PropertiesパネルのPage Optionsタブでページオプションを定義する際は、Templateではなく、StandardまたはCustomモードを使用してください。

    表題欄でシート番号を自動的に付けるパラメーターを使用する場合、ドキュメントでは従来のSheetNumberパラメーターと、GOST準拠のSheetNumber_OneSheetパラメーターという2種類のシステムパラメーターがサポートされていることに注意してください。後者は、Draftsmanドキュメントにシートが1枚しかない場合、現在のシート番号を表示しません(GOST 2.104-2006製図規格に準拠)。それ以外の場合は、SheetNumberパラメーターと同じ番号を表示します。

  5. メインメニューからFile » Save to Serverコマンドを選択し、テンプレートを接続先のWorkspaceに保存します。Edit Revisionダイアログが表示され、Workspaceに作成するDraftsmanシートテンプレートアイテムのNameとDescriptionを定義し、必要に応じてリリースノートを追加できます。

    シートテンプレート形式と互換性のない要素はすべて削除されます。互換性のない要素がある場合は、保存前に警告ダイアログが表示され、実行される処理の詳細が示されます。

既存のローカルDraftsmanテンプレートをWorkspaceに保存する

既存のDraftsmanドキュメント/シートテンプレート(*.DwfDot/*.DwsDot)がある場合は、そのテンプレートをWorkspaceに直接保存することもできます。手順は次のとおりです。

  1. Altium Designerでテンプレートを開きます。

  2. メインメニューからFile » Save to Serverコマンドを選択します。

    Workspaceに保存する前に、ファイルをローカルに保存(File » Save)しておく必要があります。

  3. Choose Planned Item Revisionダイアログが表示されます。このダイアログで、シートの保存先となるDraftsmanドキュメント/シートテンプレートアイテムを選択し、OKをクリックします。シートは、そのアイテムの次のリビジョン(またはPlanned状態の既存のリビジョン)に保存されます。

    保存先のDraftsmanドキュメント/シートテンプレートアイテムが存在しない場合は、Choose Planned Item Revisionダイアログで、選択したWorkspaceフォルダー内にその場で作成できます。ダイアログのリビジョンリスト領域を右クリックし(フォルダーにまだアイテムがない場合は Add an item コントロールをクリックし)、Create Item » Draftsman Document Template / Draftsman Sheet Template コマンドを選択します。この場合は、必ず(Create New Itemダイアログの) Open for editing after creationオプションを無効にしてください。有効のままだと、直接編集モードに入ります。

  4. Edit Revisionダイアログが表示されます。このダイアログでは、Name、Descriptionを定義し、必要に応じてリリースノートを追加できます。

  5. OKをクリックすると、テンプレートが保存され、アイテムのリビジョンに格納されます。

  • Preferencesダイアログの Data Management – Templatesページ にあるTemplatesタブで、 ボタンのメニュー、またはテンプレートグリッドのAddコンテキストメニューからLoad from Fileコマンドを使用して、Workspaceに新しいDraftsmanドキュメント/シートテンプレートを作成することもできます。開いたOpenダイアログ(標準のWindowsのファイルを開くダイアログ)で、File nameフィールドの右側にあるドロップダウンからDraftsman Document File (*.DwfDot) / Draftsman Sheet File (*.DwsDot)オプションを選択し、目的のファイルを参照して開きます。このファイルは、Draftsman TemplatesタイプのWorkspaceフォルダー内に自動的に作成される新しいDraftsmanドキュメント/シートテンプレートアイテムの初期リビジョンにアップロードされます。

  • Workspaceに保存するDraftsmanドキュメント/シートテンプレートがLocal Template folder(PreferencesダイアログのData Management – Templatesページ の下部で定義)にあり、テンプレートグリッドのLocalエントリの下に表示されている場合は、そのテンプレートを右クリックしてMigrate to Serverコマンドを選択することで、新しいDraftsmanドキュメント/シートテンプレートアイテムに移行できます。Template migrationダイアログのOKボタンをクリックして、移行処理を進めます。このダイアログに記載されているとおり、元のテンプレートファイルはローカルテンプレートフォルダー内のZipアーカイブに追加されます(そのため、Localテンプレートリストには表示されなくなります)。

WorkspaceのDraftsmanテンプレートの編集

Workspace内のDraftsmanドキュメント/シートテンプレートは、いつでも再度開いて編集できます。 Preferences ダイアログの Data Management – Templatesページ にある Templates タブで、テンプレートのエントリを右クリックし、コンテキストメニューから Edit コマンドを選択します。一時的なDraftsmanエディターが開き、そのリビジョンに含まれるテンプレートが編集用に開かれます。必要な変更を加えたら、ドキュメントをDraftsmanドキュメント/シートテンプレートアイテムの次のリビジョンに保存します。

WorkspaceのDraftsmanドキュメント/シートテンプレートを更新する必要があり、更新済みのDraftsmanドキュメント/シートテンプレートファイルが手元にある場合は、そのファイルをWorkspaceのテンプレートにアップロードできます。 Preferences ダイアログの Data Management – Templatesページ にある Templates タブで、テンプレートのエントリを右クリックし、コンテキストメニューから Upload コマンドを選択します。開いたOpenダイアログ(標準のWindowsのファイルを開くダイアログ)で目的のファイルを参照して開くと、そのファイルがDraftsmanドキュメント/シートテンプレートアイテムの次のリビジョンにアップロードされます。

ローカルのDraftsmanテンプレートの作成

現在エディターで開いているDraftsmanドキュメント(*.PCBDwf)を、いずれかのテンプレート形式で保存することでも、ローカルのDraftsmanシート/ドキュメントテンプレートを作成できます。

目的のDraftsmanドキュメントがアクティブな状態で、メインメニューからFile » Save Copy As または File » Save As コマンドを選択します。 表示されたSaveダイアログで、使用しているAltium Designerのローカルテンプレートフォルダー(Preferencesダイアログの Data Management – Templatesページの下部にあるLocal Templates folderフィールドで定義。デフォルトのインストールでは C:\Users\Public\Documents\Altium\AD<Version>)を参照し、テンプレートの名前を入力して、Save as typeドロップダウンからAltium Draftsman Sheet Templates (*.DwsDot)またはAltium Draftsman Document Templates (*.DwfDot)を選択します。

他のAltium Designerドキュメント(回路図、PCBなど)と同様に、Save Asコマンドを使用すると、プロジェクト構造内の既存のソースファイル(この場合はDraftsman図面ドキュメント)が、新しく保存したファイル(Draftsmanテンプレートドキュメント)に置き換えられます。ソースドキュメント(*.PCBDwf)は、ディスク上のプロジェクトフォルダーからは削除されません。

より適切な方法は、Save Copy Asオプションを使用することです。このオプションでは、ソースドキュメント(およびプロジェクトの内容)をそのまま保持しながら、指定したディレクトリに新しいテンプレートを保存できます。

ローカルのDraftsmanテンプレートは、Preferencesダイアログの Data Management – Templatesページ にあるTemplatesタブで、グリッドのLocal領域に表示されます(このページの Template visibility オプションが Server & Local に設定されている場合にのみ表示されます)。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents