Draftsman の配置および編集テクニック

概略

この記事では、Altium DesignerのDraftsmanドキュメントでオブジェクトを配置・編集するための基本的な手法を解説します。共通の配置手順、配置前にオブジェクトのデフォルトプロパティを設定する方法、ページに配置した後のさまざまな編集方法を紹介します。また、Propertiesパネル、グラフィカル編集、移動・回転コマンド、コピー&ペーストの動作、複数オブジェクトの一括編集、Format Painter、テキスト検索などの実用的なツールも取り上げ、作業を進めながらPCB図面を仕上げていく方法をわかりやすく説明します。Draftsmanのコンテンツをより確実かつ効率的に調整し、図面の見栄えを向上させたい方は、ぜひこのガイドを読み進めてください。

- Draftsmanオブジェクトの配置に共通するワークフローと、配置前にデフォルト設定を調整する方法を学びます。
- Propertiesパネルでの変更、グラフィカルなサイズ変更や移動、移動・回転コマンドなど、配置後に利用できる主な編集方法を確認します。
- コピー&ペースト、複数オブジェクトの一括編集、Format Painter、テキスト検索など、Draftsmanでの作業効率を高める機能を理解します。
AIでさらに深掘り:

PCB図面の作成には、さまざまなオブジェクトを使用できます。 Draftsmanエディターのデザインスペースには、図面を構成する多数の設計オブジェクトを配置できます。図面の作成過程では、目的の外観を実現するために、これらのオブジェクトの配置やプロパティを変更する必要があります。

オブジェクトの配置と編集に共通する操作

Altium DesignerのDraftsmanでは、配置するオブジェクトの種類にかかわらず、配置手順はほぼ同じです。基本的な手順は次のとおりです。

  1. 次のいずれかの場所から、配置するオブジェクトを選択します。

    • メインの Place メニュー。

    • デザインスペースの上部にある Active Bar。

    • デザインスペースの右クリックメニューにあるPlaceサブメニュー。

  2. 配置するオブジェクトを選択すると、必要に応じてソースPCBファイルから図面データが取得され、 カーソルが十字形に変わって編集モードであることを示します。また、該当する場合は、オブジェクトがカーソルに追従して表示されます。 カーソルを目的の位置に移動し、クリックするか Enter を押してオブジェクトを配置します。寸法などのオブジェクトでは、位置を決めてクリックする操作を繰り返し、オブジェクトに必要なすべての位置を指定する必要があります。

  3. ビュー以外のオブジェクトを配置した後も、配置モードは継続します(十字形カーソルで示されます)。そのため、同じ種類のオブジェクトをすぐに続けて配置できます。配置モードを終了するには、右クリックするか Esc キーを押します。領域オブジェクトの配置などでは、この操作を2回行う必要がある場合があります。1回目でオブジェクトの配置を完了し、2回目で配置モードを終了します。配置モードを終了すると、カーソルは元の形状に戻ります。

配置前の編集

オブジェクトのデフォルトプロパティは、 Preferences ダイアログの Draftsman – Defaultsページ でいつでも変更できます。オブジェクトのほとんどのプロパティ、または事前に定義可能なプロパティは、編集可能なデフォルト設定として用意されています。これらのプロパティは、以降に配置するオブジェクトに適用されます。 Primitive List でオブジェクトを選択すると、右側にそのオプションが表示されます。

 Primitive List 列を使用してオブジェクトのプロパティにアクセスし、必要に応じてデフォルト値を編集します。
 Primitive List 列を使用してオブジェクトのプロパティにアクセスし、必要に応じてデフォルト値を編集します。

配置後の編集

配置済みのオブジェクトは、いくつかの方法で編集できます。以下で説明します。

関連するプロパティパネル

この編集方法では、対応する Properties パネルのモードとダイアログを使用して、配置済みオブジェクトのプロパティを変更します。

パネルの内容は、選択したオブジェクトに合わせて自動的に切り替わります。
パネルの内容は、選択したオブジェクトに合わせて自動的に切り替わります。

 Properties パネルを開いて配置済みオブジェクトのプロパティにアクセスするには、次のいずれかの操作を行います。

  • オブジェクトを選択した後、デザインスペースの右下にある クリックしてドラッグすると移動​ボタンから Properties パネルを選択するか、メインメニューから View » Panels » Properties を選択します。

  • デザインスペース内のオブジェクトをダブルクリックします。

  • オブジェクトを右クリックし、コンテキストメニューから Item Properties を選択します。

 Properties パネルがすでにアクティブな場合は、オブジェクトをクリックすると、パネルでそのプロパティにアクセスできます。 パネルの内容は、デザインスペースで現在選択されているオブジェクトのプロパティ設定に合わせて自動的に更新されます。

グラフィカル編集

この編集方法では、デザインスペース内で配置済みオブジェクトを直接選択し、位置を変更できます。対応しているオブジェクトでは、サイズや形状も変更できます。 選択されたオブジェクトは、次の1つ以上の方法で示されます。

  • 角や端点に表示される1つ以上の編集ハンドル。

  • 青い破線の選択境界ボックス。

  • オブジェクトの色が選択色の青に変化。

選択後は、次のグラフィカル操作が可能です。

  • オブジェクトの移動 – オブジェクト上の任意の場所をクリックしたままドラッグして、位置を変更します。オブジェクトが回転に対応している場合は、 Spacebar を押すと反時計回りに、 Shift+Spacebar を押すと時計回りに、90度単位で回転します。

  • オブジェクトのサイズ変更 – 対応している場合は、編集ハンドル/ノードをクリックしてドラッグすると、オブジェクトのサイズを変更できます。グラフィカルなサイズ変更に対応するオブジェクトには、ビューオブジェクト、注釈、グラフィックツールがあります。レイヤースタック凡例と表オブジェクトは、グラフィカルなサイズ変更には対応していません。

    選択した基板アセンブリビューの編集ハンドルの例。 ハンドルをドラッグすると、ビューの縮尺を変更できます。
    選択した基板アセンブリビューの編集ハンドルの例。 ハンドルをドラッグすると、ビューの縮尺を変更できます。

選択したDraftsmanオブジェクトは、矢印キーを押すと、現在のグリッド値単位で微調整できます。 また、 Shift キーを押しながら矢印キーを押すと、グリッド値の10倍の単位で微調整できます。

各オブジェクトのグラフィカル編集方法の詳細については、Draftsmanオブジェクトのドキュメントを参照してください。

移動および回転コマンド

 M ショートカットキーを押して表示される Moveポップアップメニューのコマンドを使用して、オブジェクトを移動および回転することもできます。

移動するオブジェクトを選択し、Moveポップアップメニューを開いて、必要なコマンドを選択します。

Move Selection コマンドを実行したら、デザインスペース内をクリックし、選択したオブジェクトが追従した状態でカーソルを移動します。オブジェクトが目的の位置に来たら、もう一度クリックします。
Move Selection By XY コマンドを実行すると、 Get X / Y Offsetsダイアログが開きます()。ダイアログのX OffsetフィールドとY Offsetフィールドを使用して、選択したオブジェクトを水平(X)軸方向および垂直(Y)軸方向に移動する距離をそれぞれ指定します。 移動方向に応じて、正の値または負の値を指定できます。
Rotate Selection コマンドを実行すると、 Rotation Angle (Degrees)ダイアログが開きます()。必要な回転の Angle を0.001°~360.00°の範囲(分解能0.001°)で入力します。反時計回りに回転する場合は正の値、時計回りに回転する場合は負の値を入力します。 OK をクリックしてダイアログを閉じ、カーソルを目的の位置に移動してクリックし、回転の基準点を指定します。選択したオブジェクトは、この基準点を中心に入力した角度だけ回転します。

コピーと貼り付けの使用

Draftsmanでは、Editメインメニューのコマンドまたは標準のショートカットを使用して、同じDraftsmanドキュメント内や異なるDraftsmanドキュメント間でオブジェクトを切り取り、コピー、貼り付けできます。

Altium Designerでは、Draftsmanドキュメントでの通常のコピー操作にWindowsのクリップボードは使用されません。この種類のドキュメントには、専用の内部クリップボードが用意されています。また、Draftsmanの内部クリップボードは、Altium Designerの他のエディターで使用される内部クリップボードとは完全に独立しています。コピーと貼り付けは、Draftsmanドキュメント内、またはDraftsmanドキュメント間でのみ行えます。

複数のオブジェクトの編集

Propertiesパネルは、複数のオブジェクトの編集に対応しています。Properties パネルでdifferent オブジェクトタイプを同時に変更することはできませんが、選択した複数のsame タイプのオブジェクトを同時に変更することはできます。標準のShift+Clickを使用して複数選択してください。パネルには、最後に選択に追加したオブジェクトの値が表示されます。

書式のコピー

書式のコピー機能を使用すると、既存のテキストスタイルを他のDraftsmanテキスト要素に簡単かつすばやく適用できます。

以下の動画に示すように、適用したいスタイルプロパティ(Propertiesパネルで定義)を持つ既存のテキスト要素を選択し、Editメインメニューまたはデザインスペースの右クリックメニューからFormat Painterコマンドを選択します。この操作により、現在選択されているテキストのスタイルプロパティが取得されます。

書式のコピーツールのアイコン()に変わったカーソルを使用して、スタイルプロパティを適用する他のテキスト要素を探して選択します。対応するテキストオブジェクトには、ビュータイトル、テキストオブジェクト、注記項目などの編集可能なテキスト要素が含まれます。

テキスト検索

Draftsmanエディターでは、指定した検索オプションに従って、特定のテキスト(またはテキストの一部)をすばやく検索できます。メインメニューからEdit » Find Textコマンドを選択するか、キーボードショートカットCtrl+Fを使用して、Find Textダイアログを開きます。

Find textダイアログ
Find textダイアログ

このダイアログで、検索する既存のテキストと、検索範囲および追加オプションを指定します。

検索するテキスト

Text To Find

このフィールドに、検索する文字列を入力します。単語全体を入力するか、文字列の一部を検索できます。後者の場合は、Whole Words Onlyオプションを無効にする必要があります。文字列には、ワイルドカード文字の?(任意の1文字)および*(任意の文字列)を使用できます。

ワイルドカードでは、常に大文字と小文字が区別されません。

検索した文字列はそれぞれ、このフィールドのドロップダウンリストに追加され、すばやく呼び出せるようになります。

検索範囲

Sheet Scope

このフィールドで、検索対象となるDraftsmanドキュメントの範囲を指定します。次のオプションから選択します。

  • Current Page – 現在のページを検索します。

  • Entire Document – Draftsmanドキュメント全体を検索します。

Selection

このフィールドで、オブジェクトの現在の選択状態に基づいて検索範囲をさらに絞り込みます。次のオプションから選択します。

  • Selected Objects – 現在選択されているオブジェクトのみを検索します。

  • DeSelected Objects – 現在選択されていないオブジェクトのみを検索します。

  • All Objects – 制限なし。選択状態に関係なく、すべてのオブジェクトを検索します。

Identifiers

このフィールドで、テキストベースのオブジェクトの種類に基づいて検索範囲をさらに絞り込みます。次のオプションから選択します。

  • All Identifiers – 制限なし。すべてのテキストベースのオブジェクト(テキスト文字列、テキストフレーム、ピン、ネット識別子、デジグネーター)を検索します。

  • Texts – テキストのみを検索します。

  • Designators Only – コンポーネントのデジグネーターのみを検索します。

オプション

Case sensistive このオプションを有効にすると、大文字と小文字を区別して検索します。検索対象のテキストは、Text To Findフィールドに入力した検索テキストと大文字・小文字が一致している必要があります。
Whole Words Only このオプションを有効にすると、単語全体が一致する場合のみ検索されます。つまり、検索テキストがそのまま完全な形で存在する必要があり、より長い文字列の一部であってはなりません。たとえば、このオプションを有効にしてcatを検索した場合、categoryの先頭3文字は検索結果として一致したとはみなされません。文字列の一部を自由に検索するには、このオプションを無効にします。

検索で複数の一致が見つかった場合は、Find text - Jumpダイアログが開きます。

Find text - Jump ダイアログ
Find text - Jump ダイアログ

ダイアログのボタンとボタンを使用すると、それぞれ前および次に一致するテキスト項目に移動できます。見つかったテキストの一致箇所を前後に移動すると、ダイアログの上部に、元の検索テキストと、デザインスペースで現在表示している項目のオブジェクトタイプおよび一致するテキストが表示されます。

メインメニューからEdit » Find Nextコマンド(ショートカット:F3)を選択すると、Find textダイアログで最後に指定した検索テキストの次の出現箇所を、ドキュメント内で検索することもできます。

DXFのインポート

Draftsmanでは、標準DXFファイルをインポートすることで、使用できるグラフィックの選択肢がさらに広がります。ファイルはFile » Import from DXFメニューコマンドで図面スペースに読み込みます。標準のWindowsのOpenダイアログでDXF(*.dxf)ファイルを選択し、表示されるDXF Import Settingsダイアログでインポートオプションを設定します。

  • 複数シートのドキュメント内の特定のシートにインポートする場合は、そのシートが現在のシートになっていることを確認してください。

  • DXFのソースグラフィックはDraftsmanの標準グラフィック図形オブジェクトとして解釈されるため、各プリミティブオブジェクトを編集できます。DXFファイルからのインポートでは、円弧、円、線、長方形、領域、テキストのオブジェクトタイプに対応しています。

以下の機能はオープンベータ版であり、詳細設定ダイアログでDraftsman.TeighaNetオプションを有効にすると使用できます。

Importing DXF File Versions R12 and Later

バージョンR12以降のDXFファイルを製造図面ドキュメント(*.PCBDwf、*.HarDwf、*.MbDwf)にインポートできます。

Importing DXF Files with Splines

スプラインを含むDXFファイルを製造図面ドキュメント(*.PCBDwf、*.HarDwf、*.MbDwf)にインポートできます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents