Draftsman ドキュメントの設定
Altium Essentials: Draftsman
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- 新しいDraftsmanドキュメントの作成方法、テンプレートの選択方法、適切なプロジェクトとソースPCBの割り当て方法を学びます。
- DraftsmanがPCBデータとのリンクを維持する仕組みと、基板設計の変更時にドキュメントを更新する方法を確認します。
- Draftsmanドキュメントの外観や動作を決める、主要なドキュメントオプションとパラメーター設定について理解します。
Draftsmanは、専用のファイル形式(*.PCBDwf)でPCB図面ファイルを作成、保存します。
新しいDraftsmanドキュメントの作成
新しいDraftsmanドキュメントを作成するには、メインメニューからFile » New » Draftsman Documentコマンドを使用するか、Projectsパネルで対象プロジェクトのエントリを右クリックし、コンテキストメニューからAdd New to Project » Draftsman Documentコマンドを選択します。開いたNew Documentダイアログでは、定義済みのドキュメントテンプレート、または空白のA4ドキュメントを作成する[Default]オプションを選択できます。

指定したプロジェクトとPCBから、空白のDraftsmanドキュメントまたはテンプレートに基づくDraftsmanドキュメントを作成します。
Workspaceテンプレート(接続先Workspaceのエントリの下に<TemplateName> (v.<Revision>)の形式で表示)では、利用可能な各テンプレートの最新リビジョンが使用されます。
ボタンをクリックすると、PreferencesダイアログのData Management – Templatesページにアクセスできます。
使用するドキュメントテンプレートに加えて、特定のProject(Altium Designerで複数のプロジェクトを開いている場合)と、選択したプロジェクト内のPCBソースDocumentを選択できます。新しいドキュメントは指定したプロジェクトに追加され、そのプロジェクトからデータを取得します。また、このプロジェクトがアクティブプロジェクトになります。
ダイアログのLayersチェックボックスでは、製造用ドキュメントテンプレートの使用時に、ドキュメント内の製造図面の生成に使用する基板レイヤー(レイヤースタックで定義されたSignal/Plane、Mask、Paste、Silk)を指定します。選択したテンプレートで、対応する基板製造ビューのLayerがAll (for document template)に設定されている場合、製造図面は1シートにつき1つ作成されます。
DraftsmanとPCBの同期
Draftsmanは、PCBの銅箔レイヤー、コンポーネントレイヤー、メカニカルレイヤーから設計データを直接抽出します。PCBデータが変更された場合は、ドキュメント内の任意の場所を右クリックしてコンテキストメニューからImport Changes From <PCBDocumentName>.PcbDocを選択するか、メインメニューからTools » Import Changes From <PCBDocumentName>.PcbDocコマンドを選択することで、Draftsmanのデータを更新できます。
ドキュメントの全般オプション
Draftsmanドキュメント全体(複数のシートやページで構成される場合もあります。詳細はこちら)の設定は、デザインスペースで何も選択されていないときに、PropertiesパネルのGeneral タブで定義します。これらの設定では、ドキュメントのソース設計データ、グラフィックスタイル、描画動作、使用する単位を指定します。設定を変更すると、適用されているドキュメントテンプレートで定義されたデフォルトのプロパティ設定が上書きされます。
| Grid Size、 Show Grid |
これらのオプションを使用して、ドキュメントのグリッドを設定します。詳細については、グリッドとスナップオプションの設定セクションを参照してください。 |
| Snapping、 Snapping Distance |
これらのオプションを使用して、スナップ機能を設定します。詳細については、グリッドとスナップオプションの設定セクションを参照してください。 |
| Document Font | ドキュメントのシートで使用する基本フォントスタイルと追加属性を設定します。これにより、基板実装ビューのタイトルなどの描画オブジェクトに適用される、ドキュメントレベルのフォントが定義されます。個々のオブジェクトのPropertiesパネルを使用して、そのオブジェクトのドキュメントレベルのフォント設定を上書きできます。 |
| Sheet Border | ドキュメントのシートのゾーン境界線と文字の色を設定します。 |
| Sheet Color | ドキュメントのシートの背景色を設定します。 |
| Variants Display、 Pattern、 Not Fitted Text、 Not Fitted Font、 Font Size (Min/Max) |
これらのオプションを使用して、選択した設計バリアントで非実装に設定されているコンポーネントの、基板実装ビュー上での表示を設定します。詳細については、基板実装ビューページを参照してください。 |
| PCB Document | Draftsmanドキュメントのデータソースとして使用する基板設計を設定します。ドロップダウンメニューから、現在のプロジェクト内の利用可能なPCBドキュメントを選択します。 |
| Variants | ドロップダウンメニューから、Draftsmanドキュメントのデータソースとして使用する基板設計のバリエーション(バリアント)を選択します。詳細については、設計バリアントのサポートセクションを参照してください。 |
| Scale | 現在のドキュメントに新しく配置する基板全体のビュー(基板実装ビュー、基板製造ビュー、ドリル図面ビューなど)のサイズを設定します。配置したビューの縮尺の調整については、ビューの操作ページを参照してください。 |
| Dash Pattern | 破線オプションの線と間隔の定義です。単位は0.02mmです(メートル単位モードの場合)。たとえば、パターン値20,10,20は、0.4mm、0.2mm、0.4mmの破線配置を繰り返す、1周期1mm(50単位)のパターンを定義します。 |
| Line Thicknesses | 利用可能な線スタイルオプションの線幅または太さです。 |
| Units | ドキュメントの主測定単位の種類を設定します。 |
| Dual Units | ドキュメントの副測定単位(併記単位)の種類を設定します。追加の併記単位は、描画オブジェクトのPropertiesパネルで有効にできます。 |
| Decimal Separator | ドロップダウンメニューから、小数点記号として使用する文字を選択します。 |
| Remove Leading Zero | 「1」未満の値を使用する際に、先頭のゼロを自動的に削除するには、このオプションを有効にします。たとえば、 このオプションを有効にすると、「0.5」は 「.5」と表示されます。 Dimensioning and Tolerancing, ASME Y14.5、 インチ単位を使用する場合、1未満の値では先頭のゼロを省略することを指定します。 |
| Primary Units |
|
| Dual Units |
|
Draftsmanドキュメントのパラメーター
デザインスペースでオブジェクトが選択されていない場合、Propertiesパネルの Parametersタブには、現在のドキュメントで使用できるパラメーターが表形式で一覧表示されます。リストには、プロジェクト(バリアントを含む)、システム、PCBのパラメーター、および追加したカスタムパラメーターが表示されます。
ボタンと
ボタンを使用して、独自のカスタムパラメーターを作成または削除します。
リストの下部にあるチェックボックスを使用して、リストに表示するパラメーターの範囲を設定します:
(プロジェクト)、
(システム)、
(PCB)。 プロジェクト、システム、PCBのパラメーターは読み取り専用ですが、追加したカスタムパラメーターは編集可能で、常にリストに表示されます。
定義済みのシステムパラメーターとPCBパラメーターを以下に示します。
システムパラメーター
Application_BuildNumber |
現在インストールされているAltium Designerのバージョンとビルド。 |
BOMPageNumber |
部品表 のプロパティのTitleフィールドで使用し、現在のBOMテーブルのページ番号を表示します。 |
BOMTotalPages |
部品表 のプロパティのTitleフィールドで使用し、BOMテーブルの総ページ数を表示します。 |
ComponentName |
部品ビュー のプロパティのTitleフィールドで使用し、ビューの作成対象となった部品のコメントを表示します。 |
CurrentDate |
システム設定から自動的に算出される現在の日付。 |
CurrentTime |
システム設定から自動的に算出される現在の時刻。 |
DocumentFullPathAndName |
Draftsmanドキュメントのファイルのフルパスと名前。例:C:\MyTestDesign\Kame_FMU_asm_rm.PCBDwf。 |
DocumentName |
Draftsmanドキュメントのファイル名のみ(ファイルパスを除く)。例: Kame_FMU_asm_rm.PCBDwf。 |
DocumentScale |
Draftsmanドキュメントで選択されている縮尺。 |
DocumentUnits |
Draftsmanドキュメントで選択されている測定単位。 |
FootprintName |
部品ビュー のプロパティのTitleフィールドで使用し、ビューの作成対象となった部品のフットプリント名を表示します。 |
HoleName |
座ぐり穴ビュー のプロパティのTitleフィールドで使用し、ビューの作成対象となったパッドの名前(デジグネーター、PCB上の位置、レイヤーに基づく)を表示します。 |
ModifiedDate |
Draftsmanドキュメントファイルの更新日。自動的に入力されます。 |
ProjectName |
Draftsmanドキュメントの親プロジェクトの実際の名前(拡張子を含む)。 例: Sample - Kame_FMU.PrjPcb。 |
Revision |
デフォルトのドキュメントレベルのパラメーター Revisionに指定されている値を表示します。 |
SheetNumber |
特殊文字列として配置すると、Draftsmanドキュメントの現在のシートのシート番号を表示します。 |
SheetNumber_OneSheet |
特殊文字列として配置すると、Draftsmanドキュメントの現在のシートのシート番号を表示します。Draftsmanドキュメントにシートが1枚しかない場合は、値を表示しません。 |
SheetTotal |
Draftsmanドキュメントの総シート数。 |
VersionControl_PCBDocumentRevNumber |
DraftsmanドキュメントのソースPCBの現在のリビジョン番号。この文字列に情報を表示するには、バージョン管理を使用する必要があります。 |
VersionControl_PCBDocumentRevNumberShort |
DraftsmanドキュメントのソースPCBの現在のリビジョン番号を表す短縮形式のGitハッシュ(先頭8文字)とVCSステータス。この文字列に情報を表示するには、バージョン管理を使用する必要があります。 |
VersionControl_PrjFolderRevNumber |
プロジェクトの現在のリビジョン番号。プロジェクト全体のコミット(プロジェクトファイルを含む)が行われるたびに増加します。この文字列に情報を表示するには、バージョン管理を使用する必要があります。 |
VersionControl_PrjFolderRevNumberShort |
プロジェクトの短縮形式のGitハッシュ(先頭8文字) とVCSステータス。 この文字列に情報を表示するには、バージョン管理を使用する必要があります。 |
VersionControl_RevNumber |
Draftsmanドキュメントの現在のリビジョン番号。この文字列に情報を表示するには、バージョン管理を使用する必要があります。 |
VersionControl_RevNumberShort |
Draftsmanドキュメントの現在のリビジョン番号を表す短縮形式のGitハッシュ(先頭8文字)とVCSステータス。この文字列に情報を表示するには、バージョン管理を使用する必要があります。 |
ViewLabel |
基板断面ビュー または 基板詳細ビュー のプロパティのTitleフィールドで使用し、ビューに適用されているLabelを表示します。 |
ViewLayerName |
基板製造ビュー のプロパティのTitleフィールドで使用し、ビューの作成対象となったLayerを表示します。 |
ViewScale |
ビューのプロパティのTitleフィールドで使用し、ビューで選択されている Scaleを表示します。 |
ViewSide |
基板実装ビュー、基板製造ビュー、部品ビュー、または基板アイソメトリックビュー のプロパティのTitleフィールドで使用し、ビューの作成対象となったView Side / Face sideを表示します。 |
ViewVariantName |
基板実装ビュー または基板アイソメトリックビュー のプロパティのTitleフィールドで使用し、ビューの作成対象となったVariationを表示します。 |
PCBパラメーター
Arc_Count |
DraftsmanドキュメントのソースPCBに含まれる円弧オブジェクトの数。 |
BoardArea |
Draftsmanドキュメントで選択された主単位で表示される、ソースPCBの面積。 |
BoardDensity |
DraftsmanドキュメントのソースPCBの密度。 |
BoardHeight |
Draftsmanドキュメントで選択された主単位で表示される、ソースPCBの高さ。 |
BoardWidth |
Draftsmanドキュメントで選択された主単位で表示される、ソースPCBの幅。 |
BlindVia_Count |
DraftsmanドキュメントのソースPCB上のブラインドビアの数。 |
BuriedVia_Count |
DraftsmanドキュメントのソースPCB上のベリードビアの数。 |
Component_Count |
DraftsmanドキュメントのソースPCBに含まれるコンポーネントオブジェクトの数。 |
ComponentMixed_Count |
DraftsmanドキュメントのソースPCB上で、SMDパッドとスルーホールパッドが混在するコンポーネントの数。 |
ComponentsArea |
Draftsmanドキュメントで選択された主単位で表示される、ソースPCBのコンポーネント面積。 |
ComponentSMD_Count |
DraftsmanドキュメントのソースPCB上で、SMDパッドを持つコンポーネントの数。 |
ComponentThru_Count |
DraftsmanドキュメントのソースPCB上で、スルーホールパッドを持つコンポーネントの数。 |
ComputerName |
Draftsmanドキュメントが作成されたコンピューターのシステム名。 |
CopperInner_Weight_Max |
内層の最大銅箔重量。 |
CopperOuter_Weight_Max |
外層の最大銅箔重量。 |
Fill_Count |
DraftsmanドキュメントのソースPCBに含まれるフィルオブジェクトの数。 |
Hole_Count |
DraftsmanドキュメントのソースPCBに含まれるパッド/ビアの穴の数。 |
Hole_Size_Min |
Draftsmanドキュメントで選択された主単位で表示される、ソースPCBの最小穴径。 |
Hole_Size_Num |
DraftsmanドキュメントのソースPCB上の穴径の種類数。 |
Item |
Project Releaserを使用してプロジェクトのソースデータがリリースされた、最新のPCBプロジェクト設計アイテムの名前。 例: SRC-Sample - Kame_FMU。 |
ItemRevision |
Project Releaserを使用してプロジェクトのソースデータがリリースされた、最新のPCBプロジェクト設計アイテムのアイテムリビジョン。 例:01.A.1。 |
ItemRevisionBase |
Project Releaserを使用してプロジェクトのソースデータがリリースされた、最新のPCBプロジェクト設計アイテムのアイテムリビジョンのベースレベル部分。 例:1。 |
ItemRevisionLevel1 |
Project Releaserを使用してプロジェクトのソースデータがリリースされた、最新のPCBプロジェクト設計アイテムのアイテムリビジョンのレベル1部分。 例:A。 |
ItemRevisionLevel2 |
Project Releaserを使用してプロジェクトのソースデータがリリースされた、最新のPCBプロジェクト設計アイテムのアイテムリビジョンのレベル2部分。例:01。 |
Layer_Count |
DraftsmanドキュメントのソースPCBの銅箔層数。 |
MicroVia_Count |
DraftsmanドキュメントのソースPCB上のマイクロビアの数。 |
Net_Count |
DraftsmanドキュメントのソースPCBに含まれるネットの数。 |
Pad_Count |
DraftsmanドキュメントのソースPCBに含まれるパッドオブジェクトの数。 |
Pcb_File_Name |
DraftsmanドキュメントのソースPCBファイルのフルパスとファイル名。例:C:\MyTestDesign\Kame_FMU.PcbDoc。 |
Pcb_File_Name_No_Path |
DraftsmanドキュメントのソースPCBのファイル名のみ(ファイルパスを除く)。例: Kame_FMU.PcbDoc。 |
PCBConfigurationName |
出力の生成元となったデータセットの名前。Release ビュー(Project Releaser)で定義されます。 |
PadSMD_Count |
DraftsmanドキュメントのソースPCB上のSMDパッドの数。 |
PadThru_Count |
DraftsmanドキュメントのソースPCB上のスルーホールパッドの数。 |
Poly_Count |
DraftsmanドキュメントのソースPCBに含まれるポリゴンプアオブジェクトの数。 |
SlotHole_Count |
DraftsmanドキュメントのソースPCBに含まれる、長穴を持つパッドオブジェクトの数。 |
SolderMask_Bottom |
ボトムソルダーマスクの有無。ボトムソルダーマスク層がない場合、パラメーターの値はNo maskになります。 ボトムソルダーマスク層があっても色が定義されていない場合、パラメーターの値はNo colorになります。ボトムソルダーマスク層があり、色が定義されている場合、パラメーターには色名(Green、Black、Blue、Redなど)またはRGBAコード(例:#FF0065FF)が表示されます。 |
SolderMask_Top |
トップソルダーマスクの有無。トップソルダーマスク層がない場合、パラメーターの値はNo maskになります。 トップソルダーマスク層があっても色が定義されていない場合、パラメーターの値はNo colorになります。トップソルダーマスク層があり、色が定義されている場合、パラメーターには色名(Green、Black、Blue、Redなど)またはRGBAコード(例:#FF0065FF)が表示されます。 |
SquareHole_Count |
DraftsmanドキュメントのソースPCBに含まれる、角穴を持つパッドオブジェクトの数。 |
StackedVia_Count |
DraftsmanドキュメントのソースPCB上のスタックビアの数。 |
String_Count |
DraftsmanドキュメントのソースPCBに含まれるテキストオブジェクトの数。 |
Thru_Via_Count |
DraftsmanドキュメントのソースPCB上のスルーホールビアの数。 |
Total_Thickness |
DraftsmanドキュメントのソースPCBの総厚。 |
Track_Count |
DraftsmanドキュメントのソースPCBに含まれるトラックオブジェクトの数。 |
VariantName |
Draftsmanドキュメントで選択された設計バリアントの名前。 |
Via_Count |
DraftsmanドキュメントのソースPCBに含まれるビアオブジェクトの数。 |
グリッドとスナップオプションの設定
Draftsmanドキュメントにオブジェクトを配置する前に、グリッドとスナップオプションを設定すると、配置が容易になります。グリッドとスナップオプションは、デザインスペースで何もオブジェクトを選択していない状態で、PropertiesパネルのGeneralタブにあるGeneral領域で設定します。
デザインスペースでは、グリッド線は点線で表示され、10本ごとに実線で表示されます。ドキュメント内で何もオブジェクトを選択していない状態で、PropertiesパネルのGrid Sizeフィールドを使用してグリッド線の間隔を設定します。または、メインメニューからView » Set Grid Sizeコマンド(ショートカット:G)を選択して開くSnap Grid (1..1000)ダイアログ(
)でも、グリッド値を設定できます。
Show Gridオプションを使用して、ドキュメントシートでのグリッド線の表示を制御します。 対応する色ボタン を使用して、デザインスペース内のグリッドの色を指定します。
スナップは、Draftsmanドキュメントのシート上でオブジェクトを配置、移動する際の補助機能です。既存のオブジェクトから生成された点やガイド、またはドキュメントに定義されたグリッドにプリミティブを引き寄せます。これにより、ドキュメントのページ上のさまざまな要素をすばやく簡単に整列できます。スナップは、PropertiesパネルのSnappingオプション、またはメインメニューのView » Toggle Snapping コマンド (ショートカット:Shift+E)で有効または無効にできます。
スナップ機能が有効な場合は、以下のオプションを個別に有効または無効にして、さらに詳細に設定できます。
| Snap to Grid | 有効にすると、エディターがオブジェクト配置モードのときに、プレビューカーソルがグリッド線の交点にスナップ(ジャンプ)します。 グリッドが表示されていない場合(つまり、Show_Grid オプションが無効な場合)は、グリッドへのスナップは機能しません。 |
| Snap to Vertices | 有効にすると、エディターがオブジェクト配置モードのときに、プレビューカーソルがオブジェクトの角(頂点)にスナップします。プレビューカーソルが頂点にスナップすると、その頂点がオレンジ色の点で強調表示されます。 |
| Snap to Boundaries | 有効にすると、エディターがオブジェクト配置モードのときに、プレビューカーソルがオブジェクトの外周線(またはその辺の延長線)にスナップします。オブジェクトの外周の延長線は、細い破線で表示されます。 |
| Snap to Line centers | 有効にすると、エディターがオブジェクト配置モードのときに、プレビューカーソルがオブジェクトの外周線の中点にスナップします。プレビューカーソルが線の中点にスナップすると、その中点がオレンジ色の点で強調表示されます。 |
| Snap to Circle centers | 有効にすると、エディターがオブジェクト配置モードのときに、プレビューカーソルが円オブジェクトの中心にスナップします。プレビューカーソルが円の中心点にスナップすると、その中心点がオレンジ色の点で強調表示されます。 |
| Snap to component references | 有効にすると、プレビューカーソルがコンポーネントの基準点にスナップします。 |
| Snap to Visible primitives | 有効にすると、プレビューカーソルは、シートの現在の表示範囲内にあるオブジェクトプリミティブにスナップします(スナップ動作は他のスナップオプションによって決まります)。無効にすると、カーソルはシート上に存在するすべてのオブジェクトにスナップします。 ![]() |
Snapping Distance オプションを使用して、プレビューカーソルがスナップ対象として指定された要素にスナップする距離を入力します。または、ドロップダウンから現在のグリッドに対する相対値(例:0.5x Snap Grid)を選択します。
ドキュメントシート(ページ)の設定
Draftsmanドキュメントはマルチシート形式であり、基板プロジェクトの特定の種類の製造情報に割り当てられた個別のページ(シート)を含めることができます。
現在のドキュメントへのシートの追加と削除は、メインメニューのToolsまたはデザインスペースの右クリックメニューにあるAdd New SheetおよびRemove Sheetコマンドで行えます。 新しいシートは、コマンド実行時にカーソルがあるシートの後に挿入され、直前のシートに現在適用されているDraftsmanシートテンプレートに従って表示されます。
Draftsmanドキュメントの個々のページ(シート)の設定は、デザインスペースでオブジェクトが選択されていない状態で、PropertiesパネルのPage Optionsタブで定義できます。 これらの設定によって、ページの基本構造(サイズ、余白など)が決まります。
ページオプションのプロパティに加えた変更は、現在のページまたはドキュメント内のすべてのページに適用できます。Propertiesパネル上部の
ボタンを選択すると、変更したプロパティ設定が現在のシートに適用され、
ボタンを選択すると、ドキュメント内のすべてのシートに変更が適用されます。現在のページ番号は、Current Page ドロップダウンに表示され、このドロップダウンから選択することもできます。
パネルのFormatting and Size領域で、ページ形式の定義方法を選択できます。
| Template | 使用可能なDraftsmanシートテンプレートから選択して、ページのサイズと形式を設定します。 Workspaceテンプレート(接続中のWorkspaceの項目の下に |
| Standard | シートサイズを標準のページ形式に設定します。Sheet Sizeドロップダウンメニューを使用して、標準のページ寸法のリストから選択します。 |
| Custom | WidthおよびHeightフィールドを使用して、シートサイズを指定したカスタム寸法に設定します。幅または高さに入力できる最大値は20000 mmです。 |
パネルのMargin and Zones領域にあるオプションで、シートの図枠のサイズとゾーン分割を定義します。
| Show Zones | 有効にすると、図枠にゾーン分割が表示されます。 |
| Vertical | シートの縦方向の余白の分割数(行数)を設定します。ゾーンラベルに使用する英数字の種類は、パネルのこの領域にあるOriginおよびLetter Positionの設定で定義します。 |
| Horizontal | シートの横方向の余白の分割数(列数)を設定します。ゾーンラベルに使用する英数字の種類は、パネルのこの領域にあるOriginおよびLetter Positionの設定で定義します。 |
| Margin | ページの端から4本の各図枠線までの距離を設定します。 |
| Origin | ドキュメントシートの外周にあるゾーンの英数字表示を、どの隅から開始するかを設定します(ゾーン位置A-1または1-A)。 |
| Letter Position | ドキュメントシート上で文字のゾーンインジケーターを配置する位置を、水平方向の外周ゾーン(列)または垂直方向のゾーン(行)から設定します。 列に割り当てられた英数字のインジケーターを、シートごとに A または 1 から開始するのではなく、すべてのドキュメントシートにわたって連続して増加させるには、Iterate Columns Across Sheets オプションをオンにします。 |
Bookmarksパネルを使用したDraftsmanドキュメントのナビゲーション
Bookmarks パネルでは、複数シートからなるDraftsmanドキュメントを簡単にナビゲートおよび管理できます。このパネルには、Projects パネルと同様に、ドキュメント全体の構造が展開可能なツリービューで表示されます。ツリーには、すべてのドキュメントシートと、各シート内の主要なビューオブジェクトが含まれます。

Bookmarks パネルを使用して、複数シートからなるDraftsmanドキュメント内のビュー間を移動します。
Bookmarks パネルには、Draftsmanドキュメント内のシートとオブジェクトが階層化されたツリービューで表示され、各シートの項目を展開したり折りたたんだりできます。ツリー内のシート項目には、Draftsmanによって降順で自動的に名前が付けられます。パネル内の各シート項目の配下には、そのシート上のDraftsmanのビュータイプのオブジェクトが含まれますが、寸法、コールアウト、図形などの補助的な作図オブジェクトは含まれません。
Bookmarks パネルには、ツリーで選択したシートや作図オブジェクトにデザインスペース内でフォーカスする、アクティブなナビゲーション機能があります。ツリーでオブジェクトを選択すると、図面ビューでもそのオブジェクトが選択され、オブジェクトが収まるようにズームされます。ツリービューのナビゲーションは双方向に連動するため、デザインスペースでシートやオブジェクトを選択すると、ツリー側の選択もそれに応じて変わります。
Bookmarks パネルには、シートの追加や削除、Draftsmanドキュメント構造内での配置順序の変更など、ドキュメントシートを管理するための追加機能も用意されています。パネル上部に並ぶ機能ボタンを使用して、ドキュメントシートの表示と構造を管理します。
-
Single/Continuousボタンを使用して、ドキュメントのページ表示形式を設定します。
ボタンを使用すると、デザインスペースにシートが1枚ずつ表示され、
ボタンを使用すると、すべてのシートがスクロール可能な連続表示になります。
-
ボタンをクリックすると、現在選択しているシートの後に新しいドキュメントシートが追加されます。
ボタンを使用すると、現在選択しているシートがツリーリストから削除されます。作図オブジェクトを選択している場合は、そのオブジェクトがシートから削除されます。
-
ボタンと
ボタンを使用すると、現在選択しているシートをツリーリスト内で1つ上または下に移動できます。それに伴ってシートとそのシート内のオブジェクトの位置が変わり、ツリー内の新しい位置に合わせてシート名が変更されます。
ツリー内のシートまたはオブジェクトの右クリックコンテキストメニューから、その他のオプションを利用できます。
-
シートの右クリックオプションを使用すると、選択したシートの削除、ドキュメントへの新しいシートの追加、または Properties パネルでのプロパティの表示ができます。このパネルがまだ開いていない場合は、自動的に開きます。
-
オブジェクトの右クリックオプションを使用すると、選択したオブジェクトの削除、または Properties パネルでのプロパティの表示ができます。このパネルがまだ開いていない場合は、自動的に開きます。
設計バリアントのサポート
Altium Designerでは、基板設計のバリエーション(設計バリアント)を作成し、そのバリアント情報をDraftsmanに渡すことができます。これにより、配置済みの図面ビューやBOMテーブルに設計バリエーションを適用できます。各バリアントにはパラメーターを追加できます。これらのパラメーターは通常、現在有効なバリアントを示すために、Altium Designerドキュメント内で特殊文字列(解釈される文字列)として使用されます。
Draftsmanでドキュメントレベルのプロジェクトの現在のバリアントを選択するには、デザインスペースで何も選択していない状態で、Properties パネルの General タブにある Properties 領域の Variants ドロップダウンを使用します。
配置済みの 基板アセンブリビュー、基板アイソメトリックビュー、基板リアリスティックビュー には、選択したバリアントが反映されます。基板アセンブリビューでは、未実装部品の表示方法は、設定されたドキュメントオプションに従います(詳細はこちら)。基板アイソメトリックビューまたは基板リアリスティックビューでは、未実装部品はビューに表示されません(
)。ビューの現在のバリアントは、デザインスペースでそのビューを選択した状態で、Properties パネルから選択できます。
=VariantName やバリアントパラメーターなどの特殊文字列は、フリー文字列として図面に配置できます。
テキストオブジェクトの詳細については、 注釈の操作 ページを参照してください。
)
)
)
)
)を見ると、現在有効な主単位をすばやく確認できます。

)が表示されます。

)に表示されます。

)
