Draftsmanエディタのショートカット
概略
- 編集、選択、移動、ズーム、グリッド制御など、日常的な操作に使えるDraftsman固有のショートカットを学べます。
- 常に使用できるショートカットと、オブジェクトの配置や移動などのインタラクティブ操作中にのみ使用できるショートカットを確認できます。
- Draftsmanエディターでの作業を効率化する、ポップアップメニューや書式設定用のショートカットキーを見つけられます。
以下のセクションでは、Draftsmanエディター固有のショートカットキーを紹介します。ショートカットキーへのアクセスや編集、Altium環境全般のショートカット、アクセラレーターキーなど、ショートカットキーに関する一般的な情報については、Altium Designerのショートカットキーを参照してください。
ショートカットキーの一覧を確認する際は、以下の点に注意してください。
-
ショートカットの表記でプラス(+)記号が使われている場合は、示された順序でキーボードの複数のキーを押したままにすることを意味します。たとえば、
Shift+F1は、Shiftキーを押したままF1キーを押すことを意味します。同様に、Shift+Ctrl+PgUpは、Shiftキーを押したまま、さらにCtrlキーも同時に押し続け、PgUpキーを押すことを意味します。 -
標準のマウスボタンを使用する場合、
Clickはマウスの左ボタンを1回クリックすること、Double-Clickはマウスの左ボタンを2回クリックすること、Right-Clickはマウスの右ボタンを1回クリックすることを意味します。
標準ショートカット
以下は、Draftsmanエディターの標準ショートカットです。通常の操作時に使用でき、インタラクティブな操作を実行している必要はありません。
一般的な編集 |
|
Double-Click |
現在カーソルの下にあるオブジェクトのプロパティを変更します。 |
Right-Click |
設計スペースのコンテキストメニューを開きます。インタラクティブコマンドの実行中は、現在の操作を終了します。 |
Ctrl+C |
選択範囲をコピーします。 |
Ctrl+X |
選択範囲を切り取ります。 |
Ctrl+V |
選択範囲を貼り付けます。 |
Delete |
選択範囲を削除します。 |
Ctrl+Z |
元に戻します。 |
Ctrl+Y |
やり直します。 |
選択 |
|
Click |
現在カーソルの下にあるオブジェクトを選択します。 |
Shift+Click |
オブジェクト上で操作すると、そのオブジェクトを現在の選択範囲に追加します(追加選択)。 |
Ctrl+A |
現在のドキュメント内のすべてのオブジェクトを選択します。 |
Click(オブジェクトのない場所で), Hold&Drag (左から右へ) |
選択領域に完全に収まるすべてのオブジェクトを選択します。 |
Click(オブジェクトのない場所で), Hold&Drag (右から左へ) |
選択領域に完全に収まる、または選択領域の境界に接するすべてのオブジェクトを選択します。 |
Shift+Tab |
基板実装図で、コンポーネントと、それに重なっているデジグネーターの選択を切り替えます。 |
移動 |
|
Click(オブジェクト上で), Hold&Drag |
現在カーソルの下にある単一のオブジェクトを移動します。そのオブジェクトが選択範囲の一部である場合は、選択されているオブジェクトのグループを移動します。 |
Left Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド1単位ずつ左に移動します。 |
Shift+Left Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド10単位ずつ左に移動します。 |
Right Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド1単位ずつ右に移動します。 |
Shift+Right Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド10単位ずつ右に移動します。 |
Up Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド1単位ずつ上に移動します。 |
Shift+Up Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド10単位ずつ上に移動します。 |
Down Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド1単位ずつ下に移動します。 |
Shift+Down Arrow |
現在の選択範囲(選択されている1つ以上の設計オブジェクト)を、現在のドキュメントの設計スペース内で、スナップグリッド10単位ずつ下に移動します。 |
Draftsmanシートの表示 |
|
Ctrl+PgDn |
アクティブなDraftsmanドキュメント全体が可能な限り表示されるように、設計スペースの表示を変更します。ドキュメントに複数のシートが含まれている場合、特にシート数が非常に多い場合は、ドキュメント全体を画面内に収められないことがあります。この場合、ドキュメントの中心を設計スペースの中心に合わせ、可能な範囲を画面内に収めて表示します。 |
PgUp |
現在のカーソル位置を基準に拡大します。 以下のいずれかの方法で、マウスを使用してドキュメントの特定の領域を拡大することもできます(使用できる方法は、マウスボタンの割り当てによって異なります)。
|
PgDn |
現在のカーソル位置を基準に縮小します。 以下のいずれかの方法で、マウスを使用してドキュメントの特定の領域から表示を縮小できます(使用できる方法は、マウスボタンの割り当てによって異なります)。
|
Mouse Wheel |
設計スペース内を垂直方向にスクロールします。これはデフォルトの設定であり、PreferencesダイアログのSystem – Mouse Wheel Configurationページで変更できます。 |
Shift+Mouse Wheel |
設計スペース内を水平方向にスクロールします。これはデフォルトの設定であり、PreferencesダイアログのSystem – Mouse Wheel Configurationページで変更できます。 |
Right-Click, Hold&Drag |
スライド(パン)用の手の形のカーソルを表示し、ドラッグして設計スペースの表示位置を移動します。 |
グリッド |
|
G |
Snap Gridダイアログを開き、必要なグリッドサイズを設定します。 |
Shift+Ctrl+G |
現在のドキュメントでグリッドの表示と非表示を切り替えます。 |
Ctrl+Shift |
オブジェクトの配置中または移動中に、グリッドを一時的に無効にします。 |
Shift+E |
スナップ機能のオンとオフを切り替えます。 |
テキストの検索 |
|
Ctrl+F |
テキストを検索します。 |
F3 |
検索テキストの次の出現箇所を検索します。 |
その他 |
|
Shift+Ctrl+C |
現在選択されているテキストオブジェクト(タイトルまたは注記)から書式をコピーします。または、書式をコピーするテキストオブジェクトを選択し、メインのEditメニューからFormat Painterコマンドを実行します。 |
Shift+Ctrl+V |
以前に選択したテキストオブジェクトからコピーした書式を、現在選択されているテキストオブジェクト(タイトルまたは注記)に貼り付けます。また、メインのEditメニューからFormat Painterコマンドを実行した場合は、他のタイトルまたは注記オブジェクトをクリックするだけで、コピーした書式をそれぞれに適用できます。 |
F11 |
Properties パネルの表示と非表示を切り替えます。 |
インタラクティブショートカット
以下のショートカットは、新しい設計オブジェクトの配置や既存のオブジェクトの移動など、インタラクティブな操作を開始すると使用できるようになります。使用できるショートカットは、インタラクティブコマンドと、そのコマンドの対象となる設計オブジェクトによって異なります。
PgUp |
ズームインします。 |
PgDn |
ズームアウトします。 |
X |
移動中のオブジェクトをX軸に沿って反転します。 |
Y |
移動中のオブジェクトをY軸に沿って反転します。 |
Esc |
現在の処理(実行中の対話型コマンドの現在のステップ、またはコマンド自体)を終了します。 |
Spacebar |
移動中のオブジェクトを反時計回りに90°単位で回転します。 |
Shift+Spacebar |
移動中のオブジェクトを時計回りに90°単位で回転します。 |
Backspace |
領域の配置中に、最後に配置したセグメントを削除します。 |
ポップアップメニューのショートカット
以下のショートカットを使用すると、設計スペース内から特定のコマンドのポップアップメニューに直接アクセスできます。 これらの一部は、エディターのメインメニュー内にあるサブメニューなので、見覚えがあるかもしれません。各メインメニューにも、設計スペース内からすばやくアクセスするためのポップアップキーが定義されています。 詳細はアクセラレーターキーを参照してください。
B |
Toolbars サブメニュー (メインの表示 メニュー内)。 |
K |
Panelsサブメニュー (メインの表示 メニュー内)。 |
M |
移動コマンドのポップアップメニュー。 |
S |
Select サブメニュー (メインのEditメニュー内)。 |
Z |
ズームコマンドのポップアップメニュー。 |