表の操作

概略

この記事では、Altium DesignerでDraftsmanの表を配置・設定する方法を解説します。特に部品表(BOM)に焦点を当て、そのデータがPCBプロジェクト、ActiveBOM、バリアント、実装図からどのように直接取得されるかを説明します。また、Propertiesパネルで設定できる主な項目として、書式設定、データソースの選択、表示モード、バリアントに基づくフィルタリング、列の管理、大規模設計向けの複数ページにわたるBOMの扱いを順に紹介します。Draftsmanドキュメントで基板製造・実装データを正確かつ見やすく提示する方法を理解したい方に向けて、利用できるオプションとその効果的な使い方を解説します。ぜひ読み進めて、PCBドキュメントをより自在に作成するための知識を身につけてください。

- BOMテーブルのデータがどこから取得されるのか、またProject、Board、バリアント、実装図などのオプションが表示内容にどう影響するのかを学べます。
- タイトル、フォント、行の色、列、並べ替え、エイリアスなど、BOMテーブルの外観と構成をカスタマイズする方法を確認できます。
- BOMテーブルの分割の仕組みを理解し、大きな部品表を複数のテーブルオブジェクトやページに分けて表示できるようになります。
AIでさらに深掘り:

Draftsmanドキュメントでは、さまざまなデータテーブルを図面に配置し、必要に応じて設定できます。テーブルのデータはプロジェクトのPCBドキュメントから直接取得され、PCBの製造および実装工程に必要な重要情報を、わかりやすく視覚的に伝えられます。

配置するテーブルの種類は、メインメニューの Place から選択できます。

部品表

Draftsmanの部品表(Place » Bill Of Materials)は、PCB設計で使用される物理的な実装部品を一覧表示する、自動生成のテーブルオブジェクトです。BOMテーブルのデータは、プロジェクトのActiveBOMドキュメントから直接取得されます。現在のプロジェクトにActiveBOMドキュメントがない場合は、プロジェクトのソースドキュメントから直接取得されます。BOMテーブルには、指定した 設計バリアント または配置済みの基板実装ビューを構成する項目を表示することもできます。

2つのBOMオブジェクトに分割された部品表。上の例では、BOMの内容をフィルタリングして、基板上面の実装ビューに含まれる項目を表示しています。
2つのBOMオブジェクトに分割された部品表。上の例では、BOMの内容をフィルタリングして、基板上面の実装ビューに含まれる項目を表示しています。

配置した部品表の表示スタイルとデータ内容は、デザインスペースでテーブルを選択すると、Propertiesパネルで設定できます。テーブルの一般プロパティは、パネルのGeneralタブ()で設定します。

タイトル

タイトル

テーブルとともに表示されるタイトル文字列です(表示が有効な場合)。対応するボタンを使用して、図面上のタイトルの表示と非表示を切り替えます。

このフィールドには、固定テキストと、特殊文字列形式の任意のパラメーターを含めることができます。タイトルにパラメーターを含めるには、=<ParameterName> 構文を使用します。含めたパラメーターの値は、図面シート上のタイトルに表示されます。使用可能なシステムパラメーターおよびPCBパラメーターの一覧については、 Draftsmanドキュメントの設定ページを参照してください。

Location ドロップダウンから、タイトルの相対位置を選択します。タイトルを手動で移動した場合(新しい位置にドラッグ&ドロップした場合)、Manualオプションが自動的に選択されます。
Font

タイトルに使用するフォントを設定します。

  •  Use Document Fontオプションが有効な場合、タイトルにはドキュメントオプションで定義されたフォントが使用されます(デザインスペースで何も選択されていないときの、 PropertiesパネルのGeneralタブにある General領域のDocument Font項目)。

  •  Use Document Fontオプションが無効な場合は、表示されるオプションを使用して、フォントの種類、サイズ、色、文字属性を選択します。

プロパティ

Table Line Style

ドロップダウンを使用して、テーブルの描画に使用する線を選択します。選択可能なオプションは、デザインスペースで何も選択されていないときのPropertiesパネルのLine Styles領域で定義されます。詳細については、Draftsmanドキュメントの設定ページを参照してください。対応する色ボタンを使用して、線の色を指定します。

Justification テーブルのサイズが更新されたときに、位置変更の基準となる点を選択します。
Even Row Color テーブルの偶数行に使用する、区別しやすい色を選択します。
Non-Even Row Color テーブルの奇数行に使用する、区別しやすい色を選択します。
Font

テーブルのデータ内容に使用するフォントを設定します。

  •  Use Document Fontオプションが有効な場合、ドキュメントオプションで定義されたフォントが使用されます(デザインスペースで何も選択されていないときの、 PropertiesパネルのGeneralタブにある General領域のDocument Font項目)。

  •  Use Document Fontオプションが無効な場合は、表示されるオプションを使用して、フォントの種類、サイズ、色、文字属性を選択します。

テーブルは、選択したフォントサイズに合わせて自動的に拡大・縮小されます。

Data Source テーブルに含まれるデータは、このオプションと、プロジェクト内にActiveBOMドキュメントが存在するかどうかによって決まります。

 

  • Project – このオプションが選択され、現在のプロジェクトに ActiveBOMドキュメントが含まれている場合、その設定と内容がDraftsmanのBOMテーブルのデータソースになります。ActiveBOMドキュメントの最新の変更を取り込むには、DraftsmanのTools » Import Changes From <PCBDocumentName>.PcbDocコマンドを使用します。
    現在のプロジェクトにActiveBOMドキュメントが含まれていない場合、DraftsmanのBOMテーブルのデータは、プロジェクトのソースドキュメントから直接取得されます。

  • Board – このオプションが選択されている場合、DraftsmanのBOMテーブルの項目は、プロジェクトの実際のPCB上に存在する部品に限定されます。

Assembly View ドロップダウンメニューのオプションを使用して、一覧表示されるBOM項目を、指定した基板実装ビューに表示される項目に絞り込みます。
View Mode
  • Base – 部品の種類ごとにテーブルの行が割り当てられ、含まれるすべての部品がDesignator列に表示されます。

  • Flat – 個々の部品ごとにテーブルの行が割り当てられます。

  • Consolidated – ソースプロジェクトにバリアントが含まれている場合、すべての設計バリアントの部品項目がテーブルに含まれます。このオプションを選択すると、Variantオプションが自動的に[No Variations]に設定されます。

Variant

利用可能な場合は、ドロップダウンメニューを使用して、BOMテーブルのデータソースとなる設計バリアントを選択します。テーブルには、Show Componentsオプションに従って、未実装の項目やパラメーターが変更された項目が反映されます。

VariationとしてDocument : <VariantName>オプションが選択されている場合、ドキュメントに指定されたバリアントがテーブルに適用されます。ドキュメントレベルのバリアントは、デザインスペースで何も選択されていないときに、PropertiesパネルのGeneralタブにあるSource領域のVariantsドロップダウンで選択します。詳細については、 Draftsmanドキュメントの設定ページを参照してください。

Show Components

バリアントを選択した場合は、ドロップダウンを使用して、一覧に含める部品項目を選択します。

  • Fitted – 現在選択されている設計バリアントで実装される部品のみを表示します。

  • All – すべての部品を表示します。

  • Not Fitted – 現在選択されている設計バリアントで実装されない部品のみを表示します。

  • Replaced – 現在選択されている設計バリアントで、代替部品が選択されている部品、またはパラメーター値が変更された実装部品のみを表示します。

Show Componentsで Fitted、 Not Fitted、または Replaced オプションが選択されたBOMテーブルは、View Modeで Base および Flat オプションが選択されている場合に機能します( Consolidatedでは機能しません)。

ページi

BOM Table ID BOMテーブルのインスタンスを識別する数値です。テーブル全体を複数のBOMテーブルオブジェクト(ページ)に分割できますが、IDは共通のままです。
Limit Page Height チェックを入れると、BOMテーブルは、Max Page Heightプロパティで指定された高さの仮想ページに分割されます。
Max Page Height テーブルの各ページの高さと、それによって決まる行数を設定します。配置されたBOMテーブルオブジェクトには1ページのみが含まれます(下記のPageを参照)。すべてのページを表示するには、追加のBOMテーブルオブジェクトを配置します。
Page 選択したBOMテーブルオブジェクトに表示されるテーブルのページ番号(1 from 2、3 from 5など)を示します。対応するドロップダウンメニューを使用して、現在選択されているBOMテーブルオブジェクトに表示するページを指定します。
Show Empty Lines チェックを入れると、BOMテーブルの空白行が表示されます。通常、これらはBOMテーブルの最終ページに表示され、指定されたページの高さが、利用可能なBOMデータ行数を超えている場合に生じます。

PropertiesパネルのColumnsタブを使用して、BOMテーブルのデータ列を管理します。

PropertiesパネルのColumnsタブで、配置されたBOMテーブルの列を操作します。
PropertiesパネルのColumnsタブで、配置されたBOMテーブルの列を操作します。

  • 各項目を編集して、BOMテーブルに含める(表示する)列と、そのテキストの配置(Align)を指定できます。

  • Widthの項目を使用して、列に含まれるテキストに対する列幅を定義します。Autoを入力すると、列内で最も幅の広いセルのテキストに合わせて、列幅が動的に変化します。

  • Order列内をクリックすると、テーブル列のデータの並べ替え順序(オフ、昇順、降順)が切り替わります。複数の列に優先順位を付けて並べ替えを適用でき、テーブル内で左側にある並べ替え対象の列ほど優先順位が高くなります。

  • テーブル列のパラメーター名に対してAliasを入力すると、BOMテーブルの見出しを変更できます。これは、ActiveBOMドキュメントによってテーブルの内容が決定されていない場合に適用されます(上記のData Sourceを参照)。

  • 列タイプのフィルターチェックボックスを使用すると、一致するパラメーターデータタイプの列が使用可能な列のリストに表示されます。タイプには、BOM()、回路図()、サーバー()、PCB()があります。すべてのタイプの選択を解除すると、BOMテーブルで表示されている列のみがリストに表示されます。

  • ボタンとボタンを使用すると、選択した項目が1つ上または下に移動し、BOMテーブル内の列の順序が左または右に移動します。表示するように設定された列で使用できます。

  • ボタンをクリックすると、テーブルの列がデフォルトの項目に戻ります(PreferencesダイアログのDraftsman – DefaultsページにあるBOMテーブルオブジェクトのデフォルト設定で定義されています)。

BOMテーブルの分割

高度なPCBプロジェクトの部品表には、多くの項目が含まれる傾向があり、図面ドキュメントに収まるテーブルとして再現するのが難しい場合があります。BOMの分割機能を使用すると、フォントやテーブルの縮小、複数のカスタムテーブル項目、外部ドキュメントに頼ることなく、BOMテーブルを複数の「ページ」にわたって表示できます。

複数ページのBOMテーブルを作成するには、配置されたBOM(ドキュメントのシートの高さを超えている可能性があります)を選択し、PropertiesパネルのPages領域にあるLimit Page Heightチェックボックスにチェックを入れます。これにより、テーブルの高さが指定された高さ(Max Page Height, mm)に制限され、それに応じてBOMテーブルに表示される行数も制限されます。

Javascript ID: Draftsman_BOM_LimitPageHeight

DraftsmanはBOM全体が表示されていないことを検出し、その状態がパネルのPage項目(例:Page 1 from 2)に示されます。対応するドロップダウンメニューで、表示するページを指定できます。BOMの追加ページ(ここではBOM Table ID = 0)を追加するには、別のBOMを配置し、Properties パネルのPages領域で次のPageを指定します。

BOMの各ページは、別のBOMテーブルを追加して適切に設定することで配置されるため、個々のBOMページ(セクション)をDraftsmanドキュメント内の任意のシートに配置できます。別のdifferent分割BOMページセットを配置するには、配置済みのBOMで異なるBOM Table IDを指定します。たとえば、0ではなく1を指定します。

Max Page Heightプロパティは、BOMテーブルのfirstページの高さを指定することに注意してください。2ページ目(ページ2)が選択されている場合、Max Page Heightプロパティは、表示対象から除外される最初のページ(ページ1)の高さを定義します。したがって、ページ2には残りのBOM項目が表示されます。まず、各ページのMax Page Heightプロパティを同じ値に設定してください。

ドリルテーブル

Draftsmanのドリルテーブル(Place » Drill Table)は、基板のドリルシンボルとデータを含む、自動生成されるテーブルオブジェクトです。ドリルテーブルは、Draftsmanのドリル図面ビューと組み合わせることで、基板製造工程に必要な情報を表と図の両方で提供します。特定の種類のドリル穴を表すシンボル行には、サイズ、めっきの有無、穴数など、さまざまな穴情報を含めることができます。穴の種類は、Drill Symbol Configurationsダイアログで指定されたシンボルごとにグループ化されます。

穴の項目をサイズ別にグループ化した、配置済みのドリルテーブル
穴の項目をサイズ別にグループ化した、配置済みのドリルテーブル

Altium DesignerにGOST 2.701-2008/2.106-1996ソフトウェア拡張機能がインストールされている場合、ドリルテーブルのPlated列の値は、Есть(めっき穴の場合)およびНет(非めっき穴の場合)として表示されます。

拡張機能の管理について詳しくは、Extending Your Installationページ(Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。

配置されたドリルテーブルの表示スタイルとデータ内容(使用するシンボルを含む)は、デザインスペースでテーブルを選択したときに、Propertiesパネルで設定できます。テーブルの一般プロパティは、パネルのGeneralタブ()で設定します。

タイトル

Title

テーブルとともに表示されるタイトルの文字列です(表示が有効な場合)。対応するボタンを使用して、図面上でのタイトルの表示と非表示を切り替えます。

このフィールドには、固定テキストと、特殊文字列形式の任意のパラメーターを含めることができます。タイトルにパラメーターを含めるには、=<ParameterName>構文を使用します。含まれるパラメーターの値は、図面シート上のタイトルに表示されます。使用可能なシステムパラメーターとPCBパラメーターの一覧については、Draftsmanドキュメントの設定ページを参照してください。

Location ドロップダウンから、タイトルの相対的な位置を選択します。タイトルを手動で移動した場合(新しい位置にドラッグ&ドロップした場合)、Manualオプションが自動的に選択されます。
Font

タイトルに使用するフォントを設定します。

  • Use Document Fontオプションが有効な場合、タイトルのフォントには、ドキュメントオプションで定義されたフォント(General内のDocument Font項目)が使用されます。領域(デザインスペースでオブジェクトが選択されていないときの、PropertiesパネルのGeneralタブ)。

  • Use Document Fontオプションが無効の場合は、表示されるオプションを使用して、フォントの種類、サイズ、色、および文字属性を選択します。

プロパティ

Layer Pairs 図面ビューに表示するPCBドリルレイヤーペアの穴を選択します。ドロップダウンメニューを使用して、ソース基板設計で使用可能なレイヤーペアから選択します。これらのレイヤーペアは、PCBエディターのレイヤースタックマネージャーで確認および編集できます。すべての基板設計にはTop - Bottomレイヤーペアがあり、その他のペアは、内層やプレーン層などの他のレイヤー間を貫通する、または他のレイヤーに達するビア穴を表します。

Counterhole BottomおよびCounterhole Topオプションは、PCBの対応する面でカウンターホール機能が有効になっているパッドがPCBドキュメントに含まれている場合にのみ使用できます(詳細)。

カウンターホールは、Counterhole BottomおよびCounterhole Top以外のレイヤーペアには含まれません。また、All Layersレイヤーペアにも含まれません。

Pads / Vias ドロップダウンを使用して、表に表示するドリル穴の種類(Pads、Vias、またはAll)を選択します。
Plated / Non-Plated ドロップダウンを使用して、表に表示する穴のめっきの種類(Plated、Non-Plated、またはAll)を選択します。
Border Line Style

ドロップダウンを使用して、表の境界線/外枠の描画に使用する線を選択します。使用可能なオプションは、デザインスペースでオブジェクトが選択されていないときの、PropertiesパネルのLine Styles領域で定義されます。詳細については、Draftsmanドキュメントの設定ページを参照してください。対応する色ボタンを使用して、線の色を指定します。

Justification 表のサイズが更新された際に、表の位置を変更する基準点を選択します。
Even Row Color 表の偶数行に使用するコントラスト色を選択します。
Non-Even Row Color 表の奇数行に使用するコントラスト色を選択します。
Font

表のデータに使用するフォントを設定します。

  • Use Document Fontオプションが有効の場合は、ドキュメントオプションで定義されたフォントが使用されます(デザインスペースでオブジェクトが選択されていないときの、PropertiesパネルのGeneralタブにあるGeneral領域のDocument Font項目)。

  • Use Document Fontオプションが無効の場合は、表示されるオプションを使用して、フォントの種類、サイズ、色、および文字属性を選択します。

表は、選択したフォントサイズに合わせて自動的に拡大・縮小されます。

Show Footer チェックを入れると、ドリル穴の総数を表示する表のフッターが有効になります。
選択するとDrill Symbol Configurationsダイアログが開きます。このダイアログでは、すべてのドリル穴データを表形式で表示し、各穴記号のスタイルとサイズを設定できます(詳細)。

単位

Primary Units

表に表示する主測定単位の種類を選択します。対応するボタンを使用して、測定単位の表示/非表示を切り替えます。

Primary UnitsとしてDocument : <Units>オプションを選択すると、ドキュメントで指定された主単位が表に適用されます。ドキュメントレベルの主単位は、デザインスペースでオブジェクトが選択されていないときに、PropertiesパネルのGeneralタブにあるUnits領域のPrimary Unitsドロップダウンで選択します。詳細については、Draftsmanドキュメントの設定ページを参照してください。

Dual Units

表に表示する副(併記)測定単位の種類を選択します。対応するボタンを使用して、副単位の値の表示/非表示を切り替えます。

Dual UnitsとしてDocument : <Units>オプションを選択すると、ドキュメントで指定された併記単位が表に適用されます。ドキュメントレベルの併記単位は、デザインスペースでオブジェクトが選択されていないときに、PropertiesパネルのGeneralタブにあるUnits領域のDual Unitsドロップダウンで選択します。詳細については、Draftsmanドキュメントの設定ページを参照してください。

精度

Primary Units

Value Precisionドロップダウンメニューを使用して、表の主単位の穴径項目の表示精度を設定します(小数点以下最大5桁、最終桁は四捨五入)。

Document : <Precision>オプションを選択すると、ドキュメントで指定された主単位の値/公差の精度が表に適用されます。ドキュメントレベルの主単位の値と公差の精度は、デザインスペースでオブジェクトが選択されていないときに、PropertiesパネルのGeneralタブにあるUnits領域で、Primary UnitsのValue PrecisionおよびTolerance Precisionオプションを使用して選択します。詳細については、Draftsmanドキュメントの設定ページを参照してください。

Dual Units

Value Precisionドロップダウンメニューを使用して、併記(副)単位の穴径項目が有効な場合の表示精度を設定します(小数点以下最大5桁、最終桁は四捨五入)。

Document : <Precision>オプションを選択すると、ドキュメントで指定された併記単位の値/公差の精度が寸法に適用されます。ドキュメントレベルの併記単位の値と公差の精度は、デザインスペースでオブジェクトが選択されていないときに、PropertiesパネルのGeneralタブにあるUnits領域で、Dual UnitsのValue PrecisionおよびTolerance Precisionオプションを使用して選択します。詳細については、Draftsmanドキュメントの設定ページを参照してください。

PropertiesパネルのColumnsタブを使用して、ドリルテーブルのデータ列()を管理します。

  • 各項目を編集して、ドリルテーブルに含める(表示する)列と、そのHorizontalおよびVerticalの配置を指定できます。

  • Width項目を使用して、列内のテキストに対する列幅を定義します。Autoを入力すると、列内で最も幅の広いセルのテキストに合わせて、幅が動的に調整されます。

  • Order列内をクリックすると、表の列データの並べ替え順序(なし、昇順、降順)が切り替わります。複数の列に優先順位を付けて並べ替えを適用できます。表の左側にある並べ替え対象の列ほど、優先順位が高くなります。

  • ドリルテーブルの見出しは、表の列パラメーター名に対してCaptionを入力することで変更できます。

  • およびを使用します ボタンを使用して、選択した項目を1つ上または下に移動し、ドリルテーブルの列順序で左または右に移動します。表示するように設定されている列で使用できます。

ドリルテーブルのシンボルスタイルと、各シンボルに対応するドリル穴タイプのグループ化は、Drill Symbol Configurations ダイアログの設定によって決まります。このダイアログは、デザインスペースでテーブルを選択した状態で、Properties パネル(General タブの Properties 領域)の ボタンをクリックすると開きます。

これは、ドリル図面ビューの Properties パネルから開くダイアログと同じですが、この場合はドリルテーブルで有効(表示)にした列のみが表示されます。2つの Drill Symbol Configuration ダイアログは同じ設定を参照するため、互いに連動することに注意してください。

Symbol Graphics ドロップダウンを使用して、あらかじめ用意された図形や文字から、穴を表すグラフィックを選択します。
Sync Symbols with PCB 有効にすると、ドリルテーブルのシンボルがPCBのシンボルと同期されます。
Symbol Size Table

テーブル内のシンボルのサイズを入力します。

  • シンボルサイズの変更は、ダイアログ上部のグリッドで現在選択されているドリルシンボルに適用されます。グリッド内の複数のドリルシンボルを選択するには、 Ctrl+Click または Shift+Click の操作を使用します。

  • また、リンクアイコンがリンク状態()の場合、ドリル図面ビューとドリルテーブルのサイズは連動します。ドリルシンボルのサイズを個別に設定するには、リンクアイコンをクリックして2つのサイズのリンクを解除し、それぞれを希望のサイズに設定します。

Symbol Size View ビュー内のシンボルのサイズを入力します。このフィールドにアクセスして編集するには、リンクアイコンがリンク解除状態()になっている必要があります。リンクアイコンをクリックすると、リンク状態が切り替わります。
Symbol Line Style

ドロップダウンを使用して、シンボルグラフィックの境界線/輪郭線の描画に使用する線を選択します。使用可能なオプションは、デザインスペースで何も選択されていないときの Properties パネルの Line Styles 領域で定義します。詳細については、Draftsmanドキュメントの設定ページを参照してください。対応する色ボタンを使用して、線の色を指定します。

Grouping 選択した条件に従って、穴が1つのシンボルにグループ化されます。たとえば、 HoleSize のみを選択した場合、PCBで使用されている穴径ごとに個別のシンボルが割り当てられます。グループ化オプションを追加で選択すると、追加の条件を区別するようにグループが細分化され、シンボルが割り当てられます。

Symbol Size Table、Symbol Size View、Symbol Line Style、Grouping のデフォルト設定は、Preferences ダイアログの Draftsman – Defaultsページで定義できます。このページで、Primitive List の Drill Table を選択し、右側のプロパティ領域にある Drill Symbol タブを開きます()。

伝送線路テーブル

インピーダンス制御配線では、目標の伝送線路インピーダンスを満たし、それによって基板設計の高速信号および/またはEMF要件を満たすことを目指して、計算に基づいた配線構造が決定されます。基板レイヤーと、その指定または計算された特性には、Layer Stack Managerからアクセスできます。ここでは、インピーダンス制御配線レイヤーを、定義可能なインピーダンスプロファイルに関連付けます。各プロファイルの基板材料と寸法が伝送線路インピーダンスの計算に適用され、配線構造が決定されます。この構造は、シングルトレースと差動ペアの両方、およびストリップライン(内層)またはマイクロストリップ(表層)の基板レイヤー構成に対応しています。

インピーダンスプロファイルの設定の詳細については、レイヤースタックの定義ページを参照してください。

基板レイヤースタック内の各伝送線路定義の構造と関連データは、PCB製造工程で重要な情報となるため、Draftsmanには、この情報を文書化するための専用の伝送線路テーブルオブジェクト(Place » Transmission Line Table)が用意されています。テーブルには、Layer Stack Managerとその伝送線路インピーダンス計算から取得したデータが入力されます。

配置された伝送線路テーブル
配置された伝送線路テーブル

配置された伝送線路テーブルの表示スタイルとデータ内容は、デザインスペースでテーブルを選択したときに表示される Properties パネルで設定できます。テーブルの一般的なプロパティは、パネルの General タブで設定します()。

タイトル

Title

テーブルとともに表示されるタイトル文字列です(表示が有効な場合)。対応する ボタンを使用して、図面内でのタイトルの表示/非表示を切り替えます。

このフィールドには、固定テキストと、特殊文字列形式の任意のパラメーターを含めることができます。タイトルにパラメーターを含めるには、=<ParameterName> の構文を使用します。含めたパラメーターの値は、図面シート上のタイトルに表示されます。使用可能なシステムパラメーターおよびPCBパラメーターの一覧については、Draftsmanドキュメントの設定ページを参照してください。

Location ドロップダウンから、タイトルの相対的な配置位置を選択します。タイトルを手動で移動した場合(新しい位置にドラッグ&ドロップした場合)は、Manual オプションが自動的に選択されます。
Font

タイトルに使用するフォントを設定します。

  • Use Document Font オプションが有効な場合、タイトルには ドキュメントオプションで定義されたフォントが使用されます(デザインスペースで何も選択されていないときの Properties パネルの General タブにある General 領域の Document Font 項目)。

  • Use Document Font オプションが無効な場合は、用意されているオプションを使用して、フォントの種類、サイズ、色、テキスト属性を選択します。

プロパティ

Table Line Style

ドロップダウンを使用して、テーブルの罫線の描画に使用する線を選択します。使用可能なオプションは、デザインスペースで何も選択されていないときの Properties パネルの Line Styles 領域で定義します。詳細については、Draftsmanドキュメントの設定ページを参照してください。対応する色ボタンを使用して、線の色を指定します。

Justification テーブルのサイズが更新されたときに、位置変更の基準となる点を選択します。
Even Row Color テーブルの偶数行に使用する色を選択し、行を見分けやすくします。
Non-Even Row Color テーブルの奇数行に使用する色を選択し、行を見分けやすくします。
Caption Font

テーブルのデータ内容に使用するフォントを設定します。

  • Use Document Font オプションが有効な場合、ドキュメントオプションで定義されたフォントが使用されます(デザインスペースで何も選択されていないときの Properties パネルの General タブにある General 領域の Document Font 項目)。

  • Use Document Font オプションがオプションが無効の場合は、 用意されているオプションを使用して、フォントの種類、サイズ、色、文字属性を選択します。

表は、選択したフォントサイズに合わせて自動的に拡大縮小されます。

Rows Font

表の本文(表の各行のテキスト)に使用するフォントを設定します。

  • Use Document Fontオプションが有効の場合、 ドキュメントオプションで定義されたフォントが使用されます(デザインスペースで何も選択されていない状態で、PropertiesパネルのGeneralタブにあるGeneral領域のDocument Font項目)。

  • Use Document Fontオプションが無効の場合は、 用意されているオプションを使用して、フォントの種類、サイズ、色、文字属性を選択します。

表は、選択したフォントサイズに合わせて自動的に拡大縮小されます。

単位

Primary Units

表に表示する主単位の種類を選択します。対応する  ボタンを使用して、測定単位の表示/非表示を切り替えます。

Document : <Units>オプションを選択すると、ドキュメントで指定された主単位が表に適用されます。ドキュメントレベルの主単位は、デザインスペースで何も選択されていない状態で、PropertiesパネルのGeneralタブにあるUnits領域のUnitsドロップダウンを使用して選択します。 詳細については、 Draftsmanドキュメントの設定ページを参照してください。

Primary Precision

主単位の値の精度(小数点以下最大5桁、最終桁は四捨五入)を選択します。

Document : <Precision>オプションを選択すると、ドキュメントで指定された主単位の値と公差の精度が表に適用されます。ドキュメントレベルの主単位の値と公差の精度は、デザインスペースで何も選択されていない状態で、PropertiesパネルのGeneralタブにあるUnits領域で、Primary UnitsのValue PrecisionおよびTolerance Precisionオプションを使用して選択します。 詳細については、 Draftsmanドキュメントの設定ページを参照してください。

Dual Units

表に表示する補助(併記)単位の種類を選択します。対応する  ボタンを使用して、補助単位の値の表示/非表示を切り替えます。

Document : <Units>オプションを選択すると、ドキュメントで指定された併記単位が表に適用されます。ドキュメントレベルの併記単位は、デザインスペースで何も選択されていない状態で、PropertiesパネルのGeneralタブにあるUnits領域のDual_Unitsドロップダウンを使用して選択します。 詳細については、 Draftsmanドキュメントの設定ページを参照してください。

Dual Precision

補助単位が有効な場合、その値の精度(小数点以下最大5桁、最終桁は四捨五入)を選択します。

Document : <Precision>オプションを選択すると、ドキュメントで指定された併記単位の値と公差の精度が寸法に適用されます。ドキュメントレベルの併記単位の値と公差の精度は、デザインスペースで何も選択されていない状態で、PropertiesパネルのGeneralタブにあるUnits領域で、Dual UnitsのValue PrecisionおよびTolerance Precisionオプションを使用して選択します。 詳細については、 Draftsmanドキュメントの設定ページを参照してください。

PropertiesパネルのColumnsタブを使用して、伝送線路のデータ列と行を管理します()。

  • Columns領域には、表に含まれる列の一覧が表示されます。 各列の項目は、表示/非表示の切り替え、見出しの名前変更(Caption)、テキストの配置オプションの切り替え(Align)、列幅の指定または自動設定(Width)によって編集できます。 一覧の項目の順序、つまり配置された表の列順は、対応するおよびボタンを使用して、選択した列の項目を移動することで変更できます。

  • Rows領域には、Impedance Id列の順序に従って並べられた表の行データが表示されます。この列は、ソースのレイヤースタック内の名前付き基板レイヤーに対応しています。各行の項目に対応する表示コントロールを使用して、表での表示/非表示を切り替えます。

表

Draftsmanドキュメントでは、図面に汎用の表を配置し、その後、Propertiesパネルや表のセル内で設定できます。カスタム表のレイアウトと内容は、用途に応じて自由に定義でき、あらゆるDraftsmanドキュメントに追加情報を柔軟に組み込むことができます。

さまざまなセル書式を適用した配置済みの表
さまざまなセル書式を適用した配置済みの表

  • 表のプロパティで使用できるオプションと表のコマンドを併用することで、Draftsmanドキュメントで必要となるさまざまな情報に対応したカスタム表を作成できます。たとえば、以下の表は、基板スタックレポートから取得した情報を表示するために作成したものです。

    カスタム表には、PCBの実装や製造に関するさまざまな情報を含めることができます。
    カスタム表には、PCBの実装や製造に関するさまざまな情報を含めることができます。

  • 表は、シートテンプレートとドキュメントテンプレートの両方に含めることができます。

表の配置コマンド(Place » Table)を実行すると、Insert tableダイアログが開き、新しい表の行数と列数を指定できます。Insert tableダイアログでOKをクリックすると、新しい表がカーソルに追従するようになり、目的の位置でもう一度クリックすると配置されます。

表の行数と列数を指定します。これらは、後からセルの右クリックメニューにあるTableコマンドで変更できます。
表の行数と列数を指定します。これらは、後からセルの右クリックメニューにあるTableコマンドで変更できます。

配置済みの表の位置は、デザインスペースで表オブジェクトを選択し、移動ハンドル(左上隅の  アイコン)を使って新しい位置にドラッグすることで、グラフィカルに変更できます。

選択した表の移動アイコンをドラッグすると、デザインスペース内で表の位置を変更できます。
選択した表の移動アイコンをドラッグすると、デザインスペース内で表の位置を変更できます。

セルまたは表のタイトルをクリックすると、表オブジェクトが選択されます。ただし、Delete コマンドは、クリックした特定の要素に適用されます。 

表の内容は、セルに直接入力(または貼り付け)して追加します。セル内で改行するには、Ctrl+Enterを使用します。

表のグラフィック属性と文字属性は、デザインスペースで表を選択した状態で、Propertiesパネル()で設定します。表オブジェクトには、テキストや構造を編集するためのさまざまな機能があり、標準の Shift+Click または Click, Hold&Dragを使用して、セルの行単位または列単位で適用できます。 手法。

タイトル

Title

テーブルとともに表示されるタイトル文字列です(表示が有効な場合)。対応する ボタンを使用して、図面内のタイトルの表示と非表示を切り替えます。

このフィールドには、固定テキストと、特殊文字列形式の任意のパラメーターを含めることができます。タイトルにパラメーターを含めるには、=<ParameterName> 構文を使用します。含まれるパラメーターの値は、図面シート上のタイトルに表示されます。 使用可能なシステムパラメーターとPCBパラメーターの一覧については、 Draftsmanドキュメントの設定ページを参照してください。

Location ドロップダウンから、タイトルの相対位置を選択します。タイトルを手動で移動した場合(新しい位置にドラッグ&ドロップした場合)は、Manual オプションが自動的に選択されます。
Font

タイトルに使用するフォントを設定します。

  •  Use Document Font オプションが有効な場合、タイトルには ドキュメントオプションで定義されたフォントが使用されます(デザインスペースでオブジェクトが選択されていないときの、 Properties パネルの General タブにある General 領域の Document Font 項目)。

  •  Use Document Font オプションが無効な場合は、用意されているオプションを使用して、フォントの種類、サイズ、色、文字属性を選択します。

プロパティ

外枠線

ドロップダウンを使用して、テーブルの境界線/外枠の描画に使用する線を選択します。使用可能なオプションは、デザインスペースでオブジェクトが選択されていないときの Properties パネルの Line Styles 領域で定義されます。詳細については、Draftsmanドキュメントの設定 ページを参照してください。 対応する色ボタンを使用して、線の色を指定します。

Inner Line ドロップダウンを使用して、セルを区切るテーブルの内側の線の描画に使用する線を選択します。使用可能なオプションは、デザインスペースでオブジェクトが選択されていないときの Properties パネルの Line Styles 領域で定義されます。詳細については、Draftsmanドキュメントの設定 ページを参照してください。 対応する色ボタンを使用して、線の色を指定します。
Column Width

選択したセルの幅を設定します。これにより、そのセルを含む列の幅も設定されます。テーブル全体を選択した場合(外枠またはタイトルをクリックした場合)、幅の設定はすべてのセルに適用されます。対応する色ボタンを使用して、現在選択されているセルの色を指定します。

Row Height このフィールドを使用して、デザインスペースで選択した行の高さを調整します。目的の高さに続けて、ヤード・ポンド法またはメートル法の単位を入力します。
Cell Padding Vertical 選択したセル内のテキストの上下の余白を設定します。
Cell Padding Horizontal 選択したセル内のテキストの左右の余白を設定します。
Font

選択したセル内のテキストに使用するフォントを設定します。

  •  Use Document Font オプションが有効な場合、ドキュメントオプションで定義されたフォントが使用されます(デザインスペースでオブジェクトが選択されていないときの、 Properties パネルの General タブにある General 領域の Document Font 項目)。

  •  Use Document Font オプションが無効な場合は、用意されているオプションを使用して、フォントの種類、サイズ、色、文字属性を選択します。

テーブルのサイズは、選択したフォントサイズに合わせて自動的に調整されます。

Alignment ボタンを使用して、選択したセル内のテキストの Horizontal (左、中央、右)および Vertical (上、中央、下)の配置と位置を設定します。
Justification テーブルのサイズが更新された際に、テーブルの位置を変更する基準となる点を選択します。

テーブルセル内の特殊文字列

テーブルには、Draftsmanドキュメントのパラメーターを特殊文字列として含めることができます。プロジェクトパラメーター(ローカルおよびWorkspace側の両方)、システムパラメーター、PCBパラメーター、ユーザーパラメーターは、テーブルセルに特殊文字列として入力すると、それぞれの値に変換されます。Draftsmanドキュメントのパラメーターには、デザインスペースでオブジェクトが選択されていないときに、Properties パネルの Parameters タブからアクセスできます。詳細については、Draftsmanドキュメントの設定ページを参照してください。

テーブルのパラメーター文字列処理では、標準のコピー&ペースト操作を使用して、スプレッドシートとの間で特殊文字列データを正しく転送することもできます。

  • Draftsmanからスプレッドシートに特殊文字列を貼り付けると、貼り付け先のスプレッドシートのセルには、その文字列を解釈した値が入力されます。

  • スプレッドシートからDraftsmanに特殊文字列データを貼り付けると、貼り付けたテキストは特殊文字列の値として解釈されます。ただし、その特殊文字列が使用可能なシステムパラメーター、プロジェクトパラメーター、またはユーザーパラメーターと一致している必要があります。

    スプレッドシートで特殊文字列を入力する場合は、セルの内容がテキストデータとして扱われるように、各入力値の先頭にアポストロフィ(')を付ける必要があります。たとえば、Unitsパラメーターの特殊文字列は '=DocumentUnits と入力します。または、スプレッドシートのすべてのセルの表示形式をテキストに設定することもできます。

テーブル構造

セル内で右クリックし、コンテキストメニューから Table メニューを選択すると、セルの設定コマンドにアクセスできます。これらのコマンドには、列や行の追加と削除、セルの結合など、テーブル操作に必要な一連の機能が用意されています。

右クリックメニューの Table コマンドには、さまざまな標準的なテーブル操作機能が用意されています。
右クリックメニューの Table コマンドには、さまざまな標準的なテーブル操作機能が用意されています。

  • Merge Cells コマンドは、テーブル内で隣接する2つ以上のセルが選択されている場合にのみ使用できます。

    • 選択範囲内のセルにテキストが含まれている状態でセルを結合すると、結合後のセルには、該当する左端または最上部のセルのテキストのみが残ります。

  • Unmerge Cells コマンドは、カーソルがテーブル内の結合セルにある場合、または選択したセル範囲に少なくとも1つの結合セルが含まれている場合にのみ使用できます。

    • セル内にテキストが含まれている場合、結合を解除すると、そのテキストは該当する左端または最上部のセルに表示されます。

    • 選択したセル範囲に複数の結合セルが含まれている状態でこのコマンドを使用すると、該当する左端または最上部の結合セルのみが結合解除されることに注意してください。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents