ハーネスの製造図面の作成

概略

この記事では、Altium DesignerのDraftsmanエディターを使用してハーネス製造図面を作成する方法を、順を追って解説します。プロジェクトへのドキュメントの追加と設定から始め、読み取り専用の配線図ビューとレイアウト図ビューの配置、詳細ビューや部品ビューの追加、さらに注釈、寸法、表を使用して製造用に設計情報を文書化する方法までを紹介します。また、配線図やレイアウト図の更新を製造図面に反映する方法や、ドキュメント内でプロパティ、単位、パラメーター、複数シート間の移動を管理する方法も取り上げます。ハーネス設計データを整理された製造ドキュメントにまとめるまでの流れを明確に把握したい方は、ぜひ読み進めてください。

- テンプレート、ドキュメント設定、単位、インポートしたプロジェクトパラメーターなど、Draftsmanでハーネス製造図面ドキュメントを作成・設定する方法を学びます。
- ハーネスの設計情報をわかりやすく表現するために追加できるビュー、注釈、寸法、その他の作図ツールの種類を確認します。
- BOM、配線リスト、接続表など、利用可能な製造用の表と、そのデータの取得元や表示方法を理解します。
AIでさらに深掘り:

配線図とレイアウト図が完成したら、その内容の読み取り専用コピーを製造図面ドキュメント (*.HarDwf) に配置し、必要に応じて注釈を追加できます。ハーネス設計の製造図面は、Draftsmanエディターで作成します。

Draftsmanの概要については、 Draftsmanによる基板設計ドキュメント作成の効率化 ページを参照してください。

ハーネスプロジェクトに製造図面を追加するには、Projectsパネルでプロジェクトのエントリーを右クリックし、コンテキストメニューからAdd New to Project » Draftsman Documentを選択します(または、メインメニューのFile » New » Draftsman Documentコマンドを使用します)。表示されるNew Documentダイアログで、必要に応じて使用可能な製造図面テンプレートを選択し、正しい Project とハーネスレイアウト図 Document が選択されていることを確認します。

New Documentダイアログ
New Documentダイアログ

製造図面テンプレートの作成について詳しくは、 ハーネステンプレートドキュメントの作成ページを参照してください。

製造図面ドキュメントの設定

製造図面ドキュメントのオプションは、ドキュメントのデザインスペースで何も選択されていない状態で、Propertiesパネルから設定できます。詳しくは、 Draftsmanドキュメントの設定 ページを参照してください。

ハーネス製造図面ドキュメントで何も選択されていない場合のPropertiesパネルのタブ
ハーネス製造図面ドキュメントで何も選択されていない場合のPropertiesパネルのタブ

  • 製造図面ドキュメントを作成した後は、メインメニューまたはデザインスペースの右クリックメニューにある Tools » Import Changes From <LayoutDrawing.LdrDoc>コマンドを使用して、配線図やレイアウト図の変更を製造図面に取り込めます。メニューコマンドの説明にかかわらず、この操作ではboth the wiring diagram and the layout drawingから変更が取り込まれることに注意してください。

  • 製造図面オブジェクトのデフォルトプロパティは、 Preferences ダイアログの Draftsman – Defaultsページで設定できます。これらのプロパティは、以降に配置するオブジェクトに適用されます。

  •  Bookmarksパネルを使用すると、複数シートからなる製造図面内の移動や管理を簡単に行えます。このパネルには、ドキュメント全体の構造が展開可能なツリー形式で表示され、すべてのドキュメントシートと、各シート内の主要なビューオブジェクトが含まれます。

  • デザインスペースで何も選択されていない状態で、PropertiesパネルのUnitsおよびDual_Unitsオプションを使用すると、寸法値および表に表示される長さの値に使用する、ドキュメントのデフォルトの測定単位を選択できます。必要に応じて、ドキュメントレベルで指定された単位を、個々のオブジェクトのプロパティで上書きできます。対応する単位は、Millimeters、Mils、Inches、 センチメートル、メートル、およびFeetです。

  • レイアウト図ドキュメントのパラメーターは、関連付けられたハーネス製造図面ドキュメントにインポートされます。これらのパラメーターは、ドキュメントのPropertiesパネルのParametersタブに一覧表示され(パネル内の アイコンの横にあるチェックボックスで、リスト内のレイアウトパラメーターの表示を切り替えられます)、特殊文字列で使用できます。=ItemRevisionや=ItemRevisionLevel1などの計算されたパラメーター値も含まれ、リリース時に生成される出力で解釈されます。

ビューの操作

製造図面ドキュメントには、このプロジェクトに含まれるハーネス配線図とハーネスレイアウト図の読み取り専用ビューを配置できます。

配線図ビュー

配線図ビュー (Place » Wiring Diagram View) は、アクティブなハーネス設計プロジェクトの配線図から自動生成される合成グラフィックです。

配線図ビューの例
配線図ビューの例

配置した配線図ビューのプロパティは、デザインスペースでそのビューを選択した状態で、Propertiesパネルから設定できます。

配線図ビューを選択した場合のPropertiesパネル
配線図ビューを選択した場合のPropertiesパネル

  • ハーネスプロジェクトに複数の配線図ドキュメントが含まれる場合(詳細を参照)、配置した配線図ビューの生成および更新に使用する配線図ドキュメントを選択できます。配線図ビューを選択した状態で、PropertiesパネルのProperties領域にあるDocumentドロップダウンを使用し、このビューの配線図ドキュメントを選択します ()。

  •  Auto Size を有効にすると、配線図ビューのサイズが自動的に調整され、外周の余白が除去されます。

  • 目的の配置に対応する矢印をクリックするか、中央に配置する場合は円をクリックして、 Justification を選択します。 Justification で選択したオプションによって、ビューのサイズが更新された際に、その位置を変更する基準点が決まります。

レイアウト図ビュー

レイアウト図ビュー (Place » Layout Drawing View) は、アクティブなハーネス設計プロジェクトのレイアウト図から自動生成される合成グラフィックです。

レイアウト図ビューの例
レイアウト図ビューの例

配置したレイアウト図ビューのプロパティは、デザインスペースでそのビューを選択した状態で、Propertiesパネルから設定できます。

レイアウト図ビューを選択した場合のPropertiesパネル
レイアウト図ビューを選択した場合のPropertiesパネル

  •  Auto Size を有効にすると、レイアウト図ビューのサイズが自動的に調整され、外周の余白が除去されます。

  • 目的の配置に対応する矢印をクリックするか、中央に配置する場合は円をクリックして、 Justification を選択します。 Justification で選択したオプションによって、ビューのサイズが更新された際に、その位置を変更する基準点が決まります。

追加のビュー

製造図面を完成させるために、ハーネス詳細ビューと部品ビューを追加できます。

ハーネス詳細ビューでは、既存の図面の指定領域を、独立した拡大詳細ビューとして表示できます。ハーネス詳細ビューの領域には、円形と矩形を選択できます。目的のビューを配置するには、Place » Additional Views » Harness Detail View メインメニューからオプション (Circle area detail view または Rectangle area detail view) を選択します。

Javascript ID: Harness_MD_HarnessDetailView_AD24

配線図ビューに適用した円形領域のハーネス詳細ビューの例

配線図ビューに適用した矩形領域のハーネス詳細ビューの例

部品ビュー (Place » Additional Views » Component View) は、現在のハーネス設計に含まれる単一の部品の図面ビューです。

部品ビューの例
部品ビューの例

図面への注釈と寸法の追加

製造図面に重要な情報を追加するために、さまざまな注釈、寸法記入、 描画 ツールが用意されています。これらには、 自動注記やハイライト表示の機能に加え、 オブジェクトの外形の長さ、サイズ、角度、または指定したオブジェクト間の距離を示すツールが含まれます。

注釈を追加したレイアウト図面ビューの例
注釈を追加したレイアウト図面ビューの例

  • コネクタまたは接続点に関連付けられ、BOM Itemを表示するように設定されたコールアウトには、コネクタ/接続点自体とその関連部品のBOMアイテム番号が表示されます。 レイアウト図面ビュー上のコンポーネントの物理ビューに追加されたコールアウトには、 そのコンポーネントに割り当てられているすべてのキャビティ のBOMアイテム番号も表示されます。

  • レイアウト図面ビュー上の接続点間に直線寸法を配置すると、 Value フィールド(寸法の長さ)には、対応するハーネスバンドルの長さが自動的に入力されます。

詳細については、次のページを参照してください。

テーブルの操作

製造図面ドキュメントでは、部品表(BOM)、配線リスト、接続テーブル、汎用テーブルを 図面上に配置できます。 テーブル内のデータはプロジェクトドキュメントから直接取得され、ハーネス製造工程で重要な情報を、わかりやすく視覚的に伝えることができます。

  • 部品表、配線リスト、接続テーブルのプロパティでは、Length Units と長さのValue Precisionを指定できます(ドキュメントレベルでの指定を上書きします)。選択したオプションは、対応するテーブルに表示される長さの値に適用されます。

  • ハーネス配線コンポーネントの場合、部品表テーブルのLength列には、ワイヤ/ケーブルの個々の長さではなく、同じBOMアイテムに属するワイヤ/ケーブルの合計長が表示されます。

  • ワイヤ、ケーブル、ハーネス被覆は長さに基づくオブジェクトであり、その値は Length フィールドに表示されます。これらのオブジェクトの Quantity フィールドはAs Requiredです。

  • 製造図面ドキュメントからテーブルオブジェクトをコピーすると、その内容を Microsoft Excelのスプレッドシートに貼り付けることができます。

 部品表 および テーブルの操作について詳しく説明します。

配線リスト

配線リスト(Place » Wiring List)は、ハーネス内の各ワイヤの始点、終点、およびパラメータ値を表示する、自動生成されるテーブルオブジェクトです。

配線リストの例
配線リストの例

配置済み配線リストのプロパティ(表示属性やデータ内容など)は、デザインスペースで配線リストを選択すると、Propertiesパネルで設定できます。

配線リスト選択時の Propertiesパネルのタブ 
配線リスト選択時の Propertiesパネルのタブ

  • 接続付きシールドオブジェクトにワイヤが接続されている場合、そのオブジェクトのデジグネータが配線リストに表示されます。

  • ワイヤのInclude Cutパラメータの値がNoの場合、そのワイヤは配線リストに表示されません。

  • 配線図で指定されたワイヤのパラメータ(およびその値)は、配線リストに反映されます。各ワイヤパラメータに対して、配線リストに列が追加されます。これらの追加列は、デフォルトでは非表示です。配線リストを選択した状態で、PropertiesパネルのColumnsタブにある表示コントロールを使用すると、これらの列をデザインスペースに表示できます(必要に応じてデフォルトの列を非表示にすることもできます)。

  • 配線リストでは、

  • 多色ワイヤがサポートされています()。

    • Color列のセルは分割され、ワイヤに割り当てられた第2色と 第3色が表示されます。

    • ColorName列には、主色、第2色、 第3色の名前が表示されます。

    • 第2色、第3色、境界色の追加列を表示することもできます。

  • ケーブル内のワイヤについては、配線リストの Length 列に各ワイヤの個別の長さが表示されます。

  • バルクヘッドコネクタ(キャビティ数が最も多いコネクタ)については、配線リストで自動的にグループ化が行われ、そのすべてのキャビティがFrom列で正しくグループ化されます。

  •  および ボタンを使用すると、Columnsタブで項目を選択した表示列を、配線リスト内で左右に1列ずつ移動できます。

  • Order列のセルをクリックすると、テーブル列のデータの並べ替え順序(なし、昇順、降順)を切り替えられます。Ctrlを押しながらOrder列のセルをクリックすると、複数の列に優先順位を付けて並べ替えを適用できます。

  • ワイヤ数が最も多いコネクタ(およびそのすべてのキャビティ)は、 From 列で自動的にグループ化されます()。

配線リストの分割

高度なハーネス設計の配線リストには多数の項目が含まれることがあり、1つのテーブルとして図面ドキュメント内に収めるのが難しい場合があります。フォントやテーブルの縮小、複数のカスタムテーブル項目、外部ドキュメントに頼る代わりに、配線リストテーブルを「分割」して、複数の「ページ」にわたって表示できます。

配置済み配線リストの Properties パネルで、 Pages 領域の Limit Page Height オプションを有効にすると、テーブルの高さを指定した高さ(Max Page Height)に制限し、それに応じてテーブルに表示される行数を制限できます。

Javascript ID: Harness_MD_WiringList_LimitPageHeight_AD25_3

エディタは配線リスト全体が表示されていないことを検出し、パネルの Page 項目にその状態を示します(例:Page 1 from 2)。関連するドロップダウンメニューでは、表示するページを指定できます。配線リストのページを追加するには、別の配線リストを配置し、 Properties パネルの Pages 領域で次の Page を指定します。

配線リストの各ページは、配線リストテーブルを追加して適切に設定することで配置されるため、製造図面ドキュメント内の任意のシートに配置できます。

 Max Page Height プロパティは、配線リストテーブルの first ページの高さを指定することに注意してください。2ページ目(ページ 2)を選択した場合、 Max Page Height プロパティは、最初の除外ページ(ページ 1)の高さを定義します。そのため、ページ 2には配線リストの残りの項目が表示されます。まず、 Max Page Heightを プロパティは各ページで同一です。

接続テーブル

接続テーブル(Place » Connection Table)は、ハーネス内のすべての接続点(コネクタピン、スプライスなど)に接続されているワイヤを表示する、自動生成されるテーブルオブジェクトです。

接続テーブルの例(すべてのコンポーネント)
接続テーブルの例(すべてのコンポーネント)

配置した接続テーブルのプロパティ(表示属性やデータ内容など)は、デザインスペースで接続テーブルを選択した状態で、Propertiesパネルから設定できます。

接続テーブルを選択したときのPropertiesパネルのタブ 
接続テーブルを選択したときのPropertiesパネルのタブ

  • Componentオプションを使用すると、プロジェクト内のすべてのコンポーネントのデータ、または特定のコンポーネントやスプライスのデータをテーブルに表示できます。

  • ワイヤのInclude CutパラメータにNoの値が設定されている場合、そのワイヤは接続テーブルに表示されません。

  • 配線図で指定したワイヤパラメータ(およびその値)は、接続テーブルに反映されます。ワイヤパラメータごとに、接続テーブルに列が追加されます。これらの追加列は、デフォルトでは非表示です。接続テーブルを選択した状態で、PropertiesパネルのColumnsタブにある表示コントロールを使用すると、デザインスペースにこれらの列を表示できます(必要に応じてデフォルトの列を非表示にすることもできます)。

  • 接続テーブルでは、多色ワイヤがサポートされています()。

    • Color列のセルは分割され、ワイヤに割り当てられた第2色と第3色が表示されます。

    • ColorName列には、主色、第2色、第3色の名前が表示されます。

    • 第2色、第3色、境界色の追加列を表示できます。

  • ケーブル内のワイヤについては、接続テーブルのLength列に各ワイヤの個別の長さが表示されます。

  • ボタンとボタンを使用すると、Columnsタブで項目を選択した表示列を、接続テーブル内で左右に1列ずつ移動できます。

  • Order列のセルをクリックすると、テーブルの列データの並べ替え順序(なし、昇順、降順)が順に切り替わります。Ctrlを押しながらOrder列のセルをクリックすると、優先順位に従って複数の列に並べ替えを適用できます。

  • PropertiesパネルのDisplay ドロップダウンを使用して、テーブルに表示するデータを設定します。

    • Wires Only – ワイヤが接続されているピンのみを表示します。

    • Wires & Parts – ワイヤが接続されているピンと、追加されたキャビティ部品(ワイヤがない密閉型コネクタのプラグなど)を表示します。

    • All Cavities – 接続されたワイヤや追加されたキャビティの有無にかかわらず、すべてのコンポーネントの全ピンを表示します(たとえば、10ピンのコンポーネントがある場合、10本すべてのピンがテーブルに表示されます)。

    • No Connect – 「未接続」オブジェクトのみを表示します。

接続テーブルの分割

高度なハーネス設計の接続テーブルには多数の項目が含まれることがあり、単一のテーブルとして図面ドキュメント内に収めるのが難しい場合があります。フォントやテーブルの縮尺を変更したり、複数のカスタムテーブル項目や外部ドキュメントを使用したりする代わりに、Harness Draftsmanドキュメント(*.HarDwf)で接続テーブルを「分割」し、複数の「ページ」にわたって表示できます。この新機能を使用するには、配置した接続テーブルのProperties パネルで、Pages 領域のLimit Page Heightオプションを有効にします。これにより、接続テーブルの高さが指定した高さ(Max Page Height)に制限され、テーブルに表示される行数も制限されます。

 

エディタは、接続テーブル全体が表示されていないことを検出し、パネルのPage項目(例:1 from 2)にその状態を示します。関連するドロップダウンメニューでは、表示するページを指定できます。接続テーブルのページをさらに追加するには、別の接続テーブル(Place » Connection Table)を配置し、Properties パネルのPages領域で次のPageを指定します。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents