ハーネス配線図の定義

ハーネス内の個々の配線接続は、ハーネス配線図(*.WirDoc)で指定します。Projects パネルでプロジェクトエントリを右クリックし、コンテキストメニューから Add New to Project » Harness Wiring Diagram を選択して、このドキュメントをハーネスプロジェクトに追加します(または、メインメニューから File » New » Harness Wiring Diagram コマンドを使用します)。

ハーネス配線図ドキュメントの設定

ハーネス配線図ドキュメントのオプションは、ドキュメントのデザインスペースで何も選択されていないときに Properties パネルで設定できます。主な設定は次のとおりです。

  • パネルの General タブの General 領域では、ドキュメントおよびそのグラフィック要素に適用される測定単位を選択し、配置しやすくするためのグリッドを設定します。Altium Designer では、表示グリッド(ナビゲーション用)、スナップグリッド(配置用)、および接続作成を補助するスナップ距離の 3 種類のグリッドが用意されています。

  • パネルの General タブの Page Options 領域では、ドキュメントシートのサイズとタイトルブロックを設定するか、利用可能なハーネス配線図テンプレートから選択します。

ハーネス配線図ドキュメントで何も選択されていないときの Properties パネルの General タブおよび Parameters タブ 
ハーネス配線図ドキュメントで何も選択されていないときの Properties パネルの General タブおよび Parameters タブ

  • ハーネス配線図ドキュメントの設定は、PCB 設計プロジェクトの回路図ドキュメント(*.SchDoc)の設定と似ています。詳細は、Setting Up a Schematic Document ページを参照してください。

  • Length Units ドロップダウンを使用して、ドキュメントの長さ単位を選択します。ソケットキャビティStrip Length および Pull Off Length の値は、選択した単位で表示されます。対応する単位は mmcmminft です。新規作成される配線図ドキュメントのデフォルト長さ単位は、Preferences ダイアログの Harness Design – General page で定義できます。

  • ハーネス配線ドキュメントテンプレートの作成について詳しくは、Creating Harness Template Documents ページを参照してください。

  • ハーネス配線図オブジェクトのデフォルトプロパティは、Preferences ダイアログの Harness Design – Defaults page で設定できます。これらのプロパティは、その後に配置するオブジェクトに適用されます。

  • ハーネス配線図ドキュメントを作成する際には、テキストオブジェクトや描画オブジェクトも使用できます。ハーネス配線図ドキュメントでのこれらのオブジェクトの操作は、PCB 設計プロジェクトの回路図ドキュメント(*.SchDoc)での操作と似ています。これらのオブジェクトの詳細は、Working with Text Objects on a Schematic および Working with Drawing Objects on a Schematic を参照してください。

    • また、ハーネス配線図オブジェクト(ワイヤや コンポーネントなど)およびハーネスレイアウト図オブジェクト(バンドルや接続ポイントなど)への active links は、テキストフレームや注記でもサポートされています。配置したテキストフレームまたは注記内のリンクをクリックすると、関連ドキュメント内のそのオブジェクトへクロスプローブできます。

  • ハーネス配線図の論理、電気、および作図上の違反を確認するために、複数の違反チェックがサポートされています。詳細は、Validating the Harness Design ページを参照してください。

  • ハーネス配線図ドキュメントは ASCII 形式で保存でき、共有時に便利です。File » Save As コマンドを使用し、開いた Save As ダイアログの Save as type ドロップダウンから Harness Wiring ascii (*.WirDoc) を選択します。File » Save コマンドを使用して ASCII 配線図を保存すると、ASCII 形式が使用されることを通知する File Format ダイアログが開きます。 dialog で ASCII Version を選択して、この形式を引き続き使用します。

マルチボードプロジェクトとハーネスプロジェクトの同期

 
 
 
 
 

ハーネスプロジェクトがマルチボード設計プロジェクトの一部である場合、ハーネス配線図はマルチボード回路図ドキュメント(*.MbsDoc)のデータから同期できます。これを行うには、メインメニューから Design » Import Changes From <Multi-board Project> コマンドを選択します。

ハーネス設計プロジェクトをマルチボードプロジェクトに追加する方法の詳細は、Harness Design ページを参照してください。

マルチボード回路図ドキュメントに複数のハーネス接続定義が含まれている場合、Select Harness Definition ダイアログが開きます。現在のハーネスプロジェクトに対応する定義を指定してください。

Select Harness Definition ダイアログ
Select Harness Definition ダイアログ

次に、Engineering Change Order ダイアログが開き、マルチボード回路図で定義されたハーネスコネクタコンポーネントとハーネスネットが表示されます。これらがハーネス配線図の基礎となります。

Engineering Change Order ダイアログを使用して、マルチボードプロジェクトからデータをインポートします。 
Engineering Change Order ダイアログを使用して、マルチボードプロジェクトからデータをインポートします。 

変更を実行した後()、マルチボード回路図ドキュメントのデータがハーネス配線図にインポートされます。各コネクタコンポーネントは回路図シンボルで表され、最初は任意の位置にハーネス配線図ドキュメント内へ配置されます。

インポート直後のハーネス配線図の例。
インポート直後のハーネス配線図の例。

マルチボード回路図で定義された論理接続を表すため、ピン間にネットラインが表示されます。この段階では、設計内に物理ワイヤはまだ存在しない点に注意してください。

マルチボードプロジェクトからハーネスプロジェクトにインポートされる接続データは、コネクタコンポーネントのピン名に依存します。そのため、データインポート前に、元ライブラリ内のコンポーネントピンに一意で正しい名前が割り当てられていることを確認してください。

コンポーネントの操作

マルチボード回路図ドキュメントからの同期 に加えて、コンポーネントをハーネス配線図に手動で配置することもできます。これにより、スタンドアロンのハーネスプロジェクト(つまりマルチボードプロジェクトの一部ではないもの)にコンポーネントを配置できるほか、マルチボードプロジェクトの一部であるハーネス配線図に追加コンポーネントを配置することもできます。

Components パネルを使用して、必要なコンポーネントのシンボルを配置します。コンポーネント配置プロセスは Schematic エディタでのものと似ています。詳細は、Searching for & Placing Components ページを参照してください。手動で追加したコンポーネントには、それらを駆動する上位の論理設計が存在しないため、ネットラインはありません。

  • コンポーネントは利用可能なライブラリから配置され、ハーネス配線図上では回路図シンボルモデルで表されます。コンポーネント作成の詳細は、Building & Maintaining Your Components and Libraries を参照してください。

  • Multi-part components もハーネス配線図に配置できます。設計データが ハーネスレイアウト図にインポートされる と、ハーネスレイアウト図内のコンポーネントにデジグネータが正しく割り当てられます。ハーネス配線図に同一コンポーネントの複数パートが配置されている場合でも、harness layout drawing にはそのコンポーネントのインスタンスは 1 つだけ配置されます()。

  • ハーネスコネクタは、ネスト構成になっている複数のマルチボードプロジェクト間の接続に使用できます。

  • 切り取り/コピーしたハーネスコンポーネントをハーネス配線図に貼り付ける際、貼り付けられたコンポーネントのデジグネータは、Preferences ダイアログの Schematic – Graphical Editing page にある Reset Parts Designators On Paste オプションに従います。 このオプションが有効な場合、コンポーネントを貼り付けると、そのデジグネータの数値部分は ? にリセットされます。

配置済みコンポーネント(または Components パネルから配置中のコンポーネント)を目的の位置に移動するには、その上でマウス左ボタンをクリックしたままマウスを動かします。ドラッグ中は、Spacebar を使用してコンポーネントを 90 度回転し、X キーおよび Y キーを使用してそれぞれ水平反転および垂直反転します。

コンポーネント移動後のハーネス配線図
コンポーネント移動後のハーネス配線図

配置済みコンポーネントの プロパティは、デザインスペースでコンポーネントを選択したときに Properties パネルで設定できます。コンポーネント用の Properties パネルには、次のタブがあります。

 
 
 
 
 
  • General – デジグネータ、コメント、位置、パラメータなどのコンポーネントの一般プロパティ。

  • Pins – コンポーネントピンの一覧。

  • Cavities – コンポーネントへのソケットキャビティの割り当てを行います(learn more)。

  • Associated Parts – 熱収縮チューブなどの追加部品をコンポーネントに割り当てることができます。

コンポーネント選択時の Properties パネルのタブ
コンポーネント選択時の Properties パネルのタブ

ソケットキャビティの割り当て

 
 
 
 
 

ソケットキャビティとそのタイプはハーネスコンポーネントに割り当てることができます。キャビティとタイプを追加するには、デザインスペースでコンポーネントを選択します。Properties パネルの Cavities タブでピンを選択し、次に  ボタンをクリックします。ドロップダウンから目的のタイプを選択します。サポートされているキャビティタイプは次のとおりです。

  • Crimp – 導体の周囲にコンタクトバレルを圧着して電気接続を提供するために使用します。

  • Seal – ワイヤの挿入口をシールして環境保護を提供するために使用します。

  • Plug – 環境シールの完全性を維持するため、開いている(未使用の)コネクタキャビティを埋めるために使用します。

  • Other – はんだなど、その他/追加の部品または材料を指定するために使用します。

Crimp キャビティタイプ、またはキャビティタイプが追加されていない行については、次の値を指定できます。

  • Strip Length – 導体から被覆を切り取る長さ。

  • Pull Off Length – 切り取った被覆を導体から引き抜く長さ。これは、ワイヤ端が完全にはストリップされず、素線の損傷を防ぐために取り外した被覆片をワイヤ上に残しておく場合に使用できます。

コンポーネント選択時に Properties パネルに表示されるこれらの値の単位は、ドキュメントで何も選択されていないときの Properties パネルの General タブにある Length Units ドロップダウンで指定します。

開いた Select Connector ダイアログで、目的のコンポーネントを参照して選択します。特定のタイプと関連情報がタブ内のピンに追加されます。下の画像は、ピン 1 に圧着端子を追加した例を示しています。

ピンは Cavities タブの表では名前(Pins 列)で表示され、キャビティの割り当てはピン名に依存するため、コンポーネントピンに一意で正しい名前が割り当てられていることを確認してください。

圧着、シール、またはプラグについては、特定タイプのキャビティはピンごとに 1 つしか追加できません。特定タイプのキャビティが追加されると、そのエントリはドロップダウンで使用不可(グレー表示)になります。Other タイプのキャビティは、ピンに任意の数だけ追加できます。

圧着が割り当てられたピンは、下の画像のようにデザインスペースで シンボルによって示されます。

Cavities タブのグリッド領域では、複数選択および選択したエントリに対するコピー/貼り付け/削除操作がサポートされています。 複数のピンエントリは、Click, Hold&Drag、 Ctrl+Click、 Shift+Click、および Ctrl+A ショートカットを使用して選択できます。

  • 複数のピンエントリが選択されている場合、  をクリックすると選択したすべてのピンにキャビティを追加でき、 をクリックするか Delete を押すと、選択したピンから追加済みキャビティを削除できます。 

  • ピンのキャビティを変更するには、そのエントリを選択し、 をクリックして Select Connector ダイアログを開き、新しいキャビティを選択します。

  • 1 つ以上のピンエントリを選択し、Ctrl+X/Ctrl+C ショートカットを使用して選択したエントリを切り取り/コピーし、続いて Ctrl+V ショートカットを使用して、現在選択されているエントリ位置に切り取り/コピーした内容を貼り付けます。

  • ハーネス配線図で接続性を作成する

    物理ワイヤは、メインメニューから Place » Harness Wire コマンドを選択してハーネス配線図ドキュメント内に配置します(ショートカット:  Shift+W)。

    コマンドを選択した後、コネクタのピンをクリックしてハーネスワイヤの始点を配置します(カーソルがピンのホットスポット上にあると、カーソル位置に赤い十字が表示されます)。カーソルを移動してクリックし、ハーネスワイヤの形状を定義する一連の頂点を固定します。最後の頂点を別のピンのホットスポットに配置した後、右クリックして配置を完了します。

    ハーネスワイヤの配置中に Shift+Spacebar を押すと、配置モードが切り替わります。このモードは、ワイヤ配置時のコーナーの作成方法と、ワイヤを配置できる角度を指定します。90 Degree または 45 Degree モード(真の直交モード)では、Spacebar を押すと開始サブモードと終了サブモードが切り替わります。現在のモードとサブモードはステータスバーに表示されます。

    ハーネスワイヤを配置している間、ネットラインは「ライブ」で追従/更新され、以下の動画で示すように、どこに配線すべきかをリアルタイムで確認できます。接続が完了すると、そのネットラインはドキュメントから消えます。

    ライブトレース機能のデモ

    配置して選択したハーネスワイヤでは、頂点をドラッグして隣接する2つのセクション間の角度を変更できます(Show example)。

    デザインスペースでハーネスワイヤを選択し、Properties パネルで変更します。このパネルでは、選択したハーネスワイヤの名前変更、幅や色の変更、およびデザインスペースで表示/非表示にできるパラメータの追加が可能です。

    ハーネスワイヤ選択時の Properties パネル
    ハーネスワイヤ選択時の Properties パネル

    • 配置済みのハーネスワイヤは、単一ワイヤを含むハーネス配線コンポーネントに置き換えることができます。これを行うには、置き換えるハーネスワイヤを選択し、Properties パネルの Design Item ID フィールド右側にある ボタンをクリックします。開いた Replace Component ダイアログで必要なコンポーネントを参照して選択します。配置済みのワイヤは、ジオメトリを変更せずに、選択したコンポーネントのプロパティとパラメータで更新されます。詳細は、 Placing a Harness Wiring Component セクションを参照してください。

    • ワイヤの主色は、デフォルトで配置済みハーネスワイヤに表示される Color パラメータによって定義されます。色を編集するには、その名前(例: Red)または16進コード(# 文字に続けて16進数を入力。例: #9900FF)をパラメータ値として入力します。あるいは、パラメータ値の左にある色ボタンをクリックし、開いたカラーピッカーで RGB 値または HEX 値、自由選択、またはプリセット一覧からワイヤ色を指定することもできます。

    • ハーネス配線図では、ワイヤの第2色および第3色を選択することで多色ハーネスワイヤをサポートしています。Properties パネルで、Parameters 領域下部の   ドロップダウンをクリックし、 Secondary および Tertiary を選択して目的の色を定義します。選択した色のパラメータは Parameters 領域に表示されます。同じドロップダウンから Border を選択すると、ハーネスワイヤの境界色も定義できます。なお、 Color パラメータは、定義済みワイヤ ColorSecondary Color、および Tertiary Color パラメータの結合値の表示/非表示を制御します。 以下のスライドショーをクリックして例を確認してください。

      Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

      主色のみが定義されたワイヤ

      第2色が定義されたワイヤ

      第3色が定義されたワイヤ

      境界色が定義されたワイヤ

      すべての色オプションが定義されたワイヤ

      多色ワイヤは、ハーネス設計の製造図面ドキュメント内の表でもサポートされています(*.HarDwf)— learn more

    • ハーネスワイヤの Include Cut パラメータが No 値である場合、そのワイヤは製造図面内の wiring list および connection table には表示されません。

    • ハーネスワイヤの ColorMin. Bending RadiusThickness、および Units パラメータは、MCAD CoDesigner を使用してハーネス設計プロジェクトを MCAD ツールと同期する際に使用されます。詳細については、 Synchronizing a Harness Design Project ページを参照してください。

    スプライスとタップの追加

    既に配置されているワイヤに新しいワイヤを接続する必要がある設計では、最初にスプライス(Place » Splice)またはタップ(Place » Tap)オブジェクトを配置する必要があります。

    • Splice – 元のワイヤはスプライスによって2本の別個のワイヤに分割されます。

      Javascript ID: Harness_WD_PlacingSplice_AD25

      別のワイヤを選択したワイヤ(W4)に接続する必要があります。

      ワイヤ上にスプライスを配置しました。スプライスによって元のワイヤがその位置で2本に分割される点に注意してください。

      別のワイヤがスプライスに接続されました。

      2本のワイヤが T 字型に接続される場合、T 字接続の位置にスプライスが自動的に配置されます(Show example)。

    • Tap – 元のワイヤは分割されません。

      Javascript ID: Harness_WD_PlacingTap_AD25

      別のワイヤを選択したワイヤ(W4)に接続する必要があります。

      ワイヤ上にタップを配置しました。タップでは元のワイヤが分割されない点に注意してください。

      別のワイヤがタップに接続されました。

    配置済みのスプライスまたはタップのプロパティ(位置および表示表現)は、デザインスペースでオブジェクトを選択したときに Properties パネルで設定できます。

    スプライス/タップ選択時の Properties パネル
    スプライス/タップ選択時の Properties パネル

    Properties パネルの Associated Parts 領域では、選択したスプライス/タップにコンポーネントを割り当てることができ、そのコンポーネントはプロジェクトの BOM に反映されます。

    ケーブルの追加

    1本以上のワイヤをケーブルに追加されたものとして定義するには、ハーネス配線図上にケーブルオブジェクトを配置します(Place » Harness Cable)。

    1本以上のワイヤをケーブルに追加されたものとして定義するには、ケーブルを配置します。
    1本以上のワイヤをケーブルに追加されたものとして定義するには、ケーブルを配置します。

    ケーブルオブジェクトを選択すると、このケーブルでカバーされるワイヤがデザインスペースでネオングリーンでハイライト表示されます()。

    配置済みケーブルオブジェクトのプロパティ(位置、表示表現、およびパラメータ)は、デザインスペースでオブジェクトを選択したときに Properties パネルで設定できます。

     
     
     
     
     

    ケーブル選択時の Properties パネル
    ケーブル選択時の Properties パネル

    ケーブルは、配置中またはグラフィカル編集時に 2:1 の固定アスペクト比を持ち、最終的な配置サイズはドキュメントの現在のスナップグリッド値によって決まります。

    • ケーブルがハーネス配線図の複数箇所のワイヤに関連付けられている場合(つまり、同じデジグネータを持つ複数のケーブルオブジェクトが異なるワイヤにまたがって配置されている場合)、1つのオブジェクトを選択すると、グループ内の関連するすべてのワイヤがハイライト表示され、それらのワイヤはすべて Properties パネルの Cable Objects 領域に一覧表示されます()。

    • ケーブルの ColorMin. Bending RadiusThickness、および Units パラメータは、MCAD CoDesigner を使用してハーネス設計プロジェクトを MCAD ツールと同期する際に使用されます。詳細については、 Synchronizing a Harness Design Project ページを参照してください。

    ワイヤのシールドとツイスト

    シールド(ドレインワイヤ接続などの接続あり/なし)は、シールド(Place » Shield または接続付きシールド(Place » Shield with Connection)オブジェクトを配置することで、複数のワイヤのグループに取り付けることができます。

    以下の例では、ワイヤ W1、W2、W3 は接続なしシールド(SH1)でシールドされ、ワイヤ W4、W8、W9 は接続付きシールド(SH2)でシールドされています。ワイヤ W10 は、SH2 をコンポーネントピンに接続するために配置されています。

    シールド済みワイヤを示すには、シールドまたは接続付きシールドオブジェクトを配置します。
    シールド済みワイヤを示すには、シールドまたは接続付きシールドオブジェクトを配置します。

    シールドまたは接続付きシールドオブジェクトを選択すると、カバーされているワイヤがデザインスペースでネオングリーンにハイライト表示されます()。

    配置済みのシールドまたは接続付きシールドオブジェクトのプロパティ(位置および表示表現)は、デザインスペースでオブジェクトを選択したときに Properties パネルで設定できます。パネルの Shield Objects 領域には、選択したオブジェクトでカバーされるワイヤが一覧表示されます。

     
     
     
     
     

    シールド選択時の Properties パネル
    シールド選択時の Properties パネル

    • シールドは、配置中またはグラフィカル編集時に 2:1 の固定アスペクト比を持ち、最終的な配置サイズはドキュメントの現在のスナップグリッド値によって決まります。 

    • シールドがハーネス配線図の複数箇所のワイヤに関連付けられている場合(つまり、同じデジグネータを持つ複数のシールドオブジェクトが異なるワイヤにまたがって配置されている場合)、1つのオブジェクトを選択すると、グループ内の関連するすべてのワイヤがハイライト表示され、それらのワイヤはすべて Properties パネルの Shield Objects 領域に一覧表示されます()。

    ワイヤ同士が撚り合わされていることを示すには、ツイスト(Place » Twist)を配置します。 ツイストは2本以上のワイヤにまたがって配置できます。

    以下の例では、ワイヤ W1 と W2 がツイスト Tw1 によって撚り合わせとして示されています。

    ワイヤが撚り合わされていることを示すには、ツイストオブジェクトを配置します。
    ワイヤが撚り合わされていることを示すには、ツイストオブジェクトを配置します。

    ツイストを選択すると、カバーされているワイヤがデザインスペースでネオングリーンにハイライト表示されます()。

    配置済みツイストのプロパティ(位置および表示表現)は、デザインスペースでオブジェクトを選択したときに Properties パネルで設定できます。パネルの Twist Objects 領域には、選択したツイストでカバーされるワイヤが一覧表示されます。

     
     
     
     
     

    ツイスト選択時の Properties パネル
    ツイスト選択時の Properties パネル

    • ツイストは、配置中またはグラフィカル編集時に 1:1 の固定アスペクト比を持ち、最終的な配置サイズはドキュメントの現在のスナップグリッド値によって決まります。 

    • ツイストがハーネス配線図の複数箇所のワイヤに関連付けられている場合(つまり、同じデジグネータを持つ複数のツイストオブジェクトが異なるワイヤにまたがって配置されている場合)、1つのオブジェクトを選択すると、グループ内の関連するすべてのワイヤがハイライト表示され、それらのワイヤはすべて Properties パネルの Twist Objects 領域に一覧表示されます()。

    • ツイストの Twists per Unit Length および Thickness パラメータは、MCAD CoDesigner を使用してハーネス設計プロジェクトを MCAD ツールと同期する際に使用されます。詳細については、 Synchronizing a Harness Design Project ページを参照してください。

    未接続ワイヤ

    未接続のワイヤ端は塗りつぶし四角で示されます。

    示された未接続ワイヤ
    示された未接続ワイヤ

    ワイヤ端は未接続のままにしてはいけません。設計上、ワイヤ端を未接続にする必要がある場合は、末端に 'no connect' オブジェクトを配置する必要があります(Place » No Connect)。

    未接続のままにするワイヤ端には 'no connect' オブジェクトを配置します。
    未接続のままにするワイヤ端には 'no connect' オブジェクトを配置します。

    配置済みの 'no connect' オブジェクトのプロパティ(位置および表示表現)は、デザインスペースでオブジェクトを選択したときに Properties パネルで設定できます。

    'no connect' オブジェクト選択時の Properties パネル
    'no connect' オブジェクト選択時の Properties パネル

    複数シートでの作業

    複数シートにまたがる完全なハーネス配線図は、各シートをそれぞれ独自の *.WirDoc ドキュメントで表し、同一階層上にすべてのシートが存在する「フラット」設計方式で定義できます。接続性は、同じワイヤデジグネータを持つ wire break オブジェクト(Place » Wire Break)を使用して、任意のシートから他の任意のシートへ直接作成されます。

    wire break の配置コマンドを選択した後、その電気的ホットスポット(カーソルで保持されている端)が接続したいワイヤに触れるようにオブジェクトを配置し、クリックするか Enter を押して配置を確定します。配置された wire break は、接続先ワイヤのプロパティ(デジグネータと色)を継承します。

    デザインスペース内で wire break を選択すると、Properties パネルで変更できます。パネルでは、接続先ワイヤのデジグネータと、そのスタイル(方向(Left または Right)および色)を定義できます。

    ワイヤの同期

    wire break で接続されたハーネスワイヤは、Design Item ID が異なっていても認識されます。さらに、同じ wire break で接続され、同じデジグネータを持つすべてのワイヤセグメントについて、品番、コメント、色、およびすべてのパラメータが比較されます。差異が見つかった場合は、Mismatched parameters in connected wire segments 違反が報告されます。また、ワイヤおよび wire break の Properties パネルにも、パラメータ間の競合が検出されたことを示す警告が表示されます。警告内の Synchronize をクリックすると Conflict Wire Parameters ダイアログが開き、ワイヤセグメントに使用するパラメータを選択できます。

    同期前のワイヤのプロパティとパラメータ

    パネルには、パラメータ間に競合があることを示す警告が表示されます。警告内の Synchronize をクリックすると、Confirm Wire Parameters ダイアログが開きます。必要なオプションを選択し、OK をクリックして同期を実行します。

    Mismatched parameters in connected wire segments ダイアログ内の Project Options 違反

    同期後、ワイヤセグメントのプロパティは同期されます。 

     
    • wire break の色とデジグネータを変更すると、接続されているワイヤの色とデジグネータもそれに応じて変更されます。逆に、ワイヤの色とデジグネータを変更すると、そのワイヤに接続されている wire break の色とデジグネータもそれに応じて変更されます。

    • 配置コマンドを選択した後に Tab を押すことで、配置中の wire break のプロパティを変更することもできます。配置前に wire break にデジグネータが定義されている場合、接続先のワイヤは wire break のデジグネータと色を継承することに注意してください。

    • wire break が接続されているワイヤに境界色が定義されている場合、その wire break もその色の境界線付きで表示されます。また、wire break のデジグネータは、接続先ワイヤの境界色で表示されます。

    • wire break には独立したフォントプロパティはありません。配置されているハーネス配線図ドキュメントの Document Font プロパティが使用されます。

    • wire break は、同じハーネス配線図シート内で接続性を作成するためにも使用できます。たとえば、一方のコネクタピンからもう一方へワイヤを引く代わりに、それぞれのピンに短いハーネスワイヤと wire break を配置できます()。

    ハーネス配線コンポーネントの配置

    Workspace に接続している場合、接続先 Workspace で必要とされる定義済みの構造とプロパティを持つコンポーネントを作成し、それらをハーネス設計で再利用して、ハーネス配線図ドキュメントに直接配置できます。

    詳細は、 Creating a Harness Wiring Component ページを参照してください。

    これらのコンポーネント(それぞれに定義済みのハーネス配線モデルが割り当てられています)は、Components panel からアクセスします。 必要なハーネス配線図ドキュメントがデザインスペースでアクティブドキュメントになっているとき、パネル内でそのエントリを右クリックし、コンテキストメニューから Place <ComponentName> コマンドを選択してコンポーネントを配置します。コンポーネントの配置動作は、そのコンポーネントに単一のワイヤオブジェクトが含まれるか、ケーブル構造(複数のワイヤや追加オブジェクト: ケーブル、シールドなど)が含まれるかによって異なります。

    • Single wire – 単一のワイヤオブジェクトを含むコンポーネントを配置する場合、ハーネスワイヤ配置モードに入ります。配置するワイヤは、コンポーネント作成時に定義されたプロパティを継承します。ハーネスワイヤの配置について詳しくは、前述の Creating Connectivity in the Harness Wiring Diagram セクションを参照してください。

    • Cable structure – ケーブル構造を含むコンポーネントの配置コマンドを選択すると、そのケーブル構造がコンポーネント作成時に定義されたとおりの状態でカーソルに付随して表示されます。ハーネス配線図ドキュメント内の目的の場所をクリックしてコンポーネントを配置します。その後、コンポーネント内の各オブジェクトを個別に編集できます。たとえば、ケーブルを構成するワイヤをハーネスコネクタのピンに接続できます。

    ライブラリからの配線図の更新

    次のオブジェクトは、元の Workspace ライブラリから更新できます。

    • ハーネスコンポーネント

    • ハーネスコンポーネントのキャビティ

    • ハーネスコンポーネントに関連付けられた部品

    • ワイヤ

    オブジェクトを選択すると、リンクされている Workspace コンポーネントに関する情報が Properties パネルに表示されます(例: ハーネスコンポーネントに関連付けられた部品については Associated Parts タブ)。

    利用可能な新しい Workspace コンポーネントリビジョンがある場合、リビジョンステータスの項目には Out of date というテキストが表示されます。個々のオブジェクトレベルでは、  ボタンをクリックすることで、リンクを Workspace コンポーネントの最新リビジョンに更新できます。

    古いハーネスコンポーネントリビジョンが示されている例
    古いハーネスコンポーネントリビジョンが示されている例

    Update from Libraries 機能(Tools » Update from Libraries)を使用して、上記オブジェクトにリンクされた古いコンポーネントを更新することもできます。 Update from Libraries 機能を使用した更新対象にオブジェクトを含めるには、そのオブジェクトに割り当てられたコンポーネントに回路図シンボルへのリンクが含まれている必要があることに注意してください。

    ハーネス配線図オブジェクトへのアノテーション

    ハーネス配線図ドキュメント内の次のオブジェクトにアノテーションを付けるには、 Tools » Annotation メニューのコマンドを使用します。

    • ハーネスコンポーネント

    • ワイヤ

    • スプライスおよびタップ

    • ケーブル

    • シールドおよび接続付きシールド

    • ツイスト

    • 'No connect' オブジェクト

    ハーネス配線図ドキュメント内のオブジェクトへのアノテーションは、PCB 設計プロジェクトの回路図ドキュメント内のコンポーネントへのアノテーション(*.SchDoc)に似ています。ハーネス配線図ドキュメントで使用可能なアノテーションコマンドの詳細については、以下のリンクを参照してください。

    AI-LocalizedAI で翻訳
    問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
    機能の提供状況

    ご利用可能な機能は、お使いのAltiumソリューション(Altium DevelopAltium Agile TeamsAltium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

    実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

    従来のドキュメント

    Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

    Content