設計内のコンポーネントに注釈を付ける
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- デザインアノテーションの目的と、回路図、PCBレイアウト、BOMなどの出力物全体でコンポーネントのデジグネータを一意にすることの重要性を学びます。
- 回路図レベル、PCB、ボードレベルのアノテーションの違いと、それぞれの方式が特に適している設計の種類を理解します。
- Annotateダイアログの概要と、アノテーションの対象範囲、処理順序、マッチングオプション、変更案を制御するための主な設定を確認します。
設計のアノテーションとは、設計内の各コンポーネントを一意のデジグネータで個別に識別できるようにする、体系的かつ組織的なプロセスです。Altium Designerではグローバル一意識別子(GUID)を使用してコンポーネントの識別情報を維持できますが、多くの設計者は従来から、回路図(論理)とPCB(物理)の各領域、および部品表(BOM)などの出力でコンポーネントを参照する主な手段として、コンポーネントのデジグネータを使用しています。
設計をアノテーションする方法は3つあります。どのアノテーションツールを使用するかは、設計の種類、個人の好み、会社の方針や手順など、さまざまな要因によって決まります。
Schematic Level Annotation
回路図レベルのアノテーションでは、設計を純粋に論理的な観点から捉えてコンポーネントのデジグネータを決定します。デバイスシートを使用しないシンプルな設計に最も適していますが、処理順序を指定できるほか、マルチパートコンポーネントの既存パッケージを完成させるオプションもあるため、基板レベルのアノテーションの前提条件にもなります。
まとめると、回路図レベルのアノテーションは次の目的で使用します。
- マルチパートコンポーネントをパッケージ化する。
- 回路図設計内の位置に基づいてコンポーネントをアノテーションする。
- プロジェクトオプションで指定されたデフォルトの命名規則を使用して、マルチチャネル設計をアノテーションする。
- 追加のアノテーションに向けて設計を準備する。
PCB Annotation
PCBアノテーションでは、PCB上のコンポーネントの物理的な位置を使用してデジグネータを決定します。 これにより、位置情報をコンポーネントのデジグネータに効果的に組み込むことができ、実装済みPCBのデバッグに非常に役立ちます。つまり、PCB設計で基板上の位置に基づいてコンポーネントをアノテーションするには、PCBアノテーションを使用します。
Board Level Annotation
基板レベルのアノテーションでは、回路図(論理)設計で使用されるデジグネータと、PCB(物理)設計上の実際のデジグネータとの対応付けを行います。基板レベルのアノテーションはあらゆる設計で使用できますが、マルチチャネル設計や、デバイスシート自体ではデジグネータを編集できないデバイスシートを組み込んだ設計で特に役立ちます。この方法では、元のデバイスシートを実際に変更せずに、設計全体を再アノテーションできます。基板レベルのアノテーションは、プロジェクト内でデジグネータが重複することによって生じるアノテーションの競合を解決し、変更内容を*.Annotationテキストファイルに保存します。また、命名規則をカスタマイズするための追加キーワードが用意されており、すべてのパーツ、または選択した範囲のパーツのみに適用できます。
まとめると、基板レベルのアノテーションは次の目的で使用します。
- デバイスシート内のコンパイル済みコンポーネントをアノテーションする。
- 位置に基づくアノテーション、グローバルインデックス、その他の設定可能なオプションを含む命名規則を使用して、複数のチャネルにまたがるすべてのコンポーネントに一意の名前を付ける。
- コンポーネントに手動で名前を付ける。
回路図アノテーション
回路図アノテーションは、Annotate ダイアログで設定します。このダイアログには、プロジェクト内の選択したシート上にあるすべてのパーツ、または選択したパーツにデジグネータを体系的に割り当てるためのコントロールが用意されており、デジグネータが一意で、位置に基づいた順序になるようにします。アノテーションオプションを設定することで、マルチパートコンポーネントのパッケージ化、インデックスと接尾辞のオプション設定、重複するデジグネータを含む回路図デジグネータのリセット、PCBからのバックアノテーションを行えます。
Annotate ダイアログには、Annotate Schematicsコマンド(Tools » Annotation » Annotate Schematics)を実行してアクセスします。

Annotateダイアログは、Annotate Schematicsコマンドから開きます。
このダイアログは、主に次の2つの領域に分かれています。
- Schematic Annotation Configuration - この領域では、アノテーションの方式と適用範囲を設定します。
- Proposed Change List - この領域には、承認後に設計変更指示(ECO)を使用して実行される変更案が一覧表示されます。
Annotateダイアログのオプションとコントロール
回路図アノテーションの設定
処理順序
この領域では、位置に基づくアノテーションの方法を指定します。ドロップダウンリストから方法を選択すると、対応する図が動的に更新され、コンポーネントがどのようにアノテーションされるかが示されます。位置に基づくアノテーションの方法として、次のいずれかを選択します。
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
処理時の位置基準
この領域では、アノテーションの順序を処理する際に使用する、コンポーネント位置の基準を指定します。次のいずれかを選択します。
- Designator - 処理順序を決定する際、コンポーネントのデジグネータを位置の基準として使用します。
- Part - 処理順序を決定する際、コンポーネントの中心を位置の基準として使用します。
サブパーツの置換
ドロップダウンを使用して、アノテーション処理の一環としてサブパーツを置換するかどうかを選択します。
マッチングオプション
マルチパートパッケージを使用する場合、設計全体のBOMコストを最小限に抑えるため、できるだけ多くのパーツを最小限の数の物理部品にまとめることが望まれます。この領域のコントロールでは、コンポーネントの照合方法とグループ化方法、および有効なグループを判定するための基準を定義できます。
-
Complete Existing Packages - このコントロールを使用して、未アノテーションのパーツを既存のパッケージに含めるかどうか、およびその方法を決定します。ドロップダウンリストから次のいずれかを選択します。
- None - 既存のパッケージは補完せず、新しいパーツはすべて新しいパッケージに配置します。
- Per Sheet - 既存のパッケージには、同じ回路図シートの新しいパーツのみを含めます。
- Whole Project - 既存のパッケージには、プロジェクト内の任意の回路図シートの新しいパーツを含めます。
- Component Parameter - このリストには、現在の設計内のコンポーネントで検出されたすべてのパラメータが含まれます。パラメータに対応するチェックボックスをオンにすると、パーツをパッケージにまとめる際の照合にそのパラメータが使用されます。マルチパートコンポーネントが同じ有効なパラメータを持ち、その値も共通している場合、それらは同じパッケージにまとめられます(ただし、Complete Existing PackagesオプションがNoneに設定されていない場合)。有効にしたパラメータを持たない残りのコンポーネントも、まとめてパッケージ化されます。
- Strictly - リスト内のComponent Parameterに対してこのオプションを有効にすると、パッケージにまとめるすべてのコンポーネントがそのパラメーターを持つことが必須mustになります。このパラメーターを持たないコンポーネントは、個別のコンポーネントとしてアノテーションされ、パッケージにはまとめられません。
右クリックメニュー
- Parameter » Enable Selected Parameters - リストで現在選択されているすべてのパラメーターの「Include」チェックボックスをオンにします。
- Parameter » Enable All Parameters - リスト内のすべてのパラメーターの「Include」チェックボックスをオンにします。
- Parameter » Disable Selected Parameters - リストで現在選択されているすべてのパラメーターの「Include」チェックボックスをオフにします。
- Parameter » Disable All Parameters - リスト内のすべてのパラメーターの「Include」チェックボックスをオフにします。
- Match Strictly » Enable Strict Matching On Selected Parameters - リストで現在選択されているすべてのパラメーターのStrictly オプションを有効にします。
- Match Strictly » Enable Strict Matching On All Parameters - リスト内のすべてのパラメーターのStrictly オプションを有効にします。
- Match Strictly » Disable Strict Matching On Selected Parameters - リストで現在選択されているすべてのパラメーターのStrictly オプションを無効にします。
- Match Strictly » Disable Strict Matching On All Parameters - リスト内のすべてのパラメーターのStrictly オプションを無効にします。
- Selection » Select All - リスト内のすべてのパラメーターエントリを選択します。
- Selection » Deselect All - リスト内のすべてのパラメーターエントリの選択を解除します。
- Selection » Invert Selection - リストで現在選択されていないすべてのパラメーターを選択し、選択されているパラメーターの選択を解除します。
アノテーション対象の回路図シート
ダイアログのこの領域には、設計プロジェクト内のすべてのソース回路図シートが表示されます。この領域のコントロールを使用して、アノテーション処理に含めるシートと、アノテーションの変更内容の計算方法を指定します。各シートについて、次の項目が表示されます。
- Include/Exclude checkbox - このチェックボックスをオンにすると、その回路図シートがアノテーション処理に含まれます。
- Schematic Sheet - このフィールドには、回路図シートの名前が表示されます。
-
Annotation Scope - このフィールドを使用して、シート上のコンポーネントに対するアノテーションの適用範囲を指定します。ドロップダウンリストから、次のいずれかの範囲を選択します。
- All - 回路図シート上のすべてのパーツをアノテーションします。
- Ignore Selected Parts - 設計内で現在選択されているパーツを除く、すべてのパーツをアノテーションします。
- Only Selected Parts - 設計内で現在選択されているパーツのみをアノテーションします。
- Order - このフィールドを使用して、シートのアノテーション順序全体における、このシートの位置を指定します。希望する順序番号をフィールドに直接入力するか、フィールドをクリックすると表示される矢印を使用して、希望する値に変更します。
- Designator Index Control - この列のコントロールを使用して、開始インデックスの使用を有効にし(対応するチェックボックスをオン)、インデックスの値を定義します。デジグネーターの値は、このインデックス値から始まります。
- Add Suffix - このフィールドを使用して、アノテーションされる各デジグネーターに付加する接尾辞を指定します。英字(A、B、C...)、数字(1、2、3...)、英数字以外の文字(_ * . %...)の接尾辞と、これらの組み合わせがサポートされています。
Additional Controls
- All On - クリックすると、すべての回路図シートがアノテーション処理に含まれます。
- All Off - クリックすると、すべての回路図シートがアノテーション処理から除外されます。
-
Right-Click Menu - この領域の右クリックコンテキストメニューでは、次のコマンドを使用できます。
-
Order Alphabetically - 回路図のリストをアルファベット順に並べ替えます。これにより、各シートに対応するOrder エントリが変更されます。
-
Order By Project Order - プロジェクト内での表示順(Projects パネルに表示される順序)に従って、回路図のリストを並べ替えます。これにより、各シートに対応するOrder エントリが変更されます。
-
All On - すべての回路図シートをアノテーション処理に含めます。
-
All Off - すべての回路図シートをアノテーション処理から除外します。
-
変更案リスト
-
Main List - ダイアログのこの領域には、アノテーション対象として選択されたシートに含まれるパーツのすべてのデジグネーターが表示されます。各エントリには、Current とProposed Designator の値の詳細、およびコンポーネントのSub (パーツ)とソースのLocation of Partが含まれます。南京錠アイコン(
)は、デジグネーターとサブパーツの変更を防ぐためにロックされた列を示します。
Current 列のデジグネーターの横にあるチェックボックス(「デジグネーターをロック」)をオンにすると、そのデジグネーターがロックされ、変更されなくなります。同様に、デジグネーターのSub フィールドの横にあるチェックボックス(「サブパーツをロック」)をオンにすると、親のマルチパーツコンポーネント内の該当するサブパーツが更新されなくなります。
この領域の右クリックメニューでは、次のコマンドを使用できます。
- Designator » Lock Selected Designators - リストで現在選択されているすべてのデジグネーターの「デジグネーターをロック」チェックボックスをオンにします。
- Designator » Lock All Designators - すべてのデジグネーターの「デジグネーターをロック」チェックボックスをオンにします。
- Designator » Unlock Selected Designators - リストで現在選択されているすべてのデジグネーターの「デジグネーターをロック」チェックボックスをオフにします。
- Designator » Unlock All Designators - すべてのデジグネーターの「デジグネーターをロック」チェックボックスをオフにします。
- Part ID » Lock Selected Part ID - リストで現在選択されているすべてのデジグネーターの「サブパーツをロック」チェックボックスをオンにします。
- Part ID » Lock All Part ID - すべてのデジグネーターの「サブパーツをロック」チェックボックスをオンにします。
- Part ID » Unlock Selected Part ID - リストで現在選択されているすべてのデジグネーターの「サブパーツをロック」チェックボックスをオフにします。
- Part ID » Unlock All Part ID - すべてのデジグネーターの「サブパーツをロック」チェックボックスをオフにします。
- Selection » Select All - リスト内のすべてのデジグネーターエントリを選択します。
- Selection » Select All With '?' - 現在のデジグネーターに「?」が含まれる(つまり、リセットされた)すべてのエントリを選択します。
- Selection » Deselect All - リスト内のすべてのデジグネーターエントリの選択を解除します。
- Selection » Invert Selection - リストで現在選択されていないすべてのデジグネーターを選択し、選択されているデジグネーターの選択を解除します。
- Annotation Summary - この領域には、対象シート数とマッチングオプションに関するアノテーションの概要が表示されます。これらの設定を変更すると、概要も動的に更新されます。
- Update Changes List - クリックすると、ダイアログの左側で定義したアノテーション設定に基づいて新たに算出された変更内容で、変更案のメインリストを更新します。情報ダイアログには、前の状態からの変更数と、元の状態からの変更数の詳細が表示されます。
- Reset All - クリックすると、メインリスト内のロックされていないすべてのデジグネータを、デフォルトのコンポーネントプレフィックス(R?、C?、D? など)にリセットします。変更内容は Proposed デジグネータ列に反映されます。ボタンのドロップダウンから、コマンドを Reset Duplicates に変更できます。複数のコンポーネントが同じデジグネータを持つ場合、1つを除くすべてのコンポーネントがデフォルトのプレフィックスにリセットされます。この場合も、情報ダイアログに、前の状態からの変更数と、元の状態からの変更数の詳細が表示されます。
- Back Annotate - クリックすると、バックアノテーション用のファイルを検索して選択するダイアログが開きます。
- Accept Changes (Create ECO) - すべての変更案を確認したら、このボタンをクリックして Engineering Change Order ダイアログを開きます。このダイアログには、変更案が「Annotate Component」変更カテゴリ内の変更項目として一覧表示されます。このダイアログでECOを検証して実行すると、回路図レベルのアノテーション処理が完了します。
コンポーネントのロック
非同種のマルチパートコンポーネントでは、アノテーション中にサブパートが変更されないよう、Properties パネルのロックアイコンが閉じた状態になっていることを確認してください。
Strictlyオプション
Component Parameter に対して Strictly チェックボックスが有効になっている場合、すべてのコンポーネントは、そのパラメータが一致するもの同士でパッケージ化される必要があります。このパラメータを持たないコンポーネントは、個別のコンポーネントとしてアノテーションされ、パッケージ化されません。
以下の例では、これらのオプションの組み合わせによって、どのような結果が得られるかを説明します。
8個のORゲートと8個の抵抗を含む設計を考えます(下図参照)。ORゲートには QuadOrGate というパラメータがあり、4個のORゲートのグループにはパラメータ値 Package1 が、もう一方の4個のORゲートのグループにはパラメータ値 Package2 が設定されています。抵抗にはこのパラメータがありません。Component Parameter コントロールで QuadOrGate のチェックボックスを有効にすると、このパラメータを使用してコンポーネントのパッケージ化方法を制御できます。この例では、Strictly チェックボックスは有効にしません。
Tools » Annotation » Annotate Schematics コマンドを実行すると、パラメータ QuadOrGate = Package1 を持つパートは同じ物理コンポーネントにパッケージ化され、パラメータ QuadOrGate = Package2 を持つパートは、それとは別のグループとしてパッケージ化されます。QuadOrGate パラメータを持たない残りのコンポーネントも、まとめてパッケージ化されます。この例では、抵抗には QuadOrGate パラメータがないという共通の属性があるため、まとめてパッケージ化されます。

Strictly オプションがオフの場合のコンポーネントのパッケージ化例。
同じ設計で Strictly オプションをオンにしてアノテーションを行うと、QuadOrGate パラメータを持つコンポーネントのみがパッケージ化されます。この場合、ORゲートはパッケージ化されますが、抵抗はパッケージ化されません。このように、Strictly オプションを使用するとパッケージ化処理を非常に細かく制御できますが、ほとんどの場合はオフにしておきます。

Strictly オプションがオンの場合のコンポーネントのパッケージ化例。
アノテーション対象の回路図シート
アノテーションの対象となる回路図シートやコンポーネント、および変更内容の算出方法を細かく制御できます。

アノテーション範囲の指定。
- 一覧に表示された回路図シートの左側にあるチェックボックスをオンにすると、そのシートがアノテーションコマンドの処理対象になります。
- アノテーションの範囲は Annotation Scope ドロップダウンリストで決定され、回路図シート全体に拡大することも、選択済みまたは未選択のコンポーネントに限定することもできます。Ignore Selected Parts または Only Selected Parts オプションを使用する場合は、アノテーションコマンドを実行する前に、設計内でコンポーネントを選択しておく必要があります。
- Order フィールドを使用して、回路図シートのアノテーション順序を設定します。フィールドに値を直接入力するか、フィールドをクリックすると表示される矢印を使用して、目的の値を設定します。
- Designator Index Control オプションがオンの場合、デジグネータの値は Start Index の値から始まります。Designator Index Control オプションがオフの場合、Start Index は影響しません。
- 対応する Suffix 列に文字列または値を指定すると、各デジグネータの末尾にサフィックスを追加できます。「A」や「1」などの1文字のサフィックスは、サブパートや他のデジグネータ値と混同しやすいため、使用を避けてください。
変更案リスト
Update Changes List ボタンをクリックして Proposed Change List を更新すると、適用前にデジグネータのすべての変更内容を確認できます。変更の対象となるのは、まだ設定されていないデジグネータ(R?、C? など)のみです。そのため、設計内のすべてのデジグネータを更新する場合は、まず Reset All ボタンを押してリセットする必要があります。
Proposed Change List には、アノテーション対象として選択されたシート内のパートのすべてのデジグネータが表示されます。各項目には、Current および Proposed のデジグネータ値の詳細に加え、コンポーネントの Sub (パート)とソースの Location of Part が表示されます。
Designator に対応するチェックボックスをオンにすると、そのデジグネータがロックされ、変更されなくなります。同様に、Sub チェックボックスをオンにすると、そのマルチパートコンポーネントは更新されなくなります。このオプションは、Properties パネルで Lock アイコンを設定する代わりに使用できます。
変更案のリストを確認したら、Accept Changes (Create ECO) ボタンをクリックして Engineering Change Order ダイアログを開きます。ECOを実行すると、アノテーションの変更内容が設計に適用されます。
その他の回路図アノテーションコマンド
ツール » Annotation メニューには、特定の処理に対応した回路図アノテーションコマンドが用意されています。このグループの最初の項目である Annotate Schematic については、すでに説明しました。

使用可能な各種アノテーションコマンド
回路図デジグネータのリセット
さまざまなソースから大量のコンテンツを切り取って新しい設計に貼り付けた場合、すべてのデジグネータをリセットする必要が生じることがあります。このコマンドはアノテーションダイアログの設定を使用するため、そのダイアログで以前に設定した項目に適用されます。 たとえば、以前にすべてのSchematic Sheets To Annotateがチェックされていた場合、Reset Schematic Designatorsコマンドは、シートが現在エディタで開かれているかどうかに関係なく、プロジェクト全体に適用されます。 一部のSchematic Sheets To Annotateのみがチェックされていた場合、Reset Schematic Designatorsコマンドはそれらのシートにのみ適用されます。
コマンドを実行すると、更新が必要なデジグネータの数を示し、変更を続行するかどうかを確認するダイアログが表示されます。 Yesをクリックすると、アクティブなプロジェクト内でアノテーションが有効になっているすべての回路図シートのコンポーネントデジグネータがリセットされ、 R?、 C?、 D?、 U?などの形式で表示されます。
ロックされているデジグネータはリセットされず、一切変更されません。
重複する回路図デジグネータのリセット
設計の一部を複製すると、新しくコピーされたコンポーネントには、コピー元と同じデジグネータ値が保持されます。 Reset Duplicate Schematic Designatorsコマンドを使用すると、重複するデジグネータを「?」にすばやくリセットできます。このコマンドはAnnotate ダイアログの設定を使用するため、そのダイアログで以前に設定した項目に適用されます。たとえば、以前にすべてのSchematic Sheets To Annotateがチェックされていた場合、 Reset Duplicate Schematic Designatorsコマンドは、シートが現在エディタで開かれているかどうかに関係なく、プロジェクト全体に適用されます。 一部のSchematic Sheets to Annotateのみがチェックされていた場合、Reset Schematic Designatorsコマンドはそれらのシートにのみ適用されます。
コマンドを実行すると、更新が必要なデジグネータの数を示し、変更を続行するかどうかを確認するダイアログが表示されます。Yesをクリックすると、アクティブなプロジェクト内でアノテーションが有効になっているすべての回路図シートで見つかった重複するコンポーネントデジグネータがリセットされ、 R?、 C?、 D?、 U?などの形式で表示されます。
ロックされているデジグネータはリセットされず、一切変更されません。
ダイアログを表示せずに回路図をアノテーション
Annotate Schematics Quietlyコマンドは、アクティブなプロジェクト内でアノテーションが有効になっているすべてのソース回路図ドキュメントを調べ、現在デジグネータが割り当てられていないコンポーネントに一意のデジグネータを割り当てます。 アノテーションはダイアログを表示せずに実行されるため、Annotateダイアログを再度開くことなく、以前の設定をすべて適用できます。これは、設計開発が急速に進んでおり、設計のコンパイル前にすばやくアノテーションを行いたい場合に特に便利です。
すべての回路図を強制的にアノテーション
このコマンドは、アクティブなプロジェクト内でアノテーションが有効になっているすべてのソース回路図ドキュメントを調べ、Annotateダイアログで現在定義されているアノテーション方式に従って、それらに含まれるすべてのコンポーネントを再アノテーションします。
Force Annotate All Schematicsコマンドの実行は、Reset Schematic Designatorsコマンドを実行した直後に Annotate Schematics Quietlyコマンドを実行することと同じです。そのため、Force Annotate All Schematics コマンドは、更新可能なコンポーネントとシートを判断する際に、Annotate ダイアログで以前に指定した設定を使用します。
このコマンドを実行すると、承認した場合に更新されるデジグネータの数を示す確認ダイアログが表示されます。 Yesをクリックすると、アクティブなプロジェクト内でアノテーションが有効になっているすべての回路図シートのコンポーネントデジグネータが、必要に応じて再アノテーションされ、Annotate ダイアログのSchematic Annotation Configuration領域で定義されている現在の位置ベースのアノテーション方式に従うようになります。
回路図のバックアノテーション
Altium DesignerのDesign Compiler と Synchronizerが導入される以前は、アノテーションの変更はネットリスト(*.net)ファイルを介して回路図からPCBへ伝達されていました。 逆方向、つまりPCBから回路図へ反映する必要があるアノテーションの変更は、バックアノテーション処理で対応していました。この処理では、Was-Is(*.WAS)ファイルまたは設計変更指示(*.ECO)ファイルを使用して、回路図デジグネータに適用する変更を指示します。
コマンドを実行すると、Choose WAS-IS File for Back-Annotation from PCBダイアログが表示されます。必要な.was(または.eco)ファイルを参照して選択します。Openをクリックすると、前回の状態からのデジグネータの変更数と、元の状態からの変更数を示す情報ダイアログが表示されます。この時点では、変更はまだ実際には適用されていません。OK をクリックしてAnnotateダイアログを開くと、現在のデジグネータに対して提案されている変更を確認してから、それらを適用するためのECOを作成するかどうかを判断できます。
回路図シートの番号付け
Number Schematic Sheetsコマンドは、コンポーネントのデジグネータではなく、回路図シートのデジグネータ(番号)を変更します。そのため、概念的には設計アノテーション全般に関連する機能です。
シートとドキュメントの番号付けにより、シートの識別番号を管理し、それぞれの回路図ドキュメント内にパラメータとして保存できます。その後、Altium Designerの特殊文字列機能(=SheetNumber、=DocumentNumber、=SheetTotal)を使用すると、これらの値をテキストオブジェクトとしてシート上(シートのフッターなど)に表示できます。
シートの番号付けの手順は次のとおりです。
シートの自動番号付け(プロジェクトオプション)
有効にすると、シートの番号付けが自動的に行われます。 値はProjectsパネルに表示されます。Project OptionsダイアログのオプションタブでAutomatic Sheet Numberingオプションをチェックしても、シートの自動番号付けを有効にできます。
シート番号の自動割り当て
Auto Sheet Numberドロップダウンボタンをクリックすると、シートの番号付けオプションにアクセスできます。
Select Numbering Schemeのオプションは次のとおりです。
- Display Order - シートは表示されている順序で番号付けされます。
- Sheets Hierarchical Structure - Depth First - シートは、最上位階層から各ブランチへと順に番号付けされます。まず最上位階層に番号を付け、次にその直下の最初のブランチ全体、続いて2番目のブランチという順に番号を付けます。
- Sheets Hierarchical Structure - Breadth First - シートは、階層内のレベルに従って番号付けされます。まず最上位階層、次に第2階層のすべてのシートという順に番号を付けます。
Select Numbering Method オプションでは、Increasing またはDecreasing の連番を選択できます。
ドキュメント番号の自動設定
Auto Document Number ドロップダウンをクリックすると、ドキュメントの番号付けオプションにアクセスできます。これらは基本的にAuto Sheet Numberオプションと同じですが、Prefix とPostfix の値が追加されています。
Parameters オプションは次のとおりです。
-
Prefix - ドキュメント番号の前に付ける接頭辞を選択します。英字(
A、B、Cなど)、数字(1、2、3など)、数字以外の文字(_、*、.、%など)の接頭辞に対応しており、これらを組み合わせることもできます。 - Start - 番号付けを開始する数値を選択します。
-
Postfix - ドキュメント番号の後ろに付ける接尾辞を選択します。英字(
A、B、Cなど)、数字(1、2、3など)、数字以外の文字(_、*、.、%など)の接尾辞に対応しており、これらを組み合わせることもできます。 - Step - ドキュメント番号ごとの増分値を選択します。たとえば、Start インデックスを1に、Step の値を100に設定すると、最初のドキュメント番号は1、次のドキュメント番号は101(開始値 + 増分)、その次は201というようになります。
シート数の更新
Update Sheet Countボタンをクリックすると、現在のプロジェクトのシート数が集計され、その結果がSheetTotal列に入力されます。シート数は、前述のいずれのコントロールで選択した番号付け方式にも関係なく、プロジェクト内のシートの総数になります。
上へ移動/下へ移動
Move UpまたはMove Downボタンを使用して、選択した回路図ドキュメントをリスト内で上下に移動します。これは、Display Order番号付け方式を使用してシート番号またはドキュメント番号を指定する場合に関係します。
カスタムの番号付け/命名
組織で使用している独自の番号付け方式や命名規則を、Auto Sheet Number またはAuto Document Numberコマンドで自動化できない場合は、カスタムのシート名と番号をSheetNumberまたはDocumentNumber フィールドに直接入力できます。
回路図シートの番号付けとデバイスシート
デバイスシートが読み取り専用(デフォルトの状態)の場合、シート番号やドキュメント番号は設定できません。プロジェクトのシート番号付けダイアログでは、更新できないことを示すために網掛けで表示されます。デバイスシートを編集可能に設定すると網掛けが解除され、通常どおりシート番号とドキュメント番号を設定できます。
PCB上のデジグネーター表示の制御
マルチチャネル設計の拡張デジグネーター文字列は、PCBエディターでの配置が煩雑になることがあります。短い名前になる命名オプションを選択するか、代わりに元の論理コンポーネントデジグネーターを表示できます。たとえば、C30_CIN1はC30と表示されます。この場合、コンポーネントのオーバーレイ上で各チャネルを枠で囲むなど、個々のチャネルを識別するための別の表記を基板に追加する必要があります。
PCB上で論理デジグネーターと物理デジグネーターのどちらを表示するかは、Board モードのPropertiesパネルにある Other 領域のDesignator Displayドロップダウンで選択できます。マルチチャネル設計のコンポーネントについて論理デジグネーターの表示を選択すると、PCB上だけでなく、印刷やガーバーなどの生成出力にも論理デジグネーターが表示されます。ただし、部品表の生成時には常に一意の物理デジグネーターが使用されます。
設計の同期 - アノテーションプロセスの完了
回路図エディターとPCBエディターの両方にアクセスできない場合を除き、回路図とPCBのデジグネーターを一致させるには、設計の直接同期を使用することをお勧めします。設計の同期では、回路図のコンポーネントと接続情報をPCBと直接比較し、差分のリストを作成します。これらの差分を解消するために必要な変更のリストは、ECO(Engineering Change Order:設計変更指示)として生成されます。ECOファイルには現在の設計と目的の設計の差分が記述されており、これを実行することで対象を更新し、設計を同期できます。
順方向同期と逆方向同期
順方向同期と逆方向同期は、データの同期時にアノテーションや設計変更が転送される方向を表す用語です。回路図を起点とし、回路図を中心に進める設計フローを想定すると、順方向同期は回路図エディターで行った変更をPCBへ反映するプロセスです。逆方向同期は、PCBで行った変更を回路図エディターへ反映するプロセスです。
順方向同期
回路図からPCBへデータを同期する主な理由は、次のとおりです。
- 回路図エディターで新しいコンポーネントを追加し、PCBレイアウトにもそのコンポーネントが必要になった。
- 回路図設計のアノテーションを初めて実行した、または前回の設計同期以降に実行した。
- マルチチャネル設計で、物理(PCB)側の命名スタイルを変更するためにProject Optionsを変更した。
- 基板レベルのアノテーションを初めて実行した、または前回の設計同期以降に実行した。
回路図設計をPCB設計へ順方向に同期するには
次のいずれかの方法で、回路図設計をPCB設計へ順方向に同期します。
- 回路図エディターのDesign メニューでUpdate PCB Document を選択します。回路図と対象のPCBドキュメントに差分がある場合は、Engineering Change Orderダイアログが開き、PCBを回路図設計と同期するために必要な変更のリストが表示されます。Execute Changesをクリックして設計を同期します。
- PCBエディターのDesign メニューでImport Changesを選択します。回路図ドキュメントの変更がPCBドキュメントに取り込まれます。
逆方向同期
逆方向同期は、PCB設計のアノテーションや変更を行い、その内容を回路図設計に反映したい場合に実行します。
PCB設計を回路図設計へ逆方向に同期するには
次のいずれかの方法で、PCB設計を回路図設計へ逆方向に同期します。
-
PCBエディターのDesign メニューでUpdate Schematicsを選択します。デフォルトでは、Project OptionsダイアログのECO生成タブにあるPush Component Designator Changes to Annotation File (if any)オプションがオンになっているため、PCBエディターで行った変更はアノテーションファイルのみに反映され、最終的にコンパイル時にコンパイル済みドキュメントへ反映されます。このオプションをオフにすると、変更はソース回路図ドキュメント(Editor ビュー)のみに反映されます。
- 回路図エディターでTools » Annotation » Annotate Schematicsを選択し、アノテーションダイアログのBack Annotateボタンをクリックします。PCB環境でデジグネーターを再アノテーションした際に生成されたWAS-ISファイルを選択します。
- 回路図エディターでTools » Annotation » Board Level Annotateを選択し、基板レベルのアノテーションダイアログのBack Annotateボタンをクリックします。PCB環境でデジグネーターを再アノテーションした際に生成されたWAS-ISファイルを選択します。
- 回路図エディターでTools » Annotation » Back Annotate Schematicsを選択します。PCB環境でデジグネーターを再アノテーションした際に生成されたWAS-ISファイルを選択します。
従来の設計同期方法
Altium Designer は、中間ファイル(ネットリストおよびWAS/IS)を使用する従来の設計同期方式をサポートしています。アノテーションデータの順方向同期にはネットリストファイルを使用でき、逆方向同期にはWAS/ISファイル(各デジグネーターの変更前の値WAS と現在の値ISを記載)を使用できます。設計の同期には、直接設計同期の使用を推奨します。
一意のIDによるコンポーネントのリンク
設計を再アノテーションすると、回路図コンポーネントのデジグネーターまたはコンパイル済みコンポーネントのデジグネーターがPCBコンポーネントのデジグネーターと一致しなくなるため、設計を適切に完了するには同期が必要です。Altium Designerでは、回路図シンボルと対応するPCBフットプリントを関連付けるキーフィールドとしてデジグネーター自体に依存するのではなく、一意の識別子(UID)システムを通じて設計の同期を維持できます。UIDは、ソースコンポーネントを一意に識別するためにシステムが生成する値で、各回路図コンポーネントと対応するPCBコンポーネントを照合します。
コンポーネントを回路図シートに配置すると、UIDが自動的に割り当てられます。ソース回路図ドキュメントから空のPCBにコンポーネント情報を初めて転送すると、各回路図コンポーネントのUID情報が、対応するPCBコンポーネントに割り当てられます。
リファクタリングにより、シートとそのコンポーネントの一意のIDを維持したまま、デバイスシートを回路図シートに、またはその逆に変換できます。また、サブ回路の一意のIDを維持したまま、現在のプロジェクト内の別の回路図シートにサブ回路をリファクタリング(移動)することもできます。Refactor コマンドは、Edit メニューにあります。
Design » Updateコマンドを実行して開始するAltium Designerの同期機能は、これらのUIDを使用して、各回路図コンポーネントと対応するPCBコンポーネントを照合します。その後、設計変更指示(ECO)を使用して設計の更新や変更を適用できます。ECOには、要求された同期処理を満たすために、1つ以上の設計ドキュメントに対して必要となるすべての変更が一覧表示されます。ECOは、次のようなさまざまな状況で設計の更新を適用するために使用されます。
- SCHからPCBへの設計更新。
- 回路図コンポーネントのデジグネーターおよびコンパイル済みコンポーネントのデジグネーターに対するアノテーションの更新。
- Parameter Manager (Tools » Parameter Manager)を使用したパラメーターの更新。
- ソースライブラリまたは社内データベースに保存されている情報によるパラメーター情報の更新。回路図とPCBを比較するたびに(Design » Updateを選択した場合など)、Altium Designerはまず、同じUIDを持つコンポーネントを照合します。 UIDが一致しないコンポーネントが検出されると通知が表示され、デジグネーターによる照合を試みるかどうかを確認されます。回路図とPCBの両方に一致するUIDを割り当てるまで、このメッセージは表示され続けます。一意のIDとその対応関係は、コンポーネントリンクの編集ダイアログ(Project » Component Links)で管理します。
UIDの変更は常に回路図ではなくPCBに適用されるため、このダイアログはPCBドキュメントがアクティブな場合にのみ開くことができます。このダイアログは設計のどの段階でも使用でき、コンポーネント間のリンクを表示して、ドキュメント間でコンポーネントが正しく対応付けられていることを確認したり、現在対応付けられていないコンポーネントに一致するUIDを割り当てたりできます。


