論理的なシステムデザインの設計

概略

Altium Designerで、マルチボード回路図のモジュールに子PCBプロジェクトをリンクし、マルチボードシステムの論理設計を取り込む方法を学びます。この記事では、システムレベルの接続に使用するコネクタの準備、モジュールのソースとプロパティの定義、コネクタのピンおよびネットのデータをインポートしてモジュールエントリに反映する方法を説明します。読み進めて、システム内の基板間接続をわかりやすく表現するための第一歩を踏み出しましょう。

- マルチボード回路図を作成し、モジュールを子PCBプロジェクトにリンクする手順を理解します。
- `System:Connector`パラメータによって、システムレベルの設計に含めるコネクタを識別する方法を学びます。
- 子PCBプロジェクトを検証し、その接続データをモジュールエントリにインポートする方法を学びます。
AIでさらに深掘り:

子PCBプロジェクトの設計からマルチボードシステムの回路図設計を作成するための基本的な手順は、次のとおりです。

  1. マルチボード設計プロジェクトを作成し、マルチボード回路図ドキュメントをプロジェクトに追加します。

  2. マルチボード回路図にグラフィカルブロック(モジュール)を配置して、子PCBプロジェクトを論理的に表現します。

  3. 各モジュールを対応する子プロジェクトにリンクします。

  4. 子プロジェクトの接続データをマルチボード設計にインポートします。

  5. モジュール間に接続を追加して、論理的なシステム設計を作成します。

マルチボード回路図ドキュメント(*.MbsDoc)をマルチボード設計プロジェクトに追加するには、Projectsパネルでプロジェクトのエントリを右クリックし、コンテキストメニューから Add New to Project » Multi-board Schematic を選択します。

各マルチボード設計プロジェクトに含めることができるマルチボード回路図ドキュメントは1つだけです。

PCBプロジェクトをマルチボード設計に対応させる

マルチボード設計で子基板の設計を表すAltium DesignerのPCBプロジェクトには、エッジコネクタやヘッダープラグ/ソケットなど、システム設計内の他のPCBとの電気的および物理的なインターフェースとなる接続部が含まれます。

システムレベルの設計で基板間の接続を確立するには、マルチボード回路図(論理)設計ドキュメントで、これらの接続部とそれに関連する電気ネットを検出して処理する必要があります。この機能は、PCBプロジェクトのコネクタに特定のコンポーネントパラメーターを設定することで有効になります。パラメーター名を System、パラメーター値をConnectorに設定します。

System:Connector というパラメーターと値を持つコネクタは、Import from Child Projectsコマンドを使用してシステムレベルの各モジュールをその子PCBプロジェクトと同期するときに検出されます。これについては、後述の「マルチボード回路図での子PCBプロジェクトの表現」セクションで説明します。

PCBプロジェクト設計内でシステムレベルの相互接続に使用する各コネクタについて、コネクタ部品を選択し、選択時に表示されるPropertiesパネルのGeneralタブにあるParameters領域のリストに、専用のコンポーネントパラメーターを追加します。

コンポーネントのプロパティについて詳しくは、 配置済みコンポーネントの操作ページを参照してください。

名前がSystem、値がConnectorのパラメーターを設定することで、このPCBコネクタがマルチボード回路図にリンクされます。
名前がSystem、値がConnectorのパラメーターを設定することで、このPCBコネクタがマルチボード回路図にリンクされます。

マルチボード回路図での子プロジェクトの表現

マルチボード設計を構成するPCBプロジェクト間の接続は、それらを表すブロック(モジュール)を回路図上に配置し、公開されているコネクタ(モジュールエントリ)同士を接続で結ぶことで確立されます。

子PCBプロジェクトの設計と、その中の特定のPCBを表すモジュールは、Place » Moduleメニューから設計スペースに配置します。

配置したモジュールのソースを定義するには、設計スペースでモジュールを選択し、PropertiesパネルのGeneralタブにある Source 領域で、Projectフィールドに対応する ボタンをクリックします。表示されるChoose Projectダイアログ(Open Projectダイアログの一形態)で、モジュールのソースとするPCBプロジェクトまたはマルチボードプロジェクトを参照して選択します。 目的のプロジェクトを選択したら、Assembly/Board ドロップダウンを使用して、そのプロジェクト内の目的のPCB基板設計/マルチボードアセンブリを選択します。

構成済みのマルチボードプロジェクトには、ソースドキュメントと、回路図のシステム設計内のモジュールにリンクされた子サブプロジェクトを含む、階層的なドキュメント構造があります。システム設計のモジュールを外部プロジェクトにリンクすると、その子プロジェクトの構造が直ちにマルチボードプロジェクトに追加されます。 Projectsパネルでプロジェクト構造を展開すると、マルチボードプロジェクトとその子プロジェクトを構成するファイルが表示されます。

マルチボードプロジェクトがサブプロジェクトから正しいデータを抽出して処理できるように、各プロジェクトのPCBを回路図と同期し、設計や作図のエラーがない状態にしてください。PCBサブプロジェクトを検証するには、パネルでその名前を右クリックし、Validate PCB Project <ProjectName>.PrjPcbコマンドを選択します。問題がある場合は、Messagesパネルに一覧表示されます。

Javascript ID: Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • PCB、別のマルチボード、またはハーネス設計プロジェクトをマルチボードプロジェクトの構造に追加するには、Projectsパネルでマルチボードプロジェクトのエントリを右クリックし、Add Existing to Projectコマンドを選択して、対応するローカルの*.PrjPcb、*.PrjMbd、または*.PrjHarファイルを参照して選択します。マルチボードプロジェクトに組み込むPCBまたはハーネス設計プロジェクトがAltium Designerですでに開かれている場合は、Projectsパネルでそのエントリを親マルチボードプロジェクトのエントリにドラッグして、構造に追加できます()。その後、親マルチボードプロジェクトのマルチボード回路図ドキュメントに新しいモジュールを手動で配置します。モジュールを選択した状態で、PropertiesパネルのSourceフィールドのドロップダウンから、子PCBプロジェクト(およびそのPCBドキュメント)または子マルチボードプロジェクト(およびそのマルチボードアセンブリドキュメント)を、そのモジュールのソースとして選択します()。ハーネスプロジェクトは、マルチボードプロジェクトと同期できます(詳しくは、 配線図の定義ページを参照してください)。

  • 親マルチボードプロジェクトの構造から子PCBプロジェクトまたは子マルチボード設計プロジェクトを削除するには、親のマルチボード回路図ドキュメントから、その子プロジェクトを参照するすべてのモジュールを削除します。これにより、子プロジェクトが構造から自動的に削除されます。

  • 子PCBプロジェクトまたはハーネス設計プロジェクトは、そのエントリをマルチボードプロジェクトの構造の外にドラッグすることでも、親マルチボードプロジェクトの構造から削除できます。ただし、この方法でPCBプロジェクトを削除した場合、その子プロジェクトを参照するモジュールはマルチボード回路図ドキュメントに残り、モジュールから子プロジェクトへのリンクも維持されます。削除した子プロジェクトに関連する要素を親マルチボードプロジェクトから完全に取り除くには、これらのモジュールを手動で削除してください。

配置したモジュールを選択した状態で、Propertiesパネルを使用してモジュールのその他のプロパティを定義します。

  • パネルのGeneralタブにあるProperties領域のDesignator およびTitleプロパティを使用して、モジュールの回路図識別子とタイトル文字列をそれぞれ指定します。対応するフィールドの右側にあるボタンでマルチボード回路図での表示/非表示を切り替え、ボタンで値の編集可否を切り替えます。フォントおよびOtherコントロールを使用して、文字列のフォント、ドキュメント内の位置、およびタイトル文字列の場合はパラメーター名の表示/非表示を設定します。

  • モジュールを選択したときにPropertiesパネルのGeneralタブに表示されるEntries 領域の表には、モジュールにモジュールエントリを追加するとデータが表示されます。以下を参照してください。

  • パネルのGeneralタブにあるGraphical領域のコントロールを使用して、モジュールの表示を設定します。サイズ(幅と高さ)、モジュール外形線の太さ、スタイル、色、および塗りつぶし色を設定できます。選択可能な線の太さとスタイルは、デザインスペースでオブジェクトを選択していないときに表示される、PropertiesパネルのLine Styles領域で定義されます。詳細については、マルチボード回路図ドキュメントの設定ページを参照してください。

  • パネルのParametersタブにあるコントロールを使用して、モジュールパラメーターの追加、変更、削除を行い、デザインスペースでの表示/非表示を設定します。  

システム全体の設計に必要なモジュールと、それらの子プロジェクトへのリンクを、マルチボード回路図設計に追加します。

メインメニューまたはデザインスペースの右クリックメニューから次のコマンドを使用してプロジェクトデータをインポートすると、リンク先プロジェクトの設計データがモジュールに取り込まれます。

  • Design » Import From Child Projects – すべてのソース(子)プロジェクトの設計データを、指定されたモジュールに反映します。

  • Design » Import From Selected Child Projects – 現在選択されているモジュールに対応するソース(子)プロジェクトの設計データを反映します。

特に重要なのは、この処理によって、子プロジェクト内で特別なSystem:Connectorパラメーターが付加されている各コネクタのピンおよびネットデータが処理されることです(詳細は上記を参照)。インポートが完了すると、これらの各コネクタに対応するモジュールエントリが、それぞれのモジュールブロックの図形上に自動的に作成されます。コネクタエントリは、子プロジェクト内のコネクタのピンおよびネットと関連付けられています。デザインスペースでモジュールエントリの図形を選択すると、Propertiesパネルにコネクタのピン/ネットなどの詳細が表示されます。別のモジュールのエントリに接続されるまでは、パネルのエントリの部品/ピン一覧で、コネクタとピンは未嵌合として表示されます。

 
  • 子プロジェクトからデータをインポートするとエントリは自動的に配置されますが、メインメニューからPlace » Entryコマンドを選択して、モジュールエントリを手動で配置することもできます。

  • モジュールエントリの図形をクリックして選択し、モジュールの外周に沿って適切な位置にドラッグします。なお、エントリのデジグネーターは個別にドラッグして別の位置に移動できます。

  • 複数のエントリを選択し、目的の位置までまとめてドラッグすることで、モジュールエントリのグループを移動することもできます。

  • エントリの色表示は、適切な移動/配置の目安になります。モジュールの外側では、エントリは一部のみがグレー表示され、配置できません。モジュール上では、エントリ全体が色付きで表示され、その位置に配置できることを示します。

エントリを選択した状態で、Propertiesパネルを使用してそのプロパティを定義します。

  • パネルのGeneralタブにあるProperties領域のコントロールを使用して、エントリのDesignatorの値、表示/非表示、スタイルを変更し、エントリのType(Male/Female)を選択します。パネルのこの領域には、エントリのコネクタのピン数(Number of Pins)と、親モジュール内でこのエントリに割り当てられた識別番号(Entry Number)も表示されます。

  • System Entry オプションを有効にすると、電源入力ソケットを表すエントリなど、別のモジュールに配線されないシステムレベルの接続としてエントリを指定できます。

    子マルチボードプロジェクトに、エントリのSystem Entryオプションが有効になっているモジュールがあります。

    親マルチボードプロジェクトに変更をインポートすると、このエントリのコネクタが、子プロジェクトを表すモジュールのモジュールエントリとして追加されます。

     
  • エントリをハーネス接続またはケーブル接続で接続すると(詳細はこちら)、パネルのMated Component領域に嵌合相手のコンポーネントに関するデータが表示されます。

  • Mated Pins内のパネルの領域では、Pin列にコネクタの各ピンと、それぞれに関連付けられたネットが表示されます。このエントリが接続されると、Mated Pin列に接続先のピンの一覧が表示されます。また、このエントリが接続されると、PropertiesパネルのAddressesタブに、そのエントリの接続経路とネットが表形式で表示されます(詳細はこちら)。

  • パネルのParametersタブにあるコントロールを使用して、エントリのパラメータを追加、変更、削除し、デザインスペースでの表示を設定します。

モジュールにモジュールエントリを追加すると、そのモジュールを選択した際に、PropertiesパネルのGeneralタブにあるEntries領域のテーブルにエントリが表示されます。Part(s)列には、ソース設計のエントリコネクタのデジグネータと名前で各モジュールエントリが表示されます。これらは使いやすいように編集できます。この名前はマルチボード設計内でのみ使用され、ソースの子プロジェクトには影響しません。

  • Mated part(s)列には、マルチボード設計内で接続を使用してエントリを別のエントリに接続すると、データが表示されます。詳細については、接続の操作ページを参照してください。

  • 一覧から、エントリのデジグネータの表示(  /  )と種類(  /  )をすばやく切り替えることができます。ボタンを使用すると、新しい未定義のエントリをモジュールと一覧に追加でき、ボタンを使用すると、一覧で選択したエントリをモジュールから削除できます。

  • ボタンを使用すると、一覧で選択した接続を、互いに関連する2つのモジュールエントリに分割できます。ボタンを使用すると、以前に分割したエントリを再び1つのエントリに統合できます。詳細については、接続の操作ページを参照してください。

外部周辺機器/コンポーネントのサポート

この機能は、詳細設定ダイアログでMBS.PlacePartおよびMBS.UseGeometryMakerオプションが有効になっている場合に使用できます。

マルチボード回路図ドキュメントは、通常の子PCB基板アセンブリに含まれない外部周辺機器/コンポーネント(つまり「非PCB」コンポーネント)をサポートしています。たとえば、外部スイッチ、センサー、その他の市販のサードパーティ製電子モジュールなどが該当します。この機能は、次の2種類のオブジェクトのサポートによって実現されています。

  • Custom Part – 1つ以上のライブラリコンポーネントをリンクできるモジュールのような要素で、メインメニューのPlace » Custom Partコマンドを使用してマルチボード回路図ドキュメントに追加します。配置したカスタム部品をデザインスペースで選択した状態で、PropertiesパネルのLinked Components領域を使用し、ボタンでカスタム部品にコンポーネントを追加し、ボタンで削除します。リンクされたコンポーネントの一覧に古いWorkspaceコンポーネントが含まれている場合は、ボタンをクリックして、それらのコンポーネントを最新リビジョンに更新します。リンクされたコンポーネントごとに、エントリが自動的に追加されます。

  • Custom Connection – 必要なコンポーネントをComponentsパネルからシート上の空いている場所にドラッグ&ドロップすることで、単一のライブラリコンポーネントをマルチボード回路図ドキュメントに追加できます。コンポーネントの各ピンに対して、エントリが自動的に追加されます。

    マルチボード回路図ドキュメント専用のカスタムシンボルをコンポーネント用に作成することもできます。ピンのプロパティのNameフィールドにカンマ区切りの名前を追加すると、複数のピンをエントリにグループ化できます。これにより、エントリ数を減らした見やすいシンボルを作成でき、そのようなコンポーネントの接続が大幅に簡素化されます。

    Javascript ID: MBS_CustomConn_MultiplePins_AD24_5

    回路図シンボルの編集中に、ピンのNameフィールドに複数の名前をカンマ区切りで追加します。

    マルチボード回路図のカスタム部品にコンポーネントを追加すると、コンポーネント全体に対する単一のエントリではなく、コンポーネントの各ピンに対するエントリが作成され、複数のピンを持つエントリが作成されます。

    コンポーネントをカスタム接続としてマルチボード回路図に配置すると、複数のピンを持つエントリが作成されます。

ライブラリコンポーネントには、接続先のWorkspaceおよび使用可能なローカルライブラリのコンポーネントを使用できます。配置/定義した後は、たとえばケーブル接続やハーネス接続を使用して、それらのコンポーネントを設計の他の部分に接続できます。

カスタム部品やカスタム接続を通じて定義されたリンク先コンポーネントは、製品/システム全体のBOMには自動的に含まれず、マルチボードアセンブリ(*.MbaDoc)にも表示されません。

クロスプローブ

Designメインメニューおよびデザインスペースの右クリックメニューにあるクロスプローブコマンドを使用すると、マルチボード回路図ドキュメントから子プロジェクト内の関連要素へすばやく移動できます。

  • 現在選択しているモジュールまたはエントリから、そのモジュールが参照するPCB設計プロジェクト内のPCBドキュメント、またはそのドキュメント上のコネクタにクロスプローブするには、Design » Crossprobe to PCB/Multi-boardコマンドを使用します。モジュールがソースのマルチボードプロジェクト(*.PrjMbd)内のマルチボードアセンブリドキュメント(*.MbaDoc)を参照している場合は、そのマルチボードアセンブリドキュメントがクロスプローブ先になります。

  • 現在選択しているモジュールまたはエントリから、そのモジュールが参照するPCB設計プロジェクト内の最上位回路図、または該当する回路図上のコネクタにクロスプローブするには、Design » Crossprobe to Schematicコマンドを使用します。

  • 現在選択しているモジュールまたはエントリから、マルチボードプロジェクト(*.PrjMbd)内のマルチボードアセンブリドキュメント(*.MbaDoc)上の基板、またはその基板上のコネクタにクロスプローブするには、Design » Crossprobe to MBAコマンドを使用します。

  • マルチボード回路図ドキュメント(*.MbsDoc)上で現在選択しているハーネス接続から、リンクされたハーネスプロジェクト(*.PrjHar)にクロスプローブするには、Design » Crossprobe to Harnessコマンドを使用します。関連付けられたハーネスプロジェクトの配線図ドキュメントが開きます。

モジュールエントリからクロスプローブすると、対象の回路図/PCBドキュメント上のクロスプローブ先オブジェクトは、PreferencesのSystem – Navigationページで定義されたHighlight Methodsオプションに従って表示されます。 ダイアログ。マルチボード回路図ドキュメントにはハイライトは適用されません。

印刷またはPDFへのエクスポート

現在アクティブなマルチボード回路図ドキュメントを印刷するには、メインメニューからFile » Printを選択します(ショートカット: Ctrl+P)。 Print ダイアログが開きます。 ダイアログの左側には、拡大・縮小可能な印刷プレビューが表示されます。右側には、標準的な印刷オプションが用意されています。プリンターの指定、プリンターの場所の確認、印刷キュー内のドキュメント数の表示、印刷部数の調整、用紙サイズや向きの設定などが可能です。 をクリックすると、設定したオプションに従って、選択したプリンターに印刷データが送信されます。

Printダイアログ
Printダイアログ

マルチボード回路図ドキュメントをPDFファイルにエクスポートするには、メインメニューからFile » Export to PDFを選択します。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents