プロセスの作成と管理

Altium Designer は強力なコラボレーティブ設計環境を提供します。その一部として、Workflows をサポートしており、これにより企業の設計者は、日常的な一般的設計プロセスを進めることができます。たとえば次のようなものです:

  • 新しい Workspace ライブラリ部品の要求
  • 設計レビューの実施
  • 新しい Workspace プロジェクトの作成。

特定の設計プロセスを実装するために使用される各 Workflow は、Process Definition の一部として作成されます。したがって、そのプロセスの基盤となる Workflow、または単に Process Workflow と呼ぶことができます。

プロセスとそれに対応する Workflow は、Enterprise Server Workspace のブラウザーインターフェースを通じて、当該 Workspace の管理者によって作成および管理されます。

前述の 3 つの設計領域については、事前定義済みのプロセスワークフローがサーバーのインストールに含まれています。これらの一部は、初期状態のままで使用できるよう有効化されています。これらをそのまま使用しても、変更しても、あるいは必要に応じて独自に作成して、会社のニーズに合わせることもできます。その他はサンプルであり、そのままでは有効化して使用できません。したがって、それぞれは一種の「テンプレート」に近いものであり、会社の要件に合わせて編集し、名前を付けて新しいプロセス定義として保存し、それを can してから、他のすべての定義とともに有効化して使用します。

強力な Process Workflow Editor により、必要に応じてシンプルにも複雑にもでき、会社の要件に沿った Workflow を備えたプロセスを構築する柔軟性が提供されます。

プロセスへのアクセス

すべてのプロセス管理は、Enterprise Server Workspace のブラウザーインターフェースにある Processes エリア(Admin – Processes)内から実行されます。

インターフェースの Processes エリアを表示するには、Enterprise Server Workspace の管理者としてサインインしている必要があります。

Enterprise Server Workspace のブラウザーインターフェースにある Processes エリアへのアクセス - プロセスと関連 Workflow を扱うための中枢コマンドです。Enterprise Server Workspace のブラウザーインターフェースにある Processes エリアへのアクセス - プロセスと関連 Workflow を扱うための中枢コマンドです。

Processes インターフェースは、次の 4 つのタブで構成されています:

  • Browser – すべてのプロセス(アクティブまたはクローズ済み)の概要リストを表示します。いわば一元化された「プロセスダッシュボード」です。
  • Part Requests – 部品要求というテーマに関連するプロセスを管理するための専用エリアを提供します。
  • Project Activities – 設計レビューや PLM システムへの公開など、Workspace プロジェクトの作業というテーマに関連するプロセスを管理するための専用エリアを提供します。
  • Project Creations – 新しい Workspace 設計プロジェクトの作成というテーマに関連するプロセスを管理するための専用エリアを提供します。
最後の 3 つのタブは、Process Themes と呼ぶことができます。Process Theme を使用すると、さまざまなプロセスを設計領域ごとに直感的にグループ化できます。また、特定の領域に必要な Workflow 要素のみをサポートすることで、新しいプロセスの作成にソフトウェアが対応できるようになり、必要な Workflow の構築を効率化します。今後、このアプローチは、必要に応じてさらにテーマを追加することでインターフェースを拡張していくための基盤を Altium に提供します。

以降の各セクションでは、これらの各種タブについてさらに詳しく見ていきます。

Browser タブ

このタブを使用すると、すべてのプロセステーマにまたがって、すべてのアクティブまたはクローズ済みプロセスを一元的に参照できます。デフォルトでは、このタブにはすべての Active(実行中の)プロセスが表示されます。リスト上部のドロップダウンフィールドを使用すると、すべての Closed プロセス(例: 完了、却下、終了)に切り替えて表示できます。

便利な 1 か所からすべてのアクティブプロセスを参照できます。画像にカーソルを合わせると、すべてのクローズ済みプロセスを参照している例が表示されます。
便利な 1 か所からすべてのアクティブプロセスを参照できます。画像にカーソルを合わせると、すべてのクローズ済みプロセスを参照している例が表示されます。

各エントリについて、次の情報が表示されます(該当する場合):

  • Status – プロセスの状態。以下のいずれかになります:
    • Active – プロセスは現在アクティブで、関連する Workflow が進行中です。
    • On hold – プロセスは現在アクティブですが、Workflow を進める前に、担当者の割り当てなどの初期入力待ちです。
    • Closed – プロセスは現在クローズされており、たとえば正常に完了したか、却下されました。
    • Terminated – プロセスは現在クローズされており、Workspace 管理者によって直接終了されました。
  • Process Name – プロセス定義の名前。
  • Title – このフィールドは、同じプロセスの複数インスタンスを区別するために使用されます。タイトルはプロセス名にインスタンス接尾辞(#1#2 など)を付けたものです。
  • State – これは、そのプロセスに関連付けられた Workflow 内で現在到達している状態です。
  • Assignee(アクティブプロセスのみ) – これは、現在の Workflow 状態からプロセスを前進させるために、今タスクを実行する必要があるユーザーです。
  • Started By – プロセスを開始したユーザー。
  • Started At – プロセスが開始された日時。
  • Ended At(クローズ済みプロセスのみ) – プロセスがクローズされた日時。

アクティブなプロセスでは、Terminate コントロール()も使用できます。これをクリックすると、プロセスを強制終了します。プロセスは Closed プロセス一覧に移動します。

コントロールを持つ任意の列でプロセスを並べ替えることができます。コントロールまたは列名をクリックしてください。検索は、リスト上部の Search フィールドを使用して行うこともできます。StatusStarted AtEnded AtTerminate を除くすべてのフィールドのデータを検索に使用できます。
  • 以前にエクスポートしたプロセス定義をファイルから直接 Browser タブ内でインポートすることもできます。その場合は、 ボタンをクリックします。表示される Open ダイアログで、必要な Workflow ファイル(*.aaw)を参照して開きます。正しいプロセステーマが検出され、ファイルの内容が Process Workflow Editor に読み込まれます。詳細については、プロセス定義のインポート/エクスポート を参照してください。
  • ボタンを使用すると、現在一覧表示されているアクティビティ(Process Workflow)のレポートを、詳細なカンマ区切りの *.csv ファイルとしてエクスポートできます - サンプルを表示Active または Closed アクティビティをエクスポートでき、含めるエントリはプロセス名の Search フィールドでフィルターできます。設計側では、Altium Designer の Explorer panel にも同等の ボタンがあり、プロジェクト参照時(デフォルトの Project view を使用)の Activites タブの下から、そのプロジェクトに関連する現在一覧表示中のアクティビティデータをダウンロードできます。

プロセスのエントリをクリックすると、その基盤となる Workflow の図が(リスト下の Diagram タブに)表示され、プロセス完了に必要な内容と、そのプロセスがフロー上のどこにあり、誰が次のタスクを実行してプロセスを先に進める必要があるかを確認できます。

右下の コントロールをクリックすると、Workflow 内で現在到達しているポイントが強調表示され、ユーザーエントリが一瞬点滅します。

選択したプロセスの基盤 Workflow を、その Diagram タブで表示しているところです。各 Workflow は図として構築されているため、プロセスが現在 Workflow のどこに位置しているか、またそのプロセスをさらに進めるために次のタスクを担当するのが誰かを、一目で確認できます。選択したプロセスの基盤 Workflow を、その Diagram タブで表示しているところです。各 Workflow は図として構築されているため、プロセスが現在 Workflow のどこに位置しているか、またそのプロセスをさらに進めるために次のタスクを担当するのが誰かを、一目で確認できます。

以下の追加タブも利用できます:

  • Data – プロセスに関連するすべてのデータを表示します。たとえば設計レビューのプロセスでは、プロジェクトとそのデータセット、レビュータイプ、レビューに関わる人々、追加の添付ファイルなどが含まれます。部品要求プロセスでは、添付データシート、パラメトリックデータ、予備コンポーネントなどが含まれる場合があります。

    添付ファイル、データシート、プロジェクトおよびプロジェクトデータセット(Item-Revision)などの該当エンティティは、すばやく移動または開けるようにハイパーリンクとして表示されます。また、このタブで標準ユーザーに表示するパラメトリックデータを設定することもできます。プロセスの Workflow を編集する際、要素が何も選択されていない状態では、Data タブに表示できるデータが右側ペインに一覧表示されます。Edit コントロールをクリックすると、関連フォーム(<ProcessName> Data)にアクセスできます。
  • History – プロセスの Workflow に沿って実行されたアクションの履歴を表示します。

    Data タブおよび History タブを使用すると、それぞれプロセスの詳細情報と、その Workflow アクティビティの履歴を参照できます。Data タブおよび History タブを使用すると、それぞれプロセスの詳細情報と、その Workflow アクティビティの履歴を参照できます。

Part Requests/Project Activities/Project Creations タブ

これらのタブでは、プロセスを特定のテーマごとにまとめて、順に、新しい Workspace ライブラリ部品の要求、設計レビューまたは PLM システムへの公開、新しい設計プロジェクトの作成に使用するプロセス Workflow を表示、作成、管理できます。

デフォルトでは、タブの上部領域には、そのテーマ内で定義されたプロセスのすべての Latest バージョンが表示されます。リスト上部のドロップダウンフィールドを使用すると、All 定義済みプロセス(つまり全バージョン)の表示に切り替えられます。

特定のテーマ(この場合は Project Activities テーマ)について定義済みプロセスの最新バージョンを参照している例。特定のテーマ(この場合は Project Activities テーマ)について定義済みプロセスの最新バージョンを参照している例。

各エントリについて、次の情報が表示されます:

  • Process Name : version – プロセス定義の名前とそのバージョン。常に最新バージョンを表示/操作するには、リスト上部のバージョンドロップダウンフィールドが Latest に設定されていることを確認してください。
  • Instances (active / all) – 現在アクティブな、このバージョンのプロセス定義のインスタンス数と、開始されたインスタンスの総数。
  • Created By – このバージョンのプロセス定義を作成したユーザー。
  • Created At – このバージョンのプロセス定義が作成(保存およびデプロイ)された日時。
  • Active – このバージョンのプロセス定義がアクティブ()で使用可能か、一時停止()されているか、またはサンプル(テンプレート)定義()であるため使用できないかを示します。設計者が使用できるように Altium Designer GUI の関連エリアに表示されるのは、アクティブなプロセス定義のみです。該当する場合は、アイコンをクリックしてアクティブ状態を切り替えてください。

    使用できる(アクティブ化して開始できる)のは、プロセス定義の最新バージョンのみです。以前のバージョンは使用できませんが、さらに新しいバージョンを作成するために変更することはできます。さらに、サンプルのプロセス定義(その Active 状態は で区別されます)は、初期状態のままでは使用できません。それぞれは一種の「テンプレート」に近いものであり、会社の要件に合わせて編集し、名前を付けて新しいプロセス定義として保存し、それを can してから、他のすべての定義とともに有効化して使用します。
  • Actions –   コントロールをクリックすると、プロセス定義に対する操作メニューにアクセスできます:
    • Start管理者として、このコマンドを選択することで、このバージョンのプロセス定義の新しいインスタンスを開始できます。これは、プロセス定義が有効化されている場合にのみ使用できます。プロセスが一時停止されているか、またはサンプル(テンプレート)定義である場合、このコマンドはグレー表示され、インスタンスを開始できません。
    • Edit – 選択すると、プロセス定義の基盤 Workflow を変更します。このバージョンのプロセス定義の Workflow 図が Process Workflow Editor に表示され、そこを起点として作業できます。元の作成者が誰であるかに関係なく、どの管理者でも任意のユーザー定義プロセス定義を変更し、次のバージョンとして保存およびデプロイできます。Altium が提供するデフォルトのプロセス定義については、これらのいずれかを編集して新しいプロセス定義を作成すること(本質的にはフォーク)はできますが、デフォルトそのものを変更することはできません。プロセス定義の編集の詳細については、既存のプロセス定義の編集 を参照してください。
    • Assign – 選択すると、Assign Access to This Workflow ウィンドウが開き、どのユーザーおよび/またはグループが基盤 Workflow にアクセスできるかを定義できます。Workflow へのアクセス管理の詳細については、プロセス Workflow アクセスの管理 を参照してください。
    • Remove – 選択すると、このバージョンのプロセス定義を削除します。なお、Altium が提供する一部のデフォルトプロセス定義は削除できません(したがって、そのようなコントロールはありません)。プロセス定義のインスタンスが少なくとも 1 つ開始されている場合、それがまだアクティブかどうかに関係なく、その定義は削除できません(メニューにこのコマンドは表示されません)。
コントロールを持つ任意の列でプロセス定義を並べ替えることができます。コントロールまたは列名をクリックしてください。検索は、リスト上部の Search フィールドを使用して行うこともできます。検索には Process Name : version 列および Created By 列のデータを使用できます。

プロセス定義のエントリをクリックすると、リスト下の Diagram タブにその図式化された Workflow が表示されます。現在アクティブなプロセスのインスタンスがある場合は、そのプロセスがフロー上のどこにあり、誰が次のタスクを実行してプロセスを前進させる必要があるかが表示されます。

プロセスの複数インスタンスがアクティブな場合、Diagram ビューには統合された状態が表示されます。右下の コントロールをクリックすると、Workflow 内で現在到達しているポイントが強調表示され、ユーザーエントリが一瞬点滅します。

選択したプロセスの基盤 Workflow を、その Diagram タブで表示しているところです。選択したプロセスの基盤 Workflow を、その Diagram タブで表示しているところです。

デフォルトのプロセス定義

Enterprise Server のインストールの一部として、Altium から多数のプロセス定義が 3 つのプロセステーマ全体にわたって提供されます。これらの一部は初期状態のままで使用できるよう有効化されており、そのまま使用できます。一方、その他はサンプルであり、直接有効化して使用することはできません。いずれも、必要に応じて独自のプロセス定義を作成する出発点として使用できます。提供されているプロセス定義に関する情報にアクセスするには、次の折りたたみ可能セクションを使用してください。

Enterprise Server のインストールには、Enterprise Server と対象の PLM インスタンス間でコンポーネントデータを同期する LibSync プロセスも含まれています。これは組み込みの読み取り専用プロセス Workflow であるため、編集できず、Workspace の Processes ページ(Admin » Processes)のプロセス一覧にも含まれません。詳細については、PLM コンポーネント同期 を参照してください。

新しいプロセス定義の追加

Related page: プロセス Workflow の定義

新しいプロセスは、専用の Process Workflow Editor を使用して作成できます。エディターにアクセスするには、まず新しいプロセスを作成したいテーマのタブをアクティブにし、その後ページ右上の ボタンをクリックします。

最初にテーマをアクティブにしておくことが重要です。そうすることで、プロセスが正しい Type で作成されます。

Process Workflow Editor へのアクセス。事前に目的のプロセステーマをアクティブにしておけば、新しいプロセス定義が正しいテーマタイプに設定されます。Process Workflow Editor へのアクセス。事前に目的のプロセステーマをアクティブにしておけば、新しいプロセス定義が正しいテーマタイプに設定されます。

新しいプロセス定義には意味のある名前を付け、その後 Workflow をグラフィカルに構築し、そのフロー内の各要素に必要な項目を定義します。ユーザータスクについては、関連する Workflow の時点でユーザーにタスクが割り当てられた際に入力を受け取るために表示されるフォームを作成するために、User Form Editor が使用されます。

強力な Process Workflow Editor により、必要に応じてシンプルにも複雑にもでき、会社の要件に沿った Workflow を備えたプロセスを構築する柔軟性が提供されます。強力な Process Workflow Editor により、必要に応じてシンプルにも複雑にもでき、会社の要件に沿った Workflow を備えたプロセスを構築する柔軟性が提供されます。

必要に応じてプロセスを定義したら、 ボタンをクリックして、そのプロセステーマで利用可能なプロセス一覧に追加します。新しいプロセス定義は、すぐに使用できるよう有効化されます。

エディターは、Workflow 図の保存およびデプロイを妨げている問題を通知します。たとえば、図には Start イベントと、少なくとも 1 つの End イベントが定義されている必要があります。また、User Task には少なくとも 1 つの Form フィールドと Assignee が必要です。

既存のプロセス定義の編集

元の作成者が誰であるかに関係なく、どの管理者でも任意のユーザー定義プロセス定義を変更し、次のバージョンとして保存およびデプロイできます。そのためには、  をクリックします。 変更したいプロセス定義の Actions 列にあるコントロールをクリックし、表示されるメニューから Edit を選択します。このバージョンのプロセス定義のワークフロー図が Process Workflow Editor に表示され、編集の開始点として使用できます。

Altium が提供するプロセス定義については、それらのいずれかを編集して新しいプロセス定義を作成すること(実質的にはフォークすること)はできますが、デフォルトの定義自体を変更することはできません。

既存のプロセス定義を編集する例 – 必要な変更を行うための Process Workflow Editor にアクセスします。既存のプロセス定義を編集する例 – 必要な変更を行うための Process Workflow Editor にアクセスします。

必要に応じてプロセスの図式ワークフローを変更し、ユーザータスクに関連付けられたフォームの変更も行ったら、 ボタンをクリックして、その定義を次のバージョンとして保存します。この例では、元のプロセス定義 Company Pre-release Review : 1(バージョン 1)を変更し、Company Pre-release Review : 2(バージョン 2)として保存しています。

変更を加えたら、保存してそのプロセス定義の次バージョンとしてデプロイします。変更を加えたら、保存してそのプロセス定義の次バージョンとしてデプロイします。

左上のドロップダウンフィールドを使用してエントリを All に設定すると、既存のプロセス定義のすべてのバージョンを確認できます。以下の画像では、Company Pre-release Review プロセス定義の両方のバージョンを確認できます。

サンプルのプロセス定義 Company Pre-release Review のすべてのバージョンを表示しています。アクティブ化して使用できるのは最新バージョン(バージョン 2)のみである点に注意してください。サンプルのプロセス定義 Company Pre-release Review のすべてのバージョンを表示しています。アクティブ化して使用できるのは最新バージョン(バージョン 2)のみである点に注意してください。

使用できる(アクティブ化して開始できる)のは、プロセス定義の最新バージョンのみです。ただし、以前のバージョンを後続バージョン作成の出発点として使用することはできます。プロセス定義の最新バージョンを削除すると、その 1 つ前のバージョンが実質的に最新となり、再びアクティブ化して使用(インスタンスの開始)できるようになります。

プロセス定義のインポート/エクスポート

プロセス定義はエクスポートおよびインポートが可能であり、Enterprise Server インスタンス間で素早く再利用できます。特に、プロセスの基盤となるワークフローが複雑な場合に大幅な時間短縮となり、いわば車輪の再発明を避けることができます。

インポートするには:

  1. インポートしたいプロセス定義に対応するテーマタブ(Part RequestsProject ActivitiesProject Creations)を開きます。

    誤ったテーマにプロセス定義をインポートしようとすると、ソフトウェアが警告を表示し、インポートは実行されません。
  2. ボタンをクリックして新しいプロセス定義を作成し、Process Workflow Editor にアクセスします。
  3. ボタンをクリックします。表示される Open ダイアログで、必要な Workflow ファイル(*.aaw)を参照して開きます。ファイルの内容により、そのプロセス定義に現在定義されている内容(名前、図など)はすべて完全に上書きされます。
インターフェースの Browser tab 内から、以前にエクスポートしたプロセス定義をファイルから直接インポートすることもできます。その場合は、 ボタンをクリックします。表示される Open ダイアログで、必要な Workflow ファイル(*.aaw)を参照して開きます。正しいプロセステーマが検出され、ファイルの内容が Process Workflow Editor に読み込まれます。

エクスポートするには:

  1. エクスポートしたいプロセス定義の必要なバージョンについて、Actions 列の  コントロールをクリックし、表示されるメニューから Edit を選択して編集モードに入ります。
  2. Process Workflow Editor ボタンをクリックします。プロセス定義は Workflow ファイル(<ProcessDefinitionName>.aaw)として、ブラウザに設定されているデフォルトのダウンロードフォルダにエクスポートされます。
  3. Workspace のブラウザインターフェースの左側ナビゲーションツリーで Processes エントリをクリックし、プロセス定義に変更を加えずに Process Workflow Editor を終了します。

プロセスワークフローへのアクセス管理

管理者は、どのユーザーおよび/またはグループがプロセスワークフローにアクセスできるかを定義できます。これを行うには、基盤となるワークフローへのアクセスを設定したいプロセス定義の Actions 列にある  コントロールをクリックし、表示されるメニューから Assign を選択します。Assign Access to This Workflow ウィンドウが開きます。

テキストフィールドにユーザーの氏名または username 全体、あるいはグループ名の入力を開始すると、一致するユーザー/グループの一覧がポップアップ表示されます。複数のユーザー/グループを追加できます。追加したユーザー/グループのワークフローへのアクセスを削除するには、名前のいちばん右にある削除用の × をクリックします。

必要に応じてユーザー/グループを定義したら、 をクリックしてワークフローの割り当てを適用します。これで、このワークフローは、以下の Designer Access to Process Workflows セクションで説明されている方法でアクセスした場合、追加されたユーザー/グループ(および Administrators グループのメンバー)のみに利用可能になります。

Assign Access to This Workflow ウィンドウに記載されているとおり、 user/group が追加されていない場合、そのワークフローはすべてのユーザーが利用できます。

プロセスワークフローへの Designer アクセス

Related pages: 設計レビューの実施PLM への公開プロセスベースの部品要求

利用可能な各プロセステーマに対して必要な一連のプロセス定義が会社の要件に合わせて作成されると、アクティブ化された定義は、Enterprise Server Workspace に接続した assigned users が使用できるようになります。以下の各セクションでは、設計者がこれらのアクティブなプロセスにどこからアクセスして開始できるかを、Altium Designer と Workspace のブラウザインターフェースの両方について説明します。

前述のとおり、Workspace の管理者は、Workspace のブラウザインターフェースの Processes エリア内にある対応するプロセステーマタブから、Actions 列の  コントロールをクリックし、表示されるメニューから Start を選択することで、アクティブ化された任意のプロセス定義の新しいインスタンスを直接開始できます。

部品要求

Related page: プロセスベースの部品要求

Altium Designer 内では、部品要求テーマに属するアクティブなプロセス定義には、次の場所からアクセスできます:

  • Components panel から。パネルのメイン領域内で右クリックすると、アクティブな部品要求プロセス定義が Operations » Submit Request サブメニューに表示されます。あるいは、Need more components? セクションの下にある Submit request リンクをクリックします。

部品要求プロセステーマに対してアクティブなプロセス定義が利用できない場合、Submit Request サブメニューは表示されません。更新のために、Workspace からサインアウトして再度サインインするか、Altium Designer を再起動する必要がある場合があります。
  • Manufacturer Part Search panel 内から。現在選択されている検索項目に アイコンがある場合、 をクリックして開く Information ペインに ボタンが表示されます。ボタンのドロップダウン部分をクリックすると、アクティブな部品要求プロセス定義のメニューにアクセスできます。ボタン本体を直接クリックすると、リスト内の最初のプロセス定義が起動します。
Manufacturer Part Search パネルから部品を要求すると、すべてのデータシートやパラメトリック情報を含む主要情報が自動入力されるという追加の利点があります。

部品要求プロセステーマに対してアクティブなプロセス定義が利用できない場合、 ボタンは表示されません。更新のために、Workspace からサインアウトして再度サインインするか、Altium Designer を再起動する必要がある場合があります。

現在選択されている検索項目に アイコンがある場合、アクティブな部品要求プロセス定義は ボタンに関連付けられたメニューから利用できます(ボタンのドロップダウン部分をクリックします)。

アクティブな部品要求プロセス定義は、パネルのメイン領域の右クリックメニューから Submit Request サブメニュー経由でもアクセスできます。

部品要求プロセステーマに対してアクティブなプロセス定義が利用できない場合、Submit Request サブメニューは表示されません。更新のために、Workspace からサインアウトして再度サインインするか、Altium Designer を再起動する必要がある場合があります。
  • Explorer panelPart requests フォルダ、または検索実行後から。 ボタンが利用可能になり、押すと選択可能なアクティブな部品要求プロセス定義が表示されます。

Legacy Part Requests feature が有効になっている場合、ボタンは として表示される点に注意してください。また、そのレガシー機能を使用した新しい部品要求に関する追加エントリもメニューに表示されます。これには (Legacy) という接尾辞が付きます。部品要求プロセステーマに対してアクティブなプロセス定義が利用できず、かつ Legacy Part Requests feature が有効でない場合、Submit Request ボタンは表示されません。更新のために、Workspace からサインアウトして再度サインインするか、Altium Designer を再起動する必要がある場合があります。

Workspace のブラウザインターフェースからは、部品要求テーマに属するアクティブなプロセス定義に Part Requests ページからアクセスできます。ページ右上の ボタンをクリックします。

Workspace のブラウザインターフェースの Part Requests ページから、アクティブな Part Requests 定義にアクセスしています。Workspace のブラウザインターフェースの Part Requests ページから、アクティブな Part Requests 定義にアクセスしています。

部品要求プロセステーマに対してアクティブなプロセス定義が利用できない場合、 ボタンは使用できません。プロセス定義が 1 つしか存在しない場合、ボタンにドロップダウン機能は表示されず、クリックするとただちにそのプロセスが開始されます。

プロジェクトアクティビティ

Related pages: 設計レビューの実施PLM への公開PLM Integration

Project Activities テーマに属するアクティブなプロセス定義には、さまざまな場所からアクセスできます。

設計レビューおよび標準 PLM 公開

Altium Designer 内では、Project Activities テーマに属するアクティブな設計レビューおよび公開プロセス定義に、Projects panel 内の設計プロジェクトのエントリを右クリックしてアクセスする Project Activities コンテキストサブメニュー、またはメインの Project » Project Activities メニューからアクセスできます。

Project Activities プロセステーマに対してアクティブな設計レビューおよび標準 PLM 公開プロセス定義が利用できない場合、それらのメニューは表示されません。

Workspace のブラウザインターフェースからは、Project Activities テーマに属するアクティブな設計レビューおよび公開プロセス定義に、インターフェースの Projects page からアクセスできます。必要なプロジェクトを選択してから、 ボタンをクリックします。

Workspace のブラウザインターフェースの Projects エリア内で、Workspace プロジェクトに対するアクティブな Project Activities 定義(設計レビューおよび標準 PLM 公開)にアクセスしています。Workspace のブラウザインターフェースの Projects エリア内で、Workspace プロジェクトに対するアクティブな Project Activities 定義(設計レビューおよび標準 PLM 公開)にアクセスしています。

Project Activities プロセステーマに対してアクティブな設計レビューおよび標準 PLM 公開プロセス定義が利用できない場合、 ボタンは表示されません。

Project Releaser による PLM 公開

Altium Designer 内では、Project Releaser の一部として PLM インスタンスへ公開するプロセスに、アクティブなプロジェクトの Project » Project Releaser サブメニュー、または Projects panel 内の設計プロジェクトのエントリを右クリックして表示される Project Releaser コンテキストメニュー項目からアクセスできます。

プロジェクト作成

Altium Designer 内では、Project Creations テーマに属するアクティブなプロセス定義に、次の 3 か所からアクセスできます:

  • メインの File » New » Project in <WorkspaceName> サブメニューから。

  • Projects パネル内のローカルプロジェクトのエントリを右クリックしてアクセスする Convert to Managed Project コンテキストサブメニューから。

  • Workspace の場所を選択した状態で、Open Project dialog 内のプロジェクトのエントリを右クリックしてアクセスする Clone コンテキストサブメニューから。

Project Creations プロセステーマに対して少なくとも 1 つのプロセス定義がアクティブな場合、Create Project dialogFile » New » Project)による新しい Workspace プロジェクト作成機能は無効になる点に注意してください。接続された Workspace はターゲット保存先として利用できません。 Regular(ローカル)および VCS タイプのプロジェクトは、このダイアログから通常どおり作成できます。

Project Creations プロセステーマに対してアクティブなプロセス定義が利用できない場合(これは Enterprise Server の新規インストール時のデフォルト状態です)、プロセスメニューは表示されず、Create Project ダイアログから通常どおり Workspace プロジェクトを作成できます。

また、このデフォルト構成では Convert to Managed Project コマンドが Make Project Available on Server に変わる点にも注意してください。

Workspace のブラウザインターフェースからは、Project Creations テーマに属するアクティブなプロセス定義に次の場所からアクセスできます:

  • インターフェースのメイン Projects ページで、 ボタンをクリックします。

Workspace のブラウザインターフェースのメイン Projects エリアから、アクティブな Project Creations 定義にアクセスしています。Workspace のブラウザインターフェースのメイン Projects エリアから、アクティブな Project Creations 定義にアクセスしています。

  • 特定のプロジェクトをクローンしたい場合は、インターフェースの Projects page からアクセスします。必要なプロジェクトを選択してから、 ボタンをクリックすると、メニュー上のプロセスにアクセスできます。

Workspace のブラウザインターフェースの Projects エリア内で、Workspace プロジェクトをクローンしたい場合にアクティブな Project Creations 定義へアクセスしています。Workspace のブラウザインターフェースの Projects エリア内で、Workspace プロジェクトをクローンしたい場合にアクティブな Project Creations 定義へアクセスしています。

  • Project Creations プロセステーマに対してアクティブなプロセス定義が利用できない場合(これは Enterprise Server の新規インストール時のデフォルト状態です)、メニューには基本的なプロジェクトクローン機能(Clone)が表示されます。これはプロセスワークフロー機能とは無関係です。
  • プロセスベースの Workspace PCB プロジェクトの設計制約管理に Constraint Manager を使用するには、そのプロジェクトの作成時に適切なプロジェクトテンプレートを割り当ててください。これは、Create Project dialogConstraint Management オプションを有効にして作成した PCB プロジェクトから保存されたテンプレートである必要があります。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Content