環境の要素
Altium Essentials: Design Environment
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- 環境設定、アカウント管理、Workspaceへの接続、インストール管理の各オプションにアクセスする方法を学びます。
- PropertiesパネルやMessagesパネルなどのパネルが、設計の編集や確認にどのように役立つかを理解します。
- Active Bar、メインメニュー、Quick Access Bar、Status Barから、よく使うコマンドを見つけます。
Altium Designerは、回路の入力から製造出力の生成まで、電子設計のあらゆる側面をサポートできる独自のソフトウェアです。基盤となるX2統合プラットフォームにより、これらすべてを単一のソフトウェアアプリケーションで実現します。このプラットフォームは、メニューやツールバー(リソースとも呼ばれます)などの標準的なユーザーインターフェース要素をすべてサポートし、各エディターが固有のリソースとコマンドを組み込めるようになっています。Altium Designerの環境を構成する各要素の説明やアクセス方法などについては、以下のセクションを参照してください。
以下のセクションでは、上の画像で強調表示されている設計スペースの主な要素について説明します。
プリファレンス
プリファレンスダイアログでは、ソフトウェアのさまざまな機能領域にわたるシステム全体の設定を一元的に行えます。これらのプリファレンスは、プロジェクトおよび関連するドキュメント全体に適用されます。各種ダイアログには、設計スペースの右上にある
をクリックしてアクセスします。ダイアログの左側にある
を使用して必要な領域の選択肢を展開し、目的のタイトルを選択すると、該当するプリファレンスページが開きます。
アクティブなワークスペースコントロール
アイコンの右側にあるアクティブなワークスペースコントロールを使用すると、利用可能なワークスペースに接続できます。Altiumアカウントへのサインイン状態とワークスペースへの接続状態に応じて、このコントロールは次のように表示されます。
-
– 現在、利用可能なワークスペースに接続しています。テキストには、接続先のワークスペース名が表示されます。
-
– 現在、ワークスペースに接続していません。コントロールをクリックして利用可能なワークスペースに接続するか、現在のユーザーコントロールのメニューからCustom connectionを選択してEnterprise Serverワークスペースに接続します。
-
– 現在、ワークスペースに接続しておらず、Altiumアカウントにもサインインしていません。現在のユーザーコントロールのメニューからSign inを選択してAltiumアカウントにサインインするか、メニューからCustom connectionを選択してEnterprise Serverワークスペースに接続します。
詳細については、ワークスペースへのアクセスを参照してください。
現在のユーザーコントロール
現在のユーザーコントロールは設計スペースの右上にあり、Altiumアカウントへのサインイン状態を示します。また、Altium Designerのインストール環境に関する各種設定を行うメニューにもアクセスできます。
サインイン
Altiumアカウントにサインインしていない場合、現在のユーザーコントロールは
と表示されます。Altiumアカウントにサインインするには、このコントロールをクリックし、表示されるメニューの
項目をクリックします。
詳細については、Altiumアカウントへのサインインを参照してください。
ライセンス(Altium Designer Agile、Altium Designer)
ライセンスシステムにより、設計ソフトウェアを迅速かつ効率的に使い始めることができます。License Management ビューにアクセスするには、現在のユーザーコントロールをクリックし、ドロップダウンメニューからLicenses を選択します。
ライセンスに関する詳細については、Altium Designer Agileのライセンス管理およびAltium Designerのライセンス管理を参照してください。
拡張機能(Altium Designer Develop)
拡張機能は、ソフトウェアに追加の機能を提供するアドオンです。新しいインポーターやエクスポーター、回路図シンボル生成ツール、機械系CADとのコラボレーションのサポートなど、追加機能をインストールまたは削除できます。
Extensions ビューにアクセスするには、現在のユーザーコントロールをクリックし、ドロップダウンメニューからExtensions を選択します。
詳細については、Altium Designer Developのインストールと管理およびAltium Designer Developのインストール環境の拡張を参照してください。
拡張機能と更新(Altium Designer Agile、Altium Designer)
拡張機能は、ソフトウェアに追加の機能を提供するアドオンです。新しいインポーターやエクスポーター、回路図シンボル生成ツール、機械系CADとのコラボレーションのサポートなど、追加機能をインストール、更新、または削除できます。Extensions and Updates ビューにアクセスするには、現在のユーザーコントロールをクリックし、ドロップダウンメニューからExtensions and Updates を選択します。
詳細については、Altium Designer Agileのインストール環境の拡張およびAltium Designerのインストール環境の拡張を参照してください。
ソフトウェアを更新すると、コアプラットフォームとインストール済みの拡張機能が最新リリースになります。Updatesにアクセスするには、現在のユーザーコントロールをクリックし、ドロップダウンメニューからExtensions and Updates を選択します。Extensions and Updates ビューで、下の画像に示すようにUpdatesタブを選択します。
![]()
(n) には、利用可能な更新の総数が表示されます。(n)がない場合、更新はありません。
Updatesページには、利用可能なコアプラットフォームの更新と、更新が利用可能なSystem ExtensionsおよびSoftware Extensionsの一覧が表示されます。
詳細については、Altium Designer Agileのインストールと管理およびAltium Designerのインストールと管理を参照してください。
カスタム接続(Altium Designer Agile、Altium Designer)
現在のユーザーコントロールのメニューにあるCustom connection項目を使用すると、設計ソフトウェア内からEnterprise Serverワークスペースに接続できます。この項目を選択すると、接続先のワークスペースに接続するためのSign inダイアログが表示されます。ワークスペースのURLとアクセス認証情報を入力し、Sign inボタンをクリックします。
詳細については、ワークスペースへのアクセスのEnterprise Serverワークスペースへの接続セクションを参照してください。
パネル
パネルは、Altium Designer環境に欠かせない要素です。特定のドキュメントエディター専用のものでも、システム全体で使用するものでも、生産性の向上に役立つ情報やコントロールを提供し、効率的な設計を可能にします。たとえば、PCB パネルでは、コンポーネント別またはネット別に参照できます。Altium Designerを初めて起動すると、プロジェクトパネルがすでに開かれており、設計スペースの左側に固定/ドッキングされています。ほかのパネルを開くには、設計スペースの右下にあるPanels ボタンをクリックし、目的のパネルを選択します。各エディターには、そのエディター専用のパネルがあります。

左の画像:PCBのパネル、右の画像:回路図のパネル
Altium Designerのほぼすべてのエディターで広く使用される、特に重要な2つのパネルが、PropertiesパネルとMessagesパネルです。
プロパティパネル
インタラクティブな Properties パネルでは、各設計エディターで扱うドキュメントやオブジェクトのプロパティを一元的に編集できます。このパネルは、現在選択されているドキュメントやオブジェクトに基づいて表示内容を動的に決定(つまり、モードを変更)し、そのドキュメントやオブジェクトに関連するプロパティや設定を表示します。Propertiesパネルでは、選択した複数のオブジェクトのプロパティを編集することもできます。

ComponentsモードのPropertiesパネル。このモードは、回路図シート上でコンポーネントを選択すると有効になります。
メッセージパネル
プロジェクトの検証、アクティブなPCBドキュメントのデザインルールチェック、ミックスドシグナルシミュレーションの実行など、ソフトウェアのメッセージ対応機能を使用する際、Messages パネルには、発生している警告やエラー、各種ステータス情報がわかりやすく一覧表示されます。このパネルは、選択したメッセージから、関連するドキュメント内の原因となったオブジェクトへのクロスプローブに対応しています。
アクティブバー
各エディターでよく使用するツールは、設計スペースの上部に表示されるActive Barから利用できます。アイコンにカーソルを合わせると、その説明がポップアップ表示されます。表示されているアイコンを使用するには、アイコンをクリックします。

上の画像:PCBのActive Bar、下の画像:回路図のActive Bar。
Active Barのボタンには、単機能のものと多機能のものがあります。多機能ボタンは、右下隅の小さな白い三角形で示されます。多機能ボタンの任意の場所を1秒間長押しするか、右クリックすると、使用可能なその他のコマンドを一覧表示するメニューが開きます。最後に使用したコマンドが、そのボタン位置のデフォルトになります。
メインメニュー
メインメニューからは、アクティブなドキュメントのコマンドや機能にアクセスできます。メニューは各エディターの左上に並んで表示され、エディターごとに固有のメニューが用意されています。
PCB(上の画像)とSCH(下の画像)のメインメニュー
コマンドを使用するには、メニュー名(例:Design)をクリックし、ドロップダウンメニューから目的のコマンドを選択します。
クイックアクセスバー
Quick Access Bar は設計スペースの左上にあり、よく使用する機能をすばやく実行できます。
-
- Altium Designerを終了して閉じます。
-
- 現在アクティブなドキュメントを保存します。
-
- 変更が加えられたすべてのドキュメントを保存します。
-
- プロジェクトを開くダイアログにアクセスし、開くプロジェクトを選択します。
-
- 直前の操作を元に戻します。このアイコンは、操作が行われた場合にのみ使用できます。
-
- 元に戻した操作をやり直します。このアイコンは、元に戻す操作が行われた場合にのみ使用できます。
ステータスバー
Status Barには、カーソルの座標位置、コマンドのプロンプト、ショートカットキー情報などの概要情報が表示されます。また、ステータスバーの右側にあるPanels ボタンから各種パネルにアクセスできます。メインメニューからView » Status Bar を選択すると、Status Bar の表示/非表示を切り替えられます。
コマンドステータスバー
Command Status Bar には、現在使用中のコマンドに関する情報が表示されます。コマンドを使用していない場合は、その状態が Idle state - ready for command というステータスでバーに表示されます。メインメニューから View » Command Status コマンドを選択すると、Command Status Bar の表示/非表示を切り替えられます。
![]()
PCBエディターのインタラクティブルーティングコマンドを使用中のCommand Status Bar。
Windowsシステムリソースモニター
リソースの使用量が高いとみなされるレベルに達すると、Altium Designerの右下にリソース警告インジケーターが表示されます。インジケーターにカーソルを合わせると、どのリソースが使用量の基準値を超えているかを確認できます。なお、インジケーターの色はリソースの使用レベルに応じて変化します。
Altium Designerのリソース使用量が高くなると警告インジケーターが表示され、対処が必要になると色が変わります。
以下のリソースが監視されます。
- Altium Designerが使用するメモリ
- 割り当てられたGDIハンドルの数
- 割り当てられたグローバルアトムとセッションアトムの割合
上記のいずれかのリソースが次のレベルに達すると、リソースモニターが作動し、警告インジケーターを表示します。
- < 60%:通常レベル(リソースインジケーターは表示されません)
- 61%~75%:高いレベルと見なされ、黄色のインジケーターで示されます
- 76%~90%:非常に高いレベルと見なされ、オレンジ色のインジケーターで示されます。また、Altium Designerの再起動を推奨するメッセージが表示されます。
- > 90%:危険なレベルと見なされ、赤色のインジケーターで示されます。また、Altium Designerの再起動を推奨するメッセージが表示されます。
ホームページ
Altium Designerの Home Page は、Altium Designer内でタブとして開くことができる独立したWebページです。このページからは、新機能、ウェビナー、動画、ブログ、チュートリアルなど、ユーザー向けのコンテンツにアクセスできます。ページの情報は継続的に更新され、Altium Designerの機能に関する最新情報を把握できるよう、動画も追加されます。
アプリケーションの起動時にHome Page が開きます。Home Page タブを閉じるには、タブを右クリックしてClose Home Pageを選択します。タブを閉じた後にHome Page にアクセスするには、設計スペースの右上隅にある
アイコンをクリックします。



