コンポーネントの配置
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- パッドやシルクスクリーンの要素から、必要に応じて追加する3Dボディまで、PCB部品のフットプリントに含まれる要素を理解できます。
- Altium Designerの部品プロパティのうち、配置、向き、レイヤーの割り当て、識別に関わるものを学べます。
- PCBエディター内で、さまざまな部品タイプや領域の定義がどのように扱われるかを確認できます。
PCB設計は配置が90%、配線が10%と言われています。それぞれの割合には議論の余地がありますが、優れた基板設計には適切な部品配置が不可欠であることは広く認められています。また、配線を進める中で配置の調整が必要になる場合もあることを覚えておいてください。
部品フットプリントは、実際の部品をプリント基板に実装するために必要なスペースと接続点を定義します。パッド、ライン、円弧などの単純なプリミティブオブジェクトや、その他の設計オブジェクトで構成されるグループオブジェクトです。

部品フットプリントは、PCB上での部品の実装と接続を定義します。 また、実際の部品を定義する3Dボディオブジェクトを含めることもできます。
パッドは、部品のピンを実装して接続するためのポイントとなります。部品オーバーレイ(シルクスクリーン)レイヤー上で部品形状の外形を定義するために、ラインや円弧などの設計プリミティブを追加することもよくあります。
部品フットプリントには、オプションで3Dボディオブジェクトを含めることもできます。これは、基板に実装される実際の部品が占める物理的な空間や外形を定義します。実際の部品が3DボディオブジェクトまたはインポートしたSTEPモデルで定義されている場合は、3次元での部品クリアランスチェックを実行できます。
部品フットプリントは、PCBフットプリントエディターで適切な設計オブジェクトを配置し、部品の実装と接続に必要な形状を作成することで作成します。部品の基準点はPCBフットプリントエディターの設計スペースの原点です。エディターでは、この基準点をピン1、幾何学的中心、または部品上の任意の位置に設定できます。フットプリントの作成について詳しくは、 PCBフットプリントの作成 ページを参照してください。
部品のプロパティ
一般タブ
位置
-
(X/Y)
-
X (1番目のフィールド)– 現在の設計スペースの原点を基準とした、部品の基準点の現在のX(水平)座標です。編集すると、部品のX位置を変更できます。値はメートル単位系またはヤード・ポンド単位系のいずれでも入力できます。現在のデフォルトとは異なる単位の値を入力する場合は、単位も指定してください。部品フットプリントの基準点は、ライブラリエディターで設定します。
-
Y (2番目のフィールド)– 現在の原点を基準とした、部品の基準点の現在のY(垂直)座標です。編集すると、部品のY位置を変更できます。値はメートル単位系またはヤード・ポンド単位系のいずれでも入力できます。現在のデフォルトとは異なる単位の値を入力する場合は、単位も指定してください。部品フットプリントの基準点は、ライブラリエディターで設定します。
-
-
Rotation – ゼロ(3 o'clock 水平方向)から反時計回りに測定した部品の回転角度(度単位)です。編集すると、部品の回転角度を変更できます。最小角度分解能は0.001°です。
プロパティ
-
Layer – 部品を配置するレイヤーを設定します。部品はTopレイヤーまたはBottomレイヤーに割り当てることができます。ドロップダウンから別のレイヤーを選択してください。レイヤーを変更すると、部品を構成するすべてのプリミティブが、それぞれ対応する反対側のレイヤーに切り替わります。たとえば、Topレイヤーの部品をBottomレイヤーに移動すると、単一レイヤーのパッドはTopからBottomに切り替わり、Top Overlay上のプリミティブはBottom Overlayに再割り当てされ、ペアのメカニカルレイヤー上のプリミティブは、そのペアのもう一方のメカニカルレイヤーに切り替わります。部品の向きはX軸を中心に反転し、部品オーバーレイのテキストは基板の下面から読める向きになります。
-
Reuse Block – 部品が再利用ブロックの一部である場合、このフィールドには親の再利用ブロック名が表示されます。 Reuse Blockハイパーリンクをクリックすると、この再利用ブロックのプロパティを確認できます。
-
Designator – 部品のデジグネーターは、最大255文字の英数字文字列です。各部品には一意のデジグネーター文字列が必要です。
または
を切り替えて、デジグネーターの表示/非表示を設定します。Designatorハイパーリンクをクリックすると、部品のデジグネーターのプロパティが開きます。
-
Comment – 部品のコメントは、最大255文字の英数字文字列です。
または
を切り替えて、コメントの表示/非表示を設定します。Commentハイパーリンクをクリックすると、部品のコメントのプロパティが開きます。
-
Area – 配置された部品の面積が、現在の基板の単位で表示されます。面積はユーザーが定義できます。定義されていない場合は、部品の選択領域から自動的に計算されます。
-
部品の面積を定義するには、PCBフットプリントエディターで、フットプリントのPropertiesパネルにあるAreaを編集します。更新したフットプリントを開いているPCBに反映するには、PCB Libraryパネルでフットプリント名を右クリックし、コンテキストメニューからUpdate PCB With <ComponentName> を選択します。
-
PCB上に配置済みの部品の面積をユーザー定義することもできます。部品を選択し、このフィールドに値を入力してください。
-
PCB上に配置された部品の面積をユーザー定義値から計算値に切り替えるには、このフィールドの値を削除します。フィールドには、自動計算された値が再入力されます。
-
自動計算される面積は、クリックして部品を選択したときにハイライト表示される領域の面積です。選択領域はCourtyardレイヤー上の図形から決定されます。このレイヤーが存在しない場合は、シルクスクリーン、3Dボディオブジェクト、および銅箔レイヤー上の図形を組み合わせて決定されます(文字列は除外されます)。以下の上側の画像は、Courtyardレイヤー上に外形が定義されている場合の部品の面積を示しています。下側の画像は、シルクスクリーン、3Dボディオブジェクト、および銅箔レイヤー上の図形から計算された面積を示しています。
► 選択領域の計算方法と、選択領域を決定するために使用できるその他のモードについて詳しくはこちらをご覧ください。
► メカニカルレイヤーの操作について詳しくはこちらをご覧ください。
-
-
Description – この部品の部品レベルの説明です。通常、説明は部品の作成時に定義しますが、回路図上の部品で編集または追加することもできます。これは、Componentsパネルに表示される説明です。
-
Type – ここで、部品フットプリントに対して以下の部品タイプのいずれかを選択します。使用可能なタイプは次のとおりです。
-
Standard– これらの部品は標準的な電気的特性を持ち、回路図とPCBの間で常に同期され(フットプリント、ピン/パッド、およびネットの割り当てがすべて一致している必要があります)、BOMに含まれます。抵抗などの標準的な電気部品が例として挙げられます。 -
Mechanical– これらの部品は電気的特性を持たず、同期されません(両方のエディターで手動で配置する必要があります)。BOMには含まれます。ヒートシンクが例として挙げられます。 -
Graphical– これらの部品は電気的特性を持たず、同期されません(両方のエディターで手動で配置する必要があります)。また、BOMには not 含まれません。会社のロゴが例として挙げられます。 -
Net Tie (in BOM)– これらの部品は、2つ以上の異なるネットを短絡するために使用します。回路図とPCBの間で常に同期され(フットプリント、ピン/パッド、およびネットの割り当てがすべて一致している必要があります)、BOMに含まれます。Standard部品とは異なり、フットプリント内の銅箔によって形成される接続はチェックされません。この銅箔によってネットを短絡できます。注:部品内に未接続の銅箔がないことを確認するには、Design Rule Checkerダイアログで Verify Shorting Copper オプションを有効にします。 -
Net Tie– これらの部品は、2つ以上の異なるネットを短絡するために使用します。回路図とPCBの間で常に同期され(フットプリント、ピン/パッド、およびネットの割り当てがすべて一致している必要があります)、BOMには not 含まれません。Standard部品とは異なり、フットプリント内の銅箔によって形成される接続はチェックされません。この銅箔によってネットを短絡できます。注:部品内に未接続の銅箔がないことを確認するには、Design Rule Checkerダイアログで Verify Shorting Copper オプションを有効にします。 -
Standard (No BOM)– これらの部品は標準的な電気的特性を持ち、回路図とPCBの間で常に同期されます(フットプリント、ピン/パッド、およびネットの割り当てがすべて一致している必要があります)。また、BOMには not 含まれません。BOMから除外したいテストポイント部品が例として挙げられます。 -
Jumper– これらの部品は、たとえば1つのレイヤーだけではすべての配線を完了できない片面PCBなど、PCB設計にジャンパー線を含めるために使用します。この部品タイプでは、部品のフットプリントとピンは回路図とPCBの間で同期されますが、ネットの割り当ては同期されません。また、部品はBOMに含まれます。部品レベルでこのオプションを選択するだけでなく、部品内の両方のパッドのJumperIDに、同じゼロ以外の値を設定する必要があります。Jumperタイプの部品は回路図上で配線する必要はありません。BOMに必要な場合にのみ、回路図に含める必要があります。BOMに不要な場合は、PCBに直接配置し、Component Type と JumperIDs を設定して、パッドの Nets を手動で割り当てることができます。
-
-
Design Item ID – 選択した部品のDesign Item IDを表示します。このフィールドは編集できません。
-
Source – 部品のソースドキュメントを表示します。
をクリックすると、別のソースドキュメントを参照して選択するためのダイアログが開きます。
-
Revision State – Workspaceライブラリ部品のリビジョンについて、ライフサイクルの状態とリビジョンのステータスを表示します。つまり、その部品のリリース済み最新リビジョン(
Up to date)か、以前のリビジョン(Out of date)かを示します。 -
Height – 部品の高さのフィールドです。このフィールドは、3Dボディオブジェクトが導入される前にPCB部品の高さを定義するために使用されていましたが、3D干渉チェックなどの作業では、3Dモデルを使用する方が部品の高さをより適切に定義できます。Altium MCAD CoDesignerでは、3Dモデルの高さではなく、このHeightフィールドで定義した値が使用されることに注意してください(詳細はこちら)。
-
3D Body Opacity – 希望する不透明度をパーセントで入力するか、スライダーバーを使用します。
-
Primitives – 対応するロックアイコンをクリックして、ロック/ロック解除を切り替えます。
– コンポーネントのすべてのプリミティブをロックし、単一のオブジェクトとして扱えるようにします。
– ロックを解除し、コンポーネントを構成する個々のプリミティブを変更できるようにします。編集後は、コンポーネントのプリミティブを再度ロックしてください。
-
Strings – 対応するロックアイコンをクリックして、ロックとロック解除を切り替えます。
– コンポーネントのすべての文字列をロックします。
– ロックを解除し、コンポーネントの文字列を変更できるようにします。
フットプリント
- Footprint Name – 選択したコンポーネントに対応するフットプリントの名前を表示します。
- Design Item ID – 選択したコンポーネントの識別情報です。
- Source – 選択したコンポーネントが配置されているWorkspaceの名前です。
- Description – PCBフットプリントエディターで定義された、コンポーネントのフットプリントの説明です。
スワップオプション
- Enable Pin Swapping – チェックを入れると、ピンスワップ機能が有効になります。
- Enable Part Swapping – チェックを入れると、パーツスワップ機能(74シリーズICの4つのパーツなど)が有効になります。
回路図の参照情報
- Designator – このPCBコンポーネントに対応付けられている回路図コンポーネントのデジグネーターです。
- Hierarchical Path – 回路図の階層構造内で、このコンポーネントがどこにあるかを表示します。
- Channel Offset – 設計を回路図からPCBに初めて転送するとき、各回路図シートの各コンポーネントに一意のチャネルオフセットが割り当てられます。
パラメータータブ
- Table – 一覧にある各パラメーターのName、Value、Sourceを表示します。
コンポーネントのデジグネーターとコメント
デジグネーターとコメントのフィールドは、PCBコンポーネント(パーツ)の子パラメーターオブジェクトです。デジグネーターは、配置された各パーツを一意に識別し、プロジェクト内のすべてのPCBドキュメントに配置された他のすべてのパーツと区別するために使用します。コメントは、配置されたオブジェクトに追加情報を付加するために使用します。コメントとデジグネーターはどちらも、親となるコンポーネントのパーツオブジェクトを配置した後に設定します。直接配置できる設計オブジェクトではありません。

配置されたデジグネーターオブジェクト
最初のコンポーネントのデジグネーターが数字で終わっている場合、PCBの2D/3Dコンポーネントのデジグネーターは、配置中に自動的に1ずつ増加します。配置する前に、Propertiesパネルで最初のコンポーネントのデジグネーターを変更してください。
デジグネーターの英字または数字を1以外の増分で増加させるには、Paste Array機能を使用します。この機能のコントロールは、貼り付け配列の設定ダイアログにあります。このダイアログは、Paste Specialダイアログ(Edit » Paste Special)の Paste Arrayボタンを押すと開きます。
グラフィカルな編集方法では、配置されたデジグネーターまたはコメントのオブジェクトをデザインスペースで直接選択し、位置、回転、向き、サイズを変更できます。
デジグネーターまたはコメントのオブジェクトを選択すると、次の編集ハンドルが使用できます。

選択されたデジグネーター
- Bをクリックしてドラッグすると、基準点A(小さなxで示されます)を中心にデジグネーター/コメントを回転できます。
- Cをクリックしてドラッグすると、デジグネーター/コメントの境界ボックスのサイズを縦方向と横方向に同時に変更できます。
- Dをクリックしてドラッグすると、デジグネーター/コメントの境界ボックスのサイズを縦方向と横方向で個別に変更できます。
-
デジグネーター/コメントの編集ハンドル以外の場所をクリックしてドラッグすると、位置を変更できます。ドラッグ中は、コメントを回転または反転できます。
- Spacebarを押すとデジグネーター/コメントが反時計回りに回転し、Shift+Spacebarを押すと時計回りに回転します。回転は、PreferencesダイアログのPCB Editor – Generalページで定義されたRotation Step の値に従います。
- XキーまたはYキーを押すと、デジグネーター/コメントをX軸またはY軸に沿って反転できます。
デジグネーターまたはコメントのオブジェクトのプロパティは、PropertiesパネルのParameterモードで変更できます。
パラメーターのプロパティ

PropertiesパネルのParameterモード。
位置
-
(X/Y)
-
X (最初のフィールド) - 現在のワークスペース原点を基準とした、デジグネーターの基準点の現在のX(水平)座標です。編集すると、デジグネーターのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も含めてください。
-
Y (2番目のフィールド) - 現在の原点を基準とした、デジグネーターの基準点の現在のY(垂直)座標です。編集すると、デジグネーターのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も含めてください。
-
- Rotation - ゼロ(3 o'clock の水平位置)から反時計回りに測定した、デジグネーターの回転角度(度)です。編集すると、デジグネーターの回転角度を変更できます。最小角度分解能は0.001°です。
プロパティ
-
Parameter type - パラメーターの種類(コンポーネント、シートシンボルなど)とパラメーター名を表示します。
-
Name - デジグネーターの名前です。
-
Value - このフィールドに、デジグネーターの値を入力します。目のアイコンをクリックすると、デザインスペースでの値の表示/非表示を切り替えられます。
-
Layer - ドロップダウンから目的のレイヤーを選択します。必要に応じて Mirror を有効にします。
-
Autoposition - ドロップダウンから、関連付けられたオブジェクトに対する自動配置位置を選択します。
-
Text Height - このフィールドに、目的のテキストの高さを入力します。
-
Font Type
-
TrueType - PC上(\Windows\Fonts フォルダー内)で使用できるフォントを使用する場合に選択します。TrueTypeフォントはUnicodeを完全にサポートしています。 デフォルトでは、ソフトウェアは使用するTrueTypeフォントにリンクします(フォントはPCBファイルには保存されません)。そのため、設計の移動先となる各PCに同じフォントが必要です。または、Preferences ダイアログの PCB Editor - True Type Fonts ページにあるオプションを使用して、使用するTrueTypeフォントをPCBファイルに埋め込むこともできます。このページでは、埋め込まれていないフォントが使用できない場合に使用する Substitution Font も選択できます。
-
Justification - 枠の長方形内でのデジグネータの位置を設定します。
- Left - 左のボタンをクリックして、テキストを水平方向の左揃えにします。
- Center - 中央のボタンをクリックして、テキストを水平方向の中央揃えにします。
- Right - 左のボタンをクリックして、テキストを水平方向の右揃えにします。
- Above - 上のボタンをクリックして、テキストを垂直方向の上揃えにします。
- Middle - 中央のボタンをクリックして、テキストを垂直方向の中央揃えにします。
- Below - 下のボタンをクリックして、テキストを垂直方向の下揃えにします。
-
Font - ドロップダウンから目的のTrueTypeフォントを選択します。必要に応じて B (bold) や I (italic) オプションを使用して、テキストを強調します。
-
Inverted - を使用してテキストを反転表示し、テキストの周囲の枠のサイズを調整します。次のオプションを使用して、テキストをさらに設定できます。
-
Size (Width/Height) -
- Width - 枠の長方形の幅です。
- Height - 枠の長方形の高さです。
-
Size (Width/Height) -
-
Inverted - を使用してテキストを反転表示し、テキストの周囲の枠のサイズを調整します。次のオプションを使用して、テキストをさらに設定できます。
-
-
Stroke
-
Justification - 枠の長方形内でのデジグネータの位置を設定します。
- Left - 左のボタンをクリックして、テキストを水平方向の左揃えにします。
- Center - 中央のボタンをクリックして、テキストを水平方向の中央揃えにします。
- Right - 左のボタンをクリックして、テキストを水平方向の右揃えにします。
- Above - 上のボタンをクリックして、テキストを垂直方向の上揃えにします。
- Middle - 中央のボタンをクリックして、テキストを垂直方向の中央揃えにします。
- Below - 下のボタンをクリックして、テキストを垂直方向の下揃えにします。
-
Font - ドロップダウンから目的のストロークフォントを選択します。選択肢は次のとおりです。
-
Default- ペンプロッターおよびベクターフォトプロッター用に設計された、シンプルなベクターフォントです。 -
Sans Serif- 複雑なフォントで、Gerberなどのベクター出力の生成に時間がかかります。 -
Serif- 複雑なフォントで、Gerberなどのベクター出力の生成に時間がかかります。
-
- Stroke Width - ストロークの幅を表示します。
-
Justification - 枠の長方形内でのデジグネータの位置を設定します。
-
TrueType - PC上(\Windows\Fonts フォルダー内)で使用できるフォントを使用する場合に選択します。TrueTypeフォントはUnicodeを完全にサポートしています。 デフォルトでは、ソフトウェアは使用するTrueTypeフォントにリンクします(フォントはPCBファイルには保存されません)。そのため、設計の移動先となる各PCに同じフォントが必要です。または、Preferences ダイアログの PCB Editor - True Type Fonts ページにあるオプションを使用して、使用するTrueTypeフォントをPCBファイルに埋め込むこともできます。このページでは、埋め込まれていないフォントが使用できない場合に使用する Substitution Font も選択できます。
-
Border Mode
-
Margin - このボタンをクリックすると、Margin Borderオプションを編集できるようになります。
- Text Offset - デジグネータを、位置揃えの基準となる辺または角から内側にオフセットする量です。Center 位置揃えモードを選択している場合、このオプションは効果がありません。このオプションは Marginでは使用できません。
-
Offset - このボタンをクリックすると、Text Offsetオプションを編集できるようになります。
- Margin Border - デジグネータの周囲の余白枠のサイズを指定します。 このオプションは Offsetでは使用できません。
-
Margin - このボタンをクリックすると、Margin Borderオプションを編集できるようになります。
PCB上でのコンポーネントの利用
設計を回路図エディターからPCBエディターに転送すると、使用可能なライブラリからPCBコンポーネントのフットプリントが自動的に配置されます。これは 設計の同期と呼ばれ、回路図とPCBの差異を検出して解消するプロセスです。
Altium Designerには、必要なコンポーネントのフットプリントをPCB設計スペースに配置しやすくする一連のツールが用意されています。これらのツールについては、次のページを参照してください。
配置済みコンポーネントの参照
PCBパネルの Componentsモードでは、パネルの3つの主要領域が、現在のPCB設計のコンポーネント階層を反映した表示に切り替わります(上から順に)。
- Component Classes
- Components クラス内
- Component Primitives

PCBパネルの各領域では、コンポーネントクラスから個々のコンポーネント、さらにコンポーネントのプリミティブへと、フィルターの選択を段階的に絞り込むことができます。
コンポーネントまたはコンポーネントのプリミティブの項目を右クリックし、Propertiesコマンドを選択する(または項目を直接ダブルクリックする)と、Propertiesパネルが開き、必要に応じてコンポーネント/プリミティブのプロパティを確認・変更できます。
コンポーネントクラスの項目を右クリックし、Properties を選択する(または項目を直接ダブルクリックする)と、そのクラスの Edit Component Classダイアログ が開きます。このダイアログでは、クラスに属するコンポーネントの確認・変更、クラス名の変更、クラスの追加ができます。
パネルの Component Primitives領域で各コンポーネントプリミティブタイプが表示対象となるかどうかは、Componentsまたは Component Primitives領域から開く右クリックメニューで、それぞれに対応するオプションが有効になっているかどうかによって決まります。

コンポーネントまたはコンポーネントのプリミティブの項目を右クリックして、含める項目を選択します。
参照中は、Components領域の Footprint列の右側にあるボックスをダブルクリックすることで、コンポーネントを簡単にロックまたはロック解除できます。

PCB パネルからロック/ロック解除を行うと、Propertiesパネルで操作する手間を省けます。
コンポーネント選択のバウンディングボックス
コンポーネントをクリックして選択すると、選択バウンディングボックスが表示されます。バウンディングボックスの定義に使用するレイヤーは、詳細設定ダイアログのPCB.ComponentSelection オプションで制御できます。このオプションには3つのモードがあります(値として0、1、または2を入力します。デフォルトのモードは2です)。
-
0 - legacy mode- このモードでは、シルクスクリーンのデジグネーター文字列とコメント文字列を除く、すべてのレイヤーの形状を組み合わせます。 -
1 - by layer mode- 以下の優先順位に従い、オブジェクトが含まれている最初のレイヤーの形状を使用します。-
コートヤードレイヤータイプ
-
3Dボディレイヤー(STEPモデルは、モデルを収容する最小の直方体サイズの3Dボディオブジェクトに格納されます。コンポーネントの選択には、STEPモデルの形状ではなく、この3Dボディが使用されます)
-
シルクスクリーンレイヤーと銅箔レイヤー
-
銅箔レイヤー
-
-
2 - by graphic mode- このモードでは、コートヤードレイヤータイプ、シルクスクリーン、3Dボディオブジェクト、および銅箔レイヤーで検出された形状を組み合わせます。文字列は除外されます。
コンポーネントへのプリミティブの追加
メインメニューからTools » Convert » Add Selected Primitives to Componentコマンドを選択すると、選択したプリミティブをコンポーネントに追加できます。コマンドを選択した後、選択したプリミティブの追加先となるコンポーネントを選択します。確定すると、新しいプリミティブは単一のコンポーネントオブジェクトの一部として認識され、コンポーネントの既存のプリミティブとともに使用できるようになります。
この操作を実行するには、対象コンポーネントのプリミティブのロックを解除する必要があります。コンポーネントのプロパティにあるPrimitives ロックアイコンを使用して、コンポーネントのプリミティブのロックを解除してください。
コンポーネントをプリミティブに分解
メインメニューのTools » Convert » Explode Component to Free Primitivesコマンドを使用するか、配置済みのコンポーネント上で右クリックし(選択状態は問いません)、コンテキストメニューからComponent Actions » Explode Component To Free Primitives(またはExplode Selected Components To Free Primitives)コマンドを選択すると、コンポーネントを構成するプリミティブオブジェクトに変換できます。分解されたコンポーネントはコンポーネントではなくなるため、デジグネーターとコメントは削除され、元の構成要素である各種プリミティブに戻ります。
分解は、該当するソースライブラリに格納されているフットプリントモデルには影響しません。影響を受けるのは、PCBドキュメント上に配置され、変換されたコンポーネントのインスタンスのみです。
参照情報へのクリック可能なリンクへのアクセス
コンポーネントに名前付きドキュメントリンクが追加されている場合、選択したコンポーネント、またはカーソル下のコンポーネントについて、指定されたドキュメントやページのURLを開くことができます。このURLは、基になるURLリンクパラメーターで定義されます。この機能により、回路図コンポーネントから転送された名前付きドキュメントリンクを、PDF、テキストファイル、HTMLページへの名前付きPCBコンポーネントリンクとして表示できます。これは、コンポーネントの名前付きドキュメントリンクが回路図からPCBへ更新されたときに行われます(Design » Update PCB Document)。この更新処理(ECO経由)では、回路図の名前付きドキュメントリンクが、対応するPCBコンポーネントのComponentLinkパラメーターペア(ComponentLinknDescription/ComponentLinknURL)に変換されます。例:
| 回路図コンポーネントのパラメーター | PCBコンポーネントのパラメーター | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
コンポーネントパラメーターで使用されるリンクインデックス番号(n)によって、Referencesサブメニュー内の対応するPCBコンポーネントリンクの表示順が決まります。PCB上のコンポーネントを選択すると、定義済みのComponentLinkパラメーターペアが、プロパティパネルのParametersセクションに表示されます。
コマンドを実行すると、Web上のリンク先ページ、または指定されたドキュメントが直接開きます(利用可能な場合)。




)。ただし、これはコートヤードレイヤーに定義された形状が閉じた形状であり、トラック端点の頂点が一致している(正確に接している)場合に限られます。それ以外の場合、バウンディングボックスは、コートヤードレイヤー上のすべてのオブジェクトを囲む最小の長方形によって定義されます。