BOM 문서 만들기
개요
- BomDoc를 생성하는 방법, 프로젝트에 추가했을 때 수행되는 작업, 프로젝트당 하나의 BomDoc만 사용할 수 있다는 주요 제한 사항을 알아봅니다.
- 보기 모드, 열 제어, 편집 도구, 그룹화 동작, 표시 설정 옵션 등 BOM 항목 목록의 구성 방식을 살펴봅니다.
- ActiveBOM이 그룹화된 부품과 사용자 정의 BOM 항목을 처리하는 방식을 이해하여 설계 부품뿐 아니라 추가 프로젝트 항목까지 빠짐없이 관리할 수 있습니다.
BOM 문서 생성
ActiveBOM에서 작업하는 BOM 문서를 BomDoc이라고 합니다. File » New 하위 메뉴를 통해 프로젝트에 새 BomDoc을 추가하거나 Projects Panel에서 프로젝트를 마우스 오른쪽 버튼으로 클릭합니다. 프로젝트에 컴포넌트가 하나 이상 있으면 Projects Panel의 프로젝트 구조에서 ActiveBOM Entry 옆에 있는 + Create 컨트롤을 클릭하여 새 BomDoc을 생성할 수 있습니다. 각 PCB 프로젝트에는 BomDoc을 하나만 포함할 수 있습니다.
프로젝트에 새 BomDoc을 추가하면 Schematic이 자동으로 컴파일되고 기존의 모든 컴포넌트가 BomDoc에 나열됩니다. Part Choices가 포함된 워크스페이스 라이브러리 컴포넌트의 경우, 아래의 솔루션 이해하기 섹션에서 설명하는 것처럼 인터페이스 하단 Region에 솔루션의 세부 정보가 표시됩니다.
Schematic에 컴포넌트를 추가로 배치하면 해당 컴포넌트가 BomDoc에 자동으로 추가됩니다. 컴포넌트 목록 위에 있는 Add new 버튼을 통해 ActiveBOM에서 직접 BOM Item과 매개변수를 수동으로 추가할 수도 있습니다. 자세한 내용은 Custom BOM Item 및 열 섹션을 참조하세요.
BOM Item 목록
BomDoc의 상단 Region에는 PCB 설계 프로젝트에서 감지된 모든 컴포넌트와 BomDoc에 직접 추가한 BOM Item이 표 형식으로 나열됩니다. 이 Region을 BOM Item 목록이라고 합니다.

Base 보기에서 표시되는 컴포넌트 목록, 즉 BOM Item 목록입니다.
BOM Item을 표시하는 보기 모드는 3가지입니다. 목록 위의 버튼을 사용하여 필요한 모드를 선택하세요.
Flat view - 각 컴포넌트를 한 행에 표시합니다.
Base view - 프로젝트의 고유한 컴포넌트마다 한 행에 표시하며, Designator 열에는 해당 유형의 모든 컴포넌트의 Designator가 나열됩니다. 그룹화된 Designator에는 여러 표시 옵션을 사용할 수 있습니다. Properties Panel에서 필요한 Designator Grouping 모드를 선택하세요.
Consolidated view - 프로젝트에 배리언트가 포함된 경우 모든 배리언트의 통합 BOM을 표시하는 데 사용합니다.
BOM Item 목록 편집 기능
컴포넌트 목록은 다음을 비롯한 다양한 스프레드시트 형태의 편집 기능을 지원합니다.
- Properties Panel의 Column 탭에서 열을 표시하거나 숨기고 열 이름의 별칭을 정의할 수 있습니다. 별칭은 열 속성 입력 대화 상자에서도 정의할 수 있습니다. 이 대화 상자는 BomDoc의 열 머리글 Region에서 열 이름을 마우스 오른쪽 버튼으로 클릭한 다음 상황에 맞는 메뉴에서 Rename Column 명령을 선택하여 열 수 있습니다. 생성된 BOM 출력에서는 별칭이 열 이름으로 사용됩니다.
-
BomDoc의 열 머리글 Region에서 열 이름을 마우스 오른쪽 버튼으로 클릭한 다음 Select Columns을(를) 선택하여 여는 Select Columns 대화 상자에서도 열을 추가하거나 제거할 수 있습니다.
열 선택 대화 상자의 옵션/컨트롤
- Search - 필드에 문자를 입력하여 열 목록을 필터링합니다. 이름에 입력한 문자가 포함된 열만 표시됩니다.
-
Visibility column - ActiveBOM 문서(
*.BomDoc)에서 ActiveBOM 열의 표시 여부를 제어합니다. 눈 아이콘을 클릭하면 열의 표시 여부가 전환됩니다. 표시되는 열은 항상 대화 상자 상단에 BomDoc에 나타나는 순서대로 나열됩니다. -
Data Source column - 열의 데이터 소스를 표시합니다. 지원되는 데이터 소스는 다음과 같습니다.
-
- BOM에 직접 추가한 Item
-
- Schematic 컴포넌트 매개변수
-
- 워크스페이스 컴포넌트 매개변수
-
- 연결된 데이터베이스 매개변수(DbLink, DbLib)
-
- Schematic 문서 매개변수
-
- Altium Cloud Services
-
- Column Name - 데이터 소스의 이름을 표시합니다. 이 이름은 BomDoc에서 열 이름으로 표시됩니다.
- Up / Down - 현재 선택한 열을 목록에서 위나 아래로 이동하는 데 사용합니다. OK을(를) 클릭하면 해당 열이 BomDoc에서 왼쪽이나 오른쪽으로 이동합니다. 표시되는 열만 순서를 변경할 수 있습니다.
-
- 각 머리글 옆의 필터 심볼을 클릭하면 선택한 목록 Item을 기준으로 Grid의 정보를 필터링할 수 있습니다.
- 드래그 앤 드롭으로 열 순서를 변경합니다.
- 원하는 열을 기준으로 정렬하고, Shift을(를) 누른 상태에서 다른 열을 선택하여 하위 정렬 기준을 추가합니다.
-
필터 아이콘을 클릭하여 열 값을 기준으로 필터링합니다.
- 표준 Windows 선택 방법으로 셀을 선택합니다.
- ActiveBOM에서 셀 내용을 복사하고, 외부 스프레드시트 Editor의 값을 Custom ActiveBOM 열에 붙여넣습니다.
- BOM이 Base 보기일 때 사용자 지정 행 번호를 정의할 수 있습니다. Base 보기에서 Set line numbers 버튼을 클릭하면 각 행에 행 번호가 추가됩니다. 버튼 오른쪽의 드롭다운 아이콘을 클릭하면 행 번호 옵션 대화 상자가 열리며, 여기에서 시작값과 증가값을 정의할 수 있습니다. 자세한 내용은 행 번호 열 섹션을 참조하세요.
- Add New 드롭다운을 클릭하여 행이나 열을 추가합니다. 자세한 내용은 Custom BOM Item 및 열 섹션을 참조하세요.
- Group by 버튼을 클릭하여 활성화된 열을 기준으로 Grid를 그룹화합니다. 여러 그룹화 기준 열을 활성화할 수 있으며(이미지 보기), 드래그 앤 드롭으로 순서를 변경할 수 있습니다. 이는 Grid 표시 기능으로, Bill of Materials 명령을 실행할 때 그룹화가 Report Manager 대화 상자로 전달되지는 않습니다.
- Reset Supply Chain 버튼을 클릭하면 선택한 BOM Item에서 사용자 정의 솔루션 순위와 수동으로 지정한 SPN 우선순위가 제거됩니다.
- BOM Item 그리드의 현재 구성은 BOM 세트로 저장할 수 있습니다. 자세한 내용은 BOM Item Grid 표시 구성 및 저장 섹션을 참조하세요.
-
표준 Windows 바로 가기 키를 사용하여 BOM Item 목록을 스크롤할 수 있습니다.
- 세로 스크롤 = MouseWheel Roll
- 가로 스크롤 = Shift + MouseWheel Roll
열 그룹

ActiveBOM 컴포넌트 목록에는 각 보기 모드에 표시되는 별도의 열 그룹이 있으며, 위 이미지는 Base 보기를 보여 줍니다.
BOM Item 그리드는 다음과 같은 주요 그룹으로 나뉩니다.
- Item Details (이미지에서 주황색으로 강조 표시) - 이 열에는 Designator, 설명, 라이브러리 참조 및 기타 컴포넌트 매개변수와 같은 컴포넌트의 매개변수 정보가 표시됩니다.
- Solutions (이미지에서 녹색으로 강조 표시) - 공급망에서 순위가 가장 높은 제조업체 + 공급업체를 표시합니다. 솔루션(제조업체 부품) 수와 각 솔루션의 공급업체 수는 ActiveBOM Properties 패널에서 구성하며, 공급업체 타일의 단색 배너로 표시됩니다. 순위는 자동으로 지정되며, 아래 솔루션 이해 섹션에서 설명하는 것처럼 수동으로 정의할 수도 있습니다.
- BOM Status (이미지에서 청록색으로 강조 표시) - 각 컴포넌트와 관련된 현재 위험을 나타냅니다. 아이콘 위에 마우스를 올리면 설명이 표시됩니다. 또는 Properties 패널에서 상세 BOM Status 열을 활성화하여 설명을 표시할 수 있습니다.
Custom BOM Item 및 열
PCB 설계 프로젝트의 BOM을 관리하려면 회로도와 PCB에 배치된 컴포넌트 및 BOM Item뿐 아니라 아직 상세 정보가 정해지지 않은 부품, 체결 부품, 베어 보드 또는 장착용 접착제 등도 관리해야 합니다. PCB 설계 프로젝트에서는 사용자 정의 BOM Item 또는 매개변수가 사용되는 경우가 많습니다. 이러한 상황에 대응하기 위해 ActiveBOM은 BOM Item과 열(매개변수)을 추가하는 기능을 지원하며, 추가한 항목은 생성되는 BOM에 포함할 수 있습니다.
- Custom row - 설계에서 고려해야 하는 사용자 정의 BOM Item(베어 보드, 접착제 등)을 손쉽게 추가할 수 있습니다. 사용자 정의 행의 모든 필드는 사용자가 정의합니다. 사용자 정의 행은 ActiveBOM에서 관리하지 않습니다. 예를 들어 수량을 3으로 설정해도 Flat 보기에 개별 항목 3개가 표시되지는 않습니다. 사용자 정의 행에서는 공급망 검색도 지원되지 않습니다.
- Custom column - ActiveBOM에서 관리하는 추가 BOM 열로, 사용자가 정의한 모든 텍스트를 포함할 수 있습니다.
- Custom Item - 추가 BOM Item으로, 일반적으로 필요하지만 아직 구체적인 정보가 정해지지 않았거나 라이브러리에 아직 없는 항목에 사용합니다. 이를 통해 해당 항목의 비용을 전체 보드 비용 추정에 포함할 수 있습니다.
-
Managed Component - BOM 문서에서 수동으로 관리하는 추가 BOM Item입니다. Component Search 대화 상자가 열리며, 현재 연결된 워크스페이스의 컴포넌트가 나열됩니다.
컴포넌트 검색 대화 상자의 옵션 및 컨트롤
- Search - 검색 텍스트 상자를 사용하여 특정 컴포넌트를 직접 검색합니다.
-
- 클릭하여 메뉴를 열고 다음 중에서 선택합니다.
- File-based Libraries Preferences - 클릭하면 사용 가능한 파일 기반 라이브러리 대화 상자가 열리며, 라이브러리를 추가하거나 제거할 수 있습니다.
- File-based Libraries Search - 클릭하면 파일 기반 라이브러리 검색 대화 상자가 열리며, 라이브러리를 검색할 수 있습니다.
- Refresh - 클릭하여 대화 상자를 새로 고칩니다.
-
- 클릭하여 대화 상자의 Details 영역 을 열거나 닫습니다(아래 설명 참조).
카테고리
이 필터를 사용하여 특정 유형의 컴포넌트만 표시하거나 사용 가능한 모든 컴포넌트를 표시할 수 있습니다.
을 사용하면 Categories 검색창에 액세스하여 특정 컴포넌트 또는 .IntLib 파일을 직접 검색할 수 있습니다.
필터
Filters 아이콘을 클릭하면 Filters 영역이 열리며, Components 목록에서 선택한 카테고리를 추가로 필터링할 수 있습니다.
컴포넌트
- Name - 컴포넌트의 이름입니다.
- Description - 각 컴포넌트의 설명입니다.
- Footprint - 컴포넌트의 풋프린트입니다.
- Operating Temperature Range - 이러한 컴포넌트가 작동하는 적정 온도 범위입니다.
- Package Description - 컴포넌트의 패키지 설명입니다.
- Manufacturer Part Search - 클릭하면 Manufacturer Part Search 패널이 열리며, 가장 적합한 컴포넌트 부품을 검색하고 선택할 수 있습니다.
- Create component - 클릭하면 컴포넌트 유형을 선택하는 Create new component 대화상자가 열립니다.
- Results - 검색에서 찾거나 나열된 컴포넌트의 총수를 표시합니다.
세부 정보
- Component Revision ID - 해당 컴포넌트의 리비전 ID와 가격을 표시합니다. 리비전 ID를 클릭하면 Explorer 패널이 열리며, 컴포넌트에 대한 자세한 정보를 확인할 수 있습니다.
- References - 클릭하면 웹 브라우저에서 컴포넌트의 참조 정보가 열립니다. 드롭다운을 사용하여 Manufacturer URL 또는 Datasheet에 액세스할 수 있습니다.
- Place - 클릭하면 선택한 컴포넌트를 Schematic 문서에 배치합니다.
- Component information - 제조업체, 출시일 및 설명 정보를 비롯한 컴포넌트 관련 정보를 표시합니다. 모든 정보를 보려면 Show More 링크를 클릭하고, 정보를 접으려면 Show Less 을 클릭합니다.
- Models - 펼치면 제공된 모델을 볼 수 있습니다. 사용 가능한 링크를 통해 단일 모델의 다양한 부분을 표시할 수 있습니다.
- References - 펼치면 Manufacturer URL 또는 Datasheet에 액세스할 수 있습니다.
- Part Choices - 펼치면 부품 선택 항목을 볼 수 있습니다. 이름, 가격 및 설명이 제공됩니다. 컴포넌트의 데이터시트도 표시됩니다.
- Where Used - 펼치면 해당 컴포넌트를 사용하는 프로젝트를 볼 수 있습니다.
마우스 오른쪽 버튼 클릭 메뉴
- Place <component> - 클릭하면 해당 문서에 컴포넌트를 배치합니다.
- Edit - 클릭하면 선택한 컴포넌트의 컴포넌트 라이브러리 문서가 열립니다.
- Navigate to <revision> - 클릭하면 Explorer 패널에서 선택한 컴포넌트가 열립니다.
- Operations - 마우스를 올리면 Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL 및 Full Item History 기능에 액세스할 수 있습니다.
- Refresh - 클릭하면 새로 고침하여 최근 업데이트 또는 편집 내용을 확인할 수 있습니다. F5 단축키를 사용하여 새로 고칠 수도 있습니다.
관리형 컴포넌트 또는 Custom Item의 인스턴스 추가
관리형 컴포넌트 또는 Custom Item을 추가한 후 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 Operations » Add Instances of 명령을 선택하여 Add to BOM Components 대화상자를 엽니다. 이 대화상자에서 BOM에 추가할 컴포넌트의 인스턴스 수를 정의합니다.
Designator prefix, 선택 사항인 Separator(X-1 또는 X:1와 같은 결과를 얻도록 정의할 수 있음), 필요한 컴포넌트의 Quantity 을 지정합니다. 이 값은 Designator 범위를 정의하는 데 사용되며 ActiveBOM의 Quantity 열에도 표시됩니다. 설명과 같은 다른 모든 파라미터는 BOM Item 그리드에서 직접 편집할 수 있습니다.
관리형 컴포넌트 또는 Custom Item 변경/제거
Designator를 편집하거나 관리형 컴포넌트 또는 Custom Item의 인스턴스를 제거하려면 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 Operations » Edit item 명령을 선택합니다. Change / Remove 대화상자가 열립니다.
변경/제거 대화상자의 옵션 및 컨트롤
- BOM Components - 대화상자의 그리드 영역에는 새 항목의 각 인스턴스가 표시됩니다. Designator 접두사 또는 값을 편집하려면 해당 New Designator 셀을 클릭하고 필요에 따라 편집합니다.
- Remove All - 이 버튼을 클릭하면 대화상자에 나열된 추가 BOM Item의 모든 인스턴스가 선택되고 제거 대상으로 표시됩니다. 대화상자의 OK 버튼을 클릭하면 Remove로 표시된 모든 항목이 ActiveBOM의 BOM Item 그리드에서 제거됩니다. 해당 새 항목의 인스턴스가 더 이상 남아 있지 않으므로 항목 자체도 제거됩니다. 이 작업은 실행 취소할 수 없습니다.
- Remove None - 이 버튼을 클릭하면 모든 Remove 표시가 해제됩니다.
- Remove Selected - 제거 대상으로 표시되지 않은 인스턴스를 선택한 경우, 세 번째 버튼을 사용하여 현재 선택한 인스턴스에 Remove 표시를 설정할 수 있습니다.
- Restore Selected - 현재 제거 대상으로 표시된 인스턴스를 선택한 경우, 세 번째 버튼을 사용하여 현재 선택한 인스턴스의 Remove 표시를 해제할 수 있습니다.
데이터 소스
ActiveBOM에서 사용할 수 있는 기본 데이터 소스는 Schematic 컴포넌트 파라미터, 워크스페이스 콘텐츠의 워크스페이스 컴포넌트 파라미터, ActiveBOM에서 제공하는 데이터입니다. ActiveBOM은 이러한 소스를 바탕으로 기본 프로젝트 BOM Item 그리드를 생성합니다. 데이터 소스의 활성화 및 표시 여부는 ActiveBOM Properties 패널의 Columns 탭에서 제어합니다.
Columns 목록 위에 있는 해당 Sources 버튼을 활성화하면 BOM에 다음 추가 데이터 소스의 정보도 포함할 수 있습니다.
The PCB - 이 옵션을 활성화하면 각 컴포넌트의 PCB 위치/회전/기판 면 데이터가 사용 가능한 Columns에 포함됩니다. 프로젝트에 PCB 문서가 여러 개 있으면 Choose PCB to Use 대화상자가 열리며, 여기에서 필요한 PCB를 선택할 수 있습니다.
Database - 외부 데이터베이스에서 추가 컴포넌트 파라미터를 불러옵니다(*.DbLib, *.SVNDbLib 또는 *.DbLink 사용).
Altium Cloud Services - 이 옵션을 활성화하면 Altium Parts Provider에서 식별되어 공급망 솔루션이 표시되는 BOM Item에 대해 다양한 추가 컴포넌트 데이터에 액세스할 수 있습니다.
Document Parameters - 이 옵션을 활성화하면 PCB 프로젝트의 모든 Schematic에서 감지된 모든 Schematic 문서 파라미터가 사용 가능한 Columns에 포함됩니다.

각 파라미터의 소스는 열 목록의 아이콘으로 표시됩니다.
데이터 소스 파라미터 우선순위
동일한 파라미터가 둘 이상의 데이터 소스에 있는 경우 ActiveBOM에서는 다음 우선순위가 적용됩니다(높은 순서부터 낮은 순서).
- BOM
- PCB
- 문서
- 서버
- 데이터베이스
- 클라우드
- Schematic
- 수동
행 번호 열
조립 도면이 포함된 PCB 설계나 설계 엔지니어, 원가 엔지니어 또는 구매 전문가 간의 BOM 데이터 교환에서 BOM 행 번호(BOM Item 위치 번호)는 각 BOM 행을 개별적으로 구분하는 간단한 방법입니다. 이를 통해 설계에서 해당 지시선, 컴포넌트 및 도해를 명확하게 식별하거나 find할 수 있습니다.
프로젝트 BOM 데이터 소스인 ActiveBOM은 프로젝트 BOM에 대해 사용자 정의 Line #을 지원하며, 수동 및 자동 Line #(BOM Item 위치 번호) 관리 기능을 모두 제공합니다.
-
모든 프로젝트 BOM Item의 위치 번호를 자동으로 설정하려면(Base 보기에서) Set Line #
버튼을 클릭합니다. 행 번호는 Item Details 열 그룹의 Line # 열에 표시됩니다. 버튼 오른쪽의 드롭다운 아이콘을 클릭하면 시작 값과 증가 값을 정의할 수 있는 Line # Options 대화 상자가 열립니다.

Line Number Options 대화 상자- Start number - 첫 번째 Line # 셀이 비어 있을 때 사용할 값입니다.
- Increment - 비어 있는 각 Line # 필드의 값을 이 값만큼 증가시킵니다.
-
Line #을 수동으로 변경하려면 Base 보기 모드로 전환한 다음 Line # 열에서 필요한 셀을 선택하고 다음 작업을 수행합니다.
- 키보드에서 Delete 키를 눌러 셀을 지운 다음,
- 새 값을 직접 입력하거나,
- Windows 클립보드에서 값 범위를 붙여넣습니다.
-
번호를 다시 매기거나 직접 추가한 번호부터 이어서 번호를 매기려면 원하는 항목의 Line # 셀을 클릭한 다음 Set Line #
버튼을 클릭합니다. Line Numbering 대화 상자가 열리면 기존 번호를 기준으로 사용하여 바로 위의 가장 가까운 비어 있지 않은 셀부터 시작해 선택한 빈 셀 또는 모든 빈 셀에 연속 번호를 매기거나(Continue numbering), 기존 번호를 모두 삭제하고 모든 행의 번호를 다시 매길 수 있습니다(Renumber all). 추가되는 번호는 Line # Options 대화 상자에서 마지막으로 정의한 기준 값과 증가 값을 사용해 계산됩니다. 필요한 경우 선택한 Line # 셀에 초기값을 입력하여 시작 번호를 정의할 수 있습니다.
BOM Item 그리드 표시 구성 및 저장
다른 우수한 스프레드시트 애플리케이션과 마찬가지로 BOM Item 그리드도 요구 사항에 맞게 구성할 수 있습니다. 일반적인 열 순서 변경 및 정렬 기능뿐 아니라 현재 구성을 BOM Set으로 저장할 수도 있습니다.
그리드 구성 기능
- 열 표시/숨기기 - Properties 패널의 Columns 기능을 사용합니다. 패널 상단의 Search 필드를 사용하면 열을 빠르게 찾을 수 있습니다.
- 열 순서 변경 - 열 제목을 클릭한 상태로 끌어서 놓습니다.
- 열 너비 변경 - 제목 영역의 열 경계에 마우스 포인터를 올려놓고 클릭하여 드래그합니다커서가 표시되는지 확인). 또는 해당 위치를 두 번 클릭하여 열 내용에 맞게 너비를 자동으로 조정합니다.
-
특정 열을 기준으로 전체 그리드 정렬:
- 열 제목을 클릭하면 해당 열의 내용을 기준으로 그리드가 영숫자순으로 정렬됩니다.
- 다시 클릭하면 반대 순서로 정렬됩니다.
- Shift 키를 누른 상태에서 다른 열 제목을 클릭하면 해당 열의 내용을 기준으로 하위 정렬됩니다.
-
특정 값으로 그리드 필터링 - 필터 아이콘
을 클릭하면 해당 열에 사용된 값으로 그리드를 필터링할 수 있습니다. (Custom)을 선택하면 Filter Editor 대화 상자가 열리며, 여기서 선택한 열을 필터링할 조건, 연산자, 값, 연산자 유형 등을 정의할 수 있습니다.
- 구성을 BOM Set으로 저장 - 자세한 내용은 아래에서 설명합니다.
BOM Set 사용하기
BOM Item 그리드 구성은 개수 제한 없이 저장할 수 있으며, 각각을 BOM Set이라고 합니다. 요구 사항에 맞게 그리드를 구성한 후 ActiveBOM Properties 패널의 BOM Sets 영역에서 Add 버튼을 클릭하여 목록에 BOM Set을 추가합니다.

눈 모양 아이콘을 클릭하여 BOM Set을 활성화합니다.
BOM Set은 ActiveBOM Properties 패널에서 구성합니다.
컴포넌트 교체
BomDoc을 검토하고 부품 주문을 준비하는 과정에서 컴포넌트의 문제가 발견되는 경우는 드물지 않습니다. 예를 들어 설계자가 컴포넌트 선정을 마무리하는 것을 잊었거나, 컴포넌트가 단종(EOL)되어 대체 가능한 부품의 가격과 공급 가능 여부를 알아보려는 경우가 있습니다. 이전에는 이를 해결하려면 회로도로 돌아가 컴포넌트를 편집하고 적절한 부품을 선택한 다음 BomDoc을 새로 고쳐야만 했습니다.
또는 BomDoc에서 컴포넌트를 변경한 다음 설계 변경 지시(ECO)를 통해 해당 변경 사항을 회로도에 반영할 수 있습니다. 선택한 컴포넌트를 마우스 오른쪽 버튼으로 클릭하고 Operations » Change <ComponentName> 명령을 선택합니다. 컴포넌트 교체 대화 상자가 열리면 교체할 컴포넌트를 검색할 수 있습니다.
Replace Component OK 버튼을 클릭하면 Engineering Change Order 대화 상자가 열리고, 회로도를 BomDoc과 동기화하는 데 필요한 변경 사항이 상세히 표시됩니다.
Variant 작업
ActiveBOM은 설계 Variant가 포함된 PCB 프로젝트를 지원합니다. 설계 Variant 기능을 사용하면 하나의 기본 PCB 설계를 만든 후 여러 가지 방식으로 부품을 실장할 수 있습니다. 조립 보드의 각기 다른 실장 구성을 design variant라고 합니다.
설계 Variant 작업:
- 설계 Variant는 Variant 관리 대화 상자 또는 Variant Manager(Project » Variants)에서 구성합니다.
- Variant를 확인하려면 아래 이미지와 같이 Projects 패널의 프로젝트 내 Variants 폴더에서 해당 이름을 두 번 클릭합니다.
ActiveBOM은 다음과 같은 방식으로 Variant를 지원합니다.
- 기본 보기 모드 또는 평면 보기 모드에서 특정 Variant의 BOM 표시
- BOM Item 목록에 미실장 Item을 포함하는 옵션 제공
- 통합 보기 모드에서 모든 Variant에 사용된 모든 부품의 통합 목록 표시
- 기본 컴포넌트와 변경된 컴포넌트 모두에 대해 수동 솔루션 정의
기본 보기 모드의 Variant
선택한 Variant에서 이러한 부품을 BOM Item Grid에 포함하려면 Properties 패널의 Show Not Fitted 옵션을 활성화합니다. 이 옵션을 활성화하면 Item 세부 정보에 Fitted 열이 자동으로 표시됩니다.
기본 보기 모드에서 Fitted 열에는 Fitted 또는 Not Fitted이 표시됩니다. 부품이 변경된 경우(이 Variant에서 대체 부품을 선택한 경우), 해당 BOM Item에 대체 부품의 세부 정보가 자동으로 표시됩니다.

현재 Variant는 ActiveBOM 상태 표시줄에 표시됩니다.
통합 보기 모드의 Variant
통합 보기 모드에는 모든 Variant에서 사용된 모든 컴포넌트가 표시됩니다. 통합 보기는 다음 기능을 제공합니다.
- 컴포넌트가 변경된 경우, 사용된 각 대체 컴포넌트마다 BOM Item이 생성되며 이러한 BOM Item은 모두 동일한 Designator를 갖습니다. 예를 들어 아래 이미지에서 BGA Variant는 TSOP Variant와 다른 색상의 LED를 사용하므로 컴포넌트 DS1과 DS2가 각각 두 번씩 나열됩니다. 컴포넌트 R1은 BGA 및 TSOP Variant가 모두 기본 설계의 원래 저항과 다른 저항을 사용하므로 세 번 표시됩니다.
-
통합 보기 모드에서 Show Not Fitted 옵션을 활성화하면 Fitted 열에
Fitted또는Varied가 표시됩니다. 통합 보기에는 모든 Variant에서 사용된 모든 컴포넌트가 표시되므로, 표시된 모든 컴포넌트는 기본 설계 또는 Variant 중 하나에 실장됩니다. - 각 Variant에는 <VariantName> - Qty 열(이 Variant에서 사용된 해당 컴포넌트의 수량 표시)과 <VariantName> - Price 열이 있으며, 후자는 단가에 수량 열의 값을 곱한 값입니다.
- 일부 설계자는 Variant뿐 아니라 기본 설계에서도 제작 문서를 생성하므로, 기본 설계로 제작할 때 사용되는 해당 컴포넌트의 인스턴스 수를 나타내는 Quantity 열도 제공됩니다. 기본 설계에서 제작 문서를 생성하지 않는 경우 이 열을 숨기세요.
- 통합 보기 모드의 Grid는 아래와 같이 기본 설계의 해당 셀 값과 다른 값을 가진 셀을 색상으로 표시합니다.

셀의 색상은 해당 셀의 값이 기본 설계에서의 값과 다름을 나타냅니다.
Variant에 대해 자세히 알아보려면 설계 Variant 페이지를 참조하세요.
BomDoc, Schematic 및 PCB 간 작업
BomDoc, Schematic 및 PCB 설계 간 작업을 지원하는 두 가지 기능인 교차 선택과 교차 탐색을 사용할 수 있습니다. 이러한 기능의 동작은 Preferences 대화 상자의 시스템 - 탐색 페이지에서 구성합니다.
두 기능 모두 다른 문서에서 동일한 컴포넌트를 찾는 데 사용할 수 있습니다. 교차 선택과 교차 탐색의 차이점은, 교차 선택 모드는 타겟 문서에서 컴포넌트를 선택하지만 해당 문서를 화면에 띄우지는 않는 반면, 교차 탐색은 타겟 문서를 화면에 띄우며 타겟 문서의 Editor로 전환하여 활성화할 수도 있다는 점입니다.
BomDoc에서 Schematic 및 PCB로 교차 선택하거나 교차 탐색할 수 있지만, Schematic 또는 PCB에서 BomDoc으로는 교차 선택하거나 교차 탐색할 수 없습니다.
교차 선택 모드
교차 선택 모드는 사용하려는 각 Editor에서 활성화해야 합니다. Tools » Cross Select Mode 명령(Shift+Ctrl+X)을 선택합니다. 교차 선택 모드가 활성화되면 메뉴 아이콘이 테두리로 강조 표시됩니다
.
교차 선택 모드를 사용하려면 타겟 문서가 열려 있어야 합니다. BomDoc의 BOM Item 목록에서 컴포넌트를 선택하면 타겟 Schematic 및 PCB 문서에서 해당 컴포넌트가 선택되고 화면 중앙에 표시됩니다(Preferences 대화 상자의 시스템 - 탐색 페이지에 있는 Cross Select Mode 옵션에서 Zooming가 활성화된 경우). 타겟 문서가 활성 문서로 표시되지는 않습니다.
BomDoc이 기본 보기 모드인 경우 아래 이미지와 같이 Schematic 및 PCB에서 해당 부품의 모든 인스턴스가 선택됩니다.

교차 선택 기능을 사용하면 BOM Item 목록에서 선택한 컴포넌트를 Schematic 및 PCB에서 찾아 선택할 수 있습니다.
교차 탐색
교차 선택은 활성화하면 BOM Item 목록을 클릭할 때마다 결과를 표시하는 모드인 반면, 교차 탐색은 사용자가 명시적으로 실행하는 동작입니다.
다음을 선택합니다. Tools » Cross Probe 명령을 메인 메뉴에서 선택하거나 BOM Item을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Cross Probe을 선택하면 Schematic의 해당 컴포넌트로 크로스 프로빙할 수 있습니다. 보드 파일이 열려 있으면 PCB 컴포넌트도 함께 크로스 프로빙됩니다.
크로스 프로빙의 주요 기능 중 하나는 타겟 문서의 Editor로 전환할 수 있다는 점입니다. 크로스 프로빙과 동시에 Editor를 전환하려면 Ctrl 키를 누른 상태에서 Cross Probe 명령을 선택하세요.

마우스 오른쪽 버튼을 클릭하면 Cross Probe 명령을 사용할 수 있으며, 해당 BOM Item에 포함된 각 컴포넌트의 Designator에 대한 Entry가 표시됩니다.
속성 Panel
활성 문서가 BOM 문서(*.BomDoc)인 경우 Properties Panel에 Document Options이 표시됩니다.
다음 접이식 섹션에는 사용 가능한 옵션과 컨트롤에 대한 정보가 나와 있습니다.
일반
- Production Quantity – 제작할 보드 수입니다. 공급망 검색 시 공급업체의 컴포넌트 공급 가능 여부를 확인하는 데 사용되므로 이 필드를 설정하는 것이 중요합니다.
- Currency – 컴포넌트 가격을 표시할 기본 통화입니다. Altium 계정에 로그인되어 있으면 통화 변환에 사용되는 환율이 매일 갱신됩니다. Preferences 대화 상자의 System – Account Management 페이지에서 Altium 연결을 해제하면 이러한 최신 환율에 액세스할 수 없게 됩니다. 이 경우 BOM 보고서 대화 상자에서 캐시된 데이터를 사용하는 옵션을 선택할 수 있습니다.
- Price Per Board – 공급업체 기반 데이터에서 산출되는 값으로, 아래에 설명된 Supplier Subtotals per Board의 합계입니다. Price Per Board에는 최소 주문 수량(MOQ)이 반영되지 않습니다.
- Order Price – Supplier Subtotals의 합계입니다. Order Price에는 MOQ가 반영되며, 이는 공급업체에 지급하는 금액입니다.
공급망
공급망 정보는 ActiveBOM 인터페이스의 하단 Region에 표시되며, 왼쪽에는 제조업체 컴포넌트가, 오른쪽에는 하나 이상의 색상으로 구분된 공급업체 타일이 표시됩니다. BOM Item에 대한 유효한 공급망 정보를 식별할 수 있으면 이 Region에 데이터가 표시됩니다. 이러한 각 Manufacturer & Supplier(s) Details 행을 솔루션이라고 합니다. 제조업체 세부 정보는 MPN(제조업체 부품 번호)으로, 공급업체 세부 정보는 SPN(공급업체 부품 번호)으로 약칭됩니다.
- Solutions per Item – 각 BOM Item에 대해 찾으려는 제조업체 부품 수입니다.
- Suppliers per Solution – 각 제조업체 부품에 대해 찾으려는 공급업체 수입니다.
-
Solutions
- Exclude Invalid SPNs – 유효하지 않은 SPN을 제외하려면 선택합니다.
- Favorite Suppliers List – 이 BomDoc의 전체 공급업체 목록을 구성할 수 있는 Favorite Suppliers 대화 상자를 엽니다.
-
Manufacturer Link – 제조업체 이름과 제조업체 부품 번호를 저장하는 Schematic 컴포넌트 파라미터를 지정하는 Define Manufacturer Link Fields 대화 상자를 엽니다. 설계에 워크스페이스 라이브러리 부품이 아닌 부품(워크스페이스에서 배치되지 않았으며 공급업체 세부 정보도 없는 부품)이 있으면 ActiveBOM은 Altium Parts Provider에 쿼리하여 적합한 공급망 솔루션을 찾을 수 있습니다. 이름/부품 번호 파라미터 쌍을 여러 개 정의할 수 있습니다. 대화 상자에서 Detect fields 버튼을 클릭하면 이름에
manufacturer용어가 포함되어 있고 논리적으로 쌍을 이룰 수 있는 모든 파라미터 쌍이 자동으로 추가됩니다.
BOM Item
이 Region에서는 BOM Item Grid에서 BOM Item을 그룹화하는 방식을 구성합니다.
-
Items
-
Show not Fitted – PCB 프로젝트에 Variant가 포함되어 있고 선택한 Variant에
Not Fitted로 설정된 부품이 있는 경우, 이 옵션을 활성화하면 BOM Item Grid에 미실장 Item이 표시됩니다. - Designator Grouping – Base 및 Consolidated 보기 모드에서는 동일한 부품이 BOM Item Grid의 한 행에 표시됩니다. 한 행에 여러 부품이 표시될 때 Designator를 개별적으로 표시할지, 범위로 표시할지 이 옵션으로 구성합니다.
- Component Grouping – Edit 버튼을 클릭하면 Component Grouping 대화 상자가 열립니다. Base 보기 또는 Consolidated 보기에서 ActiveBOM은 ItemID(워크스페이스 라이브러리) 또는 LibRef(파일 기반 또는 데이터베이스 라이브러리)가 동일한 컴포넌트를 같은 컴포넌트로 식별합니다. 대화 상자에서 파라미터를 활성화하여 컴포넌트 그룹화 방식을 더 세밀하게 조정할 수 있습니다. 프로젝트에 관리형 컴포넌트만 포함되어 있으면 관리형 컴포넌트는 항상 ItemID로 그룹화되므로 Edit 버튼을 사용할 수 없습니다.
-
Show not Fitted – PCB 프로젝트에 Variant가 포함되어 있고 선택한 Variant에
BOM 세트
BOM 세트를 사용하면 BOM Item Grid의 레이아웃과 Configuration을 캡처하여 이름이 지정된 세트로 저장할 수 있습니다. BOM 세트는 개수 제한 없이 정의할 수 있습니다.
-
Current BOM Set – 눈 아이콘을 클릭하면 해당 BOM 세트가 BOM Item Grid에 적용됩니다.
-
Add – 열의 표시 여부, 순서 및 너비를 설정한 다음 Add를 클릭하여 해당 Configuration을 BOM 세트로 저장합니다. BOM 세트 이름을 편집하려면 한 번 클릭하여 선택한 다음 다시 클릭하여 문자열을 편집합니다.
-
Update – BOM Item Grid의 Configuration이 변경된 경우 Update를 클릭하여 이 Configuration을 다시 저장합니다.
-
Delete –
를 클릭하여 현재 선택된 BOM 세트를 제거합니다.
BOM 검사
ActiveBOM은 각 BOM Item과 해당 Item에서 감지된 모든 공급망 데이터를 종합적으로 검사합니다.
- Violation Type grid – 현재 BomDoc에 있는 위반 사항을 유형별로 개수와 함께 표시합니다. 필터 아이콘을 클릭하면 해당 BOM 검사를 통과하지 못한 BOM Item만 표시됩니다. 하나의 BOM Item이 여러 BOM 검사를 통과하지 못할 수도 있습니다.
-
BOM Checks –
를 클릭하여 BOM 검사 대화 상자를 엽니다. 이 대화 상자에서 가능한 각 위반 유형의 보고 모드를 설정할 수 있습니다.
열
Panel의 이 Region에서는 각 BOM Item에 표시할 파라미터와 해당 파라미터에 사용할 수 있는 데이터 소스를 설정합니다.
-
Sources – BomDoc에 직접 추가된 데이터 외에 ActiveBOM에서 사용할 수 있는 Default 데이터 소스는 Schematic 컴포넌트 파라미터와 워크스페이스 콘텐츠의 워크스페이스 라이브러리 컴포넌트 파라미터입니다. ActiveBOM은 이러한 소스를 바탕으로 기본 프로젝트 BOM Item Grid를 생성합니다. BOM에는 다음과 같은 추가 데이터 소스의 정보도 포함할 수 있습니다.
-
PCB – 활성화하면 각 컴포넌트에 대해 사용 가능한 Columns에 PCB 위치/회전/기판 면 데이터가 포함됩니다.
-
Database – 활성화하면 외부 데이터베이스(*.DbLib,*.SVNDbLib또는*.DbLink)에서 추가 컴포넌트 파라미터를 불러옵니다. -
Document – 활성화하면 PCB 프로젝트의 모든 Schematic에서 감지된 모든 Schematic 문서 파라미터가 사용 가능한 Columns에 포함됩니다.
-
Altium Cloud Services – 활성화하면 Altium Parts Provider에서 식별되고 공급망 솔루션이 표시된 BOM Item에 대해 다양한 추가 컴포넌트 데이터에 액세스할 수 있습니다.
-
-
Columns – ActiveBOM에서 사용할 수 있는 모든 부품 정보 소스의 목록입니다. 열 Region은 머리글 필드를 클릭하여 정렬할 수 있습니다.
- Visibility – 각 행에는 눈 모양 아이콘이 있습니다. 이 아이콘을 클릭하여 기본 BOM Item Grid에서 해당 열의 표시 여부를 제어합니다.
- Source – 해당 파라미터의 출처를 나타내는 아이콘을 표시합니다.
- Name – 소스 문서에 정의되어 있거나 사용자가 생성한 BomDoc 열에 입력한 속성/파라미터의 이름입니다.
- Alias – 필요한 경우 별칭을 정의하여 열 이름을 변경할 수 있습니다.
- Add – 클릭하여 BOM Item Grid에 새 Custom 열을 추가합니다.






