BOM 문서 만들기

개요

이 문서에서는 Altium Designer에서 ActiveBOM 문서(BomDoc)를 생성하고 사용하는 방법을 안내합니다. 프로젝트에 BomDoc를 추가하는 방법부터 프로젝트를 자동으로 컴파일하고 프로젝트의 부품을 가져오는 방식까지 살펴봅니다. 또한 BOM 항목 목록, 사용 가능한 보기 모드, 자주 사용하는 편집 및 필터링 기능, 동일한 부품의 그룹화 방식, 열 구성 방법을 실무 관점에서 설명합니다. 설계에 직접 배치되지 않은 부품을 위해 사용자 정의 BOM 항목과 열을 추가하는 방법도 다룹니다. ActiveBOM을 설정하고 탐색하는 방법을 명확하게 이해하여 프로젝트 BOM을 더욱 효과적으로 관리하고 싶다면, 계속 읽고 자신 있게 다음 단계를 진행해 보세요.

- BomDoc를 생성하는 방법, 프로젝트에 추가했을 때 수행되는 작업, 프로젝트당 하나의 BomDoc만 사용할 수 있다는 주요 제한 사항을 알아봅니다.
- 보기 모드, 열 제어, 편집 도구, 그룹화 동작, 표시 설정 옵션 등 BOM 항목 목록의 구성 방식을 살펴봅니다.
- ActiveBOM이 그룹화된 부품과 사용자 정의 BOM 항목을 처리하는 방식을 이해하여 설계 부품뿐 아니라 추가 프로젝트 항목까지 빠짐없이 관리할 수 있습니다.
AI로 더 깊이 알아보기:

BOM 문서 생성

ActiveBOM에서 작업하는 BOM 문서를 BomDoc이라고 합니다. File » New 하위 메뉴를 통해 프로젝트에 새 BomDoc을 추가하거나 Projects Panel에서 프로젝트를 마우스 오른쪽 버튼으로 클릭합니다. 프로젝트에 컴포넌트가 하나 이상 있으면 Projects Panel의 프로젝트 구조에서 ActiveBOM Entry 옆에 있는 + Create 컨트롤을 클릭하여 새 BomDoc을 생성할 수 있습니다. 각 PCB 프로젝트에는 BomDoc을 하나만 포함할 수 있습니다.

고급 설정 대화 상자에서 BOM.ActiveBOMDesignPreview 옵션을 활성화하면 + Create 컨트롤을 사용할 수 있습니다.

프로젝트에 새 BomDoc을 추가하면 Schematic이 자동으로 컴파일되고 기존의 모든 컴포넌트가 BomDoc에 나열됩니다. Part Choices가 포함된 워크스페이스 라이브러리 컴포넌트의 경우, 아래의 솔루션 이해하기 섹션에서 설명하는 것처럼 인터페이스 하단 Region에 솔루션의 세부 정보가 표시됩니다.

Schematic에 컴포넌트를 추가로 배치하면 해당 컴포넌트가 BomDoc에 자동으로 추가됩니다. 컴포넌트 목록 위에 있는 Add new 버튼을 통해 ActiveBOM에서 직접 BOM Item과 매개변수를 수동으로 추가할 수도 있습니다. 자세한 내용은 Custom BOM Item 및 열 섹션을 참조하세요.

  • BomDoc을 열면 프로젝트가 자동으로 컴파일되고 설계 부품 목록과 해당 부품의 공급망 세부 정보가 새로 고쳐집니다. 대규모 설계를 처음 열 때는 이 작업에 시간이 걸릴 수 있으며, BomDoc을 열기만 했는데도 수정된 파일로 표시될 수 있습니다.
  • 프로젝트에 연결된 워크스페이스에서 편집한 후 다시 저장한 컴포넌트가 포함되어 있으면, BomDoc을 활성화할 때 자동으로 새로 고쳐집니다. Revision Status 열에는 변경된 컴포넌트의 Out of date 상태가 표시되므로, 어떤 컴포넌트를 최신 리비전으로 업데이트해야 하는지 바로 확인할 수 있습니다. 
  • 각 설계 프로젝트에는 BomDoc을 하나만 포함할 수 있습니다.

BOM Item 목록

BomDoc의 상단 Region에는 PCB 설계 프로젝트에서 감지된 모든 컴포넌트와 BomDoc에 직접 추가한 BOM Item이 표 형식으로 나열됩니다. 이 Region을 BOM Item 목록이라고 합니다.

Base 보기에서 표시되는 컴포넌트 목록, 즉 BOM Item 목록입니다.
Base 보기에서 표시되는 컴포넌트 목록, 즉 BOM Item 목록입니다.

BOM Item을 표시하는 보기 모드는 3가지입니다. 목록 위의 버튼을 사용하여 필요한 모드를 선택하세요.

Flat view button, click to display each BOM Item in its own row in the BOM Item list  Flat view - 각 컴포넌트를 한 행에 표시합니다.

Base view button, click to cluster common BOM Items into the same row in the BOM Item list Base view - 프로젝트의 고유한 컴포넌트마다 한 행에 표시하며, Designator 열에는 해당 유형의 모든 컴포넌트의 Designator가 나열됩니다. 그룹화된 Designator에는 여러 표시 옵션을 사용할 수 있습니다. Properties Panel에서 필요한 Designator Grouping 모드를 선택하세요.

Consolidated view button, click to display a consolidated BOM when the project includes variants Consolidated view - 프로젝트에 배리언트가 포함된 경우 모든 배리언트의 통합 BOM을 표시하는 데 사용합니다.

BOM Item 목록 편집 기능

컴포넌트 목록은 다음을 비롯한 다양한 스프레드시트 형태의 편집 기능을 지원합니다.

  • Properties Panel의 Column 탭에서 열을 표시하거나 숨기고 열 이름의 별칭을 정의할 수 있습니다. 별칭은 열 속성 입력 대화 상자에서도 정의할 수 있습니다. 이 대화 상자는 BomDoc의 열 머리글 Region에서 열 이름을 마우스 오른쪽 버튼으로 클릭한 다음 상황에 맞는 메뉴에서 Rename Column 명령을 선택하여 열 수 있습니다. 생성된 BOM 출력에서는 별칭이 열 이름으로 사용됩니다.
  • BomDoc의 열 머리글 Region에서 열 이름을 마우스 오른쪽 버튼으로 클릭한 다음 Select Columns을(를) 선택하여 여는 Select Columns 대화 상자에서도 열을 추가하거나 제거할 수 있습니다.

    Select Columns 대화 상자
    Select Columns 대화 상자

    SiliconExpert 또는 Z2Data 통합 기능을 사용하는 경우 각 서비스의 매개변수 열도 선택할 수 있습니다. 자세한 내용은 SiliconExpert에서 부품 데이터 가져오기 및 Z2Data에서 부품 데이터 가져오기 페이지를 참조하세요.
  • 드래그 앤 드롭으로 열 순서를 변경합니다.
  • 원하는 열을 기준으로 정렬하고, Shift을(를) 누른 상태에서 다른 열을 선택하여 하위 정렬 기준을 추가합니다.
  • 필터 아이콘을 클릭하여 열 값을 기준으로 필터링합니다. Grid displays include a Filter icon, click this to configure filtering based on values present in this column
  • 표준 Windows 선택 방법으로 셀을 선택합니다.
  • ActiveBOM에서 셀 내용을 복사하고, 외부 스프레드시트 Editor의 값을 Custom ActiveBOM 열에 붙여넣습니다.
  • BOM이 Base 보기일 때 사용자 지정 행 번호를 정의할 수 있습니다. Base 보기에서 Set line numbers 버튼(Set Line Numbers button, click the arrow to configure line numbering)을 클릭하면 각 행에 행 번호가 추가됩니다. 버튼 오른쪽의 드롭다운 아이콘을 클릭하면 행 번호 옵션 대화 상자가 열리며, 여기에서 시작값과 증가값을 정의할 수 있습니다. 자세한 내용은 행 번호 열 섹션을 참조하세요.
  • Add New 드롭다운(Add new button, click to add an additonal row or column to the BomDoc)을 클릭하여 행이나 열을 추가합니다. 자세한 내용은 Custom BOM Item 및 열 섹션을 참조하세요.
  • Group by 버튼(Group by button, use this to group the grid by the enabled column)을 클릭하여 활성화된 열을 기준으로 Grid를 그룹화합니다. 여러 그룹화 기준 열을 활성화할 수 있으며(이미지 보기), 드래그 앤 드롭으로 순서를 변경할 수 있습니다. 이는 Grid 표시 기능으로, Bill of Materials 명령을 실행할 때 그룹화가 Report Manager 대화 상자로 전달되지는 않습니다.
  • Reset Supply Chain 버튼()을 클릭하면 선택한 BOM Item에서 사용자 정의 솔루션 순위와 수동으로 지정한 SPN 우선순위가 제거됩니다.
  • BOM Item 그리드의 현재 구성은 BOM 세트로 저장할 수 있습니다. 자세한 내용은 BOM Item Grid 표시 구성 및 저장 섹션을 참조하세요.
  • 표준 Windows 바로 가기 키를 사용하여 BOM Item 목록을 스크롤할 수 있습니다.
    • 세로 스크롤 = MouseWheel Roll
    • 가로 스크롤 = Shift + MouseWheel Roll

여러 구성 및 BOM 표시 옵션은 ActiveBOM Properties 패널에서 설정합니다.

동일한 컴포넌트 식별

ActiveBOM은 Base 및 Consolidated 보기에서 동일한 컴포넌트를 그룹화하기 위해 다음 방식을 사용합니다.

  • 워크스페이스 라이브러리 컴포넌트 - DesignItemID 기준.
  • 워크스페이스 라이브러리가 아닌 컴포넌트 - DesignItemID 및 Library Name, 그리고 컴포넌트 그룹화 대화 상자에서 활성화한 컴포넌트 매개변수 기준. 이 방식을 사용하면 설계자는 라이브러리에 워크스페이스 라이브러리가 아닌 범용 컴포넌트를 생성한 다음, 배치 후에 구체적인 컴포넌트 정보를 입력할 수 있습니다. Component Grouping 대화 상자에서 기본적으로 활성화된 매개변수는 Comment, Description, Value입니다. ActiveBOM Properties 패널에서 컴포넌트 그룹화 Edit 버튼을 클릭하면 대화 상자가 열립니다. 이 버튼은 설계에 워크스페이스 라이브러리가 아닌 컴포넌트가 있는 경우에만 사용할 수 있습니다.

컴포넌트 그룹화 참고 사항:

  • Component Grouping 대화 상자는 동일한 컴포넌트를 식별하여 그룹화하는 데 사용됩니다. PCB 컴포넌트 속성과 같은 다른 매개변수/속성도 Component Grouping 대화 상자에 나열할 수 있지만, 동일한 컴포넌트를 정의하는 데는 컴포넌트 매개변수만 사용할 수 있습니다.
  • 상면 컴포넌트와 하면 컴포넌트를 그룹화하는 등 다른 목적으로 BomDoc 또는 사용자 정의 BOM에서 컴포넌트를 그룹화하려면 List 보기로 전환한 다음 ActiveBOM의 Group by 버튼(이미지 보기)을 사용하거나, Report Manager의 열 그룹화 기능(이미지 보기)을 사용하세요. ActiveBOM Group by 드롭다운 목록에서 사용할 수 있는 매개변수는 Properties 패널의 Columns 탭에서 현재 표시하도록 설정된 매개변수입니다.

열 그룹

ActiveBOM 컴포넌트 목록에는 각 보기 모드에 표시되는 별도의 열 그룹이 있으며, 위 이미지는 Base 보기를 보여 줍니다.
ActiveBOM 컴포넌트 목록에는 각 보기 모드에 표시되는 별도의 열 그룹이 있으며, 위 이미지는 Base 보기를 보여 줍니다.

BOM Item 그리드는 다음과 같은 주요 그룹으로 나뉩니다.

  1. Item Details (이미지에서 주황색으로 강조 표시) - 이 열에는 Designator, 설명, 라이브러리 참조 및 기타 컴포넌트 매개변수와 같은 컴포넌트의 매개변수 정보가 표시됩니다.
  2. Solutions (이미지에서 녹색으로 강조 표시) - 공급망에서 순위가 가장 높은 제조업체 + 공급업체를 표시합니다. 솔루션(제조업체 부품) 수와 각 솔루션의 공급업체 수는 ActiveBOM Properties 패널에서 구성하며, 공급업체 타일의 단색 배너로 표시됩니다. 순위는 자동으로 지정되며, 아래 솔루션 이해 섹션에서 설명하는 것처럼 수동으로 정의할 수도 있습니다.
  3. BOM Status (이미지에서 청록색으로 강조 표시) - 각 컴포넌트와 관련된 현재 위험을 나타냅니다. 아이콘 위에 마우스를 올리면 설명이 표시됩니다. 또는 Properties 패널에서 상세 BOM Status 열을 활성화하여 설명을 표시할 수 있습니다.
Consolidated 보기에서는 BOM Status 열 바로 앞에 Variants이라는 추가 그룹이 표시됩니다. 이 그룹에는 각 Variant에 대해 한 쌍의 열이 포함되며, 각 컴포넌트의 수량과 단가가 표시됩니다(이미지 보기). 자세한 내용은 Variant 작업 섹션을 참조하세요.
열 표시와 별칭 정의는 ActiveBOM Properties 패널의 Columns 섹션에서 관리할 수 있습니다. 사용자 정의 행, 컴포넌트 또는 열을 추가하려면 컴포넌트 목록 위의 Add new 버튼을 클릭하세요.

Custom BOM Item 및 열

Image showing a custom row being added to a BomDoc

PCB 설계 프로젝트의 BOM을 관리하려면 회로도와 PCB에 배치된 컴포넌트 및 BOM Item뿐 아니라 아직 상세 정보가 정해지지 않은 부품, 체결 부품, 베어 보드 또는 장착용 접착제 등도 관리해야 합니다. PCB 설계 프로젝트에서는 사용자 정의 BOM Item 또는 매개변수가 사용되는 경우가 많습니다. 이러한 상황에 대응하기 위해 ActiveBOM은 BOM Item과 열(매개변수)을 추가하는 기능을 지원하며, 추가한 항목은 생성되는 BOM에 포함할 수 있습니다.

  • Custom row -  설계에서 고려해야 하는 사용자 정의 BOM Item(베어 보드, 접착제 등)을 손쉽게 추가할 수 있습니다. 사용자 정의 행의 모든 필드는 사용자가 정의합니다. 사용자 정의 행은 ActiveBOM에서 관리하지 않습니다. 예를 들어 수량을 3으로 설정해도 Flat 보기에 개별 항목 3개가 표시되지는 않습니다. 사용자 정의 행에서는 공급망 검색도 지원되지 않습니다.
  • Custom column - ActiveBOM에서 관리하는 추가 BOM 열로, 사용자가 정의한 모든 텍스트를 포함할 수 있습니다.
  • Custom Item - 추가 BOM Item으로, 일반적으로 필요하지만 아직 구체적인 정보가 정해지지 않았거나 라이브러리에 아직 없는 항목에 사용합니다. 이를 통해 해당 항목의 비용을 전체 보드 비용 추정에 포함할 수 있습니다.
  • Managed Component - BOM 문서에서 수동으로 관리하는 추가 BOM Item입니다. Component Search 대화 상자가 열리며, 현재 연결된 워크스페이스의 컴포넌트가 나열됩니다.

    Component Search 대화 상자는 Manufacturer Part Search 패널에 적용된 기본 검색 엔진 기능과 보기를 사용합니다. Manufacturer Part Search 패널은 Altium Parts Provider 서비스를 활용하여 컴포넌트 제조업체 및 공급업체 데이터 검색에 중점을 두는 반면, Component Search 대화 상자에는 워크스페이스 라이브러리 및 파일 기반 라이브러리 소스에서 바로 배치할 수 있는 컴포넌트가 표시됩니다.

    선택한 추가 BOM Item은 마우스 오른쪽 버튼 클릭 메뉴의 Operations 하위 메뉴에서 언제든지 변경할 수 있습니다.
    • Properties 패널의 Column 탭을 사용하면 열의 표시 여부, 이름 또는 별칭을 빠르게 찾고 확인하고 관리할 수 있습니다. 열 이름에 별칭이 정의되어 있으면 BOM Item 그리드에 해당 별칭이 표시됩니다.
    • ActiveBOM에서 추가한 모든 추가 BOM Item과 파라미터는 다른 BOM 출력에서도 사용할 수 있으며, 소프트웨어 API를 통해서도 사용할 수 있습니다.
사용자 지정 행, 열 또는 항목의 필드는 ActiveBOM 문서가 Base View 모드일 때만 편집할 수 있습니다.

 

관리형 컴포넌트 또는 Custom Item의 인스턴스 추가

관리형 컴포넌트 또는 Custom Item을 추가한 후 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 Operations » Add Instances of 명령을 선택하여 Add to BOM Components 대화상자를 엽니다. 이 대화상자에서 BOM에 추가할 컴포넌트의 인스턴스 수를 정의합니다.

Designator prefix, 선택 사항인 Separator(X-1 또는 X:1와 같은 결과를 얻도록 정의할 수 있음), 필요한 컴포넌트의 Quantity 을 지정합니다. 이 값은 Designator 범위를 정의하는 데 사용되며 ActiveBOM의 Quantity 열에도 표시됩니다. 설명과 같은 다른 모든 파라미터는 BOM Item 그리드에서 직접 편집할 수 있습니다.

관리형 컴포넌트 또는 Custom Item 변경/제거

Designator를 편집하거나 관리형 컴포넌트 또는 Custom Item의 인스턴스를 제거하려면 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 Operations » Edit item 명령을 선택합니다. Change / Remove 대화상자가 열립니다.

데이터 소스

ActiveBOM에서 사용할 수 있는 기본 데이터 소스는 Schematic 컴포넌트 파라미터(Icon indicating that this parameter was sourced from a schematic component), 워크스페이스 콘텐츠의 워크스페이스 컴포넌트 파라미터(Icon indicating that this parameter was sourced from a Workspace Library component stored), ActiveBOM에서 제공하는 데이터(Icon indicating that this parameter was sourced from the ActiveBOM document (BomDoc))입니다. ActiveBOM은 이러한 소스를 바탕으로 기본 프로젝트 BOM Item 그리드를 생성합니다. 데이터 소스의 활성화 및 표시 여부는 ActiveBOM Properties 패널의 Columns 탭에서 제어합니다.

Columns 목록 위에 있는 해당 Sources 버튼을 활성화하면 BOM에 다음 추가 데이터 소스의 정보도 포함할 수 있습니다.

Click the PCB source button to include parameters from the PCB The PCB - 이 옵션을 활성화하면 각 컴포넌트의 PCB 위치/회전/기판 면 데이터가 사용 가능한 Columns에 포함됩니다. 프로젝트에 PCB 문서가 여러 개 있으면 Choose PCB to Use 대화상자가 열리며, 여기에서 필요한 PCB를 선택할 수 있습니다.

Click the Database source button to include parameters from the database (database components only) Database - 외부 데이터베이스에서 추가 컴포넌트 파라미터를 불러옵니다(*.DbLib, *.SVNDbLib 또는 *.DbLink 사용).

Click the Altium Cloud Services source button to include parameters from the Altium Parts Provider Altium Cloud Services - 이 옵션을 활성화하면 Altium Parts Provider에서 식별되어 공급망 솔루션이 표시되는 BOM Item에 대해 다양한 추가 컴포넌트 데이터에 액세스할 수 있습니다.

Click the Document Parameters source button to include parameters from the project schematic documents Document Parameters - 이 옵션을 활성화하면 PCB 프로젝트의 모든 Schematic에서 감지된 모든 Schematic 문서 파라미터가 사용 가능한 Columns에 포함됩니다.

각 파라미터의 소스는 열 목록의 아이콘으로 표시됩니다.
각 파라미터의 소스는 열 목록의 아이콘으로 표시됩니다.

  • Columns 목록 위의 버튼으로 해당 데이터 소스를 활성화하거나 제거할 수 있습니다. 소스를 비활성화하면 해당 소스의 모든 데이터가 그리드에서 제거됩니다.
  • Columns 목록 아래의 체크박스는 Columns 목록에 사용할 수 있는 편리한 필터입니다. 이를 사용하면 그리드에서 데이터를 제거하지 않고도 Columns 목록에서 데이터 소스를 추가하거나 제거할 수 있습니다.

Altium Parts Provider를 사용하는 것 외에도 ODBC 연결을 통해 기존 회사 데이터베이스에 연결할 수 있습니다. 이를 위해서는 Altium Designer에서 Custom Parts Provider Synchronization 기능을 활성화하고(Configure Platform 페이지(Importers\Exporters 아래)에서 Custom Data Synchronization 옵션 선택), Preferences 대화 상자의 Data Management - Parts Providers 페이지에서 이를 공급자로 활성화해야 합니다. 이 기능을 사용하면 회사 데이터베이스를 워크스페이스 부품 공급자처럼 활용할 수 있습니다.

자세한 내용은 Part Source Configuration 페이지(Altium 365 워크스페이스, Enterprise Server 워크스페이스)에서 Custom 데이터베이스 부품 공급자에 관한 내용을 참조하세요.

행 번호 열

조립 도면이 포함된 PCB 설계나 설계 엔지니어, 원가 엔지니어 또는 구매 전문가 간의 BOM 데이터 교환에서 BOM 행 번호(BOM Item 위치 번호)는 각 BOM 행을 개별적으로 구분하는 간단한 방법입니다. 이를 통해 설계에서 해당 지시선, 컴포넌트 및 도해를 명확하게 식별하거나 find할 수 있습니다.

프로젝트 BOM 데이터 소스인 ActiveBOM은 프로젝트 BOM에 대해 사용자 정의 Line #을 지원하며, 수동 및 자동 Line #(BOM Item 위치 번호) 관리 기능을 모두 제공합니다.

  • 모든 프로젝트 BOM Item의 위치 번호를 자동으로 설정하려면(Base 보기에서) Set Line # 버튼을 클릭합니다. 행 번호는 Item Details 열 그룹의 Line # 열에 표시됩니다. 버튼 오른쪽의 드롭다운 아이콘을 클릭하면 시작 값과 증가 값을 정의할 수 있는 Line # Options 대화 상자가 열립니다.

    Line Number Options 대화 상자
    Line Number Options 대화 상자

    • Start number - 첫 번째 Line # 셀이 비어 있을 때 사용할 값입니다.
    • Increment - 비어 있는 각 Line # 필드의 값을 이 값만큼 증가시킵니다.
    대화 상자에 입력한 값은 이후 Line # 명령을 사용할 때도 유지됩니다.
  • Line #을 수동으로 변경하려면 Base 보기 모드로 전환한 다음 Line # 열에서 필요한 셀을 선택하고 다음 작업을 수행합니다.
    • 키보드에서 Delete 키를 눌러 셀을 지운 다음,
    • 새 값을 직접 입력하거나,
    • Windows 클립보드에서 값 범위를 붙여넣습니다.
  • 번호를 다시 매기거나 직접 추가한 번호부터 이어서 번호를 매기려면 원하는 항목의 Line # 셀을 클릭한 다음 Set Line # Set Line Number button 버튼을 클릭합니다. Line Numbering 대화 상자가 열리면 기존 번호를 기준으로 사용하여 바로 위의 가장 가까운 비어 있지 않은 셀부터 시작해 선택한 빈 셀 또는 모든 빈 셀에 연속 번호를 매기거나(Continue numbering), 기존 번호를 모두 삭제하고 모든 행의 번호를 다시 매길 수 있습니다(Renumber all). 추가되는 번호는 Line # Options 대화 상자에서 마지막으로 정의한 기준 값과 증가 값을 사용해 계산됩니다. 필요한 경우 선택한 Line # 셀에 초기값을 입력하여 시작 번호를 정의할 수 있습니다.

    ActiveBOM 문서(*BomDoc)에서 행 번호 중 일부가 이미 정의되어 있으면 Line numbering 대화 상자의 Continue numbering 유형이 열립니다.

    ActiveBOM 문서(*BomDoc)에서 모든 행 번호가 이미 정의되어 있으면 Line numbering 대화 상자의 Renumber all 유형이 열립니다.

Line # 관리 기능은 Base 보기 모드에서만 사용할 수 있습니다.

BOM Item 그리드 표시 구성 및 저장

다른 우수한 스프레드시트 애플리케이션과 마찬가지로 BOM Item 그리드도 요구 사항에 맞게 구성할 수 있습니다. 일반적인 열 순서 변경 및 정렬 기능뿐 아니라 현재 구성을 BOM Set으로 저장할 수도 있습니다.

BOM Set 사용하기

BOM Item 그리드 구성은 개수 제한 없이 저장할 수 있으며, 각각을 BOM Set이라고 합니다. 요구 사항에 맞게 그리드를 구성한 후 ActiveBOM Properties 패널의 BOM Sets 영역에서 Add 버튼을 클릭하여 목록에 BOM Set을 추가합니다.

눈 모양 아이콘을 클릭하여 BOM Set을 활성화합니다.
눈 모양 아이콘을 클릭하여 BOM Set을 활성화합니다.

BOM Set은 ActiveBOM Properties 패널에서 구성합니다.

Report Manager에서 BOM을 생성할 때 원하는 BOM Set을 선택할 수 있습니다.

컴포넌트 교체

BomDoc을 검토하고 부품 주문을 준비하는 과정에서 컴포넌트의 문제가 발견되는 경우는 드물지 않습니다. 예를 들어 설계자가 컴포넌트 선정을 마무리하는 것을 잊었거나, 컴포넌트가 단종(EOL)되어 대체 가능한 부품의 가격과 공급 가능 여부를 알아보려는 경우가 있습니다. 이전에는 이를 해결하려면 회로도로 돌아가 컴포넌트를 편집하고 적절한 부품을 선택한 다음 BomDoc을 새로 고쳐야만 했습니다.

또는 BomDoc에서 컴포넌트를 변경한 다음 설계 변경 지시(ECO)를 통해 해당 변경 사항을 회로도에 반영할 수 있습니다. 선택한 컴포넌트를 마우스 오른쪽 버튼으로 클릭하고 Operations » Change <ComponentName> 명령을 선택합니다. 컴포넌트 교체 대화 상자가 열리면 교체할 컴포넌트를 검색할 수 있습니다.

An existing part can be replaced via the right-click menu The Replace Component dialog is used to replace an existing component

Replace Component OK 버튼을 클릭하면 Engineering Change Order 대화 상자가 열리고, 회로도를 BomDoc과 동기화하는 데 필요한 변경 사항이 상세히 표시됩니다.

  • 컴포넌트 교체 기능은 현재 연결된 워크스페이스에서 새 컴포넌트를 검색합니다. 검색 결과에 적합한 컴포넌트가 없으면 대화 상자에 Manufacturer Part Search 패널을 여는 링크가 표시됩니다. 이 패널에서 마우스 오른쪽 버튼을 클릭하여 컴포넌트를 자신의 워크스페이스로 Acquire(Create New Component 대화 상자 및 컴포넌트 Editor 사용)하거나, 컴포넌트를 zip 압축 파일의 통합 라이브러리 패키지로 로컬에 Download할 수 있습니다. 이러한 명령은 Manufacturer Part Search 패널에서 선택한 부품에 Altium Designer 모델이 포함된 경우에만 사용할 수 있습니다(Icon that displays when a part includes schematic and PCB design models 아이콘 확인).
  • Replace Component 대화 상자의 검색, 카테고리 및 필터 기능을 사용하는 대신, 검색 결과를 마우스 오른쪽 버튼으로 클릭하여 Find Similar Components 대화 상자를 열 수도 있습니다. 이 대화 상자는 마우스 오른쪽 버튼으로 클릭한 컴포넌트의 값을 기준으로, 특정 값 범위에서 공통 속성과 파라미터를 공유하는 여러 컴포넌트를 빠르게 찾을 수 있다는 장점이 있습니다(이미지 보기).
  • 컴포넌트 변경이 보드 설계에도 영향을 미치는 경우 Schematic에서 Update PCB도 수행해야 합니다.

ECO 적용에 대해 자세히 알아보세요.

Variant 작업

ActiveBOM은 설계 Variant가 포함된 PCB 프로젝트를 지원합니다. 설계 Variant 기능을 사용하면 하나의 기본 PCB 설계를 만든 후 여러 가지 방식으로 부품을 실장할 수 있습니다. 조립 보드의 각기 다른 실장 구성을 design variant라고 합니다.

설계 Variant 작업:

  • 설계 Variant는 Variant 관리 대화 상자 또는 Variant Manager(Project » Variants)에서 구성합니다.
  • Variant를 확인하려면 아래 이미지와 같이 Projects 패널의 프로젝트 내 Variants 폴더에서 해당 이름을 두 번 클릭합니다.

Image showing how to select a variant of the project

ActiveBOM은 다음과 같은 방식으로 Variant를 지원합니다.

  • 기본 보기 모드 또는 평면 보기 모드에서 특정 Variant의 BOM 표시
  • BOM Item 목록에 미실장 Item을 포함하는 옵션 제공
  • 통합 보기 모드에서 모든 Variant에 사용된 모든 부품의 통합 목록 표시
  • 기본 컴포넌트와 변경된 컴포넌트 모두에 대해 수동 솔루션 정의

기본 보기 모드의 Variant

선택한 Variant에서 이러한 부품을 BOM Item Grid에 포함하려면 Properties 패널의 Show Not Fitted 옵션을 활성화합니다. 이 옵션을 활성화하면 Item 세부 정보에 Fitted 열이 자동으로 표시됩니다.

기본 보기 모드에서 Fitted 열에는 Fitted 또는 Not Fitted이 표시됩니다. 부품이 변경된 경우(이 Variant에서 대체 부품을 선택한 경우), 해당 BOM Item에 대체 부품의 세부 정보가 자동으로 표시됩니다.

현재 Variant는 ActiveBOM 상태 표시줄에 표시됩니다.
현재 Variant는 ActiveBOM 상태 표시줄에 표시됩니다.

통합 보기 모드의 Variant

통합 보기 모드에는 모든 Variant에서 사용된 모든 컴포넌트가 표시됩니다. 통합 보기는 다음 기능을 제공합니다.

  • 컴포넌트가 변경된 경우, 사용된 각 대체 컴포넌트마다 BOM Item이 생성되며 이러한 BOM Item은 모두 동일한 Designator를 갖습니다. 예를 들어 아래 이미지에서 BGA Variant는 TSOP Variant와 다른 색상의 LED를 사용하므로 컴포넌트 DS1과 DS2가 각각 두 번씩 나열됩니다. 컴포넌트 R1은 BGA 및 TSOP Variant가 모두 기본 설계의 원래 저항과 다른 저항을 사용하므로 세 번 표시됩니다.
  • 통합 보기 모드에서 Show Not Fitted 옵션을 활성화하면 Fitted 열에 Fitted 또는 Varied가 표시됩니다. 통합 보기에는 모든 Variant에서 사용된 모든 컴포넌트가 표시되므로, 표시된 모든 컴포넌트는 기본 설계 또는 Variant 중 하나에 실장됩니다.
  • 각 Variant에는 <VariantName> - Qty 열(이 Variant에서 사용된 해당 컴포넌트의 수량 표시)과 <VariantName> - Price 열이 있으며, 후자는 단가에 수량 열의 값을 곱한 값입니다.
  • 일부 설계자는 Variant뿐 아니라 기본 설계에서도 제작 문서를 생성하므로, 기본 설계로 제작할 때 사용되는 해당 컴포넌트의 인스턴스 수를 나타내는 Quantity 열도 제공됩니다. 기본 설계에서 제작 문서를 생성하지 않는 경우 이 열을 숨기세요.
  • 통합 보기 모드의 Grid는 아래와 같이 기본 설계의 해당 셀 값과 다른 값을 가진 셀을 색상으로 표시합니다.

셀의 색상은 해당 셀의 값이 기본 설계에서의 값과 다름을 나타냅니다.
셀의 색상은 해당 셀의 값이 기본 설계에서의 값과 다름을 나타냅니다.

Variant에 대해 자세히 알아보려면 설계 Variant 페이지를 참조하세요.

BomDoc, Schematic 및 PCB 간 작업

BomDoc, Schematic 및 PCB 설계 간 작업을 지원하는 두 가지 기능인 교차 선택과 교차 탐색을 사용할 수 있습니다. 이러한 기능의 동작은 Preferences 대화 상자의 시스템 - 탐색 페이지에서 구성합니다.

두 기능 모두 다른 문서에서 동일한 컴포넌트를 찾는 데 사용할 수 있습니다. 교차 선택과 교차 탐색의 차이점은, 교차 선택 모드는 타겟 문서에서 컴포넌트를 선택하지만 해당 문서를 화면에 띄우지는 않는 반면, 교차 탐색은 타겟 문서를 화면에 띄우며 타겟 문서의 Editor로 전환하여 활성화할 수도 있다는 점입니다.

BomDoc에서 Schematic 및 PCB로 교차 선택하거나 교차 탐색할 수 있지만, Schematic 또는 PCB에서 BomDoc으로는 교차 선택하거나 교차 탐색할 수 없습니다.

교차 선택 모드

교차 선택 모드는 사용하려는 각 Editor에서 활성화해야 합니다. Tools » Cross Select Mode 명령(Shift+Ctrl+X)을 선택합니다. 교차 선택 모드가 활성화되면 메뉴 아이콘이 테두리로 강조 표시됩니다 Cross Select icon, displays in the Tools menu when Cross Selection is enabled in an editor.

교차 선택 모드를 사용하려면 타겟 문서가 열려 있어야 합니다. BomDoc의 BOM Item 목록에서 컴포넌트를 선택하면 타겟 Schematic 및 PCB 문서에서 해당 컴포넌트가 선택되고 화면 중앙에 표시됩니다(Preferences 대화 상자의 시스템 - 탐색 페이지에 있는 Cross Select Mode 옵션에서 Zooming가 활성화된 경우). 타겟 문서가 활성 문서로 표시되지는 않습니다.

BomDoc이 기본 보기 모드인 경우 아래 이미지와 같이 Schematic 및 PCB에서 해당 부품의 모든 인스턴스가 선택됩니다.

교차 선택 모드의 표시 동작은 Preferences 대화 상자의 시스템 - 탐색 페이지에 있는 Cross Select Mode 옵션으로 제어합니다.

타겟 문서는 활성 문서가 되지 않습니다. 따라서 소스 문서와 타겟 문서를 나란히 열어 두는 것이 좋습니다.

Schematic(또는 PCB)에서 BomDoc으로의 교차 선택도 지원됩니다.

교차 선택 기능을 사용하면 BOM Item 목록에서 선택한 컴포넌트를 Schematic 및 PCB에서 찾아 선택할 수 있습니다.
교차 선택 기능을 사용하면 BOM Item 목록에서 선택한 컴포넌트를 Schematic 및 PCB에서 찾아 선택할 수 있습니다.

교차 탐색

교차 선택은 활성화하면 BOM Item 목록을 클릭할 때마다 결과를 표시하는 모드인 반면, 교차 탐색은 사용자가 명시적으로 실행하는 동작입니다.

다음을 선택합니다. Tools » Cross Probe 명령을 메인 메뉴에서 선택하거나 BOM Item을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Cross Probe을 선택하면 Schematic의 해당 컴포넌트로 크로스 프로빙할 수 있습니다. 보드 파일이 열려 있으면 PCB 컴포넌트도 함께 크로스 프로빙됩니다.

크로스 프로빙의 주요 기능 중 하나는 타겟 문서의 Editor로 전환할 수 있다는 점입니다. 크로스 프로빙과 동시에 Editor를 전환하려면 Ctrl 키를 누른 상태에서 Cross Probe 명령을 선택하세요.

마우스 오른쪽 버튼을 클릭하면 Cross Probe 명령을 사용할 수 있으며, 해당 BOM Item에 포함된 각 컴포넌트의 Designator에 대한 Entry가 표시됩니다.
마우스 오른쪽 버튼을 클릭하면 Cross Probe 명령을 사용할 수 있으며, 해당 BOM Item에 포함된 각 컴포넌트의 Designator에 대한 Entry가 표시됩니다.

크로스 프로빙 중에는 메인 설계 창을 분할하거나 Schematic을 새 창에서 열어 BomDoc(소스)과 Schematic(타겟) 문서를 나란히 표시하는 것이 더 효율적입니다. 두 작업에 대한 명령은 모두 문서 탭의 마우스 오른쪽 버튼 클릭 메뉴에서 사용할 수 있습니다.

속성 Panel

활성 문서가 BOM 문서(*.BomDoc)인 경우 Properties Panel에 Document Options이 표시됩니다.

다음 접이식 섹션에는 사용 가능한 옵션과 컨트롤에 대한 정보가 나와 있습니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents