네비게이터 패널
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
개요
- Navigator Panel에서 개별 Schematic 시트, 전체 프로젝트 및 설계 계층 구조를 탐색하여 연결된 객체를 빠르게 찾는 방법을 알아보세요.
- Panel에서 Schematic으로, Schematic에서 다시 Panel로 양방향으로 탐색하는 방법과 Alt 키를 누른 상태로 클릭하여 관련 PCB 항목의 위치를 확인할 수 있는 경우를 살펴보세요.
- 하이라이트, 확대/축소, 흐리게 표시 및 유효성 검사가 탐색 중 화면 표시에 어떤 영향을 주는지 이해하고, 복잡한 설계의 연결 관계를 더 쉽게 파악해 보세요.
설계 규모가 크고 여러 시트에 걸쳐 있으면 Schematic을 눈으로 확인하는 것만으로는 Net을 추적하고 설계의 연결 상태를 검증하기 어려울 수 있습니다. PCB에서 동일한 객체를 찾는 것은 더욱 어렵습니다. 이 작업을 돕기 위해 Navigator Panel을 사용합니다.

Navigator Panel을 통해 전체 설계를 살펴보세요. Alt 키를 누른 상태에서 Panel을 클릭하면 PCB에서도 해당 Item을 찾을 수 있습니다.
Navigator Panel에서는 활성 소스 Schematic 문서 또는 활성 프로젝트의 모든 소스 Schematic 문서를 탐색할 수 있습니다. 이 Panel은 백그라운드에서 자동으로 생성되는 설계의 연결 모델을 탐색의 기반으로 사용합니다. 또한 PCB의 컴포넌트, 패드, 버스 및 Net을 탐색하는 데도 사용할 수 있습니다.
설계 탐색
탐색은 두 가지 방법으로 수행할 수 있습니다. Navigator Panel을 클릭하여 Schematic에서 해당 객체를 찾거나, Schematic의 객체를 클릭하여 Navigator Panel에서 해당 객체를 찾을 수 있습니다.
Navigator Panel에서 탐색
Navigator Panel을 표시하려면 소프트웨어 오른쪽 하단의 Panels 버튼을 사용하거나 메뉴에서 View » Panels » Navigator을 선택합니다.
Schematic을 열면 컴포넌트 및 연결 정보가 즉시 Panel에 로드됩니다. Documents 영역의 아이콘을 클릭하여 정보를 표시합니다. 소프트웨어는 전체 프로젝트에 대한 동적 데이터 모델을 자동으로 구축하고, 편집 작업이 수행될 때마다 이 모델을 유지 관리합니다. 모든 Schematic 시트의 문서 탭이 그래픽 편집 영역 상단에 표시되는 것은 아닙니다. 시트는 백그라운드에서 열리며, 사용자가 해당 시트에서 작업을 수행할 때만 탭이 나타납니다.
동적 데이터 모델은 각 Editor와 Navigator Panel에서 사용할 수 있습니다. Panel의 내용이 설계의 현재 상태와 일치하는지 확실하지 않다면 Validate Project 명령을 선택하여 모델을 강제로 새로 고칩니다(Project 메뉴 또는 Navigator Panel의 마우스 오른쪽 버튼 컨텍스트 메뉴).

Navigator Panel에서 객체를 클릭하면 전체 설계에서 해당 객체의 모든 인스턴스를 찾을 수 있습니다.
대화형 탐색
Panel에 표시된 객체 목록에서 객체를 클릭하여 그래픽 영역에서 찾을 수 있을 뿐만 아니라, 그래픽 영역에서 목록으로 역방향 탐색도 할 수 있습니다. 이를 대화형 탐색이라고 하며, Navigator Panel 상단의 Interactive Navigation 버튼을 클릭하여 이 모드를 시작합니다. 커서가 십자 모양으로 바뀌어 탐색 모드임을 나타내며, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 누를 때까지 이 모드가 유지됩니다.
설계를 탐색하면 현재 강조 표시 옵션에 따라 시트 표시가 업데이트되고, Navigator Panel도 업데이트되어 그래픽 편집 창에서 현재 선택한 항목과 관련된 정보를 보여줍니다.

대화형 탐색을 실행한 다음( Navigator Panel 상단의 버튼), 시트의 객체를 클릭하면 Panel과 설계의 나머지 부분에서 해당 객체를 찾을 수 있습니다.
대화형 탐색 단축키
Navigator Panel에서 대화형 탐색을 시작하는 것 외에도, Schematic Editor에서 언제든지 Alt 키를 누른 상태로 설계 객체를 클릭하여 탐색을 실행할 수 있습니다. 와이어, Net 레이블, 포트, 시트 Entry, 시트 심볼 또는 컴포넌트를 포함한 모든 객체를 클릭할 수 있습니다.
Alt+클릭 단축키를 사용하여 설계를 탐색하세요.
탐색 중 객체가 강조 표시되는 방식
Navigator Panel에서 객체를 클릭하면 해당 객체가 그래픽 편집 영역에 표시됩니다. 객체가 표시되는 방식은 Preferences 대화 상자의 시스템 - 탐색 설정에 따라 달라집니다. Navigator Panel에서 설정에 바로 접근하려면 Panel 상단의 Navigation Options 버튼을 클릭하여 대화 상자를 엽니다.
Preferences 대화 상자의 Highlight Methods 영역에는 Panel 또는 문서 자체에서 탐색할 때 문서에 적용되는 임시 필터링의 시각적 결과를 제어하는 옵션이 있습니다. 이 옵션들은 원하는 조합으로 활성화할 수 있습니다. 예를 들어, 설계 Editor 창에서 필터링된 모든 객체를 확대하고 선택하는 동시에, 다른 설계 객체를 흐리게 표시하여 화면을 간결하게 만들 수 있습니다.
Navigator Panel
Navigator Panel에서는 설계의 연결 모델을 확인할 수 있습니다. 설계 구조는 Panel의 네 섹션에 표시되며, 각 섹션은 아래에서 설명합니다.
Navigator Panel은 전체 설계를 연결 관계 중심으로 보여줍니다.
문서 섹션
Panel 상단의 Documents 섹션에서는 세 가지 방식으로 설계를 볼 수 있습니다. 즉, individual sheets, flattened hierarchy(전체 프로젝트), 또는 full design hierarchy 탐색 방식입니다. 이 첫 번째 섹션의 아이콘을 한 번 클릭하면 데이터가 Panel에 로드되고, 두 번 클릭하면 그래픽 편집 공간에도 결과가 표시됩니다.
문서 섹션의 기능
문서 섹션 |
|
| Individual Sheets | 작성된 각 Schematic 시트의 아이콘을 표시하며, 각 아이콘은 한 번 클릭하면 Navigator Panel에 결과가 표시되고, 두 번 클릭하면 그래픽 편집 공간에도 결과가 표시됩니다. |
| Flattened Hierarchy (전체 프로젝트 |
전체 프로젝트의 모든 객체와 연결 관계를 표시합니다. 설계에 반복 시트(채널)가 있으면 각 채널 클래스에 대한 하위 아이콘이 표시되며, 이 아이콘은 채널 이름(반복 시트의 한 번 클릭하면 Navigator Panel에 결과가 표시되고, 두 번 클릭하면 그래픽 편집 공간에도 결과가 표시됩니다. |
| Full Design Hierarchy | 프로젝트의 모든 Logical 시트에 대한 아이콘을 표시합니다. 설계에 반복 시트(채널)가 있으면 각 채널에 대한 시트 아이콘이 표시되며, 각 아이콘은 한 번 클릭하면 Navigator Panel에 결과가 표시되고, 두 번 클릭하면 그래픽 편집 공간에도 결과가 표시됩니다. 반복 채널의 아이콘을 두 번 클릭하면 해당 채널의 시트가 표시되고, Schematic 편집 공간 하단에서 해당 채널의 탭이 선택됩니다. |
컴포넌트 섹션
Panel의 두 번째 영역에는 첫 번째 섹션에서 현재 선택한 문서에 있는 모든 컴포넌트가 포함됩니다. 목록에서 최상위 컴포넌트 인스턴스 Entry를 선택하면 해당 Entry를 기준으로 필터가 적용되며, 시각적 결과는 선택한 강조 표시 방법에 따라 결정됩니다. 활성화된 강조 표시 옵션에 Connective Graph 옵션이 포함되어 있으면, 선택한 컴포넌트에 연결된 다른 모든 컴포넌트도 표시됩니다(이러한 컴포넌트를 포함하도록 필터가 확장됨). 연결된 컴포넌트는 녹색 그래프 연결선으로 시각적으로 강조 표시됩니다.
Connective Graph가 활성화되어 있으므로, Panel에서 선택한 컴포넌트에 연결된 각 컴포넌트까지 녹색 선이 그려집니다.
컴포넌트 섹션의 기능
컴포넌트 섹션 |
|
| Information available | 각 컴포넌트 Entry에는 Parameters 및 Implementations(모델) 하위 폴더가 있습니다. 강조 표시 옵션에서 Pins 옵션을 활성화하면 Pins 하위 폴더도 사용할 수 있습니다 |
| When you click | Instance 목록에서 핀 Entry를 클릭하면 Panel의 Net / Bus 섹션에서 해당 핀의 Entry가 선택되고, 해당 Parent Net의 모든 핀이 Panel의 하단 섹션에 나열됩니다. 선택한 핀 Entry를 기준으로 필터도 적용되며, 시각적 결과는 활성화된 강조 표시 방법에 따라 결정됩니다. |
| Connective Graph | Connective Graph 옵션을 활성화한 경우, 선택한 핀의 Parent Net에 연결된 다른 모든 핀도 표시됩니다(이러한 핀을 포함하도록 필터가 확장됨). 연결된 핀의 Parent Net은 빨간색 그래프 연결선으로 시각적으로 강조 표시됩니다 |
Net / 버스 섹션
Panel의 세 번째 섹션에는 탐색 중인 문서(또는 평탄화된 계층 구조)의 모든 Net과 버스가 나열됩니다. Entry를 클릭하면 해당 Net/버스와 연결된 모든 객체(핀, Net 라벨, 포트, 시트 Entry, 시트 간 커넥터)가 활성화된 강조 표시 방식에 따라 설계 Editor 창에 표시됩니다.
Net / 버스 섹션의 기능
Net / 버스 섹션 |
|
| Information available | 선택한 Net/버스에 연결된 다양한 객체 유형은 현재 활성화된 강조 표시 옵션과 현재 선택한 Net/버스에 해당 객체 유형이 존재하는지에 따라 하위 폴더에 나열됩니다. 각 Net/버스에는 연결된 핀/포트/Net 라벨/시트 Entry/시트 간 커넥터를 연결하는 데 사용된 그래픽 선을 나열하는 추가 하위 폴더가 포함될 수 있습니다. 선 Entry를 클릭하면 해당 선 객체만 필터링하고 시각적 제어 설정을 적용합니다. |
| When you click | Panel에 표시하도록 활성화된 모든 Net 객체(그래픽 선 제외)는 Panel의 하단 섹션에 표시됩니다. 여기에서도 객체를 클릭하면 활성화된 강조 표시 방식에 따라 필터링이 적용됩니다. |
버스 Net - Net 핀 섹션
Panel의 네 번째 섹션에 표시되는 내용은 탐색 중인 객체와 표시하도록 설정한 객체라는 두 가지 요소에 따라 달라집니다. Net / 버스 섹션에서 bus을 클릭하면 해당 버스의 Net이 이 Panel 섹션에 나열됩니다. Net / 버스 섹션에서 net을 클릭하면 해당 Net의 핀이 나열됩니다. 해당 Net에 연결된 Net 식별자도 표시가 활성화되어 있으면 함께 나열됩니다.
Signal 섹션
Navigator Panel에서는 일반적인 객체 중심 방식 대신 Signal 중심 방식으로 설계를 볼 수 있습니다. Panel의 Documents 섹션에서 Schematic 문서를 선택한 상태로 Panel 상단의 Show Signals 옵션을 활성화하면 Panel의 세 번째 섹션이 Signal 모드로 전환됩니다.
Signal Entry를 클릭하면 필터가 적용되고 해당 Signal의 노드(핀/포트/Net 라벨/시트 Entry/시트 간 커넥터)가 활성화된 강조 표시 방식에 따라 설계 Editor 창에 표시됩니다. 목록의 각 Signal에는 해당 Signal과 연결된 노드 핀, 시트 Entry 또는 시트 간 커넥터가 나열됩니다. 이러한 Entry는 해당 객체 유형의 표시 옵션이 활성화되어 있는지와 관계없이 표시됩니다.
Signal 섹션의 기능
Signal 섹션 |
|
| Signal | Signal 이름(버스 또는 Net 이름)입니다. |
| Width | 이 Signal에 포함된 개별 Net의 수입니다. |
| Click on a top-level signal entry | 최상위 Signal Entry를 클릭하면 해당 Signal과 연결된 모든 Signal 노드가 Panel의 하단 섹션에 표시됩니다. 여기에는 핀, Net 라벨, 포트, 시트 Entry, 시트 간 커넥터가 포함될 수 있습니다. Entry는 해당 객체 유형의 표시 옵션이 활성화된 경우에만 표시됩니다. |
| Click on a sub-entry | 기본 Signal 목록에서 하위 Entry를 클릭하면 해당 Signal의 Parent Net과 연결된 모든 Net 객체가 Panel의 하단 섹션에 표시됩니다. |
| SignalName Driven By Pin X | Signal과 연결된 노드 핀이 Output 핀 또는 I/O 핀인 경우 표시됩니다. X는 Signal을 구동하는 컴포넌트 핀의 Designator를 나타냅니다. |
| Driving Node Pin X | Signal과 연결된 노드 핀이 입력 핀인 경우 표시됩니다. X는 Signal에 의해 구동되는 컴포넌트 핀의 Designator를 나타냅니다. |
| Driven By Node Sheet Entry SignalName | 시트 Entry 노드의 전기적 유형이 Output 또는 I/O인 경우 표시되며, 이 Entry는 Signal을 구동합니다. |
| Driving Node Sheet Entry X | 시트 Entry의 전기적 유형이 입력인 경우 표시되며, 이 Entry는 Signal에 의해 구동됩니다. |
PCB 탐색
Navigator Panel에서 클릭하여 Schematic의 객체를 탐색할 때 PCB의 해당 객체도 동시에 탐색할 수 있습니다. Alt 키를 누른 상태에서 Navigator Panel의 객체를 클릭하면 타겟 객체가 Schematic과 PCB 양쪽에서 강조 표시됩니다.
탐색은 항상 Schematic에서 이루어지므로 PCB의 객체를 탐색하려면 Schematic과 PCB를 동시에 표시해야 합니다. PCB를 별도의 창에 표시하거나 Split Vertical 또는 Split Horizonal 기능을 사용하여 그래픽 공간을 나누면 됩니다(아래에는 세로 분할이 표시됨). 각 명령은 문서 탭을 마우스 오른쪽 버튼으로 클릭하면 나타나는 컨텍스트 메뉴에서 사용할 수 있습니다.
Alt 키를 누른 상태에서 설계를 탐색하면 PCB에서도 해당 객체를 찾을 수 있습니다.
Altium Designer에는 다음을 비롯하여 Schematic과 PCB 간 작업을 위한 다양한 기능이 포함되어 있습니다.
| Cross probe | 교차 탐색 - 마우스 오른쪽 버튼을 클릭하여 실행한 다음, 한 Editor에서 객체(컴포넌트, 핀, Net)를 클릭하면 다른 Editor의 해당 객체로 이동합니다. continuous(원본 Editor에 머무름)와 jump-to(타겟 Editor/문서를 활성 문서로 설정)의 두 가지 모드가 있습니다. 교차 탐색 중 Ctrl을 누르고 있으면 jump-to 모드가 실행됩니다. 교차 탐색은 Schematic, PCB 및 BOM Editor, 제약 조건 관리자, Project, Navigator, Messages Panel에서 지원됩니다. |
| Cross select | 한 Editor에서 컴포넌트를 클릭하여 선택하면 다른 Editor에서도 해당 컴포넌트가 선택됩니다. Schematic과 PCB Editor 간에 지원되며, View 메뉴에서 활성화할 수 있습니다. |
Navigator Panel 컨텍스트 메뉴
Navigator Panel의 마우스 오른쪽 버튼 컨텍스트 메뉴에는 다음 명령이 포함되어 있습니다.
)
)
)


).
).
).

)
