회로도에서 회로 연결성 만들기
Altium Essentials: Creating Hierarchy
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
개요
- Physical 연결과 Logical 연결의 차이점과 Schematic에서 각 방식이 유용한 경우를 알아봅니다.
- 와이어, Net 라벨, 포트, 전원 포트, 버스, 시트 엔트리 등 연결을 구성하는 Schematic 객체를 살펴봅니다.
- Altium Designer에서 Connectivity Insight와 관련 선택 및 강조 표시 도구를 사용해 연결을 검사하고 탐색하는 방법을 알아봅니다.
컴포넌트와 컴포넌트 간의 연결 방식이 여러분만의 고유한 전자 회로를 만듭니다. Schematic에서는 컴포넌트 핀을 서로 연결하여 설계의 Logical 표현을 생성합니다. 인쇄 회로 기판을 설계할 때는 Physical 컴포넌트를 배치하고 라우팅을 통해 동일한 연결 관계를 구현합니다.
Physical 및 Logical 연결 관계
Schematic에서 한 컴포넌트에서 다른 컴포넌트로 와이어를 그려 연결 관계를 만들 수 있습니다. 이를 Physical 연결 관계라고 합니다.
각 컴포넌트 핀에 짧은 와이어와 Net 레이블을 배치하여 핀을 서로 연결할 수도 있습니다. 소프트웨어는 이 두 Net 구간을 식별하고 연결하여 하나의 Net을 형성합니다. 이러한 연결 방식을 Logical 연결 관계라고 합니다.
Physical 연결 관계를 사용하면 회로를 살펴볼 때 각 와이어를 따라갈 수 있지만, 와이어가 많으면 Schematic이 빽빽하고 복잡해질 수 있습니다. 반면 Net 레이블은 배선량을 줄여 주지만, 사용자가 가능한 모든 연결을 찾으려면 시트 전체를 살펴봐야 합니다. 설계자는 두 방식을 혼합하는 것을 포함하여 자신의 설계에 가장 적합한 연결 모델을 자유롭게 선택할 수 있습니다.
와이어를 배치하여 Physical 연결 관계를 만들거나 Net 레이블을 사용하여 Logical 연결 관계를 만드세요.
Schematic 시트 within Logical 연결 관계를 만드는 것 외에도, Schematic 시트 between Logical 연결 관계를 만드는 객체가 있습니다. 이러한 연결 관계를 만드는 방식은 Schematic을 평면 설계로 구성하는지, 계층형 설계로 구성하는지에 따라 달라집니다. 자세한 내용은 아래에서 설명합니다.

시트 간 연결에 사용할 수 있는 다양한 Net 식별자가 있습니다.
Connectivity Insight
Altium Designer의 Connectivity Insight 기능(Design Insight 기능의 일부)은 프로젝트 내 연결 관계를 즉시 표시합니다. 선택적으로 Schematic 미리보기를 포함하는 문서 트리로 표시되며, 선택 가능한 요소를 통해 프로젝트의 연결 구조를 빠르고 시각적으로 탐색할 수 있습니다.
Default 설정 상태에서 Connectivity Insight 기능은 다음을 표시합니다.
- 커서를 Schematic 연결 객체(와이어, 포트 등) 위에 놓으면 관련 Net 연결 정보가 표시됩니다.
- 객체에 Alt+Double-click 을 사용하면 트리 기반의 연결 관계 미리보기 맵이 표시됩니다.
이 기능에 더해, Signal Net에 속한 객체 위에 커서를 놓고 Ctrl+Alt을 누르면 사용할 수 있는 기능도 있습니다. 이 기능은 선택 가능한 트리 보기를 엽니다. 트리에서 원하는 시트를 클릭하면 해당 문서로 빠르게 이동할 수 있습니다.
이 기능은 Preferences 대화상자의 System - Design Insight 페이지에서 Document Tree 항목의 Mouse Hover 옵션을 선택하거나 선택 해제하여 활성화하거나 비활성화할 수 있습니다.
연결 관계를 만드는 데 사용되는 객체
Schematic Editor에는 연결 관계를 만드는 데 사용되는 다음 객체가 포함되어 있습니다. 이러한 객체를 통틀어 net identifiers라고 합니다.
| Net 식별자 | 기능 |
|---|---|
| 버스 | Data[0..7]과 같이 여러 Net을 하나로 묶는 데 사용됩니다. Net 이름은 특정 명명 규칙에 따라 순차적으로 지정해야 합니다(예: Data0, Data1,... Data7). 이 이름 지정 방식에 따라 버스 이름(예: Data[0..7])이 결정됩니다. |
| 버스 Entry | 버스 라인의 양쪽에서 서로 다른 두 Net을 분기할 때 두 Net 사이에 단락이 발생하지 않도록 지원하는 그래픽 요소입니다. 다른 상황에서는 필요하지 않습니다. |
| 시트 외부 커넥터 | 한 Schematic 시트의 Net을 다른 시트에 연결하는 데 사용됩니다(동일한 시트 내 연결에는 사용하지 않음). 수평 연결 관계(평면 설계)만 지원합니다. 시트 외부 커넥터는 포트에 비해 기능이 제한적입니다. |
| Net 레이블 | 동일한 Schematic 시트에서 같은 이름의 다른 Net 레이블과 연결 관계를 만드는 데 사용되는 Net 식별자입니다. Net 이름은 Net 레이블에 의해 자동으로 지정됩니다. Net 레이블은 컴포넌트 핀, 와이어 및 버스에 배치할 수 있습니다. 프로젝트 옵션에서 Net Identifier Scope에 Global을 사용하도록 구성하지 않으면 Net 레이블은 시트 간에 연결되지 않습니다. |
| 핀 | 핀은 컴포넌트의 Physical 핀을 나타내기 위해 Schematic 심볼 Editor에 배치됩니다. 핀의 한쪽 끝만 전기적으로 활성화되며, 이를 핀의 핫 엔드라고도 합니다. |
| 포트 | 한 Schematic 시트의 Net을 다른 시트에 연결하는 데 사용됩니다. 계층형 설계에서는 수직으로, 평면 설계에서는 수평으로 연결할 수 있습니다(수직 및 수평 설계는 아래에서 설명합니다). Project Options 대화상자의 옵션 탭에서 Allow Ports to Name Nets 옵션을 활성화하면 포트 이름이 Net 이름으로 사용됩니다. 이 경우 포트는 Schematic 시트 내에서도 연결되지만, 같은 이름의 Net 레이블에는 연결되지 않습니다(자세히 알아보기). |
| 전원 포트 | 설계 구조와 관계없이 Schematic 프로젝트 전체에서 이름이 같은 모든 전원 포트와 연결 관계를 만듭니다. Net 이름은 전원 포트에 의해 자동으로 지정됩니다. 필요한 경우 이 Net의 연결 범위를 특정 Schematic 시트로 제한할 수 있습니다 (자세히 알아보기). |
| 시트 Entry | 시트 심볼 내부에 배치되어 해당 시트 심볼의 하위 시트에 있는 동일한 이름의 포트와 연결 관계를 만듭니다. Project Options 대화상자의 Options 탭에서 Allow Sheet Entries to Name Nets 옵션을 활성화하면 시트 Entry가 Net 이름으로 사용됩니다. |
| Signal 하네스 | 임의의 Net 조합, 버스 및 하위 수준의 Signal 하네스를 하나로 묶는 데 사용됩니다. |
| 와이어 | Schematic의 지점 간에 전기적 연결을 형성하는 데 사용되는 폴리라인 형태의 전기 설계 기본 요소입니다. 와이어는 Physical 전선에 해당합니다. |
Net 라벨
Net 라벨은 Schematic의 여러 지점을 식별하고 전기적으로 연결합니다.
개요
Schematic 컴포넌트 핀 사이에 와이어를 배치하여 전기적 연결을 만들 수 있습니다. 핀이 와이어로 physically 연결되므로 이를 물리적 연결이라고 합니다. Net 라벨과 같은 적절한 Net 식별자를 사용하여 논리적으로 연결할 수도 있습니다. Net 라벨은 사람이 쉽게 알아볼 수 있는 Net 식별자를 제공할 뿐 아니라, 회로의 지점들을 실제로 와이어로 연결하지 않고도 연결할 수 있게 해 줍니다.
사용 방법
Net 라벨은 Schematic Editor에서만 다음 방법으로 배치할 수 있습니다.
-
메인 메뉴에서 Place » Net Label 을 선택합니다.
-
설계 공간 상단의 Active Bar 에 있는 그래픽 객체 드롭다운에서 Net Label 버튼을 클릭합니다. (Active Bar 버튼을 길게 클릭하면 관련된 다른 명령에 액세스할 수 있습니다. 한 번 사용한 명령은 Active Bar의 해당 섹션에서 맨 위 항목이 됩니다.)
-
설계 공간에서 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Place » Net Label 을 선택합니다.
-
배선 도구 모음에서
버튼을 클릭합니다.
배치
명령을 실행하면 커서가 십자 모양으로 바뀌고, Net 라벨이 커서에 붙어 있는 Net 라벨 배치 모드로 전환됩니다.
-
Tab을 눌러 Properties 패널의 Net Label 모드를 엽니다. Net Name 필드가 선택되어 편집할 수 있는 상태가 되면 새 Net 이름을 입력합니다.
-
Net 라벨의 왼쪽 아래 모서리가 할당할 객체에 닿도록 위치를 잡은 다음, 클릭하거나 Enter을 눌러 Net 라벨을 배치합니다.
-
계속해서 Net 라벨을 배치하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 배치 모드를 종료합니다.
배치 중 Net 라벨이 커서에 붙어 있고 Net 라벨의 중심점이 고정되기 전에는 다음과 같은 추가 작업을 수행할 수 있습니다.
- Tab 키를 누르면 배치가 일시 중지되고 Properties 패널의 Net 라벨 모드에 액세스하여 속성을 즉시 변경할 수 있습니다. 설계 공간에 오버레이로 표시되는 일시 중지 버튼을 클릭하면 배치가 다시 시작됩니다.
- X 또는 Y 키를 눌러 Net 라벨을 X축 또는 Y축을 기준으로 뒤집습니다.
- Spacebar 을 누르면 Net 라벨이 시계 반대 방향으로 회전하고, Shift+Spacebar 을 누르면 시계 방향으로 회전합니다. 회전은 90° 단위로 이루어집니다.
배치 시 고려 사항:
- Net 라벨의 전기적 핫스폿은 왼쪽 아래 모서리이므로, 유효한 연결을 만들려면 이 모서리가 와이어, 버스 또는 신호 하네스에 must 닿아야 합니다.
- Net 라벨을 배치하기 전에 Net 속성을 입력하고 입력한 값이 숫자로 끝나는 경우, 이후 배치하는 각 Net 라벨에서 이 숫자 값이 자동으로 증가합니다. 이 동작은 Preferences 대화 상자의 Schematic – 일반 페이지에 있는 Auto-Increment During Placement 옵션에서 설정합니다. Net 라벨에는 Primary 필드만 적용되며, Secondary 필드는 핀처럼 필드가 여러 개인 객체에 적용됩니다.
그래픽 편집
Net 라벨은 in-place 편집이라는 방식으로 그래픽 편집할 수 있습니다. Net 라벨 문자열을 제자리에서 편집하려면 한 번 클릭하여 선택하고 잠시 기다린 다음, 다시 클릭하여 편집 모드로 전환합니다.
![]() |
한 번 클릭하여 문자열을 선택합니다. |
![]() |
잠시 기다린 다음 다시 클릭하여 제자리 편집 모드로 전환합니다. |
![]() |
문자열이 선택되어 대체할 문자열을 입력할 수 있는 상태가 됩니다. |
편집을 마치면 Enter을 누르거나 문자열 바깥을 클릭하여 제자리 편집 모드를 종료합니다.
참고
- Net 라벨은 하나의 Schematic 시트 내에서 논리적 연결을 만듭니다. Schematic 시트 간의 연결은 만들지 않습니다. 시트 간에 연결하려면 포트를 사용해야 합니다.
-
Net 라벨을 반전 표기하려면(텍스트 위에 막대를 표시하려면) 다음 방법 중 하나를 사용합니다.
-
Net 이름의 각 문자 뒤에 백슬래시 문자를 넣습니다(예:
E\N\A\B\L\E). -
Preferences 대화 상자의 Schematic - 그래픽 편집 페이지에서 Single '\' Negation 옵션을 활성화한 다음, Net 이름 맨 앞에 백슬래시 문자 하나를 넣습니다(예:
\ENABLE).
-
Net 이름의 각 문자 뒤에 백슬래시 문자를 넣습니다(예:
- 개별 Net이 버스를 구성하는 경우 이름 지정 방식에 특정 요구 사항이 적용됩니다. 자세한 내용은 버스 페이지를 참조하세요.
-
유형이 다른 Net 식별자는 이름이 같더라도 서로 자동으로 연결되지 않습니다. 예를 들어 이름이
AGND인 Net 라벨은 이름이AGND인 전원 포트에 자동으로 연결되지 않습니다. 이들을 연결하려면 와이어를 배치해야 합니다.
Net 라벨 속성
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 설계 공간 원점을 기준으로 한 객체 기준점의 현재 X(수평) 좌표입니다. 이 값을 편집하여 객체의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력하세요.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 객체 기준점의 현재 Y(수직) 좌표입니다. 이 값을 편집하여 객체의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력하세요.
- Rotation - 드롭다운을 사용하여 회전 각도를 선택합니다.
속성
- Net Name - 드롭다운에서 Net 이름을 선택하거나 이름을 직접 입력합니다.
- Font - 컨트롤을 사용하여 원하는 글꼴, 글꼴 크기, 색상을 선택하고 필요에 따라 굵게, 기울임꼴 등의 속성을 설정합니다.
- Justification - 원하는 정렬에 해당하는 화살표를 클릭하여 정렬을 선택하거나, 원을 클릭하여 가운데로 정렬합니다.
오프시트 커넥터
오프시트 커넥터는 Schematic 시트 간의 연결을 만드는 데 사용됩니다.
요약
오프시트 커넥터는 전기 설계 기본 객체입니다. 오프시트 커넥터는 동일한 Parent 시트 심볼에 속한 여러 Schematic 시트의 Net을 연결하는 데 사용됩니다.
사용 가능 여부
오프시트 커넥터는 Schematic Editor에서만 다음 방법으로 배치할 수 있습니다.
-
주 메뉴에서 Place » Off Sheet Connector 을 선택합니다.
-
Active Bar에서 Off Sheet Connector 명령을 찾아 사용합니다.
-
설계 공간에서 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Place » Off Sheet Connector 을 선택합니다.
배치
명령을 실행하면 커서가 십자 모양으로 바뀌고 오프시트 커넥터가 커서에 부착된 상태로 오프시트 커넥터 배치 모드로 전환됩니다.
- Tab 키를 눌러 Properties Panel의 오프시트 커넥터 모드를 엽니다. Net Name 이 선택되어 편집할 수 있는 상태가 되면 새 Net 이름을 입력합니다.
- 오프시트 커넥터의 전기적 핫스폿(커서에 부착된 끝부분)이 연결할 와이어에 닿도록 위치를 잡은 다음 클릭하거나 Enter 키를 눌러 배치합니다.
- 오프시트 커넥터를 계속 배치하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
배치 중 오프시트 커넥터가 커서에 부착된 상태에서 다음 작업도 수행할 수 있습니다.
- Tab 키를 누르면 배치가 일시 중지되고 Properties Panel의 Off Sheet Connector 모드에 액세스하여 속성을 즉시 변경할 수 있습니다. 배치를 재개하려면 워크스페이스의 일시 중지 버튼 오버레이를 클릭합니다.
- X 또는 Y 키를 눌러 오프시트 커넥터를 X축 또는 Y축을 기준으로 뒤집습니다.
- Spacebar 키를 누르면 오프시트 커넥터가 시계 반대 방향으로 회전하고, Shift+Spacebar 키를 누르면 시계 방향으로 회전합니다. 회전은 90° 단위로 이루어집니다.
그래픽 편집
오프시트 커넥터는 in-place 편집이라는 방식으로 그래픽 편집할 수 있습니다. 오프시트 커넥터 문자열을 제자리에서 편집하려면 한 번 클릭하여 선택하고 잠시 기다린 다음 다시 클릭하여 편집 모드로 전환합니다.
잠시 기다린 다음 다시 클릭하여 제자리 편집 모드로 전환합니다.
문자열이 선택되어 대체할 문자열을 입력할 수 있는 상태가 됩니다.
오프시트 커넥터는 제자리에서 편집할 수 있습니다.
편집을 마치면 Enter 키를 누르거나 문자열 바깥을 클릭하여 제자리 편집 모드를 종료합니다.
참고 사항
-
오프시트 커넥터와 분할된 시트 심볼이 유용한 경우도 있지만 제한 사항이 있다는 점을 기억해야 합니다. 이들은 자동 컴포넌트 클래스를 올바르게 형성하지 않으므로, 사용하기로 한 경우 PCB에서 해당 클래스를 수동으로 다시 만들어야 합니다.
-
특정 Net을 둘 이상의 시트에 걸쳐 올바르게 연결하려면 각 시트의 오프시트 커넥터에 동일한 Net을 할당해야 합니다.
-
포트 상호 참조는 오프시트 커넥터에 적용할 수 없으므로 가능한 경우 포트를 사용해야 합니다.
오프시트 커넥터 속성
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 워크스페이스 원점을 기준으로 한 객체 기준점의 현재 X(가로) 좌표입니다. 객체의 X 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 객체 기준점의 현재 Y(세로) 좌표입니다. 객체의 Y 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력합니다.
-
Rotation - 드롭다운에서 회전 각도를 선택합니다. 선택 가능한 값은
0 Degrees,90 Degrees,180 Degrees,270 Degrees입니다.
속성
-
Net Name - Net 이름을 입력합니다.
-
Cross Ref - 이 필드는 오프시트 커넥터에 적용된 상호 참조 값을 표시합니다.
-
Style - 드롭다운에서 사용 가능한 옵션인
Left또는Right중 기본값을 선택합니다. 색상 상자를 클릭하면 기본 색상을 선택할 수 있는 드롭다운이 열립니다.
일반(Net)
오프시트 커넥터에 할당된 Net의 속성을 표시합니다. 필요에 따라 수정하세요.
파라미터(Net)
- Selection buttons - Grid에 표시할 객체를 클릭하세요.
- Add - 드롭다운을 사용하여 원하는 객체를 추가한 다음 값을 정의하세요.
전원 포트
개요
전원 포트는 전기 설계의 기본 요소입니다. 전원 또는 접지 Net을 정의하는 데 사용되는 특수한 회로도 객체입니다. 전원 포트를 사용하면 설계의 어느 위치에서든 전원 Net을 편리하게 표시하고 핀이나 와이어에 연결할 수 있습니다. 이름이 같은 전원 Net은 다음 두 가지 경우를 제외하고 설계 전체에서 자동으로 연결됩니다.
-
계층적 설계에서 전원 포트가 포트 객체에 직접 배선되어 있는 경우(즉, Net Identifier Scope이
Hierarchical로 설정된 설계이거나, 최상위 시트에 시트 Entry가 있고 Net Identifier Scope이Automatic로 설정된 설계), 해당 전원 Net은 배치된 시트 내에서만 유효한 로컬 Net이 됩니다. – 따라서 시트 외부로의 Net 연결은 포트/시트 Entry 조합의 배선으로 정의해야 합니다(자세히 알아보기). -
Net Identifier Scope이
Strict Hierarchical로 설정된 경우. 이 설정은 모든 전원 Net을 각 시트 내에서만 유효한 로컬 Net으로 지정합니다. Net 식별자 범위 설정에 대해 자세히 알아보세요.
사용 방법
Schematic Editor에서 다음 방법으로 전원 포트를 배치할 수 있습니다.
-
주 메뉴에서 Place » Power Port을 클릭합니다.
-
Wiring 도구 모음에서
버튼을 클릭하여 VCCNet이 미리 할당된 막대형 전원 포트를 배치합니다. -
Wiring 도구 모음에서
버튼을 클릭하여 GNDNet이 미리 할당된 전원 접지형 전원 포트를 배치합니다. -
Active Bar의 전원 포트 드롭다운에서 명령을 선택합니다.
-
Utilities 도구 모음에서
버튼을 클릭하여 다양한 스타일과 Net이 미리 할당된 여러 전원 포트를 비롯한 전원 포트 명령을 제공하는 드롭다운을 엽니다.
-
설계 공간에서 마우스 오른쪽 버튼을 클릭한 다음 상황에 맞는 메뉴에서 Place » Power Port 을 선택합니다.
배치
명령을 실행하면 커서가 십자 모양으로 바뀌고 전원 포트 배치 모드로 전환됩니다. 전원 포트 심볼이 커서에 붙어 이동합니다.
- 객체의 위치를 지정한 다음 클릭하거나 Enter 키를 눌러 배치합니다.
- 전원 포트를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
배치 중 전원 포트가 커서에 붙어 있는 동안 다음 작업을 추가로 수행할 수 있습니다.
- Tab 키를 눌러 배치를 일시 중지하고 Properties Panel의 전원 포트 모드에 접근하여 속성을 즉시 변경할 수 있습니다. 배치를 재개하려면 설계 공간의 일시 중지 버튼 오버레이를 클릭합니다.
- Alt 키를 눌러 초기 이동 방향에 따라 이동 방향을 수평축 또는 수직축으로 제한합니다.
- Spacebar 키를 누르면 전원 포트가 반시계 방향으로 회전하고, Shift+Spacebar 키를 누르면 시계 방향으로 회전합니다. 회전은 90° 단위로 이루어집니다.
- X 또는 Y 키를 눌러 전원 포트를 X축 또는 Y축을 기준으로 반전합니다.
그래픽 편집
이 편집 방법을 사용하면 설계 공간에서 배치된 전원 포트 객체를 직접 선택한 다음 그래픽 방식으로 위치를 변경할 수 있습니다. 전원 포트의 크기와 모양은 고정되어 있습니다. 따라서 전원 포트 객체를 선택해도 편집 핸들이 표시되지 않습니다.
- 점선 상자 안의 아무 곳이나 클릭한 다음 드래그하여 전원 포트를 원하는 위치로 이동합니다. 드래그하는 동안 전원 포트를 회전(Spacebar/Shift+Spacebar)하거나 반전(X 또는 Y 키를 눌러 X축 또는 Y축을 기준으로 뒤집기)할 수 있습니다.
-
전원 포트 객체에 할당된 Net은 다음 방법으로 해당 위치에서 직접 편집할 수 있습니다.
- 전원 포트를 한 번 클릭하여 선택합니다.
- 다시 한 번 클릭하거나 Enter 키를 눌러 제자리 편집 모드로 들어갑니다. 소프트웨어가 두 번의 개별 클릭을 한 번의 더블 클릭으로 인식하지 않도록 클릭 사이에 충분한 시간을 두어야 합니다. 더블 클릭하면 Properties Panel이 열립니다.
- 제자리 텍스트 편집을 마치려면 Enter 키를 누르거나 마우스로 전원 포트 바깥을 클릭합니다.
전원 포트 스타일
다음과 같은 전원 포트 그래픽 스타일을 사용할 수 있으며, Properties Panel에서 객체의 Style 속성을 편집하여 설정할 수 있습니다.
|
화살표 |
|
막대 |
|
원 |
|
접지 |
|
GOST 화살표 |
|
GOST 막대 |
|
GOST 접지 |
|
GOST 전원 접지 |
|
전원 접지 |
|
신호 접지 |
|
물결 |
참고 사항
-
전원 포트를 부정 표시하려면(이름 위에 윗줄 표시) 다음 방법 중 하나를 사용합니다.
-
Net 이름의 각 문자 뒤에 백슬래시 문자를 추가합니다(예:
V\C\C\3\). -
Preferences 대화 상자의 Schematic - 그래픽 편집 페이지에서 Single '\' Negation 옵션을 활성화한 다음, Net 이름 맨 앞에 백슬래시 문자 하나를 추가합니다(예:
\VCC3).
-
-
Schematic에서 PCB 문서를 업데이트할 때는 전원 포트가 포함된 각 Net에 Supply Nets Design Rule을 추가하는 것이 권장됩니다.
전원 포트 속성
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 설계 공간 원점을 기준으로 한 객체 기준점의 현재 X(수평) 좌표입니다. 이 값을 편집하여 객체의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 포함해야 합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 객체 기준점의 현재 Y(수직) 좌표입니다. 이 값을 편집하여 객체의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 포함해야 합니다.
- Rotation - 드롭다운을 사용하여 회전 각도를 선택합니다.
속성
-
Name - 전원 포트의 이름입니다. 눈 아이콘을 사용하여 이름을 표시하거나 숨깁니다.
-
Style - 드롭다운을 사용하여 전원 객체의 스타일을 선택합니다. 선택에 따라 미리보기 이미지가 업데이트됩니다. 색상 상자를 클릭하여 색상을 선택합니다.
-
Font - 컨트롤을 사용하여 원하는 글꼴, 글꼴 크기, 색상을 선택하고, 필요한 경우 굵게, 기울임꼴 등의 속성을 설정합니다.
일반(Net)
전원 포트에 할당된 Net의 속성을 표시합니다. 필요에 따라 업데이트합니다.
매개변수(Net)
- Selection buttons - Grid에 표시할 객체를 클릭합니다.
- Add - 드롭다운을 사용하여 원하는 객체를 추가한 다음 값을 정의합니다.
와이어
와이어는 Schematic에서 전기적 연결을 만드는 데 사용됩니다.
요약
와이어는 Schematic의 지점 사이에 전기적 연결을 형성하는 데 사용되는 폴리라인 형태의 전기 설계 기본 요소입니다. 실제 전선에 해당합니다.
사용 방법
Schematic Editor에서는 다음 방법으로만 와이어를 배치할 수 있습니다.
- 주 메뉴에서 Place » Wire을(를) 선택합니다.
- 설계 공간 상단에 있는 Active Bar의 드롭다운에서 와이어 버튼을 클릭합니다. (Active Bar 버튼을 길게 클릭하면 관련된 다른 명령에 액세스할 수 있습니다. 명령을 한 번 사용하면 해당 명령이 Active Bar의 해당 섹션에서 맨 위 항목이 됩니다.)
-
Wiring 도구 모음에서
버튼을 클릭합니다.
- 설계 공간에서 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Place » Wire 명령을 선택합니다.
- Ctrl+W 단축키를 사용합니다.
배치
명령을 실행하면 커서가 십자선으로 바뀌고 와이어 배치 모드로 들어갑니다. 다음 순서에 따라 배치합니다.
- 클릭하거나 Enter 키를 눌러 와이어의 시작점을 고정합니다.
- 커서를 위치시킨 다음 클릭하거나 Enter 키를 눌러 와이어의 형상을 정의하는 일련의 꼭짓점을 고정합니다.
- 마지막 꼭짓점을 배치한 후 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 와이어 배치를 완료합니다.
- 추가 와이어 객체를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
- Backspace 또는 Delete 키를 사용하여 마지막으로 배치한 와이어 세그먼트를 제거합니다.
배치 모드
와이어 배치에는 세 가지 '수동' 배치 모드가 있으며, 그중 두 가지에는 시작 및 끝 하위 모드가 있습니다. 모드는 와이어를 배치할 때 모서리가 생성되는 방식과 와이어를 배치할 수 있는 각도를 지정합니다. 배치 중에는 다음 작업을 수행할 수 있습니다.
-
Shift+Spacebar 키를 눌러 모드를 순환합니다.
-
90 Degree또는45 Degree모드(정직교 모드라고 함)에서는 Spacebar 키를 눌러 시작 및 끝 하위 모드 간에 전환합니다. -
배치 중에는 현재 배치 모드가 상태 표시줄에 표시됩니다. 와이어 배치 중 언제든지 모드를 변경할 수 있습니다.
-
Any Angle이외의 모드에서는 커서에 연결된 선분이 look-ahead 세그먼트입니다. 실제로 배치하는 세그먼트는 이 미리보기 세그먼트 앞에 있습니다.
배선 안내
회로도에는 객체 간의 전기적 연결을 쉽게 정의할 수 있도록 설정 가능한 전기적 그리드가 있습니다. 와이어를 배치하는 동안 와이어가 다른 전기적 객체의 전기적 그리드 범위 내에 들어오면 커서가 해당 고정 객체에 스냅되고 핫스폿(파란색 십자)이 나타납니다.
핫스폿은 유효한 연결이 가능한 위치를 안내하고 커서를 전기적 연결 지점에 자동으로 스냅합니다.
전기적 그리드는 Document Options 모드에 있는 Properties 패널의 General 탭에서 정의할 수 있습니다. 전기적 그리드는 현재 스냅 그리드보다 약간 작게 설정하는 것이 좋습니다. 그렇지 않으면 전기적 객체를 스냅 그리드 한 칸 간격으로 배치하기 어려울 수 있습니다.
그래픽 편집
이 편집 방법을 사용하면 설계 공간에서 배치된 와이어 객체를 직접 선택하고 크기 및/또는 형상을 그래픽으로 변경할 수 있습니다.
와이어 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.
- A을 클릭하고 드래그하여 와이어 끝점의 위치를 변경합니다.
- B을 클릭하고 드래그하여 와이어 꼭짓점을 이동합니다. 끝점은 고정된 상태로 유지됩니다.
- 와이어 세그먼트를 클릭하고 드래그하여 해당 세그먼트를 grab하고 위치를 변경합니다. 끝점과 다른 꼭짓점은 고정된 상태로 유지됩니다.
-
꼭짓점을 마우스 오른쪽 버튼으로 클릭한 다음 Edit Wire Vertex n 명령을 선택하면
nth꼭짓점 항목이 선택되어 편집할 준비가 된 상태로 Wire 대화 상자가 열립니다. 필요에 따라 꼭짓점 및/또는 와이어의 다른 속성을 편집합니다. 자세한 내용은 와이어 속성 섹션을 참조하십시오. - 꼭짓점을 클릭한 상태로 키보드의 Delete 키를 누르면 해당 꼭짓점이 제거됩니다.
드래그 관련 정보
- 드래그 중에는 핫스폿을 통해 자동 접합점이 생성될 위치를 시각적으로 표시합니다.
- 드래그가 끝나면 불필요하거나 중복된 자동 접합점이 제거됩니다.
새 자동 접합점 생성 표시
영향을 받는 배선에 따라 드래그 작업을 수행하면 새 위치에 자동 접합점이 생성될 수 있습니다. 이러한 새 접합점이 생성될 위치를 시각적으로 알려주기 위해 핫스폿이 사용됩니다. Preferences 대화 상자의 Schematic - Compiler 페이지에 있는 Auto-Junctions 영역에서 와이어와 버스에 대한 핫스폿 사용 여부와 색상을 설정합니다.
선택 및 제거
와이어를 선택한 상태에서 세그먼트를 클릭하면 해당 세그먼트만 개별적으로 선택됩니다. 이러한 와이어 '하위 선택' 상태에서는 관련 편집 핸들이 빨간색으로 표시됩니다.
그런 다음 SCH List 패널을 사용하여 세그먼트의 관련 꼭짓점을 직접 편집할 수 있으며, 변경 사항은 회로도에 즉시 반영됩니다.
Delete 키를 눌러 선택한 와이어 세그먼트를 제거할 수도 있습니다. 서로 다른 와이어의 여러 세그먼트를 삭제할 수 있습니다. 각 세그먼트가 선택되어 있는지 확인하십시오(이후 추가할 각 세그먼트에서 Shift+Click을 두 번 수행하여 전체 세그먼트 선택에 포함). 자동 접합점도 고려되므로 와이어 세그먼트를 해당 접합점까지만 제거할 수 있습니다. 이때 접합점에 연결된 다른 와이어 세그먼트가 두 개만 남게 되는 경우 해당 접합점도 함께 제거됩니다.
자동 접합점
와이어의 T자 접합부는 정션(컴파일러 생성 정션)을 통해 자동으로 연결됩니다. Preferences 대화상자의 Schematic - 일반 페이지에서 Break Wires At Autojunctions 옵션을 활성화하면 자동 정션이 삽입되는 지점에서 기존 와이어 세그먼트가 두 개로 분할됩니다. 예를 들어 T자 접합부를 만들 때 직각으로 만나는 와이어 세그먼트는 정션 양쪽에서 각각 하나씩, 두 개의 세그먼트로 분할됩니다. Break Wires At Autojunctions 옵션을 비활성화하면 와이어 세그먼트는 정션에서 분할되지 않고 유지됩니다.
와이어 속성
일반(Net)
와이어에 할당된 Net의 속성을 표시합니다.
꼭짓점
- Width - 드롭다운을 사용하여 원하는 너비를 선택합니다. 색상 상자를 클릭하여 객체에 사용할 색상을 선택합니다.
-
Vertices Grid - 객체에 현재 정의된 모든 꼭짓점을 다음 항목으로 나열합니다.
- Index - 꼭짓점에 할당된 인덱스입니다(편집 불가).
- X - 꼭짓점의 X(수평) 좌표입니다. 클릭하여 편집합니다.
- Y - 꼭짓점의 Y(수직) 좌표입니다. 클릭하여 편집합니다.
-
Add - 클릭하여 새 꼭짓점을 추가합니다. 새 꼭짓점은 현재 포커스가 있는 꼭짓점 항목 아래에 추가되며, 처음에는 해당 항목과 동일한 X, Y 좌표를 갖습니다. 현재 선택된 꼭짓점을 제거하려면
을 클릭합니다.
파라미터(Net)
- Selection buttons - Grid에 표시할 객체를 클릭합니다.
- Add - 드롭다운을 사용하여 원하는 객체를 추가한 다음 값을 정의합니다.
컴파일러 생성 정션

Schematic 컴파일러는 각 T자 접합부에 정션을 자동으로 추가하여 전기적 연결을 완성합니다.
요약
정션은 전기 설계 기본 객체입니다. Schematic 시트에서 교차하는 와이어(또는 버스나 Signal 하네스)를 연결하는 데 사용되는 작은 원형 객체입니다. 컴파일러 생성 정션은 두 와이어/버스/Signal 하네스가 T자 형태로 연결되거나, 와이어/버스/Signal 하네스가 핀, 전원 포트 또는 기타 전기적 객체에 직각으로 연결될 때 자동 정션 기능에 의해 자동으로 배치되는 정션입니다.
사용 가능 여부
이 유형의 정션은 Schematic Editor의 자동 정션 기능에 의해 자동으로 배치됩니다. 따라서 사용자가 직접 접근하여 배치할 수 있는 설계 객체가 아닙니다.
배치
컴파일러 생성 정션은 배선 중 T자 접합부가 생길 때마다 자동으로 배치됩니다. 예를 들어 두 와이어/버스/Signal 하네스가 T자 형태로 만나거나, 와이어/버스/Signal 하네스가 컴포넌트 핀 끝 또는 전원 포트와 같은 다른 전기적 객체와 직각으로 교차할 때 배치됩니다.
편집
컴파일러 생성 정션은 일반적인 방식(대화상자 또는 Schematic 시트에서의 그래픽 편집)으로 편집할 수 없습니다. 컴파일러 생성 정션의 표시 속성은 아래 이미지와 같이 Preferences 대화상자의 Schematic - Compiler 페이지에서 구성합니다. 컴파일러 생성 정션의 표시를 비활성화해도 해당 정션 지점의 전기적 연결은 끊어지지 않습니다.
환경설정 대화상자에서 컴파일러 생성 정션(자동 정션)의 표시 옵션을 구성합니다.
새 자동 정션 생성 표시
영향을 받는 배선에 따라 드래그 작업으로 인해 새로운 위치에 자동 정션이 생성될 수 있습니다. 이러한 새 정션이 생성될 위치를 시각적으로 알려주기 위해 핫스폿이 사용됩니다. 환경설정에서 이러한 핫스폿 사용을 활성화하고 와이어 및 버스에 대한 핫스폿 색상도 지정할 수 있습니다.
드래그 작업 중 예상되는 자동 정션 표시를 제어합니다.

드래그 작업으로 인해 생성될 것으로 예상되는 새 자동 정션을 보여주는 예입니다.
연결 상태 변경의 시각적 표시
컴포넌트를 드래그하는 동안 실수로 너무 멀리 이동하거나 경로를 벗어나면 의도하지 않은 자동 정션이 생성되어 회로 연결 상태에 치명적인 변경이 발생할 수 있습니다. 드래그 중 연결 상태를 적시에 시각적으로 알려주기 위해 다음 두 가지 아이콘이 사용됩니다.
- OK - 드래그 작업이 회로의 연결 상태를 변경하지 않습니다.
- Alert - 드래그 작업으로 인해 회로의 연결 상태가 변경됩니다.
드래그하는 동안 해당 아이콘이 커서 근처에 표시됩니다.

드래그 작업으로 연결 상태가 변경될 것임을 시각적으로 경고합니다.
십자형 정션 변환
와이어 또는 버스 객체로 생성된 4방향 정션을 서로 인접한 두 개의 3방향 정션으로 빠르게 변환할 수 있습니다. 이를 위해 메인 메뉴에서 Tools » Convert » Convert Cross Junctions 명령을 선택합니다. 명령을 실행하면 Junctions Conversion 대화상자가 나타납니다. 이 대화상자에서 변환 범위(현재 문서, 프로젝트 문서 또는 열려 있는 모든 Schematic 문서)를 지정하고, 변환 가능한 모든 4방향 정션을 대상으로 할지, 아니면 타겟 문서에서 선택된 와이어/버스와 연결된 정션만 대상으로 할지 결정합니다. 변환 옵션을 원하는 대로 구성한 후 대화상자에서 OK 을 클릭하면 변환이 수행됩니다.

접합점 변환 대화상자
접합점 변환 대화상자의 옵션/컨트롤
범위
-
Sheet Scope - 다음 옵션 중 하나를 선택하여 업데이트 범위를 지정합니다.
- Current Document - 활성 Schematic 문서만 현재 템플릿의 변경 사항으로 업데이트합니다.
- Project Documents - 활성 Schematic 문서와 활성 프로젝트의 다른 모든 Schematic 문서를 각 문서의 현재 템플릿 변경 사항으로 업데이트합니다. 현재 닫혀 있는 Schematic 문서는 열립니다.
- Open Documents - 활성 Schematic 문서와 열려 있는 다른 모든 Schematic 문서를 상위 프로젝트에 관계없이 각 문서의 현재 템플릿 변경 사항으로 업데이트합니다.
-
Selection - 드롭다운에서 범위에 포함할 객체를 선택합니다.
- Selected Objects - Sheet Scope에서 선택한 시트의 선택된 객체만 선택합니다.
- All Objects - Sheet Scope에서 선택한 시트의 모든 객체를 선택합니다.
옵션
- Miter Size - 마이터 크기를 지정하는 값을 입력합니다.
설계 구조가 연결성에 미치는 영향
Related page: 다중 시트 및 계층형 설계
설계가 하나의 Schematic 시트에 들어가지 않으면 여러 시트에 나누어 배치할 수 있습니다. 다중 시트 Schematic에서 구조를 구성하고 연결성을 만드는 방식은 두 가지로 구분됩니다. 하나는 큰 Schematic 시트 하나를 여러 개의 작은 시트로 나눈 것으로 볼 수 있는 평면형 설계이고, 다른 하나는 시트가 조부모-부모-자식 형태의 구조로 연결되는 계층형 설계입니다.
다중 시트 설계는 아래 이미지와 같이 상위 시트에 하위 시트를 나타내고 해당 시트로 연결되는 시트 심볼을 배치하여 구현합니다.

시트 심볼은 하위 수준의 시트를 나타내고 해당 시트로 연결됩니다. 평면형 설계에서는 이 구조의 깊이가 한 단계로 제한되지만, 계층형 설계에서는 깊이에 제한이 없습니다.
평면형 설계
Related page: 다중 시트 및 계층형 설계
한 시트에서 다른 시트로 직접 연결성이 생성되는 설계를 평면형 설계라고 합니다. 이 연결은 상위 시트의 시트 심볼을 거치지 않습니다. 평면형 설계에서 시트 심볼은 단순히 하위 시트를 나타내고 참조합니다. 계층 구조가 없으므로 설계의 모든 시트가 Projects Panel에 동일한 수준으로 표시됩니다. 아래 두 이미지는 모두 평면형 설계를 보여줍니다.
평면형 설계는 생성하기가 더 간단합니다. 평면형 설계에는 각 하위 시트에 대한 시트 심볼이 배치된 최상위 시트를 포함할 수 있지만, 이 최상위 시트는 시트 간 연결성을 생성하는 데 사용되지 않으므로 선택 사항입니다. Schematic 시트가 두세 개뿐인 소규모 설계에서는 최상위 시트가 별다른 가치를 더하지 않는다고 판단할 수 있습니다. 시트 수가 많아지면 최상위 시트에 논리 블록(시트 심볼)이 배치된 방식을 통해 회로 설계의 기능을 파악하는 데 도움이 됩니다.

최상위 시트가 없는 경우(왼쪽)와 있는 경우(오른쪽)의 동일한 설계로, 둘 다 평면형 설계의 예입니다.
평면형 설계에서는 위 이미지의 확대경 부분에 표시된 것처럼 포트, 시트 외부 커넥터, 전원 포트 및 Net 레이블을 사용하여 시트 간 연결을 생성할 수 있습니다. 권장되는 방법은 각 시트 within Net 레이블을 사용하고, 시트 between 연결에는 포트를 사용하는 것입니다. 포트는 시트 외부 커넥터보다 더 많은 기능을 제공합니다. 예를 들어 포트 상호 참조를 추가할 수 있으며, 아래 이미지와 같이 각 포트에 다른 시트의 일치하는 포트를 참조하는 SheetName[GridReference]를 추가합니다.
평면형 설계의 시트 수에는 제한이 없습니다.

각 포트 옆에 포트 상호 참조가 추가되어 일치하는 포트의 타겟 시트와 Grid 참조를 나타냅니다.
계층형 설계
Main page: 다중 시트 및 계층형 설계
시트 간 연결성이 시트 심볼에서 해당 시트 심볼이 참조하는 하위 시트로 이어지는 설계를 계층형 설계라고 합니다. Net 수준에서는 해당 시트 심볼의 시트 Entry와 하위 시트에 있는 동일한 이름의 포트 사이에 연결성이 생성됩니다. 생성되는 시트 간 연결성이 상위 시트와 하위 시트 사이에서 위아래 방향으로만 이어지므로 이러한 연결성을 수직 연결성이라고도 합니다.

계층형 설계에서 Net 수준의 연결성은 상위 시트의 시트 Entry에서 하위 시트의 일치하는 포트로 이어집니다.
계층형 설계에는 두 가지 주요 장점이 있습니다.
- 첫 번째는 Schematic 시트를 논리 블록(시트 심볼)으로 구조화하고 표현하는 방식을 통해 설계의 기능을 독자에게 보여줄 수 있다는 점입니다. 최상위 Schematic은 설계를 상위 수준의 기능 블록 집합으로 표현하며, 각 블록은 전체 회로의 전통적인 왼쪽에서 오른쪽으로, 입력에서 출력으로 이어지는 흐름에서 자신의 위치를 반영하도록 배치됩니다. 필요한 경우 이러한 블록을 더 작은 블록으로 세분화할 수 있으므로, 컴포넌트가 배치되는 최하위 Schematic은 컴포넌트 수가 적고 비교적 단순한 구조를 가질 수 있습니다. 각 시트가 비교적 단순하므로 실제 시트 크기를 작게 유지할 수 있으며, 이는 Schematic을 인쇄할 때 큰 장점이 됩니다.
- 또 다른 주요 장점은 계층적 설계에서 Signal을 추적하기가 일반적으로 훨씬 쉽다는 점입니다. 상위 시트의 시트 Entry와 하위 시트의 포트를 대응시키기만 하면 각 시트 내의 배선을 따라 Signal을 추적할 수 있기 때문입니다.
계층적 설계를 구성하려면 추가 작업이 필요합니다. 시트 심볼에는 시트 Entry가 필요하며, 최상위 시트에는 한 시트 심볼에서 다른 시트 심볼로 Signal을 전달하는 배선이 있어야 합니다. 소프트웨어에는 시트 Entry를 하위 시트의 포트와 동기화하는 데 도움이 되는 도구가 포함되어 있습니다(모든 시트 심볼에 대해서는 Design » Synchronize Sheet Entries and Ports을 사용하고, 개별 시트 심볼에 대해서는 해당 시트 심볼을 마우스 오른쪽 버튼으로 클릭한 다음 Sheet Symbol Actions » Synchronize Sheet Entries and Ports 선택). 또한 대규모 설계를 작은 단위로 나누는 데 도움이 되는 도구도 포함되어 있습니다(Edit » Refactor » Move Selected Subcircuit to Different Sheet). 이러한 구조 재편 및 리팩터링 도구에 대한 자세한 내용은 설계 리팩터링 페이지를 참조하세요.
계층적 설계는 깊이에 제한이 없으며, Schematic 시트를 개수 제한 없이 포함할 수 있습니다.
멀티채널 설계
Main article: 멀티채널 설계 생성
전자 설계에 반복되는 회로 구간이 포함되는 경우는 흔합니다. 스테레오 앰프일 수도 있고, 64채널 믹싱 콘솔일 수도 있습니다. 이러한 유형의 설계는 multi-channel design라는 기능 모음을 통해 완벽하게 지원됩니다. 멀티채널 설계에서는 반복되는 회로를 한 번만 작성한 다음, 동일한 하위 Schematic을 참조하는 여러 시트 심볼을 배치하거나 하나의 시트 심볼이 참조하는 하위 Schematic을 필요한 횟수만큼 반복하도록 구성하여 소프트웨어에 반복을 지시합니다. 컴파일된 설계는 컴퓨터 메모리에서 확장되며, 사용자 정의 명명 규칙에 따라 모든 컴포넌트와 연결이 필요한 횟수만큼 반복됩니다.

왼쪽에는 동일한 하위 시트(PortIO.SchDoc)를 참조하는 시트 심볼 4개가 있습니다. 오른쪽에서는 Repeat 키워드를 통해 InputChannel.SchDoc이 8번 반복됩니다.
작성한 Logical 설계는 실제로 평면화되지 않으며, 항상 멀티채널 Schematic으로 유지됩니다. 이를 PCB 레이아웃으로 전송하면 Physical 컴포넌트와 Net이 필요한 횟수만큼 반복 생성되며, Schematic과 보드 간 작업에 사용할 수 있는 교차 탐색 및 교차 선택 도구를 모두 활용할 수 있습니다. PCB Editor에는 한 채널의 배치와 라우팅을 다른 모든 채널에 복제하는 도구도 있으며, 채널 전체를 손쉽게 이동하고 방향을 바꿀 수도 있습니다. 멀티채널 설계에 대한 자세한 내용은 멀티채널 설계 문서를 참조하세요.
소프트웨어는 계층적 구조 모델을 사용하여 메모리에 채널 인스턴스를 생성하므로, 멀티채널 설계는 반드시 계층적이어야 합니다.
Net 식별자 범위 설정
Dialog page: 프로젝트 옵션
소프트웨어는 Net Identifier Scope의 현재 설정을 사용하여 Schematic 시트 간의 연결 방식을 결정합니다. Net Identifier Scope은 Project Options 대화 상자(Project » Project Options)의 옵션 탭에서 구성합니다.

설계 구조에 맞는 Net Identifier Scope 모드를 선택하세요.
Global, Flat 및 Hierarchical 옵션의 동작은 아래 이미지에 나와 있습니다.

세 가지 주요 모드(Global, Flat, Hierarchical) 각각에서 연결이 생성되는 방식을 보여 주는 간단한 예입니다.
위에서 언급한 세 가지 옵션 외에 Automatic 옵션도 있습니다. 일반적으로 Net Identifier Scope 을 Automatic로 설정해 두는 것이 좋습니다. 소프트웨어는 시트 구조와 포트 및 시트 Entry의 유무를 기준으로 세 가지 옵션 중 가장 적합한 옵션을 선택합니다.
Automatic로 설정하면 소프트웨어는 다음 기준에 따라 세 가지 주요 Net 식별자 모드 중 사용할 모드를 자동으로 선택합니다.
-
최상위 시트에 시트 Entry가 있으면
Hierarchical이 사용됩니다. -
시트 Entry는 없지만 포트가 있으면
Flat이 사용됩니다. -
시트 Entry와 포트가 모두 없으면
Global이 사용됩니다.
Net 이름 지정 방식
컴포넌트 핀 사이에 와이어를 배치할 때마다 연결이 생성됩니다. 설계의 모든 Net에는 이름이 지정됩니다. Net 이름 지정에 사용할 수 있는 Net 식별자를 배치하지 않은 경우, 소프트웨어는 해당 Net에 속한 핀 중 하나를 기준으로 Net 이름을 지정합니다. 예를 들어 아래 이미지에 표시된 NetR7_1과 같습니다. 이후 컴포넌트 Designator가 변경되면 시스템에서 생성한 Net 이름도 변경되며, 동기화를 유지하려면 이러한 변경 사항을 Schematic과 PCB 간에 전달해야 합니다.

Net 식별자가 없는 Net에는 해당 Net에 속한 핀 중 하나를 기준으로 시스템에서 생성한 이름이 할당됩니다.
하나의 Net에 여러 Net 식별자 사용
하나의 Schematic 시트에서 동일한 Net에 서로 다른 이름의 Net 레이블을 여러 개 지정할 수는 없습니다. 이러한 경우 유효성 검사 중에 감지되어 오류로 표시됩니다. 그러나 동일한 Net이 여러 시트에 걸쳐 있는 경우, 각 시트에서 해당 Net에 서로 다른 Net 식별자를 지정하는 것은 허용됩니다.
이 기능을 사용하면 다음과 같은 작업을 수행할 수 있습니다.
- 계층 구조의 각 레벨에서 Net 이름을 변경하여 해당 시트에서의 기능을 더 잘 나타낼 수 있습니다.
- 하위 Schematic 시트의 Net 이름을 변경하지 않고도 해당 시트를 재사용할 수 있습니다.
Net 이름 지정을 제어하는 옵션
Dialog page: 프로젝트 옵션
최종적으로 PCB에서 각 Net은 하나의 이름만 가질 수 있습니다(Net Tie를 사용하여 두 Net을 의도적으로 연결하는 경우가 아니라면, 하나의 PCB Net에 두 개의 이름을 지정할 수 없습니다). 소프트웨어는 여러 이름을 가진 Net이 프로젝트에서 하나의 이름만 갖도록 자동으로 처리하지만, 선택된 이름이 예상과 다를 수 있습니다. 이름 선택 방식을 제어하는 다양한 옵션은 Project Options 대화상자의 Options 탭에 있는 Netlist Options 섹션에서 사용할 수 있습니다. 각 옵션에 대한 자세한 내용은 프로젝트 옵션 대화상자 페이지를 참조하십시오.
이러한 옵션을 설정할 때는 Allow Ports to Name Nets 및 Higher Level Names Take Priority 옵션을 활성화하는 것이 좋습니다. 이 옵션들과 함께 각 시트의 주요 Net에 Net 레이블을 적절히 사용하면, 여러 시트에 걸친 Net을 포함한 모든 주요 Net에 이름을 지정하고 상위 레벨 Schematic에서 지정한 이름을 하위 레벨 Schematic에서도 사용할 수 있습니다.
동일한 이름을 가진 두 개의 별도 Net
서로 다른 Schematic 시트에서 서로 다른 Net에 동일한 Net 이름을 사용한 경우에도 Net 이름 지정 문제가 발생할 수 있습니다. 이 문제는 유효성 검사 중 Duplicate Nets 오류 검사를 통해 감지됩니다. 이러한 상태에서는 설계를 PCB로 전송할 수 없습니다. 설계 전송 시 두 개의 별도 Net이 하나의 PCB Net으로 병합되기 때문입니다.
이 문제는 Project Options 대화상자의 옵션 탭에서 Append Sheet Numbers to Local Nets 옵션을 활성화하여 해결할 수 있습니다. 이 옵션을 활성화하면 아래 이미지와 같이 모든 로컬 Net의 이름 뒤에 SheetNumber 파라미터 값이 추가됩니다.

Net 레이블 Input이 여러 시트에서 사용되었으므로, Duplicate Nets 오류를 방지하기 위해 Append Sheet Numbers to Local Net 옵션을 활성화했습니다.
컴파일된 시트 탭을 클릭하면 이 옵션의 효과를 확인할 수 있습니다(오른쪽 이미지). Net 이름 뒤에 _2가 추가된 것을 확인하십시오.
두 Net을 의도적으로 연결하기
서로 다른 두 Net을 의도적으로 연결해야 하는 경우가 있습니다. 이는 단순한 이름 지정 문제가 아니라, 설계 요구 사항에 따라 두 Net을 단락시켜야 하는 경우입니다. 예를 들어 아날로그 접지와 디지털 접지를 제어된 방식으로 연결해야 하는 경우가 이에 해당합니다.
이 작업은 Net Tie 컴포넌트를 통해 두 Net을 연결하여 수행합니다. Net Tie 컴포넌트는 제어된 단락 연결로, 보드에서 Net이 연결되는 위치를 지정할 수 있게 해 줍니다. Schematic에서 Net Tie 컴포넌트에는 두 개 이상의 핀이 있으며, 각 핀은 단락시킬 Net 중 하나에 연결됩니다. 아래와 같이 컴포넌트의 Component Type 속성은 Net Tie로 설정됩니다.

Schematic에서 하나의 클록을 두 개의 FPGA 클록 핀으로 라우팅하는 데 사용된 Net Tie 컴포넌트입니다.
Schematic에서는 핀이 서로 not배선되어 있지 않지만(Schematic에서는 단락되지 않음), PCB 풋프린트 내부에서는 서로 are연결되어 있습니다.
PCB 측에서는 풋프린트에 Schematic 심볼의 핀 수와 동일한 수의 Pad가 있으며, 그 사이를 구리로 연결합니다. 아래 예시 이미지에서는 두 개의 정사각형 Pad를 일정 길이의 Track으로 연결하여 이를 구현했습니다. 이 작업은 PCB 라이브러리 Editor에서 풋프린트 내부에 수행합니다. PCB의 Component Type 속성도 Net Tie로 설정합니다.
소프트웨어는 Net Tie PCB 컴포넌트 내부에서 생성된 단락을 자동으로 무시하므로 DRC 오류가 발생하지 않습니다.

PCB에 배치된 동일한 Net Tie 컴포넌트입니다. Net Tie 풋프린트의 Pad(선택된 상태)가 Track으로 단락되어 있습니다.
Net Tie 컴포넌트로 서로 다른 두 Net을 연결하면, 각 Net은 Schematic 전체와 PCB에서 고유한 이름을 유지합니다.
전원 Net
이 설정의 Default 동작은 전원 Net을 전역으로 간주하는 것입니다. 즉, 모든 Schematic 시트에서 전원 Net을 사용할 수 있다고 가정합니다. 전원 Net에 접근하려면 필요한 Net 이름을 가진 전원 포트를 배치한 다음 컴포넌트를 해당 전원 포트에 와이어로 연결합니다. 설계가 컴파일되면 프로젝트의 모든 시트에 걸쳐 각 전원 Net에 연결된 핀이 모두 서로 연결됩니다.

전원 포트가 어떤 Net에 연결되는지는 심볼의 스타일이 아니라 Net 이름에 따라 결정됩니다. 강조 표시된 세 전원 포트는 모두 GND 전원 Net에 연결됩니다.
전원 Net의 로컬화 - 전체 적용
앞서 설명한 것처럼, 계층형 설계에서 Net 식별자 범위의 Strict Hierarchical 옵션을 선택하면 전원 Net을 각 Schematic 시트로 로컬화할 수 있습니다. 이 방식은 모든 시트의 모든 전원 Net을 로컬화하므로, Signal Net과 동일한 방식으로 전원 Net을 수동으로 서로 연결해야 합니다. 서로 연결하지 않으면 각 Schematic 시트에 있는 각 전원 Net에 대해 Duplicate Net Name 오류가 발생합니다. 또한 포트를 전원 포트에 연결할 수 있도록 Connection 매트릭스 설정을 조정해야 합니다.

Net Identifier Scope가 Strict Hierarchical로 설정되어 있으면 모든 전원 Net을 해당 Net이 사용되는 모든 시트에 와이어로 연결해야 합니다.
시트 간에 로컬화된 전원 Net 연결하기
계층형 설계에서 로컬화된 전원 Net은 다른 Net과 동일한 방식으로, 하위 시트의 포트에서 상위 시트에 있는 시트 심볼의 시트 Entry로 연결합니다. 전원 Net의 경우 이 기법은 개별 전원 Net만 지원하며, 버스로 묶인 전원 Net은 지원하지 않습니다.
다중 채널 설계를 생성하고 아래와 같이 Repeat 문을 사용하여 각 채널에 고유한 개별 전원 Net을 공급하려는 경우, 시트 Entry-포트 조합을 통해 각 채널에 하나의 Net만 전달하므로 이 방식이 지원됩니다. 설계에서 각 시트 Entry-포트 조합을 통해 상위에서 하위로 개별 전원 Net만 연결한다면 Netlist가 올바르게 생성됩니다.
로컬화된 전원 Net이 버스가 아닌 개별 Net으로 계층 구조를 오가면 다중 채널 설계의 각 채널에 분배할 수 있습니다.
전원 Net의 로컬화 - 개별 적용
계층형 설계의 특정 전원 Net은 (즉, Net Identifier Scope가 Hierarchical로 설정된 설계 또는 최상위 시트에 시트 Entry가 있고 Net Identifier Scope가 Automatic로 설정된 설계 – Net 식별자 범위 설정 자세히 알아보기) 해당 Schematic 시트의 전원 포트를 포트에 연결하여 특정 시트에서만 로컬화할 수도 있습니다.

여기서는 3V3 전원 Net이 이 시트에서만 로컬화되었으므로 상위 시트에서도 수동으로 연결해야 합니다. GND 및 5V Net은 전역 전원 Net으로 유지됩니다.
동적 컴파일
Related page: 설계 프로젝트 유효성 검사
두 핀을 와이어로 연결하는 것은 실제 Net을 생성하는 것이 아니라 설계 의도를 작성하는 것입니다. Net은 프로젝트가 컴파일될 때 비로소 생성됩니다. 컴파일은 컴포넌트와 연결 방식에 대한 세부 정보뿐 아니라 컴포넌트 및 설계의 상세 파라미터 정보도 추출합니다. 컴파일된 프로젝트 모델을 통합 데이터 모델(Unified Data Model)이라고 합니다.
설계 데이터 모델은 동적 컴파일을 통해 사용자가 작업을 수행할 때마다 증분 업데이트되며, 이를 동적 데이터 모델(Dynamic Data Model, DDM)이라고 합니다. 프로젝트를 수동으로 컴파일할 필요 없이 모든 과정이 자동으로 수행됩니다. 동적 컴파일 덕분에 설계 연결성 모델은 사용자가 작업을 수행할 때마다 증분 업데이트됩니다. 설계 프로젝트의 자동 컴파일 프로세스는 다음 세 가지 기능을 수행합니다.
- 설계 계층 구조를 인스턴스화합니다.
- 모든 설계 시트 간의 Net 연결성을 설정합니다.
- 설계의 내부 동적 데이터 모델(DDM)을 구축합니다.
따라서 설계 변경 사항은 즉시 Navigator 및 Projects Panel에 반영됩니다.
DDM과 컴파일러 설정 간의 Logical 오류, 전기적 오류 및 도면 작성 오류를 확인하려면 프로젝트 유효성을 검사해야 합니다. 이 명령은 기본 메뉴에서 Project » Validate Project 명령을 선택하거나, Projects Panel에서 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭한 후 컨텍스트 메뉴에서 Validate Project 명령을 선택하여 실행할 수 있습니다.
컴파일러에서 감지한 위반 사항은 Messages Panel에 경고 및/또는 오류로 표시됩니다. 컴파일러는 소스 문서의 위반 사항을 검사할 때 프로젝트 유형에 해당하는 Project Options 대화 상자의 오류 보고 및 Connection 매트릭스 탭에 정의된 옵션을 사용합니다.
동적 데이터 모델
소프트웨어의 핵심 요소는 통합 데이터 모델(Unified Data Model, UDM)입니다. 자동으로 수행되는 동적 컴파일을 통해 설계 프로세스의 중심이 되는 싱글 통합 모델이 생성됩니다. Schematic 및 PCB를 비롯한 소프트웨어 내의 다양한 Editor와 서비스는 모델의 데이터에 접근하고 이를 조작할 수 있습니다. UDM은 각 설계 영역에 별도의 데이터 저장소를 사용하는 대신, 컴포넌트와 연결 정보를 포함하여 설계의 모든 측면에 관한 정보를 수용하도록 구성되어 있습니다. 설계 프로세스의 중심이 되는 이 싱글 통합 모델은 동적 설계 컴파일의 결과로 생성됩니다. 따라서 프로젝트를 여는 순간부터 통합 데이터 모델을 사용할 수 있으며, 추가 수동 컴파일이 필요하지 않습니다. 즉, 진정한 동적 데이터 모델(Dynamic Data Model, DDM)입니다. 따라서 사용자가 작업을 수행할 때마다 모델이 증분 업데이트(컴파일)됩니다. Schematic 설계에서 콘텐츠를 자유롭게 배치하고, 배선하고, 재배열하고, 이름을 바꾸고, 추가하고, 삭제할 수 있습니다.
PCB 설계 컴파일 프로세스는 Schematic 및 PCB Editor 외부의 코드로 관리됩니다. 이 방식에는 여러 장점이 있으며, 가장 큰 장점은 설계의 통합 데이터 모델이 개별 Schematic 및 PCB Editor 외부에 존재한다는 것입니다. UDM에는 설계의 모든 컴포넌트와 각 컴포넌트가 서로 연결되는 방식에 대한 상세한 설명이 포함됩니다.

소프트웨어는 Schematic과 PCB 전반의 연결 데이터를 관리합니다.
컴파일이 동적으로 수행되므로 다음 위치 및 작업에서는 설계 컴파일을 위한 추가 수동 작업이 필요하지 않습니다.
- Navigator 및 Projects Panel
- ActiveBOM
- ECO 수행
- 크로스 프로빙
- Net 색상 강조 표시
- 핀 스와핑
- 컴포넌트 상호 참조
그렇다면 설계 전체에서 Net을 추적하는 등의 작업을 위해 통합 데이터 모델과 어떻게 상호 작용할 수 있을까요? Navigator Panel을 통해 이러한 작업을 수행할 수 있습니다.
연결 상태 살펴보기
Panel page: Navigator Panel
설계 규모가 크고 여러 시트에 걸쳐 있으면 설계 내 연결 상태를 추적하고 검증하기 어려울 수 있습니다. 이 과정을 돕기 위해 Navigator Panel을 사용할 수 있습니다. 이 Panel은 컴파일된 전체 설계의 보기를 제공합니다.
Panel의 기본적인 사용 방법은 다음과 같습니다.
-
Panel 상단의
버튼을 클릭하여 Preferences 대화 상자를 열고 원하는 Highlight Methods을(를) 활성화하여 탐색 동작을 설정합니다. 또는 아래 이미지와 같이 Panel에서 관심 있는 객체를 마우스 오른쪽 버튼으로 클릭하고 메뉴 옵션을 사용하여 탐색 동작을 구성합니다.
-
Panel의 Documents for Region에서 탐색 범위를 설정합니다. 전체 설계를 탐색하려면
Flattened Hierarchy을(를) 선택합니다. - 목록의 Instance 섹션에서 컴포넌트를 클릭하면 해당 컴포넌트로 이동합니다. 컴포넌트를 확장하면 핀을 찾거나 해당 핀으로 이동할 수 있습니다.
- Net /Bus 섹션에서 Net 또는 버스를 클릭하면 해당 Net 또는 버스로 이동합니다.
- Alt 키를 누른 상태에서 클릭하면 Schematic과 PCB 양쪽에서 해당 객체로 이동합니다.

Navigator Panel에서 컴포넌트 또는 Net을 클릭하면 해당 컴포넌트 또는 Net을 찾고 설계 전체의 연결 상태를 추적할 수 있습니다. 표시 옵션에 접근하려면 마우스 오른쪽 버튼을 클릭하세요. 이미지 위에 커서를 올리면 Schematic과 PCB에서 동시에 컴포넌트로 이동하는 모습을 볼 수 있습니다(PCB 객체를 포함하려면 Navigator Panel에서 Alt 키를 누른 상태로 클릭하세요).
보드의 컴포넌트 탐색
Navigator Panel에서 Schematic과 PCB(Alt 키를 누른 경우)의 컴포넌트를 찾을 수 있을 뿐만 아니라, Schematic에서 직접 PCB의 핀/컴포넌트/Net/버스/하니스를 탐색할 수도 있습니다.
예를 들어, Schematic에서 컴포넌트를 찾기 위해 클릭할 때 PCB에서도 동일한 컴포넌트를 찾을 수 있습니다.
방법은 다음과 같습니다.
- Highlight Methods에서 Selecting 옵션을 활성화하고, Preferences 대화 상자의 System - Navigation 페이지에 있는 Cross Select Mode 섹션에서도 원하는 옵션을 활성화합니다.
- Schematic 및 PCB Editor 양쪽에서 교차 선택(Tools » Cross Select Mode)을 활성화합니다.

이 옵션들은 탐색 및 교차 선택 동작을 구성합니다.
이제 아래 이미지와 같이 Schematic에서 핀/컴포넌트/Net/버스/하니스를 선택하면 PCB에서도 해당 객체가 선택됩니다.

Schematic에서 컴포넌트와 Net을 선택하면 PCB에서도 해당 객체가 선택됩니다. 교차 선택은 PCB에서 Schematic 방향으로도 작동합니다.
프로젝트 구조에서 컴포넌트 및 Net 검색
Panel의 구조를 탐색하여 관심 있는 컴포넌트 또는 Net을 찾은 다음, 객체를 두 번 클릭하면 프로젝트의 Schematic 문서에 해당 객체의 인스턴스가 표시됩니다. Preferences 대화 상자의 시스템 - 탐색 페이지에 있는 옵션을 사용하여 객체 강조 표시 동작(확대/축소, 흐리게 표시, 선택 등)을 지정하세요.
Navigator Panel에서도 프로젝트 객체 탐색 기능을 사용할 수 있으며, 이 Panel은 설계 객체와 관련 데이터의 상세한 계층 구조를 제공합니다. 시스템 - 탐색 환경설정은 Project 및 Navigator Panel 양쪽의 객체 강조 표시 동작을 결정합니다.
Connection 강조 표시
연결 탐색 옵션은 Projects Panel에서 선택한 객체의 연결 관계를 보여줍니다. Panel의 객체 계층 목록에서 Net 등의 항목을 두 번 클릭하면 Schematic에서 해당 객체의 상호 연결이 강조 표시됩니다.
미리보기 기능은 Preferences 대화 상자의 System – Navigation 페이지에 있는 Highlight Methods 섹션의 Connectivity Graph 옵션으로 활성화됩니다. 선택한 객체와 연결된 전원 객체의 연결 상태도 보려면 추가로 Include Power Parts 옵션을 선택하세요.
전역 Net 강조 표시
Alt 키를 누른 상태에서 와이어(Alt+Click)를 클릭하여 Net을 선택하면 모든 Schematic에서 설계 전반의 Net 연결 상태를 강조 표시할 수 있습니다. 해당 Net의 모든 Schematic 인스턴스는 강조 표시되고 다른 객체는 흐리게 표시되므로, 간단한 동작 하나로 설계 내 신호/전원 전파 경로를 시각적으로 확인할 수 있습니다.
빈 공간을 클릭하면 Net 강조 표시가 해제되며, 동작 방식은 Preferences 대화 상자의 System - Navigation 페이지에 있는 Highlight Methods 설정에 따라 결정됩니다. Dimming 옵션을 선택 해제하면 Net 강조 표시 기능이 비활성화됩니다.
Net 색상 구성
Main page: Net에 색상 적용
Schematic의 가독성을 높이고 PCB Editor에서 Net과 라우팅 작업을 더 쉽게 수행할 수 있도록 Schematic 배선과 PCB Net 및 라우팅에 색상을 적용할 수 있습니다.
아래 이미지와 같이 Schematic Editor의 View » Set Net Colors 하위 메뉴에 있는 명령을 사용하여 Net 또는 버스에 강조 색상을 적용할 수 있습니다. 이 색상은 Update PCB 명령을 통해 언제든지 PCB Editor로 전송할 수 있습니다.
PCB Editor에서 Connection Lines의 기본 색상과 표시 여부는 PCB View Configuration Panel의 System Colors 섹션에서 구성합니다. 이 기본 색상은 Net이 생성될 때(Schematic에서 설계를 처음 전송할 때) 적용되며, 이 옵션을 변경해도 기존 연결선의 색상은 변경되지 않습니다.
PCB Editor에서 각 Net에 적용된 색상은 PCB Panel의 Nets 모드에 표시됩니다. 아래 이미지의 오른쪽 하단에 표시된 것처럼 Net 이름 옆 체크박스의 배경색을 확인하세요.
색상은 라우팅되지 않은 Net(연결선)에 항상 적용됩니다. 라우팅된 Net에도 색상을 표시하려면 PCB Panel에서 Net 이름 옆의 체크박스를 선택하고, Preferences 대화 상자의 Board Insight Color Overrides 페이지에서 표시 옵션을 구성하세요. 아래 이미지에서는 재정의 색상의 Base Pattern이 Solid로, Zoom Out Behavior가 Override Color Dominates로 설정되어 있습니다.
Schematic에 적용된 Net 색상은 Update PCB 명령을 통해 PCB로 전송됩니다. 보드에서 색상이 표시되는 방식을 제어하려면 PCB Color Override 기능을 구성하세요.
PCB Net의 색상 변경
Schematic 배선에 색상을 적용하여 PCB로 전송하는 것이 항상 가능한 것은 아닙니다. 이 경우에도 PCB Editor에서 연결선과 라우팅에 색상을 적용할 수 있습니다. 설계가 전송된 후 Net의 색상을 변경하려면 PCB Panel의 Nets 모드에서 Net 이름을 두 번 클릭하세요. 개별 Net의 색상은 Edit Net 대화 상자에서 편집할 수 있습니다.
여러 Net의 색상을 변경하려면 PCB Panel의 Nets 모드를 사용하세요.
- 표준 Windows 다중 선택 방식(Shift+click 또는 Ctrl+click)을 사용하여 여러 Net 클래스 또는 여러 개별 Net을 선택합니다.
- 선택한 객체를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Change Net Color 명령을 선택하여 선택한 Net에 새 색상을 지정합니다.
- 다시 마우스 오른쪽 버튼을 클릭하고 Display Override » Selected On을 선택하여 선택한 Net의 색상 재정의 기능을 활성화합니다.

연결선의 색상을 변경하고 표시 재정의 기능을 활성화하여 Net의 가시성을 높이세요.





















)

