회로도와 PCB를 동기화 상태로 유지하기
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
개요
- 양방향 비교와 직접 업데이트 워크플로의 차이점과 각 방식이 사용되는 상황을 알아봅니다.
- 부품, 연결 정보, 클래스 및 일부 설계 규칙을 포함하여 Altium Designer가 Schematic과 PCB 간에 동기화할 수 있는 항목을 이해합니다.
- Comparator 및 ECO Generation 설정과 같은 프로젝트 옵션이 동기화 프로세스와 적용 가능한 변경 사항에 어떤 영향을 미치는지 살펴봅니다.
Schematic에서 PCB로 설계를 진행할 때 가장 흔히 수행하는 작업은 Schematic과 PCB를 일치시키거나 동기화하는 것입니다. 작성한 설계를 새 PCB로 처음 전송하든, 기존 설계의 Schematic 또는 PCB를 변경하든, 양쪽을 동기화할 방법이 필요합니다. Altium Designer는 설계 동기화 작업을 간소화하는 강력한 설계 동기화 기능을 제공하므로, 설계자는 설계 과정의 창의적인 측면에 집중할 수 있습니다.
동기화 프로세스는 Schematic과 PCB 간의 차이점을 감지하고 해결합니다.
설계 동기화는 Schematic 편집기와 PCB 편집기 간에 직접 수행되며, Netlist와 같은 중간 문서는 사용되지 않습니다. 소프트웨어는 비교 엔진을 사용하여 설계의 모든 측면을 비교하고, Output을 차이점 목록으로 상세히 표시합니다. 설계자는 차이점을 해결하기 위해 어느 쪽을 변경할지 결정하며, 이에 따라 일련의 ECO(Engineering Change Order)가 생성됩니다. 이를 적용하면 설계의 양쪽이 다시 동기화됩니다.
동기화할 수 있는 항목은 무엇인가요?
동기화 프로세스는 Schematic의 컴포넌트 및 연결 데이터가 PCB의 컴포넌트 및 연결 데이터와 일치하도록 합니다. 컴포넌트 및 연결 데이터뿐 아니라 Net 클래스, 컴포넌트 클래스, Design Rule과 같은 다른 설계 제약 조건도 동기화합니다.
비교기 옵션 구성
Dialog page: PCB 프로젝트 옵션, 비교기 탭
정확히 what Schematic 및 PCB 데이터를 비교할지는 Options for PCB Project 대화 상자의 비교기 탭에서 구성합니다. Project » Project Options을 선택하여 대화 상자를 여세요.

비교 엔진은 Options for Project 대화 상자의 Comparator 탭에 정의된 설정을 따릅니다.
대화 상자의 기본 Region에는 Different Designators 및 Changed Net Name과 같은 비교 유형이 5개 범주로 분류된 긴 목록이 표시됩니다. 오른쪽의 Mode 열에는 각 항목의 드롭다운이 있으며, 여기에서 Find Differences 또는 Ignore Differences과 같은 비교 모드를 선택할 수 있습니다. 텍스트 유형 비교에는 대소문자를 구분하지 않고 비교할 수 있는 세 번째 옵션이 있습니다.
새 프로젝트의 Default 설정은 모든 비교 유형에 대해 차이점을 찾는 것입니다. 프로젝트에 맞게 옵션을 설정하세요.
대화 상자 하단에는 Object Matching Criteria 설정 옵션이 있습니다. 매칭은 단순한 문자열의 정확한 일치에 의존하지 않는 정교한 다중 패스 프로세스입니다. 자세한 내용은 Net 및 클래스 매칭 섹션을 참조하세요.
대화 상자 하단의 Ignore Rules Defined in the PCB Only 옵션에 주목하세요. 이 옵션을 활성화하면 PCB에서 정의한 Rule이 비교 프로세스에서 제외됩니다.
Net 및 컴포넌트 클래스 동기화
Dialog page: PCB 프로젝트 옵션, 클래스 생성 탭
Design » Update PCB을 수행하면 컴포넌트 및 연결 데이터뿐 아니라 클래스와 Design Rule도 생성하고 동기화할 수 있습니다.
Design Rule 동기화
파라미터 세트 객체를 사용하여 Schematic에서 Design Rule을 정의할 수 있습니다. 파라미터 세트 객체를 선택하면 Properties Panel 또는 모달 대화 상자에 Rules Region이 표시됩니다. Add 드롭다운을 클릭하여 Design Rule을 추가하세요. 해당 Rule은 파라미터 세트 객체가 접촉하고 있는 Net / 버스 / 하네스 / 블랭킷 아래의 객체에 적용됩니다.
아래 이미지에서는 폭 제약 조건 Design Rule이 USB_data Net 클래스에 적용되고 있습니다. 이 Net 클래스 역시 이 파라미터 세트의 일부로, Parameters 드롭다운의 Classes Region에서 정의됩니다.

파라미터 세트는 Schematic 블랭킷 객체 아래에 있는 Net에 대한 Net 클래스와 Design Rule을 정의하는 데 사용됩니다. 필요한 측정 단위는 PCB Rule 편집 대화 상자 하단에서 구성합니다.
Schematic에서 Design Rule 추가
- Net / 버스 / 하네스 / 블랭킷에 파라미터 세트를 연결합니다. 필요한 경우 파라미터 세트에 Net 클래스 정의를 추가합니다.
- Add 파라미터 세트에 Rule 정의를 추가합니다. 그러면 위에 표시된 것처럼 Choose Design Rule Type 대화 상자가 열립니다.
- 필요한 Rule Type을 선택합니다.
- OK 버튼을 클릭하여 Edit PCB Rule 대화 상자를 엽니다.
- 필요에 따라 PCB Rule 요구 사항을 구성합니다. 이 PCB Rule에 필요한 측정 단위는 대화 상자 하단에서 선택합니다.
위 이미지와 아래 이미지 모두에서 Design Rule은 블랭킷에 연결된 파라미터 세트 객체에 정의되어 있습니다. 파라미터 세트 객체에 클래스 정의를 포함하면 PCB Net 클래스도 생성되며, 클래스 정의가 있으므로 PCB Rule의 적용 범위는 InNetClass('<PCB_NetClassName >')로 지정됩니다.
아래 이미지에서는 파라미터 세트 객체가 Differential Pair 지시자로 표시되어 있습니다. 이는 Place » Directives » Differential Pair 명령을 사용하여 배치하는 특수한 유형의 파라미터 세트 객체입니다.

Differential Pair 지시자는 Net 클래스와 Design Rule을 정의하는 데 사용되며, 이렇게 정의된 항목은 대상 Differential Pair에 적용됩니다.
ECO 생성 옵션 구성
Options for Project 대화 상자에는 ECO 생성 탭도 있습니다. 이 탭에서는 ECO를 생성할 수 있는 설계 변경 사항을 정의합니다. 일반적으로 이 옵션들은 모두 활성화하며, 대화 상자의 비교기 탭에 있는 옵션을 사용하여 Schematic과 PCB 간에 동기화할 설계 변경 사항을 설정합니다.

ECO 생성 탭에서는 ECO를 생성할 수 있는 변경 유형을 정의합니다.
차이점 찾기
설계 동기화 기능은 양방향으로 차이점을 감지하고 해결할 수 있습니다. 즉, Schematic에서 PCB로, 또는 PCB에서 Schematic으로 차이점을 반영할 수 있습니다.
소프트웨어는 양쪽에 변경 사항을 동시에 적용하여 이러한 차이점을 해결할 수 있습니다. 예를 들어, 전자 설계자가 커패시터의 값을 변경하고 PCB 설계자가 동일한 커패시터의 풋프린트를 변경한 상황을 가정해 보겠습니다. Comment 변경은 Schematic에서 PCB로 업데이트하고, 풋프린트 변경은 PCB에서 Schematic으로 업데이트하면 한 번의 업데이트 과정으로 이 두 가지 차이점을 해결할 수 있습니다.
비교기 엔진이 Schematic 프로젝트와 PCB를 비교하면 전체 차이점 목록이 생성됩니다. 이 단계에서는 다시 동기화하기 위해 어느 쪽을 변경해야 하는지 미리 정하지 않습니다.
차이점 목록은 Differences between 대화 상자에서 확인할 수 있습니다.
Differences between 대화 상자의 옵션 및 컨트롤
이 대화 상자는 기본적으로 Differences, Update 및 Change Order의 세 가지 주요 영역으로 나뉩니다.
차이점
대화 상자의 이 영역에는 비교기가 선택한 문서 사이에서 찾은 모든 차이점이 나열됩니다. 각 차이점은 해당 차이점이 있는 문서의 열에 표시됩니다. 차이점은 Project Options 대화 상자의 비교기 탭에 나열되어 활성화된 비교 유형별로 그룹화됩니다. 이 그룹 수준의 Entry에는 해당 유형의 차이점 수가 표시됩니다.
Entry를 두 번 클릭하면 관련 원본 문서의 객체로 크로스 프로빙할 수 있습니다.
업데이트
대화 상자의 이 영역을 사용하여 차이점을 해결하기 위해 업데이트할 문서를 지정합니다. 기본적으로 모든 Decision Entry에는 처음에 No Change 결정이 적용됩니다.
각 차이점의 업데이트 결정은 Decision 열에서 해당 Entry를 클릭한 다음, 표시되는 ECO 결정 대화 상자에서 필요한 업데이트 작업을 선택하여 개별적으로 지정할 수 있습니다. 업데이트 방향(비교한 문서 중 업데이트할 문서)을 선택하거나, 아무것도 업데이트하지 않으려면 No Updates을 선택하면 됩니다.
변경 지시
대화 상자의 이 영역에는 조치를 취하기로 결정한 각 차이점에 대해 수행할 작업, 작업의 영향을 받는 객체, 작업이 수행될 문서가 나열됩니다. 이 정보는 업데이트를 생성하는 데 사용할 후속 ECO를 구성하는 데 사용됩니다. 이 영역에 나열되는 일반적인 작업은 다음과 같습니다.
- Remove - 차이점을 유발하는 객체가 포함된 문서 방향으로 업데이트하는 경우, 해당 객체가 제거됩니다.
- Add - 차이점을 유발하는 객체가 포함되지 않은 문서 방향으로 업데이트하는 경우, 해당 객체가 추가됩니다.
- Update - 두 문서 모두 동일한 객체를 포함하지만 일부 속성이 다른 경우, 선택한 방향에 따라 변경할 객체가 결정됩니다.
마우스 오른쪽 버튼 메뉴
- Create Change Order - 엔지니어링 변경 지시(ECO)를 생성하는 데 사용합니다.
- Generate Report - 비교기가 찾은 차이점에 대한 보고서를 생성하는 데 사용합니다. 선택한 업데이트 결정과 작업은 생성되는 ECO에 포함됩니다. 보고서는 Report Preview 대화 상자에 로드됩니다. 이 대화 상자에서 보고서를 살펴본 후, 지원되는 다양한 형식 중 하나로 내보내거나 직접 인쇄할 수 있습니다.
- << Update All in - 모든 차이점의 업데이트 방향을 왼쪽 문서로 설정하는 데 사용합니다(해당되는 경우).
- Update All in >> - 모든 차이점의 업데이트 방향을 오른쪽 문서로 설정하는 데 사용합니다(해당되는 경우).
- Reverse Direction For All - 모든 차이점의 업데이트 방향을 빠르게 반대로 바꾸는 데 사용합니다(해당되는 경우). 차이점의 방향을 변경할 수 없는 경우 해당 Entry는 No Change으로 설정됩니다.
- Set No Action For All - 모든 차이점의 업데이트 결정을 No Change으로 빠르게 설정하는 데 사용합니다.
- << Update Same Kind in - 현재 선택된 차이점과 동일한 비교 유형에 속하는 모든 차이점의 업데이트 방향을 왼쪽 문서로 설정하는 데 사용합니다(해당되는 경우).
- Update Same Kind in >> - 현재 포커스가 있는 차이점과 비교 유형이 같은 모든 차이점의 업데이트 방향을 오른쪽 문서로 설정합니다(해당하는 경우).
- Reverse Direction For Same Kind - 현재 포커스가 있는 차이점과 비교 유형이 같은 모든 차이점의 업데이트 방향을 빠르게 반대로 바꿉니다(해당하는 경우). 차이점의 방향을 변경할 수 없는 경우 해당 Entry는 No Change로 설정됩니다.
- Set No Action For Same Kind - 현재 포커스가 있는 차이점과 비교 유형이 같은 모든 차이점의 업데이트 방향을 No Change로 빠르게 설정합니다.
- << Update Selected in - 선택한 모든 차이점의 업데이트 방향을 왼쪽 문서로 설정합니다(해당하는 경우).
- Update Selected in >> - 선택한 모든 차이점의 업데이트 방향을 오른쪽 문서로 설정합니다(해당하는 경우).
- Reverse Direction For Selected - 선택한 모든 차이점의 업데이트 방향을 빠르게 반대로 바꿉니다(해당하는 경우). 차이점의 방향을 변경할 수 없는 경우 해당 Entry는 No Change로 설정됩니다.
- Set No Action For Selected - 선택한 모든 차이점의 업데이트 결정을 No Change로 빠르게 설정합니다.
- Invert Selection - 목록에서 현재 선택되지 않은 모든 차이점을 선택하거나, 선택된 차이점의 선택을 해제합니다.
추가 컨트롤
대화 상자 하단에서 다음 버튼을 사용할 수 있습니다.
- Create Engineering Change Order - 이 버튼을 클릭하여 ECO를 생성합니다. Engineering Change Order 대화 상자가 나타나며, 여기서 업데이트를 검증하고 실행하여 문서를 동기화할 수 있습니다.
- Report Differences - 이 버튼을 클릭하여 Comparator가 발견한 차이점에 대한 보고서를 생성합니다. 지정한 업데이트 결정과 작업은 생성되는 ECO에 포함됩니다. 보고서는 Report Preview 대화 상자에 로드됩니다. 이 대화 상자에서 보고서를 검토한 후 지원되는 여러 형식 중 하나로 내보내거나 직접 인쇄할 수 있습니다.
- Explore Differences - 이 버튼을 클릭하여 ECO를 생성하기 전에 Comparator가 발견한 차이점을 자세히 살펴봅니다. Differences between 대화 상자가 닫히고 Differences Panel이 열린 상태로 기본 워크스페이스로 돌아갑니다. Panel에는 Comparator에 나열된 모든 차이점이 동일한 범주로 표시됩니다. Panel을 사용하여 Parent 문서에서 차이점의 원인이 되는 객체로 크로스 프로빙할 수 있습니다.
Difference between 대화 상자를 열고 차이점 목록을 확인하려면 다음을 수행합니다.
-
아래 이미지에 표시된 Choose Documents to Compare 대화 상자를 열려면 Project » Show Differences 명령을 실행하거나, Projects Panel에서 원하는 프로젝트(또는 해당 프로젝트의 소스 문서 중 하나)의 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Show Differences 명령을 선택합니다. Choose Documents to Compare 대화 상자는 비교할 두 문서 또는 문서 집합을 선택하는 데 사용되며, 일반적으로 회로도 프로젝트와 PCB를 비교합니다. Advanced Mode 옵션을 선택하면 이 대화 상자에서 임의의 문서 간 비교도 수행할 수 있습니다. 예를 들어 넷리스트와 PCB 또는 PCB와 PCB를 비교할 수 있습니다.
일반적으로 기본 모드와 고급 모드 모두에서 대화 상자의 Default 설정은 대부분의 설계 비교 요구 사항에 적합합니다. 즉, 동기화를 위해 소스 문서와 타겟 PCB 설계를 비교하는 경우에 적합합니다. 이 대화 상자에서는 다른 문서도 비교할 수 있으므로, 프로젝트의 여러 버전을 로드하고 서로 대응하는 소스 문서 간의 차이점을 비교해야 할 때 유용합니다.

회로도 프로젝트와 비교할 PCB를 선택합니다. - 대화 상자의 기본 영역에서 PCB를 선택하고 OK를 클릭하여 아래에 표시된 Difference between 대화 상자를 엽니다. PCB 문서가 현재 소스 문서와 동기화되어 있다면 차이점이 발견되지 않았다는 대화 상자가 나타납니다.
Differences between 대화 상자가 열립니다. Synchronizer는 양방향으로 작동합니다. 즉, 동일한 ECO에서 두 문서 모두에 대한 업데이트를 지정할 수 있습니다. 비교한 문서를 동기화하려면 각 차이점에 대해 작업 수행 여부와 변경 방향을 결정해야 합니다. 즉, 차이점을 해소하기 위해 어느 문서를 업데이트할지 지정해야 합니다. 따라서 다음 단계는 각 차이점에 업데이트 방향을 지정하는 것입니다.
- 개별 차이점의 경우 Update 열을 클릭하면 아래 이미지와 같이 방향 선택기가 표시됩니다.
- 동일한 종류의 여러 차이점의 경우 Different Footprints와 같은 제목을 마우스 오른쪽 버튼으로 클릭하고 필요한 Update Same Kind 명령을 선택합니다.
- 모든 차이점의 경우 대화 상자의 아무 곳이나 마우스 오른쪽 버튼으로 클릭하고 필요한 Update All 명령을 선택합니다.

각 차이점을 해소하는 ECO를 생성하려면 해당 차이점의 업데이트 방향을 설정해야 합니다.
Explore Differences 버튼을 클릭하여 Differences Panel에 액세스하고, 아래의 Differences Panel로 설계 변경 사항 살펴보기 섹션에 설명된 대로 차이점을 살펴봅니다.
Report Differences를 클릭하여 Comparator가 발견한 차이점, 지정된 업데이트 결정, 생성되는 ECO에 포함될 작업에 대한 보고서를 설정하고 인쇄하거나 내보냅니다.
업데이트 방향을 지정한 후 Create Engineering Change Order 버튼을 클릭하여 Engineering Change Order 대화 상자를 엽니다. 이 대화 상자는 아래의 차이점 해소 - ECO 적용 섹션에 설명되어 있습니다.
Differences Panel로 설계 변경 사항 살펴보기

Differences Panel은 문서 간 차이점을 계층 구조로 표시합니다.
요약
Differences Panel은 설계 문서를 비교할 때 소프트웨어에 내장된 Differences Comparator가 발견한 Logical 또는 Physical 차이점을 표시하는 데 사용됩니다. 예를 들어, 프로젝트의 소스 문서 계층 구조(회로도)와 PCB 설계 문서를 비교할 수 있습니다. 이 Panel에서는 프로젝트 문서를 동기화하는 데 사용할 엔지니어링 변경 지시(ECO)를 생성하기로 결정하기 전에 차이점을 대화형으로 살펴볼 수 있습니다.
Panel 열기
Differences Panel을 열려면:
- 기본 메뉴에서 View » Panels » Differences 을 선택합니다.
- 설계 워크스페이스 오른쪽 하단의 Panels 버튼을 클릭한 다음 Differences을 클릭합니다.
차이점 표시
Differences Panel을 사용하는 방식은 다음 중 어떤 목적을 달성하려는지에 따라 달라집니다.
- 프로젝트 계층 구조 내의 Logical 차이점을 감지하여 전체 프로젝트의 내용과 구조 측면에서 무결성을 분석합니다.
- 동일한 Schematic 또는 PCB 문서의 두 버전 간 그래픽(Physical) 차이점을 감지하여 비교합니다.
Logical 차이점 표시
프로젝트 문서의 Logical 차이점 비교는 Choose Documents To Compare 대화 상자에서 수행합니다. 이 대화 상자는 Projects Panel에서 프로젝트(또는 프로젝트 문서)를 마우스 오른쪽 버튼으로 클릭한 다음 해당 상황에 맞는 메뉴에서 Show Differences을 선택하여 엽니다.

프로젝트 이름을 마우스 오른쪽 버튼으로 클릭한 다음 Show Differences을 선택하여 Choose Documents To Compare 대화 상자를 엽니다.
일반적으로 PCB 문서를 Parent 프로젝트의 소스 문서 계층 구조와 비교하여 회로도 설계 내용과 PCB 설계 내용 간의 Logical 차이점을 감지합니다.
OK을 클릭한 후 지정된 문서 간에 차이점이 있으면 차이점 비교 대화 상자가 열립니다. Differences Panel의 정보는 Differences between 대화 상자에서 Explore Differences 버튼을 클릭한 후에만 표시됩니다.
Differences Panel에는 Differences between 대화 상자에 나열된 차이점만 표시됩니다. 이러한 차이점은 Project Options 대화 상자(Project » Options)의 Comparator 탭에서 선택한 항목에 따라 결정됩니다. 이 탭에는 부품, 네트 및 파라미터와 관련된 차이점 등 모든 비교 유형이 나열됩니다. 각 비교 범주의 Mode을 Find Differences 또는 Ignore Differences으로 설정하면 Differences Comparator가 해당 결과를 Differences between 대화 상자로 전달할지 여부가 결정됩니다.

Project Options 대화 상자에서 차이점을 감지하고 보고하는 방식을 설정합니다.
Differences Panel은 소스 문서 간에 발견된 차이점을 트리 구조로 표시하며, 최상위 폴더에는 감지된 차이점의 총수가 표시됩니다. 그런 다음 차이점 비교 대화 상자에 나타나는 각 비교 유형별로 하위 폴더가 생성됩니다. 각 하위 폴더에는 발견된 구체적인 차이점이 나열되며, 각 차이점은 해당 차이를 발생시키는 문서 내 객체로 더 세분화됩니다.
연결된 문서가 열려 있거나 열린 상태에서 숨겨져 있는 경우, Panel에서 객체 Entry를 클릭하면 문서의 해당 객체로 크로스 프로빙됩니다.
객체는 확대/축소 및 흐리게 표시 효과를 통해 시각적으로 표시되며, 다른 모든 객체를 흐리게 표시하여 해당 객체를 강조합니다. 흐리게 표시되는 정도의 대비는 Preferences 대화 상자의 System - Navigation 페이지에 있는 Highlight Methods Region의 Dimming 슬라이더로 조절할 수 있습니다.
Physical 차이점 표시
동일한 회로도 또는 PCB 문서의 두 버전에 대한 그래픽(Physical) 비교는 기본적으로 위에서 설명한 Logical 비교와 같은 방식으로 수행하지만, Choose Documents To Compare 대화 상자의 Advanced Mode도 함께 사용합니다.
Show Differences 명령(Projects Panel의 마우스 오른쪽 버튼 메뉴)을 사용하여 Choose Documents To Compare 대화 상자를 연 다음 Advanced Mode 확인란을 선택하여 문서의 Physical 비교를 수행합니다. 이제 대화 상자에 모든 프로젝트 파일이 표시되므로 비교할 문서의 두 버전을 선택합니다.

Advanced Mode의 Choose Documents To Compare 대화 상자에서 Physical 비교를 수행할 문서를 선택합니다.
OK을 클릭하면 그래픽 비교가 진행되고 앞서 설명한 차이점 비교 대화 상자가 열립니다. Explore Differences을 클릭하면 Differences Panel에 대화형 차이점 목록이 열립니다.
Panel은 문서 간에 발견된 차이점을 트리 구조로 표시합니다. 최상위 폴더에는 감지된 차이점의 총수가 표시됩니다. 각 차이점 유형별로 항목이 생성되며, 각 항목에는 해당하는 구체적인 참조와 관련 객체(포트, 부품 등)가 포함됩니다.
감지된 차이점의 객체 Entry를 선택하면 Editor 설계 공간에서 해당 객체가 강조 표시되고 확대됩니다.
참고 사항
- Panel의 객체가 현재 숨겨진 문서에 있는 경우, 연결된 Entry를 클릭하면 문서가 자동으로 열리고 설계 Editor 창에서 활성 문서로 지정됩니다.
- Differences Panel에서 크로스 프로빙할 때 적용되는 필터링은 일시적입니다. 따라서 필터 범위를 벗어나는 설계 객체도 선택하거나 편집할 수 있습니다.
- 새 문서 비교를 수행하거나 Parent 프로젝트를 컴파일하면 Differences Panel의 정보가 지워집니다.
- 기본 메뉴의 Project » Show Physical Differences 명령을 사용하면 회로도 또는 PCB 문서의 두 버전 사이에 존재하는 Physical 차이점을 감지하고, 설계 공간에서 두 문서를 나란히 볼 때 이러한 차이점을 그래픽으로 표시할 수 있습니다. 이 Show Physical Differences 기능은 순수한 시각적 비교만 제공합니다. 비교 중인 두 문서 모두 ECO 생성을 통해 업데이트할 수 없습니다. 이 기능은 동일한 문서의 두 버전을 비교하기 위한 것이지만, 프로젝트의 소스 계층 구조와 PCB처럼 서로 다른 문서를 비교하면 감지된 Logical 차이점을 나열하는 Differences Panel이 표시됩니다.
직접 업데이트 수행
설계자는 일반적으로 업데이트를 어느 방향으로 적용할지 알고 있으며 모든 업데이트가 같은 방향으로 이루어지므로, 앞서 설명한 차이점 감지 및 방향 지정 과정을 건너뛸 수 있습니다.
Project 메뉴에서 Show Differences 명령을 선택하는 대신, 회로도 Editor 또는 PCB Editor의 Design 메뉴에서 Update 명령을 선택합니다. 명령을 실행하는 Editor에 따라 변경 사항을 적용할 방향, 즉 this Editor에서 that Editor로의 방향이 결정됩니다. 예를 들어, 회로도의 모든 변경 사항을 PCB에 적용하려면 회로도 Editor에서 Design » Update을 선택합니다.
Differences between 대화 상자를 건너뛰고 바로 Engineering Change Order 대화 상자로 이동합니다.
모든 업데이트를 같은 방향으로 적용하려면 Design » Update 명령을 사용합니다.
차이점 해결 - ECO 적용
각 차이점은 엔지니어링 변경 지시(ECO)를 적용하여 해결합니다. ECO는 Engineering Change Order 대화 상자에 한 줄에 하나씩 나열되며, 각각 별도의 Enable 체크박스가 있습니다.
Engineering Change Order 대화 상자를 사용할 때:
- 대화 상자는 모든 변경 사항이 활성화된 상태로 열립니다. 지금은 보류하려는 변경 사항을 비활성화하세요. 이 대화 상자는 다중 선택을 지원합니다. 마우스 오른쪽 버튼 클릭 컨텍스트 메뉴를 사용하여 선택한 ECO의 활성화 상태를 전환할 수 있습니다.
- 마우스 오른쪽 버튼 클릭 메뉴의 Cross Probe 명령을 사용하여 해당 ECO의 영향을 받는 객체를 살펴봅니다.
- Validate Changes 버튼을 사용하여 변경 사항을 수행할 수 있는지 확인합니다. ECO는 일반적으로 객체를 사용할 수 없을 때 실패합니다. 예를 들어, 지정한 PCB 풋프린트가 사용 가능한 파일 기반 라이브러리에 없거나, 지정한 Pad가 풋프린트에 없는 경우입니다.
- 특정 ECO에 필요한 객체가 처음에는 없었지만 현재 ECO를 처리하는 동안 추가된 경우에도 ECO가 실패할 수 있습니다. 이 경우 Update 명령을 다시 실행하여 해당 ECO를 완료합니다.

각 설계 변경 사항은 ECO로 표시됩니다. 필요한 ECO를 활성화하세요.
Engineering Change Order 대화 상자의 옵션 및 컨트롤
이 대화 상자는 두 가지 주요 영역인 Modifications 및 Status으로 나뉩니다.
수정 사항
대화 상자의 이 Region에는 동기화에 필요한 변경 사항을 구현하기 위한 모든 수정 사항이 나열됩니다. 수정 사항은 Project Options - ECO Generation 대화 상자에 나열되고 활성화된 수정 유형별로 그룹화됩니다. 이 그룹 수준의 Entry에는 해당 유형의 수정 사항 수가 표시됩니다. 이 Region의 각 개별 수정 사항에는 다음 정보가 표시됩니다.
- Enable - 이 옵션은 ECO를 실행할 때 해당 수정 사항을 포함할지 여부를 결정합니다. 체크박스를 직접 클릭하여 활성화/포함(선택됨) 상태와 비활성화/제외(선택 해제됨) 상태 사이를 전환합니다. 스페이스바를 사용하여 Enable 체크박스를 선택하거나 선택 해제할 수 있습니다.
- Action - 수행할 구체적인 작업입니다. 작업 유형은 수행해야 하는 ECO 유형에 따라 달라집니다.
- Affected Object - 작업의 영향을 받는 객체입니다.
- Affected Document - 작업을 수행할 문서입니다.
마우스 오른쪽 버튼 클릭 메뉴
기본적으로 모든 수정 사항은 ECO 실행 시 포함되도록 활성화되어 있습니다. 필요에 따라 각 수정 Entry를 개별적으로 활성화/비활성화하거나, 마우스 오른쪽 버튼 클릭 메뉴에서 다음 명령을 사용하여 여러 수정 사항의 활성화 상태를 변경할 수 있습니다.
- Validate Changes - 클릭하여 ECO에 포함하도록 활성화된 수정 사항의 유효성을 검사합니다. 검사 결과는 대화 상자의 Status Region에 있는 Check 열에 표시됩니다.
- Execute Changes - 클릭하여 ECO를 실행합니다. 실행 결과는 대화 상자의 Status Region에 있는 Done 열에 표시됩니다. 유효성 검사 단계를 통과한 변경 사항만 실행된다는 점에 유의하세요.
- Create Report - 클릭하여 ECO에 포함된 수정 사항에 대한 보고서를 생성합니다. 보고서는 Report Preview 대화 상자에 로드됩니다.
- Cross Probe - 클릭하여 관련 회로도 및 PCB 문서에서 수정 작업에 관련된 타겟 객체와 참조 객체를 크로스 프로브합니다.
- Expand All - 클릭하여 목록의 모든 수정 사항을 펼쳐서 표시합니다.
- Contract All - 클릭하여 목록의 모든 수정 사항을 접어서 표시합니다.
- Enable All - 모든 수정 사항을 활성화합니다.
- Disable All - 모든 수정 사항을 비활성화합니다.
- Enable Selected - 선택한 모든 수정 사항을 활성화합니다.
- Disable Selected - 선택한 모든 수정 사항을 비활성화합니다.
- Enable all of same Kind - 현재 포커스가 있는 수정 사항과 동일한 수정 유형의 모든 수정 사항을 활성화합니다.
- Disable all of same Kind - 현재 포커스가 있는 수정 사항과 동일한 수정 유형의 모든 수정 사항을 비활성화합니다.
- Invert Selection - 목록에서 현재 선택되지 않은 모든 수정 사항을 빠르게 선택하고, 선택된 수정 사항은 선택 해제합니다.
상태
대화 상자의 이 Region에는 활성화된 각 수정 사항에 대해 다음 상태 정보가 표시됩니다.
- Check - 이 필드는 수정 사항에 대한 유효성 검사 결과를 표시합니다. 녹색 체크 표시는 제안된 변경 사항이 지원되며 ECO 실행 시 수행됨을 의미합니다. 빨간색 X 표시는 제안된 변경 사항이 유효하지 않아 ECO 실행 시 수행되지 않음을 의미합니다.
- Done - 이 필드는 수정 사항의 실행 결과를 표시합니다. 녹색 체크 표시는 유효한 수정 사항이 성공적으로 실행되었음을 의미합니다.
- Message - 수정 사항이 유효성 검사 단계를 통과하지 못하면 이 필드와 Messages 패널에 항목이 표시되어 실패 원인을 알려줍니다.
추가 컨트롤
대화 상자 하단과 마우스 오른쪽 버튼 클릭 메뉴에서 다음 컨트롤을 사용할 수 있습니다.
- Validate Changes - 클릭하면 ECO에 포함하도록 활성화된 수정 사항에 대해 유효성 검사를 실행합니다. 검사 결과는 대화 상자의 Status 영역에 있는 Check 열에 표시됩니다.
- Execute Changes - 클릭하면 ECO를 실행하고 여기에 포함된 유효한 변경 사항을 적용합니다. 실행 결과는 대화 상자의 Status 영역에 있는 Done 열에 표시됩니다. 유효성 검사 단계를 통과한 변경 사항만 실행된다는 점에 유의하십시오.
- Report Changes - 클릭하면 ECO에 포함된 수정 사항에 대한 보고서를 생성합니다. 보고서는 Report Preview 대화 상자에 로드됩니다.
- Only Show Errors - 이 옵션을 선택하면 Engineering Change Order 오류만 표시됩니다. 유효성 검사를 통과한 변경 사항은 표시되지 않습니다. 오류 목록만 표시하면 설계를 빠르게 검토하고 필요한 변경을 수행하여 최종 ECO가 유효성 검사를 완전히 통과하도록 할 수 있습니다.
Schematic과 PCB 간의 연결 이해하기
고유 식별자를 통한 컴포넌트 매칭
각 Schematic 컴포넌트는 고유 식별자(UID)를 통해 해당 PCB 컴포넌트에 연결됩니다. UID는 Schematic 컴포넌트를 시트에 배치할 때 할당되며, 설계를 PCB 에디터로 전송할 때 이 값이 PCB 컴포넌트로 전달됩니다. Synchronizer을 사용하여 Schematic 소스 문서와 비어 있는 PCB 설계 문서 간에 컴포넌트 정보를 처음 전송하면 모든 컴포넌트가 고유 ID로 자동 연결됩니다. 즉, 각 Schematic 컴포넌트의 ID 정보가 해당 컴포넌트 풋프린트에 할당됩니다.
이 방식은 단순한 설계에는 적합하지만 다중 채널 설계는 지원할 수 없습니다. 다중 채널 설계에서는 동일한 Schematic 컴포넌트가 각 물리적 채널에서 반복되므로, 반복된 PCB 컴포넌트가 동일한 UID를 갖게 됩니다. 이를 처리하기 위해 PCB 컴포넌트의 UID는 상위 시트 심볼의 UID와 Schematic 컴포넌트의 UID를 결합하여 생성됩니다. PCB UID의 구문은 다중 채널 설계를 생성한 방식에 따라 약간 달라집니다.
동일한 Schematic 시트를 참조하는 여러 시트 심볼을 배치하여 다중 채널 설계를 생성한 경우, 각 시트 심볼이 고유 ID를 제공할 수 있으므로 PCB UID는 다음 형식을 갖습니다.
\SheetSymbolUID\SchComponentUID
Repeat 키워드를 사용하여 다중 채널 설계를 생성한 경우, 사용 가능한 시트 심볼 UID가 하나뿐이므로 PCB UID에는 ChannelIndex 값도 포함되며, 형식은 다음과 같습니다.
\ChannelIndex+SheetSymbolUID\SchComponentUID
컴포넌트가 연결되지 않은 경우
UID를 사용하여 Schematic과 PCB 컴포넌트를 매칭하면, Designator가 동기화되지 않은 상태가 되더라도(예를 들어 PCB 재어노테이션을 여러 번 수행한 경우) Schematic과 PCB를 다시 동기화할 수 없게 될 위험이 없다는 장점이 있습니다.
Schematic 또는 PCB에 있는 컴포넌트에 대해 다른 에디터에 일치하는 컴포넌트(동일한 UID)가 없으면 다음과 같이 처리됩니다.
- 추가 컴포넌트가 소스 에디터에만 있으면 타겟 에디터에 해당 컴포넌트를 추가하는 ECO가 생성됩니다.
- 추가 컴포넌트가 타겟 에디터에만 있으면 해당 추가 컴포넌트를 제거하는 ECO가 생성됩니다.
- 두 에디터 모두에 매칭되지 않은 컴포넌트가 있으면 소프트웨어에 처리 방법을 지정해야 하므로 Failed to Match Unique Identifiers 대화 상자가 열립니다.
e Failed to Match Unique Identifiers 대화 상자
대화 상자 버튼은 다음 옵션을 제공합니다.
- Automatically Create Component Links - 매칭되지 않은 컴포넌트의 Designator가 이미 서로 일치한다는 것을 알고 있다면 이 버튼을 클릭합니다. 소프트웨어는 컴포넌트 Designator를 사용하여 이러한 추가 컴포넌트에 일치하는 UID를 할당합니다. Designator로 매칭할 수 있는 컴포넌트에 다른 속성 차이(예: 일치하지 않는 매개변수)가 있으면 이에 대한 ECO가 생성됩니다. Designator로 매칭할 수 없는 컴포넌트가 있으면 이를 추가하거나 제거하는 ECO가 생성됩니다(소스 에디터에 있는 추가 컴포넌트는 추가하고, 타겟 에디터에 있는 추가 컴포넌트는 제거).
-
Manual Component Links - 서로 일치하는 컴포넌트가 있다는 것은 알지만 Designator 상태는 모르는 경우 이 버튼을 클릭합니다. Edit Component Links 대화 상자(아래 설명 참조)가 열리며, 여기서 각 소스 및 타겟 컴포넌트를 수동으로 선택하여 매칭된 컴포넌트 목록으로 옮기고 일치하는 UID를 할당할 수 있습니다. 그런 다음 Designator와 기타 일치하지 않는 컴포넌트 속성을 동기화하는 ECO가 생성됩니다.
- Cancel - 이 버튼을 클릭하면 소스 에디터에 있는 추가 컴포넌트를 추가하고 타겟 에디터의 추가 컴포넌트를 제거하는 ECO가 생성됩니다.
컴포넌트 수동 연결
Schematic 컴포넌트와 해당 PCB 컴포넌트 풋프린트 간의 연결 상태는 Edit Component Links 대화 상자(PCB 에디터의 Projects » Component Links 명령)에서 언제든지 확인하고 관리할 수 있습니다.

Edit Component Links 대화 상자는 UID 불일치를 감지하고 해결하는 데 사용되며, PCB 에디터에서 실행합니다.
대화 상자의 기능을 요약하면 다음과 같습니다.
- 매칭되지 않은 컴포넌트는 왼쪽의 두 Un-Matched Components 열에 표시되고, 일치하는 UID를 공유하는 컴포넌트는 대화 상자 오른쪽의 Matched Components 영역에 표시됩니다.
- 대화 상자 중앙의 화살표 버튼은 선택한 컴포넌트를 수동으로 매칭하거나 매칭을 해제하는 데 사용되며, 현재 매칭된 모든 컴포넌트의 매칭을 해제할 수도 있습니다.
- 대화 상자 하단의 Add Pairs Matched By 버튼과 옵션은 현재 매칭되지 않은 컴포넌트 목록을 검색하고 활성화된 속성(Designator, Comment, 풋프린트)을 기준으로 매칭을 시도하는 데 사용됩니다.
- Perform Update 버튼을 클릭하면 새로 매칭된 각 PCB 컴포넌트에 해당 Schematic 컴포넌트의 UID가 할당됩니다. Matched 내의 항목을 이동한 경우 대화 상자의 섹션을 Unmatched 섹션으로 다시 이동하면, 계속 진행할 경우 기존 컴포넌트 연결이 해제된다는 확인 대화 상자가 나타납니다. Yes 을 클릭하면 업데이트가 진행되고, PCB 문서에서 수정된 컴포넌트 링크를 요약하는 정보 대화 상자가 나타납니다. Matched 섹션의 새 항목은 Link Modified로 요약되며, 이전에 연결되어 있었으나 이제 매칭을 해제한 항목은 Link Removed로 요약됩니다.
- 이 대화 상자를 사용하여 컴포넌트를 수동으로 연결한 후에는 동기화 상태를 확인하는 것이 좋습니다(Design » Update 명령 실행).
Net 및 클래스 매칭
Net과 클래스에는 모두 상위 항목(Net 또는 클래스)과 하위 항목(해당 Net 또는 클래스의 멤버)이 있습니다. 이들을 매칭하려면 상위 항목, 하위 항목 또는 둘 모두의 변경을 지원할 수 있도록 컴포넌트 연결에 사용되는 UID 방식과는 다른 접근 방식이 필요합니다. 예를 들어, Schematic에서 Net 이름을 변경하는 간단한 작업 때문에 PCB에서 해당 Net과 모든 하위 핀을 제거하고, 새 이름의 Net을 추가한 다음, 모든 하위 핀을 새 Net에 추가해야 해서는 안 됩니다.
이를 지원하기 위해 소프트웨어에는 멤버와 이름을 기준으로 Net과 클래스를 매칭하는 별도의 알고리즘이 포함되어 있습니다. 매칭 프로세스는 Options for Project 대화 상자의 Comparator 탭에 있는 Object Matching Criteria 섹션에서 설정합니다.

Default 설정은 먼저 멤버를 기준으로 매칭한 다음 객체 유형 이름을 기준으로 매칭하는 것입니다.
이러한 유형의 객체 매칭은 다음과 같이 처리됩니다.
- 설계 동기화 시 Default 동작은 Min Match % 및 Min Match Member 설정에 따라 먼저 멤버를 기준으로 매칭을 시도하는 것입니다.
- 멤버 매칭에 실패하면 소프트웨어는 이름을 기준으로 매칭을 시도합니다(Use Name Matching 옵션이 활성화된 경우).
- 이 두 매칭 프로세스 중 하나라도 성공하면 Engineering Change Order 대화 상자로 진행합니다.
-
두 매칭 방식이 모두 실패하거나 Use Name Matching 옵션이
Never로 설정되어 있으면 Match Manually 대화 상자가 열립니다.
- Match Manually 대화 상자에서 No을 클릭하면 사용자 매칭 프로세스를 건너뛰고 바로 Engineering Change Order 대화 상자로 이동합니다. 매칭되지 않은 객체의 매칭을 시도하지 않았으므로 소프트웨어는 참조 객체와 타겟 객체가 서로 관련이 없다고 가정합니다. 따라서 보드에서 Unmatched Reference Objects을 제거하고 Unmatched Target Objects을 새 객체로 추가하는 ECO가 생성됩니다.
- 대화 상자에서 Yes을 클릭하여 수동으로 매칭하면 아래와 같이 Match 대화 상자가 열립니다(대화 상자 제목은 매칭되지 않은 객체 유형에 맞게 변경됩니다).
Match 대화 상자는 서로 대응하는 것으로 알고 있는 객체를 수동으로 매칭하는 데 사용됩니다. 확실하지 않으면 오른쪽을 비워 두고 Continue을 클릭하세요.
매칭 대화 상자의 옵션 및 컨트롤
-
Unmatched <Object>
- Unmatched Reference Objects - 매칭되지 않은 객체를 나열합니다. 펼치기/접기 컨트롤을 사용하여 목록을 열거나 닫습니다.
- Unmatched Target Objects - 타겟 객체를 나열합니다. 펼치기/접기 컨트롤을 사용하여 목록을 열거나 닫습니다.
-
- 클릭하면 선택한 참조 객체와 타겟 객체를 매칭하고, 선택한 객체를 Unmatched 영역에서 Matched Pairs 영역으로 이동합니다.
-
- 클릭하면 선택한 객체를 Matched Pairs 영역에서 Unmatched 영역으로 이동합니다. 이 작업을 수행하면 이동한 객체의 매칭이 해제됩니다.
-
- 클릭하면 모든 객체를 Matched Pairs 영역에서 Unmatched 영역으로 이동합니다. 이 작업을 수행하면 이동한 객체의 매칭이 해제됩니다.
- Matched Pairs - 현재 매칭된 Reference Object 및 Target Object 을 나열합니다.
- Continue - 클릭하면 매칭 업데이트를 적용하고 Engineering Change Order 대화 상자를 엽니다.
- 이 대화 상자에서 Unmatched Reference Objects 및 Unmatched Target Objects의 매칭할 객체를 선택한 다음 대화 상자의 Matched Pairs 섹션으로 이동합니다. 이러한 객체에 대해 소프트웨어는 이름이 일치하도록 업데이트하는 ECO와 멤버도 일치하도록 제거/추가하는 ECO를 생성합니다.
- 확실하지 않으면 객체를 수동으로 매칭하지 않아도 됩니다. 매칭되지 않은 객체에 대해서는 소프트웨어가 참조 객체와 타겟 객체가 서로 관련이 없다고 가정하므로, 보드에서 Unmatched Reference Objects을 제거하고 Unmatched Target Objects을 새 객체로 추가하는 ECO를 생성합니다.
- 서로 대응하는 것으로 알고 있는 객체를 모두 매칭한 후 Continue을 클릭하여 Engineering Change Order 대화 상자를 엽니다.
- Cancel을 클릭하면 업데이트 프로세스가 종료됩니다.
Design Rule 매칭
Schematic에 정의된 Design Rule도 PCB의 대응하는 Rule에 연결되어야 합니다. 연결 메커니즘이 없다면 Schematic의 Rule을 업데이트하고 해당 변경 사항을 PCB에 반영할 수 없습니다. UID는 Schematic의 Design Rule을 PCB의 Design Rule에 연결하는 데 사용됩니다.
UID는 Schematic에서 Rule 정의를 포함하는 파라미터 세트에 자동으로 할당되며, 설계 동기화 중에 PCB로 전송됩니다.
Design Rule은 UID를 사용하여 Schematic의 Design Rule 정의를 PCB의 Design Rule과 매칭합니다.
일반적으로 PCB Editor의 PCB Rules and Constraints 대화 상자에서 UID를 수동으로 편집한 경우가 아니라면 Rule의 일치 여부를 수동으로 관리할 필요가 없습니다. UID가 일치하지 않으면 소프트웨어는 일치하는 PCB Rule이 없는 각 Schematic Rule에 대해 PCB에 새 Rule을 추가하고, 일치하는 Schematic Design Rule이 없는 PCB Design Rule을 제거합니다.
