Setting Up a Draftsman Document
Altium Essentials: Draftsman
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Dowiedz się, jak utworzyć nowy dokument Draftsman, wybrać szablony oraz przypisać właściwy projekt i źródłowe PCB.
- Zobacz, jak Draftsman zachowuje powiązanie z danymi PCB i jak odświeżyć dokument po wprowadzeniu zmian w projekcie płytki.
- Poznaj najważniejsze opcje dokumentu i ustawienia parametrów, które wpływają na wygląd i działanie dokumentu Draftsman.
Draftsman tworzy i zapisuje pliki rysunków PCB w dedykowanym formacie pliku (*.PCBDwf).
Tworzenie nowego dokumentu Draftsman
Aby utworzyć nowy dokument Draftsman, użyj polecenia File » New » Draftsman Document z menu głównego lub kliknij prawym przyciskiem myszy wpis odpowiedniego projektu w panelu Projects, a następnie wybierz polecenie Add New to Project » Draftsman Document z menu kontekstowego. Otwarte okno dialogowe New Document umożliwia wybranie gotowego szablonu dokumentu lub opcji [Default], która tworzy pusty dokument A4.

Utwórz pusty dokument Draftsman lub dokument oparty na szablonie dla wskazanego projektu i PCB.
W przypadku szablonów z Workspace (wymienionych pod wpisem połączonego Workspace w formacie <TemplateName> (v.<Revision>)) zostanie użyta najnowsza rewizja każdego dostępnego szablonu. Kliknij przycisk
, aby przejść do strony Zarządzanie danymi – Szablony w oknie dialogowym Preferences.
Oprócz wybranego szablonu dokumentu można wskazać konkretny Project (gdy w Altium Designer otwartych jest wiele projektów) oraz źródłowy Document PCB znajdujący się w wybranym projekcie. Nowy dokument zostanie dodany do wskazanego projektu i będzie z niego pobierał dane, a projekt ten stanie się projektem aktywnym.
Pola wyboru Layers w oknie dialogowym określają, które warstwy płytki (Signal/Plane, Mask, Paste i/lub Silk, zgodnie z definicją stosu warstw) są używane do generowania rysunków produkcyjnych w dokumencie, gdy używany jest szablon dokumentacji produkcyjnej. Rysunki produkcyjne będą tworzone po jednym na arkusz, jeśli właściwość Layer odpowiedniego widoku produkcyjnego płytki jest ustawiona na All (for document template) w wybranym szablonie.
Synchronizowanie dokumentu Draftsman z PCB
Draftsman pobiera dane projektowe bezpośrednio z warstw miedzi, komponentów i mechanicznych PCB. Po zmianie danych PCB można odświeżyć dane w dokumencie Draftsman, klikając prawym przyciskiem myszy w dowolnym miejscu dokumentu i wybierając Import Changes From <PCBDocumentName>.PcbDoc z menu kontekstowego lub wybierając polecenie Tools » Import Changes From <PCBDocumentName>.PcbDoc z menu głównego.
Ogólne opcje dokumentu
Ustawienia całego dokumentu Draftsman (który może składać się z wielu arkuszy/stron – dowiedz się więcej) są dostępne na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Ustawienia te określają źródłowe dane projektowe dokumentu, styl graficzny, zachowanie rysunków i stosowane jednostki. Zmiany tych ustawień zastępują domyślne ustawienia właściwości zdefiniowane w zastosowanym szablonie dokumentu.
| Grid Size, Show Grid |
Użyj tych opcji, aby skonfigurować siatkę dokumentu. Więcej informacji można znaleźć w sekcji Konfigurowanie siatki i opcji przyciągania. |
| Snapping, Snapping Distance |
Użyj tych opcji, aby skonfigurować funkcję przyciągania. Więcej informacji można znaleźć w sekcji Konfigurowanie siatki i opcji przyciągania. |
| Document Font | Ustaw podstawowy styl czcionki i dodatkowe atrybuty używane w arkuszach dokumentu. Określa to czcionkę na poziomie dokumentu, stosowaną do obiektów rysunkowych, takich jak tytuł widoku montażowego płytki. Czcionkę na poziomie dokumentu można zastąpić dla poszczególnych obiektów za pomocą panelu Properties tych obiektów. |
| Sheet Border | Ustaw kolor linii obramowania strefowego i jego oznaczeń w arkuszach dokumentu. |
| Sheet Color | Ustaw kolor tła arkuszy dokumentu. |
| Variants Display, Pattern, Not Fitted Text, Not Fitted Font, Font Size (Min/Max) |
Użyj tych opcji, aby skonfigurować wyświetlanie na widokach montażowych płytki komponentów oznaczonych jako niemontowane w wybranym wariancie projektu. Więcej informacji można znaleźć na stronie Widok montażowy płytki. |
| PCB Document | Ustaw projekt płytki używany jako źródło danych dokumentu Draftsman. Z menu rozwijanego wybierz jeden z dokumentów PCB dostępnych w bieżącym projekcie. |
| Variants | Z menu rozwijanego wybierz wariant projektu płytki, który będzie używany jako źródło danych dokumentu Draftsman. Więcej informacji można znaleźć w sekcji Obsługa wariantów projektu. |
| Scale | Ustaw rozmiar nowo wstawianych widoków całej płytki (takich jak widok montażowy płytki, widok produkcyjny płytki lub widok rysunku wierceń) w bieżącym dokumencie. Więcej informacji o sterowaniu skalą wstawionego widoku można znaleźć na stronie Praca z widokami. |
| Dash Pattern | Definicje długości kresek i odstępów dla opcji linii przerywanych, wyrażone w jednostkach 0,02 mm (w trybie metrycznym). Na przykład wartość wzoru 20,10,20 określa powtarzający się układ kresek o długościach 0,4 mm, 0,2 mm i 0,4 mm, o długości cyklu 1 mm (50 jednostek). Niestandardowy wariant linii przerywanej można utworzyć za pomocą przycisku |
| Line Thicknesses | Grubość dostępnych wariantów stylu linii. Użyj przycisku |
| Units | Ustaw podstawową jednostkę miary dokumentu. |
| Dual Units | Ustaw dodatkową jednostkę miary dokumentu (do podwójnego wymiarowania). Dodatkowe jednostki można włączyć dla obiektu rysunkowego w jego panelu Properties. |
| Decimal Separator | Z menu rozwijanego wybierz znak używany jako separator dziesiętny. |
| Remove Leading Zero | Włącz tę opcję, aby automatycznie usuwać zero wiodące w przypadku wartości mniejszych niż „1”. Na przykład „0.5” będzie wyświetlane jako „.5”, gdy ta opcja jest włączona. Dimensioning and Tolerancing, ASME Y14.5, określa, że dla wartości mniejszych niż 1 należy pomijać zera wiodące podczas korzystania z jednostek calowych. |
| Primary Units |
|
| Dual Units |
|
Parametry dokumentu Draftsman
Karta Parameters panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt, przedstawia tabelaryczną listę parametrów dostępnych w bieżącym dokumencie. Lista zawiera parametry projektu (w tym wariantu), systemowe, PCB oraz wszelkie dodane parametry niestandardowe.
Użyj przycisków
i
, aby tworzyć lub usuwać własne parametry niestandardowe.
Użyj pól wyboru u dołu listy, aby określić zakres wyświetlanych parametrów:
(projekt),
(system),
(PCB). Parametry projektu, systemowe i PCB są dostępne tylko do odczytu, natomiast wszelkie dodane parametry niestandardowe można edytować i są one zawsze uwzględniane na liście.
Poniżej przedstawiono predefiniowane parametry systemowe i PCB.
Parametry systemowe
Application_BuildNumber |
Wersja i numer kompilacji bieżącej instalacji Altium Designer. |
BOMPageNumber |
Używany w polu Title we właściwościach tabeli zestawienia materiałowego do wyświetlania numeru bieżącej strony tabeli BOM. |
BOMTotalPages |
Używany w polu Title we właściwościach tabeli zestawienia materiałowego do wyświetlania łącznej liczby stron tabeli BOM. |
ComponentName |
Używany w polu Title we właściwościach widoku komponentu do wyświetlania komentarza komponentu, dla którego utworzono widok. |
CurrentDate |
Bieżąca data, określana automatycznie na podstawie ustawień systemowych. |
CurrentTime |
Bieżąca godzina, określana automatycznie na podstawie ustawień systemowych. |
DocumentFullPathAndName |
Pełna ścieżka i nazwa pliku dokumentu Draftsman. Przykład: C:\MyTestDesign\Kame_FMU_asm_rm.PCBDwf. |
DocumentName |
Sama nazwa pliku dokumentu Draftsman (bez ścieżki do pliku). Przykład: Kame_FMU_asm_rm.PCBDwf. |
DocumentScale |
Skala wybrana dla dokumentu Draftsman. |
DocumentUnits |
Jednostki miary wybrane dla dokumentu Draftsman. |
FootprintName |
Używany w polu Title we właściwościach widoku komponentu do wyświetlania nazwy footprintu komponentu, dla którego utworzono widok. |
HoleName |
Używany w polu Title we właściwościach widoku otworu z pogłębieniem do wyświetlania nazwy pola lutowniczego (z uwzględnieniem jego oznaczenia, położenia na PCB i warstwy), dla którego utworzono widok. |
ModifiedDate |
Znacznik daty modyfikacji pliku dokumentu Draftsman; jest uzupełniany automatycznie. |
ProjectName |
Rzeczywista nazwa projektu nadrzędnego dokumentu Draftsman (wraz z rozszerzeniem). Przykład: Sample - Kame_FMU.PrjPcb. |
Revision |
Wyświetla wartość określoną dla domyślnego parametru na poziomie dokumentu Revision. |
SheetNumber |
Po umieszczeniu jako ciąg specjalny wyświetla numer bieżącego arkusza dokumentu Draftsman. |
SheetNumber_OneSheet |
Po umieszczeniu jako ciąg specjalny wyświetla numer bieżącego arkusza dokumentu Draftsman. Nie wyświetla żadnej wartości, jeśli dokument Draftsman zawiera tylko jeden arkusz. |
SheetTotal |
Łączna liczba arkuszy dokumentu Draftsman. |
VersionControl_PCBDocumentRevNumber |
Numer bieżącej rewizji źródłowej płytki PCB dokumentu Draftsman. Aby ten ciąg zawierał jakiekolwiek informacje, konieczne jest korzystanie z kontroli wersji. |
VersionControl_PCBDocumentRevNumberShort |
Skrócony hash Git (pierwsze osiem znaków) i status VCS bieżącej rewizji źródłowej płytki PCB dokumentu Draftsman. Aby ten ciąg zawierał jakiekolwiek informacje, konieczne jest korzystanie z kontroli wersji. |
VersionControl_PrjFolderRevNumber |
Numer bieżącej rewizji projektu, zwiększany przy każdym pełnym zatwierdzeniu projektu (tj. obejmującym plik projektu). Aby ten ciąg zawierał jakiekolwiek informacje, konieczne jest korzystanie z kontroli wersji. |
VersionControl_PrjFolderRevNumberShort |
Skrócony hash Git (pierwsze osiem znaków) i status VCS projektu. Aby ten ciąg zawierał jakiekolwiek informacje, konieczne jest korzystanie z kontroli wersji. |
VersionControl_RevNumber |
Numer bieżącej rewizji dokumentu Draftsman. Aby ten ciąg zawierał jakiekolwiek informacje, konieczne jest korzystanie z kontroli wersji. |
VersionControl_RevNumberShort |
Skrócony hash Git (pierwsze osiem znaków) i status VCS bieżącej rewizji dokumentu Draftsman. Aby ten ciąg zawierał jakiekolwiek informacje, konieczne jest korzystanie z kontroli wersji. |
ViewLabel |
Używany w polu Title we właściwościach widoku przekroju płytki lub widoku szczegółowego płytki do wyświetlania Label zastosowanego do widoku. |
ViewLayerName |
Używany w polu Title we właściwościach widoku produkcyjnego płytki do wyświetlania Layer, dla którego utworzono widok. |
ViewScale |
Używany w polu Title we właściwościach widoku do wyświetlania wybranego dla tego widoku Scale. |
ViewSide |
Używany w polu Title we właściwościach widoku montażowego płytki, widoku produkcyjnego płytki, widoku komponentu lub widoku izometrycznego płytki do wyświetlania View Side / Face side, dla których utworzono widok. |
ViewVariantName |
Używany w polu Title we właściwościach widoku montażowego płytki lub widoku izometrycznego płytki do wyświetlania Variation, dla którego utworzono widok. |
Parametry PCB
Arc_Count |
Liczba obiektów łuków na źródłowej płytce PCB dokumentu Draftsman. |
BoardArea |
Powierzchnia źródłowej płytki PCB dokumentu Draftsman wyrażona w podstawowych jednostkach miary wybranych dla dokumentu Draftsman. |
BoardDensity |
Gęstość źródłowej płytki PCB dokumentu Draftsman. |
BoardHeight |
Wysokość źródłowej płytki PCB dokumentu Draftsman wyrażona w podstawowych jednostkach miary wybranych dla dokumentu Draftsman. |
BoardWidth |
Szerokość źródłowej płytki PCB dokumentu Draftsman wyrażona w podstawowych jednostkach miary wybranych dla dokumentu Draftsman. |
BlindVia_Count |
Liczba przelotek ślepych na źródłowej płytce PCB dokumentu Draftsman. |
BuriedVia_Count |
Liczba przelotek zagrzebanych na źródłowej płytce PCB dokumentu Draftsman. |
Component_Count |
Liczba obiektów komponentów na źródłowej płytce PCB dokumentu Draftsman. |
ComponentMixed_Count |
Liczba komponentów z mieszanymi padami (zarówno SMD, jak i przewlekanymi) na źródłowej płytce PCB dokumentu Draftsman. |
ComponentsArea |
Powierzchnia zajmowana przez komponenty na źródłowej płytce PCB dokumentu Draftsman wyrażona w podstawowych jednostkach miary wybranych dla dokumentu Draftsman. |
ComponentSMD_Count |
Liczba komponentów z padami SMD na źródłowej płytce PCB dokumentu Draftsman. |
ComponentThru_Count |
Liczba komponentów z padami przewlekanymi na źródłowej płytce PCB dokumentu Draftsman. |
ComputerName |
Nazwa systemowa komputera, na którym utworzono dokument Draftsman. |
CopperInner_Weight_Max |
Maksymalna gramatura miedzi na warstwach wewnętrznych. |
CopperOuter_Weight_Max |
Maksymalna gramatura miedzi na warstwach zewnętrznych. |
Fill_Count |
Liczba obiektów wypełnień na źródłowej płytce PCB dokumentu Draftsman. |
Hole_Count |
Liczba otworów w padach i przelotkach na źródłowej płytce PCB dokumentu Draftsman. |
Hole_Size_Min |
Minimalna średnica otworu na źródłowej płytce PCB dokumentu Draftsman wyrażona w podstawowych jednostkach miary wybranych dla dokumentu Draftsman. |
Hole_Size_Num |
Liczba unikatowych średnic otworów na źródłowej płytce PCB dokumentu Draftsman. |
Item |
Nazwa najnowszego elementu projektu PCB, w którym opublikowano dane źródłowe projektu za pomocą narzędzia Project Releaser. Przykład: SRC-Sample - Kame_FMU. |
ItemRevision |
Rewizja najnowszego elementu projektu PCB, w którym opublikowano dane źródłowe projektu za pomocą narzędzia Project Releaser. Przykład: 01.A.1. |
ItemRevisionBase |
Część poziomu bazowego rewizji najnowszego elementu projektu PCB, w którym opublikowano dane źródłowe projektu za pomocą narzędzia Project Releaser. Przykład: 1. |
ItemRevisionLevel1 |
Część poziomu 1 rewizji najnowszego elementu projektu PCB, w którym opublikowano dane źródłowe projektu za pomocą narzędzia Project Releaser. Przykład: A. |
ItemRevisionLevel2 |
Część poziomu 2 rewizji najnowszego elementu projektu PCB, w którym opublikowano dane źródłowe projektu za pomocą narzędzia Project Releaser. Przykład: 01. |
Layer_Count |
Liczba warstw miedzi na źródłowej płytce PCB dokumentu Draftsman. |
MicroVia_Count |
Liczba mikroprzelotek na źródłowej płytce PCB dokumentu Draftsman. |
Net_Count |
Liczba sieci na źródłowej płytce PCB dokumentu Draftsman. |
Pad_Count |
Liczba obiektów padów na źródłowej płytce PCB dokumentu Draftsman. |
Pcb_File_Name |
Pełna ścieżka i nazwa pliku źródłowej płytki PCB dokumentu Draftsman. Przykład: C:\MyTestDesign\Kame_FMU.PcbDoc. |
Pcb_File_Name_No_Path |
Sama nazwa pliku źródłowej płytki PCB dokumentu Draftsman (bez ścieżki pliku). Przykład: Kame_FMU.PcbDoc. |
PCBConfigurationName |
Nazwa zestawu danych, na podstawie którego wygenerowano dane wyjściowe, zdefiniowana w Release widoku (Project Releaser). |
PadSMD_Count |
Liczba padów SMD na źródłowej płytce PCB dokumentu Draftsman. |
PadThru_Count |
Liczba padów przewlekanych na źródłowej płytce PCB dokumentu Draftsman. |
Poly_Count |
Liczba obiektów wylewek poligonowych na źródłowej płytce PCB dokumentu Draftsman. |
SlotHole_Count |
Liczba obiektów padów z otworami podłużnymi na źródłowej płytce PCB dokumentu Draftsman. |
SolderMask_Bottom |
Dostępność dolnej maski lutowniczej. Jeśli nie ma warstwy dolnej maski lutowniczej, parametr przyjmie wartość No mask. Jeśli warstwa dolnej maski lutowniczej istnieje, ale jej kolor nie jest zdefiniowany, parametr przyjmie wartość No color. Jeśli warstwa dolnej maski lutowniczej istnieje i ma zdefiniowany kolor, parametr będzie wskazywać ten kolor — jego nazwę (Green, Black, Blue, Red itd.) lub kod RGBA (np. #FF0065FF). |
SolderMask_Top |
Dostępność górnej maski lutowniczej. Jeśli nie ma warstwy górnej maski lutowniczej, parametr przyjmie wartość No mask. Jeśli warstwa górnej maski lutowniczej istnieje, ale jej kolor nie jest zdefiniowany, parametr przyjmie wartość No color. Jeśli warstwa górnej maski lutowniczej istnieje i ma zdefiniowany kolor, parametr będzie wskazywać ten kolor — jego nazwę (Green, Black, Blue, Red itd.) lub kod RGBA (np. #FF0065FF). |
SquareHole_Count |
Liczba obiektów padów z otworami prostokątnymi na źródłowej płytce PCB dokumentu Draftsman. |
StackedVia_Count |
Liczba przelotek ułożonych w stos na źródłowej płytce PCB dokumentu Draftsman. |
String_Count |
Liczba obiektów tekstowych na źródłowej płytce PCB dokumentu Draftsman. |
Thru_Via_Count |
Liczba przelotek przelotowych na źródłowej płytce PCB dokumentu Draftsman. |
Total_Thickness |
Całkowita grubość źródłowej płytki PCB dokumentu Draftsman. |
Track_Count |
Liczba obiektów ścieżek na źródłowej płytce PCB dokumentu Draftsman. |
VariantName |
Nazwa wariantu projektu wybranego dla dokumentu Draftsman. |
Via_Count |
Liczba obiektów przelotek na źródłowej płytce PCB dokumentu Draftsman. |
Konfigurowanie siatki i opcji przyciągania
Przed rozpoczęciem umieszczania obiektów w dokumencie Draftsman ustaw siatki i skonfiguruj opcje przyciągania, aby ułatwić rozmieszczanie obiektów. Opcje siatki i przyciągania konfiguruje się w obszarze General na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt.
W obszarze projektowym linie siatki są wyświetlane jako linie kropkowane, a co dziesiąta linia siatki jest rysowana linią ciągłą. Ustaw odległość między liniami siatki za pomocą pola Grid Size w panelu Properties, gdy w dokumencie nie jest zaznaczony żaden obiekt. Wartość siatki można również ustawić w oknie dialogowym Snap Grid (1..1000) , otwieranym przez wybranie polecenia View » Set Grid Size z menu głównego (skrót: G).
Użyj opcji Show Grid , aby sterować wyświetlaniem linii siatki na arkuszach dokumentu. Użyj odpowiedniego przycisku koloru, aby określić kolor siatki w obszarze projektowania.
Przyciąganie ułatwia umieszczanie i przesuwanie obiektów na arkuszach dokumentu Draftsman. Funkcja ta przyciąga obiekt podstawowy do punktów lub prowadnic wyznaczanych przez istniejące obiekty albo przez siatkę zdefiniowaną dla dokumentu. Pozwala to szybko i łatwo wyrównywać różne elementy na stronach dokumentu. Przyciąganie można włączyć lub wyłączyć za pomocą opcji Snapping w panelu Properties lub polecenia View » Toggle Snapping w menu głównym (skrót: Shift+E).
Po włączeniu funkcji przyciągania można ją dodatkowo skonfigurować, niezależnie włączając lub wyłączając poniższe opcje.
| Snap to Grid | Po włączeniu tej opcji kursor podglądu będzie przyciągany (przeskakiwał) do przecięć linii siatki, gdy edytor znajduje się w trybie umieszczania obiektów. Należy pamiętać, że przyciąganie do siatki nie działa, gdy siatka nie jest wyświetlana (tj. gdy opcja Show_Grid jest wyłączona). |
| Snap to Vertices | Po włączeniu tej opcji kursor podglądu będzie przyciągany do narożnika (wierzchołka) obiektu, gdy edytor znajduje się w trybie umieszczania obiektów. Wierzchołek jest oznaczany pomarańczową kropką, gdy kursor podglądu zostanie do niego przyciągnięty. |
| Snap to Boundaries | Po włączeniu tej opcji kursor podglądu będzie przyciągany do linii obrysu obiektu (lub przedłużenia tej krawędzi), gdy edytor znajduje się w trybie umieszczania obiektów. Przedłużenia obrysu obiektu są wyświetlane jako cienkie linie przerywane. |
| Snap to Line centers | Po włączeniu tej opcji kursor podglądu będzie przyciągany do środka odcinka obrysu obiektu, gdy edytor znajduje się w trybie umieszczania obiektów. Środek odcinka jest oznaczany pomarańczową kropką, gdy kursor podglądu zostanie do niego przyciągnięty. |
| Snap to Circle centers | Po włączeniu tej opcji kursor podglądu będzie przyciągany do środka okręgu, gdy edytor znajduje się w trybie umieszczania obiektów. Środek okręgu jest oznaczany pomarańczową kropką, gdy kursor podglądu zostanie do niego przyciągnięty. |
| Snap to component references | Po włączeniu tej opcji kursor podglądu będzie przyciągany do punktów odniesienia komponentów. |
| Snap to Visible primitives | Po włączeniu tej opcji kursor podglądu będzie przyciągany (zgodnie z pozostałymi opcjami przyciągania) do obiektów podstawowych widocznych w bieżącym widoku arkusza. Po wyłączeniu tej opcji kursor będzie przyciągany do wszystkich obiektów znajdujących się na arkuszu. ![]() |
Użyj opcji Snapping Distance, aby wprowadzić odległość, przy której kursor podglądu będzie przyciągany do elementów określonych jako cele przyciągania. Możesz też wybrać z listy rozwijanej wartość względem bieżącej siatki (np. 0.5x Snap Grid).
Konfigurowanie arkuszy (stron) dokumentu
Dokumenty Draftsman mają format wieloarkuszowy, dzięki czemu mogą zawierać osobne strony (arkusze) przeznaczone na określone rodzaje informacji produkcyjnych dotyczących projektu płytki.
Arkusze można dodawać do bieżącego dokumentu i usuwać z niego za pomocą poleceń Add New Sheet i Remove Sheet dostępnych w menu głównym Tools lub w menu kontekstowym obszaru projektowania. Nowy arkusz jest wstawiany za arkuszem, na którym znajduje się kursor w chwili uruchomienia polecenia, a jego wygląd będzie zgodny z szablonem arkusza Draftsman aktualnie zastosowanym do arkusza bezpośrednio go poprzedzającego.
Ustawienia poszczególnych stron (arkuszy) dokumentu Draftsman można określić na karcie Page Options panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt. Ustawienia te określają podstawową strukturę strony (rozmiar, marginesy itp.).
Zmiany właściwości w opcjach strony można zastosować do bieżącej strony lub do wszystkich stron dokumentu. Wybierz przycisk
u góry panelu Properties, aby zastosować zmienione ustawienia właściwości do bieżącego arkusza, lub przycisk
, aby zastosować zmiany do wszystkich arkuszy dokumentu. Numer bieżącej strony jest wyświetlany na liście rozwijanej Current Page, z której można też wybrać stronę.
W sekcji Formatting and Size panelu można wybrać sposób definiowania formatu strony.
| Template | Ustaw rozmiar i format strony, wybierając jeden z dostępnych szablonów arkuszy Draftsman. W przypadku szablonów z przestrzeni roboczej (wymienionych pod pozycją odpowiadającą połączonej przestrzeni roboczej, w formacie |
| Standard | Ustaw rozmiar arkusza na standardowy format strony. Użyj listy rozwijanej Sheet Size, aby wybrać jeden ze standardowych wymiarów strony. |
| Custom | Ustaw niestandardowe wymiary arkusza za pomocą pól Width i Height. Pamiętaj, że maksymalna wartość szerokości lub wysokości, jaką można wprowadzić, wynosi 20000 mm. |
Opcje w sekcji Margin and Zones panelu określają rozmiar ramki arkusza i jej podział na strefy.
| Show Zones | Włącz tę opcję, aby wyświetlić podział ramki na strefy. |
| Vertical | Ustaw liczbę podziałów (wierszy) na pionowym marginesie arkusza. Typ alfanumerycznych oznaczeń stref jest określany przez ustawienia Origin i Letter Position w tej sekcji panelu. |
| Horizontal | Ustaw liczbę podziałów (kolumn) na poziomym marginesie arkusza. Typ alfanumerycznych oznaczeń stref jest określany przez ustawienia Origin i Letter Position w tej sekcji panelu. |
| Margin | Ustaw odległość między krawędzią strony a każdą z czterech linii ramki. |
| Origin | Określ, od którego narożnika arkuszy dokumentu mają zaczynać się alfanumeryczne oznaczenia stref na obwodzie (pozycja strefy A-1 lub 1-A). |
| Letter Position | Określ, gdzie na arkuszach dokumentu mają być umieszczane literowe oznaczenia stref: w poziomych strefach obwodowych (kolumnach) czy w strefach pionowych (wierszach). Zaznacz opcję Iterate Columns Across Sheets, aby oznaczenia alfanumeryczne przypisane do kolumn były kolejno zwiększane we wszystkich arkuszach dokumentu (zamiast zaczynać od A lub 1 na każdym arkuszu). |
Nawigowanie po dokumencie Draftsman za pomocą panelu Bookmarks
Panel Bookmarks umożliwia wygodne nawigowanie po wieloarkuszowych dokumentach Draftsman i zarządzanie nimi. Panel przedstawia rozwijane drzewo całej struktury dokumentu, podobnie jak panel Projects, i zawiera wszystkie arkusze dokumentu oraz główne obiekty widoków w tych arkuszach.

Użyj panelu Bookmarks, aby poruszać się między widokami w wieloarkuszowym dokumencie Draftsman.
Panel Bookmarks przedstawia uporządkowane drzewo arkuszy i obiektów w dokumencie Draftsman, w którym każdy wpis arkusza można rozwijać i zwijać. Draftsman automatycznie nadaje nazwy wpisom arkuszy w kolejności malejącej. Elementy podrzędne każdego wpisu arkusza w panelu obejmują obiekty typu widok Draftsman znajdujące się na tym arkuszu, ale nie obejmują pomocniczych obiektów rysunkowych, takich jak wymiary, odnośniki, kształty graficzne itp.
Panel Bookmarks zapewnia aktywną nawigację: arkusz lub obiekt rysunkowy wybrany w drzewie jest wyświetlany w obszarze projektowania. Obiekt wybrany w drzewie zostaje również zaznaczony w widoku rysunku, a powiększenie jest dostosowywane tak, aby go pokazać. Nawigacja w drzewie działa w obu kierunkach, dlatego zaznaczenie w nim zmienia się również w odpowiedzi na wybór arkuszy lub obiektów w obszarze projektowania.
Panel Bookmarks zawiera dodatkowe funkcje zarządzania arkuszami dokumentu, takie jak dodawanie i usuwanie arkuszy oraz zmiana ich kolejności w strukturze dokumentu Draftsman. Przyciski funkcji u góry panelu służą do zarządzania widokiem i strukturą arkuszy dokumentu:
-
Ustaw sposób wyświetlania stron dokumentu za pomocą przycisków Single/Continuous: przycisk
ustawia obszar projektowania tak, aby wyświetlał jeden arkusz naraz, a przycisk
włącza tryb ciągły, w którym wszystkie arkusze są wyświetlane w przewijanej sekwencji.
-
Kliknij przycisk
, aby dodać nowy arkusz dokumentu za aktualnie wybranym arkuszem. Przycisk
usuwa aktualnie wybrany arkusz z drzewa lub, jeśli wybrano obiekt rysunkowy, usuwa ten obiekt z arkusza.
-
Użyj przycisków
i
, aby przenieść aktualnie wybrany arkusz o jedną pozycję w górę lub w dół drzewa. Arkusz wraz z zawartymi w nim obiektami zmieni odpowiednio pozycję, a jego nazwa zostanie zmieniona tak, aby odpowiadała nowej pozycji w drzewie.
Dodatkowe opcje są dostępne w menu kontekstowym otwieranym prawym przyciskiem myszy dla arkusza lub obiektu w drzewie.
-
Użyj opcji dostępnych po kliknięciu arkusza prawym przyciskiem myszy, aby usunąć wybrany arkusz, dodać nowy arkusz do dokumentu lub uzyskać dostęp do jego właściwości w panelu Properties, który zostanie otwarty, jeśli nie jest jeszcze otwarty.
-
Użyj opcji dostępnych po kliknięciu obiektu prawym przyciskiem myszy, aby usunąć wybrany obiekt lub uzyskać dostęp do jego właściwości w panelu Properties, który zostanie otwarty, jeśli nie jest jeszcze otwarty.
Obsługa wariantów projektu
W Altium Designer można tworzyć odmiany projektu płytki (warianty projektu) i przekazywać informacje o nich do Draftsman, co z kolei pozwala zastosować wariant projektu do umieszczonego widoku rysunku lub tabeli BOM. Do każdego wariantu można dodać parametry. Parametry te są zwykle stosowane w dokumentach Altium Designer jako ciągi specjalne (interpretowane), aby wskazać, który wariant jest aktualnie aktywny.
W Draftsman bieżący wariant projektu na poziomie dokumentu wybiera się z listy rozwijanej Variants w sekcji Properties na karcie General panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt.
Umieszczone widoki: widok montażowy płytki, widok izometryczny płytki i widok realistyczny płytki będą odzwierciedlać wybrany wariant. W przypadku widoku montażowego płytki sposób wyświetlania niemontowanych komponentów zależy od skonfigurowanych opcji dokumentu (dowiedz się więcej). W przypadku widoku izometrycznego płytki lub widoku realistycznego płytki niemontowane komponenty nie są wyświetlane Bieżący wariant dla widoku można wybrać w panelu Properties, gdy widok jest zaznaczony w obszarze projektowania.
Ciągi specjalne, takie jak =VariantName i parametry wariantów, można umieszczać na rysunku jako swobodne ciągi tekstowe.
Więcej informacji o obiektach tekstowych można znaleźć na stronie Praca z adnotacjami.
)
)
)
)
).
)
).
).
)
).