Working with Tables

W skrócie

W tym artykule wyjaśniamy, jak umieszczać i konfigurować tabele w dokumentach Draftsman w Altium Designer. Szczególną uwagę poświęcamy tabelom zestawienia materiałowego (BOM) oraz temu, jak ich dane są pobierane bezpośrednio z projektu PCB, ActiveBOM, wariantów i widoków montażowych. Omawiamy najważniejsze ustawienia dostępne w panelu Properties, w tym formatowanie, wybór źródła danych, tryby widoku, filtrowanie według wariantów, zarządzanie kolumnami oraz obsługę wielostronicowych zestawień BOM w większych projektach. Jeśli chcesz lepiej zrozumieć, jak dokładnie i czytelnie przedstawiać dane produkcyjne i montażowe w dokumentach Draftsman, znajdziesz tu opis dostępnych opcji i wskazówki dotyczące ich skutecznego wykorzystania. Czytaj dalej, aby zyskać większą kontrolę nad dokumentacją PCB.

- Dowiesz się, skąd pochodzą dane tabeli BOM i jak opcje Project i Board, warianty oraz widoki montażowe wpływają na wyświetlaną zawartość.
- Zobaczysz, jak dostosować wygląd i strukturę tabeli BOM, w tym tytuły, czcionki, kolory wierszy, kolumny, sortowanie i aliasy.
- Zrozumiesz, jak działa dzielenie tabel BOM, dzięki czemu będziesz w stanie przedstawiać obszerne zestawienia materiałowe w wielu obiektach tabel i na wielu stronach.
Zagłęb się w temat dzięki AI:

Dokument Draftsman umożliwia umieszczanie na rysunku różnych tabel danych i konfigurowanie ich zgodnie z potrzebami. Dane tabelaryczne są pobierane bezpośrednio z dokumentu PCB projektu i pozwalają w prosty, przejrzysty sposób przekazywać kluczowe informacje dotyczące procesów produkcji i montażu PCB.

Typ tabeli do umieszczenia można wybrać z menu głównego Place.

Zestawienie materiałowe

Zestawienie materiałowe Draftsman (Place » Bill Of Materials) to automatycznie generowany obiekt tabeli zawierający listę fizycznych elementów montażowych w projekcie PCB. Dane tabeli BOM są pobierane bezpośrednio z dokumentu ActiveBOM projektu lub, jeśli dokument ActiveBOM nie występuje w bieżącym projekcie, bezpośrednio z dokumentów źródłowych projektu. Tabela BOM może również przedstawiać elementy składowe określonego wariantu projektu lub umieszczonego widoku montażowego płytki.

Tabela zestawienia materiałowego podzielona na dwa obiekty BOM. W powyższym przykładzie zawartość BOM jest filtrowana tak, aby obejmowała elementy z widoku montażowego górnej strony płytki.
Tabela zestawienia materiałowego podzielona na dwa obiekty BOM. W powyższym przykładzie zawartość BOM jest filtrowana tak, aby obejmowała elementy z widoku montażowego górnej strony płytki.

Styl wizualny i zawartość danych umieszczonej tabeli zestawienia materiałowego można skonfigurować w panelu Properties, gdy tabela jest zaznaczona w obszarze projektowym. Ogólne właściwości tabeli konfiguruje się na karcie General tego panelu ().

Tytuł

Tytuł

Tekst tytułu wyświetlany wraz z tabelą (jeśli jest włączony). Użyj powiązanego przycisku , aby przełączać widoczność tytułu na rysunku.

Pole może zawierać tekst statyczny oraz dowolne parametry w postaci ciągów specjalnych. Użyj składni =<ParameterName>, aby uwzględnić parametr w tytule. Wartości uwzględnionych parametrów będą wyświetlane w tytule na arkuszu rysunkowym. Listę dostępnych parametrów systemowych i parametrów PCB można znaleźć na stronie Konfigurowanie dokumentu Draftsman.

Location Z listy rozwijanej wybierz jedno z dostępnych położeń tytułu względem tabeli. Opcja Manual jest wybierana automatycznie po ręcznym przeniesieniu tytułu (przeciągnięciu i upuszczeniu w nowym miejscu).
Font

Określa czcionkę używaną w tytule.

  • Gdy opcja Use Document Font jest włączona, w tytule używana jest czcionka zdefiniowana w opcjach dokumentu (pozycja Document Font w sekcji General na karcie General panelu Properties, gdy żaden obiekt nie jest zaznaczony w obszarze projektowym).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać typ, rozmiar i kolor czcionki oraz atrybuty tekstu.

Właściwości

Table Line Style

Użyj list rozwijanych, aby wybrać linię używaną do rysowania tabeli. Dostępne opcje są zdefiniowane w sekcji Line Styles panelu Properties, gdy żaden obiekt nie jest zaznaczony w obszarze projektowym. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman. Użyj powiązanego przycisku koloru, aby określić kolor linii.

Justification Wybierz punkt, względem którego zmienia się położenie tabeli po zmianie jej rozmiaru.
Even Row Color Wybierz kontrastujący kolor parzystych wierszy tabeli.
Non-Even Row Color Wybierz kontrastujący kolor nieparzystych wierszy tabeli.
Font

Określa czcionkę używaną do wyświetlania danych w tabeli.

  • Gdy opcja Use Document Font jest włączona, używana jest czcionka zdefiniowana w opcjach dokumentu (pozycja Document Font w sekcji General na karcie General panelu Properties, gdy żaden obiekt nie jest zaznaczony w obszarze projektowym).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać typ, rozmiar i kolor czcionki oraz atrybuty tekstu.

Tabela zostanie automatycznie przeskalowana, aby dostosować ją do wybranego rozmiaru czcionki.

Data Source Ta opcja oraz ewentualna obecność dokumentu ActiveBOM w projekcie określają dane uwzględniane w tabeli:

 

  • Project – gdy ta opcja jest wybrana, a dokument ActiveBOM jest zawarty w bieżącym projekcie, jego konfiguracja i zawartość stają się źródłem danych tabeli BOM w dokumencie Draftsman. Użyj polecenia Tools » Import Changes From <PCBDocumentName>.PcbDoc w narzędziu Draftsman, aby uwzględnić bieżące zmiany w dokumencie ActiveBOM.
    Jeśli dokument ActiveBOM nie jest zawarty w bieżącym projekcie, dane w tabeli BOM dokumentu Draftsman są pobierane bezpośrednio z dokumentów źródłowych projektu.

  • Board – gdy ta opcja jest wybrana, pozycje w tabeli BOM dokumentu Draftsman są ograniczone do komponentów obecnych na fizycznej płytce PCB projektu.

Assembly View Użyj opcji menu rozwijanego, aby przefiltrować pozycje BOM do elementów widocznych w określonym widoku montażowym płytki.
View Mode
  • Base – każdemu unikatowemu typowi komponentu przypisywany jest wiersz tabeli, a wszystkie uwzględnione elementy są wymienione w kolumnie Designator.

  • Flat – każdemu komponentowi przypisywany jest osobny wiersz tabeli.

  • Consolidated – jeśli projekt źródłowy zawiera warianty, tabela będzie zawierać pozycje komponentów ze wszystkich wariantów projektu. Wybranie tej opcji spowoduje automatyczne ustawienie opcji Variant na [No Variations].

Variant

Użyj menu rozwijanego, aby wybrać wariant projektu, jeśli jest dostępny, jako źródło danych tabeli BOM. Tabela uwzględni pozycje, które nie są montowane lub mają zmienione parametry, zgodnie z opcją Show Components.

Gdy jako Variation wybrano opcję Document : <VariantName>, do tabeli stosowany jest wariant określony dla dokumentu. Wariant na poziomie dokumentu wybiera się za pomocą listy rozwijanej Variants w sekcji Source na karcie General panelu Properties, gdy żaden obiekt nie jest zaznaczony w obszarze projektowym. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman.

Show Components

Po wybraniu wariantu użyj listy rozwijanej, aby określić, które pozycje komponentów mają zostać uwzględnione na liście:

  • Fitted – wyświetlaj tylko komponenty montowane w aktualnie wybranym wariancie projektu.

  • All – wyświetlaj wszystkie komponenty.

  • Not Fitted – wyświetlaj tylko komponenty niemontowane w aktualnie wybranym wariancie projektu.

  • Replaced – wyświetlaj tylko komponenty, dla których wybrano zamienniki, lub montowane komponenty o zmienionych wartościach parametrów w aktualnie wybranym wariancie projektu.

Tabela BOM z opcją Fitted, Not Fitted lub Replaced wybraną dla Show Components działa z opcjami Base i Flat wybranymi dla View Mode (ale nie z Consolidated).

Stronyi

BOM Table ID Identyfikator liczbowy instancji tabeli BOM. Cała tabela może być podzielona na kilka obiektów tabeli BOM (stron), dla których identyfikator pozostaje wspólny.
Limit Page Height Po zaznaczeniu tej opcji tabela BOM jest dzielona na kolejne wirtualne strony, każda o wysokości określonej we właściwości Max Page Height.
Max Page Height Określa wysokość, a tym samym liczbę wierszy na każdej stronie tabeli. Umieszczony obiekt tabeli BOM zawiera tylko jedną stronę (patrz Page poniżej), a pozostałe strony są dodawane przez umieszczenie kolejnych obiektów tabeli BOM.
Page Wskazuje numer strony tabeli (1 from 2, 3 from 5 itd.) wyświetlanej w wybranym obiekcie tabeli BOM. Użyj powiązanego menu rozwijanego, aby określić żądaną stronę dla aktualnie wybranego obiektu tabeli BOM.
Show Empty Lines Po zaznaczeniu tej opcji wyświetlane są puste wiersze w tabeli BOM. Zwykle znajdują się one na ostatniej stronie tabeli BOM, gdy określona wysokość strony przekracza liczbę dostępnych wierszy danych BOM.

Użyj karty Columns panelu Properties, aby zarządzać kolumnami danych tabeli BOM.

Zarządzaj kolumnami umieszczonej tabeli BOM na karcie Columns panelu Properties.
Zarządzaj kolumnami umieszczonej tabeli BOM na karcie Columns panelu Properties.

  • Pozycje można edytować, aby określić, które kolumny mają być uwzględnione (widoczne) w tabeli BOM, oraz ustawić wyrównanie ich tekstu (Align).

  • Użyj pola Width, aby określić szerokość kolumny względem zawartego w niej tekstu. Wprowadź Auto, aby szerokość zmieniała się dynamicznie i dopasowywała do najdłuższego tekstu w komórce kolumny.

  • Kliknij w kolumnie Order, aby przełączać opcje kolejności sortowania danych w kolumnie tabeli (wyłączone, rosnąco i malejąco). Sortowanie można stosować do wielu kolumn według priorytetów — sortowane kolumny po lewej stronie tabeli mają wyższy priorytet.

  • Nagłówki tabeli BOM można zmieniać, wprowadzając Alias dla nazwy parametru kolumny tabeli — dotyczy to sytuacji, gdy zawartość tabeli nie jest określana przez dokument ActiveBOM (patrz Data Source powyżej).

  • Użyj pól wyboru filtra typów kolumn, aby wypełnić listę dostępnych kolumn parametrami o odpowiednich typach danych: BOM (), schemat (), serwer (), PCB (). Usuń zaznaczenie wszystkich typów, aby wyświetlić tylko kolumny widoczne w tabeli BOM.

  • Użyj przycisków  i , aby przesunąć wybraną pozycję o jedno miejsce w górę lub w dół, a tym samym w lewo lub w prawo w kolejności kolumn tabeli BOM. Opcja jest dostępna dla kolumn ustawionych jako widoczne.

  • Kliknij przycisk , aby przywrócić domyślne kolumny tabeli (zgodnie z ustawieniami domyślnymi obiektu tabeli BOM na stronie Draftsman – Ustawienia domyślne w oknie dialogowym Preferences).

Dzielenie tabel BOM

Zestawienie materiałowe w większości zaawansowanych projektów PCB zwykle zawiera dużą liczbę pozycji, co utrudnia przedstawienie go w postaci tabeli mieszczącej się w dokumencie rysunkowym. Zamiast skalować czcionkę i tabelę, tworzyć wiele niestandardowych tabel lub korzystać z dokumentu zewnętrznego, można użyć funkcji dzielenia BOM, która umożliwia przedstawienie tabeli BOM na kilku „stronach”.

Aby utworzyć wielostronicową tabelę BOM, zaznacz umieszczoną tabelę BOM (która prawdopodobnie przekracza wysokość arkusza dokumentu) i zaznacz pole Limit Page Height w obszarze Pages panelu Properties. Ograniczy to wysokość tabeli do wskazanej wartości (Max Page Height, mm), a tym samym liczbę wierszy wyświetlanych w tabeli BOM.

Javascript ID: Draftsman_BOM_LimitPageHeight

Draftsman wykrywa, że nie jest wyświetlane całe zestawienie BOM, co sygnalizuje pole Page w panelu (na przykład Page 1 from 2), a powiązane menu rozwijane pozwala wskazać wyświetlaną stronę. Aby dodać kolejne strony BOM (tutaj BOM Table ID = 0), umieść kolejną tabelę BOM i określ następną Page w obszarze Pages panelu Properties .

Ponieważ każdą stronę BOM umieszcza się przez dodanie kolejnej tabeli BOM i odpowiednie jej skonfigurowanie, poszczególne strony (sekcje) BOM można umieszczać na dowolnym arkuszu dokumentu Draftsman. Aby umieścić kolejny, different zestaw stron podzielonej tabeli BOM, określ inną wartość BOM Table ID w umieszczonej tabeli BOM — na przykład 1 zamiast 0.

Pamiętaj, że właściwość Max Page Height określa wysokość strony first w tabeli BOM. Gdy wybrana jest druga strona (strona 2), właściwość Max Page Height określa wysokość pierwszej pominiętej strony (strony 1). Strona 2 wyświetla więc pozostałe pozycje BOM. Zacznij od ustawienia identycznej wartości właściwości Max Page Height dla każdej strony.

Tabela otworów

Tabela otworów w Draftsman (Place » Drill Table) to automatycznie generowany obiekt tabeli zawierający symbole i dane otworów płytki. Tabela otworów w połączeniu z widokiem rysunku wierceń w Draftsman dostarcza zarówno tabelarycznych, jak i graficznych informacji na potrzeby produkcji płytki. Wiersz z symbolem reprezentującym określony typ otworu może zawierać szereg informacji o otworach, takich jak rozmiar, metalizacja i liczba wystąpień. Typy otworów są grupowane pod symbolami zgodnie z ustawieniami w oknie dialogowym Drill Symbol Configurations.

Umieszczona tabela otworów z pozycjami pogrupowanymi według rozmiaru
Umieszczona tabela otworów z pozycjami pogrupowanymi według rozmiaru

Gdy w używanej instalacji Altium Designer zainstalowane jest rozszerzenie GOST 2.701-2008/2.106-1996, wartości w kolumnie Plated tabeli otworów są wyświetlane jako Есть (dla otworów metalizowanych) i Нет (dla otworów niemetalizowanych). 

Więcej informacji o zarządzaniu rozszerzeniami znajdziesz na stronie Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Styl wizualny i zawartość danych umieszczonej tabeli otworów, w tym używany symbol, można konfigurować w panelu Properties po zaznaczeniu tabeli w obszarze projektowym. Ogólne właściwości tabeli konfiguruje się na karcie General panelu ().

Tytuł

Title

Tekst tytułu wyświetlanego wraz z tabelą (jeśli jest włączony). Użyj powiązanego przycisku , aby przełączać widoczność tytułu na rysunku.

Pole może zawierać tekst statyczny i dowolne parametry w postaci ciągów specjalnych. Użyj składni =<ParameterName>, aby dodać parametr do tytułu. Wartości uwzględnionych parametrów będą wyświetlane w tytule na arkuszu rysunkowym. Listę dostępnych parametrów systemowych i parametrów PCB znajdziesz na stronie Konfigurowanie dokumentu Draftsman.

Location Rozwiń listę, aby wybrać jedną z dostępnych względnych pozycji tytułu. Opcja Manual jest wybierana automatycznie, jeśli tytuł zostanie przesunięty ręcznie (przeciągnięty i upuszczony w nowym miejscu).
Font

Określa czcionkę używaną w tytule.

  • Gdy opcja Use Document Font jest włączona, tytuł używa czcionki określonej w opcjach dokumentu (pole Document Font w General w sekcji na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać typ, rozmiar i kolor czcionki oraz atrybuty tekstu.

Właściwości

Layer Pairs Wybierz, które otwory dla par warstw wierceń PCB będą wyświetlane w widoku rysunku. Z menu rozwijanego wybierz jedną z par warstw dostępnych w źródłowym projekcie płytki. Pary te można przeglądać i edytować w edytorze PCB, dostępnym z poziomu Menedżera stosu warstw. Każdy projekt płytki zawiera parę warstw Top - Bottom, natomiast pozostałe pary odpowiadają otworom przelotek przechodzących między innymi warstwami lub do tych warstw, np. warstw wewnętrznych lub warstw płaszczyzn.

Opcje Counterhole Bottom i Counterhole Top są dostępne tylko wtedy, gdy dokument PCB zawiera pola lutownicze z włączonymi pogłębieniami otworów po odpowiednich stronach PCB (dowiedz się więcej).

Pamiętaj, że pogłębienia otworów są wykluczone z par warstw innych niż Counterhole Bottom i Counterhole Top. Pogłębienia otworów są również wykluczone z pary warstw All Layers.

Pads / Vias Z listy rozwijanej wybierz typ otworów wierconych (Pads, Vias lub All), który będzie wyświetlany w tabeli.
Plated / Non-Plated Z listy rozwijanej wybierz typ metalizacji otworów (Plated, Non-Plated lub All), który będzie wyświetlany w tabeli.
Border Line Style

Za pomocą list rozwijanych wybierz linię używaną do rysowania obramowania/obrysu tabeli. Dostępne opcje są zdefiniowane w sekcji Line Styles panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman. Użyj powiązanego przycisku koloru, aby określić kolor linii.

Justification Wybierz punkt, względem którego zmienia się położenie tabeli po zmianie jej rozmiaru.
Even Row Color Wybierz kontrastowy kolor parzystych wierszy tabeli.
Non-Even Row Color Wybierz kontrastowy kolor nieparzystych wierszy tabeli.
Font

Ustaw czcionkę używaną do wyświetlania danych w tabeli.

  • Gdy opcja Use Document Font jest włączona, używana jest czcionka zdefiniowana w opcjach dokumentu (pozycja Document Font w sekcji General na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać typ, rozmiar i kolor czcionki oraz atrybuty tekstu.

Tabela zostanie automatycznie przeskalowana do wybranego rozmiaru czcionki.

Show Footer Zaznacz, aby włączyć stopkę tabeli pokazującą łączną liczbę otworów wierconych.
Wybierz, aby otworzyć okno dialogowe Drill Symbol Configurations, które przedstawia wszystkie dane otworów wierconych w formie tabeli i umożliwia ustawienie stylu oraz rozmiaru symbolu każdego otworu (dowiedz się więcej).

Jednostki

Primary Units

Wybierz typ podstawowych jednostek miary, które będą wyświetlane w tabeli. Użyj powiązanego przycisku , aby włączać i wyłączać wyświetlanie jednostek miary.

Gdy jako Primary Units wybrana jest opcja Document : <Units>, w tabeli stosowane są jednostki podstawowe określone dla dokumentu. Jednostki podstawowe na poziomie dokumentu wybiera się za pomocą listy rozwijanej Primary Units w sekcji Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman.

Dual Units

Wybierz typ dodatkowych jednostek miary, które będą wyświetlane w tabeli. Użyj powiązanego przycisku , aby włączać i wyłączać wyświetlanie wartości w jednostkach dodatkowych.

Gdy jako Dual Units wybrana jest opcja Document : <Units>, w tabeli stosowane są jednostki dodatkowe określone dla dokumentu. Jednostki dodatkowe na poziomie dokumentu wybiera się za pomocą listy rozwijanej Dual Units w sekcji Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman.

Precyzja

Primary Units

Użyj menu rozwijanego Value Precision, aby ustawić precyzję (do pięciu cyfr po przecinku, z zaokrągleniem ostatniej cyfry) dla rozmiarów otworów podawanych w tabeli w jednostkach podstawowych.

Gdy wybrana jest opcja Document : <Precision>, w tabeli stosowana jest precyzja wartości/tolerancji w jednostkach podstawowych określona dla dokumentu. Precyzję wartości i tolerancji w jednostkach podstawowych na poziomie dokumentu wybiera się za pomocą opcji Value Precision i Tolerance Precision dla Primary Units w sekcji Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman.

Dual Units

Użyj menu rozwijanego Value Precision, aby ustawić precyzję (do pięciu cyfr po przecinku, z zaokrągleniem ostatniej cyfry) dla rozmiarów otworów podawanych w jednostkach dodatkowych, jeśli są włączone.

Gdy wybrana jest opcja Document : <Precision>, do wymiaru stosowana jest precyzja wartości/tolerancji w jednostkach dodatkowych określona dla dokumentu. Precyzję wartości i tolerancji w jednostkach dodatkowych na poziomie dokumentu wybiera się za pomocą opcji Value Precision i Tolerance Precision dla Dual Units w sekcji Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman.

Użyj karty Columns panelu Properties, aby zarządzać kolumnami danych tabeli wierceń ().

  • Pozycje można edytować, aby określić uwzględniane (widoczne) kolumny tabeli wierceń oraz ich wyrównanie Horizontal i Vertical.

  • Użyj pola Width, aby zdefiniować szerokość kolumny względem zawartego w niej tekstu. Wpisz Auto, aby szerokość zmieniała się dynamicznie i dostosowywała do najszerszego tekstu w komórkach kolumny.

  • Kliknij w kolumnie Order, aby przełączać opcje sortowania danych w kolumnie tabeli (wyłączone, rosnąco i malejąco). Sortowanie można zastosować do wielu kolumn według priorytetu — sortowane kolumny po lewej stronie tabeli mają wyższy priorytet.

  • Nagłówki tabeli wierceń można zmienić, wpisując Caption dla nazwy parametru kolumny tabeli.

  • Użyj  i  przyciski do przesuwania wybranej pozycji o jedno miejsce w górę lub w dół  i tym samym w lewo lub w prawo w kolejności kolumn tabeli wierceń. Dostępne dla kolumn ustawionych jako widoczne.

Style symboli w tabeli wierceń oraz sposób grupowania typów otworów pod tymi symbolami są określane przez ustawienia w oknie dialogowym Drill Symbol Configurations, otwieranym po kliknięciu przycisku w panelu Properties (w sekcji Properties na karcie General), gdy tabela jest zaznaczona w obszarze projektowania.

Jest to to samo okno dialogowe, które otwiera się z panelu Properties dla widoku rysunku wierceń, ale w tym przypadku wyświetlane są tylko kolumny włączone (ustawione jako widoczne) dla tabeli wierceń. Należy pamiętać, że obie wersje okna dialogowego Drill Symbol Configuration korzystają z tego samego źródła, a zatem wprowadzane w nich zmiany wpływają na siebie.

Symbol Graphics Użyj listy rozwijanej, aby wybrać żądany symbol graficzny otworu spośród dostępnych kształtów i liter.
Sync Symbols with PCB Gdy opcja jest włączona, symbole w tabeli wierceń są synchronizowane z symbolami na PCB.
Symbol Size Table

Wprowadź żądany rozmiar symbolu w tabeli.

  • Należy pamiętać, że rozmiar symbolu zostanie zmieniony dla symboli wierceń aktualnie zaznaczonych w siatce u góry okna dialogowego. Aby zaznaczyć wiele symboli wierceń w siatce, użyj metody Ctrl+Click lub Shift+Click.

  • Należy również pamiętać, że rozmiary w widoku rysunku wierceń i tabeli wierceń są ze sobą powiązane, jeśli ikona powiązania wskazuje stan połączony (). Aby ustawić rozmiar symboli wierceń niezależnie, kliknij ikonę powiązania, aby rozłączyć oba rozmiary, a następnie ustaw żądany rozmiar dla każdego z nich.

Symbol Size View Wprowadź żądany rozmiar symbolu w widoku. Aby uzyskać dostęp do tego pola i je edytować, ikona powiązania musi wskazywać stan rozłączony (). Kliknij ikonę powiązania, aby zmienić jego stan.
Symbol Line Style

Użyj list rozwijanych, aby wybrać linię używaną do rysowania obramowania/obrysu symboli graficznych. Dostępne opcje są zdefiniowane w sekcji Line Styles panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman. Użyj powiązanego przycisku koloru, aby określić kolor linii.

Grouping Wybrane kryteria spowodują zgrupowanie pasujących otworów pod jednym symbolem. Na przykład, jeśli wybrano tylko HoleSize, do każdego rozmiaru otworu użytego na PCB zostanie przypisany osobny symbol. W miarę wybierania kolejnych opcji grupowania przypisywanie symboli będzie uwzględniać dodatkowe kryteria, tworząc bardziej szczegółowy schemat grupowania.

Ustawienia domyślne dla Symbol Size Table, Symbol Size View, Symbol Line Style i Grouping można zdefiniować na stronie Draftsman – Ustawienia domyślne w oknie dialogowym Preferences. Na tej stronie wybierz Drill Table w Primitive List i otwórz kartę Drill Symbol w obszarze właściwości po prawej stronie ().

Tabela linii transmisyjnych

Obliczenia stosowane podczas trasowania z kontrolowaną impedancją pozwalają uzyskać struktury ścieżek, które mają zapewnić docelową impedancję linii transmisyjnej, a tym samym spełnić wymagania projektu płytki dotyczące szybkich sygnałów i/lub pól elektromagnetycznych. Dostęp do warstw płytki oraz ich określonych lub obliczonych właściwości zapewnia menedżer stosu warstw (Layer Stack Manager), w którym warstwy trasowania z kontrolowaną impedancją są powiązane z definiowalnymi profilami impedancji. Materiały płytki i wymiary określone w każdym profilu są wykorzystywane do obliczania impedancji linii transmisyjnej, co pozwala uzyskać określoną strukturę ścieżki. Struktura ta uwzględnia zarówno pojedyncze ścieżki, jak i pary różnicowe oraz konfiguracje warstw płytki typu stripline (wewnętrzne) lub microstrip (powierzchniowe).

Więcej informacji na temat konfigurowania profili impedancji można znaleźć na stronie Definiowanie stosu warstw.

Ponieważ struktura i powiązane dane każdej definicji linii transmisyjnej w stosie warstw płytki są istotne dla procesu produkcji PCB, Draftsman udostępnia specjalny obiekt tabeli linii transmisyjnych (Place » Transmission Line Table) służący do dokumentowania tych informacji. Tabela jest wypełniana danymi pobieranymi z menedżera stosu warstw oraz z wykonywanych w nim obliczeń impedancji linii transmisyjnych.

Umieszczona tabela linii transmisyjnych
Umieszczona tabela linii transmisyjnych

Wygląd i zawartość danych umieszczonej tabeli linii transmisyjnych można skonfigurować w panelu Properties, gdy tabela jest zaznaczona w obszarze projektowania. Ogólne właściwości tabeli konfiguruje się na karcie General tego panelu ().

Tytuł

Title

Tekst tytułu, który będzie wyświetlany wraz z tabelą (jeśli ta opcja jest włączona). Użyj powiązanego przycisku , aby przełączać widoczność tytułu na rysunku.

Pole może zawierać tekst statyczny oraz dowolne parametry w postaci ciągów specjalnych. Użyj składni =<ParameterName>, aby dodać parametr do tytułu. Wartości dodanych parametrów będą wyświetlane w tytule na arkuszu rysunkowym. Listę dostępnych parametrów systemowych i parametrów PCB można znaleźć na stronie Konfigurowanie dokumentu Draftsman.

Location Użyj listy rozwijanej, aby wybrać jedną z dostępnych względnych pozycji tytułu. Opcja Manual jest wybierana automatycznie, jeśli tytuł zostanie przesunięty ręcznie (przeciągnięty i upuszczony w nowym miejscu).
Font

Określa czcionkę używaną w tytule.

  • Gdy opcja Use Document Font jest włączona, czcionka tytułu jest określana przez opcje dokumentu (pozycja Document Font w sekcji General na karcie General panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać żądany krój, rozmiar i kolor czcionki oraz atrybuty tekstu.

Właściwości

Table Line Style

Użyj list rozwijanych, aby wybrać linię używaną do rysowania linii tabeli. Dostępne opcje są zdefiniowane w sekcji Line Styles panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman. Użyj powiązanego przycisku koloru, aby określić kolor linii.

Justification Wybierz punkt, względem którego zmieniane jest położenie tabeli po zmianie jej rozmiaru.
Even Row Color Wybierz kontrastowy kolor parzystych wierszy tabeli.
Non-Even Row Color Wybierz kontrastowy kolor nieparzystych wierszy tabeli.
Caption Font

Określa czcionkę używaną do wyświetlania danych w tabeli.

  • Gdy opcja Use Document Font jest włączona, używana czcionka jest określana przez opcje dokumentu (pozycja Document Font w sekcji General na karcie General panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt).

  • Gdy opcja Use Document Font opcja jest wyłączona, użyj dostępnych opcji, aby wybrać żądany krój, rozmiar i kolor czcionki oraz atrybuty tekstu.

Tabela zostanie automatycznie przeskalowana, aby dopasować się do wybranego rozmiaru czcionki.

Rows Font

Określa czcionkę używaną w treści tabeli (tekst w wierszach tabeli).

  • Gdy opcja Use Document Font jest włączona, używana jest czcionka zdefiniowana w opcjach dokumentu (pozycja Document Font w obszarze General na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać żądany krój, rozmiar i kolor czcionki oraz atrybuty tekstu.

Tabela zostanie automatycznie przeskalowana, aby dopasować się do wybranego rozmiaru czcionki.

Jednostki

Primary Units

Wybierz typ podstawowej jednostki miary, która będzie wyświetlana w tabeli. Użyj powiązanego przycisku , aby włączyć lub wyłączyć wyświetlanie jednostek miary.

Po wybraniu opcji Document : <Units> do tabeli stosowane są jednostki podstawowe określone dla dokumentu. Jednostki podstawowe na poziomie dokumentu wybiera się z listy rozwijanej Units w obszarze Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman.

Primary Precision

Wybierz precyzję (do pięciu cyfr po przecinku, z zaokrągleniem ostatniej cyfry) dla wartości w jednostkach podstawowych.

Po wybraniu opcji Document : <Precision> do tabeli stosowana jest precyzja wartości i tolerancji w jednostkach podstawowych określona dla dokumentu. Precyzję wartości i tolerancji w jednostkach podstawowych na poziomie dokumentu wybiera się za pomocą opcji Value Precision i Tolerance Precision dla Primary Units w obszarze Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman.

Dual Units

Wybierz typ dodatkowej jednostki miary, która będzie wyświetlana w tabeli. Użyj powiązanego przycisku , aby włączyć lub wyłączyć wyświetlanie wartości w jednostkach dodatkowych.

Po wybraniu opcji Document : <Units> do tabeli stosowane są jednostki dodatkowe określone dla dokumentu. Jednostki dodatkowe na poziomie dokumentu wybiera się z listy rozwijanej Dual_Units w obszarze Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman.

Dual Precision

Wybierz precyzję (do pięciu cyfr po przecinku, z zaokrągleniem ostatniej cyfry) dla wartości w jednostkach dodatkowych, jeśli ich wyświetlanie jest włączone.

Po wybraniu opcji Document : <Precision> do wymiaru stosowana jest precyzja wartości i tolerancji w jednostkach dodatkowych określona dla dokumentu. Precyzję wartości i tolerancji w jednostkach dodatkowych na poziomie dokumentu wybiera się za pomocą opcji Value Precision i Tolerance Precision dla Dual Units w obszarze Units na karcie General panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Więcej informacji można znaleźć na stronie Konfigurowanie dokumentu Draftsman.

Użyj karty Columns panelu Properties, aby zarządzać kolumnami i wierszami danych linii transmisyjnej ().

  • Obszar Columns zawiera listę kolumn uwzględnionych w tabeli. Każdą pozycję kolumny można edytować, włączając lub wyłączając jej widoczność, zmieniając jej nagłówek (Caption), przełączając opcje wyrównania tekstu (Align) lub ustawiając określoną bądź automatyczną szerokość kolumny (Width). Kolejność pozycji na liście, a tym samym kolejność kolumn we wstawionej tabeli, można zmienić, przesuwając zaznaczoną pozycję kolumny za pomocą powiązanych przycisków  i .

  • Obszar Rows zawiera listę danych wierszy tabeli uporządkowaną według kolumny Impedance Id, która odpowiada nazwanym warstwom płytki w źródłowym stosie warstw. Użyj kontrolki widoczności powiązanej z każdą pozycją wiersza, aby włączyć lub wyłączyć jej wyświetlanie w tabeli.

Tabela

Dokument Draftsman umożliwia umieszczenie na rysunku tabeli ogólnego przeznaczenia, a następnie skonfigurowanie jej w panelu Properties oraz w samych komórkach tabeli. Układ i zawartość tabeli niestandardowej można dowolnie definiować zgodnie z jej przeznaczeniem, co zapewnia elastyczny sposób dodawania dodatkowych informacji do dowolnego dokumentu Draftsman.

Wstawiona tabela z różnymi sposobami formatowania komórek
Wstawiona tabela z różnymi sposobami formatowania komórek

  • Korzystając zarówno z opcji dostępnych we właściwościach tabeli, jak i z poleceń tabeli, można utworzyć tabelę niestandardową odpowiadającą różnorodnym potrzebom informacyjnym w dokumencie Draftsman. Na przykład poniższa tabela została utworzona w celu przedstawienia informacji pochodzących z raportu stosu warstw płytki.

    Tabelę niestandardową można utworzyć tak, aby zawierała różnorodne informacje dotyczące montażu i produkcji PCB.
    Tabelę niestandardową można utworzyć tak, aby zawierała różnorodne informacje dotyczące montażu i produkcji PCB.

  • Tabele można umieszczać zarówno w szablonach arkuszy, jak i w szablonach dokumentów.

Uruchomienie polecenia wstawiania tabeli (Place » Table) otwiera okno dialogowe Insert table, w którym można określić liczbę wierszy i kolumn nowej tabeli. Po kliknięciu OK w oknie dialogowym Insert table nowa tabela zostaje dołączona do kursora i można ją umieścić w żądanym miejscu kolejnym kliknięciem.

Określ liczbę komórek w wierszach i kolumnach tabeli — można ją później zmienić za pomocą poleceń Table dostępnych po kliknięciu komórki prawym przyciskiem myszy.
Określ liczbę komórek w wierszach i kolumnach tabeli — można ją później zmienić za pomocą poleceń Table dostępnych po kliknięciu komórki prawym przyciskiem myszy.

Położenie wstawionej tabeli można zmienić graficznie, zaznaczając obiekt tabeli w obszarze projektowym, a następnie przeciągając go w nowe miejsce za pomocą uchwytu przesuwania, czyli ikony  w lewym górnym rogu.

Przeciągnij ikonę przesuwania zaznaczonej tabeli, aby zmienić jej położenie w obszarze projektowym.
Przeciągnij ikonę przesuwania zaznaczonej tabeli, aby zmienić jej położenie w obszarze projektowym.

Obiekt tabeli zostaje zaznaczony po kliknięciu komórki lub tytułu tabeli. Jednak polecenie Delete będzie dotyczyć konkretnego klikniętego elementu. 

Zawartość tabeli wprowadza się przez wpisanie (lub wklejenie) jej bezpośrednio do komórek. Użyj Ctrl+Enter, aby dodać nowy wiersz tekstu w komórce.

Atrybuty graficzne i tekstowe tabeli definiuje się w panelu Properties, gdy tabela jest zaznaczona w obszarze projektowym (). Obiekt tabeli oferuje szeroki zakres funkcji edycji tekstu i struktury, które można stosować do wierszy lub kolumn komórek za pomocą standardowych Shift+Click lub Click, Hold&Drag techniki.

Tytuł

Title

Tekst tytułu wyświetlany wraz z tabelą (jeśli jest włączony). Użyj powiązanego przycisku , aby przełączać widoczność tytułu na rysunku.

Pole może zawierać tekst statyczny oraz dowolne parametry w postaci ciągów specjalnych. Użyj składni =<ParameterName>, aby dodać parametr do tytułu. Wartości uwzględnionych parametrów będą wyświetlane w tytule na arkuszu rysunkowym. Listę dostępnych parametrów systemowych i parametrów PCB znajdziesz na stronie Konfigurowanie dokumentu Draftsman.

Location Rozwiń listę, aby wybrać jedną z dostępnych pozycji względnych tytułu. Opcja Manual jest wybierana automatycznie po ręcznym przesunięciu tytułu (przeciągnięciu i upuszczeniu go w nowym miejscu).
Font

Określa czcionkę używaną w tytule.

  • Gdy opcja Use Document Font jest włączona, czcionka tytułu jest określana przez opcje dokumentu (pozycja Document Font w sekcji General na karcie General panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać żądany krój, rozmiar i kolor czcionki oraz atrybuty tekstu.

Właściwości

Linia zewnętrzna

Użyj list rozwijanych, aby wybrać linię używaną do rysowania obramowania/obrysu tabeli. Dostępne opcje są zdefiniowane w sekcji Line Styles panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman. Użyj powiązanego przycisku koloru, aby określić kolor linii.

Inner Line Użyj list rozwijanych, aby wybrać linię używaną do rysowania wewnętrznych linii tabeli oddzielających komórki. Dostępne opcje są zdefiniowane w sekcji Line Styles panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman. Użyj powiązanego przycisku koloru, aby określić kolor linii.
Column Width

Określa szerokość zaznaczonych komórek, a tym samym szerokość kolumny, w której się znajdują. Jeśli zaznaczona jest cała tabela (przez kliknięcie jej obrysu lub tytułu), ustawienie szerokości zostanie zastosowane do wszystkich komórek. Użyj powiązanego przycisku koloru, aby określić kolor aktualnie zaznaczonych komórek.

Row Height Użyj tego pola, aby dostosować wysokość wiersza zaznaczonego w obszarze projektowania. Wprowadź żądaną wysokość, a następnie jednostkę imperialną lub metryczną.
Cell Padding Vertical Określa odstęp poniżej i powyżej tekstu w zaznaczonych komórkach.
Cell Padding Horizontal Określa odstęp z lewej i prawej strony tekstu w zaznaczonych komórkach.
Font

Określa czcionkę używaną do tekstu w zaznaczonych komórkach.

  • Gdy opcja Use Document Font jest włączona, używana czcionka jest określana przez opcje dokumentu (pozycja Document Font w sekcji General na karcie General panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt).

  • Gdy opcja Use Document Font jest wyłączona, użyj dostępnych opcji, aby wybrać żądany krój, rozmiar i kolor czcionki oraz atrybuty tekstu.

Tabela zostanie automatycznie przeskalowana, aby pomieścić tekst o wybranym rozmiarze czcionki.

Alignment Użyj przycisków, aby ustawić Horizontal (do lewej, do środka lub do prawej) oraz Vertical (do góry, do środka lub do dołu) wyrównanie i położenie tekstu w zaznaczonych komórkach.
Justification Wybierz punkt, względem którego zmienia się położenie tabeli po zmianie jej rozmiaru.

Ciągi specjalne w komórkach tabeli

Tabela umożliwia umieszczanie parametrów dokumentu Draftsman w postaci ciągów specjalnych. Parametry projektu (zarówno lokalne, jak i pochodzące z Workspace), parametry systemowe, parametry PCB oraz parametry użytkownika zostaną zastąpione swoimi wartościami po wprowadzeniu ich jako ciągów specjalnych w komórkach tabeli. Parametry dokumentu Draftsman są dostępne na karcie Parameters w panelu Properties, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt. Więcej informacji znajdziesz na stronie Konfigurowanie dokumentu Draftsman.

Obsługa ciągów parametrów w tabeli obejmuje również możliwość prawidłowego przenoszenia danych ciągów specjalnych do arkusza kalkulacyjnego i z niego za pomocą standardowych operacji kopiowania i wklejania.

  • Podczas wklejania ciągów specjalnych z dokumentu Draftsman do arkusza kalkulacyjnego komórki docelowe zostaną wypełnione zinterpretowanymi wartościami tych ciągów.

  • Podczas wklejania danych ciągów specjalnych z arkusza kalkulacyjnego do dokumentu Draftsman wklejony tekst zostanie zinterpretowany jako wartość ciągu specjalnego — pod warunkiem że ciąg specjalny odpowiada dostępnemu parametrowi systemowemu, projektu lub użytkownika.

    Podczas przygotowywania wpisów ciągów specjalnych w arkuszu kalkulacyjnym należy poprzedzić każdą wprowadzaną wartość apostrofem ('), aby zawartość komórki była traktowana jako dane tekstowe. Na przykład ciąg specjalny dla parametru Units należy wprowadzić jako '=DocumentUnits. Można też ustawić format tekstowy dla wszystkich komórek arkusza kalkulacyjnego.

Struktura tabeli

Kliknij komórkę prawym przyciskiem myszy i wybierz menu Table z menu kontekstowego, aby uzyskać dostęp do poleceń konfiguracji komórek. Zapewniają one pełny zestaw funkcji edycji tabeli, umożliwiających dodawanie i usuwanie kolumn/wierszy oraz scalanie komórek.

Polecenia Table dostępne po kliknięciu prawym przyciskiem myszy oferują szereg standardowych funkcji edycji tabeli.
Polecenia Table dostępne po kliknięciu prawym przyciskiem myszy oferują szereg standardowych funkcji edycji tabeli.

  • Polecenie Merge Cells jest dostępne tylko wtedy, gdy w tabeli zaznaczone są co najmniej dwie sąsiadujące komórki.

    • Jeśli scalane komórki zawierają tekst, po scaleniu w komórce pozostanie tylko tekst z komórki znajdującej się najbardziej po lewej stronie lub najwyżej (zależnie od układu).

  • Polecenie Unmerge Cells jest dostępne tylko wtedy, gdy kursor znajduje się w scalonej komórce tabeli lub zaznaczony zakres komórek obejmuje co najmniej jedną scaloną komórkę.

    • Jeśli komórka zawiera tekst, po rozdzieleniu pojawi się on w komórce znajdującej się najbardziej po lewej stronie lub najwyżej (zależnie od układu).

    • Jeśli zaznaczony zakres obejmuje wiele scalonych komórek, użycie tego polecenia spowoduje rozdzielenie tylko scalonej komórki znajdującej się najbardziej po lewej stronie lub najwyżej.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents