Nawigacja po dokumencie

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Podczas pracy z dokumentem graficznym, takim jak arkusz schematu, dokument PCB lub dokument Draftsman, można przybliżać, oddalać i przesuwać widok, aby skupić się na określonym obszarze dokumentu. Służą do tego następujące podstawowe skróty:

  • Ctrl+Mouse Wheel do przybliżania i oddalania
  • Right-Click, Hold&Drag do przesuwania dokumentu

Menu główne View zawiera szereg poleceń umożliwiających sterowanie widokiem bieżącego dokumentu.

Używaj poleceń z menu głównego View, aby sterować widokiem dokumentu. Na górnym obrazie pokazano menu View edytora schematów. Na dolnym obrazie pokazano menu View edytora PCB.

Używaj poleceń z menu głównego View, aby sterować widokiem dokumentu. Na górnym obrazie pokazano menu View edytora schematów. Na dolnym obrazie pokazano menu View edytora PCB.

Polecenia te obejmują:

  • Fit Document — wyświetlenie całego obszaru bieżącego dokumentu.

  • Fit All Objects — wyświetlenie wszystkich obiektów projektu w bieżącym dokumencie.

  • Area — przybliżenie wskazanego przez użytkownika obszaru bieżącego dokumentu.

  • Around Point — ponowne ustawienie obszaru wyświetlania wokół wskazanego punktu w bieżącym dokumencie.

  • Selected Objects — zmiana widoku w obszarze projektowym tak, aby wszystkie zaznaczone obiekty były widoczne.

  • Zoom In — przybliżenie projektu względem pozycji kursora w bieżącym dokumencie.

  • Zoom Out — oddalenie projektu względem pozycji kursora w bieżącym dokumencie.

  • Zoom Last — przywrócenie poprzedniego widoku bieżącego dokumentu.

Można również użyć skrótu Z, aby otworzyć menu podręczne z poleceniami powiększania.

W edytorach PCB i footprintów PCB menu to zapewnia dostęp do polecenia Select, które otwiera okno dialogowe Zoom Value (0.001x..4x). Umożliwia ono zmianę powiększenia widoku bieżącego dokumentu o określony współczynnik. Wartości większe od 1 służą do przybliżania (zwiększania powiększenia). Wartości mniejsze od 1 służą do oddalania (zmniejszania powiększenia).

Okno dialogowe Zoom Value
Okno dialogowe Zoom Value

Podczas przeglądania dokumentu PCB lub footprintu PCB w 3D dostępne są dodatkowe polecenia, skróty i elementy sterujące umożliwiające płynną nawigację w widoku. Więcej informacji można znaleźć na stronie Sterowanie widokiem 3D.

Przechodzenie do określonego punktu w dokumencie

Za pomocą poleceń z podmenu Edit » Jump w menu głównym edytora schematów, symboli schematowych, PCB lub footprintów PCB można przejść do określonego punktu w aktywnym dokumencie. Menu podręczne Jump można również otworzyć, naciskając klawisz J w obszarze projektowym. Można na przykład przejść do:

  • początku układu współrzędnych dokumentu:
    • początku układu współrzędnych arkusza schematu (odpowiadającego lewemu dolnemu narożnikowi) — Origin;

    • bezwzględnego początku układu współrzędnych dokumentu PCB — Absolute Origin;

    • względnego początku układu współrzędnych bieżącego dokumentu PCB — Current Origin;

    • położenia punktu odniesienia komponentu w dokumencie footprintu PCB — Reference;

  • dowolnego miejsca w bieżącym dokumencie na podstawie współrzędnych XY podanych przez użytkownika — wybierz polecenie New Location, aby w wyświetlonym oknie dialogowym Jump To Location wprowadzić współrzędne X i Y miejsca w obszarze projektowym, do którego ma zostać przeniesiony kursor. W edytorze PCB można również użyć pól Delta X i Delta Y, aby określić względne przesunięcia X i Y do miejsca docelowego.

    Okno dialogowe Jump To Location — w edytorze schematów (pierwszy obraz) i w edytorze PCB (drugi obraz)
    Okno dialogowe Jump To Location — w edytorze schematów (pierwszy obraz) i w edytorze PCB (drugi obraz)

  • obiektu w dokumencie. Użyj poniższych poleceń, aby przejść do interesującego Cię obiektu:
    • komponentu na arkuszu schematu — Jump Component. Po uruchomieniu polecenia pojawi się okno dialogowe Component Designator. Wprowadź oznaczenie komponentu, do którego chcesz przejść. Jeśli oznaczenie jest prawidłowe, a komponent istnieje w źródłowym dokumencie schematu w aktywnym projekcie, odpowiedni dokument schematu zostanie uaktywniony, a komponent docelowy zostanie przybliżony i wyśrodkowany (o ile to możliwe) w obszarze projektowym. Znaleziony komponent (lub wszystkie części komponentu wieloczęściowego) zostanie również wyświetlony w panelu Messages . Kliknij dwukrotnie wpis komunikatu, aby przejść do tego komponentu (lub jego części) w obszarze projektowym.

      Okno dialogowe Component Designator
      Okno dialogowe Component Designator

      W przypadku komponentu wieloczęściowego wprowadź tylko oznaczenie podstawowe. Nie dodawaj sufiksu części. Na przykład, aby przejść do dwuczęściowego układu scalonego, którego części mają oznaczenia IC1_CPA i IC1_CPB, wprowadź IC1_CP w oknie dialogowym Component Designator. W przypadku komponentu wieloczęściowego zostanie wyróżniona pierwsza część i otwarte okno dialogowe Find Text - Jump. Użyj tego okna, aby przechodzić między częściami komponentu.
      Włącz opcję Physical w oknie dialogowym Component Designator, aby ograniczyć funkcję przechodzenia wyłącznie do fizycznych oznaczeń komponentów — tych, które pojawiają się na kartach widoku Compiled Document źródłowych dokumentów schematów. Gdy ta opcja jest wyłączona, funkcja przechodzenia uwzględnia tylko oznaczenia logiczne — te, które pojawiają się na kartach widoku Editor źródłowych dokumentów schematów.
    • określonego komponentu w dokumencie PCB — Component. Po uruchomieniu polecenia pojawi się okno dialogowe Component Designator. Wpisz oznaczenie komponentu, aby do niego przejść. Jeśli nie znasz oznaczenia, wpisz ? i kliknij OK , aby otworzyć okno dialogowe Components Placed, zawierające listę wszystkich komponentów w projekcie. Wprowadź tekst w polu Mask, aby wyszukać żądany komponent. Podczas wpisywania lista jest filtrowana tak, aby wyświetlać tylko ciągi pasujące do maski. W ciągu można używać symboli wieloznacznych ? (dowolny pojedynczy znak) i * (dowolne znaki). Kursor zostanie przeniesiony do punktu odniesienia wybranego komponentu.

      Wpisz ? w oknie dialogowym Component Designator, aby otworzyć okno dialogowe Components Placed z listą wszystkich komponentów na PCB.
      Wpisz ? w oknie dialogowym Component Designator, aby otworzyć okno dialogowe Components Placed z listą wszystkich komponentów na PCB.

    • określonej sieci w dokumencie PCB — Net. Po uruchomieniu polecenia pojawi się okno dialogowe Net Name. Wpisz nazwę sieci, do której chcesz przejść, lub wpisz ? i naciśnij OK , aby otworzyć okno dialogowe Nets Loaded, zawierające listę wszystkich wczytanych sieci projektu. Wprowadź tekst w polu Mask, aby wyszukać żądaną sieć. Podczas wpisywania lista jest filtrowana tak, aby wyświetlać tylko ciągi pasujące do maski. W masce można używać symboli wieloznacznych ? (dowolny pojedynczy znak) i * (dowolne znaki). Jeśli sieć docelowa jest już widoczna w głównym oknie projektu, kursor zostanie przeniesiony do najbliższego obiektu projektu należącego do tej sieci. Jeśli sieć znajduje się poza widokiem, kursor zostanie ustawiony na najbliższym obiekcie projektu należącym do tej sieci, a widok zostanie wyśrodkowany na tym obiekcie w obszarze projektowym (o ile to możliwe).

      Wpisz ? w oknie dialogowym Net Name, aby otworzyć okno dialogowe Nets Loaded z listą wszystkich sieci na PCB.Wpisz ? w oknie dialogowym Net Name, aby otworzyć okno dialogowe Nets Loaded z listą wszystkich sieci na PCB.

    • konkretnego pola lutowniczego komponentu w dokumencie PCB — Pad. Po uruchomieniu polecenia pojawi się okno dialogowe Jump To Pad Number. Wprowadź oznaczenie wymaganego pola lutowniczego wybranego komponentu w formacie ComponentDesignator-PadDesignator (np. U1-6) i kliknij OK. Jeśli docelowe pole lutownicze jest już widoczne w obszarze projektowania, kursor po prostu przeskoczy do jego środka. Jeśli pole znajduje się poza widocznym obszarem, kursor zostanie umieszczony w jego środku, a widok zostanie wyśrodkowany na tym polu (o ile to możliwe).

      Okno dialogowe Jump To Pad Number
      Okno dialogowe Jump To Pad Number

    • określonego ciągu tekstowego w dokumencie PCB — String. Po uruchomieniu polecenia pojawi się okno dialogowe Jump To String. Wpisz ciąg tekstowy, do którego chcesz przejść, lub wpisz ? i kliknij OK , aby otworzyć okno dialogowe Strings zawierające listę wszystkich ciągów tekstowych znajdujących się w aktywnym dokumencie płytki (zarówno niezależnych, jak i należących do innych obiektów grupowych). To okno pozwala szybko znaleźć ciąg tekstowy, do którego chcesz przejść. Jeśli docelowy ciąg tekstowy jest już widoczny w obszarze projektowania, kursor po prostu przeskoczy do jego punktu zakotwiczenia — punktu, za który jest on chwytany podczas przesuwania lub wokół którego jest obracany. Jeśli ciąg tekstowy znajduje się poza widocznym obszarem, kursor zostanie umieszczony w jego punkcie zakotwiczenia, a widok zostanie wyśrodkowany na tym punkcie (o ile to możliwe).

      Wpisz ? w oknie dialogowym Jump To String, aby otworzyć okno dialogowe Strings z listą wszystkich sieci na PCB.
      Wpisz ? w oknie dialogowym Jump To String, aby otworzyć okno dialogowe Strings z listą wszystkich sieci na PCB.

      System przeprowadzi trzy wyszukiwania: najpierw wyszuka ciąg tekstowy zgodny z podanym pod względem wielkości liter, znaków i długości; następnie ciąg zawierający te same znaki, ale mogący zawierać również dodatkowe znaki; a na końcu ciąg zawierający te same znaki, bez uwzględniania wielkości liter.

    • przechodzenia kolejno do wszystkich znaczników błędów w bieżącym dokumencie projektu — Error Marker. Po uruchomieniu polecenia kursor przeskoczy do pierwszego znacznika błędu kontroli reguł projektowych (DRC), który zostanie wyśrodkowany w głównym oknie projektowania. Ponowne użycie polecenia spowoduje przejście do drugiego znacznika błędu i tak dalej. Polecenie umożliwia przejście do znacznika błędu niezależnie od tego, czy naruszenie zostało zaakceptowane jako wyjątek.

      Aby sprawdzić naruszenia związane z obiektem pod kursorem, kliknij prawym przyciskiem myszy i wybierz odpowiednie polecenie z podmenu Violations .

  • przechodzenia kolejno do wszystkich zaznaczonych obiektów projektu w bieżącym dokumencie — Selection. Po uruchomieniu polecenia kursor przeskoczy do pierwszego zaznaczonego obiektu, który zostanie przybliżony i wyśrodkowany w głównym oknie projektowania. Ponowne użycie polecenia spowoduje przejście do drugiego zaznaczonego obiektu i tak dalej, umożliwiając cykliczne przechodzenie przez wszystkie zaznaczone obiekty w bieżącym dokumencie. Polecenie przechodzi przez zaznaczone obiekty w kolejności, w jakiej zostały pierwotnie dodane do zaznaczenia.

  • pozycji w bieżącym dokumencie schematu lub PCB, której współrzędne zostały wcześniej zapisane we wskazanym znaczniku lokalizacji — wybierz polecenie Location Marks » n, aby przejść do pozycji zapisanej we wskazanym znaczniku lokalizacji za pomocą polecenia Set Location Marks » n.

    W przypadku dokumentu schematu zapisana lokalizacja jest dostępna tylko wtedy, gdy dokument pozostaje otwarty (niezależnie od tego, czy jest aktywny). Po zamknięciu i ponownym otwarciu dokumentu znacznik lokalizacji będzie pusty. W przypadku dokumentu PCB znaczniki lokalizacji są zapisywane wraz z projektem, dzięki czemu zdefiniowane przez użytkownika pozycje pozostają dostępne również podczas kolejnych sesji projektowania.
AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.