Criando e Definindo a Biblioteca de Banco de Dados

Num relance

Aprenda a criar e definir bibliotecas de banco de dados padrão e com controle de versão no Altium Designer. Este artigo aborda a conexão com um banco de dados externo, a vinculação de uma SVNDbLib a um repositório Subversion, a escolha das tabelas do banco de dados a serem incluídas e a introdução de critérios de correspondência que vinculam os componentes inseridos aos seus registros de origem. Continue lendo para dar o próximo passo na configuração da sua biblioteca de banco de dados.

- Entenda as funções dos arquivos DbLib e SVNDbLib e onde criá-los.
- Explore as opções de conexão com bancos de dados, incluindo atalhos para Access e Excel, strings de conexão e arquivos Microsoft Data Link.
- Aprenda a navegar pelas tabelas conectadas e editá-las, controlar sua inclusão na biblioteca e definir critérios de correspondência de componentes para cada tabela.
Aprofunde-se com a IA:

A base do recurso de biblioteca de banco de dados é o arquivo de biblioteca de banco de dados. Ele está disponível em dois formatos, dependendo de você usar uma biblioteca de banco de dados padrão ou uma biblioteca de banco de dados com controle de versão:

  • Standard Database Library - o arquivo de biblioteca de banco de dados. Esse arquivo é criado e gerenciado usando o editor DatabaseLib do Altium Designer. Esse editor fica disponível quando o documento ativo na janela principal de projeto é um arquivo *.DbLib.
  • Version-Controlled Database Library - o arquivo de biblioteca de banco de dados SVN. Esse arquivo é criado e gerenciado usando o editor SVNDatabaseLib do Altium Designer. Esse editor fica disponível quando o documento ativo na janela principal de projeto é um arquivo *.SVNDbLib.

Exemplo de arquivo DbLib aberto no editor DatabaseLib. Passe o cursor sobre a imagem para ver um exemplo de arquivo SVNDbLib aberto no editor SVNDatabaseLib.Exemplo de arquivo DbLib aberto no editor DatabaseLib. Passe o cursor sobre a imagem para ver um exemplo de arquivo SVNDbLib aberto no editor SVNDatabaseLib.

Crie um novo arquivo desses tipos escolhendo o comando File » New » Library  nos menus principais e selecionando a opção Database Library ou SVN Database Library na região Database da caixa de diálogo New Library que se abre.

Conexão com um banco de dados externo

Os dados de tabelas e de mapeamento só aparecerão na janela principal do editor depois que o arquivo ativo de biblioteca de banco de dados/biblioteca de banco de dados SVN for conectado com sucesso ao banco de dados externo desejado. A conexão é definida usando os controles disponíveis na região Source of Connection.

Especificação da conexão com o banco de dados externo por meio de um arquivo DbLib. Passe o cursor sobre a imagem para ver a conexão por meio de um arquivo SVNDbLib.Especificação da conexão com o banco de dados externo por meio de um arquivo DbLib. Passe o cursor sobre a imagem para ver a conexão por meio de um arquivo SVNDbLib.

É possível se conectar a qualquer banco de dados que ofereça suporte a OLE DB. Cada uma das opções disponíveis nessa região usa uma string de conexão OLE DB para se conectar ao banco de dados de destino. Alguns bancos de dados podem não oferecer suporte a OLE DB. No entanto, praticamente todos os sistemas de gerenciamento de banco de dados usados atualmente podem ser acessados pela interface Open Database Connectivity (ODBC). O recurso de vínculo com banco de dados usa o provedor ODBC da Microsoft, que permite que um ADO (ActiveX Data Object) se conecte a qualquer fonte de dados ODBC. Como resultado, é possível se conectar a qualquer banco de dados ODBC. O provedor OLE DB para o banco de dados ODBC é especificado como parte da string de conexão.

A conexão também pode ser definida na guia Connection da caixa de diálogo Database Connection, acessada escolhendo o comando Tools » Database Connection nos menus principais ou clicando no botão Advanced (à direita do botão Connect , na parte inferior da região).

Conexão rápida com bancos de dados Access e Excel

A opção Select Database Type oferece um método rápido de criar uma string de conexão quando o banco de dados de destino foi criado usando o Microsoft Access ou o Microsoft Excel. Ao usar essa opção, selecione o tipo de banco de dados e, em seguida, procure e selecione o arquivo de banco de dados desejado. A string de conexão correspondente será gerada automaticamente e inserida no campo da opção Use Connection String.

O caminho completo pode ser especificado, ou você pode optar por armazenar o caminho relativo ao arquivo de biblioteca de banco de dados/biblioteca de banco de dados SVN.

Criação de uma string de conexão

Se o banco de dados da sua empresa não for baseado em Access ou Excel e você quiser criar a string de conexão explicitamente, habilite a opção Use Connection String e clique no botão Build associado à direita. A caixa de diálogo Data Link Properties será exibida.

Criação de uma string de conexão por meio da caixa de diálogo Data Link Properties.Criação de uma string de conexão por meio da caixa de diálogo Data Link Properties.

A caixa de diálogo é aberta na guia Connection . O provedor OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider é definido por padrão na guia Provider da caixa de diálogo. Essa é a configuração padrão do provedor para novos arquivos de biblioteca de banco de dados/biblioteca de banco de dados SVN e também é usada para conectar a arquivos de banco de dados Access (*.mdb). Altere o provedor conforme necessário.

Na guia Connection , insira o nome (incluindo o caminho) do banco de dados ao qual deseja se conectar.

Se o banco de dados exigir credenciais de login, insira-as conforme necessário, juntamente com quaisquer outras configurações avançadas disponíveis na guia Advanced da caixa de diálogo. A guia All fornece uma lista resumida das opções de vínculo definidas, bem como opções adicionais relacionadas ao provedor OLE DB escolhido. As opções podem ser modificadas conforme necessário nessa guia.

Depois de definir as opções de vínculo, você pode verificar se a conexão foi bem-sucedida clicando no botão Test Connection (na guia Connection ). Se a conexão for bem-sucedida, será exibida uma caixa de diálogo de confirmação.

A caixa de diálogo Data Link Properties é uma caixa de diálogo da Microsoft e, portanto, pressionar F1 ou usar o botão Help disponível dará acesso ao arquivo Microsoft Data Link Help. Esse arquivo não faz parte do conjunto de documentação do Altium Designer.

Especificação de um arquivo de vínculo de dados

Se a fonte de dados à qual você deseja se conectar for descrita por um arquivo Microsoft Data Link (*.udl), habilite a terceira opção de conexão - Use Data Link File - e clique no botão Browse associado para localizar o arquivo desejado. Um arquivo de vínculo de dados é essencialmente um meio de armazenamento de uma string de conexão.

Prosseguindo com a conexão

Após definir a conexão com o banco de dados externo, o texto do botão Connect ficará em negrito, indicando que você pode prosseguir com a conexão. Se os detalhes da conexão estiverem corretos, as informações de tabelas e mapeamento do banco de dados de destino serão carregadas no arquivo Database Library/SVN Database Library. O texto do botão Connect mudará para Connected e o botão ficará desabilitado.

Se houver um problema com os detalhes da conexão, por exemplo, uma string de conexão construída incorretamente ou um caminho inserido de forma errada, a conexão falhará e uma mensagem será exibida para alertar sobre isso. Verifique as configurações de conexão e clique novamente no botão Connect .

Exemplos de indicação de falha de conexão em uma biblioteca de banco de dados. Exemplos de indicação de falha de conexão em uma biblioteca de banco de dados.

Se você alterar as configurações de conexão enquanto estiver conectado a um banco de dados, a conexão ativa será perdida e o texto do botão Connect mudará para Reconnect. Clique para restabelecer a conexão.

Após a conexão inicial bem-sucedida e depois de salvar o arquivo Database Library/SVN Database Library, a conexão será estabelecida automaticamente sempre que o arquivo for aberto, desde que o local e o nome do arquivo do banco de dados de destino não sejam alterados.

Especificação do vínculo com o repositório de controle de versão (somente SVNDbLib)

Com uma DbLib, as bibliotecas de símbolos e modelos são armazenadas no disco rígido ou em outro meio de armazenamento local ou de rede. Lembre-se de que, no caso de uma SVNDbLib, essas bibliotecas são armazenadas sob controle de versão em um repositório Subversion. Como parte do arquivo SVNDbLib, você deve definir o vínculo com esse repositório. A conexão com o repositório SVN é definida na aba SVN Repository da caixa de diálogo Database Library Options (Tools » Options). Essa caixa de diálogo também pode ser acessada clicando no botão Options na região Field Settings da visualização do documento.

Exemplo de conexão com um repositório SVN baseado em arquivos.Exemplo de conexão com um repositório SVN baseado em arquivos.

Listagem de tabelas do banco de dados

Após a conexão bem-sucedida com o banco de dados externo, os dados de tabelas e mapeamento serão carregados. O lado esquerdo do documento DbLib/SVNDbLib lista todas as tabelas existentes no banco de dados conectado.

Em um banco de dados baseado em Excel, uma tabela é, na verdade, uma aba da planilha vinculada. O nome da tabela terá o sufixo $.

Tabelas existentes no banco de dados conectado.Tabelas existentes no banco de dados conectado.

A opção Enable ao lado de cada entrada de tabela permite controlar se essa tabela fará parte da biblioteca de banco de dados resultante. Quando a biblioteca de banco de dados é adicionada à lista de bibliotecas disponíveis baseadas em arquivos para navegação no painel Components, cada tabela aparece como uma biblioteca separada. Assim, embora na prática apenas uma biblioteca de banco de dados seja adicionada, da perspectiva do painel Components , é como se você tivesse adicionado várias bibliotecas distintas. Para obter mais informações, consulte Pesquisa de componentes em bibliotecas baseadas em arquivos e em bancos de dados.

Ao clicar em uma entrada de tabela na lista, seu ícone muda de Database table icon, inactive table para Database table icon, active table para identificá-la como a tabela ativa no momento. A tabela, com todos os seus dados, aparece na aba Table Browser do documento. Essa é uma visualização editável da tabela e permite consultar rapidamente seu conteúdo e fazer as edições necessárias, sem precisar abrir o próprio banco de dados externo.

Navegação em uma tabela de origem no banco de dados conectado.Navegação em uma tabela de origem no banco de dados conectado.

Para ampliar a área do navegador de tabelas (conforme mostrado na ilustração acima), recolha toda a área superior (configurações de conexão e de campos) clicando no controle Collapse icon - collapse a region of the database library document, no canto superior direito da visualização do documento. Clique em Expand icon - expand a region of the database library document para expandir. A tabela também oferece os recursos conhecidos de agrupamento, classificação e filtragem.

Especificação dos critérios de correspondência

Após a inserção de um componente a partir do banco de dados externo, é necessário haver uma forma de manter o vínculo entre esse componente inserido e o registro do banco de dados cujas informações foram usadas para criá-lo. Essencialmente, é preciso estabelecer uma correspondência entre os dois.

Quando um componente é inserido, suas informações de parâmetros são criadas dinamicamente, usando os campos correspondentes no registro do banco de dados. O vínculo após a inserção entre o componente do esquemático e o registro do banco de dados é estabelecido usando um ou mais desses parâmetros. A região Field Settings do documento permite definir os critérios de correspondência: uma consulta simples por chave única ou uma correspondência mais avançada usando uma cláusula Where.

Os critérios de correspondência são especificados individualmente para cada tabela.

Controle dos critérios de correspondência após a inserção.Controle dos critérios de correspondência após a inserção.

Consulta por chave única

Se a opção Single key lookup estiver habilitada (padrão), os campos Database field e Part parameter ficarão disponíveis. O primeiro lista todos os nomes de campos disponíveis (cabeçalhos de coluna) na tabela ativa do banco de dados. Como os parâmetros de um componente do esquemático são adicionados no momento da inserção, o campo Part parameter refletirá o campo escolhido no banco de dados.

Normalmente, o campo de chave de consulta utilizado é algo que identifica exclusivamente cada componente no banco de dados externo, como um código de peça. O campo de consulta escolhido é identificado na aba Field Mappings do documento pela entrada Design Parameter exibida em cinza.

Mapeamento de chave única por código de peça.Mapeamento de chave única por código de peça.

Ao usar o recurso Update Parameters From Database em algum momento após a inserção, as informações são lidas do parâmetro de chave escolhido nos componentes inseridos no esquemático e, em seguida, pesquisadas no campo (chave) escolhido do banco de dados, em todas as tabelas habilitadas. Quando há uma correspondência, as informações de outras células desse registro da tabela de origem podem ser transferidas para os parâmetros mapeados no componente do esquemático.

Correspondência avançada — a cláusula Where

Embora a opção Single key lookup funcione bem quando há um código de peça ou identificador exclusivo para estabelecer a correspondência, ela não é tão eficaz quando a correspondência é feita por um parâmetro que não é exclusivo, como capacitância ou resistência. Nesse caso, deve-se usar a cláusula Where, mais avançada, que permite especificar uma correspondência por várias chaves para vincular o componente do esquemático ao seu registro de origem no banco de dados.

Em sua forma mais simples, a cláusula Where (escrita usando a sintaxe SQL) reflete as entradas escolhidas que definem a consulta por chave única. Por exemplo, se Database field fosse definido como Part Number — o padrão —, o campo Part parameter também seria definido automaticamente como Part Number, e a entrada da cláusula Where seria:

[Part Number] = '{Part Number}'

Os colchetes ao redor do campo do banco de dados (coluna da tabela) são caracteres de delimitação, conforme especificado na aba Advanced da caixa de diálogo Database Connection. Acesse essa caixa de diálogo clicando no botão Advanced na região Source of Connection do documento ou pelo menu principal Tools .

Mapping between the component parameters and the database, using a Where clause A aba Advanced da caixa de diálogo Database Connection oferece opções SQL adicionais para delimitar
tabelas ou usar nomes de esquema de tabela em uma cláusula Where construída.

Ao delimitar nomes de tabelas, os caracteres de delimitação específicos dependerão do banco de dados que você estiver usando. Por exemplo, colchetes [ ] só podem ser usados em bancos de dados da Microsoft, como Access, Excel via ADO ou MSSQL (versões mais recentes). O MYSQL usa o caractere ` (acento grave) como delimitador. Na verdade, em qualquer banco de dados, só é necessário delimitar os nomes das colunas se eles contiverem espaços ou forem palavras reservadas (desse banco de dados). Consulte a documentação do seu software de banco de dados para verificar quais caracteres de delimitação são usados (se houver).

As chaves especificam que a entrada referenciada é um parâmetro de projeto. As aspas simples são usadas para especificar que o parâmetro de projeto deve ser tratado como uma string, e não como um número (sem aspas). A correspondência de tipos é muito importante, pois o SQL é sensível a tipos. O parâmetro de projeto deve ser do mesmo tipo que a coluna no banco de dados.

Usando a sintaxe SQL padrão, a cláusula Where pode então ser ampliada para fazer a correspondência usando várias entradas Database field/Part parameter, por exemplo:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

Nesse caso, seria estabelecido um vínculo com um único registro na tabela correspondente do banco de dados, usando três parâmetros de projeto diferentes. Observe que a entrada do parâmetro de projeto Tolerance não está entre aspas. Isso significa que o tipo da coluna na tabela associada do banco de dados é Number, e não String.

Usando a sintaxe SQL padrão, você pode criar uma cláusula Where tão simples ou tão complexa quanto desejar.

Mapeamento de campos do banco de dados para parâmetros de projeto

Os parâmetros de projeto de um componente inserido a partir de uma biblioteca de banco de dados são criados/adicionados no momento da inserção. Quais parâmetros são efetivamente criados e as opções usadas para atualizar suas informações após a inserção — usando o comando Tools » Update Parameters From Database — são determinados pelas informações de mapeamento e atualização especificadas no arquivo Database Library/SVN Database Library. Essas configurações são feitas na aba Field Mappings da visualização principal do documento.

As opções de mapeamento e atualização são especificadas individualmente para cada tabela.

Especifique as opções de mapeamento e atualização de parâmetros na aba Field Mappings do documento DbLib/SVNDbLib.Especifique as opções de mapeamento e atualização de parâmetros na aba Field Mappings do documento DbLib/SVNDbLib.

Mapeamento de modelos e parâmetros

As duas primeiras colunas (da esquerda para a direita) na aba Field Mappings são usadas para controlar quais informações do banco de dados serão mapeadas para os atributos, modelos e parâmetros do componente.

  • Database Field Name - esta coluna lista todos os nomes de campos (colunas) da tabela atualmente ativa no banco de dados.
  • Design Parameter - esta coluna define como cada campo correspondente no banco de dados será usado. Ele pode fornecer o símbolo ou o modelo de footprint de um componente (nesse caso, estará entre colchetes) ou ser incluído como um parâmetro do componente (nesse caso, não estará entre colchetes).
Ao abrir um documento DbLib/SVNDbLib conectado a um banco de dados, você notará que alguns parâmetros de projeto incluem colchetes e outros não. Os colchetes indicam um nome reservado, como [Library Ref]. Esses dados são usados para preencher os atributos e modelos do componente. Os parâmetros de projeto que não incluem colchetes tornam-se parâmetros do componente.

O mapeamento inicial é realizado automaticamente ao estabelecer a conexão com o banco de dados, e todos os campos do banco de dados são mapeados.

Observe que o mapeamento automático pressupõe que os nomes dos campos do banco de dados correspondam aos nomes reservados usados no Altium Designer. Caso contrário, o mapeamento deverá ser configurado manualmente.

Atributos & modelos

Se o nome do campo do banco de dados for um dos seguintes nomes reservados, a entrada de mapeamento do atributo/modelo correspondente será definida automaticamente no campo Design Parameter:

  • Description → [Description]
  • Footprint Ref → [Footprint Ref]
  • Footprint Path → [Footprint Path]
  • Footprint Ref n → [Footprint Ref n]
  • Footprint Path n → [Footprint Path n]
É possível especificar um número ilimitado de referências a modelos de footprint (e caminhos) em uma tabela do banco de dados e mapeá-las no arquivo DbLib/SVNDbLib. Nos nomes reservados, n representa um número inteiro positivo a partir de 2.
  • Library Ref → [Library Ref]
  • Library Path → [Library Path]
  • Orcad Footprint → [Orcad Footprint]
  • Orcad Library → [Orcad Library]
Essas referências são usadas ao importar um arquivo de configuração e bibliotecas do OrCAD CIS e gerar uma biblioteca de banco de dados padrão (DbLib).
  • PCB3D Ref → [PCB3D Ref]
  • PCB3D Path → [PCB3D Path]

    • As referências a PCB3D referem-se ao visualizador 3D legado e não devem ser usadas em novos projetos. O mecanismo 3D nativo do Editor de PCB pode renderizar corpos de componentes e arquivos de modelos 3D importados associados aos footprints dos componentes.
    • Os mapeamentos de modelos PCB3D podem ser definidos em um arquivo SVNDbLib; no entanto, o armazenamento de bibliotecas de modelos PCB3D no repositório Subversion não é suportado.
  • Sim Description → [Sim Description]
  • Sim Excluded Parts → [Sim Excluded Parts]
  • Sim File → [Sim File]
  • Sim Kind → [Sim Kind]
  • Sim Model Name → [Sim Model Name]
  • Sim Netlist → [Sim Netlist]
  • Sim Parameters → [Sim Parameters]
  • Sim Port Map → [Sim Port Map]
  • Sim Spice Prefix → [Sim Spice Prefix]
  • Sim SubKind → [Sim SubKind]

    Consulte Mapeamento de modelos de simulação abaixo para saber mais sobre os campos relacionados a modelos de simulação.
    Apenas um vínculo de modelo de simulação pode ser definido para um componente em um banco de dados externo. Normalmente, haverá apenas um único modelo de simulação vinculado a um componente. Se desejar configurar vários vínculos de modelos de simulação, os demais vínculos deverão ser definidos e armazenados com esse componente no arquivo da biblioteca de esquemáticos de origem.
    Modelos de simulação vinculados são suportados em uma biblioteca de banco de dados com controle de versão (SVNDbLib); no entanto, o armazenamento de arquivos de modelos de simulação no repositório Subversion não é suportado.

Esses mapeamentos definem as informações de atributos e modelos do componente. Quando o componente é inserido, o símbolo esquemático especificado pelo campo [Library Ref] do registro correspondente no banco de dados será extraído da biblioteca de esquemáticos especificada. Da mesma forma, as informações de footprint de PCB e de modelo de simulação armazenadas no registro serão adicionadas ao componente como modelos vinculados de footprint e de simulação, respectivamente.

A entrada [Library Ref] deve existir na coluna Design Parameter e ser mapeada para o Database Field Name que especifica o símbolo esquemático para que seja possível inserir um componente da Database Library/SVN Database Library em um esquemático. Se a tabela do banco de dados contiver a referência do símbolo em um Database Field Name diferente, por exemplo, SCH Symbol, será necessário definir manualmente a entrada Design Parameter associada a esse campo como [Library Ref], usando a lista suspensa disponível nessa célula.

Da mesma forma, se as informações de referência dos modelos forem inseridas no banco de dados usando nomes de campos diferentes, será necessário realizar o mapeamento manualmente, escolhendo a entrada Design Parameter apropriada ([Footprint Ref], [Footprint Ref n], [PCB3D Ref], [Sim Model Name] e assim por diante) na lista suspensa de cada campo.

Mapping the symbol and footprint models from the database to the design componentPara definir as informações de símbolo e modelo de um componente no momento da inserção, os campos de referência de símbolo e modelo no banco de dados são as entidades de mapeamento
essenciais — certifique-se de que haja uma referência de símbolo e pelo menos uma referência de footprint de PCB no mapeamento definido.

Como mencionado, vários modelos de PCB podem ser mapeados. O Database Field Name mapeado para Design Parameter [Footprint Ref] será o footprint padrão quando o componente for inserido no esquemático. Esse será o footprint inserido quando o projeto for transferido para o domínio de PCB.
Ao mapear símbolos e modelos para um arquivo DbLib/SVNDbLib, as informações de caminho no banco de dados externo são opcionais. Para obter mais informações, consulte Especificação dos locais das bibliotecas de símbolos e modelos.

Mapeamento de modelos de simulação

Esta seção aborda cada um dos campos de banco de dados que podem ser adicionados a uma tabela de banco de dados externo para definir o vínculo com o modelo de simulação, que será criado ao posicionar o componente.

  • Sim Model Name – o nome do modelo que você deseja usar. Após o posicionamento do componente, essa informação aparecerá no campo Model Name da caixa de diálogo Sim Model.

    Ao mapear campos do banco de dados para parâmetros de projeto no arquivo DBLib, o campo Sim Model Name é análogo aos campos Footprint Ref, Library Ref etc.
  • Sim Description – uma descrição do modelo vinculado. Essa informação é opcional e não afeta o funcionamento do vínculo com o modelo de simulação.
  • Sim File – um arquivo de modelo específico no qual localizar o modelo de simulação especificado no campo Sim Model Name. Esse campo pode ser usado de várias maneiras:

    • Você pode inserir um caminho absoluto para um arquivo de modelo (por exemplo, C:\DbLibs\Switching Diodes\Libraries\JAS33.mdl). O modelo especificado no campo Sim Model Name será procurado nesse arquivo e usado se for encontrado.
    • Você pode inserir um caminho relativo (em relação ao arquivo DbLib) para um arquivo de modelo (por exemplo, Libraries\JAS33.mdl). O modelo especificado no campo Sim Model Name será procurado nesse arquivo e usado se for encontrado.
    • Você pode inserir apenas o nome do arquivo de modelo (por exemplo, JAS33.mdl). Os caminhos de pesquisa definidos como parte do arquivo DbLib serão usados para localizar o primeiro arquivo de modelo que corresponda ao nome especificado e que contenha uma correspondência para o modelo especificado no campo Sim Model Name.
    • Você pode deixar o campo em branco. Os caminhos de pesquisa definidos como parte do arquivo DbLib serão usados para localizar o primeiro arquivo de modelo que contenha uma correspondência para o modelo especificado no campo Sim Model Name.
    Os caminhos de pesquisa do arquivo DbLib são definidos na aba Symbol & Model Search Paths da caixa de diálogo Database Library Options (Tools » Options).
  • Sim Kind – a categoria principal do modelo ao qual o vínculo é estabelecido.
  • Sim SubKind – o tipo de modelo ao qual o vínculo é estabelecido.
  • Sim Netlist – as informações do template de netlist, de acordo com o tipo de modelo ao qual o vínculo é estabelecido. Esse campo se torna especialmente importante se você estiver especificando seu próprio template de netlist e tiver definido o campo Sim SubKind como Generic Editor, o que oferece mais controle sobre quais informações são inseridas na netlist.

    Esse campo deve ser definido e não pode ser deixado em branco; caso contrário, nenhuma entrada para o modelo será criada na netlist de simulação, e o componente não será simulado quando for posicionado a partir da biblioteca de banco de dados.
  • Sim Spice Prefix – o prefixo SPICE para o tipo de modelo ao qual você está vinculando.
  • Sim Port Map – o mapeamento dos pinos do componente do esquemático para os pinos do modelo vinculado. Após o posicionamento do componente, essas informações aparecerão na região Pin Mapping da caixa de diálogo Sim Model.

    Cada par de pinos deve ser inserido no seguinte formato:

    (SchematicPinNumber:ModelPinNumber),

    com cada par mapeado separado por uma vírgula.

    Por exemplo, ao mapear um modelo de simulação de diodo em que o pino 1 do esquemático (ânodo) deve ser mapeado para o pino 1 do modelo (ânodo), e o pino 3 do esquemático (cátodo) deve ser mapeado para o pino 2 do modelo (cátodo), isso seria inserido no campo do banco de dados como:

    (1:1),(3:2)

  • Sim Excluded Parts – crie este campo no banco de dados se desejar excluir determinadas partes de um componente de múltiplas partes da simulação. Essas informações correspondem à opção Exclude part from simulation na região Pin Mapping da caixa de diálogo Sim Model.

    Por padrão, todas as partes de um componente de múltiplas partes são incluídas em uma simulação, portanto, você só precisa especificar, por número, as partes que deseja excluir. Separe as várias partes na lista de exclusão usando vírgulas. Por exemplo, se um componente tiver quatro partes e você não quiser que as partes 2 e 4 sejam incluídas em nenhuma simulação, deverá inserir o seguinte no campo do banco de dados:

    2,4

  • Sim Parameters – crie este campo no banco de dados se desejar atribuir valores aos parâmetros de simulação do modelo. Esses são parâmetros que podem ser definidos no nível do componente, diferentemente dos parâmetros mais avançados que podem ser incluídos em um arquivo de modelo.

    Um parâmetro deve ser inserido no seguinte formato:

    ParameterName=Value,

    Vários parâmetros devem ser separados pelo caractere de barra vertical (|).

    Você deve se lembrar de que um parâmetro de simulação no nível do componente também pode ser definido como um parâmetro do componente — aparecendo na região Parameters da caixa de diálogo Component Properties associada, com a possibilidade de ser exibido na folha do esquemático. Por padrão, uma entrada de parâmetro no campo Sim Parameters será adicionada automaticamente como um parâmetro do componente. Se você não quiser que um parâmetro de simulação seja adicionado como parâmetro do componente, basta adicionar um ponto de exclamação como prefixo ao nome do parâmetro (por exemplo, !Initial Voltage=100mV).

    Considere um modelo de diodo que tenha os quatro parâmetros a seguir no nível do componente:

    • Fator de área
    • Condição inicial
    • Tensão inicial
    • Temperatura.

    Agora, considere adicionar valores no banco de dados para o Fator de área (digamos, 2) e a Temperatura (digamos, 22°C). Além disso, nenhum dos dois deve ser adicionado como parâmetro do componente. A entrada no campo Sim Parameters seria:

    !Area Factor=2|!Temperature=22

Após posicionar o componente da biblioteca de banco de dados, você pode verificar se as informações definidas para o vínculo de simulação estão de fato conforme o necessário. Com o componente posicionado selecionado na área de projeto, selecione a entrada do modelo de simulação na região Parameters do painel Properties e clique no botão  para acessar a caixa de diálogo Sim Model, onde você pode verificar se:

  • O arquivo de modelo foi localizado conforme o esperado. Quando encontrado, a aba Model File da caixa de diálogo exibirá o conteúdo do arquivo.
  • As demais informações de simulação do banco de dados foram adicionadas à caixa de diálogo conforme o esperado.

Os valores armazenados nos campos do banco de dados serão usados para o componente posicionado a partir da biblioteca de banco de dados ao executar uma simulação. Observe, no entanto, que, se você acessar a caixa de diálogo Sim Model de um modelo de simulação de um componente posicionado a partir de uma biblioteca de banco de dados e clicar em OK, os campos Sim Netlist e Sim Spice Prefix serão definidos automaticamente para esse componente com base no texto do modelo escolhido.

Parâmetros

Todos os outros nomes de campos do banco de dados serão mapeados automaticamente para parâmetros de projeto com os mesmos nomes. Por exemplo, se um campo no banco de dados se chamar Tolerance, um parâmetro de projeto com o nome Tolerance será mapeado para ele. Você pode alterar o nome de um parâmetro de projeto clicando em sua célula e digitando diretamente o novo nome. São esses nomes de parâmetros de projeto que aparecerão na região Parameters da caixa de diálogo de propriedades associada ao componente, depois que ele for posicionado em uma folha do esquemático.

Você pode ter um grande número de campos de dados associados a um componente no banco de dados, e nem todos eles você desejará, ou sequer precisará, adicionar como parâmetros de projeto ao componente quando ele for inserido em uma folha de esquemático. Grande parte dessas informações pode ser necessária apenas ao gerar uma lista de materiais. A caixa de diálogo Report Manager permite adicionar informações de parâmetros a uma BOM diretamente de um banco de dados vinculado, reduzindo a quantidade de informações que são “carregadas” com os documentos-fonte do esquemático. Para obter mais informações, consulte a seção Preparação de uma BOM no Report Manager.

Para os campos que você explicitamente não deseja mapear do banco de dados, defina a entrada Design Parameter como [None]. Os campos do banco de dados não mapeados são identificados na guia por um ícone de cruz vermelha (Cross icon, indicating that a database field is not mapped to a component parameter). Os campos do banco de dados mapeados são identificados por um ícone de marca de seleção verde (Tick icon, indicating that a database field is mapped to a component parameter).

Configure o mapeamento de parâmetros conforme necessário. Defina como [None] para impedir que um parâmetro do banco de dados seja mapeado para o componente inserido. Os parâmetros não mapeados podem ser incluídos diretamente na BOM, se necessário.Configure o mapeamento de parâmetros conforme necessário. Defina como [None] para impedir que um parâmetro do banco de dados seja mapeado para o componente inserido. Os parâmetros não mapeados podem ser incluídos diretamente na BOM, se necessário.

Para remapear rapidamente um campo não mapeado, clique na linha desse campo e use o atalho de teclado Ctrl+D. Observe que, para mapeamentos de modelos, será necessário selecionar manualmente uma opção na lista suspensa Design Parameter associada.

Opções de atualização de parâmetros

As colunas restantes na guia Field Mappings permitem especificar as ações aplicadas aos parâmetros ao inserir um componente da biblioteca de banco de dados pela primeira vez ou ao atualizar um componente já inserido usando o comando Tools » Update Parameters From Database.

As quatro colunas são as seguintes:

  • Update Values - uma célula nesta coluna é usada para determinar a ação a ser executada se o parâmetro existir tanto na folha de esquemático quanto no banco de dados, mas os valores forem diferentes no momento. Escolha atualizar o parâmetro do componente inserido com o valor armazenado no banco de dados (Update) ou não atualizá-lo (Do not update). Esta opção é respeitada ao usar o comando Update Parameters From Database, após a inserção do componente.
  • Add To Design - uma célula nesta coluna é usada para determinar a ação a ser executada se o parâmetro for encontrado no banco de dados, mas não existir no componente inserido. Você pode optar por adicionar o parâmetro (Add), não adicionar o parâmetro (Do not add) ou adicionar o parâmetro somente se ele tiver um valor atribuído no banco de dados (Add only if not blank in database). Esta opção é respeitada tanto na inserção inicial do componente da biblioteca de banco de dados quanto ao usar o comando Update Parameters From Database, após a inserção do componente.
  • Visible On Add - uma caixa de seleção nesta coluna é usada para determinar se um parâmetro recém-adicionado, resultante da inserção inicial ou de uma atualização após a inserção, ficará visível no componente na folha de esquemático (marcada) ou não (desmarcada).
  • Remove From Design - uma célula nesta coluna é usada para determinar a ação a ser executada se o parâmetro existir no componente inserido, mas não estiver no banco de dados ou estiver, porém sem valor. Você pode optar por não remover o parâmetro (Do not remove) ou removê-lo somente se ele não tiver um valor atribuído no banco de dados (Remove only if blank in database). Esta opção é respeitada ao usar o comando Atualizar parâmetros do banco de dados, após a inserção do componente.

Inicialmente, os campos Update Values, Add To Design e Remove From Design — para cada campo mapeado do banco de dados — serão definidos com a entrada Default, e a opção Visible On Add estará desabilitada, conforme ilustrado na imagem a seguir.

Opções iniciais (padrão) de atualização de parâmetros.Opções iniciais (padrão) de atualização de parâmetros.

Observando a imagem, há quatro pontos importantes a destacar sobre as opções de atualização:

  1. Os campos do banco de dados não mapeados não terão opções de atualização associadas.
  2. Os mapeamentos baseados em atributos e modelos (entradas entre colchetes na coluna Design Parameter) não terão opções de atualização associadas, pois não são parâmetros de projeto.
  3. O campo-chave (por exemplo, Part Number na imagem) não terá opções de atualização associadas. Este campo é usado exclusivamente para correspondência de parâmetros.
  4. Uma configuração de Default faz com que uma opção de atualização siga sua definição padrão correspondente, conforme especificado na guia Default Actions da caixa de diálogo Database Library Options (Tools » Options nos menus principais ou Options no menu de contexto da guia Table Browser). Essa caixa de diálogo também pode ser acessada clicando no botão Options na região Field Settings da visualização do documento.

Defina as opções padrão de atualização de parâmetros em um local centralizado para uma DbLib. Passe o cursor sobre a imagem para ver o equivalente para uma SVNDbLib.Defina as opções padrão de atualização de parâmetros em um local centralizado para uma DbLib. Passe o cursor sobre a imagem para ver o equivalente para uma SVNDbLib.

O quarto ponto é vantajoso porque permite especificar as opções de atualização em um local centralizado e, em seguida, apontar para esse local ao definir as opções de atualização de cada campo mapeado. É por isso que a entrada Default é carregada automaticamente nos campos de atualização correspondentes ao mapear um campo do banco de dados para um parâmetro de projeto.

Se desejar substituir a configuração padrão de uma opção de atualização, clique no campo de atualização correspondente, na guia Field Mappings, e clique novamente para acessar uma lista suspensa com as opções de atualização aplicáveis.

As opções de atualização de parâmetros podem ser substituídas manualmente, se necessário.As opções de atualização de parâmetros podem ser substituídas manualmente, se necessário.

Dessa forma, você tem controle total sobre como os parâmetros do projeto são atualizados. Você pode definir todos os campos como Default e tomar as decisões de atualização necessárias na caixa de diálogo Database Library Options, definir cada campo de atualização individualmente ou combinar as duas abordagens — a decisão é inteiramente sua, conforme julgar mais adequado. Para componentes inseridos, a atualização, quando executada, é realizada por meio de uma caixa de diálogo Engineering Change Order. Se, nessa etapa, houver atualizações que você prefira não realizar, poderá optar por não incluir essas alterações específicas — tendo, assim, a palavra final sobre quais parâmetros de projeto serão atualizados.

Especificação dos locais das bibliotecas de símbolos e modelos

Ao inserir um componente de uma biblioteca de banco de dados, seu símbolo — especificado pelo mapeamento [Library Ref] — é extraído da biblioteca de esquemáticos especificada (*.SchLib). Da mesma forma, quaisquer referências a modelos (footprint, PCB3D, simulação) especificadas no banco de dados estarão nos arquivos correspondentes de biblioteca de PCB (*.PcbLib), biblioteca PCB3D (*.PCB3DLib) e modelo de simulação (*.mdl, *.ckt). Os caminhos para esses arquivos podem ser especificados explicitamente no banco de dados das seguintes formas:

  • Inserindo um caminho absoluto para o arquivo.
  • Inserindo um caminho relativo para o arquivo.

Se você definiu campos no banco de dados para informações de caminho, esses campos precisam ser mapeados para os parâmetros de projeto apropriados — [Library Path], [Footprint Path], [PCB3D Path], [Sim File] e assim por diante (consulte a seção Mapeamento de modelos e parâmetros).

Inserir caminhos — mesmo relativos — em uma tabela de banco de dados pode ser um pouco restritivo. Se você alterar o local de uma biblioteca ou de um arquivo de modelo, precisará atualizar a tabela do banco de dados de acordo. Para oferecer maior liberdade, é possível especificar informações de busca de bibliotecas no próprio arquivo DbLib/SVNDbLib. Isso permite especificar o nome da biblioteca de origem ou do arquivo de modelo no banco de dados, ou simplesmente não defini-lo.

Using Search Paths with a large number of symbol/model files - embora os caminhos de pesquisa ofereçam maior flexibilidade e simplicidade para configurar como os símbolos e modelos são localizados, essa abordagem não é recomendada quando há um grande número de arquivos de símbolos ou modelos no local de pesquisa. Dependendo do esquema de nomenclatura de arquivos utilizado, os caminhos de pesquisa podem exigir que todos os arquivos de biblioteca/modelo presentes no caminho sejam pesquisados sempre que um símbolo/modelo for necessário, por exemplo, ao navegar pelos componentes ou transferir o projeto do esquemático para a PCB.

Para uma biblioteca de banco de dados

Para uma DbLib, os caminhos de pesquisa de bibliotecas são definidos na aba Symbol and Model Search Paths da caixa de diálogo Database Library Options (Tools » Options). Essa caixa de diálogo também pode ser acessada clicando no botão Options na região Field Settings da visualização do documento.

Especificação dos caminhos de pesquisa para bibliotecas de símbolos e modelos.Especificação dos caminhos de pesquisa para bibliotecas de símbolos e modelos.

Para adicionar um caminho à lista:

  1. Digite o caminho diretamente no campo abaixo da região Caminhos de pesquisa de bibliotecas ou clique no botão Browse for a folder button para acessar a caixa de diálogo Browse for Folder, na qual você pode localizar o diretório que contém os arquivos de biblioteca/modelo necessários.
  2. Você pode adicionar um caminho completo ou relativo (em relação ao local do arquivo DbLib). Controle isso usando a opção Add/Update As Relative Path.
  3. Após especificar o caminho necessário, adicione-o à lista de caminhos de pesquisa clicando no botão Add .
  4. Continue adicionando outros caminhos de pesquisa conforme necessário.
Na inserção direta, se você especificar um caminho incorreto (por exemplo, para uma pasta que não existe), a entrada ainda poderá ser adicionada, mas aparecerá esmaecida na lista para indicar que é um caminho de pesquisa inválido. Se perceber que inseriu um caminho incorretamente, você poderá selecioná-lo na lista e clicar no botão Remove ou modificar sua definição e clicar no botão Update .

Os caminhos de pesquisa de bibliotecas determinam onde os arquivos de biblioteca e modelo podem ser encontrados ao inserir componentes da biblioteca de banco de dados e ao pesquisar um modelo após a inserção. O modelo específico utilizado dependerá de como você configurou os caminhos de pesquisa de bibliotecas e de ter adicionado ou não informações específicas de biblioteca ao banco de dados. A pesquisa seguirá esta ordem:

  1. Se houver um caminho completo no campo de caminho mapeado para o símbolo ou modelo, use esse arquivo de biblioteca/modelo e extraia o símbolo ou modelo especificado no campo de referência correspondente.
  2. Se houver um caminho relativo no campo de caminho mapeado para o símbolo ou modelo, use esse arquivo de biblioteca/modelo e extraia o símbolo ou modelo especificado no campo de referência correspondente.
  3. Se houver apenas um nome de arquivo de biblioteca/modelo no campo de caminho mapeado para o símbolo ou modelo, use os caminhos de pesquisa para localizar o primeiro arquivo de biblioteca/modelo que corresponda ao nome especificado e que contenha uma correspondência para o símbolo ou modelo especificado no campo de referência correspondente.
  4. Se não houver informações sobre o arquivo de biblioteca/modelo no banco de dados, use os caminhos de pesquisa para localizar o primeiro arquivo de biblioteca/modelo que contenha uma correspondência para o símbolo ou modelo especificado no campo de referência correspondente.

Para uma biblioteca de banco de dados SVN

Para uma SVNDbLib, os diretórios-base no repositório Subversion — nos quais ficam os símbolos e os modelos de footprint — são especificados na aba SVN Repository da caixa de diálogo Database Library Options (Tools » Options). Essa caixa de diálogo também pode ser acessada clicando no botão Options na região Field Settings da visualização do documento.

Especificação dos diretórios-base do repositório para símbolos e footprints.Especificação dos diretórios-base do repositório para símbolos e footprints.

Use os campos disponíveis na região Models Location para especificar o diretório-base dos símbolos e footprints. Clique no botão Click the ellipsis button to select the repository folder for the symbols and footprints à direita de um campo para acessar a caixa de diálogo Browse for directory, que oferece uma visualização do repositório vinculado. Use essa caixa de diálogo para selecionar a pasta necessária.

Navegação até o diretório correspondente no repositório SVN vinculado.Navegação até o diretório correspondente no repositório SVN vinculado.

É importante ressaltar que os símbolos e footprints devem estar nos diretórios-base do repositório especificados. Naturalmente, eles podem estar em subpastas desses diretórios, e os caminhos especificados para símbolos e footprints podem apontar para o mesmo diretório no repositório.

Os locais dos modelos determinam onde os arquivos de biblioteca e modelo podem ser encontrados ao inserir componentes da biblioteca de banco de dados com controle de versão e ao pesquisar um modelo após a inserção. O símbolo esquemático e os modelos de footprint específicos utilizados dependerão de como você configurou esses locais e de ter adicionado ou não informações específicas de biblioteca ao banco de dados. A pesquisa seguirá esta ordem:

  1. Se houver um caminho completo no campo de caminho mapeado para o símbolo ou modelo de footprint (por exemplo, http://MyServer/svn/MyCompany/ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), use esse arquivo de biblioteca e extraia o símbolo ou footprint especificado no campo de referência correspondente.
  2. Se houver um caminho relativo (em relação à raiz do repositório) no campo de caminho mapeado para o símbolo ou modelo de footprint (por exemplo, /ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), use esse arquivo de biblioteca e extraia o símbolo ou footprint especificado no campo de referência correspondente. A URL do repositório — especificada na região Conexão com o servidor do repositório da caixa de diálogo — será adicionada como prefixo ao caminho inserido para formar o endereço absoluto.
  3. Se houver apenas um nome de arquivo de biblioteca no campo de caminho mapeado para o símbolo ou modelo de footprint (por exemplo, Capacitor_NonPolarized.SchLib), use os locais de modelos especificados no repositório para localizar o primeiro arquivo de biblioteca que corresponda ao nome especificado e que contenha uma correspondência para o símbolo ou modelo de footprint especificado no campo de referência correspondente.
Ao pesquisar uma correspondência de símbolo/modelo, os caminhos das pastas no diretório-base de símbolos ou footprints são organizados em uma lista plana, classificados e pesquisados em ordem alfabética. Se o Assistente de divisão de bibliotecas for utilizado, sempre haverá uma biblioteca correspondente com o nome do próprio símbolo/footprint.
  1. Se não houver informações sobre o arquivo de biblioteca no banco de dados, use os locais de modelos especificados para localizar o primeiro arquivo de biblioteca que contenha uma correspondência para o símbolo ou modelo de footprint especificado no campo de referência correspondente.
Ao localizar o símbolo/footprint, o sistema procurará inicialmente a primeira biblioteca com o mesmo nome do próprio símbolo ou footprint. Por exemplo, se o nome lógico do símbolo no banco de dados (especificado pelo mapeamento [Library Ref]) for Capacitor_NonPolarized, o sistema procurará o primeiro arquivo chamado Capacitor_NonPolarized.SchLib e buscará o símbolo nesse arquivo. Se o símbolo/footprint não puder ser encontrado dessa forma, o sistema procurará uma correspondência em todas as bibliotecas.
AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents