Vinculando Componentes Existentes a um Banco de Dados da Empresa usando um Arquivo de Vínculo de Banco de Dados

Num relance

Vincule componentes existentes de esquemáticos ou bibliotecas ao banco de dados central de componentes da sua empresa usando um arquivo Database Link no Altium Designer. Este artigo explica como o DbLink se diferencia das abordagens baseadas em bibliotecas de banco de dados, como criar um arquivo DbLink e como configurar uma conexão com um banco de dados externo. Também aborda a sincronização dos parâmetros mapeados dos componentes com os registros do banco de dados, para que essas informações possam ser incluídas na sua lista de materiais. Continue lendo para dar o próximo passo e manter os dados dos seus componentes sincronizados.

- Entenda quando usar DbLink em vez de DbLib ou SVNDbLib.
- Aprenda a criar um arquivo Database Link e configurar conexões com Access, Excel e outros bancos de dados compatíveis.
- Identifique os requisitos de vinculação por campos-chave e as considerações sobre mecanismos de banco de dados de 64 bits.
Aprofunde-se com a IA:

Um requisito comum em muitas organizações é vincular os componentes do CAD eletrônico ao banco de dados central de componentes da empresa. O Altium Designer oferece suporte a isso, permitindo vincular componentes existentes a registros no banco de dados da empresa por meio da criação e do uso de um arquivo Database Link. O arquivo Database Link é adicionado ao projeto ou ao pacote de bibliotecas, permitindo vincular, respectivamente, componentes já posicionados em folhas de esquemático ou, mais tipicamente, componentes definidos em uma biblioteca de esquemáticos de origem.

Após estabelecer o vínculo, você pode transferir informações paramétricas mapeadas dos registros do banco de dados para os parâmetros de projeto dos componentes usando o comando Tools » Update Parameters From Database. Essas informações podem então ser incluídas na lista de materiais (BOM) final, pronta para a aquisição dos componentes.

The Move from 32-bit to 64-bit Software

Com o lançamento do Altium Designer versão 18.0 e do Altium NEXUS versão 1.0, o software de projeto passou a ser de 64 bits. Para vincular componentes de projeto a um banco de dados em uma versão de 64 bits do software Altium, o mecanismo de banco de dados de backend também deve ser de 64 bits. Se você usa o Microsoft Access ou o Excel para gerenciar os dados de backend e tem uma versão de 32 bits do Office instalada, também é possível instalar o mecanismo de banco de dados do Microsoft Access de 64 bits. Para obter informações detalhadas sobre como fazer isso, siga as instruções na página Como usar bibliotecas de banco de dados com o Altium Designer de 32 e 64 bits no mesmo computador.

Se você tentar se conectar por meio do mecanismo de banco de dados do Microsoft Access de 32 bits, a mensagem de erro a seguir será exibida.

Error dialog, reporting that a 64-bit version of the Microsoft Access Database engine is required for database linking

Observe que certos erros de conexão, como uma sintaxe incorreta nos detalhes de Provider do Connection String, podem fazer com que o mecanismo de banco de dados errado seja chamado e a caixa de diálogo de erro mostrada acima seja exibida, mesmo após a instalação do mecanismo de banco de dados de 64 bits.

Uma observação sobre as opções de vinculação...

O Altium Designer oferece três métodos para vincular um componente a um banco de dados: usando um arquivo Database Link (*.DbLink), um arquivo Database Library (*.DbLib) ou um arquivo SVN Database Library (*.SVNDbLib), respectivamente. A abordagem DbLink oferece uma maneira eficiente de vincular e manter os componentes usados no projeto (ou nas bibliotecas) sincronizados com os dados inseridos no banco de dados. A abordagem DbLib/SVNDbLib aproveita essa eficiência comprovada de vinculação e acrescenta a liberdade de posicionar um componente diretamente do banco de dados — essencialmente criando o componente de forma dinâmica a partir das informações armazenadas para ele no registro correspondente do banco de dados.

Antes de explorar mais a fundo o recurso de vinculação a bancos de dados, vale a pena discutir as diferenças entre esses dois métodos quanto à forma de utilizá-los.

Vinculação usando um arquivo Database Link

  • Com esse método, o arquivo Database Link define o vínculo entre o componente do esquemático e um registro correspondente em um banco de dados. A correspondência entre registros é estabelecida pela vinculação de campos-chave, que pode usar um único campo-chave (por exemplo, um número de peça) ou vários campos-chave (por meio da definição de uma cláusula Where).
  • Nesse método de vinculação, as informações de modelo e de parâmetros do componente devem ser predefinidas como parte do componente de biblioteca do Altium Designer. O componente de biblioteca também deve incluir as informações necessárias dos campos-chave como parte de sua definição. Após essa definição, você adiciona um arquivo Database Link ao pacote de bibliotecas ou ao projeto e pode então sincronizar as informações do componente (parâmetros) com o conteúdo dos campos do banco de dados.
  • Embora cada componente físico definido por cada registro do banco de dados não precise corresponder a um componente de biblioteca exclusivo do Altium Designer — vários componentes do banco de dados podem compartilhar o mesmo símbolo de componente —, esse método de vinculação normalmente é usado em uma relação de “um registro do banco de dados para um componente do Altium Designer”. O componente exclusivo do Altium Designer pode ser uma instância posicionada em uma folha de esquemático ou um componente exclusivo em uma biblioteca de componentes.
  • Na vinculação a bancos de dados do tipo DbLink, você inclui o arquivo Database Link no pacote de bibliotecas ou no projeto.

A vinculação entre componentes de biblioteca e um banco de dados externo só é possível se a biblioteca fizer parte de um pacote de bibliotecas integradas (*.LibPkg). Escolha o comando File » New » Library » Integrated Library para criar um novo pacote de bibliotecas e, em seguida, adicione a ele as bibliotecas de esquemáticos de origem.

► Saiba mais sobre Bibliotecas integradas.

Vinculação usando um arquivo Database Library

Related page: Bibliotecas de banco de dados

  • Com esse método, o arquivo Database Library também define o vínculo entre o componente do esquemático e um registro correspondente em um banco de dados. Novamente, a correspondência entre registros é estabelecida pela vinculação de campos-chave, que pode usar um único campo-chave (por exemplo, um número de peça) ou vários campos-chave (por meio da definição de uma cláusula Where).
  • Nesse método de vinculação, as informações de símbolo, modelo e parâmetros de um componente são armazenadas como parte da definição do registro desse componente no banco de dados externo. O componente de esquemático referenciado (armazenado em uma biblioteca de componentes subjacente (*.SchLib)) é apenas o símbolo; ele não tem modelos vinculados nem parâmetros de projeto definidos.
  • Quando o componente é posicionado, suas informações de parâmetros e modelos são criadas dinamicamente, usando os campos correspondentes no registro do banco de dados associado e de acordo com o mapeamento definido. Um ou mais desses parâmetros serão então usados para manter um vínculo contínuo com o banco de dados, conforme os critérios de correspondência definidos, permitindo futuras sincronizações após o posicionamento.
  • Esse método de vinculação, devido à criação dinâmica de componentes no momento do posicionamento, é muito adequado para uma relação de “vários registros do banco de dados para um componente do Altium Designer”. Por exemplo, seu banco de dados pode incluir a série de resistores E96, com todos os registros referenciando o mesmo símbolo de resistor do esquemático e o mesmo footprint de PCB.
  • Ao contrário da vinculação a bancos de dados do tipo DbLink, na qual o arquivo DbLink deve ser incluído no pacote de bibliotecas (ou no projeto), o arquivo DbLib/SvnDbLib não precisa ser adicionado ao projeto. A biblioteca de banco de dados (DbLib) é incluída nas Bibliotecas disponíveis, acessíveis pelo painel Components. Lembre-se de que as Bibliotecas disponíveis podem consistir em Bibliotecas do projeto, Bibliotecas instaladas ou bibliotecas encontradas nos caminhos de pesquisa especificados.
  • Normalmente, você configura os arquivos DbLib/SVNDbLib organizando-os por biblioteca. Por exemplo, pode ter um arquivo para todos os resistores detalhados no banco de dados da empresa, outro para capacitores e assim por diante.
Uma SVN Database Library (*.SVNDbLib) é uma extensão do modelo de vinculação DbLib. Esse tipo de arquivo é usado exatamente da mesma forma que um DbLib, mas o símbolo do esquemático e os modelos associados são armazenados em bibliotecas sob controle de versão (Subversion).

Criação do arquivo Database Link

Como mencionado, a base do recurso de vinculação a bancos de dados é o arquivo Database Link. Esse arquivo é criado e gerenciado usando o editor DatabaseLink do Altium Designer. Esse editor fica disponível quando o documento ativo na janela principal de projeto é um arquivo *.DbLink.

Exemplo de arquivo DbLink aberto no editor DatabaseLink.Exemplo de arquivo DbLink aberto no editor DatabaseLink.

Crie um novo arquivo desse tipo:

  • Escolhendo o comando File » New » Library » Database Link File nos menus principais.
  • Clicando com o botão direito do mouse na entrada do projeto desejado no painel Projects e escolhendo o comando Add New to Project » Database Link File no menu de contexto.

Quando adicionados a um projeto, os arquivos Database Link aparecem no painel Projects , na subpasta Settings\Database Link Files.

The DbLink file appears in the Settings folder in the Projects panel

Se um documento padrão tiver sido especificado na página System - New Document Defaults da caixa de diálogo Preferences, o arquivo Database Link será criado usando esse padrão como modelo. É possível atribuir um padrão diferente para um arquivo Database Link criado como parte de um projeto de PCB, de um pacote de biblioteca integrada ou como documento avulso.

Conexão com um banco de dados externo

Os dados de tabelas e mapeamento só aparecerão na janela principal do editor depois que o arquivo Database Link ativo estiver conectado com êxito ao banco de dados externo desejado. A conexão é definida usando os controles disponíveis na região Source of Connection.

Especificação da conexão com o banco de dados externo.Especificação da conexão com o banco de dados externo.

É possível conectar-se a qualquer banco de dados que ofereça suporte a OLE DB. Cada uma das opções disponíveis nessa região usa uma string de conexão OLE DB para se conectar ao banco de dados de destino. Alguns bancos de dados podem não oferecer suporte a OLE DB. No entanto, praticamente todos os sistemas de gerenciamento de bancos de dados em uso atualmente podem ser acessados pela interface Open Database Connectivity (ODBC). O recurso de vínculo com banco de dados usa o provedor ODBC da Microsoft, que permite que um ADO (ActiveX Data Object) se conecte a qualquer fonte de dados ODBC. Assim, é possível conectar-se a qualquer banco de dados ODBC. O provedor OLE DB para o banco de dados ODBC é especificado como parte da string de conexão.

A conexão também pode ser definida na guia Connection da caixa de diálogo Database Connection, acessada pelo menu principal Tools ou clicando no botão Advanced (à direita do botão Connect , na parte inferior da região).

Conexão rápida com bancos de dados Access e Excel

A opção Select Database Type oferece um método rápido para criar uma string de conexão quando o banco de dados de destino foi criado usando o Microsoft Access ou o Microsoft Excel. Ao usar essa opção, selecione o tipo de banco de dados e, em seguida, localize e selecione o arquivo de banco de dados desejado. A string de conexão correspondente será composta automaticamente e inserida no campo da opção Use Connection String.

É possível especificar o caminho completo ou optar por armazenar o caminho relativo ao arquivo Database Link.

Criação de uma string de conexão

Se o banco de dados da sua empresa não for baseado em Access ou Excel e você quiser criar a string de conexão explicitamente, habilite a opção Use Connection String e clique no botão Build associado, à direita. A caixa de diálogo Data Link Properties será exibida.

Criação de uma string de conexão por meio da caixa de diálogo Data Link Properties. Criação de uma string de conexão por meio da caixa de diálogo Data Link Properties.

A caixa de diálogo é aberta na guia Connection . O provedor OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider é definido por padrão na guia Provider da caixa de diálogo. Essa é a configuração padrão do provedor para novos arquivos Database Link e também é usada para se conectar a arquivos de banco de dados Access (*.mdb). Altere o provedor conforme necessário.

Na guia Connection , insira o nome (incluindo o caminho) do banco de dados ao qual deseja se conectar.

Se o banco de dados exigir permissão de login, insira as informações necessárias, juntamente com quaisquer outras configurações avançadas disponíveis na guia Advanced da caixa de diálogo. A guia All apresenta uma lista resumida das opções de vínculo definidas, além de opções adicionais relacionadas ao provedor OLE DB escolhido. As opções também podem ser modificadas nessa guia, conforme necessário.

Depois de definir as opções de vínculo, você pode verificar se a conexão foi bem-sucedida clicando no botão Test Connection (na guia Connection ). Se a conexão for bem-sucedida, será exibida uma caixa de diálogo de confirmação.

A caixa de diálogo Data Link Properties é uma caixa de diálogo da Microsoft e, por isso, pressionar F1 ou usar o botão Help disponível dará acesso ao arquivo Microsoft Data Link Help. Esse arquivo não faz parte do conjunto de documentação da Altium.

Especificação de um arquivo Data Link

Se a fonte de dados à qual deseja se conectar for descrita por um arquivo Microsoft Data Link (*.udl), habilite a terceira opção de conexão — Use Data Link File — e clique no botão Browse associado para localizar o arquivo desejado. Um arquivo Data Link é essencialmente um recipiente de armazenamento para uma string de conexão.

Prosseguimento com a conexão

Após definir a conexão com o banco de dados externo, o texto do botão Connect ficará em negrito, indicando que você pode prosseguir com a conexão. Se os detalhes da conexão estiverem corretos, as informações de tabelas e mapeamento do banco de dados de destino serão carregadas no arquivo Database Link. O texto do botão Connect mudará para Connected e o botão ficará acinzentado e desabilitado.

Se houver algum problema com os detalhes da conexão, por exemplo, se uma string de conexão tiver sido criada incorretamente ou um caminho tiver sido inserido de forma errada, a conexão falhará e uma mensagem será exibida para alertar sobre isso. Verifique as configurações de conexão e clique novamente no botão Connect .

Exemplos de sinalização de falha na conexão.Exemplos de sinalização de falha na conexão.

Se você alterar as configurações de conexão enquanto estiver conectado a um banco de dados, a conexão ativa será perdida e o texto do botão Connect mudará para Reconnect. Clique para restabelecer a conexão.

Após a conexão inicial bem-sucedida e o salvamento do arquivo Database Link, a conexão será estabelecida automaticamente sempre que o arquivo for aberto, desde que o local e o nome do arquivo do banco de dados de destino não sejam alterados.

Listagem de tabelas do banco de dados

Após a conexão bem-sucedida com o banco de dados externo, os dados de tabelas e mapeamento serão carregados. O lado esquerdo do documento DbLink lista todas as tabelas existentes no banco de dados conectado.

Tabelas existentes no banco de dados conectado.Tabelas existentes no banco de dados conectado.

A opção Enable ao lado de cada entrada de tabela permite controlar se essa tabela será ou não usada ao atualizar parâmetros a partir do banco de dados.

Ao clicar em uma entrada de tabela na lista, seu ícone muda de Database table icon, inactive table para Database table icon, active table para identificá-la como a tabela ativa no momento. A tabela, com todos os seus dados, aparece na guia Table Browser do documento. Essa é uma cópia não editável da tabela e permite consultar rapidamente seu conteúdo, sem precisar abrir o próprio banco de dados externo.

Consulta a uma tabela de origem no banco de dados conectado.Consulta a uma tabela de origem no banco de dados conectado.

Para ampliar a área do navegador de tabelas (como mostrado na ilustração acima), recolha toda a área acima (configurações de conexão e de campos) clicando no controle Collapse icon - collapse a region of the DbLink document, no canto superior direito da visualização do documento DbLink. Clique em Expand icon - expand a region of the DbLink document para expandi-la novamente.

Especificação dos critérios de correspondência

Para atualizar as informações dos parâmetros dos componentes com aquelas armazenadas nos campos do banco de dados externo, cada componente do projeto deve primeiro ser associado a uma linha de uma tabela do banco de dados. A região Field Settings do documento permite definir os critérios de correspondência: uma busca simples por chave única ou uma correspondência mais avançada usando uma cláusula Where.

Os critérios de correspondência são especificados individualmente para cada tabela.

Controle dos critérios de correspondência.Controle dos critérios de correspondência.

Busca por chave única

Se a opção Single key lookup estiver habilitada (padrão), os campos Database field e Part parameter ficarão disponíveis. O Database field lista todos os nomes de campos disponíveis (cabeçalhos de coluna) na tabela ativa do banco de dados. O campo Part parameter lista todos os parâmetros encontrados em todos os componentes do projeto, tanto os parâmetros do sistema quanto os definidos pelo usuário.

Use estes campos para especificar a correspondência entre um campo da tabela e um parâmetro de uma peça (comum a todas as peças). Normalmente, o campo de correspondência em ambos os casos é algo que identifica exclusivamente cada componente no banco de dados externo, como um número de peça. O campo de pesquisa escolhido é destacado na aba Field Mappings do documento pela entrada Design Parameter exibida em cinza.

Mapeamento de chave única por número de peçaMapeamento de chave única por número de peça

Ao usar o recurso Tools » Update Parameters From Database, as informações são lidas do parâmetro-chave escolhido nos componentes inseridos no esquemático e, em seguida, pesquisadas no campo (chave) escolhido do banco de dados, em todas as tabelas habilitadas. Quando há uma correspondência, as informações de outras células desse registro da tabela de origem podem ser transferidas para os parâmetros mapeados no componente do esquemático.

Correspondência avançada — a cláusula Where

Embora a opção Single key lookup funcione bem quando há um número de peça/ID exclusivo para estabelecer a correspondência, ela não é tão eficaz ao fazer a correspondência por um parâmetro que não é exclusivo, como capacitância ou resistência. Nesse caso, deve-se usar a cláusula Where, mais avançada, que permite especificar a correspondência por várias chaves para vincular o componente do esquemático à linha desejada na tabela correspondente do banco de dados.

Em sua forma mais simples, a cláusula Where (escrita usando a sintaxe SQL) reflete as entradas escolhidas que definem a pesquisa por chave única. Por exemplo, se Database field tiver sido definido como Part Number e o Part parameter exclusivo (existente para todas as peças do projeto) tiver sido definido como Part Number, a entrada da cláusula Where seria:

[Part Number] = '{Part Number}'

Os colchetes ao redor do campo do banco de dados (coluna da tabela) são caracteres de delimitação, conforme especificado na aba Advanced da caixa de diálogo Database Connection. Acesse essa caixa de diálogo clicando no botão Advanced na região Source of Connection do documento ou pelo menu principal Tools .

A aba Advanced  da caixa de diálogo Database Connection oferece opções SQL adicionais para delimitar nomes de tabelas ou usar nomes de esquemas de tabelas em uma cláusula Where construída. A aba Advanced da caixa de diálogo Database Connection oferece opções SQL adicionais para delimitar nomes de tabelas ou usar nomes de esquemas de tabelas em uma cláusula Where construída.

Ao delimitar nomes de tabelas, os caracteres de delimitação específicos dependerão do banco de dados que você estiver usando. Por exemplo, os colchetes [ ] só podem ser usados em bancos de dados da Microsoft, como Access, Excel via ADO ou MSSQL (versões mais recentes). O MYSQL usaria o caractere ' como delimitador. Em qualquer banco de dados, só é necessário delimitar nomes de colunas se eles incluírem espaços ou forem palavras reservadas (desse banco de dados). Consulte a documentação do seu software de banco de dados específico para verificar quais caracteres de delimitação são usados (se houver).

As chaves especificam que a entrada referenciada é um parâmetro do projeto. As aspas simples são usadas para especificar que o parâmetro do projeto deve ser tratado como uma string, e não como um número (sem aspas). A correspondência de tipos é muito importante, pois o SQL é sensível a tipos. O parâmetro do projeto deve ter o mesmo tipo da coluna no banco de dados.

Usando a sintaxe SQL padrão, a cláusula Where pode então ser ampliada para estabelecer a correspondência usando várias entradas Database field/Part parameter, por exemplo:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

Nesse caso, um único registro na tabela correspondente do banco de dados seria vinculado usando três parâmetros diferentes do projeto. Observe que a entrada do parâmetro de projeto Tolerance não está entre aspas. Isso significa que o tipo da coluna na tabela associada do banco de dados é Number, e não String.

Usando a sintaxe SQL padrão, você pode tornar a cláusula Where tão simples ou complexa quanto desejar. Um exemplo de uma cláusula mais complexa seria:

[Tolerance] BETWEEN {Min Tolerance} AND {Max Tolerance} AND [Price] <= {Max Price} AND [Manufacturer] IN ('{Preferred Manufacturer 1}', '{Preferred Manufacturer 2}')

Nesse caso, a tabela seria consultada para encontrar peças correspondentes com base em três campos do banco de dados: Tolerance, Price e Manufacturer. A tolerância deve estar dentro do intervalo definido pelos parâmetros de projeto Min Tolerance e Max Tolerance. O preço deve ser menor ou igual ao especificado no parâmetro de projeto Max Price, e o fabricante pode ser qualquer um dos dois candidatos especificados pelos parâmetros de projeto Preferred Manufacturer 1 e Preferred Manufacturer 2.

Criação de um parâmetro de peça

Se não houver um parâmetro adequado nos seus componentes do Altium Designer para usar como Part parameter para fins de correspondência no arquivo DbLink, você precisará criar um. A adição desse parâmetro “base” pode ser feita rapidamente usando o comando Tools » Parameter Manager ou o painel Properties do editor correspondente.

Adição de um parâmetro usando o recurso de gerenciamento de parâmetros

Para adicionar um novo parâmetro usando o recurso de gerenciamento de parâmetros:

  1. Em um documento de esquemático (ou documento de biblioteca de esquemáticos), escolha Tools » Parameter Manager nos menus principais. A caixa de diálogo de opções do editor de parâmetros será exibida. Para adicionar o novo parâmetro a todas as peças, certifique-se de que a opção Parts esteja habilitada na região Include Parameters Owned By e que All Objects esteja definido como critério na região That Meet the Following Criteria.

Configuração das opções de gerenciamento de parâmetros.Configuração das opções de gerenciamento de parâmetros.

  1. Clicar em OK abrirá a caixa de diálogo do editor de tabela de parâmetros, mostrando todos os parâmetros atualmente pertencentes a todos os objetos de peça nos documentos-fonte de esquemático do projeto ativo (ou aos componentes de esquemático na biblioteca de esquemáticos ativa). Clique no botão Add Column e use a caixa de diálogo de adição de parâmetro exibida para definir o nome do parâmetro. Certifique-se de que a opção Add to all objects esteja habilitada para que o novo parâmetro seja adicionado a todas as peças.

Na primeira vez, deixe o Value do parâmetro sem atribuição — apenas adicione o parâmetro a cada peça. Você pode executar o editor de tabela de parâmetros uma segunda vez para definir o valor de cada parâmetro. A caixa de diálogo oferece suporte a atalhos de edição padrão do Windows, como: usar as teclas de seta para mover de uma célula para outra; F2 para editar o valor da célula atual; e copiar e colar blocos de um editor de texto ou de uma planilha na célula selecionada e no número necessário de células abaixo dela, na caixa de diálogo.

Exemplo de uso do recurso de gerenciamento de parâmetros para adicionar um novo parâmetro a todas as peças, em todos os esquemáticos-fonte de um projeto.Exemplo de uso do recurso de gerenciamento de parâmetros para adicionar um novo parâmetro a todas as peças, em todos os esquemáticos-fonte de um projeto.

  1. Após adicionar a nova coluna, clique no botão Accept Changes (Create ECO). Use a caixa de diálogo Engineering Change Order exibida para Validate e, em seguida, Execute as alterações, adicionando o parâmetro a cada uma das peças necessárias.

Execução das alterações de parâmetros (adição do novo parâmetro a todas as peças) por meio de uma ordem de alteração de engenharia.Execução das alterações de parâmetros (adição do novo parâmetro a todas as peças) por meio de uma ordem de alteração de engenharia.

Adição de um parâmetro usando o painel Properties

Um novo parâmetro pode ser adicionado a todas as peças selecionadas usando o painel Properties. O procedimento a seguir descreve o caso em que você deseja adicionar o mesmo parâmetro a todos os componentes do documento de biblioteca de esquemáticos ativo, usando os painéis SCHLIB Filter e Properties.

O procedimento é semelhante ao adicionar um parâmetro às peças inseridas em documentos-fonte de esquemático. Nesse caso, serão usados os painéis SCH Filter e Properties do editor de esquemáticos.
  1. Primeiro, selecione todos os componentes da biblioteca usando o painel SCH Filter e a consulta IsPart. Certifique-se de que a opção Whole Library esteja habilitada; caso contrário, apenas o componente ativo da biblioteca será considerado.

Configure um filtro para selecionar todas as peças no documento de biblioteca de esquemáticos ativo.Configure um filtro para selecionar todas as peças no documento de biblioteca de esquemáticos ativo.

  1. No painel Properties do editor de bibliotecas, verifique, por meio do texto na parte inferior do painel, se todos os componentes da biblioteca estão selecionados. Se o painel Properties não estiver visível, clique no botão  Panels button, click to display a menu of available panels no canto inferior direito da área de trabalho para exibi-lo.

Verifique se todas as peças estão selecionadas. Verifique se todas as peças estão selecionadas.

  1. Adicione o parâmetro necessário usando a aba Parameters do painel. Clique no botão Add para adicionar um novo parâmetro padrão e, em seguida, edite o nome conforme necessário. Observe que o parâmetro já foi adicionado a todos os componentes selecionados; se você clicar no botão Add novamente, um segundo parâmetro será adicionado.

Adicione o novo parâmetro necessário a todas as peças selecionadas. Adicione o novo parâmetro necessário a todas as peças selecionadas.

Mapeamento de campos do banco de dados para parâmetros de projeto

Os parâmetros de projeto de componentes existentes — tanto aqueles posicionados nas folhas de esquemático de origem de um projeto quanto aqueles definidos em uma biblioteca de componentes de esquemático adicionada a um pacote de bibliotecas — são atualizados com informações armazenadas externamente em um banco de dados da empresa usando o comando Update Parameters From Database, disponível no menu principal Tools quando o documento de esquemático ou de biblioteca de esquemáticos está ativo.

Quando ocorre uma correspondência entre um componente do projeto e um registro em uma tabela do banco de dados vinculado, o que acontece em seguida é determinado pelas informações de mapeamento e atualização especificadas no arquivo Database Link. Essas configurações são definidas na aba Field Mappings da visualização principal do documento.

As opções de mapeamento e atualização são especificadas individualmente para cada tabela.

Especifique as opções de mapeamento e atualização de parâmetros na aba Field Mappings do documento DbLink.Especifique as opções de mapeamento e atualização de parâmetros na aba Field Mappings do documento DbLink.

Mapeamento de parâmetros

As duas primeiras colunas (da esquerda para a direita) na aba Field Mappings permitem controlar quais informações do banco de dados serão mapeadas para os parâmetros de um componente.

A coluna Database Field Name lista todos os nomes de campos (colunas) da tabela atualmente ativa no banco de dados. A coluna Design Parameter permite especificar o parâmetro de projeto que deve ser mapeado para o campo correspondente no banco de dados. O mapeamento inicial é realizado automaticamente ao estabelecer a conexão com o banco de dados, com todos os campos do banco de dados mapeados para parâmetros de projeto com os mesmos nomes. Por exemplo, se um campo no banco de dados se chamar Tolerance, um parâmetro de projeto com o nome Tolerance será mapeado para ele.

Você pode alterar a entrada de um parâmetro de projeto das seguintes formas:

  • Clicando na célula e digitando diretamente o nome de um parâmetro diferente.
  • Usando a lista suspensa associada à célula para escolher um parâmetro de projeto existente.

Você pode ter um grande número de campos de dados associados a um componente no banco de dados, e nem todos eles precisarão ou deverão ser adicionados como parâmetros de projeto ao componente existente. Muitas dessas informações podem ser necessárias apenas ao gerar uma lista de materiais. A caixa de diálogo Report Manager inclui uma opção que permite adicionar informações de parâmetros a uma BOM diretamente de um banco de dados vinculado, permitindo reduzir a quantidade de informações que são “carregadas” com os documentos de esquemático de origem. Para obter mais informações, consulte a seção Adição de informações do banco de dados diretamente a uma BOM.

Para os campos que você explicitamente não deseja mapear a partir do banco de dados, defina a entrada Design Parameter como [None]. Os campos do banco de dados não mapeados são identificados na aba por um ícone de cruz vermelha (Cross icon, indicating that a database field is not mapped to a component parameter). Os campos do banco de dados mapeados são identificados por um ícone de marca de seleção verde (Tick icon, indicating that a database field is mapped to a component parameter).

Defina o mapeamento de parâmetros conforme necessário. Defina o mapeamento de parâmetros conforme necessário.

Para remapear rapidamente um campo não mapeado, clique na linha desse campo e use o atalho de teclado Ctrl+D. O nome do parâmetro de projeto será idêntico ao do Database Field Name correspondente.

Opções de atualização de parâmetros

As demais colunas na aba Field Mappings permitem especificar as ações executadas para os parâmetros ao atualizar um componente usando o comando Tools » Update Parameters From Database. Nas descrições a seguir, o termo Altium component é usado para representar um componente posicionado em uma folha de esquemático ou um componente definido em uma biblioteca de componentes de esquemático (que faz parte de um pacote de bibliotecas).

As quatro colunas são as seguintes:

  • Update Values - uma célula nesta coluna é usada para determinar a ação que deve ser executada se o parâmetro existir para o componente Altium e no banco de dados, mas os valores forem diferentes no momento. Escolha atualizar o parâmetro do componente Altium com o valor armazenado no banco de dados (Update) ou não realizar nenhuma atualização (Do not update).
  • Add To Design - uma célula nesta coluna é usada para determinar a ação que deve ser executada se o parâmetro for encontrado no banco de dados, mas não existir para o componente do Altium Designer. Você pode optar por adicionar o parâmetro (Add), não adicionar o parâmetro (Do not add) ou adicionar o parâmetro somente se houver um valor atribuído a ele no banco de dados (Add only if not blank in database).
  • Visible On Add - uma caixa de seleção nesta coluna é usada para determinar se um parâmetro recém-adicionado ficará visível para o componente Altium (marcada) ou não (desmarcada).
  • Remove From Design - uma célula nesta coluna é usada para determinar a ação que deve ser executada se o parâmetro existir para o componente do Altium Designer, mas não estiver no banco de dados ou estiver, porém sem valor. Você pode optar por não remover o parâmetro em nenhuma circunstância (Do not remove) ou removê-lo somente se não houver um valor atribuído a ele no banco de dados (Remove only if blank in database).

Inicialmente, os campos Update Values, Add To Design e Remove From Design — para cada campo mapeado do banco de dados — serão definidos com a entrada Default, e a opção Visible On Add estará desativada, conforme ilustrado na imagem a seguir.

Opções iniciais (padrão) de atualização de parâmetros.Opções iniciais (padrão) de atualização de parâmetros.

Observando a imagem, há três pontos importantes a destacar sobre as opções de atualização:

  1. Os campos do banco de dados não mapeados não terão opções de atualização associadas.
  2. O campo-chave (por exemplo, Part Number na imagem) não terá opções de atualização associadas. Esse campo é usado exclusivamente para fins de correspondência de parâmetros.
  3. Uma configuração de Default faz com que uma opção de atualização siga sua definição padrão correspondente, conforme especificado na aba Default Actions da caixa de diálogo Database Link Options (Tools » Options). Essa caixa de diálogo também pode ser acessada clicando no botão Options na região Field Settings da visualização do documento.

Defina as opções padrão de atualização de parâmetros em um local centralizado.Defina as opções padrão de atualização de parâmetros em um local centralizado.

O terceiro ponto é vantajoso porque permite especificar as opções de atualização em um local centralizado e, em seguida, apontar para esse local ao definir as opções de atualização de cada campo mapeado. É por isso que a entrada Default é carregada automaticamente nos campos de atualização pertinentes ao mapear um campo do banco de dados para um parâmetro de projeto.

Se desejar substituir a configuração padrão de uma opção de atualização, clique no campo de atualização correspondente na aba Field Mappings e, em seguida, clique novamente para acessar uma lista suspensa com as opções de atualização aplicáveis.

As opções de atualização de parâmetros podem ser substituídas manualmente, se necessário.As opções de atualização de parâmetros podem ser substituídas manualmente, se necessário.

Dessa forma, você tem controle total sobre como os parâmetros do projeto são atualizados. Você pode definir todos os campos como Default e tomar as decisões de atualização necessárias na caixa de diálogo Database Link Options, definir cada campo de atualização individualmente ou combinar as duas opções — a decisão é inteiramente sua, conforme considerar mais adequado. Quando executada, a atualização é realizada por meio de uma caixa de diálogo Engineering Change Order. Se, nessa etapa, houver atualizações que você prefira não realizar, poderá optar por não incluir essas alterações específicas — tendo, assim, a palavra final sobre quais parâmetros do projeto serão atualizados.

Garantindo a sincronização

Depois que as opções de mapeamento e atualização tiverem sido especificadas conforme necessário no arquivo Database Link, e o arquivo tiver sido salvo, você poderá transferir informações do banco de dados para os parâmetros mapeados dos componentes do Altium Designer. Lembre-se de que o parâmetro escolhido como campo-chave é usado para garantir que um componente do Altium Designer mantenha seu vínculo com o registro correspondente a esse componente no banco de dados externo. Isso significa que, a qualquer momento no futuro, alterações nas informações dos parâmetros no banco de dados poderão ser facilmente transferidas de volta para o componente do Altium Designer, sincronizando ambos. As atualizações são realizadas usando o comando Update Parameters From Database, disponível no menu principal Tools do Editor de Esquemáticos/Editor de Bibliotecas de Esquemáticos.

Sincronização dupla — DbLib/SVNDbLib e DBLink

Você pode ter um projeto existente no qual a maioria dos componentes posicionados tenha sido vinculada a um banco de dados externo usando um arquivo DbLink. Alterações no projeto podem resultar em circuitos adicionais, cujos componentes podem ser posicionados usando o recurso Biblioteca de Banco de Dados. É perfeitamente possível que o arquivo DbLib/SVNDbLib associado aponte para um banco de dados externo diferente.

Ao usar o comando Update Parameters From Database, todos os parâmetros vinculados dos componentes posicionados serão consultados — em todos os bancos de dados vinculados, independentemente do método de vinculação utilizado — e as diferenças detectadas nesses parâmetros serão exibidas na caixa de diálogo Selecionar alterações de parâmetros.

Se o mesmo campo do banco de dados tiver sido usado para correspondência nos arquivos DbLink e DbLib/SVNDbLib, a busca por uma correspondência será realizada primeiro no banco de dados vinculado pelo arquivo DbLink e, em seguida, no banco de dados vinculado pelo arquivo DbLib/SVNDbLib. Se o componente estiver presente nos dois bancos de dados, é possível que a correspondência e a atualização sejam feitas a partir do registro externo errado.

Adicionando informações do banco de dados diretamente a uma BOM

Related page: Configuração da BOM no Gerenciador de Relatórios

Historicamente, as informações de origem de uma lista de materiais (BOM) eram obtidas das informações dos parâmetros dos componentes posicionados no projeto. No entanto, isso pode fazer com que muitas informações sejam anexadas a um esquemático apenas para uso na BOM. Se os componentes do Altium Designer posicionados estiverem vinculados a um banco de dados externo por meio de um arquivo DbLink, o Gerador de BOM poderá extrair quaisquer outras informações dos registros que não tenham sido adicionadas aos componentes como parâmetros do projeto.

É possível incluir parâmetros de um banco de dados externo, independentemente do método utilizado para estabelecer o vínculo com esse banco de dados — DbLink, DbLib ou SVNDbLib.

Ao configurar o relatório da lista de materiais usando a caixa de diálogo Gerenciador de Relatórios, clique no botão Database Parameters (  Database Parameters source button, click to make linked database parameters available in the Report Manager ) na aba Colunas da caixa de diálogo para incluí-los como fonte para a BOM, conforme mostrado abaixo. Essa opção só estará disponível se um ou mais componentes do projeto estiverem vinculados a um banco de dados externo.

Na lista Colunas, o ícone Database icon, indicates that this parameter comes from the database é usado para identificar um parâmetro que existe para um ou mais componentes posicionados em um banco de dados externo vinculado. Clique no ícone de visibilidade para que ele se torne um olho ( Visibility icon ), incluindo assim essa coluna (parâmetro) na BOM.

Inclua informações adicionais dos componentes que existem apenas em um banco de dados externo.Inclua informações adicionais dos componentes que existem apenas em um banco de dados externo.

Em um projeto que inclui Variantes, os parâmetros usados para consultar o banco de dados são alterados na caixa de diálogo Gerenciamento de Variantes. Como esses valores de parâmetros existem apenas na caixa de diálogo Variant Management, eles só são usados para consultar e encontrar registros correspondentes no banco de dados quando uma BOM está sendo configurada para geração. Para isso, certifique-se de que a subopção — Include DB Parameters in Variations — esteja habilitada na aba Geral das propriedades de Report Manager.

O Altium Designer também inclui um poderoso editor de BOM, chamado ActiveBOM. O ActiveBOM oferece um conjunto completo de recursos de gerenciamento de BOM, incluindo a capacidade de adicionar itens à BOM, além de uma integração estreita com a cadeia de suprimentos de componentes.

► Saiba mais sobre o ActiveBOM

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents