Validando um componente
Antes de salvar um componente de Biblioteca do Workspace definido/editado no editor de componentes (no modo Edição de Componente Único ou Edição em Lote de Componentes) no Workspace conectado e disponibilizar o componente para uso em projetos, é essencial garantir que esse componente atenda aos requisitos de acordo com as configurações definidas. Quando você tenta salvar um componente de volta no Workspace, o editor de componentes executa uma validação – uma Component Rule Check. Esse recurso também pode ser executado manualmente, a qualquer momento, escolhendo o comando Tools » Component Rule Check nos menus principais. Certifique-se de ter salvo seu componente localmente (File » Save) antes de fazer isso.
Assim como um projeto de placa tem um processo de validação para detectar quaisquer violações, o editor de componentes tem uma funcionalidade de validação de componentes. Quaisquer violações encontradas são listadas no painel Messages.
A validação de componentes testa uma série de possíveis problemas com o componente e seus modelos definidos – tanto testes fixos quanto uma variedade de tipos de violação que podem ser definidos pelo usuário no nível global.
As seguintes verificações de validação fixas têm todas um modo de relatório de
:
Folder path not specified for component
Resumo
Essa violação ocorre quando não é especificada uma pasta no Workspace de destino onde um componente que está sendo definido no Editor de Componentes deve ser salvo.
Notificação
Uma notificação será exibida no painel Messages no seguinte formato:
Folder path not specified for component <ItemID>
onde:
- ItemID é o ID usado para o componente no Workspace.
Recomendação para Resolução
-
No Editor de Componentes no modo Edição de Componente Único, use o campo Folder na Component para especificar uma pasta no Workspace de destino onde o componente será salvo. Para especificar manualmente uma pasta de destino, clique no botão
para acessar a caixa de diálogo Choose Folder. Navegue até uma pasta existente e escolha-a, ou crie uma nova dinamicamente.
-
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo FolderPath (no grupo de colunas Component) na região de definição do componente do editor para especificar uma pasta no Workspace de destino onde o componente será salvo. Para especificar manualmente uma pasta de destino, clique uma vez dentro do campo FolderPath de um componente para revelar o botão
e clique para acessar a caixa de diálogo Choose Folder. Navegue até uma pasta existente e escolha-a, ou crie uma nova dinamicamente.
Component not having a unique Id
Resumo
Essa violação ocorre quando o ID do Item de um componente que está sendo definido no Editor de Componentes é o mesmo que o ID do Item de outro item no Workspace conectado.
Notificação
Uma notificação será exibida no painel Messages no seguinte formato:
Duplicate Component Id: "<ItemID>"
onde:
- ItemID é o ID usado para o componente no Workspace.
Recomendação para Resolução
-
No Editor de Componentes no modo Edição de Componente Único, use o campo Id na região Component para especificar outro ID que seja exclusivo para o conteúdo do Workspace conectado.
-
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Item ID no grupo de colunas Component da região de definição do componente para especificar outro ID que seja exclusivo para o conteúdo do Workspace conectado.
Observação
Essa violação normalmente ocorre quando um valor de ID de Item atribuído automaticamente a um componente é substituído manualmente. Para um novo componente criado por meio do comando File » New » Component ou do painel Components , esse campo é preenchido de acordo com o template de componente definido para o tipo de componente escolhido na caixa de diálogo Create new component dialog. Quando não existe um template, ou quando a entrada <Undefined> é escolhida na caixa de diálogo, é usado um esquema de nomenclatura padrão; CMP-{00000}. Para um novo componente criado por meio do painel Explorer , esse campo é preenchido de acordo com o esquema de nomenclatura padrão especificado para a pasta pai desse componente. Se a pasta pai tiver um template de componente anexado, então a Nomenclatura de Componentes definida será trazida desse template. O software atribuirá automaticamente o próximo ID exclusivo disponível, com base nesse esquema, após varrer todo o Workspace e os identificadores do conteúdo existente.
As verificações definidas pelo usuário são configuradas na página Data Management – Component Rule Checks da caixa de diálogo Preferences.
Qualquer um dos testes fixos que falharem ou verificações definidas pelo usuário no nível de Erro Fatal impedirão que o componente seja salvo no Workspace.
As configurações padrão das verificações definidas pelo usuário podem não ser adequadas para seus componentes, por isso é importante familiarizar-se com as opções e com a forma de configurá-las para se adequarem aos seus projetos. Informações sobre cada verificação de erro definida pelo usuário podem ser encontradas abaixo.
Violações Associadas a Componentes
Duplicate component by Name
Default report mode:
Resumo
Essa violação ocorre quando o nome de um componente que está sendo definido no Editor de Componentes é igual ao nome de um componente no Workspace conectado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Duplicate component by Name
Recomendação para Resolução
Atribua nome(s) diferentes e exclusivos ao(s) componente(s), conforme necessário.
-
No Editor de Componentes no modo Edição de Componente Único, use o campo Name na região Component para especificar outro nome que seja exclusivo para os componentes no Workspace conectado.
-
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Item ID no grupo de colunas Component da região de definição do componente para especificar outro nome que seja exclusivo para os componentes no Workspace conectado.
Duplicate component by PCL
Default report mode:
Resumo
Essa violação ocorre quando um componente que está sendo definido no Editor de Componentes possui uma Part Choice que é usada por outro componente no Workspace conectado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Duplicate component by Part Choice list
Recomendação para Resolução>Atribua Part Choice(s) diferentes e exclusivas ao(s) componente(s), conforme necessário.
-
No Editor de Componentes no modo Edição de Componente Único, use a região Part Choices para alterar a lista de Part Choices do componente para uma que seja exclusiva para os componentes no Workspace conectado.
-
No Editor de Componentes no modo Edição em Lote de Componentes, use o grupo de colunas Part Choice n da região de definição do componente para alterar a lista de Part Choices do componente para uma que seja exclusiva para os componentes no Workspace conectado.
No Editor de Componentes no modo Edição de Componente Único, use a região Part Choices para alterar a lista de Part Choices do componente para uma que seja exclusiva para os componentes no Workspace conectado.
No Editor de Componentes no modo Edição em Lote de Componentes, use o grupo de colunas Part Choice n da região de definição do componente para alterar a lista de Part Choices do componente para uma que seja exclusiva para os componentes no Workspace conectado.
Invalid pin mappings
Default report mode:
Resumo
Essa violação ocorre quando um componente que está sendo definido no Editor de Componentes possui um mapeamento ambíguo entre o símbolo do componente e o(s) footprint(s). Por exemplo, a violação ocorre se o símbolo tiver pinos definidos em seus campos Designator como 1, 2, 3, enquanto o footprint tiver pads definidos em seus campos Designator como B, C, E, ou quando o número de pinos do símbolo for maior que o número de pads do footprint.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Pin <PinDesignator> of the symbol <SymbolName> (<SymbolRevisionID>) does not have corresponding pad <PadDesignator> in footprint <FootprintName> (<FootprintRevisionID>)
onde:
-
PinDesignatoré o Designator do pino do símbolo. -
SymbolNameé o nome do símbolo. -
SymbolRevisionIDé o ID Item-Revisão do símbolo. -
PadDesignatoré o Designator do pad do footprint. -
FootprintNameé o nome do footprint. -
FootprintRevisionIDé o ID Item-Revisão do footprint.
Recomendação para Resolução
Edite o modelo atualmente adicionado ou selecione outro modelo para garantir que os pinos do símbolo tenham correspondência um-para-um com os pads do footprint.
-
No Editor de Componentes no modo Edição de Componente Único:
-
clique no controle
no canto superior direito da visualização do modelo para modificar o modelo que está sendo usado atualmente (referenciado) pelo componente no editor temporário correspondente para esse tipo de modelo;
-
clique no controle
no canto superior direito da visualização do modelo e escolha a entrada Select Model no menu para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo;
-
clique no controle
no canto superior direito da visualização do símbolo para acessar o painel Pins e alterar diretamente os destinos pad/pino mapeados clicando em uma célula do modelo e inserindo o valor necessário.
-
-
No Editor de Componentes no modo Edição em Lote de Componentes:
-
clique com o botão direito na entrada do modelo na região Model Links e escolha o comando Edit no menu de contexto para modificar o modelo que está sendo usado atualmente (referenciado) pelo componente no editor temporário correspondente para esse tipo de modelo;
-
clique no campo Item ID do modelo na região Model Links e depois clique no botão
para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo.
-
Missing Component Description
Default report mode:
Resumo
Essa violação ocorre quando a descrição de um componente que está sendo definido no Editor de Componentes não é especificada.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Component Description is not specified
Recomendação para Resolução>Especifique uma descrição para o(s) componente(s) com problema, conforme necessário.
-
No Editor de Componentes no modo Edição de Componente Único, use o campo Description na região Component para especificar uma descrição.
-
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Description no grupo de colunas Component da região de definição do componente para especificar uma descrição para o(s) componente(s) com problema.
No Editor de Componentes no modo Edição de Componente Único, use o campo Description na região Component para especificar uma descrição.
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Description no grupo de colunas Component da região de definição do componente para especificar uma descrição para o(s) componente(s) com problema.
Missing Component Name
Default report mode:
Resumo
Essa violação ocorre quando o nome de um componente que está sendo definido no Editor de Componentes não é especificado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Component Name is not specified
Recomendação para Resolução>Especifique um nome para o(s) componente(s) com problema, conforme necessário.
-
No Editor de Componentes no modo Edição de Componente Único, use o campo Name na região Component para especificar um nome.
-
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Name no grupo de colunas Component da região de definição do componente para especificar um nome para o(s) componente(s) com problema.
No Editor de Componentes no modo Edição de Componente Único, use o campo Name na região Component para especificar um nome.
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Name no grupo de colunas Component da região de definição do componente para especificar um nome para o(s) componente(s) com problema.
Missing Component Type
Default report mode:
Resumo
Essa violação ocorre quando o tipo de um componente que está sendo definido no Editor de Componentes não é especificado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Component Type is not specified
Recomendação para Resolução>Especifique um tipo para o(s) componente(s) com problema, conforme necessário.
-
No Editor de Componentes no modo Edição de Componente Único, use o campo Type na região Component para especificar um tipo.
-
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Type no grupo de colunas Component da região de definição do componente para especificar um tipo para o(s) componente(s) com problema.
No Editor de Componentes no modo Edição de Componente Único, use o campo Type na região Component para especificar um tipo.
No Editor de Componentes no modo Edição em Lote de Componentes, use o campo Type no grupo de colunas Component da região de definição do componente para especificar um tipo para o(s) componente(s) com problema.
Model revision is in Inapplicable State
Default report mode:
Resumo
Essa violação ocorre quando é detectado que um modelo vinculado que está sendo usado (referenciado) por uma definição de componente está em um estado inaplicável. Por exemplo, o modelo está atualmente Obsolete e, portanto, não deve ser usado. A aplicabilidade é determinada por meio da opção Allowed to be used in designs na caixa de diálogo State Properties. Na caixa de diálogo Edit Lifecycle Definitions, acesse essa caixa de diálogo para o estado necessário clicando duas vezes na entrada do estado dentro da definição de ciclo de vida pai ou selecionando sua entrada e clicando no ícone de edição que aparece Quando essa opção está habilitada, um modelo nesse estado pode ser usado em um componente. Ele é considerado Applicable. Se essa opção estiver desabilitada, um modelo nesse estado não pode ser usado validamente e é considerado Inapplicable (ou não aplicável).
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ModeName> (<ModelRevisionID>) revision is in inapplicable state
onde:
-
ModelNameé o nome do modelo. -
ModelRevisionIDé o ID Item-Revisão do modelo.
Recomendação para Resolução>Escolha um modelo substituto ou uma revisão do mesmo modelo que seja válida para uso no componente.
-
No Editor de Componentes no modo Edição de Componente Único, clique no controle
no canto superior direito da visualização do modelo e escolha a entrada Select Model no menu para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo.
-
No Editor de Componentes no modo Edição em Lote de Componentes, clique no campo Item ID do modelo na região Model Links e depois clique no botão
para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo.
No Editor de Componentes no modo Edição de Componente Único, clique no controle
no canto superior direito da visualização do modelo e escolha a entrada Select Model no menu para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo.
No Editor de Componentes no modo Edição em Lote de Componentes, clique no campo Item ID do modelo na região Model Links e depois clique no botão
para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo.
Model revision is Out Of Date
Default report mode:
Resumo
Essa violação ocorre quando é detectado que um modelo vinculado que está sendo usado (referenciado) por uma definição de componente está desatualizado. Se houver uma revisão mais recente do modelo disponível, o campo Revision State refletirá isso usando o texto Out of date, à direita do estado de ciclo de vida da revisão atual sob a visualização do modelo (no Editor de Componentes no modo Edição de Componente Único), ou o campo Revision Status na região Model Links será sinalizado pelo texto Out of date, exibido em negrito (no Editor de Componentes no modo Edição em Lote de Componentes).
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ModelName> (<ModelRevisionID>) revision is Out of Date
onde:
-
ModelNameé o nome do modelo. -
ModelRevisionIDé o ID Item-Revisão do modelo.
Recomendação para Resolução>Atualize os links de modelo do componente que estiverem desatualizados para usar a revisão mais recente dos modelos.
-
No Editor de Componentes no modo Edição de Componente Único, clique no controle
no canto superior direito da visualização do modelo e escolha a entrada Update to Latest no menu.
-
No Editor de Componentes no modo Edição em Lote de Componentes, clique com o botão direito em qualquer lugar da entrada do modelo na Model Links região e escolha Update to Latest Revision no menu.
No Editor de Componentes no modo Edição de Componente Único, clique no controle
no canto superior direito da visualização do modelo e escolha a entrada Update to Latest no menu.
No Editor de Componentes no modo Edição em Lote de Componentes, clique com o botão direito em qualquer lugar da entrada do modelo na Model Links região e escolha Update to Latest Revision no menu.
Number of Pads exceeds Number of Pins
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint que está sendo usado (referenciado) por uma definição de componente inclui mais pads (pads SMD colocados em camadas de cobre e pads de furo passante metalizado) do que pinos do símbolo esquemático referenciado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Number of pads in the footprint <FootprintName> (<FootprintRevisionID>) (<FootprintNumberOfPads>) exceeds number of pins in the symbol <SymbolName> (<SymbolRevisionID>) (<SymbolNumberOfPins>)
onde:
-
FootprintNameé o nome do footprint. -
FootprintRevisionIDé o ID de Item-Revisão do footprint. -
FootprintNumberOfPadsé o número de pads no footprint. -
SymbolNameé o nome do símbolo. -
SymbolRevisionIDé o ID de Item-Revisão do símbolo. -
SymbolNumberOfPinsé o número de pinos no símbolo.
Recomendação para resolução
Edite o modelo atualmente adicionado ou selecione outro modelo de símbolo/footprint para garantir que o footprint tenha um número de pads que não exceda o número de pinos do símbolo.
-
No Editor de Componentes, no modo Single Component Editing:
-
clique no controle
no canto superior direito da visualização do modelo para modificar o modelo que está sendo usado (referenciado) pelo componente no editor temporário correspondente para esse tipo de modelo;
-
clique no controle
no canto superior direito da visualização do modelo e escolha a entrada Select Model no menu para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo.
-
-
No Editor de Componentes, no modo Batch Component Editing:
-
clique com o botão direito na entrada do modelo na região Model Links e escolha o comando Edit no menu de contexto para modificar o modelo que está sendo usado (referenciado) pelo componente no editor temporário correspondente para esse tipo de modelo;
-
clique no campo Item ID do modelo na região Model Links e depois clique no botão
para procurar e escolher um modelo diferente ou uma revisão diferente desse mesmo modelo.
-
Revision that is being edited is not latest
Default report mode:
Resumo
Essa violação ocorre quando a revisão do componente que está sendo editada não é a revisão mais recente disponível no Workspace conectado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ComponentName> (<ComponentRevisionID>) revision is Out of Date
onde:
-
ComponentNameé o Name do componente. -
ComponentRevisionIDé o ID de Item-Revisão do componente.
Recomendação para resolução
Selecione a revisão mais recente do componente para edição. Para fazer isso, procure o componente no painel Components panel, clique com o botão direito em sua entrada no painel e escolha Edit.
Unrecognized combination of Manufacturer+Part Number in Part Choice
Default report mode:
Resumo
Essa violação ocorre quando uma entrada incorreta para a escolha de peça de um componente é adicionada, e a peça não pode ser recuperada pelo Workspace.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Manufacturer+Part Number combination was not found in the available Part Sources ("Part Choice <n>")
onde:
-
né o número sequencial da escolha de peça com problema.
Recomendação para resolução
Especifique uma escolha de peça válida para o(s) componente(s) com problema.
-
No Editor de Componentes, no modo Single Component Editing, remova escolhas de peça inválidas da região Part Choices e adicione novas escolhas de peça corretas.
-
No Editor de Componentes, no modo Batch Component Editing, insira valores corretos nos campos Part Choice n na região de definição do componente. Observe que, enquanto o valor de um campo de escolha de peça tiver uma entrada incorreta, o texto aparecerá esmaecido e em itálico. Quando ambas as entradas estiverem corretas, o texto aparecerá normalmente, em branco.
Violações associadas a footprints
Duplicate Pad Designator
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint vinculado a um componente que está sendo definido no Editor de Componentes tem vários objetos Pad com o mesmo valor da propriedade Designator.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Duplicate Pad Designator On Pads Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
onde:
-
Identifier1é o identificador da primeira instância do pad com designador duplicado, representado pelo pareamento rede-designador e pelas coordenadas do pad. -
Layer1é a camada na qual a primeira instância do pad com designador duplicado está colocada. -
Identifier2é o identificador da segunda instância do pad com designador duplicado, representado pelo pareamento rede-designador e pelas coordenadas do pad. -
Layer2é a camada na qual a segunda instância do pad com designador duplicado está colocada.
Recomendação para resolução
Atribua designadores diferentes e exclusivos aos pads do modelo de footprint vinculado.
-
No Editor de Componentes, no modo Single Component Editing, clique no controle
no canto superior direito da visualização do footprint.
-
No Editor de Componentes, no modo Batch Component Editing, clique com o botão direito na entrada do footprint na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de footprint que está sendo usado (referenciado) pelo componente será aberto no editor temporário de PCB Footprint. Selecione os pads com problema e altere os valores da propriedade Designator deles no modo Pad mode of the Properties panel.
Duplicate Primitives
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint vinculado a um componente que está sendo definido no Editor de Componentes tem objetos idênticos colocados na mesma posição e na mesma camada.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Duplicate Primitives: <ObjectType1> <Identifier1> on <Layer1> And <ObjectType2> <Identifier2> on <Layer2>
onde:
-
ObjectType1é o tipo da primeira instância do objeto duplicado. -
Identifier1é o identificador da primeira instância do objeto duplicado; a representação do identificador depende do tipo de objeto. -
Layer1é a camada na qual a primeira instância do objeto duplicado está colocada. -
ObjectType2é o tipo da segunda instância do objeto duplicado. -
Identifier2é o identificador da segunda instância do objeto duplicado; a representação do identificador depende do tipo de objeto. -
Layer2é a camada na qual a segunda instância do objeto duplicado está colocada.
Recomendação para resolução
Remova objetos duplicados do modelo de footprint.
-
No Editor de Componentes, no modo Single Component Editing, clique no controle
no canto superior direito da visualização do footprint.
-
No Editor de Componentes, no modo Batch Component Editing, clique com o botão direito na entrada do footprint na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de footprint que está sendo usado (referenciado) pelo componente será aberto no editor temporário de PCB Footprint. Selecione objetos duplicados e remova-os usando o atalho Delete.
Mirrored Footprint (designed on bottom layer)
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint vinculado a um componente que está sendo definido no Editor de Componentes tem primitivas significativas (pads, trilhas, arcos, preenchimentos, regiões, retângulos, cadeias de texto, objetos keepout) colocadas na Bottom Layer, mas não tem tais primitivas colocadas na Top Layer.
No editor de PCB Footprint, o footprint é construído para o lado superior da placa; ele pode ser invertido para a parte inferior durante o processo de projeto da PCB, se necessário.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Bottom Layer Component
Recomendação para resolução
Inverta as primitivas do footprint da Bottom Layer para a Top Layer.
-
No Editor de Componentes, no modo Single Component Editing, clique no controle
no canto superior direito da visualização do footprint.
-
No Editor de Componentes, no modo Batch Component Editing, clique com o botão direito na entrada do footprint na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de footprint que está sendo usado (referenciado) pelo componente será aberto no editor temporário de PCB Footprint. Selecione primitivas na Bottom Layer e altere a propriedade Layer delas no modo correspondente do painel Properties para Top Layer.
Missing Pad Designator
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint vinculado a um componente que está sendo definido no Editor de Componentes tem um objeto Pad sem valor especificado para a propriedade Designator.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Missing Pad Designator on Pad: Pad <Identifier> on <Layer>
onde:
-
Identifieré o identificador do pad sem designador especificado, representado pela rede do pad e suas coordenadas. -
Layeré a camada na qual o pad sem designador especificado está colocado.
Recomendação para resolução
Especifique valores de designador para os pads do modelo de footprint vinculado.
-
No Editor de Componentes, no modo Single Component Editing, clique no controle
no canto superior direito da visualização do footprint para abrir o footprint que está sendo usado (referenciado) pelo componente no editor temporário de PCB Footprint.
-
No Editor de Componentes, no modo Batch Component Editing, clique com o botão direito na entrada do footprint na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de footprint que está sendo usado (referenciado) pelo componente será aberto no editor temporário de PCB Footprint. Selecione um pad com problema e especifique o valor da propriedade Designator dele no modo Pad mode of the Properties panel.
Offset Footprint Reference
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint vinculado a um componente que está sendo definido no Editor de Componentes tem seu ponto de referência (origem) fora do retângulo delimitador formado pelos objetos do footprint.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Offset Component Origin
Recomendação para resolução
Altere a localização do ponto de referência para que ele fique dentro do retângulo delimitador formado pelos objetos do footprint.
-
No Editor de Componentes, no modo Single Component Editing, clique no controle
no canto superior direito da visualização do footprint para abrir o footprint que está sendo usado (referenciado) pelo componente no editor temporário de PCB Footprint.
-
No Editor de Componentes, no modo Batch Component Editing, clique com o botão direito na entrada do footprint na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de footprint que está sendo usado (referenciado) pelo componente será aberto no editor temporário de PCB Footprint. Use os comandos do submenu Edit » Set Reference dos menus principais para alterar a localização atual da referência do footprint.
Shorted Copper
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint vinculado a um componente que está sendo definido no Editor de Componentes tem objetos Pad que estão conectados entre si por objetos em uma camada de cobre.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Shorted Copper Connection Between Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
onde:
-
Identifier1é o identificador da primeira instância do pad no par de pads em curto, representado pelo pareamento rede-designador e pelas coordenadas do pad. -
Layer1é a camada na qual a primeira instância do pad no par de pads em curto está colocada. -
Identifier2é o identificador da segunda instância do pad no par de pads em curto, representado pelo pareamento rede-designador e pelas coordenadas do pad. -
Layer2é a camada na qual a segunda instância do pad no par de pads em curto está colocada.
Recomendação para resolução
Remova os objetos da camada de cobre que conectam os pads do modelo de footprint vinculado.
-
No Editor de Componentes, no modo Single Component Editing, clique no controle
no canto superior direito da visualização do footprint.
-
No Editor de Componentes, no modo Batch Component Editing, clique com o botão direito na entrada do footprint na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de footprint que está sendo usado (referenciado) pelo componente será aberto no editor temporário de PCB Footprint. Selecione os objetos da camada de cobre que conectam os pads, depois altere-os para que não conectem os pads ou remova esses objetos.
Unconnected Copper
Default report mode:
Resumo
Essa violação ocorre quando um modelo de footprint vinculado a um componente que está sendo definido no Editor de Componentes tem objetos em uma camada de cobre, e esses objetos não estão conectados a nenhum objeto Pad. Quando esse footprint for colocado em um projeto de PCB, uma rede não será atribuída a esses objetos da camada de cobre, e eles se tornarão cobre morto.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Unconnected Copper on primitive : <ObjectType> <Identifier> on <Layer>
onde:
-
ObjectTypeé o tipo da instância do objeto que não está conectado a nenhum objeto Pad no modelo de footprint. -
Identifieré o identificador do objeto que não está conectado a nenhum objeto Pad no modelo de footprint; a representação do identificador depende do tipo de objeto. -
Layeré a camada na qual a instância do objeto que não está conectada a nenhum objeto Pad no modelo de footprint está colocada.
Recomendação para resolução
Altere o modelo de footprint para que os objetos que atualmente não estão conectados a nenhum objeto Pad no modelo de footprint sejam conectados aos pads.
-
No Editor de Componentes, no modo Single Component Editing, clique no controle
no canto superior direito da visualização do footprint.
-
No Editor de Componentes, no modo Batch Component Editing, clique com o botão direito na entrada do footprint na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de footprint que está sendo usado (referenciado) pelo componente será aberto no editor temporário de PCB Footprint. Coloque objetos na(s) camada(s) de cobre para formar uma conexão entre os pads do footprint e os objetos que atualmente não estão conectados a nenhum objeto Pad, ou remova esses objetos desconectados.
Violações associadas a símbolos
Different pins between modes
Default report mode:
Resumo
Esta violação ocorre quando um dos modos de exibição de um símbolo tem um pino extra.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Extra Pin in display mode <DisplayMode> of the symbol <SymbolRevisionID>. Part <PartDesignator>. Pin Name "<PinName>"
onde:
-
DisplayModeé o modo específico de representação gráfica do símbolo no qual o(s) pino(s) extra foi(ram) encontrado(s). Um símbolo tem um modo Normal e pode ter até 255 modos Alternate definidos. Saiba mais sobre creating multiple graphical display modes of the same component symbol. -
SymbolRevisionIDé o ID Item-Revisão do símbolo. -
PartDesignatoré o Designator da parte do símbolo. -
PinNameé o Name do pino problemático.
Recomendação para resolução
Esta violação normalmente surge quando um modo gráfico alternativo é definido para um símbolo e:
- Um pino extra foi adicionado a um modo de exibição que não está especificado em outro modo de exibição, ou
- Um pino foi especificado com um Designator e/ou Name diferentes de um pino especificado em outro modo de exibição.
Não apenas deve haver um número idêntico de pinos entre os modos de exibição gráfica, como os pinos também devem ser idênticos em Designator e Name. Saiba mais sobre creating multiple graphical display modes of the same component symbol.
Altere o Designator e/ou Name do(s) pino(s) problemático(s) para que o número de pinos e suas propriedades Designator e Name sejam os mesmos entre os modos de exibição do símbolo, ou remova um pino extra de um modo de exibição.
-
No Component Editor, no modo Single Component Editing mode, clique no controle
no canto superior direito da visualização do símbolo.
-
No Component Editor, no modo Batch Component Editing mode, clique com o botão direito na entrada do símbolo na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de símbolo que está sendo usado (referenciado) no momento pelo componente será aberto no editor temporário de biblioteca esquemática. Selecione os pinos problemáticos e altere os valores de sua propriedade Designator e/ou Name no Pin mode of the Properties panel, ou remova esses pinos usando o atalho Delete.
Duplicate Pin Designators
Default report mode:
Resumo
Esta violação ocorre quando dois ou mais pinos no modelo de símbolo do componente têm o mesmo designador.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Duplicate Pin Designator(s) (mode <DisplayMode>): <PinDesignatorList>
onde:
-
DisplayModeé o modo específico de representação gráfica do símbolo no qual o(s) pino(s) duplicado(s) foi(ram) encontrado(s). Um símbolo tem um modo Normal e pode ter até 255 modos Alternate definidos. -
PinDesignatorListé a lista separada por vírgulas dos designadores de pino que estão duplicados no símbolo problemático.
Recomendação para resolução
Altere o designador do(s) pino(s) problemático(s) conforme apropriado, para que cada um tenha uma atribuição exclusiva.
-
No Component Editor, no modo Single Component Editing mode, clique no controle
no canto superior direito da visualização do símbolo.
-
No Component Editor, no modo Batch Component Editing mode, clique com o botão direito na entrada do símbolo na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de símbolo que está sendo usado (referenciado) no momento pelo componente será aberto no editor temporário de biblioteca esquemática. Selecione os pinos problemáticos e altere os valores de sua propriedade Designator no Pin mode of the Properties panel, ou remova esses pinos usando o atalho Delete.
Missing Default Designator
Default report mode:
Resumo
Esta violação ocorre quando o modelo de símbolo do componente não tem designador padrão especificado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Missing Default Designator
Recomendação para resolução
Especifique um designador padrão para o modelo de símbolo problemático.
-
No Component Editor, no modo Single Component Editing mode, clique no controle
no canto superior direito da visualização do símbolo.
-
No Component Editor, no modo Batch Component Editing mode, clique com o botão direito na entrada do símbolo na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de símbolo que está sendo usado (referenciado) no momento pelo componente será aberto no editor temporário de biblioteca esquemática. Abra o Symbol mode of the Properties panel (ativo quando nenhum objeto está selecionado no espaço de projeto) e especifique o prefixo de designador necessário seguido pelo caractere '?' no campo Designator (por exemplo, C?). Os pontos de interrogação nos designadores dos componentes colocados em uma folha esquemática serão atualizados com números reais durante o processo de Design Annotation.
Missing Pin Designator
Default report mode:
Resumo
Esta violação ocorre quando um pino no modelo de símbolo do componente não tem designador especificado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Missing Pin Designator of the symbol <SymbolRevisionID>
onde:
-
SymbolRevisionIDé o ID Item-Revisão do símbolo problemático.
Recomendação para resolução
Especifique um designador para cada pino no modelo de símbolo problemático.
-
No Component Editor, no modo Single Component Editing mode, clique no controle
no canto superior direito da visualização do símbolo.
-
No Component Editor, no modo Batch Component Editing mode, clique com o botão direito na entrada do símbolo na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de símbolo que está sendo usado (referenciado) no momento pelo componente será aberto no editor temporário de biblioteca esquemática. Selecione os pinos problemáticos e especifique os valores de sua propriedade Designator no Pin mode of the Properties panel, ou remova os pinos usando o atalho Delete.
Missing Pin Name
Default report mode:
Resumo
Esta violação ocorre quando um pino no modelo de símbolo do componente não tem nome especificado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Missing Pin Name of the symbol <SymbolRevisionID>. Pin Designator "<PinDesignator>".
onde:
-
SymbolRevisionIDé o ID Item-Revisão do símbolo problemático. -
PinDesignatoré o Designator do pino problemático.
Recomendação para resolução
Especifique um nome para cada pino no modelo de símbolo problemático.
-
No Component Editor, no modo Single Component Editing mode, clique no controle
no canto superior direito da visualização do símbolo.
-
No Component Editor, no modo Batch Component Editing mode, clique com o botão direito na entrada do símbolo na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de símbolo que está sendo usado (referenciado) no momento pelo componente será aberto no editor temporário de biblioteca esquemática. Selecione os pinos problemáticos e especifique os valores de sua propriedade Name no Pin mode of the Properties panel, ou remova esses pinos usando o atalho Delete.
Nota
Apenas uma instância de violação será listada no painel Messages para cada componente distinto. Um componente pode muito bem ter um símbolo com mais de um pino sem nome definido.
Missing Pins in Sequence
Default report mode:
Resumo
Esta violação ocorre quando pinos ausentes são detectados na sequência numérica dos valores de designador de pino do símbolo problemático. Por exemplo, se o símbolo tiver pinos com designadores 1, 2, 5, e não houver pinos com designador 3 e 4.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Missing Pin Designator In Sequence : <PinDesignatorList> [<LowerPinDesignator>..<UpperPinDesignator>]
onde:
-
PinDesignatorListé a lista separada por vírgulas dos designadores de pino ausentes na sequência numérica detectada no símbolo problemático. -
LowerPinDesignatoré o valor numérico mínimo dos designadores de pino detectados no símbolo problemático. -
UpperPinDesignatoré o valor numérico máximo dos designadores de pino detectados no símbolo problemático.
Recomendação para resolução
No modelo de símbolo problemático, adicione pinos com os designadores de pino ausentes na sequência ou altere os designadores de pino para que formem uma sequência contínua de valores inteiros.
-
No Component Editor, no modo Single Component Editing mode, clique no controle
no canto superior direito da visualização do símbolo.
-
No Editor de Componentes no modo Batch Component Editing mode, clique com o botão direito na entrada do símbolo na região Model Links e escolha o comando Edit no menu de contexto.
O modelo de símbolo que está sendo usado no momento (referenciado) pelo componente será aberto no editor temporário da Biblioteca Esquemática. Usando o comando Place » Pin dos menus principais, adicione o número necessário de pinos e especifique os valores da propriedade Designator no modo Pin do painel Properties para que os designadores dos pinos no símbolo formem uma sequência contínua de valores inteiros. Você também pode editar a propriedade Designator dos pinos já posicionados no símbolo.
Nota
Há componentes que não usam numeração sequencial de pinos, por exemplo, um BGA com numeração de pinos não sequencial; A1, A3, A5 (e assim por diante). Nessa situação, sugere-se liberar o componente com essa violação e registrar o motivo nas Notas de Liberação. Como alternativa, defina a verificação Missing Pins in Sequence na página Data Management – Component Rule Checks da caixa de diálogo Preferences como No Report.


