Vinculação a Dados da Cadeia de Suprimentos para Bibliotecas de Componentes Baseadas em Banco de Dados e em Arquivos

Num relance

Acesse informações de fornecedores em tempo real enquanto projeta com bibliotecas de componentes baseadas em banco de dados e em arquivos no Altium Designer. Este artigo apresenta o acesso a dados de fornecedores nos fluxos de trabalho com SchLib, DbLib e SVNDbLib, explica como configurar as preferências de fornecedores e explora o painel Pesquisa de peças de fabricantes para encontrar peças e consultar informações sobre preços, estoque e ciclo de vida. Continue lendo para tomar decisões mais bem fundamentadas sobre o fornecimento de componentes no seu fluxo de trabalho de projeto.

- Configure fornecedores preferenciais, regiões geográficas e moedas para as pesquisas de peças.
- Use palavras-chave, categorias e filtros paramétricos para encontrar peças de fabricantes adequadas.
- Consulte preços de fornecedores, disponibilidade e detalhes dos componentes para apoiar a seleção e a aquisição.
Aprofunde-se com a IA:

O Altium Designer facilita a vinculação dos componentes do seu projeto a peças reais, permitindo que você acesse dados atualizados de fornecedores enquanto projeta. Por meio de uma conexão direta com os serviços web de dados de componentes da Altium, você pode pesquisar peças de fabricantes e selecionar entre os fornecedores compatíveis que oferecem essas peças. Esses dados atualizados dos fornecedores podem então ser integrados ao processo de projeto — no desenvolvimento da biblioteca, durante o projeto e na liberação do projeto. Em resumo, esse recurso permite acessar bancos de dados de fornecedores de dentro do Altium Designer, pesquisando e selecionando componentes de fabricantes para o projeto.

Os dados vinculados da peça e do fornecedor também serão incluídos ou poderão ser adicionados na liberação do projeto em uma lista de materiais — algo especialmente útil para calcular os custos do projeto e realizar compras.

A vinculação a dados de fornecedores not exige que você esteja conectado à sua conta Altium. As pesquisas de peças de fabricantes e fornecedores são realizadas por meio dos serviços web da Altium. No entanto, ao exibir informações de preços em outras moedas, as taxas de câmbio para conversão monetária são atualizadas diariamente, desde que você are conectado à sua conta.

Este documento aborda a vinculação a dados de fornecedores para metodologias de gerenciamento de componentes que utilizam SchLib, DbLib ou SVNDbLib como base para o armazenamento de componentes. Se você estiver usando um Workspace conectado — e Componentes do Workspace —, um vínculo semelhante, mas distinto e mais avançado, entre o componente de projeto e a cadeia de suprimentos é estabelecido por meio do conceito de opções de peças. Quando o recurso Custom Parts Provider Synchronization está habilitado no Altium Designer (consulte a página Installing & Managing (Altium Designer Develop, Altium Designer Agile, Altium Designer) para obter mais informações sobre como alterar as funcionalidades principais instaladas), um Workspace conectado fornece uma interface para qualquer conexão com banco de dados de peças configurada no Workspace, como um vínculo com o banco de dados interno de peças de uma empresa (diretamente ou por meio de uma interface ODBC ou OLE-DB). Você precisa estar conectado ao Workspace para acessar esses dados de componentes. Portanto, essa funcionalidade não está disponível nem se aplica à vinculação a dados de fornecedores em metodologias de gerenciamento de componentes baseadas em arquivos.

Consulte Configuração de fontes de peças para obter mais informações sobre a configuração centralizada de fornecedores como parte de uma instalação do Altium On-Prem Enterprise Server, incluindo a configuração de uma interface com um banco de dados de peças.

Preferências de fornecedores

A página Gerenciamento de dados – Provedores de peças da caixa de diálogo Preferences é a central de configuração dos fornecedores que estarão disponíveis nas pesquisas de dados de peças, além de outras opções relacionadas à vinculação a dados de fornecedores.

Configure as opções relacionadas ao recurso de vinculação a dados de fornecedores como parte das suas preferências do Altium Designer.
Configure as opções relacionadas ao recurso de vinculação a dados de fornecedores como parte das suas preferências do Altium Designer.

Use a seção Altium Parts Options da página para configurar o serviço de acordo com suas necessidades.

As opções incluem:

  • Location – habilite as regiões geográficas das quais o serviço de peças coletará dados. Embora muitos fornecedores atuem em várias regiões, se uma peça estiver disponível exclusivamente em um local específico, ela só será listada se essa região estiver habilitada. Arraste e solte as entradas de localização na lista para definir sua ordem de prioridade de uso.

  • Currency – habilite as moedas internacionais que estarão disponíveis para seleção ao pesquisar peças e examinar os resultados. Arraste e solte os ícones de moedas na lista para definir sua ordem de prioridade de uso.

  • Supplier – habilite os fornecedores a serem incluídos nas pesquisas de dados de fornecedores. Serão retornados apenas resultados de peças desses fornecedores. Ao incluir mais fornecedores para uso com o recurso, você poderá comparar e encontrar as melhores ofertas para os componentes necessários ao seu projeto. Um fornecedor associado a um símbolo na coluna Verified indica que o Altium Parts Provider recebe dados diretamente desse fornecedor.

Observe que, se você estiver conectado a um servidor, a região Altium Parts Options se tornará somente leitura e adotará as configurações definidas pelo servidor. Isso é indicado pela presença do ícone ao lado do nome da página na árvore de navegação.

Pesquisa de dados de fornecedores de componentes

A principal interface de acesso às peças de fabricantes disponíveis e aos respectivos dados atualizados de fornecedores é o painel Pesquisa de peças de fabricantes. Com recursos avançados de pesquisa e localização de peças baseados em categorias e filtragem paramétrica, o painel também funciona como um portal direto para peças reais oferecidas pelos vários fornecedores que você habilitou para o recurso. Acesse esse painel selecionando View » Panels » Manufacturer Part Search no menu principal ou a opção Manufacturer Part Search no menu do botão , no canto inferior direito da tela principal.

Pesquise itens reais de fornecedores por meio do painel Manufacturer Part Search.Pesquise itens reais de fornecedores por meio do painel Manufacturer Part Search.

Conforme ilustrado, o painel é dividido essencialmente em três seções funcionais:

  • Component Search, Type and Filtering:
    • No campo Search superior, insira uma ou mais palavras-chave relacionadas à peça do componente. Os resultados retornados incluem vínculos de fornecedores para cada peça de fabricante listada.
    • Use a lista suspensa Categories () para restringir os resultados ao tipo de componente selecionado.
    • Marque as opções de parâmetros relevantes no painel Filters à esquerda (habilitado com o ícone ) para filtrar os resultados e exibir os componentes que atendem aos valores desses parâmetros.
Todas as funções acima podem ser usadas em conjunto para localizar com rapidez e precisão as peças de componentes necessárias e, por associação, os dados atualizados dos fornecedores disponíveis para essas peças.
  • Search Results:
    • Esta região central do painel é preenchida com todas as peças de fabricantes que correspondem aos critérios atuais de pesquisa, categoria e filtro. A coluna Supply Info apresenta um resumo dos dados de fornecimento de cada entrada, com base no preço unitário, na quantidade mínima de pedido (MOQ) e no estoque disponível do fornecedor mais adequado. A faixa colorida associada a cada peça de fabricante fornece uma indicação rápida do seu status de ciclo de vida — por exemplo, verde indica que a peça é adequada para produção em volume, enquanto uma faixa vermelha sinaliza uma peça considerada obsoleta.
    • Uma entrada de peça selecionada inclui um vínculo para dados de fornecedores na coluna Manufacturer Part (por exemplo, 9 SPNs), que abre uma lista horizontal de blocos de opções de fornecedores para essa peça de fabricante. Cada bloco dessa lista corresponde a um fornecedor específico e apresenta um resumo do nível de estoque atual, dos preços e do código da peça no fornecedor. Consulte Vinculação a um item de fornecedor abaixo para obter informações sobre como esses dados são aplicados aos componentes do projeto.
    • As configurações de opções do painel, disponíveis em  botão no canto superior direito do painel, configure como os dados dos resultados da pesquisa são exibidos:
      • Currency menu – A moeda usada nas informações de preços do painel é determinada pela configuração de prioridade de moeda na página Gerenciamento de dados – Provedores de peças. Para alterar rapidamente a configuração atual do painel, selecione outra moeda neste menu suspenso.

      • Exclude Invalid SPNs opção – Ative esta opção para remover o link de dados do fornecedor na coluna Manufacturer Part das entradas em que os dados do fornecedor para essa peça sejam inadequados para uso (inválidos), como quando não há informações de preço ou estoque disponíveis.

      • Preferências dos provedores de peças link – Fornece acesso direto à página Gerenciamento de dados – Provedores de peças Preferences. Somente os fornecedores habilitados na página de preferências serão incluídos na lista de fornecedores/distribuidores de uma peça do fabricante.

  • Component Details:
    • O painel Details (aberto com o botão no canto superior direito) mostra todos os dados disponíveis para o componente selecionado, incluindo seus parâmetros, modelos, folhas de dados e links para informações de fornecedores na web.
    • O painel também inclui opções de download para visualizar/salvar as especificações da peça do fabricante () ou salvar o próprio componente localmente () das seguintes formas:
      • Salvando o componente no Workspace Altium conectado no momento, ou
      • Baixando o componente como uma biblioteca de arquivos compactada em ZIP, ou 
      • Posicionando o componente na folha de esquemático ativa.

► Consulte a página Pesquisa de peças de fabricantes para obter informações detalhadas sobre seus recursos e sua aplicação.

Visualização e edição de links de fornecedores

Os links de fornecedores atualmente definidos para um componente de biblioteca ou para um componente inserido em uma folha de esquemático podem ser visualizados e editados usando a caixa de diálogo Supplier Links for. Para acessar essa caixa de diálogo:

  • For a schematic library component – clique com o botão direito em qualquer lugar da área de projeto e escolha o comando Supplier Links no menu de contexto.
  • For a Database library / SVN Database Library component – clique com o botão direito na entrada de um componente na guia Table Browser do arquivo DbLib/SVNDbLib correspondente e escolha o comando Edit Supplier Links no menu de contexto.
  • For a placed component on a schematic sheet – clique com o botão direito no componente e escolha o comando Supplier Links no menu de contexto.

Após executar o comando, a caixa de diálogo Supplier Links for será aberta. Ela lista todos os links atualmente definidos para o componente. Se houver várias peças de fabricantes disponíveis — ou seja, várias soluções —, as soluções serão classificadas automaticamente da melhor para a pior, com base na disponibilidade, no preço e no estado do ciclo de vida da peça informado pelo fabricante. A peça do fabricante é mostrada à esquerda, com os detalhes do fornecedor disponível selecionado à direita.

A caixa de diálogo Supplier Links for
A caixa de diálogo Supplier Links for

Todos os links de fornecedores atualmente definidos para um componente de biblioteca de esquemáticos também podem ser visualizados e editados diretamente no painel Properties do componente selecionado. Os links de fornecedores definidos para o componente selecionado são mostrados na região Part Choices do painel. Os dados detalhados do link de fornecedor selecionado estão disponíveis por meio do link clicável no bloco do fornecedor (conforme mostrado abaixo) ou pesquisando pelo valor do parâmetro Supplier Part Number 1 desse componente no painel Manufacturer Part Search.

Para adicionar outro link de fornecedor, clique no botão na parte inferior da região Part Choices. A caixa de diálogo Supplier Links for será aberta; clique no botão  para abrir a caixa de diálogo Add Supplier Links, que pode ser usada para pesquisar e adicionar outros links ao item desejado. Use o botão na caixa de diálogo Add Supplier Links para remover o link de fornecedor selecionado do componente de biblioteca.

A caixa de diálogo Add Supplier Links oferece um recurso de pesquisa baseado em categorias e filtragem paramétrica semelhante ao do painel Manufacturer Part Search . Consulte essa página para obter mais detalhes.

Muitos fornecedores oferecem descontos para pedidos em grandes quantidades. Clique no link Show more no bloco de SPN para visualizar diferentes preços unitários com base na quantidade pedida ao fornecedor. (Você pode então clicar no link Show less para recolher a lista de preços por quantidade.)

Personalização do processo de pesquisa – Palavras-chave sugeridas

Quando a caixa de diálogo Adicionar links de fornecedores é usada para localizar e selecionar dados adequados de fornecedores de componentes, o software realiza automaticamente uma pesquisa de peças do fabricante com base nos dados de parâmetros extraídos do componente de destino. A expressão de pesquisa usada pelo software é definida na área Suggested Keywords da página Gerenciamento de dados – Provedores de peças da caixa de diálogo Preferences, que permite configurar a expressão de pesquisa aplicada para se adequar à estrutura da sua biblioteca de componentes. Você tem controle total sobre quais parâmetros das peças são usados como palavras-chave de pesquisa e em que ordem.

Palavras-chave sugeridas padrão usadas ao pesquisar peças automaticamente nos bancos de dados dos fornecedores.Palavras-chave sugeridas padrão usadas ao pesquisar peças automaticamente nos bancos de dados dos fornecedores.

Na área Suggested Keywords da caixa de diálogo, as atribuições de prioridade padrão (com a prioridade mais alta no topo da lista) significam que, por padrão, o valor de Comment será usado primeiro como critério de pesquisa. Se o componente de origem não tiver um comentário, a próxima tentativa usará seu valor de Description. Se este também estiver em branco, será usado o Name do componente.

Você pode incluir seus próprios parâmetros de palavras-chave conforme necessário clicando no botão Add . Isso adicionará uma nova entrada de parâmetro (com o nome padrão Parameter Name) ao final da lista (atribuindo a ela, portanto, a prioridade mais baixa), com o novo parâmetro automaticamente em foco e pronto para ter seu nome alterado. Para modificar o nome de um parâmetro existente, clique uma vez no campo de nome para colocá-lo em foco e, em seguida, insira o novo nome conforme necessário. Como alternativa, selecione um parâmetro clicando no campo de prioridade associado e, em seguida, clique no botão Edit .

Clique em qualquer lugar da coluna Priority para efetivar a alteração do nome. Você também pode pressionar Enter, mas lembre-se de que isso confirmará a alteração e fechará a caixa de diálogo Preferences .

Use os botões Move Up ou Move Down para mover o parâmetro selecionado para cima ou para baixo na lista, respectivamente, aumentando ou diminuindo o valor de Priority atribuído a ele.

Exemplo de parâmetro de palavra-chave sugerida definido pelo usuário, adicionado e configurado com a prioridade mais alta.Exemplo de parâmetro de palavra-chave sugerida definido pelo usuário, adicionado e configurado com a prioridade mais alta.

Embora os parâmetros padrão possam ser editados ou até mesmo removidos, eles podem ser restaurados pela lista suspensa associada a uma entrada de parâmetro.

Quantidade e preços

Os fornecedores normalmente têm preços diferentes com base na quantidade de um item a ser comprada. As quantidades necessárias para obter preços unitários progressivamente menores variam não apenas entre fornecedores, mas também entre os itens de um mesmo fornecedor. Ao selecionar dados de fornecedores de peças do fabricante no painel Pesquisa de peças do fabricante, um resumo dessas informações fica disponível no bloco do fornecedor da peça ao selecionar o link Show more. Isso permite tomar uma decisão informada sobre preços (e estoque) ao escolher um link de fornecedor, com base nos dados atuais.

Os preços e os níveis de estoque dos fornecedores variam. Lembre-se de que há um atraso na atualização das informações dos fornecedores no banco de dados do serviço agregador fornecido pelo Altium Parts Provider. Passe o mouse sobre o símbolo em um bloco de fornecedor para ver quando as informações foram atualizadas pela última vez.

Os links de fornecedores adicionados a um componente de biblioteca também oferecem informações detalhadas de preço por quantidade na área Part Choices do painel Properties, para o componente de biblioteca selecionado. 

Exemplo de Unit Price exibido com base em Order Quantity especificado, em que o pedido de 100 unidades reduz o preço de 0,1 USD para 0,018 USD por capacitor. Exemplo de Unit Price exibido com base em Order Quantity especificado, em que o pedido de 100 unidades reduz o preço de 0,1 USD para 0,018 USD por capacitor.

Conversão de moeda

Diferentes fornecedores operam em diferentes regiões do mundo, muitas vezes em várias delas, e, por isso, é comum que os preços dos produtos sejam apresentados em moedas diferentes. O Altium Designer permite converter a exibição dessas informações de preços para uma das várias moedas compatíveis.

Para exibir rapidamente todas as informações de preços em uma única moeda no painel Pesquisa de peças do fabricante, selecione a moeda desejada no menu suspenso Currency, disponível no botão do painel. Para exibir os preços na moeda padrão usada por um fornecedor, escolha a entrada None do menu.

A conversão de moedas é realizada usando as taxas de câmbio aplicáveis. Essas taxas são atualizadas diariamente (a cada 24 horas), mas você precisa estar conectado à sua conta Altium para que as taxas de conversão atuais sejam aplicadas.

Para definir as preferências de uso de moedas no Altium Designer, habilite/desabilite as moedas e defina sua prioridade na página Gerenciamento de dados – Provedores de peças da caixa de diálogo Preferences.

► Consulte Preferências de fornecedores acima para obter mais informações.

Importação de parâmetros específicos

Parâmetros específicos de fabricantes/fornecedores podem ser importados do painel Pesquisa de peças de fabricantes para um componente de biblioteca ou um componente posicionado usando o comando Add Parameter(s) To, disponível na seção Details do painel, aberta pelo botão .

Para isso, selecione uma peça de fabricante ou uma de suas subentradas de fornecedor na lista de resultados de pesquisa do painel e, em seguida, as entradas de parâmetros desejadas na seção Details do painel. Clique com o botão direito em uma entrada de parâmetro selecionada (destacada) e escolha a opção de comando Add Parameter(s) To para propagar os parâmetros para o componente de destino.

  • Para um componente de biblioteca, o destino é a entrada selecionada no painel Biblioteca SCH ou (para uma biblioteca de banco de dados) o Table Browser da DBLib.

  • Para um componente posicionado, o destino é selecionado no Editor de esquemáticos usando o cursor em cruz.

Os pontos importantes sobre a propagação de pares parâmetro-valor são:

  • Se o parâmetro já existir no componente de destino, seu valor será atualizado – consulte Voltage Rating nas imagens de exemplo acima.

  • Se o parâmetro ainda não existir, o par parâmetro-valor importado será adicionado ao componente de destino – Tolerance e Material na imagem acima.

  • O processo seguirá as configurações da região Parameter Import Options da página Gerenciamento de dados – Provedores de peças da caixa de diálogo Preferences. Por exemplo, se Capacitance estiver mapeado para Value, o segundo parâmetro será adicionado como um valor de capacitância ao componente de destino – Value 1nF.

  • Parâmetros de fornecedores, como Stock e Pricing, ficam disponíveis na seção Details do painel Manufacturer Part Search somente quando um bloco de fornecedor (em vez da peça de fabricante) é selecionado como origem.

  • Assim como ocorre com outros parâmetros, os dados de fornecedor adicionados irão update os parâmetros de fornecedor existentes no componente de destino. O sufixo dos dados de fornecedor permanece em 1, e adições subsequentes não incrementam o valor do sufixo.

Inclusão de dados de fornecedores em uma lista de materiais

Os links de dados de fornecedores adicionados aos componentes de um projeto, ou os links inerentes a um componente posicionado a partir de uma biblioteca, são salvos com o projeto e ficam disponíveis para inclusão em uma Bill of Materials (BOM).

Relatório de BOM

No nível mais básico, os links de fornecedores dos componentes ficam disponíveis em um relatório de BOM gerado a partir dos documentos de origem do projeto. Selecione Reports » Bill of Materials para abrir a caixa de diálogo Lista de materiais do projeto, que pode ser configurada conforme suas necessidades e gerada em diversos formatos (Excel, PDF, HTML etc.). O relatório de BOM também pode ser incluído como uma saída de relatório em uma tarefa de saída do projeto.

► Consulte Configuração da BOM no Gerenciador de relatórios para obter informações detalhadas.

Um relatório de BOM simples exibirá os parâmetros de dados de fornecedores dos componentes que incluem links de fornecedores.Um relatório de BOM simples exibirá os parâmetros de dados de fornecedores dos componentes que incluem links de fornecedores.

Um relatório de BOM extrairá os dados de links de fornecedores de um documento ActiveBOM (veja abaixo), caso exista no projeto, em vez de extraí-los dos documentos de projeto.

Documento ActiveBOM

A abordagem muito mais avançada e recomendada para gerenciar links de fabricantes e fornecedores na lista de materiais de um projeto é incluir um documento ActiveBOM no projeto – File » New » ActiveBOM Document. Observe que todos os benefícios dessa abordagem são obtidos ao usar componentes de biblioteca do Workspace.

► Consulte Gerenciamento de BOM com o ActiveBOM para obter informações detalhadas.

O ActiveBOM usa dados de componentes Solutions para adicionar um conjunto abrangente de informações atualizadas sobre peças, como detalhes da peça do fabricante (incluindo o status do ciclo de vida), preços de fornecedores e níveis de estoque.

Os links de fornecedores existentes nos componentes, adicionados anteriormente no nível da biblioteca ou do documento esquemático, são convertidos automaticamente em soluções do ActiveBOM. Observe que essas soluções continuarão exibindo apenas o único fornecedor adicionado quando você definiu o link de fornecedor, mesmo que a peça desse fabricante esteja disponível em vários fornecedores.

O próximo passo além das soluções de BOM derivadas de links de fornecedores existentes, adicionados aos componentes na biblioteca ou no esquemático, é adicionar novas soluções de componentes na interface do ActiveBOM.

As soluções nativas do ActiveBOM, centradas no fabricante, oferecem mapeamento avançado de dados entre o componente de projeto e a peça do fabricante, além de all of the approved Suppliers dessa peça. Os dados da solução em tempo real ficam disponíveis durante todo o processo de projeto e tornam-se a fonte de todas as saídas do tipo BOM.

Você pode não apenas ter vários fornecedores de uma peça específica de fabricante associados ao seu componente de projeto (solução), como também associar várias peças de fabricantes a essa solução. Se a associação DesignPart - ManufacturerPart for armazenada como parte do componente de projeto no seu Workspace, a abordagem será denominada Part Choices; se a associação for armazenada no documento ActiveBOM (BomDoc), será denominada Manufacturer Links.

Essa abordagem poderosa significa que o componente de projeto não precisa armazenar nenhuma informação sobre fornecedores ou códigos de peças de fornecedores. 

► Saiba mais sobre Adição de informações da cadeia de suprimentos a um componente no Altium Designer.

Se o seu projeto não usar componentes do Workspace, use a opção Create/Edit Manufacturer Links do menu do botão para adicionar uma solução do ActiveBOM à entrada de componente atualmente selecionada. Selecione o botão na caixa de diálogo Edit Manufacturer Links que aparece em seguida e, depois, uma entrada de componente de fabricante adequada na caixa de diálogo Add Part Choices. Após a confirmação (OK), esse link de peça será adicionado como uma nova entrada na caixa de diálogo Edit Manufacturer Links.

Após confirmar a adição na caixa de diálogo (), a solução do ActiveBOM será adicionada à entrada do componente na BOM. Observe que, nesse caso, a solução inclui a lista completa de opções de fornecedores, na qual a opção selecionada (em verde) é designada como a “Melhor” solução de fornecedor para a peça do fabricante.

Use o painel Propriedades associado para configurar os recursos do ActiveBOM, como a moeda aplicada, a fonte de dados dos links de fabricantes, as colunas de dados visíveis, os agrupamentos de itens da BOM, os avisos de verificação da BOM etc.

► Consulte Gerenciamento de BOM com o ActiveBOM para obter mais informações.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents