Criando um Footprint de PCB

A área que o componente ocupa na placa fabricada é definida pelo footprint do componente. Um footprint típico inclui pads e uma serigrafia do componente, podendo também incluir quaisquer outros detalhes mecânicos necessários. No exemplo de footprint abaixo, a maior parte do contorno do componente é definida em uma camada mecânica (as linhas verdes), em vez da serigrafia (amarela), pois esse componente será montado de modo que fique sobre um recorte na placa.

O footprint define o espaço que o componente ocupa e fornece os pontos de conexão entre os pinos/pads do componente e o roteamento na placa. 
O footprint define o espaço que o componente ocupa e fornece os pontos de conexão entre os pinos/pads do componente e o roteamento na placa.

O componente montado nesse footprint pode ser modelado usando objetos Corpo 3D. O objeto Corpo 3D é usado como um contêiner para importar um modelo em formato MCAD genérico, conforme mostrado na imagem abaixo.

Um modelo MCAD adequado pode ser importado para um objeto Corpo 3D.
Um modelo MCAD adequado pode ser importado para um objeto Corpo 3D.

Mesmo com um amplo conjunto de recursos que fornecem componentes de PCB prontos (como o painel de pesquisa de peças de fabricantes), é provável que, em algum momento da sua carreira, você precise criar um componente de PCB personalizado. Os footprints de componentes de PCB são criados no editor de footprints de PCB usando o mesmo conjunto de objetos primitivos disponíveis no editor de PCB. Além de footprints, logotipos de empresas, definições de fabricação e outros objetos necessários durante o projeto da placa também podem ser salvos como componentes de PCB.

Criando um novo footprint de PCB

Os footprints podem ser criados diretamente no seu Workspace conectado. Para isso:

  1. Selecione File » New » Library nos menus principais e, na caixa de diálogo New Library que se abre, selecione Create Library Content » Footprint na região Workspace da caixa de diálogo.

    Crie um novo footprint do Workspace usando a caixa de diálogo New Library
    Crie um novo footprint do Workspace usando a caixa de diálogo New Library

  2. Na caixa de diálogo Create New Item que se abre, insira as informações necessárias, certifique-se de que a opção Open for editing after creation esteja habilitada e clique em OK. O footprint do Workspace será criado e o editor temporário de footprints de PCB será aberto, apresentando um documento .PcbLib como documento ativo. Esse documento será nomeado de acordo com o Item-Revisão, no formato: <Item><Revision>.PcbLib (por exemplo, PCC-001-0001-1.PcbLib). Use o documento para definir o footprint conforme descrito abaixo.

    Exemplo de edição da revisão inicial de um footprint do Workspace – o editor temporário de footprints de PCB fornece o documento no qual você define seu footprint.
    Exemplo de edição da revisão inicial de um footprint do Workspace – o editor temporário de footprints de PCB fornece o documento no qual você define seu footprint.

  3. Quando o footprint estiver definido conforme necessário, salve-o no Workspace usando o controle Save to Server à direita da entrada do footprint no painel Projects. A caixa de diálogo Edit Revision será exibida, na qual você pode alterar o nome e a descrição e adicionar notas de versão conforme necessário. O documento e o editor serão fechados após o salvamento.

Um footprint do Workspace salvo pode ser usado ao definir um componente usando o Editor de Componentes no modo de edição de componente único ou no modo de edição de componentes em lote.

Os footprints do Workspace podem ser explorados usando o painel Components. Habilite a visibilidade dos modelos clicando no botão  na parte superior do painel e selecionando Models; em seguida, selecione a categoria Footprints.

Para editar um footprint do Workspace, clique com o botão direito na sua entrada no painel Components e selecione o comando Edit. Novamente, o editor temporário será aberto, com o footprint aberto para edição. Faça as alterações necessárias e salve o documento na próxima revisão do footprint do Workspace.

 
 
 
 
 

Ao salvar um footprint editado no seu Workspace, você pode preservar o estado atual do ciclo de vida do footprint. Esse controle é fornecido pela opção Preserve lifecycle state (not recommended), disponível na caixa de diálogo Create Revision ao salvar novamente (). Quando a opção está habilitada, a nova revisão do footprint será automaticamente definida com o estado do ciclo de vida da revisão anterior. Esse recurso está disponível para quem tem a permissão operacional Allow to skip lifecycle state change for new revisions atribuída (saiba mais sobre Definir permissões de operações globais para um Workspace).

  • Quando você faz uma alteração em um footprint do Workspace, no momento em que salva essa alteração em uma nova revisão do footprint, todos os componentes do Workspace que usam esse footprint ficam efetivamente desatualizados, pois continuam usando a revisão anterior. Na maioria dos casos, você certamente desejará salvar novamente esses componentes do Workspace, com os respectivos vínculos de modelo atualizados para usar as revisões mais recentes disponíveis. Para simplificar esse processo, um Workspace, em conjunto com o Altium Designer, permite atualizar os componentes que utilizam o footprint no momento em que ele é salvo novamente, após quaisquer modificações feitas por meio do recurso de edição direta.

    Para obter mais informações sobre como atualizar os componentes que utilizam um modelo de domínio ao salvá-lo, consulte a página Criando e editando conteúdo.

  • Você também pode atualizar o footprint do Workspace usado por um componente do Workspace diretamente, durante a edição desse componente no Editor de Componentes, no modo de edição de componente único ou no modo de edição de componentes em lote.

  • Da perspectiva de um projetista, um componente do Workspace reúne, em uma única entidade, todas as informações necessárias para representar esse componente em todos os domínios de projeto. Portanto, nesse sentido, ele pode ser considerado um contêiner – um “recipiente” no qual todos os modelos de domínio e informações paramétricas são armazenados. Quanto à sua representação nos diversos domínios, um componente do Workspace não contém os modelos de domínio do Workspace em si, mas sim vínculos para esses modelos. Esses vínculos são especificados ao definir o componente.

  • Os footprints de PCB também podem ser criados no Workspace como parte da importação de bibliotecas de componentes existentes de gerações anteriores (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). A interface desse processo – o Library Importer – apresenta um fluxo intuitivo que utiliza as bibliotecas inicialmente selecionadas e as importa para o seu Workspace. Saiba mais sobre o Importador de Bibliotecas.

  • Um novo footprint do Workspace também pode ser criado ao definir um componente do Workspace no Editor de Componentes em seu modo de edição de componente único.

  • Um footprint também pode ser criado como parte de uma biblioteca de footprints de PCB baseada em arquivos.

Definindo um footprint de PCB

Os footprints são sempre criados no lado superior, independentemente do lado da placa em que serão posicionados, usando o mesmo conjunto de ferramentas e objetos de projeto disponíveis no editor de PCB. Os atributos específicos de camada, como pads de montagem em superfície e definições de máscara de solda, são automaticamente transferidos para as camadas correspondentes do lado inferior quando você vira o footprint para o outro lado da placa durante o posicionamento do componente.

Os objetos de projeto podem ser posicionados em qualquer camada; no entanto, o contorno normalmente é criado na camada Top Overlay (serigrafia), e os pads na camada multicamada (para pinos de componentes de furo passante) ou na camada de sinal superior (para pinos de componentes de montagem em superfície). Quando você posiciona o footprint em uma PCB, todos os objetos que o compõem são atribuídos às suas camadas definidas.

Vistas 2D e 3D de um footprint para um componente joystick. A imagem 3D mostra o modelo STEP importado do componente. Observe que os pads e a serigrafia do componente podem ser vistos abaixo do modelo STEP.
Vistas 2D e 3D de um footprint para um componente joystick. A imagem 3D mostra o modelo STEP importado do componente. Observe que os pads e a serigrafia do componente podem ser vistos abaixo do modelo STEP.

Os footprints mostrados nesta página servem apenas para ilustrar os procedimentos necessários; suas dimensões não são precisas. Sempre confira as especificações de um novo footprint com a folha de dados do fabricante.

A sequência típica para criar manualmente o footprint de um componente é:

  1. Prepare o espaço de projeto: defina as opções de ajuste, configure as grades e as guias - saiba mais.

  2. Os footprints devem ser criados ao redor do ponto de referência do espaço de projeto, no centro do editor de footprints de PCB. Esse ponto de referência é, na verdade, a origem relativa do espaço de projeto e é o ponto pelo qual o footprint do componente é capturado pelo cursor nas operações de posicionamento e movimentação (dependendo da configuração atual de Object Snap Options na página PCB Editor – General da caixa de diálogo Preferences). Use as teclas de atalho J, R para ir diretamente ao ponto de referência. Se você se esquecer de ir até o ponto de referência antes de começar a criar seu footprint, poderá trazer o pad de referência para o footprint usando os comandos do submenu Edit » Set Reference:
    • Pin 1 - defina o ponto de referência do componente como o pino 1 do footprint.

    • Center - defina o ponto de referência do componente como o centro do footprint.

    • Location - defina o ponto de referência do componente como uma posição definida pelo usuário.

    O ponto escolhido será definido como 0,0 - ele se tornará a nova origem relativa, e as posições de todas as primitivas serão atualizadas em relação a esse ponto.

  3. Posicione os pads (Place » Pad) de acordo com os requisitos do componente. Após executar o comando Posicionar pad, mas antes de posicionar o primeiro pad, pressione a tecla Tab para abrir o painel Properties e definir todas as propriedades do pad, incluindo Designator, Size and Shape, Layer e Hole Size (para um pad de furo passante). O designador é incrementado automaticamente nos posicionamentos subsequentes de pads. Para um pad de montagem em superfície, defina Layer como Top Layer. Para um pad de furo passante, defina Layer como Multi-Layer.

    Alguns footprints exigem pads com formato irregular. Isso pode ser feito usando objetos de pad com formato personalizado. Para saber mais, consulte a página Personalização de uma pilha de pads.
    • Um dos procedimentos mais importantes na criação de um novo footprint de componente é posicionar os pads que serão usados para soldar o componente à PCB. Eles devem ser posicionados nos locais exatos para corresponder aos pinos do dispositivo físico.
    • Também é necessário ter cuidado ao atribuir designadores aos pads, pois essa é a propriedade que o Altium Designer usa para mapear os números dos pinos do símbolo esquemático.
  4. Para garantir o posicionamento preciso dos pads, considere configurar uma grade específica para essa tarefa. Use as teclas de atalho Ctrl+G para abrir a caixa de diálogo do editor de grade cartesiana e a tecla Q para alternar a grade entre os sistemas imperial e métrico.

  5. Para posicionar um pad com precisão ao movê-lo com o mouse, use as teclas de seta do teclado para mover o cursor em incrementos da grade atual. Além disso, manter Shift pressionado permitirá mover em passos de 10 vezes o espaçamento da grade. A posição X, Y atual é exibida na barra de status e também no visor Heads Up. O visor Heads Up contém tanto a posição quanto a diferença entre a posição do último clique e a posição atual do cursor. Use o atalho Shift+H para ativar e desativar o visor Heads Up. Como alternativa, clique duas vezes para editar um pad posicionado e insira as posições X e Y necessárias no painel Properties .

  6. Para verificar a distância entre dois pontos no espaço de projeto, use Reports » Measure Distance (atalho Ctrl+M). Siga as instruções na barra de status.

  7. Os atributos específicos dos pads, como máscara de solda e máscara de pasta, são calculados automaticamente com base nas dimensões do pad e nas regras de projeto de máscara aplicáveis. Embora as configurações de máscara possam ser definidas manualmente para cada pad, isso dificulta a modificação dessas configurações posteriormente, durante o processo de projeto da placa. Normalmente, isso só é feito quando não é possível selecionar os pads por meio de regras de projeto. Observe que as regras são definidas no editor de PCB durante o projeto da placa.

  8. Use trilhas, arcos e outros objetos primitivos para definir o contorno do componente que aparece na serigrafia da PCB, na camada Top Overlay. Se o componente for virado para o lado inferior da placa durante o posicionamento, a serigrafia será automaticamente transferida para a camada Bottom Overlay.

  9. Posicione trilhas e outros objetos primitivos em uma camada mecânica para definir detalhes mecânicos adicionais, como uma área de reserva para posicionamento. As camadas mecânicas são camadas de uso geral. Você deve atribuir uma função a essas camadas e usá-las de forma consistente em todos os seus footprints.

  10. Posicione objetos de corpo 3D para definir a forma tridimensional do componente físico que será montado na PCB.

    Um objeto de corpo 3D adicionado a um footprint pode fazer referência a um modelo 3D carregado no Workspace conectado.
  11. Os textos de designador e comentário são adicionados automaticamente à camada de serigrafia do footprint durante seu posicionamento no espaço de projeto da PCB. Textos adicionais de designador e comentário podem ser incluídos posicionando as strings especiais .Designator e .Comment em uma camada mecânica.

    Ao posicionar textos de designador e comentário, é necessário definir um par de camadas no editor de PCB. Isso garante que os textos fiquem vinculados ao lado da placa em que o componente está montado e sejam transferidos para o outro lado da placa quando o componente for virado. Para obter mais informações, consulte a seção Como lidar com requisitos especiais específicos de camada abaixo.
  12. Defina as propriedades do footprint (por exemplo, seu nome e sua descrição) na guia Footprint do painel Properties no modo Library Options (ativo quando nenhum objeto está selecionado no espaço de projeto, pode ser acessado usando Tools » Footprint Properties comando nos menus principais). Consulte a seção abaixo para saber mais sobre as opções e os controles disponíveis na aba Footprint do painel.

  • Para uma definição padronizada de pads/vias em todos os footprints, a biblioteca de pads/vias (*.PvLib) pode ser usada para posicionar pads/vias – saiba mais.
  • O editor de footprints de PCB também oferece alguns assistentes para agilizar o processo de criação de footprints:
    • O IPC Compliant Footprint Wizard – gera um footprint de PCB totalmente compatível com a Revisão B da norma IPC 7351 – Generic Requirements for Surface Mount Design and Land Pattern Standard – saiba mais.
    • O IPC Compliant Footprints Batch Generator – ao trabalhar com uma biblioteca de footprints de PCB baseada em arquivos, use o IPC Compliant Footprints Batch Generator para gerar rapidamente vários footprints, em diversos níveis de densidade – saiba mais.
    • O Footprint Wizard – permite selecionar entre vários tipos de encapsulamento e preencher as informações adequadas para, então, criar o footprint do componente para você – saiba mais.

Preparando o espaço de projeto

Por padrão, as grades são exibidas usando pontos. Se preferir, elas podem ser exibidas usando linhas. Isso é configurado na caixa de diálogo Grid Editor, acessada clicando no botão Properties do painel Properties, conforme mostrado na imagem abaixo. Como alternativa, pressione o atalho Ctrl+G para abrir a caixa de diálogo.

Na imagem, a grade fina é exibida como pontos, e a grade grossa é exibida como linhas.
Na imagem, a grade fina é exibida como pontos, e a grade grossa é exibida como linhas.

Painel de propriedades

Ao editar um footprint no editor de footprints de PCB, quando nenhum objeto de projeto está selecionado no espaço de projeto, o painel Properties apresenta o Library Options.

As seções recolhíveis a seguir contêm informações sobre as opções e os controles disponíveis na aba General do painel:

As seções recolhíveis a seguir contêm informações sobre as opções e os controles disponíveis na aba Footprint do painel:

A possibilidade de definir as propriedades do footprint usando a aba Footprint do painel Properties está disponível quando a opção PCB.FootprintParameters está habilitada na caixa de diálogo Configurações avançadas. Quando essa opção está desabilitada, as propriedades do footprint são definidas usando a PCB Library Footprint caixa de diálogo (), acessada selecionando o comando Tools » Footprint Properties nos menus principais, selecionando uma entrada de footprint na região Footprints do painel PCB Library e clicando no botão Edit, ou clicando duas vezes em uma entrada de footprint na região Footprints do painel PCB Library.

Quando um objeto de projeto é selecionado, o painel apresenta opções específicas para esse tipo de objeto. A tabela a seguir lista os tipos de objetos disponíveis para posicionamento no espaço de projeto de footprints de PCB – clique em um link para acessar a página de propriedades desse objeto.

Corpo 3D Arco
Área de exclusão em arco Preenchimento
Área de exclusão de preenchimento Pad
Região Área de exclusão de região
Texto (String, Quadro de texto) Trilha
Área de exclusão de trilha Via

Expansões das máscaras de solda e de pasta

Para verificar se as máscaras de solda e/ou de pasta foram definidas corretamente no editor de footprints de PCB, abra o painel Configuração de visualização e habilite a opção de exibição () para cada camada de máscara.

O anel que aparece ao redor da borda de cada pad na cor da camada de máscara de solda superior representa a borda da forma da máscara de solda que se projeta para fora do pad multicamada pelo valor da expansão, pois multi-layer está no topo da ordem de desenho das camadas; essa camada é desenhada por cima. A Layer Drawing Order é definida na página Editor de PCB - Exibição da caixa de diálogo Preferences).

A imagem abaixo mostra um footprint de PCB com uma borda roxa (cor da camada de máscara de solda superior) ao redor da borda de cada pad.

Para percorrer rapidamente as camadas, use o Modo de camada única (Shift+S) em combinação com Ctrl+Shift+Wheel roll.

Por padrão, a forma criada nas camadas de máscara é a forma do pad, expandida ou contraída pelo valor especificado pelas regras de projeto Expansão da máscara de solda e Expansão da máscara de pasta definidas na PCB em que o footprint é posicionado. Em alguns casos, pode ser necessário sobrepor as regras de projeto de expansão e especificar uma expansão de máscara como atributo do pad, selecionar uma opção em um conjunto padrão de formas de máscara predefinidas ou criar sua própria forma personalizada. Nessas situações, você pode configurar as máscaras de pasta/solda de um pad selecionado em seu painel Properties - saiba mais. Como alternativa, você pode posicionar primitivas adequadas (regiões, trilhas etc.) na camada de máscara necessária.

Em uma biblioteca de PCB, todos os objetos cuja expansão da máscara de solda é controlada por regras terão um valor de expansão igual a 0 mil. Esse recurso está disponível quando a opção PCB.SolderMaskZeroExpansion está habilitada na caixa de diálogo Configurações avançadas. Quando essa opção está desabilitada, o valor de expansão da máscara de solda desses objetos em uma biblioteca de PCB é de 4 mils.

Suporte a parâmetros

Os parâmetros aplicados a objetos no Altium Designer oferecem um meio poderoso e flexível de adicionar informações complementares a um projeto de PCB. Como propriedades do objeto pai, os parâmetros podem ser aplicados em vários níveis, incluindo projetos, documentos, modelos e objetos individuais em um documento de projeto.

Consulte o objeto Parâmetro para obter mais informações.

Os parâmetros disponibilizados no ambiente de PCB podem ser usados para filtrar consultas, regras de projeto, scripts e variantes, e podem ser aplicados aos footprints de componentes de PCB para invocar strings personalizadas nos footprints posicionados.

Parâmetros por meio de uma Ordem de alteração de engenharia

Os recursos de parâmetros da PCB se baseiam em funcionalidades incluídas no mecanismo de ECO e no documento de PCB, que permitem transferir parâmetros de componentes definidos pelo usuário para o ambiente de PCB e mantê-los nele. Essa transferência é unidirecional, e os parâmetros transferidos são somente leitura no ambiente de PCB.

A transferência de parâmetros é realizada criando uma ECO do esquemático para a PCB com o comando de menu Design » Update PCB Document.

Quando a ECO é executada (usando o botão Execute Changes ), todos os novos parâmetros de componentes do esquemático definidos pelo usuário são transferidos para a referência de footprint correspondente no projeto de PCB. 

A detecção e a migração de parâmetros para a PCB são determinadas pelas configurações das opções do projeto (Project » Project Options). Na caixa de diálogo Project Options, defina o comportamento de detecção e modificação de diferenças na seção Differences Associated with Parameters da aba Comparator e na seção Modifications Associated with Parameters da aba ECO Generation.

Para visualizar os parâmetros transferidos no editor de PCB, clique duas vezes em um componente para abrir o painel Properties e, em seguida, selecione a aba Parameters . A aba listará os parâmetros atuais do usuário atribuídos ao footprint do componente selecionado. Os parâmetros de um footprint de componente selecionado também estão disponíveis no painel Components .

Links para informações de referência

O ambiente de PCB aceita automaticamente os parâmetros ComponentLink predefinidos do esquemático. Eles são definidos como pares de parâmetros (descrição e URL do link) que normalmente estabelecem links para dados de referência em arquivos específicos ou locais na internet – geralmente o site de um fabricante ou a URL de uma folha de dados.

Consulte Definição de links clicáveis para informações de referência em uma biblioteca de esquemáticos e Acesso a links clicáveis para informações de referência em um documento de PCB para obter informações sobre os parâmetros de links de referência.

Nos espaços de projeto de esquemáticos e de PCB, os links são acessados pelo menu de contexto aberto com o botão direito do mouse ao posicionar o cursor sobre um componente (nas opções do submenu References). Os parâmetros especializados são adicionados no painel Properties e, quando transferidos para o ambiente de PCB, aparecem como parâmetros do footprint do componente. 

Parâmetros em footprints de origem

Os parâmetros transferidos para a PCB podem ser usados para fornecer informações adicionais de produção ou funcionamento da placa por meio dos footprints dos componentes. Ao adicionar strings especiais aos footprints na biblioteca de origem, as strings personalizadas serão interpretadas na camada mecânica ou de serigrafia de destino.

Uma string especial que representa um parâmetro definido pelo usuário pode ser adicionada ao footprint do componente de origem usando o botão de strings especiais e a lista suspensa () no painel Properties .

No footprint de biblioteca abaixo, a string especial .Designator foi posicionada na camada Mecânica 2.

Uma string especial que representa um parâmetro do usuário pode ser adicionada ao footprint do componente.

Quando esse parâmetro personalizado também tiver sido aplicado aos componentes do esquemático e os dados do parâmetro tiverem sido transferidos para a PCB, as strings interpretadas do footprint aparecerão tanto na visualização da placa quanto nos arquivos de saída gerados. Neste caso, a string do parâmetro especial contém um identificador personalizado da peça do componente para auxiliar na montagem.

A aplicação de parâmetros do usuário a footprints de componentes como strings especiais pode atender a vários outros requisitos personalizados de PCB, incluindo rótulos de função para chaves e conectores, nos quais uma string de parâmetro de 'função' pode ser posicionada na serigrafia superior dos footprints desses tipos de componentes.

Para ver o valor interpretado das strings especiais no layout da placa, habilite a opção Special Strings na região Additional Options da aba View Options no View Configuration painel. As strings especiais são sempre convertidas nos arquivos de saída gerados.
No editor de esquemáticos, se desejar, habilite a opção Display Names of Special Strings that have No Value Defined na página Schematic – Graphical Editing da caixa de diálogo Preferences.

Consultas de parâmetros

As strings de parâmetros no domínio de PCB também são acessíveis por meio da linguagem de consulta do Altium Designer e, portanto, estão disponíveis para funções de filtragem de objetos, incluindo o recurso Localizar objetos semelhantes.

Para selecionar objetos semelhantes, clique com o botão direito em um componente e selecione Find Similar Objects no menu de contexto para abrir a caixa de diálogo Find Similar Objects.

A caixa de diálogo Localizar objetos semelhantes inclui uma seção Parameters na qual as opções de filtragem podem ser selecionadas conforme necessário.

O painel PCB Filter pode aplicar palavras-chave de consulta específicas de parâmetros como critérios de filtro e pode ser usado para criar regras de projeto baseadas em parâmetros de PCB.

Há várias palavras-chave de consulta disponíveis para trabalhar com parâmetros de footprints de PCB, incluindo funções específicas para converter valores de strings em números (como StrToNumber). As conversões de valores de strings reconhecem as unidades (V, mA, mV, kOhm etc.) e permitem determinar o resultado da consulta pelo processamento numérico de uma string de valor de parâmetro.

Os tipos de unidade suportados que podem ser especificados nas consultas são:

  • % – Porcentagem
  • A – Corrente
  • C – Temperatura
  • dB – Decibéis
  • F – Capacitância
  • G – Condutância
  • H – Indutância
  • Hz – Frequência
  • Kg – Massa
  • m – Comprimento
  • Ohm – Resistência
  • Q – Carga
  • s – Tempo
  • V – Tensão
  • W – Potência
  • Z – Impedância

Há várias palavras-chave de consulta de parâmetros disponíveis para trabalhar com parâmetros de footprints de componentes de PCB.

O exemplo mostrado na caixa de diálogo Query Helper acima processa o parâmetro de tensão nominal de cada componente (usando a conversão de string em número – StrToNumber(Unit Value, Unit Type))  para determinar se seu valor é maior que 50 V. Quando aplicado no painel PCB Filter, o layout da placa de exemplo revela um único componente de alta tensão, C1 (que possui um valor de tensão nominal de 3 kV).

A notação científica E também é suportada; assim, por exemplo, uma consulta para filtrar valores de capacitores acima de 1 nF seria semelhante a:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
Como alternativa, a função de conversão numérica poderia ser usada tanto para o ParameterValue retornado and para o valor de comparação:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Regras e scripts

As consultas de parâmetros de PCB também podem ser aplicadas a scripts e regras de projeto do Altium Designer. Estas últimas podem realizar verificações de validação do layout, como detectar parâmetros de footprints para avaliar o posicionamento de componentes ou a atribuição de camadas. Observe que as funções listadas na caixa de diálogo Query Helper acima estão disponíveis na linguagem de scripts.

O exemplo abaixo mostra a consulta de tensão nominal de capacitores (veja a consulta de filtro acima) aplicada a uma regra de posicionamento de componentes que, quando executada, verifica valores específicos de espaçamento para componentes detectados como dispositivos de alta tensão (>50V).

As regras de projeto definidas por parâmetros específicos de footprints, transferidos do ambiente de esquemáticos, podem ser usadas para detectar condições personalizadas de layout.

Da mesma forma, parâmetros personalizados de PCB podem ser usados para verificar a compatibilidade dos componentes com as camadas, por exemplo, quando um componente não suporta soldagem por onda e, portanto, o posicionamento na camada inferior. Nesse caso, uma consulta de correspondência de objetos que processa um parâmetro personalizado ‘WaveSoldering’ (Yes/No) pode ser aplicada à Regra de camadas permitidas.

A regra (em lote) verificará então o valor desse parâmetro do componente e criará uma violação se o componente não for compatível com o posicionamento na camada inferior.

Variantes

Os parâmetros transferidos para a PCB que estão incluídos em variações do projeto (Variantes de projeto) são processados com a seleção da variante.

Na prática, um parâmetro de componente que varia no ambiente de PCB será detectado dinamicamente por uma string de consulta ou, por exemplo, exibido em uma camada da placa por meio de uma string especial. 

Parâmetros de footprints definidos pelo usuário

Este recurso está disponível quando a opção PCB.FootprintParameters está habilitada na caixa de diálogo Configurações avançadas.

O Altium Designer oferece suporte a parâmetros de footprints definidos pelo usuário. A região Parameters na aba Footprint do painel Properties  em seu modo Library Options  pode ser usada para visualizar e editar parâmetros de footprints quando nenhum objeto está selecionado na área de projeto do editor de footprints de PCB.

Quando o componente é colocado na PCB, você pode ver esses parâmetros no painel Properties  no modo Component  na aba Parameters .

  • Os parâmetros de footprints dos componentes colocados em uma PCB serão propagados para os footprints nas bibliotecas geradas pelo comando Make PCB Library ou Make Integrated Library do menu principal do editor de PCB.
  • Os parâmetros de footprints são suportados pelo mecanismo de comparação do Altium Designer e nas saídas geradas de Pick and Place e ODB++.
Altium MCAD CoDesigner oferece suporte ao posicionamento de componentes MCAD nativos no MCAD de acordo com a vinculação configurada. Em alguns casos, vários footprints com modelos diferentes são vinculados a um único componente (por exemplo, um LED que pode ser montado em uma PCB de duas maneiras: verticalmente, com terminais retos, ou horizontalmente, com terminais dobrados). Usando os parâmetros de footprints, você agora pode fazer referência aos diferentes modelos MCAD a partir desses diferentes footprints. Saiba mais sobre Vinculação de componentes de projeto ECAD e MCAD nativos.

Strings de designador e comentário

Strings padrão de designador e comentário

Quando um footprint é colocado em uma placa, ele recebe um designador e um comentário com base nas informações extraídas da visualização esquemática do projeto. Os espaços reservados para as strings de designador e comentário não precisam ser definidos manualmente, pois são adicionados automaticamente quando o footprint é colocado em uma placa. As posições dessas strings são determinadas pela opção Autoposition das strings de designador e comentário no painel Properties no modo Parameter quando a string de designador ou comentário é selecionada na área de projeto. A posição e o tamanho padrão das strings de designador e comentário são configurados na respectiva primitiva na página Editor de PCB - Padrões da caixa de diálogo Preferences .

Strings adicionais de designador e comentário

Pode haver situações em que você queira cópias adicionais das strings do designador ou do comentário. Por exemplo, sua empresa de montagem deseja um desenho de montagem detalhado com o designador exibido dentro do contorno de cada componente, enquanto sua empresa exige que o designador fique logo acima do componente na serigrafia da PCB final. Essa necessidade de um designador adicional pode ser atendida incluindo a string especial .Designator no footprint. Uma string especial .Comment também está disponível para especificar a posição da string de comentário em outras camadas ou posições.

Para atender aos requisitos da empresa de montagem, a string .Designator seria posicionada em uma camada mecânica no editor de footprints de PCB, e impressões que incluíssem essa camada poderiam então ser geradas como parte das instruções de montagem do projeto.

Como atender a requisitos especiais específicos de camadas

Um componente de PCB pode ter vários requisitos especiais, como a necessidade de um ponto de cola ou de uma definição de máscara de solda removível. Muitos desses requisitos especiais estarão vinculados ao lado da placa em que o componente é montado e deverão passar para o outro lado da placa quando o componente for invertido.

Em vez de incluir um grande número de camadas de finalidade específica que podem ser raramente usadas, o editor de PCB do Altium Designer atende a esse requisito por meio de um recurso chamado pares de camadas. Um par de camadas consiste em duas camadas mecânicas definidas como um par. Sempre que um componente é invertido de um lado da placa para o outro, todos os objetos em uma camada mecânica pareada são transferidos para a outra camada mecânica desse par. Com essa abordagem, você seleciona uma camada mecânica adequada para incluir o ponto de cola (ou outros requisitos especiais) e define seu formato usando os objetos disponíveis. Ao posicionar esse footprint em uma placa, você deve configurar o pareamento de camadas. Isso informa ao software para qual camada ele deve transferir os objetos quando esse componente for invertido para o outro lado da placa. Não é possível definir pares de camadas no editor de footprints de PCB; isso é feito no editor de PCB.

O pareamento de camadas precisa ser definido before o componente ser invertido. Se o pareamento for definido depois que o componente tiver sido movido para o lado inferior, os elementos mecânicos serão invertidos, mas permanecerão em sua camada original. Se você esquecer de criar os pares de camadas antes da inversão, poderá atualizar a partir da biblioteca para renovar a instância do componente posicionada na placa.

Os nomes das camadas mecânicas podem ser editados diretamente no painel View Configurations, clicando com o botão direito e selecionando Edit Layer.

Uma abordagem comum para gerenciar o uso de camadas mecânicas é atribuir um número de camada dedicado a cada função de camada mecânica necessária. Essa abordagem exige que todos os projetistas sigam o mesmo esquema de atribuição e numeração de camadas. Ela também pode criar dificuldades quando os componentes são obtidos de outras fontes que não seguem o mesmo esquema de atribuição e numeração. Se um esquema diferente tiver sido usado, os objetos do projeto deverão ser movidos de sua camada mecânica atual para a camada mecânica atribuída a essa função.

Esse problema é resolvido com a introdução da propriedade Layer Type. Quando um componente é inserido de uma biblioteca no editor de PCB, copiado de uma biblioteca para outra ou criado pelo IPC Footprint Wizard, as atribuições existentes de tipo de camada são correspondidas automaticamente, independentemente dos números de camadas mecânicas atribuídos a esses tipos de camada. Os objetos são realocados nas camadas corretas de acordo com seu tipo de camada. Se o software não conseguir encontrar uma correspondência pelo tipo de camada, ele recorrerá à correspondência pelo número da camada.

Tanto para camadas mecânicas individuais quanto para pares de camadas de componentes, você pode selecionar um tipo de camada em uma lista predefinida de tipos. Você pode acessar as caixas de diálogo mostradas abaixo clicando com o botão direito em uma camada individual e selecionando o comando Edit Layer ou Add Component Layer no menu.

Para obter informações detalhadas sobre os tipos de camadas mecânicas relacionados a componentes, consulte a página Como trabalhar com camadas mecânicas.

Como adicionar altura a um footprint de PCB

No nível mais simples de representação 3D, informações de altura podem ser adicionadas a um footprint de PCB. Para isso, abra o painel Properties em seu modo Library Options (ativo quando nenhum objeto está selecionado no espaço de projeto) e insira a altura recomendada para o componente no campo Height da aba Footprint do painel.

Regras de projeto de altura podem ser definidas durante o projeto da placa (clique em Design » Rules no editor de PCB), normalmente para verificar a altura máxima dos componentes em uma classe de componentes ou dentro de uma definição de região.

Uma opção melhor para definir informações de altura seria associar corpos 3D ao footprint de PCB.

Como gerenciar componentes com primitivas de roteamento

Quando um projeto é transferido, o footprint especificado em cada componente é extraído das bibliotecas disponíveis e posicionado na placa. Em seguida, a propriedade de rede de cada pad no footprint é definida com o nome da rede conectada ao pino desse componente no esquemático. Todos os objetos que tocam um pad se conectam à mesma rede desse pad.

O editor de PCB inclui uma ferramenta abrangente de gerenciamento de redes. Para iniciá-la, selecione Design » Netlist » Configure Physical Nets nos menus principais para abrir a caixa de diálogo Configurar redes físicas. Clique no botão Menu para exibir um menu de opções. Clique na lista suspensa do cabeçalho New Net Name para selecionar a rede a ser atribuída às primitivas não atribuídas.

Footprints com vários pads conectados ao mesmo pino

O footprint mostrado abaixo, de um transistor SOT223, tem vários pads conectados ao mesmo pino lógico do componente no esquemático — o pino 2. Para fazer essa conexão, dois pads foram adicionados com o mesmo designador — '2'. Quando o comando Design » Update PCB é usado no editor de esquemáticos para transferir as informações do projeto para a PCB, a sincronização resultante mostrará as linhas de conexão chegando aos dois pads no editor de PCB, ou seja, eles estão na mesma rede. Ambos podem ser roteados.

Footprint SOT223 mostrando dois pads com o designador 2.
Footprint SOT223 mostrando dois pads com o designador 2.

Preparação da serigrafia

Para ajudar a resolver problemas comuns de projeto para fabricação (DFM) causados pela sobreposição da serigrafia ao cobre exposto e aos furos, o editor de footprints de PCB inclui um recurso dedicado à preparação da serigrafia dos seus footprints. Esses problemas podem ser resolvidos de forma eficaz por meio de:

  • recorte automático de linhas e arcos da serigrafia;
  • recorte ou movimentação automática de preenchimentos e regiões;
  • movimentação automática de strings de texto da serigrafia.
A ferramenta de preparação da serigrafia também pode ser acessada durante o projeto de uma PCB – saiba mais.

Para acessar a ferramenta de preparação da serigrafia no editor de footprints de PCB, use o comando Tools » Silkscreen Preparation nos menus principais. A caixa de diálogo Silkscreen Preparation será aberta.

Use a caixa de diálogo para configurar os ajustes de recorte/movimentação dos objetos da serigrafia. As opções disponíveis são:

  • Clip to Exposed Copper – habilite para recortar automaticamente os objetos nas áreas de cobre exposto.
  • Clip to Solder Mask Openings – habilite para recortar automaticamente os objetos nas aberturas da máscara de solda.
  • Silkscreen Clearance – defina a distância mínima aceitável entre os objetos da serigrafia e o cobre exposto / as aberturas da máscara de solda e os furos.
  • Min Remaining Length – se o comprimento da linha/arco for menor que o valor definido após o recorte, os objetos serão removidos do footprint. Observe que esse comprimento é medido de vértice a vértice, e não de borda a borda – mostrar imagem.
  • Move Text – habilite para afastar os textos da serigrafia do cobre exposto / das aberturas da máscara de solda e dos furos se a distância entre eles for menor que Silkscreen Clearance. O deslocamento é limitado pelo valor de Max Distance.
  • Fill & Region – selecione uma ação a ser executada nos preenchimentos e nas regiões quando a distância entre eles e o cobre exposto / as aberturas da máscara de solda e os furos for menor que Silkscreen Clearance:
    • None – os preenchimentos e as regiões permanecem inalterados.
    • Clip – os preenchimentos e as regiões serão recortados para manter Silkscreen Clearance. Os preenchimentos são convertidos em regiões, quando aplicável.
    • Move – os preenchimentos e as regiões serão afastados do cobre exposto / das aberturas da máscara de solda e dos furos. O deslocamento é limitado pelo valor de Max Distance.
  • Max Distance – defina a distância máxima pela qual textos, designadores de componentes, preenchimentos e regiões podem ser deslocados para manter Silkscreen Clearance.

Clique em OK para recortar e/ou deslocar os objetos de serigrafia de acordo com as configurações da caixa de diálogo.

Se uma ação não puder ser executada em um objeto (por exemplo, um texto não puder ser deslocado devido à limitação de Max Distance), uma mensagem referente a esse objeto aparecerá no painel Messages.

Um exemplo do resultado da ferramenta de preparação da serigrafia é mostrado abaixo.

Javascript

Criação de um footprint usando o assistente de footprints compatíveis com IPC

O IPC Compliant Footprint Wizard gera um footprint de PCB que está em plena conformidade com a Revisão B da norma IPC 7351 - Generic Requirements for Surface Mount Design and Land Pattern Standard. Em vez de trabalhar diretamente com as dimensões do footprint (como faz o Assistente de footprints), o IPC Compliant Footprint Wizard usa informações dimensionais do próprio componente e, em seguida, calcula as propriedades adequadas dos pads e de outros elementos do footprint de acordo com os algoritmos publicados pelo IPC.

Em vez de exigir que você insira as propriedades dos pads e das trilhas usados para definir o footprint, o Wizard recebe como entrada as dimensões reais do componente. Com base nas fórmulas desenvolvidas para a norma IPC-7351, o Wizard gera o footprint usando objetos padrão do Altium Designer, como pads e trilhas.

  • Esta caixa de diálogo está em conformidade com a Revisão B da norma IPC 7351 - Requisitos genéricos para projetos de montagem em superfície e padrão de disposição de pads. A IPC-7351B foi publicada em 2010 e substitui a IPC-7351A (publicada em 2007).

  • Para acessar o IPC Compliant Footprint Wizard no Altium Designer, a extensão de software IPC Footprint Generator deve estar instalada. Essa extensão é instalada com o Altium Designer por padrão. Ela pode ser instalada ou removida manualmente.

    Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Para executar o IPC Compliant Footprint Wizard, selecione Tools » IPC Compliant Footprint Wizard nos menus principais de um documento de biblioteca de PCB.

Na página Select Component Type, escolha a família de componentes para a qual deseja criar um footprint na página Select Component Type. A área de pré-visualização à direita do assistente muda dinamicamente para mostrar o componente selecionado e também indica os tipos de encapsulamentos que podem ser gerados. A tabela a seguir lista os tipos de componentes e encapsulamentos compatíveis com o assistente.

Nome Descrição Encapsulamentos incluídos
BGA Matriz de esferas BGA, CGA
BQFP Encapsulamento plano quadrado com protetores nos cantos BQFP
CAPAE Capacitor eletrolítico de alumínio CAPAE
CFP Encapsulamento cerâmico plano com terminais em dois lados - terminais tipo asa de gaivota cortados e conformados CFP
Matriz de chips Matriz de chips Matriz de chips
DFN Encapsulamento plano sem terminais salientes, com contatos em dois lados DFN
CHIP Componentes chip, 2 pinos Capacitor, indutor, resistor
CQFP Encapsulamento cerâmico plano quadrado - terminais tipo asa de gaivota cortados e conformados CQFP
DPAK Encapsulamento de transistor DPAK
LCC Suporte de chip sem terminais salientes LCC
LGA Matriz de contatos planos LGA
MELF Componentes MELF, 2 pinos Diodo, resistor
MOLDED Componentes moldados, 2 pinos Capacitor, indutor, diodo
PLCC Suporte plástico de chip com terminais, quadrado - terminais em J PLCC
PQFN Encapsulamento plano quadrado sem terminais salientes, com contatos recuados PQFN
PQFP Encapsulamento plástico plano quadrado PQFP, PQFP com pad exposto
PSON Encapsulamento de pequenas dimensões sem terminais salientes, com contatos recuados PSON
QFN Encapsulamento plano quadrado sem terminais salientes QFN, LLP
QFN-2ROW Encapsulamento plano quadrado sem terminais salientes, 2 fileiras, quadrado QFN de fileira dupla
SODFL Diodo de pequenas dimensões, terminal plano SODFL
SOIC Encapsulamento de circuito integrado de pequenas dimensões, passo de 1,27 mm - terminais tipo asa de gaivota SOIC, SOIC com pad exposto
SOJ Encapsulamento de pequenas dimensões - terminais em J SOJ
SON Encapsulamento de pequenas dimensões sem terminais salientes SON, SON com pad exposto
SOP, TSOP Encapsulamento de pequenas dimensões - terminais tipo asa de gaivota SOP, TSOP, TSSOP
SOT143/343 Transistor de pequenas dimensões SOT143, SOT343
SOT223 Transistor de pequenas dimensões SOT223
SOT23 Transistor de pequenas dimensões 3 terminais, 5 terminais, 6 terminais
SOT89 Transistor de pequenas dimensões SOT89
SOTFL Transistor de pequenas dimensões, terminal plano 3 terminais, 5 terminais, 6 terminais
BOBINADO Indutor bobinado de precisão, 2 pinos Indutor

As páginas seguintes do assistente mudam de acordo com o tipo de componente selecionado. Siga as páginas intuitivas do assistente para configurar o footprint específico do componente conforme necessário. Algumas observações sobre o uso do IPC Compliant Footprint Wizard:

  • Todas as dimensões são inseridas no assistente em unidades métricas (mm).

  • As dimensões gerais do encapsulamento, as informações dos pinos, o espaçamento dos calcanhares dos terminais, os filetes de solda e as tolerâncias podem ser inseridos e visualizados imediatamente.

    A alteração das tolerâncias IPC pode resultar em footprints de PCB que não estejam em conformidade com o IPC.

  • É possível inserir dimensões mecânicas, como informações de Courtyard, montagem e corpo do componente (3D).

  • O Wizard permite retornar às etapas anteriores, facilitando a revisão e os ajustes.

  • Prévias do footprint são exibidas em todas as etapas. Para cada tipo de componente, a região Preview é atualizada dinamicamente para mostrar a nova localização, o tamanho etc., de diversas configurações. Na região Preview , você pode clicar em  ou  para alternar entre as prévias em 2D e 3D.

  • Se desejar, você pode visualizar uma prévia do modelo STEP 3D antes de gerá-lo. Clique em Generate STEP Model Preview em qualquer página do Wizard após selecionar o tipo de componente para visualizar uma prévia do modelo STEP 3D na região Preview.

  • As máscaras de pasta são divididas em pequenos preenchimentos para encapsulamentos com um pad térmico grande (com dimensões de 2,1 mm x 1,6 mm ou maiores).

  • Para encapsulamentos com terminais do tipo asa de gaivota, os pads são recortados para impedir que se estendam sob o corpo do encapsulamento.

  • Para encapsulamentos pequenos com um pad térmico central grande, os pads periféricos são recortados para garantir o espaçamento necessário entre os pads de acordo com a norma IPC.

  • Quando o recorte dos pads é aplicado, um aviso é exibido na caixa de diálogo.

  • O nome e a descrição do footprint são sugeridos automaticamente com base nas informações inseridas no Wizard , mas podem ser alterados para atender aos requisitos da organização.

  • De acordo com a norma IPC, o assistente oferece três variantes de footprint (_L, _N, _M), cada uma adequada a uma densidade diferente de placa.

  • O botão Finish pode ser pressionado em qualquer etapa para gerar o footprint exibido na prévia atual. Se você clicar em Finish antes de concluir todo o Wizard, o footprint será criado usando os valores padrão do sistema para o tipo de componente selecionado.

  • Ao trabalhar com uma biblioteca de footprints de PCB baseada em arquivo, use o Gerador em lote de footprints compatíveis com IPC para gerar rapidamente vários footprints em diferentes níveis de densidade.

Quando o assistente é acessado a partir de uma biblioteca de footprints de PCB baseada em arquivo, a página Footprint Destination fica disponível, permitindo selecionar o local onde o footprint recém-criado será armazenado – mostrar imagem:

  • Selecione Existing PcbLib File se quiser armazenar o footprint em um arquivo de biblioteca de PCB existente. Você pode inserir o arquivo diretamente na caixa de texto ou usar o  para abrir uma caixa de diálogo e procurar o arquivo desejado.
  • Selecione New PcbLib File se quiser armazenar o footprint em um novo arquivo de biblioteca de PCB. Insira o nome do novo arquivo de biblioteca de PCB na caixa de texto. O sistema acrescentará a extensão .PcbLib ao nome do novo arquivo de biblioteca.
  • Selecione Current PcbLib File para armazenar o footprint no arquivo de biblioteca de PCB exibido.
  • Ative Produce 3D/STEP model para gerar um modelo STEP 3D.
  • Se você tiver uma licença válida de 'MCAD Co-Designer - SOLIDWORKS(R)', poderá optar por salvar o modelo como um arquivo do tipo Parasolid. Clique na lista suspensa à direita de Format e selecione Parasolid. O arquivo mostrado na caixa de texto External File agora é um arquivo *.x_t. Esse é o nome e o local do arquivo que será salvo.
  • Selecione Embedded (padrão) ou External File. Selecione External File para salvar seu modelo STEP 3D como um arquivo externo. O tipo de arquivo padrão é STEP, e o nome do arquivo aparece na caixa de texto External File com *.step como extensão. Se desejar, clique em  para procurar e selecionar a pasta na qual salvar o modelo STEP 3D gerado.

Como criar um footprint usando o assistente de footprints

O editor de footprints de PCB inclui um Footprint Wizard. Esse Wizard permite selecionar entre vários tipos de encapsulamento e preencher as informações apropriadas para, em seguida, criar o footprint do componente para você. Observe que, no Footprint Wizard, você insere as dimensões necessárias para os pads e a serigrafia do componente.

Para iniciar o Footprint Wizard, selecione Tools » Footprint Wizard nos menus principais ou clique com o botão direito na área de projeto e escolha o comando Tools » Footprint Wizard no menu de contexto.

Use a página Component patterns para especificar o padrão do componente que deseja criar. Selecione o padrão desejado na lista e use a lista suspensa para selecionar a unidade do componente (Imperial (mil) ou Metric (mm)). Os padrões disponíveis são:

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

As páginas seguintes do assistente mudam de acordo com o padrão de componente selecionado. Siga as páginas intuitivas do assistente para configurar o footprint específico do componente conforme necessário.

Ao configurar o estilo de nomenclatura dos pads para um footprint com o padrão Edge Connectors, Leadless Chip Carriers (LCC) ou Quad Packs (QUAD), clique na seta verde para alterar a ordem/direção da nomenclatura – mostrar imagem.

Como gerar um relatório do componente

Para gerar um relatório do footprint de PCB ativo, escolha o comando Reports » Component nos menus principais. Após executar o comando, o relatório será gerado (<PCBLibraryDocumentName>.CMP) na mesma pasta do documento de biblioteca de PCB de origem e será aberto automaticamente como o documento ativo na janela principal de projeto. O relatório apresenta informações que incluem as dimensões do footprint e um detalhamento dos objetos primitivos que o compõem, bem como as camadas em que estão localizados.

O relatório será adicionado ao painel Projects como um documento avulso na subpasta Documentation\Text Documents.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents