Modelos de componentes

Para ajudar a simplificar a criação dos seus componentes, o Altium Designer, em conjunto com seu Workspace conectado, permite criar e definir Component Templates (Itens de Modelo de Componente) nesse Workspace. Assim como um modelo de esquemático pode ser usado para predefinir informações nas folhas de esquemático que o referenciam, um modelo de componente é referenciado por um componente da biblioteca do Workspace e fornece configurações predefinidas para uso na definição desse componente.

Em particular, os modelos de componente foram desenvolvidos com foco nas informações paramétricas, permitindo definir, em um único local, um conjunto de parâmetros que ficará disponível para o componente que referencia o modelo. Por meio do modelo, você pode controlar quais desses parâmetros ficarão visíveis, preencher valores padrão e até marcar como obrigatórios os parâmetros necessários. Verificações de validação são realizadas ao salvar o componente para garantir a conformidade.

Os valores padrão especificados para muitas das configurações do modelo podem ser bloqueados como somente leitura ou disponibilizados seletivamente para que o projetista os substitua ao definir um componente.

Um modelo de componente também é a base para criar um componente genérico. Para saber mais, consulte a página Criação de Componentes Genéricos.

O acesso aos modelos de componente dependerá do licenciamento do software. Para obter mais informações, consulte a caixa Note no lado direito da página.

Esses modelos de componente são criados diretamente no Workspace. Depois que um modelo de componente é criado (e seus dados são salvos em uma revisão), ele pode ser reutilizado na criação de um ou mais componentes.

Tipo de Pasta

Ao criar a pasta na qual os modelos de componente serão armazenados, você pode especificar o tipo da pasta. Isso não afeta o conteúdo da pasta — a liberação de um modelo de componente sempre resultará em um Item de Modelo de Componente correspondente. Esse tipo apenas fornece uma indicação visual do que está armazenado na pasta e pode ser útil ao navegar pelo Workspace em busca de conteúdo específico. Para designar uma pasta como local de armazenamento de modelos de componente, defina seu Folder Type como Component Templates ao configurar as propriedades da pasta na caixa de diálogo Editar Pasta.

Especificar o tipo da pasta — seu uso pretendido — fornece uma indicação visual do conteúdo dessa pasta ao navegar pelo Workspace.
Especificar o tipo da pasta — seu uso pretendido — fornece uma indicação visual do conteúdo dessa pasta ao navegar pelo Workspace.

Tipo de Conteúdo

Ao criar um Item de Modelo de Componente de destino no qual armazenar seu modelo de componente, certifique-se de que seu Content Type esteja definido como Component Template na caixa de diálogo Criar Novo Item. Se você estiver criando o Item em uma pasta do tipo Component Templates, esse tipo de conteúdo estará disponível no menu de contexto acessado com o botão direito do mouse durante a criação do Item.

Criação de um modelo de componente em uma pasta Component Templates — o Content Type correto está disponível no menu de contexto.
Criação de um modelo de componente em uma pasta Component Templates — o Content Type correto está disponível no menu de contexto.

Como Salvar um Modelo de Componente

Related page: Criação & Edição de Conteúdo

Até aqui, discutimos o suporte a modelos de componente no Workspace em termos dos tipos de pasta e de conteúdo relacionados. Salvar um modelo de componente já definido em uma revisão de um Item de Modelo de Componente pode ser feito de maneira simplificada.

Um modelo de componente pode ser editado e salvo na revisão inicial de um Item de Modelo de Componente recém-criado, graças ao suporte do Workspace à edição direta. A edição direta elimina a necessidade de manter dados de origem separados sob controle de versão. Você pode simplesmente editar um tipo de conteúdo compatível usando um editor temporário carregado com os dados de origem mais recentes diretamente do próprio Workspace. Quando a edição é concluída, a entidade é salva (ou salva novamente) em uma revisão subsequente planejada de seu Item pai, e o editor temporário é fechado. Não há arquivos no seu disco rígido, dúvidas sobre estar trabalhando com os dados de origem corretos ou mais recentes, nem necessidade de manter um software separado de controle de versão. O Workspace cuida de tudo, com alto nível de integridade e de uma forma que agiliza consideravelmente as alterações nos seus dados.

Ao criar um Item de Template de Componente, você tem a opção de editar e salvar um template de componente na revisão inicial desse Item após sua criação. Para isso, habilite a opção Open for editing after creation, na parte inferior da caixa de diálogo Criar Novo Item (habilitada por padrão). O Item será criado e o Editor de Templates de Componentes temporário será aberto, apresentando um documento .CMPT como documento ativo na janela principal de projeto. Esse documento será nomeado de acordo com o Item e sua revisão, no formato: <Item><Revision>.CMPT (por exemplo, CMPT-0001-1.CMPT).

 
 
 
 
 

Exemplo de edição da revisão inicial de um template de componente diretamente no Workspace – o Editor de Templates de Componentes temporário fornece o documento no qual você pode definir seu template de componente.
Exemplo de edição da revisão inicial de um template de componente diretamente no Workspace – o Editor de Templates de Componentes temporário fornece o documento no qual você pode definir seu template de componente.

Use o documento para definir o template de componente conforme necessário. Para obter mais informações sobre como fazer isso, consulte Definição do Template.

Há três controles relevantes para a edição direta, disponíveis no Quick Access Bar (no canto superior esquerdo da janela principal do aplicativo) ou na barra de ferramentas Component Template Standard:

  • – Save Active Document. Use este botão para salvar localmente as alterações feitas no documento. Isso permite salvar as alterações atuais caso você queira voltar mais tarde para fazer outras alterações antes de salvar definitivamente no Workspace.
  • / – Save to Server. Use este botão para salvar o template de componente definido no Workspace, armazenando-o na revisão inicial (planejada) do Item de Template de Componente de destino. A caixa de diálogo Edit Revision será exibida, na qual você poderá alterar o Nome e a Descrição e adicionar notas de lançamento conforme necessário. O documento e o editor serão fechados após o salvamento. O documento que contém o template de componente de origem, *.CMPT, será armazenado na revisão do Item.

    Um controle Save to Server também está disponível à direita da entrada do template de componente, no próprio painel Projetos .
  • / – Discard Local Changes. Use este botão se quiser cancelar a edição e descartar as alterações feitas. O documento e o editor serão fechados, e nada será liberado para o Item de Template de Componente de destino.

Esses controles também estão disponíveis como comandos – Save (Atalho: Ctrl+S), Save to Server (Atalho: Ctrl+Alt+S) e Discard Local Changes – no menu principal File e no menu de contexto da entrada do template de componente no painel Projects.

Os dados salvos no Workspace consistem no template de componente de origem, definido no arquivo de Template de Componente (<Item><Revision>.CMPT).

 
 
 
 
 

Exemplo de template de componente definido e salvo de volta no Workspace.
Exemplo de template de componente definido e salvo de volta no Workspace.

Herança de um Template de Componente

Este recurso está disponível quando a opção UI.ComponentTemplateInheritance está habilitada na caixa de diálogo Configurações Avançadas.

Você pode usar um template de componente do tipo de componente raiz se o subtipo não tiver um template de componente vinculado. Ao criar uma hierarquia de tipos de componentes, os subtipos de componentes herdarão o template de componente atribuído ao tipo de componente raiz/pai.

O Editor CMPT (Template de Componente)

Para acessar o Editor de Templates de Componentes no Altium Designer, a extensão de software Component Template Editor deve estar instalada. Essa extensão é instalada com o Altium Designer por padrão. Ela pode ser instalada ou removida manualmente.

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definição do Template

O Editor de Templates de Componentes é basicamente dividido em duas regiões principais, ilustradas na imagem a seguir e resumidas logo depois.

 
 
 
 
 

O Editor de Templates de Componentes pode ser dividido, de forma geral, em duas regiões principais.
O Editor de Templates de Componentes pode ser dividido, de forma geral, em duas regiões principais.

  1. Upper Region – para definir opções no nível do componente (opções de ciclo de vida, nomenclatura e pasta) para um componente que referencia o template.
  2. Lower Region – para definir os parâmetros a serem usados por um componente que referencia o template.

Especificação das Opções do Componente

A metade superior do editor é dedicada à definição dos valores padrão para as seguintes propriedades do componente:

  • Lifecycle Definition – escolha a definição de ciclo de vida a ser aplicada a um componente criado usando o template. O campo suspenso lista todas as definições configuradas para o Workspace e permitidas para uso por um componente.

  • Revision Naming – escolha o esquema de nomenclatura de revisões a ser aplicado a um componente criado usando o template. O campo suspenso lista todos os esquemas configurados para o Workspace e permitidos para uso por um componente.

    Se a opção para controlar o uso de definições de ciclo de vida e esquemas de nomenclatura de revisões por tipo de conteúdo estiver habilitada para alguma definição ou esquema, e o tipo de conteúdo Componente não estiver configurado para usar uma definição ou esquema específico, essa definição ou esquema não estará disponível na lista suspensa correspondente.

  • Component Naming – use este campo para definir um Esquema de Nomenclatura de Itens padrão para um componente criado usando o modelo, garantindo um ID exclusivo para o componente resultante no Workspace. A entrada neste campo será usada como modelo para nomear automaticamente o componente (no campo Id associado (ao usar o Editor de Componentes no modo Single Component Editing), ou no campo Item ID (ao usar o Editor de Componentes no modo Batch Component Editing)). O software atribuirá automaticamente o próximo ID exclusivo disponível com base nesse esquema, após verificar todo o Workspace e os identificadores do conteúdo existente. Um esquema de nomenclatura de itens padrão – CMP-{00000} – é fornecido, mas você pode, naturalmente, criar seu próprio esquema digitando-o no campo e garantindo que a parte variável esteja entre chaves (por exemplo, CMP-001-{0000}).

  • Default Folder – para especificar uma pasta padrão no Workspace de destino onde um componente salvo será armazenado. Para isso, clique no botão Choose para acessar a caixa de diálogo Choose Folder (uma versão do painel Explorer), na qual você pode navegar até uma pasta existente no Workspace e selecioná-la, ou criar uma nova no momento.

Não há um campo para definir o Workspace de destino, pois ele será fixado para usar o mesmo Workspace em que reside a revisão do modelo de componente.

A opção Allow override de cada propriedade pode ser usada para controlar individualmente se essa propriedade pode ser alterada (habilitada) ou não (desabilitada) pelo usuário ao definir um componente no Editor de Componentes.

Quando o modelo é referenciado, as entradas especificadas nesta região são usadas para preencher previamente os campos correspondentes no Editor de Componentes (quando disponíveis):

  • Single Component Editing mode – os campos Id e Folder, na área Advanced Settings da região Component.
  • Batch Component Editing mode – na aba Document Options da caixa de diálogo Opções do Documento e, consequentemente, nos campos Item ID e FolderPath, na área Component da região de definições de componentes.

Quando o modelo é referenciado, as entradas são usadas para preencher previamente os campos correspondentes ao editar um componente no Editor de Componentes no modo Single Component Editing (à esquerda) e no modo Batch Component Editing (à direita).
Quando o modelo é referenciado, as entradas são usadas para preencher previamente os campos correspondentes ao editar um componente no Editor de Componentes no modo Single Component Editing (à esquerda) e no modo Batch Component Editing (à direita).

Definição de parâmetros

A metade inferior do editor é dedicada à definição e ao gerenciamento dos parâmetros que serão disponibilizados a um componente que referencie o modelo.

 
 
 
 
 

Exemplos de parâmetros definidos em um modelo de componente.
Exemplos de parâmetros definidos em um modelo de componente.

Parâmetros padrão do sistema

Vários parâmetros do sistema são incluídos por padrão ao criar um novo modelo de componente, conforme ilustrado na imagem a seguir e detalhado posteriormente.

 
 
 
 
 

Parâmetros padrão do sistema incluídos em um modelo de componente recém-criado.
Parâmetros padrão do sistema incluídos em um modelo de componente recém-criado.

  • ComponentType – este parâmetro permite especificar o tipo de componente. Isso facilita buscas direcionadas por meio do poderoso recurso de pesquisa do Workspace – um recurso que permite não apenas pesquisar por tipo de componente, mas também realizar buscas mais inteligentes, com suporte a parâmetros de componentes que reconhecem unidades de medida. Ao navegar pelos componentes do seu Workspace usando o painel Componentes, o agrupamento Categories dos componentes é derivado dos parâmetros ComponentType associados a cada componente. Clique no campo Default Value associado e, em seguida, no botão para acessar a caixa de diálogo Choose component type. Use-a para selecionar o tipo de componente desejado e clique em OK – o tipo escolhido será inserido como valor do parâmetro ComponentType, de volta à grade principal de parâmetros.

    A caixa de diálogo Choose component type reflete o conjunto de tipos de componentes definidos na página Gerenciamento de Dados – Tipos de Componentes da caixa de diálogo Preferences. Clique no botão na parte inferior da caixa de diálogo Choose component type para acessar essa página de preferências, onde você pode personalizar essa lista para atender melhor às suas necessidades – adicionando novos tipos e subtipos ou editando e removendo tipos existentes.

    Exemplo de modelo de componente, com o parâmetro do sistema ComponentType definido como Diodes.
    Exemplo de modelo de componente, com o parâmetro do sistema ComponentType definido como Diodes.

     
     
     
     
     

    O tipo de dados deste parâmetro está definido como ComponentType e não pode ser modificado. Além disso, o parâmetro ComponentType não pode ser copiado nem removido. Selecione a célula e use a tecla Delete para limpar o valor.

  • SCHLIB e PCBLIB – estes dois parâmetros permitem especificar modelos padrão de símbolo e footprint, respectivamente. Clique no campo Default Value associado a cada parâmetro e, em seguida, clique no botão para acessar uma caixa de diálogo na qual poderá escolher o modelo desejado.

    Observe que você está escolhendo o modelo, e não uma revisão específica desse modelo. Dessa forma, um componente que utiliza o template sempre usará a revisão mais recente do modelo escolhido.

    Especifique modelos de símbolo e footprint como parte do seu template.
    Especifique modelos de símbolo e footprint como parte do seu template.

     
     
     
     
     

    Os tipos de dados destes parâmetros estão definidos como SCHLIB e PCBLIB, respectivamente, e não podem ser modificados. Além disso, os parâmetros de modelo não podem ser copiados nem removidos. Selecione a célula e use a tecla Delete para limpar o valor.

  • Name e Description – estes dois parâmetros permitem definir o nome e a descrição do componente, respectivamente. Insira os textos desejados no campo Default Value associado a cada parâmetro.

    Especifique os parâmetros Name e Description como parte do seu template.
    Especifique os parâmetros Name e Description como parte do seu template.

     
     
     
     
     

    O tipo de dados de ambos os parâmetros está definido como Text e não pode ser modificado. Além disso, estes parâmetros não podem ser copiados nem removidos.

Adição de um novo parâmetro de usuário

Para adicionar um novo parâmetro de usuário à lista, clique no botão (ou use o comando Add no menu de contexto acessado com o botão direito do mouse) – o parâmetro será adicionado ao final da lista atual.

 
 
 
 
 

Exemplo de adição de um novo parâmetro de usuário ao template.
Exemplo de adição de um novo parâmetro de usuário ao template.

Cada parâmetro é apresentado na grade com as seguintes informações:

  • Name – use este campo para nomear o parâmetro, geralmente com um nome significativo que indique sua finalidade. Ao serem adicionados inicialmente, os parâmetros receberão nomes padrão (Parameter, Parameter 1, Parameter 2 e assim por diante).

  • Type – o tipo de parâmetro. Inicialmente, esta entrada terá como padrão Text, mas há suporte para uma variedade de tipos de dados com reconhecimento de unidades, bem como para o tipo PCBLIB, que facilita a definição de múltiplos footprints, e HarnessWiring, que facilita a definição de um componente de fiação de chicote. Também há suporte para tipos de parâmetros definidos pelos dicionários disponíveis – saiba mais.

  • Visible – habilite esta opção (que é o estado padrão de um parâmetro recém-adicionado) para que a opção Show correspondente ao parâmetro seja habilitada ao editar um ou mais componentes no Editor de Componentes (configurado no modo Batch Component Editing). Isso, por sua vez, controla a exibição da coluna correspondente a esse parâmetro na região inferior do Editor de Componentes, onde são definidas as próprias definições dos componentes. Esta propriedade não tem efeito ao definir um componente usando o modo Single Component Editing do editor.

  • Read Only – habilite esta opção para tornar o parâmetro somente leitura. Ao editar um componente que faz referência ao modelo, o valor do parâmetro não poderá ser editado.

  • Required – habilite esta opção para tornar o parâmetro um 'parâmetro obrigatório'. Ao editar um componente que faz referência ao modelo, o parâmetro deverá ter um valor definido; caso contrário, não será possível salvar o componente. No Editor de Componentes, esse parâmetro é identificado pela célula de valor com uma borda vermelha (no modo Batch Component Editing) ou contendo o ícone (no modo Single Component Editing), quando nenhum valor tiver sido inserido.

  • Default Value – use este campo para inserir um valor padrão para o parâmetro.

    • Se o parâmetro estiver marcado como obrigatório (opção Required habilitada) e também tiver sido definido como somente leitura (opção Read Only habilitada), um valor padrão MUST ser inserido. Caso contrário, ao editar um componente que faz referência ao modelo, o parâmetro será sinalizado como sem valor, mas isso não poderá ser resolvido porque o parâmetro não é editável, pois é somente leitura. Uma nova revisão deste modelo de componente não poderá ser salva no Workspace até que isso seja resolvido.

    • Ao editar uma revisão de um componente, um parâmetro existente definido pelo usuário que tenha o mesmo nome de um parâmetro no modelo de componente vinculado será substituído pela versão do modelo. Qualquer valor existente desse parâmetro será mantido (e não será sobrescrito pelo valor padrão do modelo).

  • Description – adicione uma descrição para o parâmetro, por exemplo, uma nota concisa sobre o que ele oferece. Se um parâmetro no modelo tiver uma descrição definida, a coluna Description será apresentada na região Parameters do Editor de Componentes em seu Single Component Editing, conforme apropriado.

A lista de parâmetros também permite ações simples de copiar e colar, permitindo duplicar um ou mais parâmetros de usuário existentes. Os parâmetros colados serão adicionados ao final da lista.

Os atalhos padrão de copiar (Ctrl+C) e colar (Ctrl+V) são suportados, e esses comandos também estão disponíveis no menu do botão direito. Vários parâmetros de usuário podem ser selecionados para operações de copiar e colar usando as técnicas padrão de Ctrl+Click e Shift+Click.
Para excluir um ou mais parâmetros de usuário da lista, selecione cada parâmetro e clique no botão , ou use o comando Remove no menu de contexto do botão direito.

Tipos de dados de parâmetros de componentes com reconhecimento de unidades

O Editor de Modelos de Componentes permite definir tipos de dados explícitos para os parâmetros de componentes definidos em um modelo de componente (*.CMPT). Além disso, esses tipos de dados reconhecem unidades, com suporte a diversos prefixos de unidades comuns. Assim, você pode inserir o valor de um parâmetro em vários formatos — como 2.2k, 2k2, 4M, 2.5GHz — e o Workspace possui a inteligência necessária para reconhecer o valor numérico dessas entradas.

Esse recurso de um modelo de componente facilita buscas direcionadas por meio do recurso de Pesquisa Avançada do servidor — um recurso que permite pesquisar não apenas por tipo de componente, mas também de forma mais inteligente, usando buscas por intervalos. Com o poder dos parâmetros de componentes que reconhecem unidades, você pode definir rapidamente uma pesquisa, por exemplo, para encontrar todos os capacitores com capacitância entre 47uF e 220uF.

Os parâmetros com reconhecimento de unidades também são usados para filtragem inteligente ao pesquisar seus próprios componentes usando o painel Componentes.

Use as seções recolhíveis a seguir para saber mais sobre os parâmetros com reconhecimento de unidades.

Tipos de dados de parâmetros definidos por dicionários

Dicionários são tipos de parâmetros personalizados com vários valores definidos. Os dicionários são gerenciados pelos administradores do Workspace na página Settings – Vault – Dictionaries da interface do Workspace no navegador, que pode ser acessada a partir do Editor de Modelos de Componentes selecionando a opção Add New Dictionary na lista suspensa Type ou clicando no controle Manage Dictionaries no canto superior direito da região Parameters.

  • A página Settings – Vault – Dictionaries também pode ser acessada na página Gerenciamento de dados – Dicionários da caixa de diálogo Preferences, clicando no controle Manage Dictionaries, e na página Gerenciamento de dados – Servidores da caixa de diálogo Preferences, clicando no controle Properties do Workspace ativo ou de um Workspace conhecido e selecionando a opção Dictionaries no menu.

  • Quando um tipo definido por dicionário é selecionado para um parâmetro, a página Settings – Vault – Dictionaries também pode ser acessada clicando na célula do parâmetro na coluna Type e, em seguida, clicando no botão  ().

Acesse a página de gerenciamento de dicionários na interface do Workspace no navegador a partir do Editor de Modelos de Componentes.
Acesse a página de gerenciamento de dicionários na interface do Workspace no navegador a partir do Editor de Modelos de Componentes.

Saiba mais sobre o gerenciamento de dicionários na interface do Workspace no navegador (Altium 365 Workspace, Enterprise Server Workspace).

Os dicionários definidos estão disponíveis como tipos de parâmetros na lista suspensa Type.

Selecione um tipo de parâmetro definido por dicionário na lista suspensa Tipo.
Selecione um tipo de parâmetro definido por dicionário na lista suspensa Tipo.

Os valores definidos para o tipo selecionado estão disponíveis na lista suspensa Default Value. Selecione o valor desejado para usar como padrão do parâmetro ou selecione <None>.

Selecione um valor padrão entre os valores definidos para o tipo selecionado.
Selecione um valor padrão entre os valores definidos para o tipo selecionado.

  • Os valores padrão são validados ao salvar o modelo de componente no Workspace. Se o valor padrão se tornar incompatível com o dicionário (por exemplo, se o valor tiver sido removido do dicionário e, em seguida, o modelo que usa esse valor tiver sido aberto para edição), esse valor padrão será destacado em vermelho na coluna Valor padrão, e uma mensagem de erro será exibida no painel Messages ao tentar salvar o modelo novamente no Workspace.

  • Se o valor de um parâmetro de componente se tornar incompatível com o dicionário (por exemplo, se o tipo desse parâmetro tiver sido alterado de Texto para um tipo definido por dicionário no modelo de componente e o valor atual do componente não corresponder a nenhum valor do tipo selecionado), esse parâmetro será destacado ao editar o componente no Editor de Componentes: um ícone de ponto de exclamação será exibido ao lado do valor incompatível ao editar o componente no modo Edição de Componente Único do editor, e o valor do parâmetro será destacado em vermelho ao editar o componente no modo Edição de Componentes em Lote. Certifique-se de que todos os parâmetros do componente sejam compatíveis com os valores do modelo; caso contrário, você não poderá salvar o componente na próxima revisão.

  • Se os dicionários tiverem sido alterados na interface do Workspace conectado no navegador, será necessário desconectar-se do Workspace e reconectar-se a ele para que essas alterações sejam refletidas no Altium Designer. Consulte a página Acessando seu Workspace para saber mais.

Definindo múltiplos footprints

O Editor de Modelos de Componentes também oferece suporte à definição de múltiplos footprints de PCB como parte de um modelo de componente. É possível especificar qualquer quantidade de vínculos com modelos de footprint, um recurso útil para quem deseja criar componentes que façam referência a 3 footprints, atendendo aos requisitos do IPC para diferentes níveis de densidade: L (menor, ou mínimo de cobre), M (maior, ou máximo de cobre) e N (nominal, ou quantidade mediana de cobre).

Para adicionar uma definição de modelo de footprint ao modelo de componente, clique em para adicionar um novo parâmetro e, em seguida, escolha a opção PCBLIB no menu suspenso associado ao campo Type.

Transforme um parâmetro recém-adicionado em uma definição de modelo de footprint definindo seu Type como PCBLIB.
Transforme um parâmetro recém-adicionado em uma definição de modelo de footprint definindo seu Type como PCBLIB.

O nome do parâmetro mudará de Parameter para PCBLIB n, em que n é o próximo número inteiro disponível para distinguir os vários modelos de footprint (por exemplo, PCBLIB 1, PCBLIB 2 e assim por diante). O modelo padrão será aquele associado à entrada PCBLIB. Quando os footprints forem importados para o Editor de Componentes, durante a definição de um componente, o modelo de footprint padrão será identificado pelo ícone no canto superior esquerdo da janela de visualização do modelo (no modo Single Component Editing) e pela entrada PCBLIB (default) na região Required Models/Parameters (no modo Batch Component Editing).

Um exemplo de componente definido no Editor de Componentes (modo Single Component Editing), usando um modelo de componente referenciado. O modelo tem três modelos de footprint definidos, que são incorporados à definição do componente. Observe que a entrada de modelo PCBLIB no modelo de componente é usada como o modelo de footprint padrão (identificado por um ícone no canto superior esquerdo) ao definir o componente. Passe o cursor sobre a imagem para ver o mesmo componente sendo definido com o Editor de Componentes no modo Batch Component Editing. Nesse caso, o footprint padrão é denominado PCBLIB (default).
Um exemplo de componente definido no Editor de Componentes (modo Single Component Editing), usando um modelo de componente referenciado. O modelo tem três modelos de footprint definidos, que são incorporados à definição do componente. Observe que a entrada de modelo PCBLIB no modelo de componente é usada como o modelo de footprint padrão (identificado por um ícone no canto superior esquerdo) ao definir o componente. Passe o cursor sobre a imagem para ver o mesmo componente sendo definido com o Editor de Componentes no modo Batch Component Editing. Nesse caso, o footprint padrão é denominado PCBLIB (default).

Importação e exportação de modelos de componente

Um arquivo de modelo de componente existente (*.CMPT) ou um arquivo de biblioteca de componentes (*.CMPLIB) pode ser importado para o editor de modelos de componente, e o modelo de componente em edição pode ser exportado para um arquivo de modelo de componente (*.CMPT). Use os comandos File » Import » Component Template, File » Import » Component Library e File » Export do menu principal do editor de componentes para selecionar a ação desejada e a caixa de diálogo padrão do Windows que se abre para navegar até o local necessário e selecionar um arquivo para importar ou definir o nome do arquivo que será exportado.

Reutilização de um modelo de componente

O uso de uma revisão de um modelo de componente — ou, mais precisamente, a referência a uma delas a partir da revisão de um componente que você está editando — pode ser feito das seguintes maneiras.

Um componente só pode referenciar um modelo de componente por vez.

Ao criar um novo componente

Ao criar um novo componente usando o comando File » New » Component nos menus principais, você pode escolher o modelo na caixa de diálogo Create new component.

Vinculação rápida de um modelo de componente a partir de uma lista de todos os modelos disponíveis, ao criar um novo componente.
Vinculação rápida de um modelo de componente a partir de uma lista de todos os modelos disponíveis, ao criar um novo componente.

Manualmente no Editor de Componentes

A reutilização de uma revisão de um modelo de componente no Editor de Componentes depende do modo de operação do editor.

No modo de edição de componente único

Ao editar um único componente nesse modo do Editor de Componentes, escolha o modelo de componente necessário no menu suspenso associado ao campo Template — parte do grupo Advanced Settings, na região Component do editor. Todos os modelos de componente disponíveis no mesmo Workspace em que o próprio componente reside são listados por nome, com suas revisões mais recentes indicadas entre colchetes. Escolha o modelo desejado para aplicá-lo.

Vinculação rápida de um modelo de componente a partir de um menu com todos os modelos disponíveis, ao editar a revisão de um componente usando o Editor de Componentes no modo Single Component Editing.
Vinculação rápida de um modelo de componente a partir de um menu com todos os modelos disponíveis, ao editar a revisão de um componente usando o Editor de Componentes no modo Single Component Editing.

No modo de edição de componentes em lote

Há duas maneiras de vincular uma revisão de um modelo de componente à revisão do componente que está sendo editada:

  • Na guia Template da caixa de diálogo Opções do Documento (Edit » Document Options). Clique no botão Choose à direita do campo Item Revision. Isso dá acesso à caixa de diálogo Choose Item (uma versão do painel Explorer). Use essa caixa de diálogo para localizar e selecionar a revisão do modelo de componente desejado. Após clicar em OK, será criado um vínculo entre a revisão do componente e a revisão de destino do modelo de componente. Esse vínculo pode ser verificado na guia Template da caixa de diálogo Document Options.

    Vinculação manual de um componente a uma revisão de um modelo de componente no Workspace de destino.
    Vinculação manual de um componente a uma revisão de um modelo de componente no Workspace de destino.

    O modelo de componente utilizado pode ser alterado a qualquer momento — clique em Choose e selecione uma revisão de outro modelo de componente.
    O status da revisão do item de modelo de componente vinculado é indicado na guia Template da caixa de diálogo Document Options. Se uma revisão mais recente do item vinculado estiver disponível, clique no botão para usar essa revisão mais recente.
  • No menu Add associado à região Required Models/Parameters do Editor de Componentes. O submenu Templates lista todos os modelos de componente por nome que estão disponíveis no mesmo Workspace em que o próprio componente reside, com suas revisões mais recentes indicadas entre colchetes. Clique em uma entrada para criar um vínculo com a revisão mais recente desse modelo de componente. Novamente, o vínculo pode ser verificado na guia Templates da caixa de diálogo Document Options.

    Vinculação rápida de um modelo de componente a partir de um menu com todos os modelos disponíveis.
    Vinculação rápida de um modelo de componente a partir de um menu com todos os modelos disponíveis.

Herdado da pasta de componentes do Workspace

Você pode especificar um modelo de componente para ser usado automaticamente em todos os componentes (e suas revisões) armazenados em uma pasta de componentes no Workspace.

Um modelo de componente padrão só pode ser definido para uma pasta do tipo Components.

Especifique o modelo desejado usando o campo Component Template ao definir as propriedades da pasta, na caixa de diálogo Editar Pasta. A lista suspensa associada ao campo lista todos os modelos de componente por nome que estão disponíveis no mesmo Workspace em que a própria pasta de componentes reside, com suas revisões mais recentes indicadas entre colchetes. Escolha uma entrada para criar um vínculo com a revisão mais recente desse modelo de componente para cada componente criado posteriormente nessa pasta.

Especifique um modelo de componente padrão a ser aplicado a todos os componentes criados na pasta de componentes pai.
Especifique um modelo de componente padrão a ser aplicado a todos os componentes criados na pasta de componentes pai.

Para não usar esse recurso, deixe/defina o campo Component Template como None.

Se um modelo de componente for escolhido no nível da pasta, esse mesmo modelo será usado, por padrão, quando forem criados componentes nas subpastas filhas. Isso facilita a herança rápida do modelo para todos os componentes nas pastas filhas.

Quando uma revisão de um componente é salva no Workspace, ela fixa a revisão específica do modelo de componente utilizado — criando um vínculo forte com essa revisão, a menos que ele seja alterado manualmente.

Impacto nos modelos e parâmetros do componente ao usar um modelo de componente

Ao editar uma revisão de um componente, quando uma revisão de um modelo de componente é vinculada/referenciada, ocorre o seguinte no Editor de Componentes em relação aos modelos e parâmetros:

  • Os modelos definidos no modelo de componente referenciado são adicionados à região Models (modo Single Component Editing) e à região Model Links (modo Batch Component Editing).
  • Um modelo referenciado existente será mantido, e o componente continuará usando esse modelo, a menos que seja alterado manualmente de forma intencional.
  • Os parâmetros definidos no modelo de componente referenciado são adicionados à região Parameters (modo Single Component Editing) e à região Required Models/Parameters (modo Batch Component Editing).

    Exemplo de parâmetros após a vinculação a uma revisão de um modelo de componente, ao usar o Editor de Componentes no modo Single Component Editing (à esquerda) e no modo Batch Component Editing (à direita).
    Exemplo de parâmetros após a vinculação a uma revisão de um modelo de componente, ao usar o Editor de Componentes no modo Single Component Editing (à esquerda) e no modo Batch Component Editing (à direita).

    Todos os parâmetros originados do modelo de componente referenciado são identificados pelo ícone (modo Single Component Editing) e pelo ícone (modo Batch Component Editing). Além disso, somente no modo de edição de componentes em lote, a opção Show de cada parâmetro baseado no modelo de componente segue o estado da opção Visible correspondente no modelo de componente.
    Os parâmetros baseados no modelo de componente não podem ser removidos.
    Você pode adicionar outros parâmetros de usuário conforme necessário.
  • Somente no modo Batch Component Editing, os parâmetros baseados no modelo de componente configurados para serem exibidos são agrupados na área de definições de componentes do editor, com Template Parameters usado como texto do cabeçalho.

    Aparência de exemplos de parâmetros baseados em modelo na área onde as próprias definições de componentes são definidas, ao usar o Editor de Componentes no modo Batch Component Editing.
    Aparência de exemplos de parâmetros baseados em modelo na área onde as próprias definições de componentes são definidas, ao usar o Editor de Componentes no modo Batch Component Editing.

  • Os campos de valor dos parâmetros baseados em modelo que foram marcados como somente leitura não poderão ser editados. Para todos os outros parâmetros baseados em modelo que não foram marcados como somente leitura, você pode alterar os valores conforme necessário.

    Com o Editor de Componentes no modo Single Component Editing, um parâmetro de modelo somente leitura é identificado na região Parameters pelo ícone .
  • Se um parâmetro baseado em modelo tiver sido marcado como obrigatório, mas não tiver recebido um valor no modelo, seu campo de valor aparecerá com uma borda vermelha (no modo Batch Component Editing) ou com o ícone (no modo Single Component Editing), alertando que é necessário fornecer um valor para esse parâmetro. Você não poderá salvar um componente no Workspace até que os valores de todos os parâmetros obrigatórios sejam definidos.

    Com o Editor de Componentes no modo Single Component Editing, um parâmetro de modelo obrigatório é identificado na região Parameters pelo ícone .

Salvar novamente um modelo de componente

A qualquer momento, você pode retornar a qualquer revisão de um modelo de componente no Workspace e editá-la diretamente. Clique com o botão direito na revisão e escolha o comando Edit no menu de contexto. Novamente, o editor temporário será aberto, com o modelo contido na revisão aberto para edição. Faça as alterações necessárias e salve o modelo de componente na próxima revisão do Item.

Clicar com o botão direito na entrada de nível superior do próprio modelo de componente permitirá editar a revisão mais recente desse modelo.

Acesso ao comando para iniciar a edição direta de uma revisão existente de um modelo de componente.
Acesso ao comando para iniciar a edição direta de uma revisão existente de um modelo de componente.

Download de dados salvos

Baixe os dados armazenados em uma revisão de um modelo de componente clicando com o botão direito nessa revisão (no painel Explorer) e escolhendo o comando Operations » Download no menu de contexto. O arquivo do modelo de componente será baixado para uma subpasta no diretório escolhido, nomeada com o ID da revisão do Item. O arquivo pode ser encontrado na pasta Released dentro dessa subpasta.

Acesse o comando Download na entrada de nível superior do próprio modelo de componente para baixar o arquivo do modelo de componente armazenado na revisão mais recente desse modelo.
Clique no botão Explore na caixa de diálogo Download from Server para acessar rapidamente a pasta de download.

Exclusão lógica

Quando você está conectado a um Workspace, uma funcionalidade flexível permite remover um modelo de componente diretamente no Altium Designer, pelo painel Explorer. Clique com o botão direito na entrada do modelo de componente no painel e escolha o comando Delete Item no menu de contexto. A caixa de diálogo Delete Items será exibida para confirmar a exclusão. A ação é, na verdade, uma “exclusão lógica”, na qual o modelo de componente será movido para a área Trash do Workspace. A Trash é essencialmente uma lixeira para a qual qualquer conteúdo do Workspace pode ser movido (por meio de uma ação de exclusão lógica). Ela fica isolada do restante do Workspace.

Com o recurso de exclusão lógica, você pode excluir um modelo de componente que esteja sendo usado.
Vários modelos de componente podem ser excluídos em uma única ação. Selecione todos os modelos de componente desejados usando os controles padrão de seleção múltipla (Shift+Click, Ctrl+Click), clique com o botão direito e escolha o comando Delete Items no menu de contexto.

Exclusão lógica de um modelo de componente. O modelo será movido para a área Trash do Workspace.
Exclusão lógica de um modelo de componente. O modelo será movido para a área Trash do Workspace.

Para prosseguir com a exclusão, clique no botão . O item será removido e uma caixa de diálogo Deletion Summary confirmará que a exclusão foi realizada com sucesso. Se houver algum problema com a exclusão, você será informado.

Todo o conteúdo excluído dessa maneira pode ser encontrado na página Trash da interface do Workspace no navegador. Observe que você só pode visualizar o conteúdo que você mesmo excluiu logicamente. Os administradores poderão visualizar todo o conteúdo da página Trash, ou seja, todo o conteúdo que foi excluído logicamente.

Pontos a considerar em relação a um modelo de componente excluído logicamente:

  • O modelo de componente não estará disponível no seu software de projeto nem na interface Web.
  • Todos os locais onde o modelo de componente estava sendo usado indicarão que ele foi excluído.
  • Um modelo de componente pode ser restaurado ou excluído permanentemente na página Trash, desde que você tenha permissões de edição. A exclusão permanente só é possível se ele não estiver sendo usado por um Item pai.
Observe que, se você tiver excluído logicamente um modelo de componente — movendo-o para a Trash —, poderá criar novamente um modelo de componente com o mesmo nome. Se, posteriormente, você restaurar o modelo de componente original e o nome original já estiver em uso, será acrescentado um sufixo inteiro para manter seu nome exclusivo no Workspace.
AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents