Trabalhando com Pads e Vias

Num relance

Este artigo apresenta como pads e vias funcionam no Altium Designer, explicando o que são, como se diferenciam, onde são usados e como são posicionados e editados nos editores de PCB e de footprints de PCB. Também destaca os principais tipos de vias, descreve os fluxos de trabalho de posicionamento direto e conversão e aborda recursos do software relacionados ao desempenho no uso de modelos e no gerenciamento de vias. Se você deseja entender melhor os objetos essenciais de uma PCB que permitem a conexão de componentes e o roteamento entre camadas, este artigo ajudará você a explorar esses conceitos fundamentais com confiança. Continue lendo.

- Você aprenderá a diferença prática entre pads e vias, incluindo sua estrutura, finalidade e os principais tipos de vias usados em um projeto de PCB.
- Você verá como pads e vias podem ser posicionados, movidos, convertidos e atribuídos nos fluxos de trabalho do Altium Designer.
- Você terá uma visão geral de como as propriedades de pads e vias são gerenciadas, incluindo o uso de modelos e as principais opções de edição no painel Propriedades.
Aprofunde-se com a IA:

Resumo de pads e vias

Os pads são usados para fornecer fixação mecânica e conexões elétricas aos pinos dos componentes Os pads são usados para fornecer fixação mecânica e conexões elétricas aos pinos dos componentes

Um pad é um objeto primitivo de projeto. Os pads são usados para fixar o componente à placa e criar os pontos de interconexão entre os pinos do componente e o roteamento na placa. Os pads podem existir em uma única camada, por exemplo, como um pad de dispositivo de montagem em superfície, ou podem ser pads tridimensionais com furo passante, com um corpo em formato de barril no plano Z (vertical) e uma área plana em cada camada de cobre (horizontal). O corpo em formato de barril do pad é formado quando a placa é perfurada e os furos são metalizados durante a fabricação. Nos planos X e Y, os pads podem ter formato circular, retangular, octogonal, retangular com cantos arredondados, retangular com cantos chanfrados ou personalizado. Os pads podem ser usados individualmente como pads livres em um projeto ou, mais comumente, no editor de bibliotecas de PCB, onde são incorporados a outras primitivas para formar os footprints dos componentes.

Uma via que se estende da camada superior (vermelha) à camada inferior (azul), conectando-as, e também se conecta a um plano de alimentação interno (verde). 
Uma via que se estende da camada superior (vermelha) à camada inferior (azul), conectando-as, e também se conecta a um plano de alimentação interno (verde).

Uma via é um objeto primitivo de projeto. As vias são usadas para criar uma conexão elétrica vertical entre duas ou mais camadas elétricas de uma PCB. As vias são objetos tridimensionais e têm um corpo em formato de barril no plano Z (vertical), com um anel plano em cada camada de cobre (horizontal). O corpo em formato de barril da via é formado quando a placa é perfurada e os furos são metalizados durante a fabricação. As vias são circulares nos planos X e Y, assim como os pads redondos. A principal diferença entre uma via e um pad é que, além de poder atravessar todas as camadas da placa (de cima a baixo), uma via também pode se estender de uma camada de superfície a uma camada interna ou entre duas camadas internas.

As vias podem ser de um dos seguintes tipos:

  • Thru-Hole – este tipo de via atravessa a placa da camada superior à camada inferior e permite conexões com todas as camadas de sinal internas.
  • Blind – este tipo de via conecta a superfície da placa a uma camada de sinal interna.
  • Buried – este tipo de via conecta uma camada de sinal interna a outra camada de sinal interna.

Os tipos de via que podem ser usados no projeto são definidos em Layer Stack Manager. Para saber mais, consulte a página Definição de vias cegas, enterradas e microvias.

As definições de pads e vias também podem ser armazenadas em bibliotecas de modelos de pads e vias; consulte a página Como trabalhar com modelos e bibliotecas de pads e vias para saber mais.

Os modelos de pads e vias não vinculados a uma biblioteca externa de pads e vias são armazenados no documento PCB, permitindo tempos de carregamento menores.

Este recurso está disponível quando a opção PCB.Performance.PadViaTemplate.LoadingOptimization está habilitada na caixa de diálogo Configurações avançadas.

O editor de PCB utiliza o conceito de 'instanciação de vias', uma abordagem para construir a geometria de uma instância de via, em vez de um modelo de via. Isso melhora o desempenho e reduz tanto o consumo de memória quanto o tempo de construção da cena.

Este recurso está em Beta Aberto e está disponível quando a opção PCB.ViaInstancing está habilitada na caixa de diálogo Configurações avançadas.

Posicionamento direto de pads e vias

Os pads e as vias podem ser posicionados tanto no editor de PCB quanto no editor de footprints de PCB. As vias normalmente são posicionadas automaticamente durante os processos de roteamento interativo ou automático, mas podem ser posicionadas manualmente, se necessário. As vias posicionadas manualmente são chamadas de vias 'livres'. Após iniciar o comando de posicionamento de pad (Place » Pad) ou via (Place » Via), o cursor mudará para uma cruz e você entrará no modo de posicionamento.

  1. Posicione o cursor e clique ou pressione Enter para posicionar um pad ou uma via.
  2. Continue posicionando outros pads ou vias, ou clique com o botão direito ou pressione Esc para sair do modo de posicionamento.
Um pad ou uma via adotará o nome de uma net se for posicionado sobre um objeto que já esteja conectado a essa net.

Durante o posicionamento, pressione a tecla Alt para restringir a direção do movimento ao eixo horizontal ou vertical, dependendo da direção inicial do movimento.

Normalmente, as vias não são posicionadas manualmente; elas são posicionadas automaticamente como parte do processo de roteamento interativo. Consulte a seção Posicionamento de vias durante o roteamento interativo para saber mais.

Os pads livres na camada Multi-layer podem ser convertidos em vias. Um pad livre é aquele que não faz parte de um objeto de componente pai. A conversão de pads livres em vias pode ser útil ao converter manualmente arquivos Gerber importados de volta para o formato PCB. Selecione todos os pads livres que deseja converter no espaço de projeto e escolha o comando Tools » Convert » Convert Selected Free Pads to Vias nos menus principais. Os pads livres serão convertidos em vias com o mesmo tamanho de furo. O maior valor encontrado entre todos os pares de dimensões XY disponíveis para o pad (correspondentes ao tamanho do pad nas diferentes camadas) será usado como diâmetro da via.

As vias também podem ser convertidas em pads livres. A conversão de vias em pads livres pode ser útil ao importar arquivos PADS-PCB e PADS 2000, nos quais as vias são usadas para conectar camadas de alimentação e terra. Isso permite a conexão adequada aos planos de alimentação internos usando pads editáveis. Selecione todas as vias que deseja converter no espaço de projeto e escolha o comando Tools » Convert » Convert Selected Vias to Free Pads nos menus principais. As vias serão convertidas em pads livres do mesmo estilo (Simple, Top-Middle-Bottom ou Full Stack) e com o mesmo tamanho de furo. O diâmetro da via será usado para definir as dimensões XY do pad nas camadas aplicáveis. O formato do pad será definido como Round.

Edição gráfica

As propriedades dos pads e das vias não podem ser modificadas graficamente, exceto sua localização.

  • Para mover um pad livre e também mover as trilhas conectadas, clique no pad, mantenha o botão pressionado e mova-o. O roteamento conectado permanecerá ligado ao pad enquanto ele for movido. Observe que o pad não se moverá se pertencer a um componente.
  • Para mover um pad livre sem mover as trilhas conectadas no Editor de PCB ou no Editor de Biblioteca de PCB, selecione o comando Edit » Move » Move e, em seguida, clique no pad, mantenha o botão pressionado e mova-o.
  • Se você clicar e arrastar um retângulo de seleção ao redor de pads component, eles não serão selecionados, pois são, na verdade, objetos filhos do componente. Para selecionar apenas os pads, mantenha Ctrl pressionado enquanto clica e arrasta a janela de seleção.
  • Se uma via estiver sendo movida junto com o roteamento para liberar mais espaço para roteamento ou componentes, pode ser mais eficiente refazer o roteamento do que movê-lo. O software inclui um recurso chamado Loop Removal. Com esse recurso habilitado, você roteia por um novo caminho (começando e terminando em algum ponto do roteamento original); assim que clicar com o botão direito para sair do modo de roteamento interativo, o roteamento antigo (loop) será removido, incluindo quaisquer vias redundantes.

Edição não gráfica pelo painel Properties

Este método de edição usa o modo associado do painel Properties para modificar as propriedades de um objeto Pad/Via.

Alívios térmicos de pads e vias

O campo Thermal Relief na região Pad Stack / Via Stack do painel Properties resume a configuração de alívio térmico atualmente aplicada. Por exemplo, Relief, 15mil, 10mil, 4, 90 significa que:

  • a conexão com alívio térmico está aplicada;
  • a folga de isolamento tem 15mil de largura;
  • os condutores do alívio térmico têm 10mil de largura;
  • os condutores do alívio térmico têm rotação de 90 graus.

Quando a caixa de seleção no campo Thermal Relief está desmarcada, os alívios térmicos de pads e vias em polígonos são rules-driven, ou seja, esses alívios são definidos pelas regras de projeto de Estilo de conexão de polígonos aplicáveis. Para pads individuais, a configuração de alívio térmico pode ser personalizada habilitando a opção Thermal Relief associada à camada desejada. Nesse caso, os alívios térmicos são considerados custom. Saiba mais sobre Definição de alívios térmicos personalizados.

Expansões das máscaras de solda e de pasta

A máscara de solda é criada automaticamente no local de cada pad/via na camada de máscara de solda. A máscara de solda é definida em negativo, ou seja, os objetos posicionados definem aberturas na camada de máscara de solda. A máscara de pasta é criada automaticamente no local de cada pad na camada de máscara de pasta. A forma criada na camada de máscara corresponde à forma do pad/via, expandida ou contraída pelo valor especificado pelas regras de projeto Expansão da máscara de solda e Expansão da máscara de pasta definidas no editor de PCB ou conforme especificado no painel Properties.

Pads com a máscara de solda exibida.
Pads com a máscara de solda exibida.

Ao editar um pad ou uma via, você verá as configurações de expansão da máscara de solda e da máscara de pasta nas regiões Pad Stack e Solder Mask Expansion do painel Properties, respectivamente. Embora essas configurações permitam controlar localmente os requisitos de expansão de um pad/via, normalmente não será necessário usá-las. Em geral, é mais fácil controlar os requisitos de máscara de pasta e máscara de solda definindo as regras de projeto apropriadas no editor de PCB. Ao usar regras de projeto, uma regra é definida para configurar a expansão de todos os componentes da placa. Depois, se necessário, você pode adicionar outras regras para situações específicas, como todas as instâncias de um determinado tipo de footprint usado na placa ou um pad específico de um componente específico, etc.

  

Para configurar as expansões de máscara nas regras de projeto:

  1. Confirme se a opção Rule Expansion está selecionada como Shape na região Pad Stack do painel Properties (para pads) e/ou se a opção Rule está selecionada na região Solder Mask Expansion do painel Properties (para vias).

  2. No editor de PCB, selecione Design » Rules nos menus principais e examine as regras de projeto da categoria Mask na caixa de diálogo Editor de regras e restrições de PCB. Essas regras serão respeitadas quando o footprint for posicionado na PCB.

Para substituir as regras de projeto de expansão e especificar uma expansão de máscara como atributo do pad/via, selecione Manual Expansion como Shape na região Pad Stack do painel Properties (para pads) e/ou Manual na região Solder Mask Expansion do painel Properties (para vias) e digite os valores necessários.

A camada de máscara de pasta para pads de furo passante é compatível com documentos Draftsman e saídas Gerber, Gerber X2, ODB++, IPC-2581 e de impressão de PCB.
Para pads, você também pode selecionar manualmente uma forma de máscara em um conjunto padrão de formas predefinidas ou criar sua própria forma personalizada – saiba mais.

Cobertura de pads e vias com máscara de solda

A cobertura parcial e completa de pads e vias com máscara de solda pode ser obtida definindo um valor apropriado para a Expansão da máscara de solda. Essa restrição de expansão pode ser definida individualmente para cada objeto no painel Properties ou por meio de regras de projeto apropriadas de Expansão da máscara de solda. Ao configurar a expansão com um valor adequado, você pode obter o seguinte:

  • Para cobrir parcialmente um pad/via – cobrindo apenas a área de cobre, defina a Expansão como um valor negativo que feche a máscara até a borda do furo do pad/via.
  • Para cobrir completamente um pad/via – cobrindo a área de cobre e o furo, defina a Expansão como um valor negativo cujo módulo seja igual ou maior que o raio do pad/via.
  • Para cobrir todos os pads/vias em uma única camada, defina o valor de Expansão apropriado e certifique-se de que o escopo (Consulta completa) de uma regra de Expansão da máscara de solda abranja todos os pads/vias da camada desejada.
  • Para cobrir completamente todos os pads/vias em um projeto no qual estejam definidos diferentes tamanhos de via, defina a Expansão como um valor negativo cujo módulo seja igual ou maior que o maior raio de pad/via. Ao cobrir um pad/via individual, há opções para seguir a expansão definida na regra de projeto aplicável ou substituir a regra e aplicar uma expansão especificada diretamente ao pad/via em questão.

Pontos de teste

Related page: Atribuição de pontos de teste na placa

O software oferece suporte completo a pontos de teste, permitindo especificar pads (de furo passante ou SMD) e vias como locais de pontos de teste em testes de fabricação e/ou montagem. Um pad/via é designado para uso como ponto de teste por meio da configuração de suas propriedades de ponto de teste correspondentes – se deve ser um ponto de teste de fabricação ou de montagem e em qual lado da placa deve ser usado como ponto de teste. Essas propriedades estão disponíveis na região Testpoint do painel Propriedades .

Para agilizar o processo e reduzir a necessidade de configurar manualmente as propriedades dos pontos de teste, o software oferece um método para atribuir pontos de teste automaticamente com base nas regras de projeto definidas e usando o Gerenciador de pontos de teste (Tools » Testpoint Manager). Em cada caso, essa atribuição automática configura as propriedades de ponto de teste correspondentes para o pad/via.

Particularidades dos pads

Designadores de pads

Cada pad deve ser identificado com um designador (geralmente representando o número de um pino do componente) de até 20 caracteres alfanuméricos. Os designadores de pads serão incrementados automaticamente em uma unidade durante o posicionamento se o pad inicial tiver um designador que termine com um caractere numérico. Altere o designador do primeiro pad, antes do posicionamento, no painel Propriedades .

Para obter incrementos alfabéticos, por exemplo, 1A, 1B, ou incrementos numéricos diferentes de 1, use a caixa de diálogo Configurar matriz de colagem, acessada ao pressionar o botão Paste Array na caixa de diálogo Colar especial (Edit » Paste Special).

Recurso de colagem em matriz

Ao definir o designador do pad antes de copiá-lo para a área de transferência, você pode usar a caixa de diálogo Setup Paste Array para aplicar automaticamente uma sequência de designadores durante o posicionamento dos pads. Usando o campo Text Increment na caixa de diálogo Setup Paste Array, é possível posicionar as seguintes sequências de designadores de pads:

  • Numérica (1, 3, 5)
  • Alfabética (A, B, C)
  • Combinação alfanumérica (A1 A2, 1A 1B, A1 B1 ou 1A 2A, etc.)

Para incrementar numericamente, defina o campo Text Increment com o valor do incremento desejado. Para incrementar alfabeticamente, defina o campo Text Increment com a letra do alfabeto que representa o número de letras que você deseja avançar. Por exemplo, se o pad inicial tiver o designador 1A, defina o campo como A (primeira letra do alfabeto) para incrementar os designadores em 1. Se você definir o campo como C (terceira letra do alfabeto), os designadores serão 1A, 1D (três letras após A), 1G, etc.

Conexões por jumper

As conexões por jumper definem conexões elétricas entre pads de componentes que não são fisicamente roteadas com primitivas na PCB. Elas são especialmente úteis em placas de camada única, nas quais um fio é usado para passar por cima das trilhas da única camada física.

Os pads de um componente podem ser identificados com um valor Jumper no painel Properties. Pads que compartilham o mesmo Jumper e a mesma rede elétrica indicam ao sistema que existe uma conexão válida entre eles, embora não estejam fisicamente conectados.

As conexões por jumper são exibidas como linhas de conexão curvas no Editor de PCB. O verificador de regras de projeto não indicará conexões por jumper como redes não roteadas.

Detalhes das vias

Definição das propriedades das vias

Embora os requisitos de abrangência de camadas (plano Z) de cada tipo de via sejam definidos na aba Tipos de via do Gerenciador de empilhamento de camadas, as propriedades dimensionais da via são definidas por:

Configuração da regra de projeto de estilo de via de roteamento

Main page: Definição, delimitação do escopo e gerenciamento das regras de projeto de PCB

As propriedades dimensionais das vias posicionadas durante o roteamento interativo, o ActiveRouting ou o roteamento automático são controladas pela regra de projeto de estilo de via de roteamento aplicável. Para ajudar a selecionar as vias na regra de projeto, há um conjunto de palavras-chave de consulta relacionadas a vias que você pode usar no escopo da regra (Where the Object Matches); elas são detalhadas abaixo.

Quando você muda de camada durante o roteamento, o software verifica as camadas inicial e final dessa mudança e escolhe um tipo de via permitido em Layer Stack Manager. Em seguida, identifica a regra de projeto de estilo de via de roteamento aplicável com a maior prioridade e aplica à via que será posicionada as configurações dimensionais da seção Constraints dessa regra.

Por exemplo, você pode ter um conjunto de redes DRAM_DATA que exigem µVias para a transição da camada TopLayer para a S2 e da camada S2 para a S3, e uma via de furo passante para todas as outras transições de camada (que também é diferente da via exigida pelas outras redes). Isso pode ser tratado criando duas regras de projeto de estilo de via de roteamento para essas redes DRAM_DATA. Um exemplo de regra de projeto adequada para µVia é mostrado abaixo; passe o cursor sobre a imagem para exibir a regra de projeto para vias de furo passante.

O escopo das regras de projeto pode ser definido para aplicá-las a tipos específicos de vias.
O escopo das regras de projeto pode ser definido para aplicá-las a tipos específicos de vias.

Quando uma via é posicionada em um espaço livre, o software não consegue aplicar uma regra de projeto de estilo de roteamento durante o posicionamento. Nessa situação, a via padrão será posicionada.

Query Keywords

Para simplificar a definição do escopo das regras de projeto de estilo de via de roteamento, estão disponíveis as seguintes palavras-chave de consulta relacionadas a vias:

Via Type Query Returns
IsVia Todos os objetos de via, independentemente do tipo de via.
IsThruVia Todas as vias que se estendem da camada superior à camada inferior.
IsBlindVia Todas as vias que começam em uma camada externa e terminam em uma camada interna e que não são µVias.
IsBuriedVia Todas as vias que começam em uma camada interna e terminam em outra camada interna e que não são µVias.
IsMicroVia Todas as vias que têm a opção µVia habilitada e conectam camadas adjacentes.
IsSkipVia Todas as vias que têm a opção µVia habilitada e abrangem 2 camadas.

Use o recurso Máscara no Assistente de consultas para encontrar as palavras-chave disponíveis relacionadas a vias. Pressione F1 quando uma palavra-chave de consulta estiver selecionada na lista para obter ajuda sobre ela.

Posicionamento de vias durante o roteamento interativo

Quando você muda de camada durante o roteamento interativo, o software insere automaticamente uma via. A via escolhida depende dos seguintes fatores:

  • Os tipos de via disponíveis para as camadas abrangidas pela mudança de camada.
  • A regra de projeto de estilo de via de roteamento aplicável ao tipo de via selecionado para essa mudança de camada.

Para mudar de camada durante o roteamento interativo:

  • Pressione a tecla * no teclado numérico para avançar para a próxima camada de sinal.
  • Use a combinação Ctrl+Shift+WheelRoll para subir ou descer pelas camadas.

µVias empilhadas sendo posicionadas durante uma mudança de camada de L1 para L4. O modo Interactive Routing do painel Properties exibe os tipos de via que serão posicionados; pressione 6 para alternar entre os empilhamentos de vias possíveis; pressione 8 para exibir uma lista dos empilhamentos de vias possíveis.

Controle da via posicionada durante o roteamento interativo

  • À medida que você muda as camadas de roteamento, o software escolhe automaticamente o tipo de via mais adequado para abranger essas camadas.

  • Se houver vários tipos de via ou combinações (empilhamentos de vias) que possam ser usados, pressione a tecla de atalho 6 para alternar interativamente entre todos os empilhamentos de vias disponíveis para essa mudança de camada; pressione o atalho 8 para exibir uma lista. Os empilhamentos de vias são apresentados na seguinte ordem: usar µVia(s), usar µVia com salto de camada, usar via cega, usar via passante. Vias empilhadas podem ser posicionadas se a mudança de camada abranger mais de uma camada e houver tipos de via adequados definidos. Os tipos de via propostos são detalhados na barra de status e no visor Heads Up, por exemplo, [µVia 1:2, µVia 2:3, µVia 3:4], como mostrado na imagem acima.

  • O último empilhamento de vias utilizado é mantido como padrão para a próxima rede que você rotear. O empilhamento de vias padrão é mantido apenas durante a sessão de edição atual.

  • As propriedades dimensionais da via são especificadas pela regra de projeto de estilo de via de roteamento aplicável; as estratégias para definir uma regra de projeto de estilo de via de roteamento adequada são discutidas acima.

  • Para alterar interativamente as dimensões da via durante uma mudança de camada, pressione o atalho 4. Isso alternará entre os modos de tamanho de via: Rule Minimum; Rule Preferred; Rule Maximum; User Choice; o modo de tamanho de via atual será exibido no visor Heads Up e na barra de status (como mostrado na imagem acima). Se Escolha do usuário estiver selecionado, pressione Shift+V para abrir a caixa de diálogo Escolher tamanhos de via e selecionar o tamanho de via desejado. A lista de tamanhos de via disponíveis exibida na caixa de diálogo é obtida da lista de vias já utilizadas no projeto; consulte-as no modo Modelos de pads e vias do painel PCB.

    Se o modo Template preferred for usado na regra de projeto de estilo de via de roteamento aplicável, o atalho 4 alternará entre os modelos de via habilitados.

  • Uma vista lateral dos tipos de via propostos é exibida no painel Properties, como mostrado acima.

  • Para posicionar uma via e continuar o roteamento na mesma camada, pressione o atalho 2.

  • Para posicionar uma via e suspender o roteamento dessa conexão, pressione o atalho / no teclado numérico.

  • Se a rede que está sendo roteada precisar se conectar a um plano de alimentação interno, pressione a tecla / (no teclado numérico) para posicionar uma via conectada ao plano de alimentação apropriado. Isso funciona em todos os modos de posicionamento de trilhas, exceto no modo Qualquer ângulo .

  • Pressione Shift+F1 durante o roteamento para acessar um menu com todos os atalhos disponíveis no comando.

Trabalhando com vias empilhadas

  • Vias empilhadas que formam uma conexão contínua podem ser manipuladas como se fossem uma única via. Use click and drag na pilha para mover todas elas, junto com as trilhas conectadas.

  • Clique uma vez para selecionar a via superior da pilha. Se o mouse não for movido, os cliques únicos subsequentes selecionarão cada uma das outras vias da pilha, em sequência.

    Se a opção Display popup selection dialog estiver habilitada na página Editor de PCB – Geral da caixa de diálogo Preferences, clicar em uma pilha de vias abrirá um menu de seleção no qual você poderá selecionar a via desejada.

  • Ctrl+Click and drag para mover apenas a via selecionada junto com as trilhas conectadas.

  • Para selecionar todas as vias de uma pilha, clique uma vez para selecionar uma delas e pressione Tab para estender a seleção a todas as vias dessa pilha.

Configurando a exibição de vias

Há vários recursos de exibição disponíveis para ajudar você a trabalhar com vias.

Cores das vias

As cores das vias são configuradas no painel Configuração de visualização. O anel de cobre da via é exibido conforme a configuração atual de Multi-Layer na seção Layers . A cor do furo da via é exibida conforme a configuração de Via Holes na seção System Colors . Você também pode desabilitar a exibição dos furos alternando  nas configurações desejadas.

A primeira imagem mostra uma via passante. A via da segunda imagem é uma via cega; o furo é exibido nas cores das camadas inicial e final.
A primeira imagem mostra uma via passante. A via da segunda imagem é uma via cega; o furo é exibido nas cores das camadas inicial e final.

Vias e a máscara de solda

A apresentação padrão das camadas no editor de PCB sempre mostra a camada Multi-Layer acima de todas as outras. Isso pode dificultar a visualização precisa do conteúdo das camadas de máscara de solda, especialmente quando um pad ou uma via usa uma expansão negativa da máscara, pois o conteúdo da camada de máscara de solda ficará oculto sob o objeto multicamada. Você pode alterar esse comportamento mudando a ordem de desenho das camadas na página Editor de PCB – Exibição da caixa de diálogo Preferences. Configure a camada atual para ser desenhada acima de todas as outras.

Ao alterar a ordem de desenho das camadas para mostrar a camada atual por cima, as aberturas da máscara serão apresentadas com precisão quando você definir Top Solder como a camada atual, conforme mostrado na imagem abaixo. As setas verdes mostram o tamanho da abertura da máscara de solda para uma via à esquerda, um pad com a abertura da máscara reduzida no centro e um pad com a abertura ampliada à direita.

Configure as opções de exibição para poder examinar as aberturas da máscara de solda.
Configure as opções de exibição para poder examinar as aberturas da máscara de solda.

Exibição de vias empilhadas

Se houver vias empilhadas, os números exibidos correspondem às camadas inicial e final de todas as vias da pilha. Passe o cursor sobre a imagem abaixo para mostrar as vias em 3D; à direita da imagem há uma pilha de três vias.

As camadas atravessadas podem ser exibidas nas vias. Passe o cursor para mostrar as vias em 3D.As camadas atravessadas podem ser exibidas nas vias. Passe o cursor para mostrar as vias em 3D.

Outras configurações de exibição de vias

Para exibir o nome da rede da via e os números das camadas no trecho atravessado pela via, habilite as opções Via Nets e Via Span, respectivamente, na região Additional Options da aba View Options do painel View Configuration.

Explorando furos de pads e vias

No modo do painel PCB Hole Size Editor, suas três regiões principais mudam para refletir (de cima para baixo):

  • A filtragem geral dos tipos de furo e de seu status, com uma subseção para os pares de camadas de furação atualmente definidos para a placa.
  • Unique Holes organizados em grupos conforme o tamanho e a forma.
  • Pads/Vias individuais que constituem cada grupo de objetos de furo.

As seções do painel mostram a filtragem cumulativa aplicada aos tipos, estilos e status dos furos.
As seções do painel mostram a filtragem cumulativa aplicada aos tipos, estilos e status dos furos.

Os grupos de furos podem ser editados coletivamente na região Unique Holes do painel, inserindo valores na célula da coluna apropriada. Você pode inserir um valor numérico para alterar o tamanho atual do furo de pads e vias na coluna Hole Size .

Editando o tamanho do furo para o grupo selecionado de seis estilos de furo correspondentes.
Editando o tamanho do furo para o grupo selecionado de seis estilos de furo correspondentes.

Você também pode alterar as entradas correspondentes de Hole Length, Hole Type e Plated dos furos, quando aplicável.

Alterando o tipo de furo para o grupo selecionado de seis estilos de furo correspondentes.
Alterando o tipo de furo para o grupo selecionado de seis estilos de furo correspondentes.

Os objetos individuais de pad/via pertencentes ao grupo de furos selecionado são listados na seção inferior Pad/Via do painel PCB. Clique com o botão direito em um objeto da lista e selecione Properties (ou clique duas vezes diretamente na entrada) para abrir o modo correspondente do painel Properties para essa primitiva, onde suas propriedades podem ser visualizadas e editadas.

Para atualizar o painel PCB no modo Hole Size Editor com os dados atuais dos símbolos de furação da PCB, clique com o botão direito em uma região do painel nesse modo e selecione o comando Refresh.

Os dados dos símbolos de furação são atualizados automaticamente ao salvar o documento PCB e para quaisquer saídas que contenham esses dados.

Os dados dos símbolos de furação não são atualizados automaticamente no painel PCB para melhorar o desempenho. A atualização manual dos dados dos símbolos de furação está disponível quando a opção PCB.LiveDrillSymbols está desabilitada na caixa de diálogo Configurações avançadas.

Suporte à furação reversa

O modo Hole Size Editor do painel PCB também pode ser usado para examinar pads e vias destinados à furação reversa. Os pares de camadas de furação reversa são exibidos na lista Layer Pairs, identificados pela adição do texto [BD].

Quando um tamanho de furo de furação reversa é selecionado, os objetos têm seu Kind exibido como Backdrill. Use esse recurso para localizar e examinar rapidamente os furos com furação reversa. Observe que as configurações de furação reversa não podem ser editadas no painel.

Relatório de furação reversa

Para gerar um relatório de todas as operações de furação reversa, clique com o botão direito na lista Furos únicos e selecione Backdrill Report no menu de contexto.

O relatório detalha cada operação de furação reversa, incluindo a localização, o diâmetro e a profundidade de furação.

Para saber mais sobre furação reversa, consulte Furação com profundidade controlada ou furação reversa.

Suporte a rebaixos de furos

O modo Hole Size Editor do painel PCB também pode ser usado para examinar pads com recursos de rebaixo de furo habilitados. Quando o projeto de PCB tem objetos de pad com recursos de rebaixo de furo (rebaixo cilíndrico/escareado) habilitados em um ou em ambos os lados, os grupos Counterholes Top e/ou Counterholes Bottom associados são exibidos na lista Layer Pairs. As colunas Counterhole Depth e Counterhole Angle podem ser exibidas na Unique Holes região do painel. Observe que as configurações de rebaixos não podem ser editadas no painel.

As informações sobre os rebaixos no projeto são exibidas no modo Hole Size Editor do painel PCB.
As informações sobre os rebaixos no projeto são exibidas no modo Hole Size Editor do painel PCB.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents