Anotando os componentes em um projeto

Altium Training

Altium Essentials: Schematic Updating

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Num relance

Este artigo explica como a anotação de projetos no Altium Designer garante que cada componente receba um designador exclusivo e apresenta as três abordagens de anotação — no nível do esquemático, da PCB e da placa — para que você entenda quando cada uma é mais adequada. Também apresenta a caixa de diálogo Anotar e descreve as principais áreas de configuração e opções usadas para controlar como os designadores são atribuídos, ordenados, agrupados em encapsulamentos e atualizados em todo o projeto. Se você quer entender melhor como escolher o método de anotação adequado e gerenciar a identificação dos componentes com confiança, este artigo ajudará a construir essa base. Continue lendo.

- Conheça a finalidade da anotação de projetos e saiba por que os designadores exclusivos dos componentes são importantes nos esquemáticos, no layout da PCB e em documentos de saída, como a lista de materiais (BOM).
- Entenda as diferenças entre a anotação no nível do esquemático, da PCB e da placa, incluindo os tipos de projeto mais adequados a cada abordagem.
- Tenha uma visão geral da caixa de diálogo Anotar e das principais configurações usadas para controlar o escopo da anotação, a ordem de processamento, as opções de correspondência e as alterações propostas.
Aprofunde-se com a IA:

A anotação do projeto é o processo sistemático e metódico que garante que cada componente do projeto possa ser identificado individualmente por meio de um designador exclusivo. Embora o Altium Designer consiga manter a identidade dos componentes usando identificadores globalmente exclusivos (GUIDs), historicamente, a maioria dos projetistas usa o designador do componente como principal meio de referência ao componente nos domínios do esquemático (lógico) e da PCB (físico), bem como em saídas como a lista de materiais (BOM).

Existem três abordagens para anotar um projeto. A escolha da ferramenta de anotação depende de vários fatores, incluindo o tipo de projeto, a preferência pessoal e as políticas e os procedimentos da empresa.

Schematic Level Annotation

A anotação no nível do esquemático usa uma visão puramente lógica do projeto para determinar os designadores dos componentes. Ela é mais útil para projetos simples que não usam folhas de dispositivos, mas, como permite especificar a ordem de processamento e oferece a opção de completar encapsulamentos existentes de componentes com múltiplas partes, também é um pré-requisito para a anotação no nível da placa.

Em resumo, use a anotação no nível do esquemático para:

  • Agrupar componentes com múltiplas partes em encapsulamentos.
  • Anotar componentes com base em sua posição no projeto esquemático.
  • Anotar projetos multicanal usando o esquema de nomenclatura padrão especificado nas opções do projeto.
  • Preparar um projeto para anotações adicionais.

PCB Annotation

A anotação da PCB usa a localização física dos componentes na PCB para determinar sua designação. Isso permite incorporar efetivamente informações de posição ao designador de um componente e pode ser muito útil ao depurar uma PCB montada. Em resumo, você deve usar a anotação da PCB para anotar componentes com base em sua posição na placa no projeto de PCB.

Consulte a página Anotação posicional da PCB para saber mais.

Board Level Annotation

A anotação no nível da placa fornece um mapeamento entre os designadores usados no projeto esquemático (lógico) e seus correspondentes reais no projeto de PCB (físico). Embora a anotação no nível da placa possa ser usada em qualquer projeto, ela é especialmente útil para projetos multicanal ou projetos que incorporam folhas de dispositivos nas quais os designadores não podem ser editados na própria folha. Dessa forma, todo o projeto pode ser reanotado sem modificar as folhas de dispositivos originais. A anotação no nível da placa resolve quaisquer conflitos de anotação que possam ocorrer devido a designadores duplicados em um projeto e armazena suas alterações em um arquivo de texto *.Annotation. Ela inclui palavras-chave adicionais para personalizar esquemas de nomenclatura e permite aplicá-los a todas as partes ou apenas a um conjunto selecionado delas.

Em resumo, use a anotação no nível da placa para:

  • Anotar os componentes compilados nas folhas de dispositivos.
  • Atribuir nomes exclusivos a todos os componentes em vários canais usando esquemas de nomenclatura que incluem anotação posicional, indexação global e outras opções configuráveis.
  • Nomear componentes manualmente.
Consulte a página Anotação no nível da placa para saber mais.

Anotação do esquemático

A anotação do esquemático é configurada usando a caixa de diálogo Annotate . A caixa de diálogo fornece controles para atribuir sistematicamente designadores a todas as partes ou às partes selecionadas nas folhas selecionadas de um projeto e garante que os designadores sejam exclusivos e ordenados com base em sua posição. As opções de anotação podem ser configuradas para agrupar componentes com múltiplas partes em encapsulamentos, definir opções de índice e sufixo, redefinir designadores do esquemático, incluindo designadores duplicados, e realizar a retroanotação a partir da PCB.

A caixa de diálogo Annotate é acessada executando o comando Anotar esquemáticos (Tools » Annotation » Annotate Schematics).

A caixa de diálogo Annotate é aberta a partir do comando Annotate Schematics.
A caixa de diálogo Annotate é aberta a partir do comando Annotate Schematics.

A caixa de diálogo é dividida em duas regiões principais:

  • Schematic Annotation Configuration - esta região é usada para configurar o esquema de anotação e o escopo da anotação.
  • Proposed Change List - esta região lista as alterações propostas que ocorrerão após serem aceitas e executadas por meio de uma ordem de alteração de engenharia (ECO).

Bloquear componentes 

Para componentes de múltiplas partes não homogêneos, certifique-se de que os ícones de bloqueio estejam fechados no painel Properties para impedir alterações nas subpartes durante a anotação.

Opção Strictly

Se a caixa de seleção Strictly estiver habilitada para um Component Parameter, todos os componentes deverão ter esse parâmetro correspondente para serem agrupados em um encapsulamento. Os componentes que não tiverem esse parâmetro serão anotados como componentes individuais e não serão agrupados.

O exemplo a seguir ilustra como essas opções se combinam para produzir um resultado específico:

Considere um projeto com oito portas OR e oito resistores (como mostrado na imagem abaixo). As portas OR contêm um parâmetro chamado QuadOrGate, com um grupo de quatro portas OR com o valor de parâmetro Package1 e o outro grupo de quatro portas OR com o valor de parâmetro Package2. Os resistores não têm esse parâmetro. Habilitar a caixa de seleção de QuadOrGate no controle Component Parameter garantirá que esse parâmetro seja usado para controlar como os componentes são agrupados em encapsulamentos; neste caso, a caixa de seleção Strictly não está habilitada.

Após executar o comando Tools » Annotation » Annotate Schematics, as partes com o parâmetro  QuadOrGate = Package1 serão agrupadas no mesmo componente físico, e aquelas com o parâmetro QuadOrGate = Package2 serão agrupadas separadamente. Todos os componentes restantes que não tiverem o parâmetro QuadOrGate serão agrupados. Neste caso, os resistores são agrupados porque seu atributo comum é não conterem o parâmetro QuadOrGate.

Exemplo de componentes agrupados quando a opção Strictly  está desmarcada.
Exemplo de componentes agrupados quando a opção Strictly está desmarcada.

Se o mesmo projeto for anotado, mas com a opção Strictly marcada, apenas os componentes que tiverem o parâmetro QuadOrGate serão agrupados. Neste caso, as portas OR serão agrupadas, mas os resistores permanecerão sem agrupamento. Consequentemente, embora a opção Strictly ofereça um controle extremamente preciso sobre o processo de agrupamento, na maioria das situações será necessário deixá-la desmarcada.

Exemplo de componentes agrupados quando a opção Strictly  está marcada.
Exemplo de componentes agrupados quando a opção Strictly está marcada.

Componentes de múltiplas partes podem usar um sufixo identificador de parte alfabético ou numérico, ou seja, U1:1, U1:2 ou U1:A, U1:B. O estilo do sufixo é definido na página Esquemático - Geral da caixa de diálogo Preferences . Observe que as preferências são globais e se aplicam a todas as folhas de esquemático abertas no momento.

Folhas de esquemático a anotar

É possível controlar com alto grau de precisão quais folhas de esquemático e componentes serão afetados pela anotação e os detalhes de como essas alterações serão calculadas.

Especificação do escopo da anotação.
Especificação do escopo da anotação.

  • Uma marca na caixa à esquerda da folha de esquemático listada indica que ela será processada como parte do comando de anotação.
  • O escopo da anotação é determinado pela lista suspensa Annotation Scope e pode ser ampliado para incluir toda a folha de esquemático ou limitado aos componentes selecionados ou não selecionados. O uso das opções Ignore Selected Parts ou Only Selected Parts exige que os componentes tenham sido selecionados no projeto antes de executar o comando de anotação.
  • Configure a ordem em que as folhas de esquemático serão anotadas usando o campo Order. Digite um valor diretamente no campo ou use as setas que aparecem ao clicar nele para definir o valor desejado.
  • Se a opção Designator Index Control  estiver marcada, o valor do designador começará a partir do valor Start Index. O Start Index não terá efeito se a opção Designator Index Control não estiver marcada.
  • Um sufixo adicional pode ser acrescentado ao final de cada designador especificando uma string ou um valor na coluna Suffix correspondente. Evite usar sufixos de um único caractere, como 'A' ou '1', pois eles podem ser facilmente confundidos com subpartes e/ou outros valores de designadores.

Lista de alterações propostas

Clique no botão Update Changes List para atualizar a Proposed Change List, de modo que todas as alterações de designadores possam ser revisadas antes de serem aplicadas. Apenas os designadores que ainda não foram definidos (ou seja, R?, C?, etc.) serão afetados pelas alterações. Portanto, se a intenção for atualizar todos os designadores do projeto, eles deverão primeiro ser redefinidos pressionando o botão Reset All.

Redefinição dos designadores antes de aplicar as configurações de anotação.
Redefinição dos designadores antes de aplicar as configurações de anotação.

O botão suspenso Reset All também pode ser usado para Reset Duplicates. 

A Proposed Change List lista todos os designadores das partes contidas nas folhas selecionadas para anotação. Para cada entrada, são incluídos detalhes dos valores de designador Current e Proposed, juntamente com a Sub (parte) do componente e a Location of Part de origem.

Marcar a caixa associada a um Designator  bloqueará esse designador específico contra quaisquer alterações. Da mesma forma, marcar a caixa Sub impedirá que esse componente específico de múltiplas partes seja atualizado. Essa opção pode ser usada como alternativa à configuração do ícone Lock no painel Properties .

Após revisar a lista de alterações propostas, clique no botão Accept Changes (Create ECO) para abrir a caixa de diálogo Engineering Change Order. Quando a ECO for executada, as alterações de anotação serão aplicadas ao projeto.

Comandos adicionais de anotação de esquemático

O menu Ferramentas » Annotation contém vários comandos específicos de anotação de esquemático. O primeiro item do grupo, Annotate Schematic, já foi abordado.

Diversos comandos de anotação disponíveis
Diversos comandos de anotação disponíveis

Redefinir designadores do esquemático

Se grandes partes do conteúdo tiverem sido recortadas e coladas de diferentes fontes em um novo projeto, poderá ser necessário redefinir todos os designadores. Como este comando usa as configurações da caixa de diálogo Anotar , ele será aplicado aos itens definidos anteriormente nessa caixa de diálogo. Por exemplo, se todos os Schematic Sheets To Annotate tiverem sido marcados anteriormente, o comando Reset Schematic Designators será aplicado ao projeto inteiro, independentemente de as folhas estarem abertas no editor ou não. Se apenas alguns Schematic Sheets To Annotate tiverem sido marcados anteriormente, o comando Reset Schematic Designators afetará apenas essas folhas.

Após executar o comando, será exibida uma caixa de diálogo de confirmação que resume o número de designadores que precisam ser atualizados e pergunta se você deseja prosseguir com as alterações. Após clicar em Yes, todos os designadores de componentes em todas as folhas de esquema do projeto ativo habilitadas para anotação serão redefinidos, passando a aparecer no formato: R?, C?, D?, U? etc.

Os designadores com status bloqueado não são redefinidos nem alterados de nenhuma forma.

Redefinir designadores de esquema duplicados 

Ao duplicar partes de um projeto, os componentes recém-copiados ainda terão os mesmos valores de designador dos componentes dos quais foram copiados. O comando Reset Duplicate Schematic Designators oferece uma maneira rápida de redefinir os designadores duplicados para '?'. Como este comando usa as configurações da caixa de diálogo Annotate , ele será aplicado aos itens definidos anteriormente nessa caixa de diálogo. Por exemplo, se todos os Schematic Sheets To Annotate tiverem sido marcados anteriormente, o comando Reset Duplicate Schematic Designators será aplicado ao projeto inteiro, independentemente de as folhas estarem abertas no editor ou não. Se apenas alguns Schematic Sheets to Annotate tiverem sido marcados anteriormente, o comando Reset Schematic Designators afetará apenas essas folhas.

Após executar o comando, será exibida uma caixa de diálogo de confirmação que resume o número de designadores que precisam ser atualizados e pergunta se você deseja prosseguir com as alterações. Após clicar em Yes, todos os designadores de componentes duplicados encontrados em todas as folhas de esquema do projeto ativo habilitadas para anotação serão redefinidos, passando a aparecer no formato: R?, C?, D?, U? etc.

Os designadores com status bloqueado não são redefinidos nem alterados de nenhuma forma.

Anotar esquemas silenciosamente

O comando Annotate Schematics Quietly é usado para examinar todos os documentos de esquema de origem do projeto ativo habilitados para anotação e atribuir um designador exclusivo a qualquer componente que ainda não tenha um. A anotação é realizada silenciosamente, permitindo aplicar todas as configurações anteriores da caixa de diálogo Annotate sem precisar reabri-la. Isso é especialmente útil se o projeto estiver passando por uma fase de desenvolvimento rápido e o projetista quiser fazer a anotação rapidamente antes de compilar o projeto.

Forçar a anotação de todos os esquemas

Este comando é usado para examinar todos os documentos de esquema de origem do projeto ativo habilitados para anotação e refazer a anotação de todos os seus componentes de acordo com o esquema de anotação atualmente definido na caixa de diálogo Annotate.

Executar o comando Force Annotate All Schematics equivale a executar o comando Reset Schematic Designators seguido imediatamente pelo comando Annotate Schematics Quietly. Consequentemente, o comando Force Annotate All Schematics usa as configurações definidas anteriormente na caixa de diálogo Annotate para determinar quais componentes e folhas podem ser atualizados.

Após executar este comando, será exibida uma solicitação de confirmação que detalha o número de designadores que serão atualizados se a solicitação for aceita. Após clicar em Yes, a anotação de todos os designadores de componentes em todas as folhas de esquema do projeto ativo habilitadas para anotação será refeita, quando necessário, para atender ao esquema atual de anotação posicional definido na região Schematic Annotation Configuration da caixa de diálogo Annotate .

Retroanotar esquemas

Antes da introdução de Design Compiler e Synchronizer no Altium Designer, as alterações de anotação eram tradicionalmente transferidas do esquema para a PCB por meio de um arquivo de netlist (*.net). As alterações de anotação que precisavam ser propagadas na direção inversa, da PCB para o esquema, eram tratadas por um processo de retroanotação. Esse processo usa um arquivo Was-Is (*.WAS) ou um arquivo de ordem de alteração de engenharia (*.ECO) para orientar as alterações a serem aplicadas aos designadores do esquema.

Este comando é, em grande parte, desnecessário, pois Design Compiler e Synchronizer são ferramentas muito mais eficazes para gerenciar a sincronização do projeto. No entanto, ele ainda é útil para fins de compatibilidade com projetos legados e para projetistas que usam ferramentas alternativas de layout de PCB (como o Specctra®). Saiba mais sobre como gerar o arquivo Was-Is.

Após executar o comando, será exibida a caixa de diálogo Choose WAS-IS File for Back-Annotation from PCB. Localize e selecione o arquivo .was (ou .eco) necessário. Após clicar em Open, será exibida uma caixa de diálogo de informações que lista quantas alterações nos designadores foram feitas desde o estado anterior e quantas foram feitas desde o estado original. Nesse momento, as alterações ainda não foram efetivamente implementadas. Clique em OK  para abrir a caixa de diálogo Annotate, na qual você pode visualizar as alterações propostas para os designadores atuais antes de decidir criar uma ECO para implementá-las.

  • Ao refazer a anotação dos designadores na PCB, cada nova anotação produz um arquivo .was exclusivo, cujo nome contém a data e a hora. Isso permite carregar vários arquivos .was em sequência, do mais antigo para o mais recente, sem perder a sincronização dos designadores entre a PCB e as folhas de esquema de origem.
  • A retroanotação também pode ser realizada diretamente na caixa de diálogo Annotation , clicando no botão Back Annotate.

Numerar folhas de esquema

O comando Number Schematic Sheets não altera os designadores de componentes, mas sim os designadores (números) das folhas de esquema. Conceitualmente, portanto, ele está relacionado ao conceito geral de anotação de projeto.

A numeração de folhas e documentos permite controlar a designação das folhas e armazenar esses valores como parâmetros nos respectivos documentos de esquema. O recurso de strings especiais do Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) pode então ser usado para exibir esses valores na folha (no rodapé da folha, por exemplo) como objetos de texto.

Numeração de folhas de esquema.
Numeração de folhas de esquema.

O processo de numeração de folhas é o seguinte:

Numeração automática de folhas (opção do projeto)

Habilite para realizar a numeração automática das folhas. Os valores serão exibidos no painel Projects. Você também pode habilitar a numeração automática de folhas marcando a opção Automatic Sheet Numbering na guia Opções da caixa de diálogo Project Options.

Número automático da folha

Clique no botão suspenso Auto Sheet Number para acessar as opções de numeração de folhas.

As opções de Select Numbering Scheme são:

  • Display Order - as folhas são numeradas na ordem em que são exibidas.
  • Sheets Hierarchical Structure - Depth First - as folhas são numeradas do nível superior para cada ramificação. O nível superior é numerado primeiro e, em seguida, a primeira ramificação abaixo do nível superior é numerada por completo, depois a segunda ramificação e assim por diante.
  • Sheets Hierarchical Structure - Breadth First - as folhas são numeradas de acordo com seu nível na hierarquia. O nível superior é numerado primeiro, depois todos os elementos do segundo nível e assim por diante.

As opções de Select Numbering Method permitem selecionar valores sequenciais Increasing ou Decreasing .

Numeração automática de documentos

Clique na lista suspensa Auto Document Number para acessar as opções de numeração de documentos. Elas são essencialmente as mesmas opções de Auto Sheet Number, mas com o acréscimo dos valores Prefix e Postfix .

As opções de Parameters são as seguintes:

  • Prefix - escolha um prefixo para colocar antes do número do documento. São aceitos prefixos alfabéticos (A, B, C etc.), numéricos (1, 2, 3 etc.) e não numéricos (_, *, ., % etc.), incluindo combinações de todos eles.
  • Start - escolha um valor numérico a partir do qual iniciar a numeração.
  • Postfix - escolha um sufixo para acrescentar ao número do documento. São aceitos sufixos alfabéticos (A, B, C etc.), numéricos (1, 2, 3 etc.) e não numéricos (_, *, . ,% etc.), incluindo combinações de todos eles.
  • Step - escolha um valor de incremento para cada número de documento. Por exemplo, se o índice Start estiver definido como 1 e o valor de Step estiver definido como 100, o primeiro número de documento será 1, o próximo será 101 (início + incremento), o seguinte 201 e assim por diante.

Atualizar contagem de folhas

Clique no botão Update Sheet Count para contar o número de folhas no projeto atual e inserir o resultado na coluna SheetTotal. A contagem de folhas será o número total de folhas no projeto, independentemente do esquema de numeração selecionado em qualquer um dos controles anteriores.

Mover para cima/baixo

Use os botões Move Up ou Move Down para mover um documento esquemático selecionado para cima ou para baixo na lista. Isso é relevante ao usar o esquema de numeração Display Order para especificar números de folhas ou de documentos.

Numeração/nomenclatura personalizada

Se uma organização tiver um sistema específico de numeração ou nomenclatura que não possa ser automatizado pelos comandos Auto Sheet Number ou Auto Document Number, os nomes e números personalizados das folhas poderão ser inseridos diretamente nos campos SheetNumber ou DocumentNumber .

Numeração de folhas de esquemático e Device Sheets

Os números de folhas ou de documentos não podem ser configurados para Device Sheets quando elas estão no modo somente leitura (estado padrão) e aparecerão hachurados na caixa de diálogo Numeração de folhas do projeto para indicar que não podem ser atualizados. Quando as Device Sheets são definidas como editáveis, o hachurado é removido e a numeração de folhas e de documentos pode ser configurada normalmente.

Controle da exibição do designador na PCB

As strings de designadores estendidos em um projeto multicanal podem ser trabalhosas de posicionar no Editor de PCB. Você pode escolher opções de nomenclatura que resultem em um nome curto ou exibir a designação lógica original do componente. Por exemplo, C30_CIN1 seria exibido como C30. Isso exigiria acrescentar alguma outra indicação à placa para identificar os canais separados, como desenhar uma caixa ao redor de cada canal na camada de serigrafia dos componentes.

Você pode alternar entre a exibição de designadores lógicos e físicos na PCB usando a lista suspensa Designator Display na região Other do painel Properties no modo Board . Se você optar por exibir os designadores lógicos dos componentes em um projeto multicanal, eles serão exibidos na PCB e em todas as saídas geradas, como impressões e arquivos Gerber. No entanto, os designadores físicos exclusivos são sempre usados ao gerar uma lista de materiais.

Sincronização do projeto - Finalização do processo de anotação

A sincronização direta do projeto é o método preferencial para manter os designadores do esquemático e da PCB correspondentes, a menos que você não tenha acesso a ambos os editores. A sincronização do projeto compara os componentes e a conectividade do esquemático diretamente com a PCB, produzindo uma lista de diferenças. Uma lista das alterações necessárias para resolver essas diferenças é gerada como uma ECO (ordem de alteração de engenharia). Um arquivo ECO descreve as diferenças entre o projeto atual e o projeto desejado e pode ser executado, atualizando o destino e sincronizando o projeto.

Sincronização direta e sincronização reversa

Os termos sincronização direta e sincronização reversa são formas específicas de descrever a direção em que a anotação e as alterações do projeto são transferidas durante a sincronização dos dados. Considerando um fluxo de projeto que começa pelo esquemático e é orientado por ele, a sincronização direta é o processo de propagar as alterações feitas no Editor de Esquemáticos para a PCB. A sincronização reversa é o processo de propagar as alterações feitas na PCB de volta para o Editor de Esquemáticos.

Sincronização direta

Alguns motivos para sincronizar os dados do esquemático com a PCB são:

  1. Um novo componente foi adicionado no Editor de Esquemáticos e precisa ser incluído no layout da PCB.
  2. Você anotou seu projeto esquemático pela primeira vez ou desde a última sincronização do projeto.
  3. Em um projeto multicanal, você alterou Project Options para modificar o estilo de nomenclatura física (PCB).
  4. Você realizou uma anotação no nível da placa pela primeira vez ou desde a última sincronização do projeto.

Para sincronizar seu projeto esquemático com o projeto da PCB

Escolha um dos seguintes métodos para sincronizar seu projeto esquemático com o projeto da PCB:

  1. Selecione Update PCB Document no menu Design do Editor de Esquemáticos. Se houver diferenças entre eles e o documento de PCB de destino, a caixa de diálogo Engineering Change Order será aberta com uma lista das modificações necessárias para sincronizar a PCB com o projeto esquemático. Clique em Execute Changes para sincronizar seu projeto.
  2. Selecione Import Changes no menu Design do Editor de PCB, que importa as alterações dos documentos esquemáticos para o documento de PCB.

Sincronização reversa

A sincronização reversa é realizada quando você anotou ou alterou seu projeto de PCB e deseja atualizar o projeto esquemático.

Para sincronizar seu projeto de PCB de volta com o projeto esquemático

Escolha um dos seguintes métodos para sincronizar seu projeto de PCB de volta com o projeto esquemático:

  1. No Editor de PCB, selecione Update Schematics no menu Design . Por padrão, a opção Push Component Designator Changes to Annotation File (if any) na guia Geração de ECO da caixa de diálogo Project Options está marcada, de modo que as alterações feitas no Editor de PCB sejam enviadas apenas para o arquivo de anotação e, por fim, para os documentos compilados durante a compilação. Desmarque essa opção para enviar as alterações apenas para o documento esquemático de origem (visualização Editor ).

  2. No editor de esquemáticos, selecione Tools » Annotation » Annotate Schematics e clique no botão Back Annotate na caixa de diálogo Anotar. Escolha o arquivo WAS-IS gerado ao reanotar os designadores no ambiente de PCB.
Esta é uma ferramenta legada. O método preferencial de sincronização do projeto é o comando Design » Update Schematics.
  1. No editor de esquemáticos, selecione Tools » Annotation » Board Level Annotate e clique no botão Back Annotate na caixa de diálogo Anotação no nível da placa. Escolha o arquivo WAS-IS gerado ao reanotar os designadores no ambiente de PCB.
Esta é uma ferramenta legada. O método preferencial de sincronização do projeto é o comando Design » Update Schematics.
  1. No editor de esquemáticos, selecione Tools » Annotation » Back Annotate Schematics. Escolha o arquivo WAS-IS gerado ao reanotar os designadores no ambiente de PCB.
Esta é uma ferramenta legada. O método preferencial de sincronização do projeto é o comando Design » Update Schematics.
Back Annotate Schematics sincroniza as alterações de anotação feitas no editor de PCB com o projeto esquemático. Este recurso é útil quando não é possível manter os editores de PCB e de esquemáticos abertos ao mesmo tempo, por exemplo, quando a PCB e o esquemático são projetados por pessoas em locais diferentes.

Métodos tradicionais de sincronização de projetos

O Altium Designer oferece suporte à abordagem tradicional de arquivos intermediários (netlist e WAS/IS) para a sincronização de projetos. A sincronização direta dos dados de anotação pode ser feita por meio de um arquivo de netlist, e a sincronização reversa pode ser feita por meio de um arquivo WAS/IS (que lista o que cada designador WAS e o que ele agora IS). O método preferencial para sincronizar seu projeto é a sincronização direta de projetos.

Vinculação de componentes com IDs exclusivos

Se você reanotou seu projeto, os designadores dos componentes do esquemático ou os designadores dos componentes compilados não corresponderão mais aos designadores dos componentes da PCB. Portanto, a sincronização será necessária para concluir o projeto com sucesso. Em vez de depender do próprio designador como campo-chave que relaciona um símbolo do esquemático ao seu footprint equivalente na PCB, o Altium Designer pode manter a sincronização do projeto por meio do sistema de identificadores exclusivos (UID). O UID é um valor gerado pelo sistema que identifica de forma exclusiva o componente de origem e associa cada componente do esquemático ao componente correspondente na PCB.

Quando um componente é inserido em uma folha de esquemático, ele recebe automaticamente um UID. Na primeira vez que as informações dos componentes são transferidas dos documentos esquemáticos de origem para uma PCB em branco, as informações de UID de cada componente do esquemático são atribuídas ao componente correspondente na PCB.

A refatoração permite converter folhas de dispositivos em folhas de esquemático e vice-versa, mantendo o ID exclusivo da folha e de seus componentes. Além disso, você pode refatorar (ou mover) subcircuitos para outras folhas de esquemático no projeto atual, mantendo o ID exclusivo do subcircuito. O comando Refactor está localizado no menu Edit .

O recurso de sincronização do Altium Designer, iniciado ao executar o comando Design » Update, usa esses UIDs para associar cada componente do esquemático ao seu equivalente na PCB. As atualizações/alterações do projeto podem então ser implementadas usando ordens de alteração de engenharia (ECOs). Uma ECO lista todas as modificações necessárias para implementar alterações em um ou mais documentos do projeto a fim de atender à ação de sincronização solicitada. As ECOs são usadas para efetuar atualizações no projeto em diversas situações, como:

  1. Atualizações do projeto do esquemático para a PCB.
  2. Atualizações de anotação nos designadores dos componentes do esquemático e nos designadores dos componentes compilados.
  3. Implementação de atualizações de parâmetros usando o Parameter Manager (Tools » Parameter Manager).
  4. Atualização das informações de parâmetros com informações armazenadas em bibliotecas de origem ou em um banco de dados da empresa. Sempre que você compara o esquemático e a PCB (por exemplo, ao selecionar Design » Update), o Altium Designer primeiro associa os componentes que compartilham o mesmo UID. Quando são detectados componentes que não compartilham um UID, você recebe um alerta e o aplicativo oferece a opção de tentar associá-los pelo designador. Até que você atribua um UID correspondente tanto no esquemático quanto na PCB, continuará recebendo essa mensagem. Os IDs exclusivos e sua correlação são gerenciados na caixa de diálogo Editar vínculos de componentes (Project » Component Links).

Observe que a caixa de diálogo só pode ser aberta quando um documento de PCB está ativo, pois as alterações de UID são sempre aplicadas à PCB, e não ao esquemático. Use a caixa de diálogo em qualquer etapa do projeto para visualizar os vínculos entre os componentes e verificar se os componentes dos diferentes documentos estão associados corretamente, bem como para atribuir UIDs correspondentes aos componentes que ainda não estão associados.

Se você pretende reanotar o esquemático ou a PCB, é essencial verificar primeiro se os UIDs correspondem, pois, após alterar todos os designadores no esquemático ou na PCB, o UID passa a ser a única informação que pode ser usada para vincular o componente do esquemático ao seu equivalente na PCB.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents