Criando um Desenho de Fabricação

Num relance

Este artigo mostra como criar um desenho de fabricação de chicotes no Altium Designer usando o editor Draftsman, desde a adição e configuração do documento no projeto até a inserção de vistas somente leitura do diagrama de fiação e do desenho de layout, a adição de vistas de detalhes e de componentes e o uso de anotações, cotas e tabelas para documentar o projeto para fabricação. Também explica como incorporar atualizações do diagrama de fiação e do desenho de layout ao desenho de fabricação e como gerenciar propriedades, unidades, parâmetros e a navegação entre várias folhas no documento. Se você quer entender como os dados do projeto de chicotes são transformados em documentação de fabricação organizada, continue lendo para conhecer o fluxo de trabalho completo.

- Aprenda a criar e configurar um documento de desenho de fabricação de chicotes no Draftsman, incluindo modelos, configurações do documento, unidades e parâmetros importados do projeto.
- Veja quais tipos de vistas, anotações, cotas e ferramentas adicionais de desenho podem ser adicionados para representar com clareza as informações do projeto de chicotes.
- Entenda quais tabelas de fabricação estão disponíveis, incluindo listas de materiais (BOMs), listas de fiação e tabelas de conexões, e como seus dados são obtidos e apresentados.
Aprofunde-se com a IA:

Quando o diagrama de fiação e o desenho de layout estiverem concluídos, cópias somente leitura de seu conteúdo poderão ser inseridas no documento de desenho de fabricação (*.HarDwf) e receber anotações conforme necessário. O desenho de fabricação de um projeto de chicote elétrico é criado no editor Draftsman.

Para obter informações gerais sobre o Draftsman, consulte a página Simplificando a documentação de projetos de placas com o Draftsman.

Adicione um desenho de fabricação ao projeto de chicote elétrico pelo painel Projects, clicando com o botão direito na entrada do projeto e selecionando Add New to Project » Draftsman Document no menu de contexto (ou use o comando File » New » Draftsman Document nos menus principais). Na caixa de diálogo New Document que se abre, selecione um modelo de desenho de fabricação disponível conforme necessário e certifique-se de que o Project e o desenho de layout do chicote elétrico Document corretos estejam selecionados.

A caixa de diálogo New Document
A caixa de diálogo New Document

Para saber mais sobre a criação de modelos de desenhos de fabricação, consulte a página Criação de documentos de modelo de chicote elétrico.

Configuração de um documento de desenho de fabricação

As opções de um documento de desenho de fabricação podem ser configuradas no painel Properties quando nenhum objeto está selecionado na área de projeto do documento. Consulte a página Configuração de um documento do Draftsman para saber mais.

As abas do painel Properties quando nenhum objeto está selecionado no documento de desenho de fabricação do chicote elétrico
As abas do painel Properties quando nenhum objeto está selecionado no documento de desenho de fabricação do chicote elétrico

  • Após a criação do documento de desenho de fabricação, quaisquer alterações feitas no diagrama de fiação ou no desenho de layout podem ser importadas para o desenho de fabricação usando o comando Tools » Import Changes From <LayoutDrawing.LdrDoc> nos menus principais ou no menu de contexto da área de projeto. Observe que, apesar da descrição no comando de menu, essa ação importará as alterações de both the wiring diagram and the layout drawing.

  • As propriedades padrão dos objetos de desenho de fabricação podem ser configuradas na página Draftsman – Padrões da caixa de diálogo Preferences. Essas propriedades serão aplicadas aos objetos inseridos posteriormente.

  • O painel Marcadores oferece uma maneira prática de navegar e gerenciar um desenho de fabricação com várias folhas. O painel apresenta uma visualização em árvore expansível de toda a estrutura do documento e inclui todas as folhas do documento e os principais objetos de vista contidos nelas.

  • Usando as opções Units e Dual_Units no painel Properties quando nenhum objeto está selecionado na área de projeto, você pode selecionar as unidades de medida padrão do documento para os valores de cotas e os valores de comprimento exibidos em tabelas. Se necessário, as unidades especificadas no nível do documento podem ser substituídas nas propriedades de objetos específicos. As unidades compatíveis são Millimeters, Mils, Inches, Centímetros, Metros e Feet.

  • Os parâmetros do documento de desenho de layout são importados para o documento de desenho de fabricação do chicote elétrico associado. Esses parâmetros são listados na aba Parameters do painel Properties do documento (a visibilidade dos parâmetros de layout na lista pode ser ativada ou desativada usando a caixa de seleção ao lado do ícone  no painel) e podem ser usados em strings especiais. Os valores de parâmetros calculados, como =ItemRevision e =ItemRevisionLevel1, também são incluídos e interpretados nos arquivos de saída gerados na liberação.

Trabalhando com vistas

Em um documento de desenho de fabricação, você pode inserir vistas somente leitura do diagrama de fiação e do desenho de layout do chicote elétrico incluídos neste projeto.

Vista do diagrama de fiação

Uma vista do diagrama de fiação (Place » Wiring Diagram View) é uma composição gráfica automatizada do diagrama de fiação do projeto de chicote elétrico ativo.

Um exemplo de vista do diagrama de fiação
Um exemplo de vista do diagrama de fiação

As propriedades de uma vista do diagrama de fiação inserida podem ser configuradas no painel Properties quando a vista está selecionada na área de projeto.

O painel Properties quando uma vista do diagrama de fiação está selecionada
O painel Properties quando uma vista do diagrama de fiação está selecionada

  • Se o projeto de chicote elétrico incluir vários documentos de diagrama de fiação (saiba mais), você poderá escolher o documento de diagrama de fiação a partir do qual uma vista inserida deverá ser gerada e atualizada. Quando a vista do diagrama de fiação estiver selecionada, use a lista suspensa Document na região Properties do painel Properties para escolher o documento de diagrama de fiação para essa vista ().

  • Quando Auto Size está habilitado, a vista do diagrama de fiação ajusta automaticamente seu tamanho para remover espaços vazios nas bordas.

  • Selecione o Justification clicando na seta correspondente ao alinhamento desejado ou no círculo para centralizar. A opção escolhida para Justification define o ponto em relação ao qual a posição da vista é alterada caso seu tamanho seja atualizado.

Vista do desenho de layout

Uma vista do desenho de layout (Place » Layout Drawing View) é uma composição gráfica automatizada do desenho de layout do projeto de chicote elétrico ativo.

Um exemplo de vista do desenho de layout
Um exemplo de vista do desenho de layout

As propriedades de uma vista do desenho de layout inserida podem ser configuradas no painel Properties quando a vista está selecionada na área de projeto.

O painel Properties quando uma vista do desenho de layout está selecionada
O painel Properties quando uma vista do desenho de layout está selecionada

  • Quando Auto Size está habilitado, a vista do desenho de layout ajusta automaticamente seu tamanho para remover espaços vazios nas bordas.

  • Selecione o Justification clicando na seta correspondente ao alinhamento desejado ou no círculo para centralizar. A opção escolhida para Justification define o ponto em relação ao qual a posição da vista é alterada caso seu tamanho seja atualizado.

Vistas adicionais

Vistas adicionais podem ser usadas para complementar seu desenho de fabricação: vista de detalhe do chicote elétrico e vista de componente.

Uma vista de detalhe do chicote elétrico permite exibir uma área definida de um desenho existente como uma vista flutuante e ampliada de seus detalhes. Estão disponíveis opções de área circular e retangular para a vista de detalhe do chicote elétrico. Para inserir a vista desejada, selecione uma opção (Circle area detail view ou Rectangle area detail view) no menu principal Place » Additional Views » Harness Detail View.

Javascript ID: Harness_MD_HarnessDetailView_AD24

Um exemplo de vista de detalhe do chicote elétrico com área circular aplicada a uma vista do diagrama de fiação

Um exemplo de vista de detalhe do chicote elétrico com área retangular aplicada a uma vista do diagrama de fiação

A vista de componente (Place » Additional Views » Component View) é uma vista de desenho de um único componente do projeto de chicote elétrico atual.

Um exemplo de vista de componente
Um exemplo de vista de componente

Anotação e cotagem do desenho

Uma série de ferramentas adicionais de anotação, cotagem e desenho está disponível para adicionar informações importantes a um desenho de fabricação. Elas incluem sistemas automatizados de notas e destaque, além de ferramentas para indicar os comprimentos, tamanhos e ângulos dos contornos dos objetos ou a distância entre objetos especificados.

Um exemplo de uma vista de desenho de layout com anotações
Um exemplo de uma vista de desenho de layout com anotações

  • Uma chamada associada a um conector ou a um ponto de conexão e configurada para exibir o item da BOM mostra os números de posição dos itens da BOM do próprio conector/ponto de conexão e de suas peças associadas. Uma chamada adicionada à vista física de um componente em uma vista de desenho de layout também exibirá os números de posição dos itens da BOM de todas as cavidades atribuídas a esse componente.

  • Quando uma cota linear é inserida entre pontos de conexão em uma vista de desenho de layout, o campo Value  (o comprimento da cota) é preenchido automaticamente com o comprimento do feixe de chicote correspondente.

Consulte as páginas a seguir para saber mais:

Trabalhando com tabelas

Um documento de desenho de fabricação permite inserir uma lista de materiais (BOM), uma lista de fiação, uma tabela de conexões e uma tabela genérica no desenho. Os dados tabulares são derivados diretamente dos documentos do projeto e oferecem uma maneira simples e visual de transmitir informações essenciais para os processos de fabricação de chicotes.

  • Nas propriedades da lista de materiais, da lista de fiação e das tabelas de conexões, você pode especificar Length Units e Value Precision de comprimento (substituindo os valores especificados no nível do documento). As opções selecionadas serão aplicadas aos valores de comprimento exibidos na tabela correspondente.

  • Para componentes de fiação do chicote, a coluna Length de uma tabela de lista de materiais apresenta o comprimento total dos fios/cabos do mesmo item da BOM, em vez de seus comprimentos individuais.

  • As coberturas de fios, cabos e chicotes são objetos baseados em comprimento, e o valor é exibido no campo Length . O campo Quantity  desses objetos é As Required.

  • Quando qualquer objeto de tabela é copiado do documento de desenho de fabricação, seu conteúdo pode ser colado em uma planilha do Microsoft Excel.

Saiba mais sobre como trabalhar com a Lista de materiais e Tabelas.

Lista de fiação

Uma lista de fiação (Place » Wiring List) é um objeto de tabela gerado automaticamente que exibe os pontos inicial e final e os valores dos parâmetros de cada fio do chicote.

Um exemplo de lista de fiação
Um exemplo de lista de fiação

As propriedades de uma lista de fiação inserida (como atributos visuais e conteúdo dos dados) podem ser configuradas no painel Properties quando a lista de fiação é selecionada na área de projeto.

As abas do painel Properties quando uma lista de fiação é selecionada 
As abas do painel Properties quando uma lista de fiação é selecionada

  • Os designadores de objetos de blindagem com conexão são exibidos na lista de fiação quando um fio está conectado ao objeto.

  • Se um fio tiver o valor No para seu parâmetro Include Cut, ele não será apresentado na lista de fiação.

  • Os parâmetros dos fios (e seus valores) especificados no diagrama de fiação são refletidos na lista de fiação. Uma coluna adicional é adicionada à lista de fiação para cada parâmetro de fio. Essas colunas adicionais ficam ocultas por padrão. Use os controles de visibilidade na aba Columns do painel Properties quando a lista de fiação estiver selecionada para mostrar essas colunas na área de projeto (e ocultar as colunas padrão, se necessário).

  • Fios multicoloridos são compatíveis com listas de fiação ():

    • As células da coluna Color são divididas para mostrar as cores secundária e terciária atribuídas ao fio.

    • A coluna ColorName inclui os nomes das cores principal, secundária e terciária.

    • Colunas adicionais para as cores secundária, terciária e da borda podem ser exibidas.

  • Para fios em um cabo, a coluna Length de uma lista de fiação exibe o comprimento individual de cada fio.

  • Para o conector de passagem (o conector com o maior número de cavidades), o agrupamento automático é aplicado à lista de fiação, garantindo que todas as suas cavidades sejam agrupadas corretamente na coluna From.

  • Use os botões  e  para mover uma coluna visível cuja entrada esteja selecionada na aba Columns uma posição para a esquerda ou para a direita na lista de fiação.

  • Clique em uma célula da coluna Order para alternar entre as opções de ordenação dos dados das colunas da tabela (desativada, crescente e decrescente). A ordenação pode ser aplicada a várias colunas por ordem de prioridade mantendo Ctrl pressionado e clicando nas células da coluna Order.

  • O conector com o maior número de fios (e todas as suas cavidades) é agrupado automaticamente na coluna From  ().

Dividindo uma lista de fiação

A lista de fiação de um projeto avançado de chicote pode ter um grande número de entradas, o que dificulta acomodá-la em um documento de desenho como uma única tabela. Em vez de recorrer ao redimensionamento da fonte e da tabela, a várias entradas de tabela personalizadas ou a um documento externo, você pode “dividir” uma tabela de lista de fiação para que ela seja apresentada em várias “páginas”.

No painel Properties  de uma lista de fiação inserida, habilite a opção Limit Page Height na região Pages  para limitar a altura da tabela ao valor de altura especificado (Max Page Height) e, consequentemente, o número de linhas exibidas na tabela.

Javascript ID: Harness_MD_WiringList_LimitPageHeight_AD25_3

O editor detecta que a lista de fiação inteira não está sendo exibida, conforme indicado pela entrada Page do painel (por exemplo, Page 1 from 2), e o menu suspenso associado permite especificar qual página será exibida. Para adicionar mais páginas à lista de fiação, insira outra lista de fiação e especifique a próxima Page na região Pages do painel Properties .

Como cada página da lista de fiação é inserida adicionando outra tabela de lista de fiação e configurando-a adequadamente, as páginas individuais da lista de fiação podem ser inseridas em qualquer folha do documento de desenho de fabricação.

Observe que a propriedade Max Page Height especifica a altura da página first na tabela da lista de fiação. Quando a segunda página é selecionada (Página 2), a propriedade Max Page Height define a altura da primeira página excluída (Página 1). A página 2, portanto, mostra as entradas restantes da lista de fiação. Comece ajustando a Max Page Height propriedade idêntica para cada página.

Tabela de conexões

Uma tabela de conexões (Place » Connection Table) é um objeto de tabela gerado automaticamente que mostra os fios conectados a cada ponto de conexão (pino de conector, emenda etc.) no chicote.

Exemplo de uma tabela de conexões (para todos os componentes)
Exemplo de uma tabela de conexões (para todos os componentes)

As propriedades de uma tabela de conexões inserida (como atributos visuais e conteúdo dos dados) podem ser configuradas no painel Properties quando a tabela de conexões está selecionada na área de projeto.

As abas do painel Properties quando uma tabela de conexões está selecionada 
As abas do painel Properties quando uma tabela de conexões está selecionada

  • Você pode usar a opção Component para mostrar na tabela os dados de todos os componentes do projeto ou os dados de um componente ou de uma emenda específica.

  • Se um fio tiver o valor No em seu parâmetro Include Cut, esse fio não será apresentado na tabela de conexões.

  • Os parâmetros dos fios (e seus valores) especificados no diagrama de fiação são refletidos na tabela de conexões. Uma coluna adicional é adicionada à tabela de conexões para cada parâmetro de fio. Essas colunas adicionais ficam ocultas por padrão. Use os controles de visibilidade na aba Columns do painel Properties quando a tabela de conexões estiver selecionada para mostrar essas colunas na área de projeto (e ocultar as colunas padrão, se necessário).

  • Fios multicoloridos são compatíveis com tabelas de conexões ():

    • As células da coluna Color são divididas para mostrar as cores secundária e terciária atribuídas ao fio.

    • A coluna ColorName inclui os nomes das cores principal, secundária e terciária.

    • Colunas adicionais para as cores secundária, terciária e de borda podem ser exibidas.

  • Para fios em um cabo, a coluna Length em uma tabela de conexões exibe o comprimento individual de cada fio.

  • Use os botões  e  para mover uma coluna visível cuja entrada esteja selecionada na aba Columns uma posição para a esquerda ou para a direita na tabela de conexões.

  • Clique em uma célula na coluna Order para alternar entre as opções de ordenação dos dados das colunas da tabela (desativada, crescente e decrescente). A ordenação pode ser aplicada a várias colunas por ordem de prioridade, mantendo Ctrl pressionado e clicando nas células da coluna Order.

  • Use a lista suspensa Display no painel Properties para configurar os dados exibidos na tabela:

    • Wires Only – mostrar apenas os pinos que têm fios conectados a eles.

    • Wires & Parts – mostrar os pinos que têm fios conectados a eles e quaisquer peças adicionadas às cavidades, como um tampão no caso de um conector selado sem fio.

    • All Cavities – mostrar todos os pinos de todos os componentes, independentemente dos fios conectados e das cavidades adicionadas (por exemplo, se houver um componente de 10 pinos, todos os 10 pinos serão mostrados na tabela).

    • No Connect – mostrar apenas objetos de “não conectado”.

Divisão de uma tabela de conexões

A tabela de conexões de um projeto avançado de chicote pode ter um grande número de entradas, o que pode dificultar sua acomodação em um documento de desenho como uma única tabela. Em vez de recorrer ao redimensionamento da fonte e da tabela, a várias entradas de tabela personalizadas ou a um documento externo, você pode “dividir” uma tabela de conexões em um documento do Harness Draftsman (*.HarDwf) para que ela seja apresentada em várias “páginas”. No painel Properties  de uma tabela de conexões inserida, habilite a opção Limit Page Height na região Pages  para usar o novo recurso. Isso limitará a altura da tabela de conexões ao valor de altura especificado (Max Page Height) e, portanto, o número de linhas mostradas na tabela.

 

O editor detecta que a tabela de conexões não está sendo mostrada por completo, conforme indicado pela entrada Page do painel (por exemplo, 1 from 2), e o menu suspenso associado permite especificar qual página é mostrada. Para adicionar mais páginas da tabela de conexões, insira outra tabela de conexões (Place » Connection Table) e especifique a próxima Page na região Pages do painel Properties .

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents