Criando o desenho de layout

Num relance

Este artigo orienta você no processo de criação de um desenho de layout de chicote no Altium Designer após a conclusão do diagrama de fiação, começando por como adicionar o documento de layout, configurar as principais opções do documento e importar dados do diagrama de fiação. Ele também apresenta como os componentes aparecem no layout, quais propriedades você pode configurar e como alternar entre representações simbólicas e de modelos físicos para uma visualização mais clara do layout. Se você busca uma visão geral prática de como transformar os dados registrados no projeto do chicote em um desenho de layout físico e entender as principais opções de configuração envolvidas, este artigo ajudará você a se orientar e a se preparar para trabalhar. Continue lendo para criar o layout do seu chicote com confiança.

- Aprenda a criar e configurar um documento de desenho de layout de chicote, incluindo unidades, grades, opções de página e modelos.
- Veja como os dados do diagrama de fiação são importados para o desenho de layout e como as atualizações do diagrama de fiação podem ser importadas novamente mais tarde.
- Entenda como os componentes são representados e configurados no desenho de layout, incluindo visualizações de símbolos e modelos físicos e as configurações de propriedades relacionadas.
Aprofunde-se com a IA:

Depois que o projeto do chicote tiver sido registrado na forma de um diagrama de fiação, a representação física do projeto poderá ser criada como um desenho de layout do chicote (*.LdrDoc). Adicione esse documento ao projeto do chicote pelo painel Projects, clicando com o botão direito na entrada do projeto e selecionando Add New to Project » Harness Wiring Diagram no menu de contexto (ou use o comando File » New » Harness Layout Drawing nos menus principais).

Configurando um documento de desenho de layout do chicote

As opções de um documento de desenho de layout podem ser configuradas no painel Properties quando nenhum objeto estiver selecionado no espaço de projeto do documento. As principais configurações são:

  • Na região General da guia General do painel – selecione as unidades de medida aplicáveis ao documento e aos seus elementos gráficos e configure as grades para facilitar o posicionamento. O Altium Designer oferece três tipos de grade: grade visível para navegação, grade de ajuste para posicionamento e distância de ajuste para auxiliar na criação de conexões.

  • Na região Page Options da guia General do painel – configure o tamanho da folha e o bloco de título do documento ou selecione um dos modelos de desenho de layout do chicote disponíveis.

As guias General e Parameters do painel Properties quando nenhum objeto está selecionado no documento de desenho de layout do chicote 
As guias General e Parameters do painel Properties quando nenhum objeto está selecionado no documento de desenho de layout do chicote

  • A configuração de um documento de desenho de layout do chicote é semelhante à configuração de um documento esquemático (*.SchDoc) de um projeto de PCB. Consulte a página Configurando um documento esquemático para saber mais.

  • Use a lista suspensa Length Units para escolher as unidades de comprimento do documento. Os valores de Feixe Length e os valores de Length Value e Offset Length do objeto de feixe serão exibidos nas unidades selecionadas. As unidades compatíveis são mm, cm, m, in e ft. As unidades de comprimento padrão dos documentos de desenho de layout recém-criados podem ser definidas na página Projeto de chicote – Geral da caixa de diálogo Preferences.

  • Para saber mais sobre a criação de modelos de documentos de desenho de layout, consulte a página Criando documentos de modelo de chicote.

  • As propriedades padrão dos objetos de desenho de layout do chicote podem ser configuradas na página Projeto de chicote – Padrões da caixa de diálogo Preferences. Essas propriedades serão aplicadas ao posicionar objetos subsequentes.

  • Ao criar um documento de desenho de layout do chicote, você também pode usar objetos de texto e de desenho. Trabalhar com esses objetos em um documento de desenho de layout do chicote é semelhante a trabalhar com eles em um documento esquemático (*.SchDoc) de um projeto de PCB. Consulte Trabalhando com objetos de texto em um esquemático e Trabalhando com objetos de desenho em um esquemático para saber mais sobre esses objetos.

    • Observe que links ativos para objetos do diagrama de fiação do chicote (por exemplo, fios e componentes) e objetos do desenho de layout do chicote (por exemplo, feixes e pontos de conexão) também são compatíveis com quadros de texto e notas. Clique em um link no quadro de texto ou na nota posicionados para localizar esse objeto no documento associado por meio de sondagem cruzada.

  • Para verificar se há violações lógicas, elétricas e de desenho no desenho de layout do chicote, estão disponíveis diversas verificações de violações. Consulte a página Validando o projeto do chicote para saber mais.

  • Um documento de desenho de layout do chicote pode ser salvo no formato ASCII, o que pode ser útil para compartilhamento. Use o comando File » Save As e selecione Harness Layout ascii (*.LdrDoc) na lista suspensa Save as type da caixa de diálogo Save As que será aberta. Ao salvar um desenho de layout em ASCII usando o comando File » Save, a caixa de diálogo File Format será aberta, informando que o formato ASCII está sendo usado. Escolha a versão ASCII na caixa de diálogo para continuar usando esse formato.

Importando dados do diagrama de fiação

Selecione o comando Design » Import Wiring Diagram nos menus principais para importar os dados do projeto do diagrama de fiação. O componente será posicionado na folha de desenho de layout nas posições relativas definidas no diagrama de fiação. Os pontos de conexão associados aos componentes também serão posicionados ao lado de cada componente no desenho de layout.

Um documento de desenho de layout do chicote com os dados importados do diagrama de fiação
Um documento de desenho de layout do chicote com os dados importados do diagrama de fiação

 
 
 
 
 
  • Depois de usar o comando, as alterações aplicadas são listadas no painel Messages ().

  • Quaisquer alterações no diagrama de fiação podem ser importadas para o desenho usando o mesmo comando Design » Import Wiring Diagram.

Trabalhando com componentes

Inicialmente, cada componente é representado no desenho de layout por seu símbolo. As propriedades de um componente posicionado podem ser configuradas no painel Properties quando o componente estiver selecionado no espaço de projeto. O painel Properties de um componente inclui as seguintes guias:

 
 
 
 
 
  • General – propriedades gerais do componente, como designador e comentário, localização, representação do modelo, parâmetros etc.

  • Pins – a lista de pinos do componente.

  • Cavities – uma visualização somente leitura das cavidades do conector atribuídas ao componente. As atribuições de cavidades só podem ser modificadas no diagrama de fiação – saiba mais.

  • Associated Parts – permite atribuir peças adicionais, como tubos termorretráteis, ao componente.

Ao colar componentes de chicote recortados/copiados em um desenho de layout de chicote, os designadores dos componentes colados respeitam a opção Reset Parts Designators On Paste da página Esquemático – Edição gráfica da caixa de diálogo Preferences. Quando os componentes são colados, a parte numérica de seus designadores é redefinida para ? quando a opção está ativada.

Configuração da representação de um componente

Usando a opção Graphical Symbol / Physical Model na região Model do painel Properties (na aba General) quando um componente está selecionado, você pode alternar entre a representação por símbolo (o símbolo do componente) e a projeção do modelo 3D (o footprint do componente). Use as outras configurações na região do painel para configurar a representação.

Javascript ID: Harness_LD_HarnessComponent_ModelType_AD25

Um componente representado por seu símbolo esquemático

O mesmo componente representado pela projeção de seu modelo 3D

Ao usar a representação Physical Model, use as opções Style para exibir o modelo como Solid (sem linhas) ou como Wireframe. Use as opções da lista suspensa Side para selecionar o lado desejado da vista do modelo (há opções ortogonais e isométricas disponíveis). As imagens abaixo demonstram algumas das configurações com os resultados correspondentes na área de projeto.

Javascript ID: Harness_LD_HarnessComponent_ModelType_Footprint_Config_AD25

Uma vista de modelo físico pode ser girada graficamente na área de projeto usando o mouse para arrastar a alça de rotação localizada no canto inferior direito da vista do modelo; o campo Rotation será atualizado automaticamente (a rotação ocorre em incrementos de 1 grau). Você também pode manter a tecla Alt pressionada para restringir a rotação a incrementos de 45 graus. Como auxílio, quando a vista é girada com o mouse, o ângulo atual é exibido em Status Bar.

Se um projeto contendo modelos que foram girados usando valores personalizados for aberto em uma versão do Altium Designer anterior à 26.9, uma mensagem de aviso de compatibilidade com versões anteriores será exibida. Você pode gerar novamente os modelos físicos usando a funcionalidade anterior, ou seja, as seleções nas listas suspensas. 

  • Para ambos os estilos Solid e Wireframe, o valor Zoom define o tamanho da caixa delimitadora verde da vista do modelo na área de projeto, e a vista do modelo sempre se ajusta à caixa delimitadora.

  • Para facilitar a integração ao usar o Altium MCAD CoDesigner com projetos de chicotes, os modelos 3D usados nas vistas físicas dos componentes de chicote são incorporados (no formato Parasolid) ao documento de desenho de layout. Quaisquer modelos 3D ausentes (existentes, mas não incorporados) serão incorporados após salvar o documento (File » Save). Este recurso está em Beta aberto e fica disponível quando a opção HarnessDesign.Embed3DModel está ativada na caixa de diálogo Configurações avançadas.

Adding Multiple Physical Model Views

  • Use a seta da lista suspensa para visualizar e editar as propriedades de uma vista física ().

  • É possível adicionar várias vistas de modelo físico para um componente usando o controle Add Component View no painel Properties ().

  • As vistas físicas adicionais adicionadas a um componente podem ser movidas de forma independente na área de projeto usando a ação de arrastar e soltar.

  • Independentemente de qual vista de modelo físico de um componente esteja selecionada na área de projeto, o painel Properties exibe as propriedades do próprio componente.

Definição da disposição física em um desenho de layout de chicote

Todas as conexões físicas no chicote são definidas como feixes de chicote (mesmo que um feixe contenha apenas um único fio). Cada feixe deve começar e terminar em um ponto de conexão. Na importação inicial dos dados de projeto do chicote (conforme descrito acima), um ponto de conexão é inserido automaticamente ao lado de cada componente e associado ao componente e a todos os seus pinos. Se a estrutura física do projeto exigir, novos pontos de conexão poderão ser inseridos, e os objetos atribuídos a um ponto de conexão poderão ser configurados.

Para ajudar a compreender a conectividade dos componentes no documento de desenho de layout de chicote, você pode exibir o grafo de conectividade no documento. Quando a opção Connective Graph estiver habilitada na página Sistema – Navegação da caixa de diálogo Preferences, use o atalho Alt+Click sobre um componente para exibir o grafo de conectividade na área de projeto (). Limpe o grafo usando o atalho Shift+C ou o comando Clear Filter do menu de contexto da área de projeto.

Trabalho com pontos de conexão

Para inserir um novo ponto de conexão, use o comando Place » Connection Point nos menus principais. Os pontos de conexão são exibidos na área de projeto conforme mostrado abaixo.

As propriedades de um ponto de conexão inserido (sua localização, representação visual etc.) podem ser configuradas no painel Properties quando o ponto de conexão estiver selecionado na área de projeto.

O painel Properties quando um ponto de conexão está selecionado
O painel Properties quando um ponto de conexão está selecionado

Use a região Associated Parts do painel Properties de um ponto de conexão selecionado para gerenciar a lista de peças associadas ao ponto de conexão, ou seja, os objetos físicos que você deseja associar à representação gráfica exibida. O modelo 3D de uma peça associada a um ponto de conexão pode ser usado para representar o ponto de conexão no documento. Com um ponto de conexão selecionado, escolha Physical Model na região Properties do painel Properties e, em seguida, use a lista suspensa Associated Part na região Type para selecionar a peça associada desejada (). O modelo será gerado e exibido no documento. Use as opções na região Type para configurar a exibição do modelo ().

Para facilitar a integração ao usar o Altium MCAD CoDesigner com projetos de chicotes, os modelos 3D usados nas vistas físicas dos pontos de conexão são incorporados (no formato Parasolid) ao documento de desenho de layout. Quaisquer modelos 3D ausentes (existentes, mas não incorporados) serão incorporados após salvar o documento (File » Save). Esse recurso está em Open Beta e fica disponível quando a opção HarnessDesign.Embed3DModel está habilitada na caixa de diálogo Configurações avançadas.

Atribuição de objetos a pontos de conexão

Os objetos atribuídos a um ponto de conexão podem ser configurados conforme necessário, de acordo com a intenção do seu projeto. Um ou mais objetos (componentes, emendas/derivações, objetos 'sem conexão' e blindagens com conexão) podem ser atribuídos a um ponto de conexão usando a caixa de diálogo Add Assigned Objects, acessada clicando no botão   na região Assigned Objects  do painel Properties .

  • Por padrão, a opção Show only unassigned objects está habilitada na caixa de diálogo, e apenas os objetos que não estão atualmente atribuídos a outros pontos de conexão são listados. Desabilite a opção para exibir uma lista de todos os objetos no desenho de layout.

  • Se um objeto já atribuído a outro ponto de conexão for selecionado na caixa de diálogo, os avisos e ícones correspondentes serão exibidos ().

  • Para evitar que uma emenda seja atribuída a mais de um ponto de conexão, ela é removida automaticamente de um ponto de conexão se já estiver atribuída a outro ponto de conexão.

Quando um componente é atribuído a um ponto de conexão, uma linha traço-ponto é exibida na área de projeto entre o componente e o ponto de conexão, conforme mostrado abaixo. Em Properties, você pode selecionar quais pinos do componente são atribuídos. Clique na célula da coluna Pins da grade na região Assigned Objects para acessar a lista suspensa e selecionar os pinos desejados do componente.

Ao arrastar um ponto de conexão sobre outro (quando válido) no desenho de layout, os dois são unidos em um único objeto, e suas listas de objetos atribuídos são mescladas.

Trabalho com feixes de chicote

Para inserir um novo feixe de chicote, use o comando Place » Harness Bundle nos menus principais (atalho: Shift+B).

Após selecionar o comando, clique em um ponto de conexão (uma cruz vermelha aparece no cursor quando ele está sobre o ponto de ancoragem de um ponto de conexão) para inserir o ponto inicial do feixe de chicote. Posicione o cursor e clique para ancorar uma série de vértices que definem o formato do feixe de chicote. Após inserir o último vértice no ponto de ancoragem de outro ponto de conexão, clique com o botão direito para concluir a inserção.

Por padrão, um feixe de chicote é inserido usando o modo de inserção Any Angle. Ao inserir um feixe de chicote, pressione Shift+Spacebar para alternar entre os modos de inserção. O modo especifica como os cantos são criados ao inserir feixes e os ângulos nos quais os feixes podem ser inseridos.  Nos modos 90 Degree ou 45 Degree (modos verdadeiramente ortogonais), pressione Spacebar para alternar entre os submodos de início e fim. O modo e o submodo atuais são exibidos na barra de status.

Um exemplo de feixe de chicote inserido entre os pontos de conexão CP1 e CP_P2.
Um exemplo de feixe de chicote inserido entre os pontos de conexão CP1 e CP_P2.

Após o posicionamento e a seleção, os vértices de um feixe de chicote podem ser arrastados para alterar o ângulo entre duas seções adjacentes.

  • Quando feixes de chicote são conectados a um ponto de conexão, as emendas ainda não atribuídas serão automaticamente atribuídas ao ponto de conexão de acordo com o diagrama de fiação.

  • Um ponto de conexão pode ser posicionado diretamente sobre um feixe de chicote existente. Isso divide o feixe de chicote original em dois feixes separados.

  • Quando um ponto de conexão que divide um feixe em dois em um desenho de layout é removido, os dois feixes são automaticamente mesclados em um único objeto de feixe.

As propriedades de um feixe de chicote posicionado (localização, representação visual etc.) podem ser configuradas no painel Properties quando o feixe de chicote está selecionado na área de projeto.

O painel Properties quando um feixe de chicote está selecionado
O painel Properties quando um feixe de chicote está selecionado

Cada feixe de chicote conterá automaticamente os objetos (fios e/ou cabos) de acordo com a conectividade definida no diagrama de fiação. Esses objetos são listados na região Bundle Objects do painel Properties quando o feixe está selecionado. Clique em um objeto nessa lista para destacar todos os feixes pelos quais o objeto selecionado passa.

No caso de uma estrutura física complexa e ramificada de um feixe, pode ser necessário alterar a atribuição de um fio para outro feixe. Use a lista suspensa na região Bundle Objects Assignment do painel Properties quando o feixe desejado estiver selecionado na área de projeto para atualizar a atribuição do fio a esse feixe conforme necessário.

Usando o campo Length na região Properties do painel, você pode definir o comprimento do feixe selecionado. Os comprimentos dos fios e cabos que passam pelos feixes são calculados com base nos valores de Length desses feixes. Os valores calculados de comprimento dos fios/cabos são mostrados na coluna Length Value da grade na região Bundle Objects do painel.

Adição de uma vista de segmento de fios

A vista de segmento de fios exibe os fios que estão dentro do segmento, ou seja, fios individuais, pares de fios trançados e fios que fazem parte de cabos. Isso permite ver exatamente como os fios se acomodam fisicamente dentro do segmento do feixe de chicote. Cada fio é identificado e exibido com sua cor definida, assim como sua espessura, baseada no valor de seu parâmetro Thickness (definido no diagrama de fiação (*.WirDoc)). Você pode inserir uma vista de segmento de um segmento de feixe já posicionado em um desenho de layout (*.LdrDoc) usando o comando Add Segment View na região Model do painel Properties . A região Segment View passa então a exibir uma lista suspensa na qual você pode selecionar o nível de Zoom para a vista adicionada. A área de projeto amplia a vista, conforme mostrado na apresentação de slides de exemplo abaixo. Para excluir uma vista de segmento, use o comando Delete na região Segment View. Clique para selecionar a vista e mova-a para o local desejado na área de projeto.

Clique em Add Segment View para adicionar uma nova vista.

A lista suspensa Zoom permite escolher o nível de zoom necessário para a vista de segmento. 

As propriedades dos fios do diagrama de fiação são transferidas para a vista de segmento, conforme mostrado para W9.

Para remover a vista de segmento, clique em Delete.  

Adição de um ponto de quebra

Um ponto de quebra, usado para indicar que o feixe está fora de escala (NTS), pode ser posicionado em um feixe de chicote. O feixe exibirá um símbolo de quebra no meio de seu segmento mais longo, conforme mostrado na primeira imagem abaixo, e as propriedades exibirão Drawn Length. Para inserir uma quebra, habilite a opção Add Break Symbol na região Properties das propriedades do feixe. Os revestimentos de chicote que cobrem um feixe de chicote com um ponto de quebra também exibirão a quebra no mesmo local. Se o revestimento do chicote terminar no ponto de quebra do feixe de chicote, ele será desenhado um pouco mais longo, conforme mostrado na segunda imagem.

Um ponto de quebra posicionado em um feixe

Um revestimento posicionado sobre um ponto de quebra existente

 
  • Se desejar, você pode substituir o comprimento calculado de um fio/cabo. Insira o valor de Offset Length necessário ou escolha Manual na lista suspensa da coluna Length Type para definir manualmente o comprimento absoluto necessário.

  • Para fios cujo comprimento foi definido em uma ferramenta MCAD e depois importado para o Altium Designer usando o MCAD CoDesigner, a entrada MCAD CoDesigner será mostrada na entrada Length Type. Nesse caso, Offset Length não pode ser definido, mas você pode substituir o valor do comprimento selecionando Manual na lista suspensa (). Saiba mais sobre como sincronizar um projeto de chicote usando o MCAD CoDesigner.

  • As unidades nas quais o valor de Length de um feixe e os valores de Length Value e Offset Length de seus objetos são mostrados no painel Properties quando o feixe está selecionado são especificadas usando a lista suspensa Length Units na guia General do painel Properties quando nenhum objeto está selecionado no documento.

Reatribuindo objetos de feixe

Você pode reatribuir objetos de feixe em um desenho de layout no qual um fio possa percorrer mais de um caminho entre seus conectores de origem e destino. Por padrão, esse fio será atribuído automaticamente ao caminho de feixe mais curto, mas você pode substituir essa atribuição. O controle Assign Objects to Bundle aparece na parte inferior da seção Bundle Objects do painel Properties (com o feixe selecionado na área de projeto), e somente quando existe um caminho de roteamento alternativo. A caixa de diálogo Assign Objects to Bundle é aberta, permitindo selecionar objetos (fios/cabos) para mover entre os feixes aplicáveis e válidos.

Revestindo feixes de chicote

Um objeto de revestimento de chicote (Place » Harness Covering) pode ser colocado sobre um feixe de chicote. O comprimento do revestimento pode ser modificado graficamente na área de projeto durante ou após a colocação.

Após selecionar um comando de colocação de revestimento de chicote, um ponto laranja aparecerá na área de projeto quando o cursor estiver sobre um feixe de chicote, indicando que o revestimento pode ser colocado (um ponto cinza indica que o revestimento de chicote não pode ser colocado naquele local específico). Clique onde deseja que o revestimento comece, mova o cursor ao longo do feixe até o ponto onde deseja que o revestimento termine e clique novamente. Os revestimentos de chicote podem se sobrepor, conforme demonstrado no vídeo abaixo. Você também pode aplicar/estender um revestimento de chicote sobre um ponto de junção (um ponto de conexão no desenho de layout onde dois ou mais feixes se encontram). Isso elimina a necessidade de ter revestimentos de chicote separados entre os pontos de junção em uma seção que contém vários conectores.

O início de um revestimento é considerado o ponto mais à esquerda e mais acima de seu caminho, e o caminho inclui apenas os feixes sobre os quais o revestimento se encontra.

As propriedades de um revestimento de chicote colocado podem ser configuradas no painel Properties quando o revestimento de chicote é selecionado na área de projeto.

O painel Properties quando um revestimento de chicote é selecionado
O painel Properties quando um revestimento de chicote é selecionado

Você pode definir o tamanho de um objeto de revestimento de chicote em relação ao tamanho do feixe que ele reveste (o Line Width do feixe) usando a lista suspensa Size no painel Properties. Percorra as imagens abaixo para ver exemplos de revestimentos de chicote de diferentes tamanhos com feixes de chicote de vários tamanhos.

 
 
 
 
 
 

Depois que um revestimento de chicote é colocado no desenho de layout, você pode atribuir a ele um componente de biblioteca (ou, se um componente já estiver atribuído ao revestimento de chicote, selecionar outro componente). Para fazer isso, selecione o revestimento de chicote e clique no botão  à direita do campo Design Item ID na região General do painel Properties. Na caixa de diálogo Replace que é aberta, localize e selecione o componente desejado. O revestimento de chicote colocado será atualizado com os parâmetros do componente escolhido.

Adicionando etiquetas de layout

Etiquetas físicas podem ser colocadas no desenho de layout (Place » Layout Label).

As propriedades de uma etiqueta de layout colocada (seu designador, texto, representação visual etc.) podem ser configuradas no painel Properties quando a etiqueta de layout é selecionada na área de projeto.

O painel Properties quando uma etiqueta de layout é selecionada
O painel Properties quando uma etiqueta de layout é selecionada

Ao definir o texto da etiqueta no campo Text, use Ctrl+Enter ou Shift+Enter para adicionar uma nova linha de texto. Habilite Show only first line para exibir apenas a primeira linha do campo Text na área de projeto. O texto da etiqueta de layout também pode ser alinhado de acordo com suas necessidades usando os controles Alignment.

Javascript ID: Harness_LD_LayoutLabel_TextOptions_AD25

Adicionando etiquetas de layout a feixes

As etiquetas de layout seguem automaticamente a orientação do feixe de chicote ao qual estão vinculadas. A etiqueta de layout se ajusta ao feixe para acompanhar sua orientação e seu caminho. Durante ou após a colocação da etiqueta de layout, pressione Spacebar para girar a etiqueta em incrementos de 90 graus ou atualize o valor de Rotation no painel Properties .

Se você não quiser que a etiqueta siga a orientação do feixe (ou seja, que não se ajuste a ele), pressione a tecla Alt durante a colocação para posicionar a etiqueta no local desejado, conforme mostrado no vídeo abaixo.

Quando o feixe que inclui uma etiqueta ajustada a ele é movido, a posição da etiqueta de layout é recalculada e acompanha o feixe.

  • Para exibir o texto da etiqueta na BOM, você pode habilitar a coluna Label Text no documento ActiveBOM do projeto () ou na tabela BOM do desenho de fabricação (). Observe que a propriedade Type da etiqueta de layout deve ser definida como Standard para que ela apareça na BOM ().

  • Após inserir uma etiqueta de layout no desenho de layout, você pode atribuir a ela um componente de biblioteca (ou, se já houver um componente atribuído à etiqueta de layout, selecionar outro componente). Para isso, selecione a etiqueta de layout e clique no botão  à direita do campo Design Item ID na região General do painel Properties. Na caixa de diálogo Replace que se abre, localize e selecione o componente desejado. A etiqueta de layout inserida será atualizada com os parâmetros do componente escolhido.

Atualização de objetos do desenho de layout a partir de bibliotecas

Os seguintes objetos podem ser atualizados a partir de sua biblioteca de origem no Workspace:

  • Componentes de chicote

  • Peças associadas a componentes de chicote

  • Peças associadas a pontos de conexão

  • Revestimentos de chicote

  • Etiquetas de layout

Quando um objeto é selecionado, as informações sobre o componente vinculado do Workspace podem ser encontradas no painel Properties (por exemplo, na guia Associated Parts para as peças associadas de um componente de chicote ou na região General para uma etiqueta de layout).

Se houver uma revisão mais recente do componente do Workspace disponível, a entrada do status da revisão indicará isso com o texto Out of date. No nível de cada objeto, o vínculo pode ser atualizado para a revisão mais recente do componente do Workspace clicando no botão .

Um exemplo de indicação de uma revisão desatualizada de componente de chicote​
Um exemplo de indicação de uma revisão desatualizada de componente de chicote

O recurso Update from Libraries (Tools » Update from Libraries) também pode ser usado para atualizar componentes desatualizados vinculados aos objetos listados acima. Observe que, para um objeto ser incluído na atualização usando o recurso Update from Libraries, o componente atribuído ao objeto deve incluir um vínculo com um símbolo esquemático.

Anotação de objetos do desenho de layout do chicote

Use os comandos do menu Tools » Annotation para anotar os seguintes objetos no documento de desenho de layout do chicote:

  • Componentes de chicote

  • Pontos de conexão

  • Feixes do chicote

  • Revestimentos de chicote

  • Etiquetas de layout

A anotação de objetos em um documento de desenho de layout do chicote é semelhante à anotação de componentes em um documento esquemático (*.SchDoc) de um projeto de PCB. Use os links a seguir para saber mais sobre os comandos de anotação disponíveis para um documento de desenho de layout do chicote:

Navegação cruzada entre o diagrama de fiação e o desenho de layout

Há suporte para navegação cruzada entre o diagrama de fiação e o desenho de layout de um projeto de chicote. O comando Cross Probe pode ser acessado no menu principal Tools e no menu de contexto do espaço de projeto.

A navegação cruzada pode ser realizada:

  • Entre componentes no diagrama de fiação e no desenho de layout.

  • De um fio no diagrama de fiação para os feixes pelos quais esse fio passa no desenho de layout.

  • De um feixe no desenho de layout para os fios que passam por esse feixe no diagrama de fiação.

Javascript ID: Harness_CrossProbe_AD25

Sondagem cruzada de um componente no diagrama de fiação para o componente correspondente no desenho de layout.

Sondagem cruzada de um componente no desenho de layout para o componente correspondente no diagrama de fiação.

Sondagem cruzada de um fio no diagrama de fiação para os feixes correspondentes no desenho de layout.

Sondagem cruzada de um feixe no desenho de layout para os fios correspondentes no diagrama de fiação.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents