Trabalhando com Tabelas

Num relance

Este artigo explica como inserir e configurar tabelas do Draftsman no Altium Designer, com foco nas tabelas de lista de materiais (BOM) e em como seus dados vêm diretamente do projeto de PCB, do ActiveBOM, das variantes e das vistas de montagem. Ele apresenta as principais configurações disponíveis no painel Propriedades, incluindo formatação, seleção da fonte de dados, modos de visualização, filtragem por variante, gerenciamento de colunas e distribuição da BOM em várias páginas para projetos maiores. Se você quer entender melhor como apresentar dados de fabricação e montagem com precisão e organização nos seus documentos do Draftsman, este artigo mostra quais opções estão disponíveis e como utilizá-las de forma eficaz. Continue lendo para ter mais controle sobre a documentação da sua PCB.

- Você aprenderá de onde vêm os dados das tabelas de BOM e como opções como Projeto, Placa, variantes e vistas de montagem afetam o que é exibido.
- Você verá como personalizar a aparência e a estrutura de uma tabela de BOM, incluindo títulos, fontes, cores das linhas, colunas, ordenação e nomes alternativos.
- Você entenderá como funcionam as tabelas de BOM divididas, para poder apresentar listas de materiais extensas em vários objetos de tabela e páginas.
Aprofunde-se com a IA:

Um documento do Draftsman permite inserir uma variedade de tabelas de dados no desenho e configurá-las conforme necessário. Os dados tabulares são obtidos diretamente do documento de PCB do projeto e oferecem uma maneira simples e visual de transmitir informações essenciais para os processos de fabricação e montagem da PCB.

O tipo de tabela a ser inserido pode ser selecionado no menu principal Place.

Lista de materiais

Uma lista de materiais do Draftsman (Place » Bill Of Materials) é um objeto de tabela gerado automaticamente que lista os itens físicos de montagem de um projeto de PCB. Os dados da tabela de BOM são obtidos diretamente do documento ActiveBOM do projeto ou, se o documento ActiveBOM não estiver presente no projeto atual, diretamente dos documentos-fonte do projeto. Uma tabela de BOM também pode representar os itens que compõem uma variante de projeto especificada ou uma vista de montagem da placa inserida.

Uma tabela de lista de materiais dividida em dois objetos de BOM. No exemplo acima, o conteúdo da BOM é filtrado para incluir os itens da vista de montagem do lado superior da placa.
Uma tabela de lista de materiais dividida em dois objetos de BOM. No exemplo acima, o conteúdo da BOM é filtrado para incluir os itens da vista de montagem do lado superior da placa.

O estilo visual e os dados incluídos em uma tabela de lista de materiais inserida podem ser configurados no painel Properties quando a tabela está selecionada na área de trabalho. As propriedades gerais da tabela são configuradas na aba General do painel ().

Título

Título

O texto do título que será exibido (se habilitado) junto à tabela. Use o botão associado para alternar a visibilidade do título no desenho.

O campo pode incluir texto estático e quaisquer parâmetros desejados na forma de strings especiais. Use a sintaxe =<ParameterName> para incluir um parâmetro no título. Os valores dos parâmetros incluídos serão exibidos no título na folha de desenho. Para obter uma lista dos parâmetros de sistema e de PCB disponíveis, consulte a página Configuração de um documento do Draftsman.

Location Selecione o menu suspenso para escolher entre várias posições relativas para o título. A opção Manual é selecionada automaticamente se o título for movido manualmente (arrastado e solto em uma nova posição).
Font

Define a fonte usada no título.

  • Quando a opção Use Document Font está habilitada, a fonte usada no título é a definida pelas opções do documento (a entrada Document Font na região General da aba General do painel Properties quando nenhum objeto está selecionado na área de trabalho).

  • Quando a opção Use Document Font está desabilitada, use as opções fornecidas para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

Propriedades

Table Line Style

Use os menus suspensos para selecionar a linha usada para desenhar a tabela. As opções disponíveis são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado na área de trabalho. Para obter mais informações, consulte a página Configuração de um documento do Draftsman. Use o botão de cor associado para especificar a cor da linha.

Justification Selecione o ponto em relação ao qual a posição da tabela será alterada se seu tamanho for atualizado.
Even Row Color Selecione a cor de contraste para as linhas pares da tabela.
Non-Even Row Color Selecione a cor de contraste para as linhas ímpares da tabela.
Font

Define a fonte usada nos dados da tabela.

  • Quando a opção Use Document Font está habilitada, a fonte usada é a definida pelas opções do documento (a entrada Document Font na região General da aba General do painel Properties quando nenhum objeto está selecionado na área de trabalho).

  • Quando a opção Use Document Font está desabilitada, use as opções fornecidas para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

A tabela será redimensionada automaticamente para acomodar o tamanho de fonte selecionado.

Data Source Esta opção e a possível presença de um documento ActiveBOM no projeto determinam os dados incluídos na tabela:

 

  • Project – quando esta opção está selecionada e o documento ActiveBOM está incluído no projeto atual, sua configuração e seu conteúdo passam a ser a fonte de dados de uma tabela de BOM do Draftsman. Use o comando Tools » Import Changes From <PCBDocumentName>.PcbDoc do Draftsman para incorporar as alterações em tempo real de um documento ActiveBOM.
    Se o documento ActiveBOM não estiver incluído no projeto atual, os dados de uma tabela de BOM do Draftsman serão obtidos diretamente dos documentos-fonte do projeto.

  • Board – quando esta opção está selecionada, as entradas na tabela de BOM do Draftsman ficam restritas aos componentes presentes na PCB física do projeto.

Assembly View Use as opções do menu suspenso para filtrar as entradas da BOM listadas, limitando-as aos itens mostrados em uma vista de montagem da placa especificada.
View Mode
  • Base – uma linha da tabela é atribuída a cada tipo único de componente e lista todos os itens incluídos na coluna Designator.

  • Flat – uma linha da tabela é atribuída a cada item de componente.

  • Consolidated – se o projeto-fonte incluir variantes, a tabela incluirá entradas de componentes de todas as variantes do projeto. Selecionar esta opção definirá automaticamente a opção Variant como [No Variations].

Variant

Use o menu suspenso para selecionar uma variante de projeto, se disponível, como fonte de dados para a tabela de BOM. A tabela refletirá as entradas que não estão incluídas ou que têm parâmetros alterados, de acordo com a opção Show Components.

Quando a opção Document : <VariantName> é selecionada como Variation, uma variante especificada para o documento é aplicada à tabela. A variante no nível do documento é selecionada usando o menu suspenso Variants na região Source da aba General do painel Properties quando nenhum objeto está selecionado na área de trabalho. Para obter mais informações, consulte a página Configuração de um documento do Draftsman.

Show Components

Quando uma variante estiver selecionada, use o menu suspenso para selecionar quais entradas de componentes serão incluídas na lista:

  • Fitted – mostrar apenas os componentes montados na variante de projeto selecionada no momento.

  • All – mostrar todos os componentes.

  • Not Fitted – mostrar apenas os componentes não montados na variante de projeto selecionada no momento.

  • Replaced – mostrar apenas os componentes para os quais foram selecionadas peças alternativas ou componentes montados com valores de parâmetros alterados na variante de projeto selecionada no momento.

Uma tabela de BOM com as opções Fitted, Not Fitted ou Replaced selecionadas para Show Components funciona com as opções Base e Flat selecionadas para View Mode (não Consolidated).

Páginasi

BOM Table ID Um identificador numérico para uma instância de tabela de BOM. A tabela completa pode ser dividida em vários objetos de tabela de BOM (páginas), e o ID permanece o mesmo em todos eles.
Limit Page Height Quando marcada, a tabela de BOM é dividida em uma sequência de páginas virtuais, cada uma com a altura especificada na propriedade Max Page Height.
Max Page Height Define a altura e, portanto, o número de linhas incluídas em cada página da tabela. Apenas uma página é incluída em um objeto de tabela de BOM inserido (consulte Page abaixo), e objetos adicionais de tabela de BOM são inseridos para abranger todas as páginas.
Page Indica o número da página da tabela (1 from 2, 3 from 5 etc.) exibida no objeto de tabela de BOM selecionado. Use o menu suspenso associado para especificar a página desejada para o objeto de tabela de BOM atualmente selecionado.
Show Empty Lines Quando marcada, as linhas em branco da tabela de BOM são exibidas. Normalmente, elas estão na última página de uma tabela de BOM, na qual a altura de página especificada excedeu o número de linhas de dados de BOM disponíveis.

Use a aba Columns do painel Properties para gerenciar as colunas de dados da tabela de BOM.

Manipule as colunas de uma tabela de BOM inserida na aba Columns do painel Properties.
Manipule as colunas de uma tabela de BOM inserida na aba Columns do painel Properties.

  • As entradas podem ser editadas para especificar as colunas incluídas (visíveis) na tabela de BOM e o alinhamento de seu texto (Align).

  • Use a entrada Width para definir a largura da coluna em relação ao texto que ela contém. Insira Auto para que a largura varie dinamicamente para acomodar o texto mais largo das células da coluna.

  • Clique na coluna Order para alternar entre as opções de ordenação dos dados da coluna da tabela (desativada, crescente e decrescente). A ordenação pode ser aplicada a várias colunas com base em prioridades, sendo que as colunas ordenadas à esquerda da tabela têm prioridade mais alta.

  • Os cabeçalhos da tabela de BOM podem ser alterados inserindo um Alias para o nome do parâmetro de uma coluna da tabela – aplica-se quando um documento ActiveBOM não está determinando o conteúdo da tabela (consulte Data Source acima).

  • Use as caixas de seleção de filtro por tipo de coluna para preencher a lista de colunas disponíveis com os tipos de dados de parâmetros correspondentes: BOM (), esquemático (), servidor (), PCB (). Desmarque todos os tipos para listar apenas as colunas visíveis na tabela de BOM.

  • Use os botões  e  para mover a entrada selecionada uma posição para cima ou para baixo e, portanto, para a esquerda ou para a direita na ordem das colunas da tabela de BOM. Disponível para colunas definidas como visíveis.

  • Clique no botão  para restaurar as entradas padrão das colunas da tabela (conforme definido nos padrões do objeto de tabela de BOM na página Draftsman – Padrões da caixa de diálogo Preferences).

Tabelas de BOM divididas

A lista de materiais da maioria dos projetos avançados de PCB tende a ter um grande número de entradas, o que pode dificultar sua reprodução como uma tabela que caiba em um documento de desenho. Em vez de recorrer ao redimensionamento de fontes e tabelas, a várias entradas de tabelas personalizadas ou a um documento externo, o recurso de divisão de BOM permite apresentar uma tabela de BOM em várias “páginas”.

Para criar uma tabela de BOM com várias páginas, selecione uma BOM inserida (que provavelmente excede a altura da folha do documento) e marque a caixa Limit Page Height na região Pages do painel Properties. Isso limitará a altura da tabela ao valor de altura especificado (Max Page Height, mm) e, portanto, o número de linhas exibidas na tabela de BOM.

Javascript ID: Draftsman_BOM_LimitPageHeight

O Draftsman detecta que a BOM inteira não está sendo exibida, conforme indicado pela entrada Page do painel (por exemplo, Page 1 from 2), e o menu suspenso associado permite especificar qual página é exibida. Para adicionar outras páginas da BOM (aqui, BOM Table ID = 0), insira outra BOM e especifique a próxima Page na região Pages do painel Properties .

Como cada página da BOM é inserida adicionando outra tabela de BOM e configurando-a adequadamente, as páginas (seções) individuais da BOM podem ser posicionadas em qualquer folha de um documento Draftsman. Para inserir outro conjunto different de páginas de BOM divididas, especifique um BOM Table ID alternativo em uma BOM inserida – por exemplo, 1 em vez de 0.

Observe que a propriedade Max Page Height especifica a altura da página first na tabela de BOM. Quando a segunda página é selecionada (Página 2), a propriedade Max Page Height define a altura da primeira página excluída (Página 1). A Página 2, portanto, mostra as entradas restantes da BOM. Comece definindo o mesmo valor para a propriedade Max Page Height em todas as páginas.

Tabela de furação

Uma tabela de furação do Draftsman (Place » Drill Table) é um objeto de tabela gerado automaticamente que contém símbolos e dados de furação da placa. A tabela de furação, combinada com a vista de desenho de furação do Draftsman, fornece informações tabulares e gráficas para o processo de fabricação da placa. Uma linha de símbolo, que representa um tipo específico de furo, pode incluir diversas informações sobre os furos, como tamanho, metalização e quantidade. Os tipos de furos são agrupados por símbolos conforme especificado na caixa de diálogo Drill Symbol Configurations.

Uma tabela de furação inserida com entradas de furos agrupadas por tamanho
Uma tabela de furação inserida com entradas de furos agrupadas por tamanho

Quando a extensão de software GOST 2.701-2008/2.106-1996 está instalada na sua instalação do Altium Designer, os valores na coluna Plated da tabela de furação são exibidos como Есть (para furos metalizados) e Нет (para furos não metalizados). 

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

O estilo visual e o conteúdo dos dados de uma tabela de furação inserida, incluindo o símbolo utilizado, podem ser configurados no painel Properties quando a tabela está selecionada na área de projeto. As propriedades gerais da tabela são configuradas na aba General do painel ().

Título

Title

O texto do título que será exibido (se habilitado) com a tabela. Use o botão associado para alternar a visibilidade do título no desenho.

O campo pode incluir texto estático e quaisquer parâmetros desejados na forma de strings especiais. Use a sintaxe =<ParameterName> para incluir um parâmetro no título. Os valores dos parâmetros incluídos serão exibidos no título na folha de desenho. Para obter uma lista dos parâmetros de sistema e de PCB disponíveis, consulte a página Configuração de um documento Draftsman.

Location Selecione o menu suspenso para escolher entre várias posições relativas para o título. A opção Manual é selecionada automaticamente se o título for movido manualmente (arrastado e solto em uma nova posição).
Font

Define a fonte usada para o título.

  • Quando a opção Use Document Font está habilitada, a fonte usada para o título é a definida pelas opções do documento (a entrada Document Font na General região da guia General do painel Properties quando nenhum objeto está selecionado no espaço de projeto).

  • Quando a opção Use Document Font estiver desativada, use as opções disponíveis para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

Propriedades

Layer Pairs Selecione quais furos dos pares de camadas de furação da PCB serão exibidos na vista de desenho. Use o menu suspenso para escolher entre os pares de camadas disponíveis no projeto da placa de origem, que podem ser visualizados e editados no editor de PCB, acessível pelo Gerenciador de empilhamento de camadas. Todos os projetos de placa terão um par de camadas Top - Bottom, enquanto os outros pares representarão furos de vias que passam entre ou até outras camadas, como camadas internas/de plano.

As opções Counterhole Bottom e Counterhole Top estão disponíveis somente quando o documento PCB inclui pads com recursos de rebaixo de furo habilitados nos lados correspondentes da PCB (saiba mais).

Observe que os rebaixos de furo são excluídos dos pares de camadas diferentes de Counterhole Bottom e Counterhole Top. Os rebaixos de furo também são excluídos do par de camadas All Layers.

Pads / Vias Use o menu suspenso para selecionar qual tipo de furo (Pads, Vias ou All) será exibido na tabela.
Plated / Non-Plated Use o menu suspenso para selecionar o tipo de metalização do furo (Plated, Non-Plated ou All) que será exibido na tabela.
Border Line Style

Use os menus suspensos para selecionar a linha usada para representar a borda/o contorno da tabela. As opções disponíveis são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado no espaço de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman. Use o botão de cor associado para especificar a cor da linha.

Justification Selecione o ponto em relação ao qual a posição da tabela será alterada se seu tamanho for atualizado.
Even Row Color Selecione a cor de contraste para as linhas pares da tabela.
Non-Even Row Color Selecione a cor de contraste para as linhas ímpares da tabela.
Font

Define a fonte usada no conteúdo de dados da tabela.

  • Quando a opção Use Document Font estiver ativada, a fonte usada será a definida pelas opções do documento (a entrada Document Font na região General da guia General do painel Properties quando nenhum objeto está selecionado no espaço de projeto).

  • Quando a opção Use Document Font estiver desativada, use as opções disponíveis para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

A tabela será redimensionada automaticamente para acomodar o tamanho de fonte selecionado.

Show Footer Marque para habilitar o rodapé da tabela, que mostra o número total de furos.
Selecione para abrir a caixa de diálogo Drill Symbol Configurations, que fornece uma visualização tabular de todos os dados dos furos e permite definir o estilo e o tamanho de cada símbolo de furo (saiba mais).

Unidades

Primary Units

Selecione o tipo de unidade de medida principal que será exibido na tabela. Use o botão  associado para alternar a visibilidade das unidades de medida.

Quando a opção Document : <Units> for selecionada como Primary Units, as unidades principais especificadas para o documento serão aplicadas à tabela. As unidades principais no nível do documento são selecionadas usando o menu suspenso Primary Units na região Units da guia General do painel Properties quando nenhum objeto está selecionado no espaço de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Dual Units

Selecione o tipo de unidade de medida secundária (dupla) que será exibido na tabela. Use o botão  associado para alternar a visibilidade dos valores das unidades secundárias.

Quando a opção Document : <Units> for selecionada como Dual Units, as unidades duplas especificadas para o documento serão aplicadas à tabela. As unidades duplas no nível do documento são selecionadas usando o menu suspenso Dual Units na região Units da guia General do painel Properties quando nenhum objeto está selecionado no espaço de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Precisão

Primary Units

Use o menu suspenso Value Precision para definir a precisão (até cinco casas decimais, com arredondamento do último dígito) das entradas de tamanho de furo na unidade principal da tabela.

Quando a opção Document : <Precision> for selecionada, a precisão de valor/tolerância da unidade principal especificada para o documento será aplicada à tabela. A precisão do valor e da tolerância da unidade principal no nível do documento é selecionada usando as opções Value Precision e Tolerance Precision para Primary Units na região Units da guia General do painel Properties quando nenhum objeto está selecionado no espaço de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Dual Units

Use o menu suspenso Value Precision para definir a precisão (até cinco casas decimais, com arredondamento do último dígito) das entradas de tamanho de furo na unidade dupla (secundária), se habilitada.

Quando a opção Document : <Precision> for selecionada, a precisão de valor/tolerância da unidade dupla especificada para o documento será aplicada à cota. A precisão do valor e da tolerância da unidade dupla no nível do documento é selecionada usando as opções Value Precision e Tolerance Precision para Dual Units na região Units da guia General do painel Properties quando nenhum objeto está selecionado no espaço de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Use a guia Columns do painel Properties para gerenciar as colunas de dados da tabela de furação ().

  • As entradas podem ser editadas para especificar as colunas incluídas (visíveis) na tabela de furação e seu alinhamento Horizontal e Vertical.

  • Use a entrada Width para definir a largura da coluna em relação ao texto que ela contém. Insira Auto para que a largura varie dinamicamente para acomodar o texto mais largo das células da coluna.

  • Clique na coluna Order para alternar entre as opções de ordenação dos dados da coluna da tabela (desativada, crescente e decrescente). A ordenação pode ser aplicada a várias colunas por prioridade, sendo que as colunas ordenadas à esquerda da tabela têm prioridade mais alta.

  • Os cabeçalhos da tabela de furação podem ser alterados inserindo um Caption para o nome do parâmetro de uma coluna da tabela.

  • Use  e  botões para mover a entrada selecionada uma posição para cima ou para baixo e, portanto, para a esquerda ou para a direita na ordem das colunas da tabela de furação. Disponível para colunas definidas como visíveis.

Os estilos dos símbolos da tabela de furação e o agrupamento dos tipos de furos sob esses símbolos são determinados pelas configurações na caixa de diálogo Drill Symbol Configurations, aberta ao clicar no botão no painel Properties (na região Properties da aba General) quando a tabela está selecionada na área de projeto.

Essa é a mesma caixa de diálogo ativada a partir do painel Properties para uma vista do desenho de furação, mas, neste caso, somente as colunas ativadas (tornadas visíveis) para a tabela de furação serão exibidas. Observe que as duas versões da caixa de diálogo Drill Symbol Configuration têm a mesma origem e, portanto, interagem.

Symbol Graphics Use a lista suspensa para selecionar a representação gráfica desejada para o furo entre diversas formas e letras predefinidas.
Sync Symbols with PCB Quando habilitada, os símbolos da tabela de furação são sincronizados com os da PCB.
Symbol Size Table

Insira o tamanho desejado dos símbolos na tabela.

  • Observe que o tamanho do símbolo será alterado para os símbolos de furação atualmente selecionados na grade na parte superior da caixa de diálogo. Para selecionar vários símbolos de furação na grade, use a técnica Ctrl+Click ou Shift+Click.

  • Observe também que o tamanho fica vinculado entre a vista do desenho de furação e a tabela de furação se o ícone de vínculo for exibido como vinculado (). Para definir o tamanho dos símbolos de furação de forma independente, clique no ícone de vínculo para desvincular os dois tamanhos e defina os tamanhos desejados para cada um.

Symbol Size View Insira o tamanho desejado dos símbolos na vista. Para acessar e editar esse campo, o ícone de vínculo deve ser exibido como desvinculado (). Clique no ícone de vínculo para alternar o estado do vínculo.
Symbol Line Style

Use as listas suspensas para selecionar a linha usada para desenhar a borda/o contorno dos símbolos gráficos. As opções disponíveis são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado na área de projeto. Para obter mais informações, consulte a página Configurando um documento do Draftsman. Use o botão de cor associado para especificar a cor da linha.

Grouping Os critérios escolhidos agruparão as seleções sob um único símbolo. Por exemplo, se apenas HoleSize estiver selecionado, um símbolo individual será atribuído a cada tamanho de furo usado na PCB. À medida que outras opções de agrupamento forem selecionadas, a atribuição de símbolos diferenciará os critérios adicionais, criando um esquema de agrupamento mais detalhado.

Você pode definir as configurações padrão para Symbol Size Table, Symbol Size View, Symbol Line Style e Grouping usando a página Draftsman – Padrões da caixa de diálogo Preferences. Nessa página, selecione Drill Table em Primitive List e abra a aba Drill Symbol na região de propriedades à direita ().

Tabela de linhas de transmissão

Os cálculos aplicados ao roteamento com impedância controlada resultam em estruturas de trilhas que visam atender a uma impedância-alvo da linha de transmissão e, portanto, aos requisitos de alta velocidade e/ou de campo eletromagnético do projeto da placa. As camadas da placa e suas propriedades especificadas ou calculadas são acessadas pelo Gerenciador de Empilhamento de Camadas, onde as camadas de roteamento com impedância controlada são associadas a perfis de impedância configuráveis. Os materiais e as dimensões da placa em cada perfil são aplicados aos cálculos de impedância da linha de transmissão, resultando em uma determinada estrutura de trilhas. A estrutura comporta tanto trilhas individuais quanto pares diferenciais, além de formatos de camadas da placa do tipo stripline (internas) ou microstrip (superficiais).

Para obter mais informações sobre a configuração de perfis de impedância, consulte a página Definindo o empilhamento de camadas.

Como a estrutura e os dados associados a cada definição de linha de transmissão no empilhamento de camadas da placa são informações importantes para o processo de fabricação da PCB, o Draftsman inclui um objeto específico de tabela de linhas de transmissão (Place » Transmission Line Table) para documentar essas informações. A tabela é preenchida com dados obtidos do Gerenciador de Empilhamento de Camadas e de seus cálculos de impedância de linhas de transmissão.

Uma tabela de linhas de transmissão posicionada
Uma tabela de linhas de transmissão posicionada

O estilo visual e o conteúdo dos dados de uma tabela de linhas de transmissão posicionada podem ser configurados no painel Properties quando a tabela está selecionada na área de projeto. As propriedades gerais da tabela são configuradas na aba General do painel ().

Título

Title

O texto do título que será exibido (se habilitado) junto à tabela. Use o botão associado para alternar a visibilidade do título no desenho.

O campo pode incluir texto estático e quaisquer parâmetros desejados na forma de strings especiais. Use a sintaxe =<ParameterName> para incluir um parâmetro no título. Os valores dos parâmetros incluídos serão exibidos no título na folha de desenho. Para obter uma lista dos parâmetros de sistema e da PCB disponíveis, consulte a página Configurando um documento do Draftsman.

Location Use a lista suspensa para escolher entre diversas posições relativas para o título. A opção Manual é selecionada automaticamente se o título for movido manualmente (arrastado e solto em uma nova posição).
Font

Define a fonte usada no título.

  • Quando a opção Use Document Font está habilitada, a fonte usada no título é a definida pelas opções do documento (a entrada Document Font na região General da aba General do painel Properties quando nenhum objeto está selecionado na área de projeto).

  • Quando a opção Use Document Font está desabilitada, use as opções fornecidas para escolher o tipo, o tamanho e a cor da fonte, além dos atributos de texto desejados.

Propriedades

Table Line Style

Use as listas suspensas para selecionar a linha usada para desenhar as linhas da tabela. As opções disponíveis são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado na área de projeto. Para obter mais informações, consulte a página Configurando um documento do Draftsman. Use o botão de cor associado para especificar a cor da linha.

Justification Selecione o ponto em relação ao qual a posição da tabela é alterada caso seu tamanho seja atualizado.
Even Row Color Selecione a cor de contraste para as linhas pares da tabela.
Non-Even Row Color Selecione a cor de contraste para as linhas ímpares da tabela.
Caption Font

Define a fonte usada no conteúdo de dados da tabela.

  • Quando a opção Use Document Font está habilitada, a fonte usada é a definida pelas opções do documento (a entrada Document Font na região General da aba General do painel Properties quando nenhum objeto está selecionado na área de projeto).

  • Quando a opção Use Document Font opção estiver desativada, use as opções disponíveis para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

A tabela será dimensionada automaticamente para acomodar o tamanho de fonte selecionado.

Rows Font

Define a fonte usada no corpo da tabela (o texto nas linhas da tabela).

  • Quando a opção Use Document Font estiver ativada, será usada a fonte definida nas opções do documento (a entrada Document Font na região General da aba General do painel Properties quando nenhum objeto estiver selecionado na área de projeto).

  • Quando a opção Use Document Font estiver desativada, use as opções disponíveis para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

A tabela será dimensionada automaticamente para acomodar o tamanho de fonte selecionado.

Unidades

Primary Units

Selecione o tipo de unidade de medida principal que será exibido na tabela. Use o botão  associado para alternar a visibilidade das unidades de medida.

Quando a opção Document : <Units> estiver selecionada, as unidades principais especificadas para o documento serão aplicadas à tabela. As unidades principais do documento são selecionadas usando a lista suspensa Units na região Units da aba General do painel Properties quando nenhum objeto estiver selecionado na área de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Primary Precision

Selecione a precisão (até cinco casas decimais, com o último dígito arredondado) para os valores das unidades principais.

Quando a opção Document : <Precision> estiver selecionada, a precisão de valor/tolerância da unidade principal especificada para o documento será aplicada à tabela. A precisão do valor e da tolerância da unidade principal do documento é selecionada usando as opções Value Precision e Tolerance Precision para Primary Units na região Units da aba General do painel Properties quando nenhum objeto estiver selecionado na área de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Dual Units

Selecione o tipo de unidade de medida secundária (dupla) que será exibido na tabela. Use o botão  associado para alternar a visibilidade dos valores das unidades secundárias.

Quando a opção Document : <Units> estiver selecionada, as unidades duplas especificadas para o documento serão aplicadas à tabela. As unidades duplas do documento são selecionadas usando a lista suspensa Dual_Units na região Units da aba General do painel Properties quando nenhum objeto estiver selecionado na área de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Dual Precision

Selecione a precisão (até cinco casas decimais, com o último dígito arredondado) para os valores das unidades secundárias, se estiverem ativadas.

Quando a opção Document : <Precision> estiver selecionada, a precisão de valor/tolerância da unidade dupla especificada para o documento será aplicada à cota. A precisão do valor e da tolerância da unidade dupla do documento é selecionada usando as opções Value Precision e Tolerance Precision para Dual Units na região Units da aba General do painel Properties quando nenhum objeto estiver selecionado na área de projeto. Para obter mais informações, consulte a página Configuração de um documento Draftsman.

Use a aba Columns do painel Properties para gerenciar as colunas e linhas de dados da linha de transmissão ().

  • A região Columns fornece uma lista das colunas incluídas na tabela. Cada entrada de coluna pode ser editada alternando sua visibilidade, renomeando seu cabeçalho (Caption), percorrendo suas opções de alinhamento de texto (Align) ou definindo uma largura de coluna específica ou automática (Width). A ordem das entradas da lista e, portanto, a ordem das colunas na tabela posicionada podem ser editadas movendo a posição de uma entrada de coluna selecionada com os botões  e  associados.

  • A região Rows fornece uma lista dos dados das linhas da tabela, ordenada pela coluna Impedance Id, que corresponde às camadas nomeadas da placa no empilhamento de camadas de origem. Use o controle de visibilidade associado a cada entrada de linha para alternar sua visibilidade na tabela.

Tabela

Um documento Draftsman permite posicionar uma tabela genérica no desenho e, em seguida, configurá-la no painel Properties e nas próprias células da tabela. O layout e o conteúdo da tabela personalizada podem ser definidos livremente conforme sua finalidade e oferecem uma maneira flexível de incluir informações adicionais em qualquer documento Draftsman.

Uma tabela posicionada com diversas formatações de células
Uma tabela posicionada com diversas formatações de células

  • Usando tanto as opções disponíveis nas propriedades da tabela quanto os comandos da tabela, é possível criar uma tabela personalizada para atender a uma ampla variedade de necessidades de informação em um documento Draftsman. A tabela mostrada abaixo, por exemplo, foi criada para exibir informações extraídas de um relatório de empilhamento da placa.

    Uma tabela personalizada pode ser criada para conter uma ampla variedade de informações de montagem e fabricação de PCBs.
    Uma tabela personalizada pode ser criada para conter uma ampla variedade de informações de montagem e fabricação de PCBs.

  • As tabelas podem ser incluídas tanto em Modelos de folha quanto em Modelos de documento.

Ao iniciar o comando de posicionamento de tabela (Place » Table), será aberta a caixa de diálogo Insert table, na qual é possível especificar o número de linhas e colunas da nova tabela. Após clicar em OK na caixa de diálogo Insert table, a nova tabela ficará presa ao cursor e poderá ser posicionada no local desejado com mais um clique.

Especifique o número de células nas linhas e colunas da tabela — esses valores podem ser modificados posteriormente por meio dos comandos Table do menu de contexto de uma célula.
Especifique o número de células nas linhas e colunas da tabela — esses valores podem ser modificados posteriormente por meio dos comandos Table do menu de contexto de uma célula.

A posição de uma tabela já posicionada pode ser alterada graficamente selecionando o objeto de tabela na área de projeto e, em seguida, arrastando-o para um novo local usando sua alça de movimentação, ou seja, o ícone  no canto superior esquerdo.

Arraste o ícone de movimentação de uma tabela selecionada para reposicioná-la na área de projeto.
Arraste o ícone de movimentação de uma tabela selecionada para reposicioná-la na área de projeto.

Um objeto de tabela é selecionado ao clicar em uma célula ou em seu título. No entanto, o comando Delete será aplicado ao elemento específico em que se clicar. 

O conteúdo é adicionado a uma tabela digitando-o (ou colando-o) diretamente nas células. Use Ctrl+Enter para adicionar uma nova linha dentro de uma célula.

Os atributos gráficos e de texto da tabela são definidos no painel Properties quando a tabela está selecionada na área de projeto (). O objeto de tabela oferece uma ampla variedade de recursos de edição de texto e estrutura, que podem ser aplicados por linha ou coluna de células usando os comandos padrão Shift+Click ou Click, Hold&Drag técnica.

Título

Title

O texto do título que será exibido (se habilitado) com a tabela. Use o botão associado para alternar a visibilidade do título no desenho.

O campo pode incluir texto estático e quaisquer parâmetros desejados na forma de strings especiais. Use a sintaxe =<ParameterName> para incluir um parâmetro no título. Os valores dos parâmetros incluídos serão exibidos no título na folha de desenho. Para obter uma lista dos parâmetros de sistema e de PCB disponíveis, consulte a página Configurando um documento do Draftsman.

Location Abra a lista suspensa para escolher entre várias posições relativas para o título. A opção Manual é selecionada automaticamente se o título for movido manualmente (arrastado e solto em uma nova posição).
Font

Define a fonte usada para o título.

  • Quando a opção Use Document Font está habilitada, a fonte usada no título é aquela definida pelas opções do documento (a entrada Document Font na região General da aba General do painel Properties quando nenhum objeto está selecionado na área de projeto).

  • Quando a opção Use Document Font está desabilitada, use as opções disponíveis para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

Propriedades

Linha externa

Use as listas suspensas para selecionar a linha usada para representar a borda/o contorno da tabela. As opções disponíveis são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado na área de projeto. Para obter mais informações, consulte a página Configurando um documento do Draftsman. Use o botão de cor associado para especificar a cor da linha.

Inner Line Use as listas suspensas para selecionar a linha usada para representar as linhas internas da tabela que dividem as células. As opções disponíveis são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado na área de projeto. Para obter mais informações, consulte a página Configurando um documento do Draftsman. Use o botão de cor associado para especificar a cor da linha.
Column Width

Define a largura das células selecionadas e, portanto, a largura da coluna que as contém. Se a tabela inteira estiver selecionada (clicando em seu contorno ou título), a configuração de largura será aplicada a todas as células. Use o botão de cor associado para especificar a cor das células atualmente selecionadas.

Row Height Use este campo para ajustar a altura de uma linha selecionada na área de projeto. Insira a altura desejada, seguida da unidade imperial ou métrica.
Cell Padding Vertical Define o espaçamento abaixo e acima do texto nas células selecionadas.
Cell Padding Horizontal Define o espaçamento à esquerda e à direita do texto nas células selecionadas.
Font

Define a fonte usada para o texto nas células selecionadas.

  • Quando a opção Use Document Font está habilitada, a fonte usada é aquela definida pelas opções do documento (a entrada Document Font na região General da aba General do painel Properties quando nenhum objeto está selecionado na área de projeto).

  • Quando a opção Use Document Font está desabilitada, use as opções disponíveis para escolher o tipo, o tamanho, a cor e os atributos de texto da fonte desejada.

A tabela será redimensionada automaticamente para acomodar o tamanho de fonte selecionado.

Alignment Use os botões para definir o alinhamento e o posicionamento do texto Horizontal (à esquerda, centralizado ou à direita) e Vertical (superior, central ou inferior) nas células selecionadas.
Justification Selecione o ponto em relação ao qual a posição da tabela será alterada se seu tamanho for atualizado.

Strings especiais em células de tabela

Uma tabela permite a inclusão de parâmetros do documento do Draftsman como strings especiais. Os parâmetros de projeto (tanto locais quanto do Workspace), de sistema, de PCB e de usuário serão convertidos em seus valores quando inseridos como uma string especial nas células da tabela. Os parâmetros do documento do Draftsman podem ser acessados na aba Parameters do painel Properties quando nenhum objeto está selecionado na área de projeto. Consulte a página Configurando um documento do Draftsman para saber mais.

O tratamento de strings de parâmetros pela tabela também inclui a capacidade de transferir corretamente dados de strings especiais de e para uma planilha usando técnicas padrão de copiar/colar.

  • Ao colar strings especiais do Draftsman em uma planilha, as células de destino da planilha serão preenchidas com o valor interpretado da string.

  • Ao colar dados de strings especiais de uma planilha no Draftsman, o texto colado será interpretado como o valor de uma string especial, desde que a string especial corresponda a um parâmetro de sistema, de projeto ou de usuário disponível.

    Ao preparar entradas de strings especiais em uma planilha, será necessário inserir um apóstrofo (') antes de cada valor, para que o conteúdo da célula seja tratado como dados de texto. Por exemplo, a string especial para o parâmetro Units seria inserida como '=DocumentUnits. Como alternativa, todas as células da planilha podem ser definidas com o formato Texto.

Estrutura da tabela

Clique com o botão direito do mouse em uma célula e selecione o menu Table no menu de contexto para acessar os comandos de configuração de células. Eles fornecem um conjunto completo de funções de manipulação de tabelas para adicionar e remover colunas/linhas e mesclar células.

Os comandos Table do menu de contexto oferecem várias funções padrão de manipulação de tabelas.
Os comandos Table do menu de contexto oferecem várias funções padrão de manipulação de tabelas.

  • O comando Merge Cells só ficará disponível para uso se duas ou mais células consecutivas estiverem selecionadas na tabela.

    • Ao mesclar células que contenham texto, após a mesclagem, apenas o texto da célula mais à esquerda/mais acima (conforme aplicável) permanecerá na célula mesclada.

  • O comando Unmerge Cells só ficará disponível para uso se o cursor estiver dentro de uma célula mesclada na tabela ou se um intervalo de células selecionado incluir pelo menos uma célula mesclada.

    • Observe que, se a célula contiver texto, após desfazer a mesclagem, esse texto aparecerá na célula mais à esquerda/mais acima (conforme aplicável).

    • Ao desfazer a mesclagem de células e houver várias células mescladas em uma seleção de células, observe que esse comando desfará a mesclagem apenas da célula mesclada mais à esquerda/mais acima.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents