Suporte para panelização

Num relance

O editor CAMtastic do Altium Designer vai além da verificação dos arquivos de saída, oferecendo ferramentas para painelizar placas levando em conta os requisitos de fabricação e montagem. Este artigo explica como configurar as dimensões do painel, o espaçamento entre as placas e a quantidade de unidades, visualizar previamente a disposição e usar códigos de deslocamento para facilitar o gerenciamento dos dados de placas repetidas. Também aborda como adicionar, remover e modificar objetos em matrizes Step & Repeat. Continue lendo para ter mais controle sobre seu fluxo de trabalho de painelização.

- Saiba como o tamanho do painel, o espaçamento e a opção Calculate determinam quantas placas cabem em um painel.
- Entenda os métodos de espaçamento Offset e Gap e visualize previamente a disposição antes de aplicá-la.
- Descubra como o Step & Repeat reduz a duplicação de dados e como atualizar matrizes após a painelização.
Aprofunde-se com a IA:

Tradicionalmente, os engenheiros de projeto usam ferramentas CAM apenas para verificação, revisando visualmente suas saídas Gerber e de furação antes de encaminhar esses arquivos ao fabricante de placas. Projetistas experientes reconhecem a importância do trabalho pós-projeto necessário para receber placas funcionais de forma confiável. Esse trabalho exige uma comunicação precisa e aberta com os setores de fabricação e montagem.

O Editor CAM do Altium Designer oferece aos projetistas tudo o que precisam para promover essa comunicação, incluindo não apenas ferramentas de verificação confiáveis, mas também o conjunto completo de ferramentas CAM disponível para fabricantes de placas e empresas de montagem. Isso inclui ferramentas para painelizar a placa e definir os contornos de fresagem.

Muitos projetistas de placas se perguntarão por que essas ferramentas estão incluídas. Nossa resposta é que é difícil determinar exatamente onde termina o seu trabalho como projetista. Alguns ficarão satisfeitos em revisar seus projetos e deixar que o fabricante se preocupe em aproveitar ao máximo a área disponível nos painéis, desde que recebam o que encomendaram. Outros podem querer se envolver mais. Você pode, por exemplo, querer painéis que atendam melhor não apenas ao fabricante, mas também à empresa de montagem.

Painelização

A caixa de diálogo Panelization A caixa de diálogo Panelization

Um painel é criado por meio de um processo automatizado, no qual você determina o tamanho do painel e como as várias cópias dos dados da placa serão organizadas no espaço do painel. Você também pode indicar como os dados serão armazenados. Recomendamos fortemente que você use um dos códigos de deslocamento disponíveis, pois eles mantêm seus arquivos pequenos e fáceis de gerenciar. As informações de imagem e furação serão definidas apenas uma vez no painel, seguidas de um conjunto de instruções de repetição.

Ferramentas de posicionamento

A painelização segue o padrão geral de edição do Editor CAM. Para começar, você pode acionar o comando Tools » Panelize PCB, selecionar os objetos que deseja incluir no painel (ou usar os atalhos de teclado E, S, L para selecionar tudo) e executar o comando clicando com o botão direito do mouse ou usando o atalho de teclado Shift+9. Essa sequência abrirá a caixa de diálogo Panelization.

A caixa de diálogo Panelization A caixa de diálogo Panelization

A caixa de diálogo Panelization exibida inicialmente contém informações calculadas com base nos limites da placa que você está painelizando (definidos pelos objetos selecionados). Na parte superior da caixa de diálogo, as dimensões horizontal e vertical dos objetos selecionados são informadas nos campos Image Size . Em seguida, são exibidos os valores de Panel Size, Spacing e Parts Count.

Todos esses campos funcionam dinamicamente. Se a opção Calculate estiver habilitada, será exibido o número máximo de colunas e linhas que cabem no tamanho de painel e nos valores de espaçamento inseridos. Você pode aumentar o número de colunas e/ou linhas no painel aproximando as placas ou reduzindo a margem ao redor das bordas do painel. Também é possível acomodar mais placas aumentando o tamanho do painel.

Desativar a opção Calculate permite trabalhar de forma inversa: você pode inserir o número de colunas e linhas que deseja acomodar no painel, e o tamanho resultante do painel será exibido de acordo com os valores inseridos nos campos Parts Count e Spacing . Como o tamanho resultante do painel terá valores irregulares, esse método provavelmente será usado apenas para determinar os requisitos mínimos do painel. Depois disso, convém reativar a opção Calculate e inserir um tamanho de painel compatível com seu fabricante e sua empresa de montagem.

A matriz de placas pode ser centralizada no painel ou posicionada no canto inferior esquerdo.

Clicar no botão Show Preview abrirá uma janela de pré-visualização na caixa de diálogo, na qual você poderá ver como os painéis aparecerão na folha. As alterações no espaçamento dos painéis serão atualizadas na janela de pré-visualização, permitindo obter o espaçamento necessário antes de prosseguir.

Depois que todas as opções forem definidas conforme necessário, clicar em OK executará a painelização, e a matriz de painéis aparecerá na área de trabalho principal do projeto. A matriz começa com os objetos selecionados originalmente e se estende para cima e para a esquerda.

  • Você pode definir com precisão o espaçamento da matriz de painéis usando um dos dois métodos:
    • Offset - este método permite especificar o espaçamento entre linhas e colunas em relação ao tamanho da imagem (ou seja, à seleção de objetos). Ao especificar um valor em um campo Offset , você precisa adicionar o espaçamento necessário ao valor do campo Image Size e inserir esse valor combinado como deslocamento. Por exemplo, se o tamanho da imagem for 0,5 pol. e você precisar de um espaçamento de 200 mils, será necessário inserir 0,7 no campo Offset correspondente.
    • Gap - este método permite especificar diretamente o espaçamento entre linhas e colunas e, portanto, não depende do tamanho da imagem. Por exemplo, se você precisar de um espaçamento de 200 mils, será necessário inserir 0,2 no campo Gap correspondente.
  • Use a opção Calculate para determinar a quantidade ideal de peças com base nos valores especificados de Panel Size e Spacing.
  • Habilitar a opção Use Step & Repeat permitirá o uso de códigos incorporados de passo e repetição para reduzir o tamanho de arquivos que contêm as mesmas informações várias vezes. Quando essa opção é usada, apenas o painel original é exibido por completo na área de trabalho do projeto; todas as outras cópias projetadas aparecem como quadros vazios.
  • Sempre que você usar o comando de painelização, uma nova camada será adicionada à lista de camadas no painel CAMtastic . Essa é a camada vent_border, à qual é atribuído o tipo Temporary na caixa de diálogo Layers Table (Tables » Layers). Esse contorno deve ser mantido se você quiser adicionar rapidamente um padrão de ventilação ao painel em uma etapa posterior.

Passos na direção certa

É natural que, ao colocar oito cópias completas da sua placa em um painel, o arquivo resultante seja pelo menos oito vezes maior. Isso se aplica sempre que os dados são exploded, ou seja, totalmente reescritos no arquivo de descrição para cada nova posição. Normalmente, o maior impacto de um arquivo assim não vem de seu tamanho, mas do fato de que cada redesenho da tela leva oito vezes mais tempo.

O CAM Editor oferece dois tipos de códigos de deslocamento para ajudar a evitar que seus arquivos cresçam a proporções difíceis de gerenciar durante a painelização: os comandos tradicionais Step & Repeat e ODB++ Steps.

Passo e repetição

Quando a opção Use Step & Repeat está habilitada na caixa de diálogo Panelization, os dados selecionados anteriormente são movidos para o canto inferior esquerdo do painel. Todas as outras seções do painel aparecem de forma muito semelhante à pré-visualização do painel: como caixas vazias que mostram os limites verticais e horizontais dos dados copiados. Essas caixas aparecem em todas as camadas que contêm informações de Step & Repeat.

Como os dados armazenados em cada passo são fixados no momento da painelização, é melhor adiar o uso de códigos Step & Repeat até ter certeza absoluta de que os dados originais não serão alterados. Esse é, naturalmente, o cenário ideal, já que a painelização costuma ser feita após a conclusão da verificação. Mas e se você descobrir pequenas alterações que precisam ser feitas depois de painelizar a placa?

É possível editar dados Step & Repeat , embora não seja fácil. Novos flashes, traços ou textos podem ser adicionados aos dados visíveis na seção inferior esquerda do painel. Esses objetos adicionais podem então ser adicionados às demais seções (repetidas) do painel usando o comando Edit » Step/Repeat » Add Objects. Após iniciar o comando, o cursor mudará para um quadrado e você entrará no modo de adição de objetos. O procedimento envolve a seguinte sequência de ações:

  1. Clique nos objetos a serem adicionados para selecioná-los. Clicar fora de um objeto permite arrastar uma área de seleção para incluir vários objetos. A seleção é cumulativa.
  2. Depois de selecionar todos os objetos necessários, clique com o botão direito do mouse.
  3. Agora selecione a matriz Step & Repeat específica à qual deseja adicionar os objetos selecionados. Basta posicionar o cursor sobre qualquer objeto incluído na seleção da matriz, no quadro original da matriz (inferior esquerdo), e clicar. Os quadros da matriz serão redimensionados para acomodar os objetos adicionados, bem como os objetos originais. Somente o quadro original (inferior esquerdo) da matriz conterá os objetos visíveis — todos os outros quadros permanecerão vazios.
  4. Continue selecionando objetos para adicionar a outras matrizes Step & Repeat ou clique com o botão direito do mouse ou pressione Esc para sair.

A adição de objetos pode fazer com que os quadros da matriz se sobreponham. Você pode modificar a distância (ou o intervalo) entre os quadros usando a caixa de diálogo Modify Step_Repeat. Para isso, escolha o comando Edit » Step/Repeat » Modify nos menus principais. Após iniciar o comando, o cursor mudará para um quadrado e você entrará no modo de modificação de matriz. Para modificar uma matriz, execute a seguinte sequência de ações:

  1. Selecione a matriz Step & Repeat específica que deseja modificar. Basta posicionar o cursor sobre qualquer objeto incluído na seleção da matriz, no quadro original da matriz (inferior esquerdo), e clicar — a caixa de diálogo Modify Step_Repeat será exibida. Use essa caixa de diálogo para modificar o número de linhas e colunas da matriz e também seu espaçamento, usando um dos dois métodos:

    • Distance - este método permite especificar o espaçamento entre linhas e colunas em relação ao tamanho da imagem (ou seja, à seleção de objetos). Ao especificar um valor em um campo Distance , é necessário somar o espaçamento desejado ao valor do campo Image Size e inserir esse valor combinado como a distância. Por exemplo, se o tamanho da imagem for de 0,5 polegada e você precisar de um espaçamento de 200 mils, deverá inserir 0.7 no campo Distance correspondente.
    • Gap - este método permite especificar diretamente o espaçamento entre linhas e colunas, sem depender do tamanho da imagem. Por exemplo, se você precisar de um espaçamento de 200 mils, deverá inserir 0.2 no campo Gap correspondente.
    Clique no botão Show Preview para expandir a caixa de diálogo e exibir a janela de pré-visualização da matriz, onde você pode ver como ela ficará após a modificação. A pré-visualização será atualizada à medida que você alterar as configurações da matriz.
  2. Após fazer as modificações necessárias na matriz, clique em OK — a matriz Step & Repeat será alterada de acordo com as modificações especificadas.
  3. Continue selecionando e modificando outras matrizes Step & Repeat ou clique com o botão direito do mouse ou pressione Esc para sair.

Fazer exclusões é um pouco mais complexo e envolve remover objetos das seções repetidas (não visíveis) do painel usando o comando Edit » Step/Repeat » Remove Objects antes de excluir esses mesmos objetos da seção visível do painel com o comando Edit » Clear. Após iniciar o comando Edit » Step/Repeat » Remove Objects, o cursor mudará para um quadrado e você entrará no modo de remoção de objetos. Para remover objetos, execute a seguinte sequência de ações:

  1. Selecione os objetos a serem removidos no quadro original (inferior esquerdo) da matriz Step & Repeat desejada. Isso pode ser feito simplesmente posicionando o cursor sobre um objeto existente que você deseja incluir na seleção e clicando. Como alternativa, clicar fora de um objeto permite arrastar uma área de seleção para incluir vários objetos. A seleção é cumulativa.
  2. Depois de selecionar todos os objetos necessários, clique com o botão direito do mouse. Os objetos serão removidos da matriz e os quadros da matriz serão redimensionados de acordo com os objetos restantes.
  3. Continue selecionando objetos para remover de outras matrizes Step & Repeat ou clique com o botão direito do mouse ou pressione Esc para sair.
Se você remover todos os objetos do quadro original da matriz, a matriz será efetivamente excluída.

Como o mesmo grupo de objetos precisa ser selecionado duas vezes, para dois comandos diferentes, a possibilidade de erro é alta, mas o Editor CAM permite selecionar novamente uma seleção anterior. Essa dificuldade é agravada pelo fato de que as caixas Step & Repeat dispostas em matriz permanecem vazias, sem fornecer nenhuma indicação de seu conteúdo até que os dados sejam decompostos em primitivas usando o comando Edit » Step/Repeat » Explode. Após iniciar o comando, o cursor mudará para um quadrado e será solicitado que você selecione a matriz Step & Repeat específica a ser decomposta. Basta posicionar o cursor sobre qualquer objeto incluído na seleção da matriz, no quadro original da matriz (inferior esquerdo), e clicar. Todos os quadros da matriz serão preenchidos com informações copiadas do original, e as bordas dos quadros serão removidas. Continue decompondo outras matrizes Step & Repeat ou clique com o botão direito do mouse ou pressione Esc para sair.

O tamanho do arquivo pode aumentar consideravelmente ao decompor os dados, dependendo da quantidade de informações que estão sendo repetidas.

Etapas ODB++

ODB++ resolvem os problemas encontrados nos códigos Step & Repeat. Cada etapa criada se torna uma nova coluna correspondente às linhas das camadas atuais. Quanto mais etapas você adicionar, maior será a matriz na qual os dados podem ser armazenados. Uma etapa pode ser inserida uma ou várias vezes em outra etapa, que é exatamente o que acontece quando você cria um painel com a opção Create ODB++ Step habilitada. Ao usar a opção Create ODB++ Step, duas novas etapas são criadas além da etapa padrão do espaço de projeto (cam_work):

  • uma para os dados que você selecionou para a criação do painel (campcb)
  • uma para o próprio painel (campanel).
    Você pode ver o conteúdo de cada etapa clicando duas vezes em seu nome na aba Steps do painel CAM.
    A etapa que contém os dados selecionados é inserida automaticamente como uma subetapa da etapa do painel, aparecendo no formato:
    [n]: NomeDaEtapa (Linhas, Colunas),
    em que [n] é o próximo número disponível atribuído à etapa inserida, começando em 1, e Rows e Columns são obtidos da região Parts Count da caixa de diálogo Panelization.

Ao visualizar o conteúdo da etapa do painel na área de projeto, a etapa (de dados) inserida aparecerá como LinhasxColunas retângulos brancos vazios. Ao contrário de uma matriz Step & Repeat , os dados dos objetos não ficam visíveis em nenhuma das seções da matriz. Uma cruz branca é exibida para cada instância da etapa inserida, definindo onde o conteúdo dos dados será inserido, caso você opte por explorar a matriz de etapas.

Antes de concluir seu trabalho, clique com o botão direito do mouse na etapa do painel e escolha Refresh Inserts. Isso garante que as etapas inseridas no painel reflitam o estado atual dos dados de origem, assegurando que todas as alterações feitas após a painelização sejam refletidas no painel final.

Para acessar a caixa de diálogo Steps Table, na qual você pode visualizar as informações das etapas ODB++ do documento atual, escolha o comando Tables » Steps nos menus principais. Ao clicar em OK na caixa de diálogo Steps Table, a guia Steps do painel CAMtastic será atualizada. Nessa guia, você pode adicionar/modificar etapas clicando com o botão direito do mouse e escolhendo o comando apropriado no menu de contexto. A caixa de diálogo Steps Table será exibida automaticamente ao importar arquivos ODB++ para o Editor CAMtastic.

Estratégias adicionais de painelização

As ferramentas automáticas podem ajudar a maximizar o número de placas idênticas no painel, mas e se os requisitos do painel forem mais complexos? Como adicionar cupons de furação ou furos de posicionamento ao painel? E se você quiser aplicar a técnica step-and-turn aos seus dados, criando um painel que seja igual independentemente de como for virado, permitindo montar componentes em ambos os lados ao passar o painel duas vezes pela mesma máquina pick-and-place? Ou se quiser otimizar o espaço do painel organizando placas diferentes no mesmo painel?

Todos esses requisitos podem ser atendidos usando etapas ODB++ no CAM Editor. O ponto de partida é a rotina de painelização automática, pois ela é a única maneira de criar um contorno de painel usando a opção Create ODB++ Step em vez da opção Use Step & Repeat.

Inserção de etapas

As caixas de diálogo Enter Value e Add Insert to ODB StepAs caixas de diálogo Enter Value e Add Insert to ODB Step

Você pode inserir etapas adicionais ao lado da matriz de placas no painel. Um fabricante de placas, por exemplo, pode colocar um cupom de furação em uma das bordas destacáveis para comparar visualmente os tamanhos de furo previstos com os das placas fabricadas. Os furos de posicionamento, usados para fixar o painel enquanto suas camadas são furadas e fresadas, podem ser necessários em outros locais do painel, e não dentro das instâncias das placas.

Primeiro, é necessário criar uma nova etapa. Isso é feito usando o comando Add Step, acessado pelo menu do botão direito do mouse na guia Steps do painel CAM. A nova etapa tem as mesmas camadas, mas todas estarão vazias nessa nova etapa. Você pode copiar ou mover dados entre etapas por meio desse mesmo menu. Como alternativa, você pode inserir novos objetos nas camadas existentes quando a nova etapa estiver ativa, e esses objetos existirão apenas nessa etapa.

Por exemplo, para criar um cupom de furação, você pode criar uma nova etapa e, em seguida, aplicar uma ocorrência de cada ferramenta usada no projeto na camada de furação, organizando-as em uma linha. Na camada de serigrafia superior, você pode inserir textos ou outros marcadores de identificação para cada diâmetro de furação.

Você também deve desenhar uma polilinha fechada ao redor dos seus dados na camada designada como tipo Border na tabela Layers, selecionando Tables » Layers no menu principal. Ela será usada para gerar um profile para ODB++, que é um arquivo que permite inserir etapas umas dentro das outras sem que seus limites sejam invadidos por padrões de ventilação.

Você pode criar outra etapa para cada cupom ou objeto que precisar adicionar ao painel. Com a etapa do painel ativa, você pode inserir cada um deles em uma posição definida na etapa principal do painel, como campanel. Para isso, use o comando Add Insert do menu do botão direito do mouse. Se você aplicou um padrão de ventilação ao criar esse painel originalmente, remova-o e aplique-o novamente. Ao fazer isso, o padrão de ventilação respeitará o contorno do perfil de cada etapa.

Step-and-turn


A painelização step-and-turn é uma técnica que agiliza as rotinas das empresas de montagem. Normalmente, placas com componentes nas faces superior e inferior exigem duas máquinas pick-and-place: uma para os componentes da face superior do painel e outra para os da face inferior. No entanto, suponha que as faces superior e inferior do painel sejam idênticas quando ele for virado; nesse caso, o painel poderia passar duas vezes pela mesma máquina de montagem.

É importante distinguir a face superior da placa da face superior do painel, pois essa técnica exige que as placas do lado direito do painel sejam iguais às do lado esquerdo, porém viradas para baixo. Ela também exige que o empilhamento dos tipos de camada seja simétrico. Metade da face superior do painel incluirá as imagens da face superior da placa, e a outra metade incluirá as imagens da face inferior da placa em formato espelhado.

Para conseguir isso no CAM Editor, primeiro você deve copiar todos os dados da placa para uma nova etapa. Você pode usar o recurso Swap Layers Data, selecionando Edit » Layers » Swap Layers Data no menu principal, para determinar onde os dados das camadas invertidas serão posicionados. Como resultado, a camada superior conterá imagens das camadas superior e inferior, mas essas imagens permanecerão em etapas separadas.

Se você ainda não criou um painel a partir do projeto original, pode fazê-lo agora, garantindo um número par de colunas ou linhas centralizadas no painel. Clique no sinal de mais ao lado da etapa campanel gerada e, em seguida, clique com o botão direito do mouse na etapa inserida para modificá-la. Altere o valor de linhas ou colunas para que metade das placas desapareça. Agora, insira a nova etapa criada, painelizando-a de forma idêntica, mas usando um ponto de referência calculado que posicione a nova matriz no mesmo local das etapas eliminadas anteriormente. Certifique-se de que a opção Mirror esteja habilitada para essa etapa.

A caixa de diálogo Modify Insert in ODB StepA caixa de diálogo Modify Insert in ODB Step

Placas diferentes no mesmo painel

A inversão de placas em um painel é, na verdade, uma aplicação bastante restrita dos recursos das etapas ODB. As placas podem ser invertidas porque a mesma camada pode conter dados diferentes em cada uma de suas etapas, que podem então ser posicionadas lado a lado na mesma área de projeto. Essa liberdade fundamental levanta a questão: por que um painel deve conter uma matriz da mesma placa? A resposta é que essa restrição não existe no CAM Editor.

Há diversos motivos para querer placas diferentes no mesmo painel. Um fabricante terá interesse em maximizar a área utilizada do painel, mas, quanto maior a placa, mais difícil isso se torna. Placas pequenas, mesmo que venham de outra origem, podem preencher o espaço disponível e reduzir os custos de fabricação. Por outro lado, um único produto pode ser composto por várias placas, que o projetista pode preferir fabricar juntas em um único painel.

Naturalmente, existem algumas restrições. Só é possível panelizar placas que compartilhem o mesmo empilhamento de camadas de sinal e planos internos. Elas também precisam ter conjuntos compatíveis de camadas de furação.

O comportamento padrão do CAM Editor é criar novas camadas quando novas imagens ou arquivos de furação são carregados. Esse método não é suficiente para panelizar placas diferentes em conjunto, pois os dados das diferentes placas precisam estar na mesma camada, mas em etapas distintas. Para facilitar esse processo, há uma opção na página Editor CAM - Importação/Exportação da caixa de diálogo Preferences, que permite importar arquivos Gerber/de furação adicionais para camadas existentes.

Com essa opção ativada, uma caixa de diálogo de mapeamento será exibida sempre que você importar arquivos adicionais de dados Gerber, de furação ou IPC após essas camadas já terem sido importadas.

A caixa de diálogo Map Layers to Import to Existing LayersA caixa de diálogo Map Layers to Import to Existing Layers

A caixa de diálogo Maps Layers to Import to Existing Layers contém os novos arquivos à esquerda e as camadas existentes à direita. Com base nas extensões e no Layer Types Detection Template, acessado selecionando Tables » Layer Type Detection no menu principal, o Editor CAM proporá correspondências, mas você poderá ajustá-las conforme necessário. Os arquivos que você não quiser mapear para camadas existentes podem ser configurados para criar uma nova camada ou ser totalmente excluídos do processo de importação.

É necessário criar uma nova etapa ODB e torná-la atual antes de prosseguir com esse processo de mapeamento. Caso contrário, todos os dados das camadas ficariam sobrepostos, sem nenhuma forma de separar os dados de uma placa dos das demais.

Padrão de compensação de cobre

A caixa de diálogo Venting e Edit Pattern - Venting A caixa de diálogo Venting e Edit Pattern - Venting

Você pode adicionar um padrão de compensação de cobre às partes não utilizadas do painel, o que pode ajudar a distribuir uniformemente o agente químico de corrosão por todo o painel. A panelização automática do Editor CAM preencherá todo o espaço entre a borda do painel e as instâncias das placas com um padrão de compensação de cobre de sua escolha.

Esse padrão pode ser raster, vetorial, sólido ou baseado em formas. Você pode escolher entre opções de formas genéricas com tamanhos definidos pelo usuário ou selecionar um DCode existente como base para o padrão de compensação de cobre. Esse padrão será aplicado apenas às camadas de sinal e de plano (definidas na coluna Layers Table in the Types ).

Se você criou um padrão de compensação de cobre ao panelizar os dados originalmente e depois adicionou etapas ODB++, como cupons, furos de fixação ou até mesmo placas invertidas ou alternativas, é recomendável atualizar o padrão de compensação de cobre. Para isso, remova o padrão e adicione-o novamente. Os comandos para essas ações serão exibidos ao clicar com o botão direito do mouse na entrada da etapa do painel (campanel), localizada na guia Steps do painel CAM. Lembre-se de tornar a etapa do painel a etapa atual para que esses comandos sejam ativados.

Para adicionar um padrão de compensação de cobre à PCB panelizada atual, selecione o comando Tools » Venting nos menus principais. O uso desse comando dependerá de você ter mantido ou não a camada vent_border ao panelizar a PCB.

  • With a vent_border layer present – após executar o comando, a caixa de diálogo Venting será exibida. Por padrão, todas as camadas de sinal e de plano estarão selecionadas para receber o padrão de compensação de cobre. Para desmarcar uma camada, basta clicar em sua entrada.

    O lado esquerdo da caixa de diálogo mostra o padrão de compensação de cobre atualmente definido que será aplicado. Clique no botão Edit Pattern para abrir a caixa de diálogo Edit Pattern - Venting, na qual você poderá definir o padrão de compensação de cobre específico que deseja usar.

    Após definir o padrão de compensação de cobre e as camadas que o receberão conforme necessário, clique em OK para aplicar o padrão ao painel, em todas as áreas externas ao vent_border.

  • With no vent_border layer present – sem uma camada vent_border, a borda do painel continuará existindo, mas as PCBs individuais do painel não terão um contorno que permita calcular a área para o padrão de compensação de cobre. Portanto, será necessário adicionar contornos a cada uma das PCBs do painel, essencialmente criando sua própria camada vent_border. Adicionar uma nova camada e usar o comando de polilinha para desenhar contornos ao redor de cada PCB do painel é uma das maneiras mais rápidas de fazer isso.

    Após executar o comando, o cursor mudará para um pequeno quadrado, e você receberá uma solicitação para selecionar os contornos do painel e das PCBs. Basta arrastar uma caixa de seleção ao redor de todo o painel. Todos os contornos das PCBs e o contorno do painel serão selecionados. Clique com o botão direito do mouse — a caixa de diálogo Venting será exibida. Defina o padrão de compensação de cobre e as camadas que o receberão conforme necessário e clique em OK. O padrão será aplicado ao painel, na área definida entre os contornos do painel e das PCBs.

  • Use a caixa de diálogo Edit Pattern - Venting para definir o padrão de compensação de cobre conforme necessário. Se Fill Type estiver definido como Polygon (Raster), todas as outras configurações dessa caixa de diálogo serão desativadas. O contorno do painel será preenchido com um padrão de polígono sólido.
  • Se Fill Type estiver definido como Vector, você poderá escolher entre usar uma imagem sólida ou uma forma/Dcode. Você pode escolher uma forma e inserir um tamanho para o preenchimento ou especificar o uso de uma abertura existente. Se tiver escolhido usar Shape/Dcode, poderá especificar o espaçamento XY da forma utilizada.
  • O uso de um padrão de polígono fará com que dois novos Dcodes sejam adicionados à sua lista de aberturas. Eles aparecerão como as entradas Poex e Poin.
  • Se você usar formas e tamanhos para padrões vetoriais que não sejam aberturas existentes, eles serão adicionados à lista de aberturas com o próximo Dcode disponível.

Assistente de fotolito

Para panelizar camadas Gerber selecionadas em uma única área de fotolito, permitindo gerar essas camadas em fotolito para o documento atual, use o comando Tools » Film Wizard nos menus principais.

Primeiro, certifique-se de que apenas as camadas Gerber que você deseja incluir no painel estejam ATIVADAS.

Após executar o comando, a caixa de diálogo Film Wizard será exibida. Use essa caixa de diálogo para definir o tamanho do fotolito e a disposição das camadas nele. Você pode selecionar uma das definições predefinidas de tamanho/disposição no campo suspenso Film Description ou inserir sua própria definição.

A região Individual Film Size da caixa de diálogo mostra a área de fotolito disponível para cada imagem na disposição, com base nas configurações de tamanho/disposição especificadas.

Clicar no botão Neg/Mirror abrirá a caixa de diálogo Film Wizard - Select Layers . Use essa caixa de diálogo para escolher quais camadas deseja espelhar ou tornar negativas no fotolito.

Após definir as opções do fotolito, clique em OK na caixa de diálogo Film Wizard para criar as camadas de fotolito. Uma caixa de diálogo será exibida solicitando que você escolha se deseja excluir os objetos antigos. Se você escolher Yes, o painel do fotolito será criado e as camadas originais serão excluídas. Se você escolher No, o painel do fotolito será criado e todas as camadas originais serão mantidas, mas ficarão DESATIVADAS.

  • Normalmente, apenas as camadas de sinal e de plano são colocadas no fotolito. Na maioria dos casos, as camadas de plano seriam negativas.
  • Se você tiver especificado suas próprias configurações de tamanho do filme/número de elementos da matriz, o botão Add Description ficará disponível. Clicar nesse botão adicionará a definição ao assistente, e ela estará disponível no campo de lista suspensa Film Description na próxima vez que você usar o comando.
  • Certifique-se de que o tamanho individual do filme seja pelo menos igual às dimensões reais da imagem. Caso contrário, você poderá prosseguir, mas uma caixa de diálogo de aviso será exibida para alertar sobre isso. Os resultados da panelização poderão não ser satisfatórios.
  • A exclusão das camadas originais é uma operação que não pode ser desfeita.
  • As camadas de filme criadas são adicionadas à lista de camadas no painel CAMtastic  e recebem os nomes film1, film2, film3, etc.
  • O número de camadas de filme é calculado dividindo-se o número de camadas habilitadas (que você deseja colocar no filme) pelo número de elementos da matriz XY em um único filme. Assim, por exemplo, se você tiver 10 camadas habilitadas e uma matriz 1x2, serão criadas 5 camadas de filme.
  • As camadas habilitadas são posicionadas nas camadas de filme de acordo com a ordem da lista de camadas. Portanto, considerando 10 camadas e uma matriz 1x2, as duas primeiras camadas seriam colocadas na camada film1, as duas seguintes na camada film2 e assim por diante. Para matrizes maiores, as camadas são posicionadas no sentido anti-horário, começando pelo canto superior esquerdo.

Bordas das placas

A forma como as placas serão separadas do painel deve ser considerada tanto pelos fabricantes quanto pelas empresas de montagem. Por exemplo, uma empresa de montagem pode preferir manter os painéis intactos até que os componentes sejam montados nas placas, o que pressupõe que os painéis sejam resistentes o suficiente para permanecerem unidos durante a montagem, mas perfurados o suficiente para permitir que as placas sejam destacadas do painel posteriormente, sem dificuldade.

Sulcamento em V

O sulcamento em V é uma solução viável, que consiste em fazer uma ranhura em formato de V entre as seções de placa, tanto na face superior quanto na inferior do painel, deixando uma fina espessura de material para mantê-las unidas. Todos os detalhes desse processo, como o ângulo da lâmina e a espessura do material remanescente, além da aplicação ou não de sulcamento interrompido (áreas em que a ranhura é interrompida, tornando o painel mais resistente), devem ser informados ao operador da máquina de sulcamento.

Atualmente, as máquinas de sulcamento exigem programação. Em geral, essa programação é feita com base em formulários não CAD que você preenche indicando os pontos de dados e as linhas na configuração do painel. Algumas empresas de sulcamento, no entanto, conseguem extrair informações de furos e linhas de arquivos Gerber; nesse caso, você pode desenhar as linhas de sulcamento no CAM Editor exatamente como desejar. De qualquer forma, colocar as linhas de sulcamento na camada de serigrafia superior fornecerá referências visuais para o operador da máquina, que serão usadas em conjunto com as informações extraídas e as fornecidas explicitamente por você.

Fresagem NC

O método tradicional para dar acabamento às bordas das placas, no entanto, utiliza fresas. É possível criar bordas lisas inserindo uma fresa na placa em locais específicos, deslocando-a ao longo de um percurso predeterminado e, em seguida, retraindo-a.


Vários aspectos são importantes ao preparar as informações de fresagem. Entre eles estão o tamanho e o formato da ferramenta de furação e o percurso de fresagem, juntamente com seus pontos de entrada e retração.

Para gerar e revisar essas instruções, o CAM Editor deve ser configurado no modo de fresagem NC, que pode ser acessado pelo menu View ou pelo painel CAM. Nesse modo, você pode criar novas ferramentas de furação para sua tabela de ferramentas selecionando Tables » NC Tools no menu principal, com base nos flashes selecionados no projeto. Após executar o comando, a caixa de diálogo Tool Table será exibida. Por padrão, a tabela conterá uma lista de ferramentas baseada em qualquer arquivo NC Drill importado; caso contrário, ela aparecerá vazia. Use a tabela para adicionar/editar definições de ferramentas. É possível definir até 99 ferramentas, cada uma com um Dcode exclusivo, começando em D9500. Use os botões Save  e Open  para salvar a definição atual da tabela de ferramentas ou carregar uma definição salva anteriormente, respectivamente. Os dados das ferramentas são armazenados em um arquivo de configurações da tabela de fresagem (Mill/Rout Table Settings) (*.mts). Ao passar o cursor sobre as diversas colunas da grade da tabela, será exibida uma dica com mais informações sobre a entrada correspondente.

Em seguida, você pode usar os comandos disponíveis no menu Rout para definir percursos de fresagem com essas ou outras fresas existentes.

Use os seguintes comandos do menu View » Display Symbols para alternar a exibição dos elementos relacionados aos percursos de fresagem:

  • Drill – alterna a exibição dos símbolos de furação no documento atual. Os símbolos de furação são usados como auxílio visual para localizar facilmente os pontos de furação. Um símbolo de furação aparece como uma cruz branca, marcando o centro do ponto de furação.
  • Direction Arrows – alterna a exibição das setas de direção dos percursos de fresagem.
  • Centerline Path – alterna a exibição da linha central original do percurso de fresagem — o percurso sem deslocamento de compensação da fresa aplicado. O efeito desse comando só é perceptível quando o modo Fill  está DESATIVADO.
  • Plunge – alterna a exibição dos símbolos dos pontos de entrada dos percursos de fresagem no documento atual. Um ponto de entrada é o ponto inicial de inserção da ferramenta de fresagem ao fresar um percurso no projeto.
  • Retract – alterna a exibição dos símbolos dos pontos de retração dos percursos de fresagem no documento atual. Um ponto de retração é o ponto de saída da ferramenta de fresagem após fresar um percurso no projeto.

Para redesenhar um percurso de fresagem selecionado, permitindo visualizar exatamente como a ferramenta de fresagem se deslocará quando a placa for fabricada, escolha o comando View » Redraw a Rout Path nos menus principais. Após executar o comando, o cursor mudará para um pequeno quadrado e será solicitado que você selecione um objeto fresado. Basta posicionar o cursor em qualquer lugar sobre o objeto que foi fresado e clicar. A seção de entrada do percurso de fresagem será redesenhada primeiro. Continue clicando para redesenhar o percurso de fresagem, um segmento por vez, até chegar ao ponto de retração. Esse é o percurso exato que a ferramenta de fresagem usará quando a placa for fabricada. Observe que pode ser mais fácil habilitar apenas a camada de fresagem, com todas as outras camadas DESATIVADAS.

Criar percurso(s) de fresagem

Para criar percursos de fresagem a partir de trilhas selecionadas no documento atual, escolha o comando Rout » Create Rout Path(s) nos menus principais. 

Primeiro, certifique-se de que as ferramentas de furação tenham sido definidas. Se você tiver carregado anteriormente um arquivo NC Drill, as ferramentas do projeto terão sido carregadas automaticamente e aparecerão na caixa de diálogo Tool Table (Tables » NC Tools). Se nenhuma ferramenta estiver definida, uma caixa de diálogo será exibida para alertar sobre isso quando você tentar executar o comando, e será necessário definir as ferramentas importando um arquivo de furação ou inserindo-as manualmente.

Depois que as ferramentas forem definidas conforme necessário, a execução do comando abrirá a Select Mill/Drill Tool caixa de diálogo. A caixa de diálogo fornece uma lista suspensa de todas as ferramentas de furação definidas atualmente para o projeto. Selecione a ferramenta que deseja usar para a fresagem e clique em OK. O cursor mudará para um pequeno quadrado e será solicitado que você selecione os objetos que deseja fresar. Basta posicionar o cursor sobre os objetos individuais e clicar para adicioná-los à seleção, ou usar uma das várias ferramentas de seleção disponíveis. Quando todos os objetos desejados estiverem selecionados, clique com o botão direito.

Os objetos selecionados serão fresados, e uma camada de fresagem será criada e adicionada à lista de camadas no painel CAMtastic . A caixa de diálogo Create Rout Path(s) será exibida, permitindo alterar a ferramenta usada para a fresagem e sua compensação. Você também pode inverter o sentido dos percursos de fresagem — os pontos de mergulho se tornarão pontos de retração e vice-versa. Essas alterações são virtuais e só serão aplicadas permanentemente quando o botão OK for clicado.

  • A fresagem normalmente está associada a trilhas. Muitas vezes, pads são incluídos na seleção e encontrados ao longo dos percursos de fresagem. Use as opções da caixa de diálogo Rout Pads Options (Rout » Rout Pads Options) para determinar como esses pads devem ser tratados. Por padrão, pads redondos serão convertidos em pontos de furação.
  • Segmentos de linha conectados individualmente terão seus próprios pontos de mergulho e retração. Para ter um único ponto de mergulho e um único ponto de retração, primeiro é necessário unir os segmentos individuais. Por outro lado, pontos de mergulho e retração podem ser adicionados a um percurso de fresagem dividindo-o em segmentos.
  • A camada de fresagem conterá todos os percursos de fresagem e, se habilitada, exibirá vários símbolos relacionados à fresagem. Esses símbolos representam os pontos de mergulho e retração, além do sentido de cada percurso.
  • As seguintes aberturas não podem ser usadas em um percurso de fresagem: Custom, Diamond, Donut, Target e Thermal.
  • Tenha cuidado para não fresar trilhas e pads em camadas de sinal/plano.
  • Os pontos de mergulho e retração serão inseridos em posições padrão quando um percurso de fresagem for criado. Esses pontos, assim como a ferramenta, a compensação e o sentido da fresagem, podem ser modificados a qualquer momento usando o comando Modify Rout Path(s) correspondente.

Modificar percursos de fresagem

Para modificar os percursos de fresagem selecionados no documento atual, escolha o comando Rout » Modify Rout Path(s) nos menus principais.

Primeiro, certifique-se de que a camada de fresagem seja a única camada ativada e esteja visível na área de projeto.

Após iniciar o comando, o cursor mudará para um pequeno quadrado e será solicitado que você selecione os percursos de fresagem que deseja modificar. Basta posicionar o cursor sobre os objetos individuais e clicar para adicioná-los à seleção, ou usar uma das várias ferramentas de seleção disponíveis. Quando todos os objetos desejados estiverem selecionados, clique com o botão direito.

A caixa de diálogo Modify Rout Path(s) será exibida, permitindo alterar a ferramenta usada para a fresagem e sua compensação. Você também pode inverter o sentido dos percursos de fresagem — os pontos de mergulho se tornarão pontos de retração e vice-versa. Essas alterações são virtuais e só serão aplicadas permanentemente quando o botão OK for clicado.

  • A camada de fresagem contém todos os percursos de fresagem e, se habilitada, exibirá vários símbolos relacionados à fresagem. Esses símbolos representam os pontos de mergulho e retração, além do sentido de cada percurso.
  • Ao modificar um único percurso de fresagem, os botões Plunge e Retract ficam disponíveis na caixa de diálogo Modify Rout Path(s). Use esses botões para alterar a posição dos pontos de mergulho e retração conforme necessário.

Opções de fresagem de pads

Na caixa de diálogo Rout Pads Options, você pode definir as opções a serem aplicadas quando pads forem encontrados ao longo de um percurso de fresagem. Para acessar a caixa de diálogo, escolha o comando Rout » Rout Pads Options nos menus principais. Configure as opções disponíveis conforme necessário.

Por padrão, pads redondos serão convertidos em pontos de furação.

Fresagem automática do contorno

Os percursos de fresagem podem ser definidos manualmente, mas as ferramentas automáticas devem ser usadas sempre que possível. Unir os segmentos do contorno da placa em uma única polilinha fechada dará muito menos trabalho do que tentar posicionar manualmente um percurso de fresagem com precisão, especialmente quando o contorno da placa contém arcos.

Primeiro, certifique-se de que o contorno da PCB seja um único limite fechado. Talvez seja necessário usar o comando Join para isso.

Use o comando Auto-Rout PCB Border do menu Rout para criar um percurso de fresagem ao redor de toda a placa, usando o contorno da PCB. Após iniciar o comando, o cursor mudará para um pequeno quadrado e será solicitado que você selecione o canto do contorno onde os pontos de mergulho e retração do percurso serão posicionados. Basta posicionar o cursor sobre o contorno e clicar — o canto selecionado será o mais próximo da posição em que você clicar. Novamente, se não conseguir selecionar nenhum vértice do contorno da PCB neste momento, verifique se o contorno é um objeto de polilinha fechada.

Em seguida, será solicitado que você escolha o sentido da fresagem. Uma linha-guia é fornecida em relação ao canto selecionado do contorno para ajudar nessa escolha. Posicione o cursor na direção geral em que deseja fresar e clique — a caixa de diálogo Auto Rout PCB será exibida. Use essa caixa de diálogo para selecionar a ferramenta que deseja usar para fresar o contorno e também especificar as extensões dos pontos de mergulho e retração.

Após definir as opções de fresagem conforme necessário, clique em OK. O percurso de fresagem será criado e adicionado à camada de fresagem.

A caixa de diálogo Auto Rout PCB A caixa de diálogo Auto Rout PCB

O vértice escolhido como início do percurso de fresagem deve estar no canto inferior esquerdo do projeto; caso contrário, as linhas de extensão, se você optar por usá-las, poderão acabar cortando a placa. Você pode seguir as instruções da barra de status e clicar em uma segunda posição no contorno para determinar o sentido do percurso de fresagem. Ao clicar com o botão direito para concluir, a caixa de diálogo Auto Rout PCB será exibida, permitindo selecionar a ferramenta de furação e os valores de extensão dos pontos de mergulho e retração.

Se não houver um valor de compensação de raio da fresa definido para a ferramenta selecionada (na tabela de ferramentas), ele poderá ser gerado automaticamente. Uma nova camada (*.rte) será criada contendo o percurso de fresagem do contorno da PCB.
Você pode então adicionar abas ao longo do percurso de fresagem, fazendo com que a ferramenta seja retraída do painel e avance uma distância especificada ao longo do percurso antes de mergulhar novamente. A colocação de abas de fresagem é semelhante à criação de segmentos de sulcamento interrompido: elas mantêm as placas totalmente conectadas ao painel em determinados pontos, prontas para serem destacadas posteriormente.

  • Ao posicionar o cursor no ponto desejado ao longo do percurso de fresagem para inserir uma aba de fixação, é importante clicar no próprio percurso de fresagem. No modo Preenchimento, o percurso de fresagem pode consistir no percurso real e em um percurso deslocado. Como resultado, o centro do percurso preenchido pode não corresponder ao percurso real e, portanto, clicar nele não inserirá nenhuma aba. Nesse caso, é aconselhável mudar para o modo Contorno (Shift+F). O percurso de fresagem e qualquer percurso deslocado (de compensação) serão exibidos, sendo o primeiro representado por uma linha contínua e o segundo por uma linha pontilhada.
  • O ponto de direção deve ser definido em uma posição adjacente à borda do contorno.
  • Se a ferramenta escolhida para a fresagem não tiver uma compensação de fresa definida, será exibida uma caixa de diálogo perguntando se você deseja atribuir um valor padrão. Esse valor padrão terá a mesma dimensão da própria ferramenta.
  • É necessário definir pelo menos uma ferramenta de furação para usar este comando. Se nenhuma ferramenta tiver sido definida, a execução deste comando abrirá uma caixa de diálogo informando esse fato, e você será direcionado à caixa de diálogo Tool Table (Tables » NC Tools), na qual poderá carregar dados de furação de um arquivo ou inserir definições de ferramentas manualmente.
  • A camada de fresagem será criada (caso ainda não exista) com base no nome da camada da qual foi obtido o contorno da PCB.

Ferramentas de fresagem manual

Os círculos podem ser criados como entidades no sentido horário ou anti-horário, permitindo definir o raio. O ponto de mergulho ficará no centro do círculo, e a ferramenta será retraída quando a fresagem do círculo estiver concluída. Os rasgos são menos automáticos, pois você deve garantir que comece no ponto de mergulho e retorne a ele quando quiser posicionar o ponto de retração clicando com o botão direito, caso queira que o rasgo fique completo. Os percursos de fresagem de texto são semelhantes aos de rasgos, com percursos predefinidos para cada letra (incluindo pontos de mergulho e retração); basta fornecer uma mensagem e indicar a altura desejada para as letras.

As instruções de fresagem, naturalmente, não são necessariamente recursos aplicados após a panelização. Quaisquer objetos de fresagem definidos em uma placa, como rasgos internos, que você incluir na panelização serão incluídos com todos os demais dados panelizados.

Para posicionar manualmente percursos de fresagem no documento atual, escolha o comando Rout » Manual Rout nos menus principais. O comando é baseado no posicionamento de polilinhas. As polilinhas são úteis quando você precisa fechar a linha ou inserir arcos como parte dela, duas operações que não podem ser realizadas com linhas padrão. 

Após executar o comando, a caixa de diálogo Select Mill/Drill Tool será exibida. Escolha a ferramenta que deseja usar para a fresagem na lista de ferramentas disponíveis. Após clicar em OK, você entrará no modo de posicionamento de polilinhas, e um círculo preenchido, representando o tamanho da ferramenta selecionada, aparecerá acompanhando o cursor. O posicionamento é realizado por meio da seguinte sequência de ações:

  1. Posicione o cursor no local desejado na área de trabalho e clique para fixar o início da polilinha.
  2. Mova o cursor e clique novamente para posicionar o próximo vértice da polilinha.
  3. Continue posicionando outros vértices, clicando a cada vez, até obter a forma desejada para a polilinha.
  4. Clique com o botão direito para abrir um menu com vários comandos que podem ser aplicados no modo de posicionamento de polilinhas. Os seguintes comandos estão disponíveis no menu:

    • End - encerra o posicionamento desta polilinha sem fechá-la.
    • Close - fecha a linha desenhando uma linha do último ponto posicionado até o ponto inicial e encerra o posicionamento desta polilinha.
    • Change to Line - altera o modo de posicionamento para linhas retas.
    • Change to Arc - altera o modo de posicionamento para arcos.
    • Draw Arc Clockwise - desenha um arco a partir do vértice anterior no sentido horário.
    • Draw Arc C-Clockwise - desenha um arco a partir do vértice anterior no sentido anti-horário.
    • Undo Polyline Changes - exclui a polilinha atual, permanecendo no modo de posicionamento de polilinhas.
    • Snap Change - ativa/desativa o modo de ajuste durante o posicionamento de polilinhas.
    • Cancel Action - exclui a polilinha atual e sai do modo de posicionamento de polilinhas.
  5. Ao encerrar ou fechar a polilinha, ou ao desfazer alterações, você permanecerá no modo de posicionamento. Continue posicionando outros objetos de polilinha ou pressione Esc para sair do modo de posicionamento de polilinhas. Como alternativa, clique com o botão direito e selecione Cancel Action no menu de contexto.

  • Uma polilinha deve ter pelo menos dois vértices distintos para que possa ser encerrada.
  • Uma polilinha deve ter pelo menos três vértices distintos para que possa ser fechada.
  • As polilinhas serão desenhadas na camada atual. A camada atual é exibida no painel CAMtastic , no topo da lista de camadas. Clicar duas vezes em qualquer camada da lista fará com que ela se torne a camada atual.
  • Para realizar a fresagem manualmente, as ferramentas já devem ter sido definidas; caso contrário, será exibida uma caixa de diálogo informando esse fato, e você será direcionado à caixa de diálogo Tool Table (Tables » NC Tools), na qual poderá adicionar definições de ferramentas.
  • A maneira mais rápida de gerar ferramentas é gerar arquivos NC Drill a partir do documento de projeto da PCB. Esses arquivos são importados para o Editor CAMtastic, e as definições de ferramentas são adicionadas à caixa de diálogo Tool Table.

Adição de uma aba de fixação ao percurso de fresagem selecionado

Para adicionar uma aba de fixação ao longo do percurso de fresagem selecionado no documento atual, escolha o comando Rout » Add Tabs nos menus principais. Após executar o comando, a caixa de diálogo Enter Value será exibida. Use essa caixa de diálogo para inserir um valor para o tamanho da aba, nas unidades da área de trabalho atualmente selecionadas (polegadas ou mm). Após clicar em OK, você retornará à janela principal de projeto, o cursor mudará para um pequeno quadrado e será solicitado que você selecione um local para a aba. Basta posicionar o cursor no ponto desejado ao longo do percurso de fresagem em que deseja inserir a aba e clicar.

A aba será inserida, dividindo efetivamente o percurso de fresagem em dois segmentos, cada um com seus próprios pontos de mergulho e retração.

Continue adicionando outras abas ao longo dos percursos de fresagem ou clique com o botão direito, ou pressione Esc, para sair.

Ao posicionar o cursor no ponto desejado ao longo do percurso de fresagem para inserir a aba, é importante clicar no próprio percurso de fresagem. No modo Fill , o percurso de fresagem pode consistir no percurso real e em um percurso deslocado. Como resultado, o centro do percurso preenchido pode não corresponder ao percurso real e, portanto, clicar nele não inserirá nenhuma aba. Nesse caso, é aconselhável mudar para o modo Outline  (Shift+F). O percurso de fresagem e qualquer percurso deslocado (de compensação) serão exibidos, sendo o primeiro representado por uma linha contínua e o segundo por uma linha pontilhada.

Conversão de linhas em arco

Para converter linhas em um arco em um percurso de fresagem específico no documento atual, escolha o comando Rout » Convert Lines to Arc nos menus principais. Após executar o comando, você entrará no modo de conversão, que envolve a seguinte sequência de ações:

  1. Selecione o ponto inicial do arco. Basta posicionar o cursor sobre um vértice do percurso de fresagem e clicar para fixar esse ponto.
  2. Selecione o ponto final do arco. Novamente, posicione o cursor sobre outro vértice no percurso de fresagem e clique para fixar esse segundo ponto. À medida que você mover o cursor, uma linha-guia aparecerá.
  3. Selecione um ponto intermediário no arco. Posicione o cursor sobre um terceiro vértice no percurso de fresagem e clique — as linhas serão substituídas por um arco, cujo tamanho é determinado pelo comprimento da linha-guia que conecta os pontos inicial e final e pela distância do ponto intermediário selecionado até essa linha.
  4. Continue convertendo outras linhas em arcos em outros percursos de fresagem ou clique com o botão direito do mouse ou pressione Esc para sair.
  • Se o percurso de fresagem for composto por segmentos de linha, esses segmentos deverão ser unidos antes que o comando possa ser usado com sucesso.
  • Para que o comando funcione, deve haver pelo menos três vértices no percurso de fresagem onde você deseja inserir o arco — por exemplo, uma polilinha que forme um ângulo reto, em que os pontos inicial e final sejam as extremidades da polilinha e o ponto intermediário do arco seja o vértice do ângulo da polilinha.

Conversão de linhas em círculo

Para converter um percurso de fresagem de contorno fechado em um círculo de fresagem no documento atual, escolha o comando Rout » Convert Lines to Circle nos menus principais. Após iniciar o comando, será solicitado que você selecione um contorno fechado. Basta posicionar o cursor sobre parte do contorno do percurso de fresagem que deseja converter em círculo e clicar — o percurso de fresagem de contorno fechado será substituído por um círculo, cujo centro é definido como o centro de um retângulo delimitador que envolveria a forma do contorno fechado, e cujo raio é definido pela distância horizontal desse centro até a borda do retângulo delimitador.

Continue convertendo outros percursos de fresagem de contorno fechado em círculos de fresagem ou clique com o botão direito do mouse ou pressione Esc para sair.

Se o percurso de fresagem for um contorno fechado composto por segmentos de linha, esses segmentos deverão ser unidos antes que o comando possa ser usado com sucesso.

Fresagem de contorno

Outra ferramenta automática, Fresagem de contorno, detecta um contorno de maneira semelhante (também é necessária uma polilinha fechada), mas cria um padrão de vaivém que remove por fresagem toda a área, em vez de cortar ao redor dela e deixar que se desprenda da placa ou do painel. Escolha o comando Rout » Mill Boundary nos menus principais para criar percursos para fresar o interior de contornos fechados no documento atual. Após iniciar o comando, o cursor mudará para um pequeno quadrado e será solicitado que você selecione os objetos de contorno fechado para os quais deseja criar percursos de fresagem. Basta posicionar o cursor sobre cada contorno fechado, um de cada vez, e clicar. Após selecionar todos os contornos fechados desejados, clique com o botão direito do mouse.

A caixa de diálogo Milling será exibida. Use essa caixa de diálogo para definir em qual camada deseja colocar os percursos de fresagem. Você pode selecionar a camada atual, uma nova camada ou uma das camadas existentes no documento. Use o campo Select Tool para escolher qual das ferramentas de furação disponíveis deseja usar para fresar os percursos. A opção Delete Old Objects permite manter os objetos de contorno originais para fins de comparação.

  • Se um contorno consistir em segmentos de linha inseridos individualmente, esses segmentos deverão ser unidos antes que o comando possa ser usado com sucesso.
  • Se você optar por adicionar os percursos de fresagem a uma nova camada, será usado o próximo número de camada disponível na lista de camadas (por exemplo, layer29).

Alterne a visualização de Preenchimento para Contorno (Shift+F) para ver o trajeto real determinado para o percurso de fresagem. A fresagem concordante ocorre quando o percurso de fresagem se move na mesma direção do lado côncavo do dente da ferramenta; a fresagem na direção oposta é chamada de discordante.

A fresagem de uma área é um recurso particularmente útil quando você atribui à ferramenta de fresagem um parâmetro do eixo Z menor que a espessura do painel. Dessa forma, você pode criar um rebaixo na placa, como pode ser necessário para a montagem de componentes especiais.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents