Reestruturando um projeto por meio de refatoração

Num relance

Este artigo apresenta uma visão geral prática dos recursos de refatoração do Altium Designer para reorganizar um projeto de PCB existente sem alterar seu funcionamento. Ele aborda situações comuns, como substituir um componente obsoleto por um subcircuito equivalente, transformar um bloco de projeto em uma folha de dispositivo reutilizável, converter um bloco reutilizável de volta em um esquemático local para personalização e mover subcircuitos entre folhas, preservando a conectividade e a intenção do projeto. Se você deseja organizar, adaptar ou reutilizar conteúdo esquemático com mais eficiência no fluxo de trabalho de um projeto existente, este artigo apresenta as ferramentas disponíveis e quando utilizá-las. Continue lendo para descobrir como essas opções de refatoração podem simplificar as atualizações do seu projeto.

- Conheça os comandos de refatoração adequados a tarefas específicas de reestruturação, incluindo conversões de componente em folha, de componente em portas, de esquemático em folha de dispositivo e de folha de dispositivo em folha de esquemático.
- Veja como o Altium Designer ajuda a preservar a conectividade, as propriedades dos símbolos e os vínculos dos subcircuitos ao reorganizar a hierarquia do esquemático.
- Entenda como esses recursos facilitam a reutilização, a conversão de conteúdo reutilizável em conteúdo local e uma organização mais clara das folhas à medida que o projeto evolui.
Aprofunde-se com a IA:

A refatoração, no sentido tradicional, é o ato de reestruturar um projeto existente (ou um conjunto de código, no contexto da programação) sem alterar a funcionalidade desse projeto (ou código). No contexto do projeto de PCBs, há várias situações em que alguma forma de refatoração proporcionaria uma solução benéfica e oportuna:

  • Um componente tornou-se obsoleto e precisa ser substituído por um subcircuito funcionalmente equivalente. (Mostrar)

  • Um projeto esquemático deve se tornar um subcircuito para uso em um projeto maior. (Mostrar)

  • Uma subfolha esquemática existente deve ser transformada em uma folha de dispositivo para reutilização em projetos futuros. (Mostrar)

  • Uma folha de dispositivo existente precisa ser tornada local e personalizada para o projeto atual. (Mostrar)

  • Parte dos subcircuitos existentes precisa ser movida para outra folha. (Mostrar)

O Altium Designer oferece vários recursos que, em conjunto, compõem suas funcionalidades de refatoração de projetos, proporcionando máxima flexibilidade para reestruturar seus projetos de acordo com os requisitos.

Conversão de um componente em um símbolo de folha

Este recurso converte um componente do documento atual em um símbolo de folha. É ideal quando um componente existente se torna obsoleto e precisa ser substituído por um subcircuito funcionalmente equivalente definido em uma folha separada.

Clicar com o botão direito do mouse em um componente e escolher o comando Part Actions » Convert Part To Sheet Symbol no menu de contexto converte o símbolo do componente em um símbolo de folha. A conectividade é mantida, com as entradas de folha nomeadas de acordo com os nomes dos pinos originais e o I/O Type definido para refletir o tipo elétrico do pino original.

O Designator do símbolo de folha é inicialmente definido como o designador do componente original, e seu File Name is é inicialmente definido como o texto de comentário do componente.

Converta um componente existente em um símbolo de folha.Converta um componente existente em um símbolo de folha.

Se a folha filha necessária existir, altere o File Name do símbolo de folha para apontar para essa folha. Caso contrário, uma subfolha pode ser criada rapidamente clicando com o botão direito do mouse no símbolo de folha e escolhendo o comando Sheet Symbol Actions » Create Sheet From Sheet Symbol. Neste último caso, portas correspondentes às entradas de folha do símbolo serão posicionadas na nova subfolha, prontas para que o subcircuito substituto seja definido e conectado.

O comando Convert Part To Sheet Symbol também está disponível no menu principal Tools » Convert.

Transferência de um componente para uma nova subfolha

Um método alternativo, e talvez mais rápido, para obter um resultado final semelhante é clicar com o botão direito do mouse no componente desejado e escolher o comando Part Actions » Push Part To Sheet. Esse comando é usado para transferir um componente do documento atual para uma nova subfolha, substituindo o componente original por um símbolo de folha que faz referência a essa folha. Essencialmente, a seguinte sequência de etapas é executada:

  1. O componente é copiado.

  2. O componente original é convertido em um símbolo de folha com o Designator definido como o designador do componente original e o File Name definido como <OriginalPartComment>.SchDoc. Novamente, a conectividade é mantida, com as entradas de folha nomeadas de acordo com os nomes dos pinos originais e o I/O Type definido para refletir o tipo elétrico do pino original.

  3. Uma nova folha esquemática é criada a partir do símbolo de folha e nomeada usando o valor de File Name do símbolo.

  4. A cópia do componente original é colada no centro da folha, com portas correspondentes às entradas de folha do símbolo posicionadas e conectadas aos pinos do componente.

Você pode então excluir o componente e substituí-lo por um circuito funcionalmente equivalente, conforme necessário.

Usando o comando Push Part To Sheet, o componente inicial é rapidamente convertido em um símbolo de folha e, em seguida, uma cópia desse componente é colada em uma folha recém-criada,
referenciada por esse símbolo.

Conversão de um componente em portas

Este recurso é usado para converter um componente do documento atual em um conjunto de portas. É ideal para um subprojeto independente existente, como uma fonte de alimentação ou uma placa satélite, que deve ser transformado em um subcircuito para uso em um projeto maior de placa única, talvez para minimizar os custos de fabricação. Isso é o inverso da seção anterior, que tratava da substituição de um componente por um subcircuito de nível inferior. Aqui, trata-se do processo de integrar um subcircuito ao projeto de nível superior, disponibilizando-o para conexão a um ponto acima na hierarquia.

Clicar com o botão direito do mouse em um componente e escolher o comando Part Actions » Convert Part To Ports no menu de contexto converte o símbolo do componente em um conjunto de portas. A conectividade é mantida, com as portas nomeadas de acordo com os nomes dos pinos originais e o I/O Type definido para refletir o tipo elétrico do pino original.

Use o comando Convert Part To Ports para substituir rapidamente um componente por portas que conectam um subcircuito a um projeto de nível superior.Use o comando Convert Part To Ports para substituir rapidamente um componente por portas que conectam um subcircuito a um projeto de nível superior.

A inserção do subcircuito na hierarquia é então concluída adicionando um símbolo de folha à folha pai de nível superior correspondente. Para fazer isso:

  1. Torne ativa a folha pai desejada.

  2. Use o comando Design » Create Sheet Symbol From Sheet.

  3. Escolha o documento (que contém as portas criadas a partir do componente) na caixa de diálogo Choose Document to Place.

  4. Um símbolo de folha aparecerá no cursor; posicione-o na folha conforme necessário e clique para concluir o posicionamento.

O símbolo de folha faz referência à subfolha subjacente (por meio de sua propriedade File Name ) e possui entradas de folha correspondentes às portas da folha filha.

Use o comando Create Sheet Symbol From Sheet para adicionar rapidamente um símbolo de folha, integrando assim o subcircuito à hierarquia do projeto.
Use o comando Create Sheet Symbol From Sheet para adicionar rapidamente um símbolo de folha, integrando assim o subcircuito à hierarquia do projeto.

Conversão de uma folha esquemática em uma folha de dispositivo

Em algum momento, o conceito de projetar para reutilização precisa atingir um nível maior de abstração. Se nos limitássemos ao nível dos componentes, cada projeto que apresentasse uma funcionalidade semelhante, como uma interface USB ou um regulador de tensão, estaria, por assim dizer, “reinventando a roda”. É aí que entram as folhas de dispositivo, ou seja, folhas esquemáticas projetadas para oferecer funcionalidades específicas de circuito. Seu uso elimina os riscos associados à abordagem tradicional de copiar e colar. Elas eliminam a repetição do esforço de projeto e ampliam o conteúdo de projeto que pode ser reutilizado em projetos futuros.

Como parte de seu conjunto de ferramentas de refatoração, o editor de esquemáticos permite converter rapidamente uma folha esquemática padrão existente em uma folha de dispositivo para reutilização em outros projetos.

Considere liberar folhas esquemáticas de subcircuitos funcionais para um Workspace conectado para obter a máxima integridade e otimizar a reutilização, além de benefícios como gerenciamento de revisões e do ciclo de vida e rastreabilidade de “onde é usado”. Disponíveis para toda a equipe de projeto da organização, esses elementos de projeto, chamados de managed schematic sheets, fornecem blocos construtivos de alto nível e alta qualidade para reutilização em projetos futuros. Você pode reutilizar essas folhas esquemáticas gerenciadas que implementam funcionalidades como componentes constituintes de um projeto maior. Para obter mais informações, consulte Como trabalhar com folhas esquemáticas gerenciadas.

Para converter uma folha esquemática existente em uma folha de dispositivo:

  1. Localize o símbolo de folha que faz referência à folha desejada na página pai correspondente na hierarquia do projeto.

  2. Selecione o símbolo de folha e escolha o comando Edit » Refactor » Convert Selected Schematic Sheet To Device Sheet nos menus principais. A caixa de diálogo Convert Schematic Sheet to Device Sheet será exibida. Escolha o local de destino para armazenar a folha de dispositivo recém-criada e também o escopo da conversão — se deseja atualizar o símbolo de folha atual ou todos os símbolos de folha relevantes no espaço de projeto ou no projeto ativo. A última opção é particularmente útil para um projeto multicanal, no qual o subcircuito existe em várias instâncias.

    Especifique os detalhes da conversão na caixa de diálogo Convert Schematic Sheet to Device Sheet.Especifique os detalhes da conversão na caixa de diálogo Convert Schematic Sheet to Device Sheet.

    Clique no botão  à direita do campo de localização para acessar a caixa de diálogo Escolher pasta de folhas de dispositivo. Essa caixa de diálogo lista todas as pastas de folhas de dispositivo definidas no momento. Para adicionar um novo local de pasta, clique no botão Device Sheet Folders na parte inferior dessa caixa de diálogo para acessar a caixa de diálogo Pastas de folhas de dispositivo. Como alternativa, defina as pastas de folhas de dispositivo na página Gerenciamento de dados - Folhas de dispositivo da caixa de diálogo Preferences.

  3. Clique em OK. O símbolo de folha será convertido em um símbolo de folha de dispositivo, e o esquemático será movido para o local de folhas de dispositivo especificado.

    As propriedades do símbolo de folha original serão herdadas pelo símbolo de folha de dispositivo.

Ao contrário das operações tradicionais de recortar e colar, a refatoração mantém os identificadores exclusivos dos subcircuitos (incluindo símbolos de folha e símbolos de folha de dispositivo), garantindo que os subcircuitos do projeto estejam sempre vinculados às suas instâncias físicas no domínio da PCB.

Conversão de uma folha de dispositivo em uma folha de esquemático

As folhas de dispositivo permitem registrar subcircuitos funcionais e reutilizá-los em diferentes projetos. No entanto, pode ser necessário modificar um subcircuito existente para um projeto específico. Em vez de modificar a própria folha de dispositivo, o editor de esquemáticos permite criar uma cópia dela, disponibilizando seus circuitos em uma folha de esquemático padrão. Isso permite modificar a cópia local de acordo com os requisitos do projeto atual, com a segurança de que a folha de dispositivo original permanece intacta.

Para “converter” uma folha de dispositivo existente em uma folha de esquemático:

  1. Localize o símbolo de folha de dispositivo que referencia a folha de dispositivo desejada.

  2. Selecione o símbolo de folha de dispositivo e escolha o comando Edit » Refactor » Convert Device Sheet To Schematic Sheet nos menus principais. A caixa de diálogo Convert Device Sheet to Schematic Sheet será exibida. Escolha o local de destino para armazenar a folha de esquemático recém-criada e também o escopo da conversão — se deseja atualizar o símbolo de folha de dispositivo atual ou todos os símbolos de folha de dispositivo relevantes no projeto ativo.

    Especifique os detalhes da conversão na caixa de diálogo Convert Device Sheet to Schematic Sheet.Especifique os detalhes da conversão na caixa de diálogo Convert Device Sheet to Schematic Sheet.

    O Target Schematic Sheet Location padrão é o diretório em que o projeto ativo está localizado. A folha é nomeada usando o File Name do símbolo de folha de dispositivo. Clique no botão à direita do campo de localização para acessar a caixa de diálogo Open , na qual você pode alterar o local e o nome com que o esquemático será salvo (se necessário).

  3. Clique em OK. O símbolo de folha de dispositivo será convertido em um símbolo de folha, e uma cópia da folha de dispositivo será armazenada localmente como uma folha padrão (desprotegida) no local especificado. O símbolo de folha fará referência a essa folha local.

    A folha de esquemático local substituirá a folha de dispositivo anterior no painel Projects  após a conversão.A folha de esquemático local substituirá a folha de dispositivo anterior no painel Projects  após a conversão.

    As propriedades do símbolo de folha de dispositivo original serão herdadas pelo símbolo de folha.

Ao contrário das operações tradicionais de recortar e colar, a refatoração mantém os identificadores exclusivos dos subcircuitos (incluindo símbolos de folha e símbolos de folha de dispositivo), garantindo que os subcircuitos do projeto estejam sempre vinculados às suas instâncias físicas no domínio da PCB.

Movimentação de subcircuitos selecionados para outra folha

À medida que um projeto evolui, pode ser necessário reorganizar o conteúdo das folhas de esquemático de origem que o compõem — uma parte específica do circuito pode ficar mais clara em uma folha própria, ou talvez uma folha esteja ficando sobrecarregada (e ilegível!) e se beneficie da transferência de parte dos circuitos para uma folha adicional ou diferente.

Outro recurso de refatoração é a capacidade de selecionar um ou mais objetos em uma folha e mover essa seleção para outra folha. Para fazer isso:

  1. Primeiro, selecione os circuitos que deseja mover.

  2. Clique com o botão direito do mouse e escolha o comando Edit » Refactor » Move Selected Subcircuit to Different Sheet no menu de contexto. A caixa de diálogo Choose Destination Document será aberta, permitindo que você especifique a folha de esquemático de destino.

Se os subcircuitos selecionados forem ficar em uma folha totalmente nova, certifique-se de que o esquemático seja criado e salvo primeiro para que apareça na caixa de diálogo Choose Destination Document.

Transfira parte de um projeto para outra folha de esquemático.Transfira parte de um projeto para outra folha de esquemático.

  1. Clique em OK. A folha escolhida ficará ativa, e o subcircuito selecionado aparecerá flutuando junto ao cursor.

  2. Posicione os circuitos na folha conforme necessário e clique para concluir o posicionamento. Após o posicionamento, esses circuitos serão removidos da folha original.

  3. Se os circuitos movidos contiverem um ou mais símbolos de folha existentes, as folhas de esquemático filhas referenciadas por esses símbolos serão movidas para ficar abaixo da folha para a qual esses símbolos foram movidos na hierarquia do projeto exibida no painel Projects. Se estiver movendo os circuitos para uma nova folha, adicione um símbolo de folha à página pai correspondente para inserir essa folha corretamente na hierarquia do projeto.

Ao contrário das operações tradicionais de recortar e colar, a refatoração mantém os identificadores exclusivos dos subcircuitos (incluindo símbolos de folha e símbolos de folha de dispositivo), garantindo que os subcircuitos do projeto estejam sempre vinculados às suas instâncias físicas no domínio da PCB.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents