Trabalhando com Folhas de Esquemático Gerenciadas

Num relance

Este artigo explica como as folhas de esquemático gerenciadas em um Workspace conectado ao Altium Designer tornam a reutilização de projetos mais confiável, rastreável e consistente do que simplesmente copiar e colar. Ele apresenta o que é uma folha de esquemático gerenciada, como ela se diferencia das folhas de dispositivo, como é armazenada e versionada no Workspace e as principais formas de criá-la e salvá-la para uso futuro. Você também verá como o tipo de pasta, o tipo de conteúdo, a nomenclatura, o ciclo de vida e a edição direta se encaixam no processo de criação de conteúdo de esquemático reutilizável em que sua equipe pode confiar. Continue lendo para descobrir como as folhas gerenciadas pelo Workspace podem ajudar você a reutilizar blocos de projeto comprovados com mais confiança.

- Entenda o que são folhas de esquemático gerenciadas, como elas permitem a reutilização e por que o armazenamento no Workspace agrega controle de versão, rastreabilidade e integridade do conteúdo.
- Conheça as diferentes formas de criar e salvar folhas de esquemático gerenciadas, incluindo a edição direta, o salvamento da folha atual e o upload de um documento de esquemático para uma revisão.
- Veja como detalhes de configuração, como tipo de pasta, tipo de conteúdo, esquemas de nomenclatura e configurações de ciclo de vida, ajudam a organizar e gerenciar conteúdo de esquemático reutilizável.
Aprofunde-se com a IA:

A possibilidade de reutilizar conteúdo de projeto é algo que todas as empresas de desenvolvimento de produtos desejam e que pode trazer grandes benefícios. Além de economizar tempo, poder reutilizar facilmente uma seção de um projeto anterior significa que toda a qualificação e os testes dessa parte do projeto já foram realizados. No entanto, a reutilização de projetos vai muito além de copiar e colar: a verdadeira reutilização exige que o conteúdo seja protegido contra alterações, garantindo que seja o mesmo de antes. Nada de edições rápidas para mudar a cor de um componente ou ajustar o valor de um resistor; trabalhar com conteúdo reutilizável deve ser como trabalhar com componentes prontos para uso: insira o conteúdo, faça as conexões e ele funcionará exatamente como da última vez.

O Altium Designer, em conjunto com um Workspace conectado, permite criar folhas de esquemático gerenciadas (Itens de Folha de Esquemático Gerenciada) nesse Workspace. Essas folhas podem ser criadas:

  • Por meio da edição direta.

  • Salvando a folha de esquemático atual no Workspace.

  • Carregando o documento de esquemático correspondente (*.SchDoc) em uma revisão de uma folha de esquemático gerenciada de destino.

Depois que uma folha de esquemático gerenciada é criada (e os dados são salvos em uma de suas revisões), ela pode ser reutilizada em futuros projetos de placas.

O que é exatamente uma folha de esquemático gerenciada?

Uma folha de esquemático gerenciada é uma folha de esquemático padrão do Altium Designer que contém componentes e conexões e foi armazenada em um Workspace para ser reutilizada em outros projetos. Ela é editada como qualquer outra folha de esquemático. O conceito de folha de esquemático gerenciada também não se limita a uma única folha: você pode inserir no seu projeto uma folha de esquemático gerenciada que seja o topo de uma árvore de outras folhas de esquemático gerenciadas.

As folhas de esquemático gerenciadas diferem das folhas de dispositivo por serem armazenadas em um Workspace, enquanto as folhas de dispositivo são armazenadas em uma pasta em um disco rígido. Assim, as folhas gerenciadas desfrutam dos benefícios associados ao conteúdo do Workspace, incluindo armazenamento simplificado, controle de versão obrigatório e, é claro, integridade protegida.

► Consulte as informações sobre Folhas de dispositivo gerenciadas localmente.

A decisão de migrar de folhas de dispositivo para folhas de esquemático gerenciadas surge quando se deseja fazer a transição de conteúdo reutilizável para conteúdo reutilizável Workspace – ou seja, quando há o desejo ou a necessidade de controlar a liberação desse conteúdo de projeto e fornecer uma fonte única desse conteúdo para toda a equipe.

Ao transformá-lo em conteúdo do Workspace, você garante que a revisão de uma folha de esquemático gerenciada usada em um projeto possa ser facilmente identificada e rastreada até sua origem sempre que necessário. E, por ser conteúdo do Workspace, ela pode ser revisada e atualizada quando necessário, e todas as relações de uso podem ser rastreadas — tanto até os componentes presentes nessa folha quanto até os projetos que a utilizam. Isso garante que você tenha todas as informações necessárias para decidir se a folha revisada deve ser propagada para os projetos existentes ou se um determinado projeto deve continuar usando a revisão anterior.

Tipo de pasta

Ao criar a pasta na qual serão armazenadas as folhas de esquemático gerenciadas, você pode especificar o tipo da pasta. Isso não afeta o conteúdo da pasta — salvar uma folha de esquemático sempre resultará em um Item de Folha de Esquemático Gerenciada correspondente. Essa configuração simplesmente fornece uma indicação visual do que está armazenado na pasta e pode ser útil ao navegar em um Workspace em busca de conteúdo específico. Para designar uma pasta como um local de armazenamento de folhas de esquemático gerenciadas, defina seu Folder Type como Managed Schematic Sheets ao configurar as propriedades da pasta na caixa de diálogo Editar pasta.

Especificar o tipo de pasta — seu uso pretendido — fornece uma indicação visual do conteúdo dessa pasta ao navegar pelo Workspace.
Especificar o tipo de pasta — seu uso pretendido — fornece uma indicação visual do conteúdo dessa pasta ao navegar pelo Workspace.

Tipo de conteúdo

Ao criar um Item de Folha de Esquemático Gerenciada de destino para armazenar sua folha de esquemático, certifique-se de que seu Content Type esteja definido como Managed Schematic Sheet na caixa de diálogo Criar novo item. Se você estiver criando o Item em uma pasta do tipo Managed Schematic Sheets, esse tipo de conteúdo estará disponível no menu de contexto do botão direito ao criar o Item.

Criação de uma folha de esquemático gerenciada em uma pasta Managed Schematic Sheets – o Content Type correto está disponível no menu de contexto.
Criação de uma folha de esquemático gerenciada em uma pasta Managed Schematic Sheets – o Content Type correto está disponível no menu de contexto.

Salvando uma folha de esquemático

Related page: Criando e editando conteúdo

Até aqui, discutimos o suporte a folhas de esquemático gerenciadas no Workspace em termos dos tipos de pasta e de conteúdo relacionados. Uma folha de esquemático já definida pode ser salva em uma revisão de um Item de folha de esquemático gerenciada de algumas maneiras, conforme descrito nas seções abaixo.

Para facilitar a reutilização de folhas gerenciadas em seus projetos, é altamente recomendável que a folha de esquemático seja anotada manualmente (Tools » Annotation » Annotate Schematics) antes de ser salva como uma folha gerenciada. Quando um projeto que utiliza folhas gerenciadas estiver concluído, todas as folhas e todos os componentes poderão ser renumerados em todo o projeto.

► Consulte a seção Anotando componentes e folhas abaixo para obter informações.

Edição direta

Uma folha de esquemático pode ser editada e salva na revisão inicial de um Item de folha de esquemático gerenciada recém-criado, graças ao suporte do Workspace à edição direta. A edição direta elimina a necessidade de manter dados de origem separados sob controle de versão. Basta editar um tipo de conteúdo compatível usando um editor temporário carregado com os dados de origem mais recentes, diretamente do próprio Workspace. Quando a edição é concluída, a entidade é salva (ou salva novamente) em uma revisão planejada subsequente de seu Item pai, e o editor temporário é fechado. Não há arquivos no disco rígido, dúvidas sobre estar trabalhando com os dados de origem corretos ou mais recentes, nem necessidade de manter um software separado de controle de versão. O Workspace cuida de tudo, com alto nível de integridade e de uma maneira que agiliza consideravelmente as alterações em seus dados.

Ao criar um Item de folha de esquemático gerenciada, você tem a opção de editar e salvar uma folha de esquemático na revisão inicial desse Item após a criação. Para isso, habilite a opção Open for editing after creation, na parte inferior da caixa de diálogo Create New Item (habilitada por padrão). O Item será criado e o Editor de esquemáticos temporário será aberto, apresentando um documento .SchDoc como documento ativo na janela principal de projeto. Esse documento será nomeado de acordo com o Item-Revisão, no formato: <Item><Revision>.SchDoc (por exemplo, SCH-0007-1.SchDoc).

Se o seu Workspace tiver pelo menos um Modelo de esquemático salvo, a caixa de diálogo Select configuration item (Schematic Templates) será exibida. Use-a para escolher qual modelo será aplicado ao documento de esquemático.

Exemplo de edição da revisão inicial de uma folha de esquemático gerenciada diretamente do Workspace — o Editor de esquemáticos temporário fornece o documento no qual você define sua folha de esquemático.
Exemplo de edição da revisão inicial de uma folha de esquemático gerenciada diretamente do Workspace — o Editor de esquemáticos temporário fornece o documento no qual você define sua folha de esquemático.

Use o documento para definir a folha de esquemático conforme necessário. Como as folhas de esquemático gerenciadas são armazenadas em um Workspace, os componentes presentes nelas também devem ser armazenados no Workspace. Dessa forma, você aproveita todos os benefícios do sistema de conteúdo fornecido pelo Workspace, incluindo a possibilidade de identificar e localizar todos os componentes usados na folha de esquemático gerenciada (os filhos), além de identificar e localizar os projetos nos quais ela foi usada (onde é usada). Para obter mais informações, consulte Criando e mantendo seus componentes e bibliotecas.

A possibilidade de usar componentes do Workspace para criar blocos de projeto maiores permite que o fluxo de projeto se torne cada vez mais simplificado e opere em um nível mais alto de abstração. Assim como quem escolhe peças em uma prateleira, o projetista reutiliza essas folhas de esquemático gerenciadas, que implementam funções do circuito, como componentes de um projeto maior. E quanto mais folhas de esquemático gerenciadas com esses circuitos forem criadas e salvas no Workspace, mais funcionalidades estarão disponíveis para o projetista, aumentando, por sua vez, a produtividade nos projetos seguintes.

Há três controles relevantes durante a edição direta, facilmente acessíveis em Quick Access Bar (no canto superior esquerdo da janela principal do aplicativo) ou na barra de ferramentas Schematic Standard:

  • – Save Active Document. Use este botão para salvar localmente as alterações feitas no documento. Isso permite salvar as alterações atuais caso você queira retomá-las mais tarde e fazer outras alterações antes de salvar definitivamente no Workspace.
  • / – Save to Workspace. Use este botão para salvar a folha de esquemático definida no Workspace, armazenando-a na revisão inicial (planejada) do Item de folha de esquemático gerenciada de destino. A caixa de diálogo Editar revisão será exibida, na qual você poderá alterar o nome e a descrição e adicionar notas de lançamento conforme necessário. O documento e o editor serão fechados após o salvamento. O documento que contém a folha de esquemático de origem (*.SchDoc) será armazenado na revisão do Item.

    Um controle Save to Server também está convenientemente disponível à direita da entrada da folha de esquemático, no próprio painel Projects.
  • / – Discard Local Changes. Use este botão se quiser cancelar a edição e descartar todas as alterações feitas. O documento e o editor serão fechados, e nada será salvo no Item de folha de esquemático gerenciada de destino.

Esses controles também estão disponíveis como comandos – Save (atalho: Ctrl+S), Save to Server (atalho: Ctrl+Alt+S) e Discard Local Changes – no menu principal File e no menu de contexto da entrada da folha de esquemático no painel Projects.

Os dados salvos no Workspace consistem na folha de esquemático de origem, definida no arquivo de documento esquemático (<Item><Revision>.SchDoc), bem como em quaisquer arquivos de definição de chicote associados (*.Harness). No painel Explorer, mude para a guia de visualização Preview para ver uma representação gráfica da folha, juntamente com uma lista dos componentes que a constituem (e do modelo de folha de esquemático gerenciada, se aplicável).

Clique no hiperlink de uma revisão de Item de componente filho para localizá-la no Explorer painel. A área de Itens filhos também oferece um menu de contexto com comandos para trabalhar com uma revisão de Item de componente filho.

Examine a revisão salva da folha de esquemático gerenciada de volta no painel Explorer. Mude para a guia de visualização Preview para ver uma representação gráfica e uma lista das revisões dos componentes filhos.
Examine a revisão salva da folha de esquemático gerenciada de volta no painel Explorer. Mude para a guia de visualização Preview para ver uma representação gráfica e uma lista das revisões dos componentes filhos.

Os componentes filhos usados na folha também podem ser consultados na guia de visualização Children. Clique duas vezes em uma entrada para localizar o componente correspondente ou clique com o botão direito para acessar um conjunto de comandos relacionados ao componente.

Consulte os componentes que constituem a folha de esquemático gerenciada por meio da visualização Children.
Consulte os componentes que constituem a folha de esquemático gerenciada por meio da visualização Children.

Como salvar uma folha existente no Workspace

Embora a edição direta seja a abordagem preferida para a maioria dos conteúdos de projeto que podem ser armazenados em um Workspace, no caso de folhas de esquemático existentes (ou mesmo folhas de dispositivo), você também pode salvar uma folha diretamente no Workspace. Para isso, é necessário ter uma revisão planejada de um Item de folha de esquemático gerenciada existente, na qual a folha será salva. O processo é o seguinte:

  1. Crie um novo Item de folha de esquemático gerenciada e sua revisão inicial planejada, ou tenha uma revisão planejada de outro Item existente, conforme necessário.

  2. Abra a folha de esquemático ou a folha de dispositivo no Altium Designer.

  3. Escolha o comando File » Save as Managed Sheet to Server nos menus principais.

  4. A caixa de diálogo Choose Planned Item Revision será exibida. Use-a para escolher a revisão de destino do Item de folha de esquemático gerenciada desejado (que deve estar no estado Planned) e clique em OK.

    Se o Item de folha de esquemático gerenciada de destino não existir, você poderá criá-lo durante o processo por meio da caixa de diálogo Choose Planned Item Revision. Nesse caso, desative a opção Open for editing after creation (na caixa de diálogo Create New Item); caso contrário, você entrará no modo de edição direta.
  5. A caixa de diálogo Editar revisão será exibida, na qual você poderá alterar o nome e a descrição e adicionar notas de lançamento conforme necessário.

  6. Após clicar em OK, a folha será salva e armazenada na revisão do Item.

Exemplo de envio de uma folha de dispositivo existente para o Workspace ao qual você está conectado. O salvamento deve ser feito em uma revisão existente de uma folha de esquemático gerenciada, e essa revisão deve estar no estado Planned.
Exemplo de envio de uma folha de dispositivo existente para o Workspace ao qual você está conectado. O salvamento deve ser feito em uma revisão existente de uma folha de esquemático gerenciada, e essa revisão deve estar no estado Planned.

Como pesquisar e posicionar uma folha de esquemático gerenciada

O painel Design Reuse descrito abaixo está em Beta Aberto e disponível quando a opção UI.ModernDesignReusePanel está habilitada na caixa de diálogo Configurações avançadas. Quando essa opção está desabilitada, uma folha de esquemático gerenciada pode ser posicionada a partir do painel Explorer. Para isso, navegue ou pesquise a folha de esquemático gerenciada que deseja posicionar, clique com o botão direito na revisão específica desejada (normalmente a mais recente; nesse caso, basta clicar com o botão direito diretamente na entrada do Item de nível superior) e escolha o comando Place.

As folhas de esquemático gerenciadas armazenadas no Workspace conectado podem ser consultadas e usadas a partir do painel Design Reuse quando ele está configurado para exibir recursos do Workspace ().

Você pode navegar pelas pastas do Workspace para encontrar a folha de esquemático gerenciada desejada. Como alternativa, use o campo Search na parte superior do painel Design Reuse para pesquisar uma folha de esquemático gerenciada pelo nome ou pela descrição.

  • Somente a revisão mais recente de cada folha de esquemático gerenciada é apresentada no painel Design Reuse.

  • Se a revisão mais recente de uma folha de esquemático gerenciada estiver em um estado do ciclo de vida com a opção Visible in Vault panels desabilitada (saiba mais), essa folha de esquemático gerenciada, por padrão, não será exibida no painel. Para exibir as folhas de esquemático gerenciadas que não estão visíveis no momento, clique no botão  no canto superior direito do painel e habilite a opção Show Hidden Revisions no menu associado.

Clique no controle Details na parte inferior do painel para expandir o painel Details, que exibe detalhes das folhas de esquemático gerenciadas selecionadas, incluindo:

  • Nome da folha de esquemático gerenciada.

  • O ícone do estado do ciclo de vida e a revisão (clique no link para abrir a visualização detalhada do Histórico do Item de Folha de Esquemático Gerenciada com a revisão mais recente selecionada).

  • Descrição da folha de esquemático gerenciada.

  • Informações gerais da folha de esquemático gerenciada.

Usando o acesso controlado ao conteúdo do Workspace, em conjunto com um esquema de ciclo de vida adequado, o pessoal autorizado (bibliotecários, gerentes seniores de projeto) pode aprovar e disponibilizar apenas as folhas de esquemático gerenciadas que devem ser usadas nos projetos. Isso permite que o projetista trabalhe com a tranquilidade de saber que está usando apenas folhas de circuitos reutilizáveis autorizadas para uso.

Prior to Placement

Há alguns pontos a observar antes de posicionar uma folha de esquemático gerenciada em um projeto:

  • O símbolo de folha de uma folha de esquemático gerenciada não pode ser posicionado em um esquemático avulso; a folha de destino deve fazer parte de um projeto.

  • Certifique-se de que a folha de esquemático que receberá o símbolo de folha associado esteja aberta no Altium Designer e seja o documento ativo. Se houver documentos abertos em várias janelas, certifique-se também de que a janela que contém esse documento de esquemático ativo esteja em foco.

Para posicionar uma folha de esquemático gerenciada em um projeto, passe o cursor sobre sua entrada no painel Design Reuse, clique no botão  (ou clique com o botão direito na entrada) e selecione o comando Place no menu. Um símbolo de folha que referencia a folha ficará vinculado ao cursor — clique no local desejado na folha de esquemático para posicioná-lo.

Ao posicionar o símbolo de folha, o Altium Designer copia a folha gerenciada que o símbolo representa do Workspace para a pasta do projeto, dentro de uma subpasta chamada \Managed\Sheets. Uma cópia de cada folha gerenciada é armazenada nesse local, cada uma em sua própria subpasta, identificada por um identificador exclusivo gerado pelo sistema (GUID).

A subpasta cujo nome é o GUID, na qual a instância da folha de esquemático gerenciada é baixada e armazenada, não deve ser editada nem renomeada de forma alguma.

Anotação dos componentes e das folhas

Para garantir a integridade dos circuitos usados em uma folha de esquemático gerenciada, essa folha não pode ser editada durante o uso normal no projeto. Isso significa que o número da folha e as atribuições de designadores não podem ser modificados na folha. Então, como numerar todas as folhas do projeto e anotar todos os componentes?

Essas tarefas são gerenciadas por dois comandos: as folhas são numeradas usando o comando Tools » Annotation » Annotate Compiled Sheets e os componentes são anotados usando o comando Tools » Annotation » Board Level Annotate. O número da folha e as atribuições de designadores são armazenados em um arquivo separado, <ProjectName>*.annotation. 

As ferramentas de anotação de componentes precisam saber a ordem em que as folhas de esquemático devem ser processadas. Por esse motivo, é melhor numerar as folhas antes de numerar os componentes.

Os princípios de Anotação dos componentes e das folhas são os mesmos de quando se utilizam Folhas de Dispositivo locais. Para obter mais informações sobre a anotação de projetos que incluem folhas de esquemático gerenciadas, consulte as seguintes seções na página Folhas de Dispositivo:

Edição de uma folha de esquemático gerenciada

Para editar uma folha de esquemático gerenciada, passe o cursor sobre sua entrada no painel Design Reuse e clique no botão  (ou clique com o botão direito na entrada) e selecione o comando Edit no menu. O editor temporário será aberto, com a folha de esquemático contida na revisão mais recente do Item de Folha de Esquemático Gerenciada aberta para edição. Faça as alterações necessárias e salve o documento na próxima revisão do Item (File » Save to Server).​​​

Se precisar alterar a folha de esquemático armazenada em um Item de Folha de Esquemático Gerenciada e já tiver a folha atualizada, você poderá enviá-la para esse Item usando o painel Explorer — a nova folha será armazenada na próxima revisão desse Item. Para obter mais informações, consulte a página Criação e edição de conteúdo.

Outras ações para folhas de esquemático gerenciadas

O menu do botão  (e o menu de contexto) de uma entrada de folha de esquemático gerenciada no painel Design Reuse também fornece acesso aos seguintes comandos:

  • Move – use para alterar o local do Item de Folha de Esquemático Gerenciada na estrutura de pastas do Workspace. Ao executar o comando, será aberta a caixa de diálogo Move Item , na qual você poderá selecionar a pasta de destino em que o Item deverá ser colocado.

  • Share – use para definir as permissões de compartilhamento da folha de esquemático gerenciada. Após selecionar o comando, a caixa de diálogo Share For Item será aberta, permitindo configurar o compartilhamento conforme necessário. Saiba mais sobre compartilhamento no nível do Item.

  • Operations – use para acessar um menu suspenso de funções adicionais para folhas de esquemático gerenciadas, conforme descrito abaixo.

    • Make a Copy – use para copiar a folha de esquemático gerenciada. Um editor temporário da folha de esquemático gerenciada será aberto, com o mesmo conteúdo da folha de esquemático gerenciada original. Faça as alterações necessárias e salve a folha de esquemático gerenciada no Workspace. 

    • Change Revision State – use para alterar o estado da revisão mais recente da folha de esquemático gerenciada. Após selecionar o comando, a caixa de diálogo de alteração de estado em lote será aberta, permitindo alterar o estado da revisão da folha de esquemático gerenciada.

    • Download – use para baixar os dados armazenados na folha de esquemático gerenciada. Os dados associados serão baixados em uma subpasta do diretório escolhido, nomeada com o ID da revisão do Item de Folha de Esquemático Gerenciada. O arquivo pode ser encontrado na(s) pasta(s) Released dentro dela.

  • Delete – use para excluir a folha de esquemático gerenciada do Workspace ao qual você está conectado. Após selecionar o comando, a caixa de diálogo Delete Items será exibida para confirmar a exclusão. 

    Na verdade, a ação é uma “exclusão lógica”, na qual a folha de esquemático gerenciada será movida para a área Trash do Workspace. Saiba mais sobre a exclusão lógica.

  • History – use para acessar uma visualização detalhada da folha de esquemático gerenciada, aberta como uma nova aba no Altium Designer.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents