Определение схемы соединений

Краткий обзор

В этой статье объясняется, как в Altium Designer создаются и настраиваются схемы соединений жгутов и как с их помощью задаются отдельные проводные соединения в проекте жгута. В ней рассматриваются добавление документа схемы соединений и настройка его основных параметров, таких как единицы измерения, сетки, параметры страницы и шаблоны, а также связанные возможности: проверка проекта, работа с текстовыми и графическими объектами и сохранение в формате ASCII. Кроме того, в статье описываются синхронизация схем соединений с многоплатными проектами, импорт компонентов и их ручное размещение. Это даст вам практическое представление об основных этапах работы ещё до начала разработки. Читайте дальше, чтобы узнать об основных шагах настройки и синхронизации, которые упрощают работу со схемами соединений жгутов.

- Как добавить и настроить документ схемы соединений жгута, включая единицы измерения, сетки, параметры страницы и настройки по умолчанию.
- Как при синхронизации с многоплатным проектом в схему соединений импортируются компоненты разъёмов и логические связи.
- Как размещать компоненты на схеме соединений и управлять ими независимо от того, импортированы ли они из многоплатного проекта или добавлены вручную.
Узнайте больше с ИИ:

Отдельные проводные соединения внутри жгута задаются на схеме соединений жгута (*.WirDoc). Добавьте этот документ в проект жгута на панели Projects: щелкните правой кнопкой мыши запись проекта и выберите Add New to Project » Harness Wiring Diagram в контекстном меню (или воспользуйтесь командой File » New » Harness Wiring Diagram в главном меню).

Настройка документа схемы соединений жгута

Параметры документа схемы соединений жгута можно настроить на панели Properties , когда в рабочей области документа не выбран ни один объект. Основные настройки:

  • В области General на вкладке General панели — выберите единицы измерения для документа и его графических элементов и настройте сетки для удобного размещения. Altium Designer предлагает три типа сеток: видимую сетку для навигации, сетку привязки для размещения и расстояние привязки для упрощения создания соединений.

  • В области Page Options на вкладке General панели — настройте размер листа документа и основную надпись или выберите один из доступных шаблонов схемы соединений жгута.

Вкладки General и Parameters панели Properties, когда в документе схемы соединений жгута не выбран ни один объект 
Вкладки General и Parameters панели Properties, когда в документе схемы соединений жгута не выбран ни один объект

  • Настройка документа схемы соединений жгута аналогична настройке документа принципиальной схемы (*.SchDoc) в проекте печатной платы. Подробнее см. на странице Настройка документа принципиальной схемы.

  • Используйте раскрывающийся список Length Units для выбора единиц длины в документе. Значения Strip Length и Pull Off Length для контактных гнезд будут отображаться в выбранных единицах. Поддерживаются единицы mm, cm, m, in и ft. Единицы длины по умолчанию для вновь создаваемых документов схем соединений можно задать на странице Проектирование жгутов — Общие диалогового окна Preferences.

  • Подробнее о создании шаблонов документов схем соединений жгута см. на странице Создание шаблонов документов жгута.

  • Свойства по умолчанию для объектов схемы соединений жгута можно настроить на странице Проектирование жгутов — Значения по умолчанию диалогового окна Preferences. Эти свойства будут применяться при размещении последующих объектов.

  • При создании документа схемы соединений жгута также можно использовать текстовые и графические объекты. Работа с ними в документе схемы соединений жгута аналогична работе в документе принципиальной схемы (*.SchDoc) проекта печатной платы. Подробнее об этих объектах см. в разделах Работа с текстовыми объектами на принципиальной схеме и Работа с графическими объектами на принципиальной схеме.

    • Обратите внимание: в текстовых рамках и примечаниях также поддерживаются активные ссылки на объекты схемы соединений жгута (например, провода и компоненты) и объекты компоновочного чертежа жгута (например, пучки и точки соединения). Щелкните ссылку в размещенной текстовой рамке или примечании, чтобы перейти к соответствующему объекту в связанном документе.

  • Для выявления логических, электрических и оформительских ошибок на схеме соединений жгута предусмотрен ряд проверок. Подробнее см. на странице Проверка проекта жгута.

  • Документ схемы соединений жгута можно сохранить в формате ASCII, что может быть удобно при обмене данными. Воспользуйтесь командой File » Save As и выберите Harness Wiring ascii (*.WirDoc) в раскрывающемся списке Save as type открывшегося диалогового окна Save As. При сохранении схемы соединений в формате ASCII с помощью команды File » Save откроется диалоговое окно File Format с уведомлением об использовании формата ASCII. Выберите версию ASCII в диалоговом окне , чтобы продолжить использовать этот формат.

Синхронизация многоплатного проекта и проекта жгута

 
 
 
 
 

Если проект жгута входит в состав многоплатного проекта, схему соединений жгута можно синхронизировать с данными документа многоплатной схемы (*.MbsDoc). Для этого выберите команду Design » Import Changes From <Multi-board Project> в главном меню.

Подробнее о добавлении проекта жгута в многоплатный проект см. на странице Проектирование жгутов.

Если документ многоплатной схемы содержит несколько описаний жгутовых соединений, откроется диалоговое окно Select Harness Definition. Укажите описание, относящееся к текущему проекту жгута.

Диалоговое окно Select Harness Definition
Диалоговое окно Select Harness Definition

Затем откроется диалоговое окно Engineering Change Order, в котором будут показаны компоненты разъемов жгута и цепи жгута, заданные на многоплатной схеме. Они станут основой схемы соединений жгута.

Используйте диалоговое окно Engineering Change Order для импорта данных из многоплатного проекта. 
Используйте диалоговое окно Engineering Change Order для импорта данных из многоплатного проекта. 

После применения изменений () данные из документа многоплатной схемы будут импортированы в схему соединений жгута. Компоненты разъемов, каждый из которых представлен своим условным графическим обозначением, появятся в документе схемы соединений жгута, первоначально в произвольных местах.

Пример схемы соединений жгута сразу после импорта.
Пример схемы соединений жгута сразу после импорта.

Между выводами будут показаны линии связей, представляющие логические соединения, заданные на многоплатной схеме. Обратите внимание: на этом этапе в проекте еще нет физических проводов.

Обратите внимание: данные о соединениях, импортируемые из многоплатного проекта в проект жгута, основаны на именах выводов компонентов разъемов. Поэтому перед импортом данных убедитесь, что выводам компонентов в исходной библиотеке присвоены уникальные и правильные имена.

Работа с компонентами

Помимо синхронизации с документом схемы многоплатной системы, компоненты можно размещать на электрической схеме жгута вручную. Это позволяет размещать компоненты как в автономном проекте жгута, не входящем в состав проекта многоплатной системы, так и добавлять дополнительные компоненты на электрическую схему жгута, входящего в такой проект.

Для размещения условных графических обозначений нужных компонентов используйте панель Components. Процесс размещения компонентов аналогичен процессу в редакторе схем — подробнее см. на странице Поиск и размещение компонентов. Обратите внимание: для компонентов, добавленных вручную, линии связи не отображаются, поскольку для них отсутствует логическое описание соединений более высокого уровня.

  • Компоненты размещаются из доступных библиотек и представлены на электрической схеме жгута моделями своих условных графических обозначений. Подробнее о создании компонентов см. в разделе Создание и сопровождение компонентов и библиотек.

  • Многосекционные компоненты также можно размещать на электрической схеме жгута. При импорте данных проекта в компоновочный чертеж жгута компонентам на этом чертеже корректно назначаются позиционные обозначения. Если на электрической схеме жгута размещено несколько секций одного компонента, на компоновочном чертеже жгута размещается только один экземпляр этого компонента ().

  • Разъемы жгута можно использовать для соединения нескольких проектов многоплатных систем, организованных во вложенную структуру.

  • При вставке вырезанных или скопированных компонентов жгута на электрическую схему жгута их позиционные обозначения формируются с учетом параметра Reset Parts Designators On Paste на странице «Схема — Графическое редактирование» диалогового окна Preferences. Если этот параметр включен, при вставке компонентов числовая часть их позиционных обозначений сбрасывается до ?.

Чтобы переместить размещенный компонент (или компонент, размещаемый из панели Components) в нужное положение, нажмите на него левой кнопкой мыши и, удерживая ее, перемещайте мышь. Во время перетаскивания используйте Spacebar для поворота компонентов на 90 градусов, а клавиши X и Y — для отражения по горизонтали и вертикали соответственно.

Электрическая схема жгута после перемещения компонентов
Электрическая схема жгута после перемещения компонентов

Свойства размещенного компонента можно настроить на панели Properties, выбрав компонент в рабочей области. Панель Properties для компонента содержит следующие вкладки:

 
 
 
 
 
  • General — общие свойства компонента: позиционное обозначение и комментарий, расположение, параметры и т. д.

  • Pins — список выводов компонента.

  • Cavities — позволяет назначать компоненту гнездовые контакты (подробнее).

  • Associated Parts — позволяет назначать компоненту дополнительные детали, например термоусадочные трубки.

Вкладки панели Properties при выбранном компоненте
Вкладки панели Properties при выбранном компоненте

Назначение гнездовых контактов

 
 
 
 
 

Компоненту жгута можно назначить элементы гнезд и их типы. Чтобы добавить элемент гнезда и указать его тип, выберите компонент в рабочей области. Выберите вывод на вкладке Cavities панели Properties , затем нажмите кнопку  . Выберите нужный тип из раскрывающегося списка. Поддерживаются следующие типы элементов гнезд:

  • Crimp — используется для создания электрического соединения путем обжима контактной гильзы вокруг проводника.

  • Seal — используется для защиты от воздействия окружающей среды путем герметизации места ввода провода.

  • Plug — используется для заполнения открытого (неиспользуемого) гнезда разъема с целью сохранения герметичности.

  • Other — используется для указания других/дополнительных деталей или материалов, например припоя.

Для типа элемента гнезда Crimp или строк, в которых тип элемента гнезда не добавлен, можно указать следующие значения:

  • Strip Length — длина участка проводника, на котором срезается изоляция.

  • Pull Off Length — длина, на которую срезанная изоляция стягивается с проводника. Это можно использовать в случаях, когда конец провода зачищается не полностью, а срезанный участок изоляции остается на проводе для предотвращения повреждения жил.

Единицы измерения, в которых эти значения отображаются на панели Properties при выбранном компоненте, задаются с помощью раскрывающегося списка Length Units на вкладке General панели Properties, когда в документе не выбран ни один объект.

В открывшемся диалоговом окне Select Connector найдите и выберите нужный компонент. Тип и соответствующая информация будут добавлены к выводу на вкладке, как показано на приведенных ниже изображениях для добавления обжимного контакта к выводу 1.

Обратите внимание: выводы представлены в таблице на вкладке Cavities по именам (столбец Pins), и назначение элементов гнезд выполняется по именам выводов, поэтому убедитесь, что выводам компонента присвоены уникальные и правильные имена.

К выводу можно добавить только один элемент каждого из следующих типов: обжимной контакт, уплотнитель или заглушка. После добавления элемента определенного типа соответствующий пункт раскрывающегося списка становится недоступным (отображается серым цветом). К выводу можно добавить любое количество элементов гнезда типа Other.

Выводы с назначенными обжимными контактами обозначаются в рабочей области символом , как показано на изображении ниже.

Табличная область вкладки Cavities поддерживает множественный выбор и операции копирования, вставки и удаления выбранных записей.

  • Несколько записей выводов можно выбрать с помощью сочетаний клавиш Click, Hold&Drag, Ctrl+Click, Shift+Click и Ctrl+A.

  • Выбрав несколько записей выводов, нажмите  , чтобы добавить элемент гнезда ко всем выбранным выводам, либо нажмите  или клавишу Delete, чтобы удалить добавленные элементы гнезд у выбранных выводов. 

  • Чтобы изменить элемент гнезда вывода, выберите его запись, затем нажмите , чтобы открыть диалоговое окно Select Connector и выбрать новый элемент гнезда.

  • Выберите одну или несколько записей выводов и используйте сочетания клавиш Ctrl+X/Ctrl+C, чтобы вырезать/скопировать выбранные записи, затем используйте сочетание клавиш Ctrl+V, чтобы вставить вырезанное/скопированное содержимое в текущую выбранную запись.

Создание соединений на схеме соединений жгута

Физические провода размещаются в документе схемы соединений жгута с помощью команды Place » Harness Wire из главного меню (сочетание клавиш: Shift+W).

После выбора команды щелкните контакт разъема (при наведении курсора на точку привязки контакта появляется красный крестик), чтобы разместить начальную точку провода жгута. Перемещайте курсор и щелкайте, чтобы зафиксировать последовательность вершин, определяющих форму провода жгута. После размещения последней вершины в точке привязки другого контакта щелкните правой кнопкой мыши, чтобы завершить размещение.

При размещении провода жгута нажимайте Shift+Spacebar для переключения режимов размещения. Режим определяет способ формирования углов при размещении проводов и допустимые углы их прокладки. В режиме 90 Degree или 45 Degree (истинно ортогональные режимы) нажимайте Spacebar для переключения между начальным и конечным подрежимами. Текущие режим и подрежим отображаются в строке состояния.

При размещении провода жгута линии связи отслеживаются и обновляются в реальном времени, показывая направление прокладки, как продемонстрировано в видео ниже. После завершения соединения соответствующая линия связи исчезает из документа.

Демонстрация функции отслеживания в реальном времени

После размещения и выбора провода жгута его вершины можно перетаскивать, изменяя угол между двумя соседними участками (Показать пример).

Выберите провод жгута в рабочей области, чтобы изменить его на панели Properties. На этой панели можно переименовать выбранный провод жгута, изменить его ширину и цвет, а также добавить параметры, которые можно отображать или скрывать в рабочей области.

Панель Properties при выбранном проводе жгута
Панель Properties при выбранном проводе жгута

  • Размещенный провод жгута можно заменить компонентом проводки жгута, содержащим один провод. Для этого выберите заменяемый провод жгута и нажмите кнопку  справа от поля Design Item ID на панели Properties. В открывшемся диалоговом окне Replace Component найдите и выберите нужный компонент. Свойства и параметры размещенного провода будут обновлены в соответствии с выбранным компонентом, при этом его геометрия останется неизменной. Дополнительные сведения см. в разделе Размещение компонента проводки жгута.

  • Основной цвет провода определяется параметром Color, который по умолчанию присутствует у размещенного провода жгута. Чтобы изменить цвет, введите его название (например, Red) или шестнадцатеричный код (символ #, за которым следует шестнадцатеричное число, например #9900FF) в качестве значения параметра. Также можно нажать кнопку цвета слева от значения параметра и воспользоваться открывшимся окном выбора цвета, в котором цвет провода задается значением RGB или HEX, произвольным выбором либо выбором из набора предустановок.

  • На схеме соединений жгута поддерживаются многоцветные провода: для этого задаются второй и третий цвета провода. На панели Properties откройте раскрывающийся список   в нижней части области Parameters , затем выберите Secondary и Tertiary , чтобы задать нужные цвета; параметр выбранного цвета появится в области Parameters . В этом же раскрывающемся списке можно выбрать Border, чтобы задать цвет контура провода жгута. Обратите внимание: параметр Color управляет отображением объединенного значения заданных параметров провода Color, Secondary Color и Tertiary Color. Примеры приведены в слайд-шоу ниже.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Провод, для которого задан только основной цвет

    Провод с заданным вторым цветом

    Провод с заданным третьим цветом

    Провод с заданным цветом контура

    Провод со всеми заданными цветами

    Многоцветные провода поддерживаются таблицами в документах производственных чертежей жгута (*.HarDwf) — подробнее.

  • Если параметр Include Cut провода жгута имеет значение No, этот провод не будет отображаться в списке проводов и таблице соединений на производственном чертеже.

  • Параметры Color, Min. Bending Radius, Thickness и Units провода жгута используются при синхронизации проекта жгута с MCAD-системой с помощью MCAD CoDesigner. Дополнительные сведения см. на странице Синхронизация проекта жгута.

Добавление сращиваний и ответвлений

Если при проектировании требуется подключить новый провод к уже размещенному, сначала необходимо разместить объект сращивания (Place » Splice) или ответвления (Place » Tap).

  • Splice — сращивание разделяет исходный провод на два отдельных провода.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    К выбранному проводу (W4) необходимо подключить другой провод.

    На проводе размещено сращивание. Обратите внимание: сращивание разделяет исходный провод на два в месте своего размещения.

    К сращиванию подключен другой провод.

    При Т-образном соединении двух проводов сращивание автоматически размещается в точке Т-образного соединения (Показать пример).

  • Tap — исходный провод остается неразрывным.

    Javascript ID: Harness_WD_PlacingTap_AD25

    К выбранному проводу (W4) необходимо подключить другой провод.

    Ответвление, размещенное на проводе. Обратите внимание: ответвление не разделяет исходный провод.

    К ответвлению подключен другой провод.

Свойства размещенного соединения или ответвления (его положение и внешний вид) можно настроить на панели Properties, выбрав объект в рабочей области.

Панель Properties при выбранном соединении или ответвлении
Панель Properties при выбранном соединении или ответвлении

Область Associated Parts панели Properties позволяет назначать компоненты выбранному соединению или ответвлению. Назначенный компонент будет включен в спецификацию проекта.

Добавление кабелей

Чтобы указать, что один или несколько проводов входят в состав кабеля, разместите объект кабеля на схеме соединений жгута (Place » Harness Cable).

Разместите кабель, чтобы указать, что один или несколько проводов входят в его состав.
Разместите кабель, чтобы указать, что один или несколько проводов входят в его состав.

При выборе объекта кабеля входящие в него провода подсвечиваются в рабочей области ярко-зеленым цветом ().

Свойства размещенного объекта кабеля (его положение, внешний вид и параметры) можно настроить на панели Properties, выбрав объект в рабочей области.

Панель Properties при выбранном кабеле
Панель Properties при выбранном кабеле

Используйте элемент блокировки/разблокировки в полях Width/Height панели, чтобы включить или отключить фиксацию пропорций. При перетаскивании маркеров редактирования объекта соотношение сторон сохраняется в соответствии с этой настройкой. По умолчанию пропорции зафиксированы, а соотношение высоты и ширины составляет 2:1.  При отключенной фиксации размеры можно изменять независимо друг от друга.

  • Если кабель связан с проводами в нескольких местах схемы соединений жгута (то есть несколько объектов кабеля с одинаковым обозначением размещены на разных проводах), при выборе одного объекта будут подсвечены все связанные провода группы, и все они будут перечислены в области Cable Objects панели Properties ().

  • Параметры кабеля Color, Min. Bending Radius, Thickness и Units используются при синхронизации проекта жгута с MCAD-системой с помощью MCAD CoDesigner. Подробнее см. на странице Синхронизация проекта жгута.

Экранирование и скручивание проводов

Чтобы добавить экран (с подключением, например к дренажному проводу, или без него) для группы проводов, разместите объект экрана (Place » Shield) или экрана с подключением (Place » Shield with Connection).

В приведенном ниже примере провода W1, W2 и W3 экранированы экраном без подключения (SH1), а провода W4, W8 и W9 — экраном с подключением (SH2). Провод W10 соединяет SH2 с выводом компонента.

Объект экрана или экрана с подключением, размещенный для обозначения экранированных проводов.
Объект экрана или экрана с подключением, размещенный для обозначения экранированных проводов.

При выборе объекта экрана или экрана с подключением охватываемые им провода подсвечиваются в рабочей области ярко-зеленым цветом ().

Свойства размещенного объекта экрана или экрана с подключением (положение и внешний вид) можно настроить на панели Properties, выбрав объект в рабочей области. В области Shield Objects панели перечислены провода, охватываемые выбранным объектом.

Панель Properties при выбранном экране
Панель Properties при выбранном экране

  • Используйте элемент блокировки/разблокировки в полях Width/Height панели, чтобы включить или отключить фиксацию пропорций. При перетаскивании маркеров редактирования объекта соотношение сторон сохраняется в соответствии с этой настройкой. По умолчанию пропорции зафиксированы, а соотношение высоты и ширины составляет 2:1.  При отключенной фиксации размеры можно изменять независимо друг от друга.

  • Если экран связан с проводами в нескольких местах схемы соединений жгута (то есть несколько объектов экрана с одинаковым обозначением размещены на разных проводах), при выборе одного объекта будут подсвечены все связанные провода группы, и все они будут перечислены в области Shield Objects панели Properties ().

Чтобы обозначить провода как скрученные между собой, разместите объект скрутки (Place » Twist). Скрутка может охватывать два или более проводов.

В приведенном ниже примере провода W1 и W2 обозначены как скрученные между собой с помощью скрутки Tw1.

Разместите объект скрутки, чтобы обозначить провода как скрученные между собой.
Разместите объект скрутки, чтобы обозначить провода как скрученные между собой.

При выборе скрутки охватываемые ею провода подсвечиваются в рабочей области ярко-зеленым цветом ().

Свойства размещенной скрутки (ее положение и внешний вид) можно настроить на панели Properties, выбрав объект в рабочей области. В области Twist Objects панели перечислены провода, охватываемые выбранной скруткой.

Панель Properties при выбранной скрутке
Панель Properties при выбранной скрутке

  • Используйте элемент блокировки/разблокировки в полях Width/Height панели, чтобы включить или отключить фиксацию пропорций. При перетаскивании маркеров редактирования объекта соотношение сторон сохраняется в соответствии с этой настройкой. По умолчанию пропорции зафиксированы, а соотношение высоты и ширины составляет 1:1.  При отключенной фиксации размеры можно изменять независимо друг от друга.

  • Если скрутка связана с проводами в нескольких местах схемы соединений жгута (то есть несколько объектов скрутки с одинаковым обозначением размещены на разных проводах), при выборе одного объекта будут подсвечены все связанные провода группы, и все они будут перечислены в области Twist Objects панели Properties ().

  • Параметры скрутки Число витков на единицу длины и Thickness используются при синхронизации проекта жгута с MCAD-системой с помощью MCAD CoDesigner. Подробнее см. на странице Синхронизация проекта жгута.

Неподключенные провода

Неподключенные концы проводов обозначаются закрашенным квадратом.

Обозначение неподключенного провода
Обозначение неподключенного провода

Конец провода не следует оставлять неподключенным. Если по проекту конец провода должен оставаться неподключенным, разместите на нем объект «Нет подключения» (Place » No Connect).

Разместите объект «Нет подключения» на конце провода, который должен оставаться неподключенным.
Разместите объект «Нет подключения» на конце провода, который должен оставаться неподключенным.

Свойства размещенного объекта «Нет подключения» (его положение и внешний вид) можно настроить на панели Properties, выбрав объект в рабочей области.

Панель Properties при выбранном объекте «Нет подключения»
Панель Properties при выбранном объекте «Нет подключения»

Работа с несколькими листами

Полную схему электрических соединений жгута можно разместить на нескольких листах (в виде «плоского» проекта, где все листы находятся на одном уровне), каждый из которых представлен отдельным документом *.WirDoc. Соединения между любыми листами создаются с помощью объектов разрыва провода (Place » Wire Break) с одинаковым обозначением провода.

После выбора команды размещения разрыва провода расположите объект так, чтобы его электрическая точка привязки (конец, удерживаемый курсором) касалась провода, к которому требуется подключение, затем щелкните мышью или нажмите Enter для размещения. Размещенный разрыв провода наследует свойства (обозначение и цвет) провода, к которому он подключен.

Выберите разрыв провода в рабочей области, чтобы изменить его на панели Properties. На этой панели можно задать обозначение провода, к которому он подключен, и его оформление: направление (Left или Right) и цвет.

Синхронизация проводов

Провода жгута, соединенные с помощью разрыва провода, распознаются даже при разных идентификаторах Design Item ID. Кроме того, все сегменты проводов с одинаковым обозначением, соединенные одним и тем же разрывом провода, сравниваются по артикулу, комментарию, цвету и всем параметрам. При обнаружении различий выдается сообщение о нарушении Mismatched parameters in connected wire segments. На панели Properties провода и разрыва провода также появляется предупреждение о конфликте параметров. Нажмите Synchronize в предупреждении, чтобы открыть диалоговое окно Conflict Wire Parameters, в котором можно выбрать, какие параметры использовать для сегмента провода.

Свойства и параметры провода до синхронизации

На панели Properties появляется предупреждение о конфликте параметров. После нажатия Synchronize в предупреждении открывается диалоговое окно Confirm Wire Parameters. Выберите нужный вариант, затем нажмите OK, чтобы выполнить синхронизацию.

Нарушение Mismatched parameters in connected wire segments в диалоговом окне Project Options

После синхронизации свойства сегментов провода согласованы. 

 
  • Обратите внимание: при изменении цвета и обозначения разрыва провода соответствующим образом изменяются цвет и обозначение провода, к которому он подключен. И наоборот, при изменении цвета и обозначения провода соответствующим образом изменяются цвет и обозначение подключенного к нему разрыва провода.

  • Свойства размещаемого разрыва провода также можно изменить, нажав Tab после выбора команды размещения. Обратите внимание: если обозначение разрыва провода задано до его размещения, провод, к которому он подключается, унаследует обозначение и цвет разрыва провода.

  • Если для провода, к которому подключен разрыв провода, задан цвет контура, этот разрыв провода также будет отображаться с контуром того же цвета. Обозначение разрыва провода также будет отображаться цветом контура подключенного провода.

  • Разрывы проводов не имеют собственных настроек шрифта; для них используются свойства Document Font документа схемы электрических соединений жгута, в котором они размещены.

  • Разрывы проводов также можно использовать для создания соединений в пределах одного листа схемы электрических соединений жгута — например, вместо прокладки провода от одного контакта разъема к другому можно разместить короткий провод жгута и разрыв провода на каждом из этих контактов ().

Размещение компонента схемы электрических соединений жгута

При подключении к Workspace можно создавать в нем компоненты с нужной заранее заданной структурой и свойствами, а затем повторно использовать их в проектах жгутов, размещая непосредственно в документах схем электрических соединений жгута.

Подробнее см. на странице Создание компонента схемы электрических соединений жгута.

Эти компоненты (каждому из которых назначена определенная модель электрических соединений жгута) доступны на панели Components. Когда нужный документ схемы электрических соединений жгута активен в рабочей области, разместите компонент, щелкнув правой кнопкой мыши его запись на панели и выбрав команду Place <ComponentName> в контекстном меню. Процесс размещения компонента зависит от того, содержит ли он один объект провода или кабельную структуру (несколько проводов и/или дополнительные объекты: кабели, экраны и т. д.).

  • Single wire — при размещении компонента, содержащего один объект провода, активируется режим размещения провода жгута. Размещаемый провод наследует свойства, заданные при создании компонента. Подробнее о размещении проводов жгута см. в разделе Создание соединений на схеме электрических соединений жгута выше.

  • Cable structure — при выборе команды размещения компонента, содержащего кабельную структуру, эта структура прикрепляется к курсору в точности в том виде, в котором она была задана при создании компонента. Щелкните в нужном месте документа схемы электрических соединений жгута, чтобы разместить компонент. Затем можно отдельно редактировать объекты компонента, например подключать провода, входящие в состав кабеля, к контактам разъемов жгута.

Обновление схемы электрических соединений из библиотек

Следующие объекты можно обновлять из исходной библиотеки Workspace:

  • Компоненты жгута

  • Контактные гнезда компонентов жгута

  • Детали, связанные с компонентами жгута

  • Провода

При выборе объекта сведения о связанном компоненте Workspace отображаются на панели Properties (например, на вкладке Associated Parts для деталей, связанных с компонентом жгута).

Если доступна более поздняя ревизия компонента Workspace, в поле состояния ревизии отображается текст Out of date. Для отдельного объекта ссылку можно обновить до последней ревизии компонента Workspace, нажав кнопку .

Пример индикации устаревшей ревизии компонента жгута​
Пример индикации устаревшей ревизии компонента жгута

Функцию Update from Libraries (Tools » Update from Libraries) также можно использовать для обновления устаревших компонентов, связанных с перечисленными выше объектами. Обратите внимание: чтобы объект был включен в обновление с помощью функции Update from Libraries, назначенный ему компонент должен содержать ссылку на схемное обозначение.

Назначение обозначений объектам схемы электрических соединений жгута

Используйте команды меню Tools » Annotation для назначения обозначений следующим объектам документа схемы электрических соединений жгута:

  • Компоненты жгута

  • Провода

  • Сращивания и ответвления

  • Кабели

  • Экраны и экраны с подключением

  • Скрутки

  • Объекты «Нет подключения»

Назначение обозначений объектам в документе схемы электрических соединений жгута аналогично назначению обозначений компонентам в документе принципиальной схемы (*.SchDoc) проекта печатной платы. Подробнее о командах назначения обозначений, доступных для документа схемы электрических соединений жгута, см. по следующим ссылкам:

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents