Аннотирование компонентов в проекте
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Краткий обзор
- Узнайте, для чего нужна аннотация проекта и почему уникальные позиционные обозначения компонентов важны для схем, топологии печатной платы и выходной документации, например спецификации (BOM).
- Разберитесь в различиях между аннотацией на уровне схемы, на печатной плате и на уровне платы, а также узнайте, для каких типов проектов лучше подходит каждый подход.
- Познакомьтесь с диалоговым окном Annotate и основными настройками, которые позволяют задавать область аннотации, порядок обработки, параметры сопоставления и предлагаемые изменения.
Аннотация проекта — это систематический и методичный процесс, обеспечивающий возможность однозначно идентифицировать каждый компонент проекта по уникальному позиционному обозначению. Хотя Altium Designer может отслеживать компоненты с помощью глобальных уникальных идентификаторов (GUID), большинство разработчиков традиционно используют позиционное обозначение как основной способ ссылки на компонент в схеме (логическое представление), на печатной плате (физическое представление), а также в выходных документах, например в спецификации (BOM).
Существует три подхода к аннотации проекта. Выбор инструмента аннотации зависит от ряда факторов, включая тип проекта, личные предпочтения, а также принятые в компании правила и процедуры.
Schematic Level Annotation
Аннотация на уровне схемы использует исключительно логическое представление проекта для определения позиционных обозначений компонентов. Она наиболее полезна для простых проектов, в которых не используются листы устройств (Device Sheets). Однако, поскольку она позволяет задавать порядок обработки и дополнять существующие корпуса секциями многосекционных компонентов, ее также необходимо выполнять перед аннотацией на уровне платы.
Итак, используйте аннотацию на уровне схемы, чтобы:
- Объединять секции многосекционных компонентов в корпуса.
- Назначать позиционные обозначения компонентам в зависимости от их расположения на схеме.
- Выполнять аннотацию многоканальных проектов с использованием схемы именования по умолчанию, заданной в параметрах проекта.
- Подготавливать проект к дальнейшей аннотации.
PCB Annotation
Аннотация печатной платы использует физическое расположение компонентов на плате для определения их позиционных обозначений. Это позволяет фактически закодировать информацию о расположении в позиционном обозначении компонента, что может быть очень полезно при отладке собранной печатной платы. Таким образом, аннотацию печатной платы следует использовать для назначения позиционных обозначений компонентам в зависимости от их расположения на плате.
Board Level Annotation
Аннотация на уровне платы обеспечивает соответствие между позиционными обозначениями в схеме (логическое представление) и обозначениями реальных компонентов на печатной плате (физическое представление). Хотя аннотацию на уровне платы можно использовать в любом проекте, она особенно полезна для многоканальных проектов или проектов с листами устройств, в которых позиционные обозначения нельзя редактировать непосредственно на самом листе устройства. Таким образом можно повторно аннотировать весь проект, не изменяя исходные листы устройств. Аннотация на уровне платы разрешает конфликты, возникающие из-за повторяющихся позиционных обозначений в проекте, и сохраняет изменения в текстовом файле *.Annotation. Она предоставляет дополнительные ключевые слова для настройки схем именования и позволяет применять эти схемы ко всем компонентам или только к выбранной группе.
Итак, используйте аннотацию на уровне платы, чтобы:
- Назначать позиционные обозначения скомпилированным компонентам на листах устройств.
- Присваивать уникальные имена всем компонентам нескольких каналов с помощью схем именования, включающих позиционную аннотацию, глобальную индексацию и другие настраиваемые параметры.
- Задавать имена компонентов вручную.
Аннотация схемы
Аннотация схемы настраивается в диалоговом окне Annotate . Элементы управления этого окна позволяют систематически назначать позиционные обозначения всем или выбранным компонентам на выбранных листах проекта, обеспечивая уникальность обозначений и их упорядоченность в соответствии с расположением компонентов. Параметры аннотации позволяют объединять секции многосекционных компонентов в корпуса, настраивать индексы и суффиксы, сбрасывать позиционные обозначения на схеме, включая повторяющиеся, а также выполнять обратную аннотацию с печатной платы.
Диалоговое окно Annotate открывается командой Annotate Schematics (Tools » Annotation » Annotate Schematics).

Диалоговое окно Annotate открывается командой Annotate Schematics.
Диалоговое окно разделено на две основные области:
- Schematic Annotation Configuration — эта область используется для настройки схемы аннотации и области ее применения.
- Proposed Change List — в этой области перечислены предлагаемые изменения, которые будут внесены после их принятия и выполнения с помощью извещения об изменениях (ECO).
Параметры и элементы управления диалогового окна Annotate
Настройка аннотации схемы
Порядок обработки
В этой области задается требуемый метод позиционной аннотации. При выборе метода из раскрывающегося списка соответствующее графическое представление динамически обновляется, показывая, как будут назначаться позиционные обозначения компонентам. Выберите один из следующих методов позиционной аннотации:
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
Опорная точка расположения
В этой области задается опорная точка, определяющая расположение компонента при установлении порядка аннотации. Выберите один из следующих вариантов:
- Designator — при определении порядка обработки в качестве опорной точки расположения компонента используется его позиционное обозначение.
- Part — при определении порядка обработки в качестве опорной точки расположения компонента используется его центр.
Замена секций
В раскрывающемся списке выберите, следует ли заменять секции в процессе аннотации.
Параметры сопоставления
При использовании многосекционных компонентов часто желательно разместить как можно больше секций в минимальном числе физических корпусов, поскольку это снижает общую стоимость спецификации проекта. Элементы управления в этой области позволяют определить, как компоненты будут сопоставляться и объединяться в группы, а также задать критерии допустимости таких групп.
-
Complete Existing Packages — этот элемент управления позволяет определить, будут ли секции без назначенных позиционных обозначений включаться в существующие корпуса и каким образом. Выберите один из следующих вариантов в раскрывающемся списке:
- None — существующие корпуса не будут дополняться, а все новые секции будут размещены в новых корпусах.
- Per Sheet — существующие корпуса будут дополняться только новыми секциями с того же листа схемы.
- Whole Project — существующие корпуса будут дополняться новыми секциями с любых листов схемы проекта.
- Component Parameter — этот список содержит все параметры, найденные у компонентов текущего проекта. Установите флажок рядом с параметром, чтобы использовать его для сопоставления секций при объединении в корпуса. Если у многосекционных компонентов совпадают выбранные параметры и их значения, секции будут объединены в один корпус (при условии, что для параметра Complete Existing Packages не выбрано значение None). Оставшиеся компоненты, у которых отсутствуют выбранные параметры, также объединяются в корпуса.
- Strictly - включите этот параметр для Component Parameter в списке, чтобы указать, что все компоненты must должны иметь этот параметр для объединения в один корпус. Компонентам, у которых отсутствует этот параметр, назначаются обозначения отдельных компонентов; в корпуса они не объединяются.
Контекстное меню
- Parameter » Enable Selected Parameters - установите флажок «Включить» для всех параметров, выбранных в списке.
- Parameter » Enable All Parameters - установите флажок «Включить» для всех параметров в списке.
- Parameter » Disable Selected Parameters - снимите флажок «Включить» для всех параметров, выбранных в списке.
- Parameter » Disable All Parameters - снимите флажок «Включить» для всех параметров в списке.
- Match Strictly » Enable Strict Matching On Selected Parameters - включите опцию Strictly для всех параметров, выбранных в списке.
- Match Strictly » Enable Strict Matching On All Parameters - включите опцию Strictly для всех параметров в списке.
- Match Strictly » Disable Strict Matching On Selected Parameters - отключите опцию Strictly для всех параметров, выбранных в списке.
- Match Strictly » Disable Strict Matching On All Parameters - отключите опцию Strictly для всех параметров в списке.
- Selection » Select All - выберите все записи параметров в списке.
- Selection » Deselect All - снимите выделение со всех записей параметров в списке.
- Selection » Invert Selection - выберите все невыбранные параметры в списке и снимите выделение с выбранных.
Листы схемы для назначения обозначений
В этой области диалогового окна перечислены все исходные листы схемы, входящие в проект. Элементы управления в этой области позволяют определить, какие листы следует включить в процесс назначения обозначений, а также задать особенности расчета изменений обозначений. Для каждого листа представлены следующие сведения:
- Include/Exclude checkbox - установите этот флажок, чтобы включить лист схемы в процесс назначения обозначений.
- Schematic Sheet - в этом поле отображается имя листа схемы.
-
Annotation Scope - используйте это поле, чтобы определить, какие компоненты на листе будут охвачены назначением обозначений. В раскрывающемся списке выберите один из следующих вариантов:
- All - обозначения будут назначены всем секциям на листе схемы.
- Ignore Selected Parts - обозначения будут назначены всем секциям, кроме выбранных в данный момент в проекте.
- Only Selected Parts - обозначения будут назначены только секциям, выбранным в данный момент в проекте.
- Order - используйте это поле, чтобы задать положение данного листа в общей последовательности назначения обозначений на листах. Введите нужный порядковый номер непосредственно в поле или задайте его с помощью стрелок, которые появляются после щелчка в поле.
- Designator Index Control - используйте элементы управления в этом столбце, чтобы включить использование начального индекса (установив соответствующий флажок) и задать его значение. Нумерация позиционных обозначений будет начинаться с этого значения индекса.
- Add Suffix - используйте это поле, чтобы задать суффикс, добавляемый к каждому назначаемому позиционному обозначению. Поддерживаются буквенные (A, B, C...), числовые (1, 2, 3...) и небуквенно-цифровые (_ * . %...) суффиксы, а также их комбинации.
Additional Controls
- All On - нажмите, чтобы включить все листы схемы в процесс назначения обозначений.
- All Off - нажмите, чтобы исключить все листы схемы из процесса назначения обозначений.
-
Right-Click Menu - в контекстном меню этой области доступны следующие команды:
-
Order Alphabetically - упорядочьте список листов схемы по алфавиту. Это повлияет на соответствующее значение Order для каждого листа.
-
Order By Project Order - упорядочьте список листов схемы в соответствии с порядком их расположения в проекте (как на панели Projects ). Это повлияет на соответствующее значение Order для каждого листа.
-
All On - включите все листы схемы в процесс назначения обозначений.
-
All Off - исключите все листы схемы из процесса назначения обозначений.
-
Список предлагаемых изменений
-
Main List - в этой области диалогового окна перечислены все позиционные обозначения секций на листах, выбранных для назначения обозначений. Для каждой записи приведены значения Current и Proposed Designator , а также Sub (секция) компонента и исходный Location of Part. Значки замка обозначают столбцы блокировки, позволяющие запретить изменение позиционных обозначений и секций.
Установка флажка рядом с позиционным обозначением в столбце Current («позиционное обозначение заблокировано») защищает это обозначение от любых изменений. Аналогично установка флажка рядом с полем Sub позиционного обозначения («секция заблокирована») предотвращает изменение соответствующей секции родительского многосекционного компонента.
В контекстном меню этой области доступны следующие команды:
- Designator » Lock Selected Designators - установите флажок «позиционное обозначение заблокировано» для всех позиционных обозначений, выбранных в списке.
- Designator » Lock All Designators - установите флажок «позиционное обозначение заблокировано» для всех позиционных обозначений.
- Designator » Unlock Selected Designators - снимите флажок «позиционное обозначение заблокировано» для всех позиционных обозначений, выбранных в списке.
- Designator » Unlock All Designators - снимите флажок «позиционное обозначение заблокировано» для всех позиционных обозначений.
- Part ID » Lock Selected Part ID - установите флажок «секция заблокирована» для всех позиционных обозначений, выбранных в списке.
- Part ID » Lock All Part ID - установите флажок «секция заблокирована» для всех позиционных обозначений.
- Part ID » Unlock Selected Part ID - снимите флажок «секция заблокирована» для всех позиционных обозначений, выбранных в списке.
- Part ID » Unlock All Part ID - снимите флажок «секция заблокирована» для всех позиционных обозначений.
- Selection » Select All - выберите все записи позиционных обозначений в списке.
- Selection » Select All With '?' - выберите все записи, текущее позиционное обозначение которых содержит знак ? (т. е. было сброшено).
- Selection » Deselect All - снимите выделение со всех записей позиционных обозначений в списке.
- Selection » Invert Selection - выберите все невыбранные позиционные обозначения в списке и снимите выделение с выбранных.
- Annotation Summary - в этой области отображается сводная информация о назначении обозначений: количество задействованных листов и параметры сопоставления. Она динамически обновляется при изменении соответствующих настроек.
- Update Changes List - нажмите, чтобы обновить основной список предлагаемых изменений с учетом новых изменений, рассчитанных на основе настроек аннотации в левой части диалогового окна. В информационном диалоговом окне будет показано количество изменений относительно предыдущего и исходного состояния.
- Reset All - нажмите, чтобы сбросить все незаблокированные позиционные обозначения в основном списке до префиксов компонентов по умолчанию, например R?, C?, D?. Изменения будут внесены в столбец позиционных обозначений Proposed . Раскрывающееся меню кнопки позволяет выбрать команду Reset Duplicates. Если у двух или более компонентов одинаковое позиционное обозначение, у всех, кроме одного, оно будет сброшено до префикса по умолчанию. В информационном диалоговом окне также будет показано количество изменений относительно предыдущего и исходного состояния.
- Back Annotate - нажмите, чтобы открыть диалоговое окно поиска и выбора файла для обратной аннотации.
- Accept Changes (Create ECO) - после проверки всех предлагаемых изменений нажмите эту кнопку, чтобы открыть диалоговое окно Engineering Change Order, в котором предлагаемые изменения представлены в категории Annotate Component. Используйте это диалоговое окно для проверки и выполнения ECO, чтобы завершить процесс аннотации на уровне схемы.
Блокировка компонентов
Для многосекционных компонентов с неоднородными секциями убедитесь, что значки блокировки на панели Properties имеют вид закрытого замка. Это предотвратит изменение состава секций при аннотации.
Параметр Strictly
Если для Component Parameter установлен флажок Strictly, объединение компонентов в корпус допускается только при совпадении значений этого параметра. Компоненты, у которых нет этого параметра, аннотируются как отдельные компоненты и не объединяются в корпуса.
Следующий пример показывает, как сочетание этих параметров влияет на результат:
Рассмотрим проект с восемью логическими элементами ИЛИ и восемью резисторами (как показано на рисунке ниже). У элементов ИЛИ есть параметр QuadOrGate: у одной группы из четырех элементов он имеет значение Package1, а у другой группы из четырех элементов — значение Package2. У резисторов такого параметра нет. Установка флажка QuadOrGate в элементе управления Component Parameter обеспечивает использование этого параметра для управления объединением компонентов в корпуса; в данном случае флажок Strictly не установлен.
После запуска команды Tools » Annotation » Annotate Schematics секции с параметром QuadOrGate = Package1 будут объединены в один физический компонент, а секции с параметром QuadOrGate = Package2 — в другой. Все оставшиеся компоненты, у которых нет параметра QuadOrGate, будут объединены вместе. В данном случае резисторы объединяются вместе, поскольку их общий признак — отсутствие параметра QuadOrGate.

Пример объединения компонентов в корпуса при снятом флажке Strictly .
Если выполнить аннотацию того же проекта с установленным флажком Strictly , в корпуса будут объединены только компоненты с параметром QuadOrGate . В данном случае элементы ИЛИ будут объединены в корпуса, а резисторы останутся необъединенными. Таким образом, хотя параметр Strictly позволяет очень точно управлять процессом объединения в корпуса, в большинстве случаев его следует оставлять выключенным.

Пример объединения компонентов в корпуса при установленном флажке Strictly .
Листы схемы для аннотации
Предусмотрены широкие возможности выбора листов схемы и компонентов, которые будут затронуты аннотацией, а также настройки расчета изменений.

Задание области аннотации.
- Флажок слева от листа схемы в списке указывает, что этот лист будет обработан при выполнении команды аннотации.
- Область аннотации определяется раскрывающимся списком Annotation Scope и может охватывать весь лист схемы либо только выбранные или невыбранные компоненты. Для использования параметров Ignore Selected Parts или Only Selected Parts необходимо выбрать компоненты в проекте до запуска команды аннотации.
- Задайте порядок аннотации листов схемы в поле Order. Введите значение непосредственно в поле или задайте нужное значение с помощью стрелок, которые появляются при щелчке в поле.
- Если установлен флажок Designator Index Control , нумерация позиционных обозначений начнется со значения Start Index. Параметр Start Index не действует, если флажок Designator Index Control не установлен.
- В конец каждого позиционного обозначения можно добавить дополнительный суффикс, указав строку или значение в соответствующем столбце Suffix . Не используйте односимвольные суффиксы, такие как «A» или «1», поскольку их легко спутать с обозначениями секций и/или другими позиционными обозначениями.
Список предлагаемых изменений
Нажмите кнопку Update Changes List, чтобы обновить Proposed Change List и проверить все изменения позиционных обозначений перед их применением. Изменения затронут только позиционные обозначения, которые еще не были назначены (например, R?, C? и т. д.). Поэтому, если необходимо обновить все позиционные обозначения в проекте, сначала сбросьте их, нажав кнопку Reset All.

Сброс позиционных обозначений перед применением настроек аннотации.
В Proposed Change List перечислены все позиционные обозначения секций, содержащихся на листах, выбранных для аннотации. Для каждой записи приведены значения позиционного обозначения Current и Proposed, а также Sub компонента (секции) и исходный Location of Part.
Установка флажка, связанного с Designator , блокирует любые изменения соответствующего позиционного обозначения. Аналогично, установка флажка Sub предотвращает изменение соответствующего многосекционного компонента. Этот параметр можно использовать вместо установки значка Lock на панели Properties .
После проверки списка предлагаемых изменений нажмите кнопку Accept Changes (Create ECO), чтобы открыть диалоговое окно Engineering Change Order. После выполнения ECO изменения аннотации будут применены к проекту.
Дополнительные команды аннотации схемы
Меню Инструменты » Annotation содержит ряд специализированных команд аннотации схемы. Первый пункт этой группы, Annotate Schematic, уже был рассмотрен.

Доступные команды аннотации
Сброс позиционных обозначений на схеме
Если значительные фрагменты содержимого были вырезаны из разных источников и вставлены в новый проект, может потребоваться сбросить все позиционные обозначения. Поскольку эта команда использует настройки из диалогового окна Нумерация , она применяется к элементам, ранее выбранным в этом окне. Например, если ранее были отмечены все Schematic Sheets To Annotate, команда Reset Schematic Designators будет применена ко всему проекту независимо от того, открыты ли сейчас его листы в редакторе. Если были отмечены лишь некоторые Schematic Sheets To Annotate, команда Reset Schematic Designators затронет только эти листы.
После запуска команды появится диалоговое окно подтверждения с указанием количества позиционных обозначений, требующих обновления, и запросом на продолжение. После нажатия Yes позиционные обозначения всех компонентов на всех листах схем активного проекта, для которых разрешена нумерация, будут сброшены и примут вид: R?, C?, D?, U? и т. д.
Заблокированные позиционные обозначения не сбрасываются и никак не изменяются.
Сброс повторяющихся позиционных обозначений на схеме
При дублировании фрагментов проекта скопированные компоненты сохраняют те же позиционные обозначения, что и исходные. Команда Reset Duplicate Schematic Designators позволяет быстро сбросить повторяющиеся позиционные обозначения до «?». Поскольку эта команда использует настройки из диалогового окна Annotate , она применяется к элементам, ранее выбранным в этом окне. Например, если ранее были отмечены все Schematic Sheets To Annotate, команда Reset Duplicate Schematic Designators будет применена ко всему проекту независимо от того, открыты ли сейчас его листы в редакторе. Если были отмечены лишь некоторые Schematic Sheets to Annotate, команда Reset Schematic Designators затронет только эти листы.
После запуска команды появится диалоговое окно подтверждения с указанием количества позиционных обозначений, требующих обновления, и запросом на продолжение. После нажатия Yes все повторяющиеся позиционные обозначения компонентов, найденные на всех листах схем активного проекта, для которых разрешена нумерация, будут сброшены и примут вид: R?, C?, D?, U? и т. д.
Заблокированные позиционные обозначения не сбрасываются и никак не изменяются.
Нумерация схем без диалогового окна
Команда Annotate Schematics Quietly используется для проверки всех исходных документов схем активного проекта, для которых разрешена нумерация, и назначения уникального позиционного обозначения каждому компоненту, у которого оно отсутствует. Нумерация выполняется без отображения диалогового окна — это позволяет применить все ранее заданные настройки диалогового окна Annotate, не открывая его повторно. Это особенно полезно на этапе интенсивной разработки, когда разработчику требуется быстро выполнить нумерацию перед компиляцией проекта.
Принудительная нумерация всех схем
Эта команда используется для проверки всех исходных документов схем активного проекта, для которых разрешена нумерация, и повторной нумерации всех содержащихся в них компонентов в соответствии с правилами нумерации, заданными в диалоговом окне Annotate.
Выполнение команды Force Annotate All Schematics эквивалентно выполнению команды Reset Schematic Designators с немедленным последующим выполнением команды Annotate Schematics Quietly. Поэтому команда Force Annotate All Schematics использует настройки, ранее заданные в диалоговом окне Annotate , для определения того, какие компоненты и листы можно обновлять.
После запуска этой команды появится запрос подтверждения с указанием количества позиционных обозначений, которые будут обновлены в случае согласия. После нажатия Yes позиционные обозначения всех компонентов на всех листах схем активного проекта, для которых разрешена нумерация, при необходимости будут переназначены в соответствии с текущими правилами нумерации по расположению, заданными в области Schematic Annotation Configuration диалогового окна Annotate .
Обратная нумерация схем
До появления в Altium Designer Design Compiler и Synchronizer изменения нумерации передавались со схемы на печатную плату через файл списка соединений (*.net). Изменения нумерации, которые требовалось передать в обратном направлении — с печатной платы на схему, — обрабатывались с помощью процедуры обратной нумерации. В этой процедуре используется файл Was-Is (*.WAS) или файл извещения об изменениях (Engineering Change Order, *.ECO), определяющий изменения позиционных обозначений на схеме.
После запуска команды появится диалоговое окно Choose WAS-IS File for Back-Annotation from PCB. Найдите и выберите нужный файл .was (или .eco). После нажатия Open появится информационное диалоговое окно, в котором будет указано, сколько изменений позиционных обозначений выполнено относительно предыдущего и исходного состояний. На этом этапе изменения фактически ещё не применены. Нажмите OK , чтобы открыть диалоговое окно Annotate, в котором можно просмотреть предлагаемые изменения текущих позиционных обозначений, прежде чем принять решение о создании ECO для их применения.
Нумерация листов схем
Команда Number Schematic Sheets изменяет не позиционные обозначения компонентов, а обозначения (номера) листов схем. Поэтому по своему смыслу она относится к общей концепции нумерации проекта.
Нумерация листов и документов позволяет управлять обозначениями листов и сохранять их в виде параметров в соответствующих документах схем. Затем с помощью специальных строк Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) эти значения можно вывести на листе (например, в основной надписи) в виде текстовых объектов.
Процесс нумерации листов выглядит следующим образом:
Автоматическая нумерация листов (параметр проекта)
Включите этот параметр для автоматической нумерации листов. Значения будут отображаться на панели Projects. Автоматическую нумерацию листов также можно включить, установив флажок Automatic Sheet Numbering на вкладке Параметры диалогового окна Project Options.
Автоматическое назначение номеров листов
Нажмите кнопку раскрывающегося списка Auto Sheet Number, чтобы получить доступ к вариантам нумерации листов.
Доступны следующие варианты Select Numbering Scheme:
- Display Order — листы нумеруются в порядке их отображения.
- Sheets Hierarchical Structure - Depth First - листы нумеруются от верхнего уровня последовательно по каждой ветви. Сначала нумеруется верхний уровень, затем полностью первая ветвь под ним, затем вторая ветвь и так далее.
- Sheets Hierarchical Structure - Breadth First - листы нумеруются в соответствии с их уровнем в иерархии. Сначала нумеруется верхний уровень, затем все листы второго уровня и так далее.
Параметры Select Numbering Method позволяют выбрать последовательные значения Increasing или Decreasing .
Автоматическая нумерация документов
Откройте раскрывающийся список Auto Document Number для доступа к параметрам нумерации документов. В целом они совпадают с параметрами Auto Sheet Number, но дополнительно включают значения Prefix и Postfix .
Доступны следующие параметры Parameters :
-
Prefix - выберите префикс, который будет добавляться перед номером документа. Поддерживаются буквенные (
A,B,Cи т. д.), цифровые (1,2,3и т. д.) и нечисловые (_,*,.,%и т. д.) префиксы, а также их сочетания. - Start - выберите числовое значение, с которого начнется нумерация.
-
Postfix - выберите суффикс, который будет добавляться после номера документа. Поддерживаются буквенные (
A,B,Cи т. д.), цифровые (1,2,3и т. д.) и нечисловые (_,*,.,%и т. д.) суффиксы, а также их сочетания. - Step - выберите значение, на которое будет увеличиваться каждый следующий номер документа. Например, если начальный индекс Start равен 1, а значение Step равно 100, номер первого документа будет 1, следующего — 101 (начальное значение + шаг), затем 201 и так далее.
Обновление количества листов
Нажмите кнопку Update Sheet Count, чтобы подсчитать количество листов в текущем проекте и поместить результат в столбец SheetTotal. Будет указано общее количество листов в проекте независимо от схемы нумерации, выбранной в любом из предыдущих элементов управления.
Перемещение вверх/вниз
Используйте кнопки Move Up или Move Down, чтобы переместить выбранный документ схемы вверх или вниз по списку. Это имеет значение при использовании схемы нумерации Display Order для назначения номеров листов или документов.
Пользовательская нумерация и именование
Если в организации используется особая система нумерации или именования, которую нельзя автоматизировать с помощью команд Auto Sheet Number или Auto Document Number, пользовательские имена и номера листов можно ввести непосредственно в поля SheetNumber или DocumentNumber .
Нумерация листов схемы и Device Sheets
Номера листов или документов нельзя задавать для Device Sheets, доступных только для чтения (состояние по умолчанию). В диалоговом окне Нумерация листов проекта они отмечены перекрестной штриховкой, указывающей на невозможность их обновления. Если для Device Sheets разрешено редактирование, штриховка исчезает, и нумерацию листов и документов можно настраивать обычным образом.
Управление отображением позиционных обозначений на печатной плате
Размещение длинных позиционных обозначений многоканального проекта в редакторе печатных плат может быть затруднительным. Можно либо выбрать параметры именования, обеспечивающие короткие имена, либо отображать исходные логические обозначения компонентов. Например, C30_CIN1 будет отображаться как C30. В этом случае потребуется добавить на плату другие обозначения для различения каналов, например обвести каждый канал рамкой на слое шелкографии компонентов.
Выбрать отображение логических или физических позиционных обозначений на печатной плате можно с помощью раскрывающегося списка Designator Display в области Other панели Properties в режиме Board . Если выбрано отображение логических обозначений компонентов многоканального проекта, они будут отображаться на печатной плате и во всех формируемых выходных данных, например на распечатках и в файлах Gerber. Однако при формировании перечня материалов всегда используются уникальные физические позиционные обозначения.
Синхронизация проекта — завершение процесса нумерации
Прямая синхронизация проекта — предпочтительный способ поддержания соответствия позиционных обозначений на схеме и печатной плате, если у вас есть доступ к обоим редакторам. При синхронизации компоненты и соединения схемы сравниваются непосредственно с печатной платой, в результате чего формируется список различий. Список изменений, необходимых для устранения этих различий, формируется в виде ECO (Engineering Change Order — извещение об изменении). Файл ECO описывает различия между текущим и требуемым состоянием проекта. Его можно выполнить, чтобы обновить целевой документ и синхронизировать проект.
Прямая и обратная синхронизация
Термины «прямая синхронизация» и «обратная синхронизация» описывают направление передачи изменений нумерации и проекта при синхронизации данных. Если представить процесс проектирования, который начинается со схемы и определяется ею, то прямая синхронизация — это перенос изменений из редактора схем на печатную плату. Обратная синхронизация — это перенос изменений с печатной платы в редактор схем.
Прямая синхронизация
Синхронизация данных схемы с печатной платой может потребоваться в следующих случаях:
- В редакторе схем добавлен новый компонент, который требуется разместить на печатной плате.
- Вы выполнили нумерацию компонентов схемы впервые или после последней синхронизации проекта.
- В многоканальном проекте вы изменили Project Options, чтобы изменить стиль физических обозначений на печатной плате.
- Вы выполнили нумерацию компонентов на уровне платы впервые или после последней синхронизации проекта.
Прямая синхронизация схемы с печатной платой
Для переноса изменений схемы на печатную плату выберите один из следующих способов:
- Выберите Update PCB Document в меню Design редактора схем. Если между схемой и целевым документом печатной платы есть различия, откроется диалоговое окно Engineering Change Order со списком изменений, необходимых для синхронизации печатной платы со схемой. Нажмите Execute Changes, чтобы синхронизировать проект.
- Выберите Import Changes в меню Design редактора печатных плат, чтобы импортировать изменения из документов схемы в документ печатной платы.
Обратная синхронизация
Обратная синхронизация выполняется, если вы изменили нумерацию компонентов или внесли другие изменения в проект печатной платы и хотите обновить схему.
Обратная синхронизация печатной платы со схемой
Для переноса изменений печатной платы на схему выберите один из следующих способов:
-
В редакторе печатных плат выберите Update Schematics в меню Design . По умолчанию флажок Push Component Designator Changes to Annotation File (if any) на вкладке Генерация ECO диалогового окна Project Options установлен, поэтому изменения, внесенные в редакторе печатных плат, передаются только в файл нумерации, а затем, при компиляции, — в скомпилированные документы. Снимите этот флажок, чтобы передавать изменения только в исходный документ схемы (представление Editor ).
- В редакторе схем выберите Tools » Annotation » Annotate Schematics, затем нажмите кнопку Back Annotate в диалоговом окне Нумерация. Выберите файл WAS-IS, созданный при повторной нумерации позиционных обозначений в редакторе печатных плат.
- В редакторе схем выберите Tools » Annotation » Board Level Annotate, затем нажмите кнопку Back Annotate в диалоговом окне Нумерация на уровне платы. Выберите файл WAS-IS, созданный при повторной нумерации позиционных обозначений в редакторе печатных плат.
- В редакторе схем выберите Tools » Annotation » Back Annotate Schematics. Выберите файл WAS-IS, созданный при повторной нумерации позиционных обозначений в редакторе печатных плат.
Традиционные методы синхронизации проекта
Altium Designer поддерживает традиционный подход к синхронизации проекта с использованием промежуточных файлов — списка соединений и WAS/IS. Прямую синхронизацию данных нумерации можно выполнить с помощью файла списка соединений, а обратную — с помощью файла WAS/IS, в котором указано, каким каждое позиционное обозначение WAS и каким оно теперь IS. Предпочтительным методом синхронизации проекта является прямая синхронизация проекта.
Связывание компонентов с помощью уникальных идентификаторов
Если вы выполнили повторную нумерацию проекта, позиционные обозначения компонентов на схеме или позиционные обозначения компонентов после компиляции больше не будут совпадать с позиционными обозначениями компонентов на плате. Поэтому для успешного завершения проекта потребуется синхронизация. Вместо использования самого позиционного обозначения в качестве ключевого поля, связывающего условное графическое обозначение компонента на схеме с соответствующим посадочным местом на плате, Altium Designer может поддерживать синхронизацию проекта с помощью системы уникальных идентификаторов (UID). UID — это автоматически сформированное системой значение, которое однозначно идентифицирует исходный компонент и связывает каждый компонент схемы с соответствующим компонентом платы.
При размещении компонента на листе схемы ему автоматически присваивается UID. При первой передаче информации о компонентах из исходных документов схемы на пустую плату UID каждого компонента схемы присваивается соответствующему компоненту платы.
Рефакторинг позволяет преобразовывать листы устройств в листы схем и наоборот, сохраняя уникальные идентификаторы листа и его компонентов. Кроме того, с помощью рефакторинга можно переносить подсхемы на другие листы схемы текущего проекта, сохраняя уникальный идентификатор подсхемы. Команда Refactor находится в меню Edit .
Функция синхронизации Altium Designer, запускаемая командой Design » Update, использует эти UID для сопоставления каждого компонента схемы с соответствующим компонентом платы. Затем обновления и изменения проекта можно применить с помощью извещений об изменениях (Engineering Change Orders, ECO). ECO содержит список всех модификаций, которые необходимо внести в один или несколько документов проекта для выполнения запрошенной синхронизации. ECO используются для внесения изменений в проект в различных ситуациях, например:
- Передача изменений проекта со схемы на плату.
- Обновление нумерации позиционных обозначений компонентов схемы и позиционных обозначений компонентов после компиляции.
- Обновление параметров с помощью Parameter Manager (Tools » Parameter Manager).
- Обновление параметров на основе информации из исходных библиотек или базы данных компании. При каждом сравнении схемы и платы (например, при выборе Design » Update) Altium Designer сначала сопоставляет компоненты с одинаковыми UID. Если обнаружены компоненты, у которых UID не совпадают, приложение уведомляет вас об этом и предлагает попытаться сопоставить их по позиционным обозначениям. Это сообщение будет появляться до тех пор, пока соответствующим компонентам схемы и платы не будут назначены одинаковые UID. Управление уникальными идентификаторами и их соответствием выполняется в диалоговом окне Редактирование связей компонентов (Project » Component Links).
Обратите внимание: это диалоговое окно можно открыть только при активном документе печатной платы, поскольку изменения UID всегда применяются к плате, а не к схеме. Используйте это окно на любом этапе проектирования, чтобы просмотреть связи между компонентами и проверить правильность их сопоставления в разных документах, а также назначить одинаковые UID компонентам, которые пока не сопоставлены.

